Mouse cursor lost when unlocking with Intel graphics

Bug #1568604 reported by Kenneth Zadeck on 2016-04-10
This bug affects 566 people
Affects Status Importance Assigned to Milestone
elementary OS
High
Unassigned
xf86-video-intel
Confirmed
Medium
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
Xenial
High
Unassigned
xserver-xorg-video-intel-lts-xenial (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella

Bug Description

[Relevant details]
This bug also affects Trusty and all distributions based on it, like Elementary OS Freya.

[Impact]
Mouse cursor is no longer visible after VT-switch for systems with Intel graphics.

Switching VTs again may cause the cursor to become visible again.
- Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7)

This is often observed in systems that lock the session and return to the greeter (including at least Xubuntu, Ubuntu Mate, and elementary OS).

[Test Case]
(Requires a lightdm-based screen locking solution)
1. Start a new session.
2. Lock your screen.
2a. You are redirected to the lightdm greeter.
3. Login/Unlock your session.
4. Cursor is no longer visible.

[Regression Potential]
remains to be seen

===

[Original Report]
Cursor is visible at unlock screen either after returning from suspend or just locking.

After unlocking screen cursor is invisible.

Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7) cursor returns

====================

no matter if you suspend or sleep, to swap or disk when you return from it, the mouse cursor is missing. you can still move the mouse and you can see (because it highlights the window) as you move it around. But the cursor is not displayed on the screen.

i am using a lenovo W540 laptop. I downloaded the latest beta on april 8 2016.

this is xubuntu using the xfce window manager.

the cursor does return if i log off and log back in, but that actually defeats the purpose of going to sleep.
---
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2016-04-08 (2 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
Package: light-locker 1.7.0-2ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Tags: xenial
Uname: Linux 4.4.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1568604/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Paul White (paulw2u) wrote :

I'm seeing this on a Toshiba C-50B. Only started in the last couple of days.

tags: added: xubuntu
tags: added: xenial
Kev Bowring (flocculant) wrote :

Perhaps a laptop issue - on this desktop can suspend and mouse is there on wake

affects: ubuntu → xfce4-power-manager (Ubuntu)
Pavlushka (pavelsayekat) wrote :

A logout and re-login solved this for me as a temporary solution.

Kev Bowring (flocculant) wrote :

@pavlushka - that is already commented in post #1

and as said there 'negates the purpose of suspend'

please don't add comments like that which add nothing - just use the Me Too option

Kev Bowring (flocculant) on 2016-04-11
affects: xfce4-power-manager (Ubuntu) → light-locker (Ubuntu)
Kev Bowring (flocculant) wrote :

@Kenneth Zadeck

first off - can you confirm the graphics adaptor on your laptop

can you please run

apport-collect 1568604

from the laptop so the bug report grabs the necessary

Kenneth Zadeck (zadeck) wrote :

Multi-GPU Configuration
1 single GPU card / integrated GPU
Graphics Processor
NVIDIA Quadro K2100M / Intel HD Graphics 4600 - 2 GB
Video System Features
NVIDIA Optimus

I need to also add that this was with the default driver that you get when you do an install.

i just installed the nvidia 361 driver and the problem seems to have gone away.

tags: added: apport-collected
description: updated

apport information

apport information

I did the apport-collect after i installed the nvidia driver. if that was a mistake, tell me and i will uninstall the driver and rerun it.

sorry, i did not read this carefully enough.

kenny

Kev Bowring (flocculant) wrote :

if we need that we'll ask again - thanks for the prompt response :)

if you find it comes back regardless of driver - please let us know

Changed in light-locker (Ubuntu):
importance: Undecided → High
Pavlushka (pavelsayekat) wrote :
Kev Bowring (flocculant) on 2016-04-11
summary: - xubuntu 16.04 beta looses mouse cursor when returning from sleep
+ xubuntu 16.04 beta loses mouse cursor when returning from sleep

can anyone affected check that a switch to vt1 and back to vt7 brings cursor back

Dan Streetman (ddstreet) wrote :

> can anyone affected check that a switch to vt1 and back to vt7 brings cursor back

yep, that does restore the pointer cursor, at least on my system.

Dan Streetman (ddstreet) wrote :

this happens even without suspending; I can just close my laptop (which is set to only lock screen), and when I open it and unlock, the pointer is not visible (except the lock screen, where the pointer is visible).

in my Xorg.0.log, the screen lock/unlock logs:
[ 5359.220] (II) intel(0): switch to mode 1024x768@60.0 on LVDS1 using pipe 0, position (0, 0), rot
[ 5360.676] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 5366.393] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 5366.393] (II) intel(0): switch to mode 1024x768@60.0 on LVDS1 using pipe 0, position (0, 0), rot

while the vt switch to VT1 then back to VT7 logs:
[ 5371.396] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 5372.514] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 5372.515] (II) intel(0): switch to mode 1024x768@60.0 on LVDS1 using pipe 0, position (0, 0), rot
[ 5373.001] (EE) intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 1, disabling CRTC:24

Dan Streetman (ddstreet) wrote :

also, I'm also using xfce window manager, and upgraded from wily to xenial last night.

Kev Bowring (flocculant) on 2016-04-17
affects: light-locker (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
affects: light-locker → xserver-xorg-video-intel
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Pavlushka (pavelsayekat) wrote :

> can anyone affected check that a switch to vt1 and back to vt7 brings cursor back
yes, it restores my cursor too.

Daniel Kessel (dkessel) wrote :

Does not only affect standby/resume. Also happens when locking/unlocking the screen.

Kev Bowring (flocculant) on 2016-04-20
summary: - xubuntu 16.04 beta loses mouse cursor when returning from sleep
+ Mouse cursor lost when returning from lock
summary: - Mouse cursor lost when returning from lock
+ Mouse cursor lost when unlocking

I have this issue or very similar in two laptops, a Toshiba and a Lenovo

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

https://shop.lenovo.com/ISS_Static/ww/wci/products/us/laptop/thinkpad/x-series/x131e-intel/X131e-Datasheet-Intel.pdf

when running systems installed from the Lubuntu alternate iso file. But since my computers are not affected in live mode and not when created from the Lubuntu desktop iso files, I suspect that it is another issue and I will create a separate bug report.

Paul White (paulw2u) wrote :

Two points to note:

1) I can confirm that just locking the screen on a Toshiba C-50B causes the mouse pointer to not appear when unlocking.
2) I've never experienced this bug during a "live" session and I *have* tried several times.

sudodus (nio-wiklund) wrote :

It might be the same bug, but I'm not sure. It is strange, that it only affects systems made from Lubuntu Xenial Alternate, not from Lubuntu Xenial desktop.

So I created the bug report

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1572640

Maybe it will be considered a duplicate, maybe not.

Martin Wolf (mwolf-adiumentum) wrote :

i did a clean installation with the final xubuntu iso and i still have the same issue with my lenovo T420 (intel only)

Detroyer (destroyer954) wrote :

I have the same issue on clean installation of xubuntu 16.04 on lenovo thinkpad e540

Kauê Rodrigues (kauefr) wrote :

This affects me on a Lenovo G40-80 laptop with an Intel i3 5005U processor.

Wayne Stark (wastark-gmail) wrote :

Also clean install from the xubuntu 16.04 amd64 iso. Intel graphics.
Happens on suspend & screen lock.

Mrinmoy Dey (mrinmoy1988) wrote :

Facing the same issue on Lubuntu 16.04 - 32 bit after upgrading from lubuntu 15.10. The issue seems to be with Light DM, Light Locker setting also not opening.

Petr Gladkikh (petrglad) wrote :

I have similar issue on Lenovo B50-70 with AMD/Intel graphics, Xubuntu.
Switching to text console and back to Ctrl+Alt+F7 does restore cursor.
I have also noted that
1. Disabling discrete AMD card in BIOS this issue still persists.
2. After waking from lock/suspend there is cursor in unlock screen but cursor disappears after session is unlocked

Kev Bowring (flocculant) wrote :

If you have this bug with intel then please use the Me Too option -

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1568604/+affectsmetoo

to register that the bug affects you.

If you have this bug without intel - please comment further.

description: updated
summary: - Mouse cursor lost when unlocking
+ Mouse cursor lost when unlocking with Intel graphics
Jens Herrmann (bugs-u) wrote :

I just got rid of this problem on 2 laptops by reconfiguring the displaymanager to gdm and back to lightdm

These are the steps it took:

1. sudo apt-get install gdm
2. sudo dpkg-reconfigure lightdm, choose gdm3 here and reboot
3. To get a login screen I had to do CTRL ALT F1 and CTRL ALT F7
4. After login the mouse cursor is also missing, CTRL+ALT F1, CTRL+ALT F7 -> its there
5. sudo dpkg-reconfigure lightdm, choose lightdm, reboot
6. login, go to STR and wake up, mouse cursor is there

Can anyone confirm this?

Kauê Rodrigues (kauefr) wrote :

@bugs-u
Didn't work for me.
Info:
Xubuntu 16.04
CPU: Intel Core i3-5005U CPU @ 2GHz
GPU: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
DE: XFCE

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1568604

tags: added: iso-testing

Happens on my Lenovo A740.

I tried, as https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815135#30 mentioned, to set accelmethod to uxa, but to no avail. Both vt-switching and xset dpms force off bring back the cursor (where locking removes it).

Drivers used:

$ grep Loading /var/log/Xorg.0.log
[ 21.562] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 21.593] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 21.596] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 21.598] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 21.598] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 21.598] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 21.598] (II) Loading sub module "fbdevhw"
[ 21.599] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 21.620] (II) Loading sub module "dri2"
[ 21.620] (II) Loading sub module "present"
[ 21.679] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 32.294] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so

This is very annoying – what package can I downgrade to avoid the problem more permanently?

Saurav (saurav1) wrote :

One workaround is to use gnome-screensaver instead of light-locker.

Happens with an Intel NUC-5i5RYH (Core i5-5250U), Xubuntu 16.04, DisplayPort driving Acer 2560x1440 monitor.

Another workaround: Create a keyboard shortcut to "light-locker-command --activate". I use "ctrl-alt-C". Using the command "xset s activate" also works. When an unlock fails to restore the mouse cursor, using the keyboard shortcut flashes the screen and when reactivated the mouse cursor is visible.

Jose Bordelon (jose-w) wrote :

I have exactly the same issue with Lubuntu 16.04 with LXDE destop and a Dell Latitude E6500.

panicopticon (embusse) wrote :

The temporary solution proposed by Leonard Samuelson (len-samuelson) in #35 works for me. I'm on a Xubuntu 16.04 on a Lenovo T530, i5-3320M, using Intel graphics.

M Hao (windcolor) wrote :

Thanks Leonard. That work around work for me. I almost want to do a fresh install.

studoret (studoret) wrote :

Happens with shuttle XH170, Intel i36100 , Ubuntu Studio 16.04 LTS

Another workaround, using one keyboard shortcut acting as CTRL-ALT-F1 / CTRL-ALT-F7 sequence :

- create a script with the following lines :

   #!/bin/sh
   sudo /bin/chvt 1
   sudo /bin/chvt 7

- add a keyboard shortcut to this script

- add permission in /etc/sudoers
   <USER> <HOSTNAME> = NOPASSWD: /bin/chvt

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in elementaryos:
status: New → Confirmed
Ilya Molokanov (f-mg-r) on 2016-06-24
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
C de-Avillez (hggdh2) on 2016-06-25
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
Sean Davis (bluesabre) on 2016-07-13
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2016-07-13
description: updated
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: New → Confirmed
affects: xserver-xorg-video-intel → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
status: Fix Released → New
no longer affects: ubuntu-translations
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
importance: Undecided → High
affects: xorg-server → xserver-xorg-video-intel
Changed in xserver-xorg-video-intel (Debian):
status: Unknown → Fix Released
Ebrael (ebraelshaddai) on 2016-07-19
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Ebrael (ebraelshaddai)
assignee: Ebrael (ebraelshaddai) → nobody
Cody Garver (codygarver) on 2016-08-09
Changed in elementaryos:
importance: Undecided → High
milestone: none → loki-rc1
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2016-08-12
description: updated
Adam Conrad (adconrad) on 2016-08-16
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Stefanos (sk) on 2016-08-16
tags: added: verification-done
removed: verification-needed
Mathes (gmathes) on 2016-08-22
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: Fix Released → Fix Committed
187 comments hidden view all 267 comments
Hannes Geist (hannes-geist) wrote :

I found a workarround for a HP 14-ac116ng (Intel Graphics) by accident:

Open the Menu with Strg + ESC or with the invisible mouse cursor. Enter something into search and then, while the menu is still open, drag the cursor from the upper left corner over the menu. It will reappear.

Jose Roa (jg-roac) wrote :

The bug remains in Elementary OS.

elementary OS 0.3.2 Freya (64-bit)
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Tested xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.1 on Xubuntu 16.04.1. Worked perfectly on Acer Aspire V3-571-6800.

linuxball (linuxball) wrote :

I had the same problem in Lubuntu 16.04.1 (running on Intel Skylake hardware).

After upgrading xserver-xorg-video-intel:amd64 from version

  2:2.99.917+git20160325-1ubuntu1

to

  2:2.99.917+git20160325-1ubuntu1.1

the problem was gone.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.917+git20160325-1ubuntu1.1

---------------
xserver-xorg-video-intel (2:2.99.917+git20160325-1ubuntu1.1) xenial; urgency=medium

  [ Sean Davis ]
  * preserve-mouse-cursor-after-vt-switch.patch: Fix lost mouse cursor after
    unlocking. (LP: #1568604)

  [ Timo Aaltonen ]
  * add-more-kbl-pciids.diff, remove-invalid-kbl-pciids.diff: Update KBL
    pciids. (LP: #1600124)

 -- Timo Aaltonen <email address hidden> Fri, 12 Aug 2016 09:32:54 +0300

Changed in xserver-xorg-video-intel (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

ttosttos (ttosttos) wrote :

The bug remains in Elementary OS.

elementary OS 0.3.2 Freya (64-bit)

Rômulo (tlromulo-o) wrote :

Yes, this is not working on Xubuntu 14.04. The bug still remains.

Stefanos (sk) wrote :

After installing the updated xserver-xorg-video-intel, this bug got fixed, but made the "text disappearing after unsuspend" bug much more frequent. This other bug is described at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1573959

Dmitriy Mozgovoy (unrtour) wrote :

When I unlock my elementary os Freya (based on Ubuntu 14.04), mouse pointer dissapears, but if I switch, for example, Youtube video to full screen, pointer appears again till next suspend.

Valdisvi (valdis-vitolins) wrote :

Following idea from comment #40, if bug still exists it's enough just to press Ctrl+F7, to push display refresh.
But at 2016-09-01 with updated 4.4.0-36-generic kernel and X.org server version 1.18.3 this bug seems fixed after locking/unlocking.

Valdisvi (valdis-vitolins) wrote :

I meant Ctrl+Alt+F7 in previous post. And it seems cursor is working after suspending also.

JP Vossen (jp-jpsdomain) wrote :

Fresh install of Xubuntu 16.05 on Dell mini9 (32-bit/atom) with Intel graphics (crash dump details in LP#1619969 if it matters):
1) At install = bug present
2) Fully update and reboot = bug fixed since that installed xserver-xorg-video-intel-2:2.99.917+git20160325-1ubuntu1.1

$ uname -a
Linux ubuntu-bellera 4.4.0-36-generic #55~14.04.1-Ubuntu SMP Fri Aug 12 11:49:30 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

1404_HWE_EOL applied
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

$ dpkg -l | grep xorg-video-intel
ii xserver-xorg-video-intel-lts-xenial 2:2.99.917+git20160325-1ubuntu1~trusty1

Still having the problem!

Workaround (switch to tty, switch to tty7)

Ctrl+Alt+F1 Ctrl+Alt+F7

1 comments hidden view all 267 comments

Tried with gnome-screensaver and xscreensaver

They work. I think the problem is light-locker

I'm trying to replace light-locker with one of them (at startup and preferences menu).

In fact, Lubuntu 12.04 LTS used xscreensaver

But Lubuntu 14.04 LTS uses light-locker

Test to do...

sudo apt-get install gnome-screensaver
sudo apt-get install xscreensaver

Ctrl+Alt+T

light-locker-command -l ----> Mouse cursor lost

killall light-locker

gnome-screensaver-command -l ----> OK

killall gnome-screensaver

xscreensaver ----> Needs daemon mode

Crtl+Alt+T

xscreensaver-command -l ----> OK

killall xscreensaver

Changed in light-locker (Ubuntu):
status: New → Invalid
importance: Undecided → High
Changed in light-locker (Ubuntu Xenial):
importance: Undecided → High
status: New → Invalid
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Triaged

This bug fixed in Xenial, but still needs to be patched in Trusty. This also will fix it in Trusty based distros like Elementary OS Freya.

I have just requested an upgrade on those. You'll be noticed when that's ready.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
no longer affects: light-locker (Ubuntu)
no longer affects: light-locker (Ubuntu Xenial)

Lenovo X230 Tablet
ElementaryOS 0.3.2 Freya (all updates up to sat 17 sept 2016)
running with TLP (http://linrunner.de/en/tlp/tlp.html)

Recently started having this issue too. When returning from lock screen:
On the lock screen the mouse cursor is visible and working. After successfull password, the mouse still works but the cursor pointer is not visible.

Notes:
  Recently I started to, ocasionally, connect to TV via display port (don't know if it is related)

Workarounds that work for me:
  - shutdown and restart the computer - this is tedious and disruptive, but works.
  - press fn+f7 (key for changing to external display. Since there is no external display the screen just flickers once) - THIS IS EASY and fast, basically, the reason for my comment here.

Mikael Larsson (m1-k) wrote :

Samsung 900X4D
ElementaryOS 0.3.2 Freya (all updates today 20 Sept. 2016.

The mouse issue is gone for me at least.

However It is not possible to get a terminal via Ctrl+Alt+n anymore. Is this related? This was my work around fix before and then it worked.

Markus J Schmidt (smiddy84) wrote :

Same bug on Xubuntu 14.04.5, was NOT present in 14.04.4.

Seems to deped on the xenial version of the driver

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel-lts-xenial (Ubuntu):
status: New → Confirmed
kabeza (kabeza) wrote :

Hi

I'm having this same issue in my desktop PC with ElementaryOS Freya
Also have a Intel based graphics board

Updated everything to 22 sept. 2016 and issue is still active

Solving temporarily with Ctrl+Alt+F1 then Alt+F7

Changed in xserver-xorg-video-intel-lts-xenial (Ubuntu):
importance: Undecided → High

I'm also having this same issue in my desktop PC with ElementaryOS Freya. Dell Vostro 3550 with Intel Graphic Card.

Using the trick Ctrl+Alt+F1 then Alt+F7 to avoid the problem.

m_k_t_6 (m-k-t-6) wrote :

I'm also having the same problem.

- ElementaryOS Freya.
- HP Z220 SFF Workstation (Intel i7-3770 CPU @ 3.40GHz. CPU integrated Intel graphics)

Solving temporarily problem with Ctrl+Alt+F1 then Alt+F7. Unbelievable that this bug still exist!

wolf (w+lf) wrote :

Bug maintainers: Looks like this should be marked as "Confirmed" for elementary OS and not "Fix released" based on the past few comments...

Zisu Andrei (matzipan) wrote :

Hey Wolf,

I believe this has been fixed in Loki (I wouldn't know, I'm running with oibaf's Intel drivers). The issue exsists in Freya since, I believe there was some update to 12.04 LTS's drivers.

kabeza (kabeza) wrote :
Download full text (3.4 KiB)

Zisu Andrei, do you have some instructions/link/whatever to solve this
manually under ElementaryOS Freya?
Thanks

On Thu, Sep 29, 2016 at 4:14 PM, Zisu Andrei <email address hidden>
wrote:

> Hey Wolf,
>
> I believe this has been fixed in Loki (I wouldn't know, I'm running with
> oibaf's Intel drivers). The issue exsists in Freya since, I believe
> there was some update to 12.04 LTS's drivers.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1568604
>
> Title:
> Mouse cursor lost when unlocking with Intel graphics
>
> Status in elementary OS:
> Fix Released
> Status in xf86-video-intel:
> Confirmed
> Status in xserver-xorg-video-intel package in Ubuntu:
> Fix Released
> Status in xserver-xorg-video-intel-lts-xenial package in Ubuntu:
> Confirmed
> Status in xserver-xorg-video-intel source package in Xenial:
> Fix Released
> Status in xserver-xorg-video-intel package in Debian:
> Fix Released
>
> Bug description:
> [Relevant details]
> This bug also affects Trusty and all distributions based on it, like
> Elementary OS Freya.
>
>
> [Impact]
> Mouse cursor is no longer visible after VT-switch for systems with Intel
> graphics.
>
> Switching VTs again may cause the cursor to become visible again.
> - Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7)
>
> This is often observed in systems that lock the session and return to
> the greeter (including at least Xubuntu, Ubuntu Mate, and elementary
> OS).
>
> [Test Case]
> (Requires a lightdm-based screen locking solution)
> 1. Start a new session.
> 2. Lock your screen.
> 2a. You are redirected to the lightdm greeter.
> 3. Login/Unlock your session.
> 4. Cursor is no longer visible.
>
> [Regression Potential]
> remains to be seen
>
> ===
>
> [Original Report]
> Cursor is visible at unlock screen either after returning from suspend
> or just locking.
>
> After unlocking screen cursor is invisible.
>
> Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7) cursor
> returns
>
> ====================
>
> no matter if you suspend or sleep, to swap or disk when you return
> from it, the mouse cursor is missing. you can still move the mouse
> and you can see (because it highlights the window) as you move it
> around. But the cursor is not displayed on the screen.
>
> i am using a lenovo W540 laptop. I downloaded the latest beta on
> april 8 2016.
>
> this is xubuntu using the xfce window manager.
>
> the cursor does return if i log off and log back in, but that actually
> defeats the purpose of going to sleep.
> ---
> ApportVersion: 2.20.1-0ubuntu1
> Architecture: amd64
> DistroRelease: Ubuntu 16.04
> InstallationDate: Installed on 2016-04-08 (2 days ago)
> InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64
> (20160323)
> NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
> Package: light-locker 1.7.0-2ubuntu1
> PackageArchitecture: amd64
> ProcEnviron:
> LANGUAGE=en_US
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignatur...

Read more...

Pedro Ávila (pedroavila95) wrote :

Solved for me:

sudo apt-add-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade

If you want to uninstall:
sudo apt-get install ppa-purge
sudo ppa-purge ppa:oibaf/graphics-drivers

kabeza (kabeza) wrote :

Tried suggestion from @pedroavila95 without luck
ElementaryOS Freya

sudo apt-add-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade
(then reboot)

Downloaded all updated, etc. still not working

Guillaume Gauffre (yomeuh) wrote :

I'm with ElementaryOS Freya.
Bug is still there

Is it because the fix is only available on xenial-updates, and still not present in trusty-updates?

The package currently installed on my laptop is xserver-xorg-video-intel-lts-xenial 2:2.99.917+git20160325-1ubuntu1

I'm using ElementaryOS Freya but now with two monitors and discovered that if you move the "hiden" mouse between the monitor the mouse cursor reappear.

I've tried to install the OIBAF drivers but nothing changed. The problem persists until now.

Grant (gsupp) wrote :

Same issue as reported in comment #244. The fix release for elementary OS only applies to version 0.4 Loki. Those of us running 0.3 Freya with the Trusty LTS Enablement Stack have not received an updated xserver-xorg-video-intel-lts-xenial:

$ lsb_release -a
No LSB modules are available.
Distributor ID: elementary OS
Description: elementary OS Freya
Release: 0.3.2
Codename: freya

$ dpkg -l | grep xorg-video-intel-lts-xenial
ii xserver-xorg-video-intel-lts-xenial 2:2.99.917+git20160325-1ubuntu1~trusty1 amd64 X.Org X server -- Intel i8xx, i9xx display driver

According to comment #203, the fix is in xserver-xorg-video-intel version 2:2.99.917+git20160325-1ubuntu1.1 (versus 2:2.99.917+git20160325-1ubuntu1). Hopefully this package will be updated in Trusty, so distros such as elementary OS Freya can benefit.

As mentioned before, the workaround is switching ttys with Ctl-Alt-F1 and then back with Ctl-Alt-F7.

Victor (victorfhansen) wrote :

This is still a problem on Black Lab Linux 7.x (built on 14.04) too. Impatiently awaiting the fix.

The use of this driver is discouraged if your hw is new enough (ca. 2007 and newer). You can try uninstalling this driver and let the server use it's builtin modesetting driver instead.

https://packages.debian.org/sid/xserver-xorg-video-intel

https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.99.917+git20160325-1ubuntu1.1

sudo apt-get purge xserver-xorg-video*
sudo reboot

Woorking! Solved!

Acer TM B115M

Martin Pitt (pitti) wrote :

I don't see anythign left to sponsor here, so unsubscribing sponsors now. Please re-subscribe when you upload further patches.

Davide Aguiari (gorghino) wrote :

Same error here with ELEMENTARY LOKI.

gorgo@dago:~$ dpkg -l | grep xorg-video-intel
ii xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1~elementary0.4.1 amd64 X.Org X server -- Intel i8xx, i9xx display driver

About my comments #261 & #262

I have problems with Google Chrome if I remove xserver-org-video-all (in my case xserver-xorg-video-all-lts-xenial) packages. Chrome works very slow and many times I'v got error application at startup.

Reinstalling the packages solves the problem with Chrome.

I read at some places that graphics acceleration can cause problems using Chrome, http://www.pcadvisor.co.uk/how-to/internet/how-turn-off-gpu-hardware-acceleration-in-google-chrome-3605455/

Eldar (fahreeve) wrote :

I have laptop with touchscreen
when cursor lost I touch the screen and move invisible cursor in touchpad and cursor displayed
I hope it will help in solving the problem

Lea Edel (ledel) wrote :

It would seem this problem still exists on trusty 14.04.5 LTS:

$ uname -a
Linux leadog 4.4.0-64-generic #85~14.04.1-Ubuntu SMP Mon Feb 20 12:10:54 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty

$ dpkg -l | grep xorg-video-intel-lts-xenial
ii xserver-xorg-video-intel-lts-xenial 2:2.99.917+git20160325-1ubuntu1~trusty1 amd64 X.Org X server -- Intel i8xx, i9xx display driver

Displaying first 40 and last 40 comments. View all 267 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.