[Xubuntu] No window manager at startup

Bug #495361 reported by Jerome on 2009-12-11
148
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Xfwm4
Confirmed
Medium
metacity
Invalid
Undecided
Unassigned
xfwm4 (Ubuntu)
Medium
Unassigned
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xfwm4

Sometimes (twice for the last 3 or 4 reboots), I get no window manager at startupt.

By that, I mean
- no window borders (title, maximize, close,...)
- window top left of screen
- focus when mouse over the window (instead of clicking)
- no panel, etc...

I can Alt-F2 to run xfwm4 and everything goes fine. Panels are created, just as normal.

I run an up to date 9.10 Xubuntu.
xfwm4 version 4.6.1 (revision 29817) for Xfce 4.6.1

I don't see anything relevant in the syslog and other logs.

There is this dodgy line :
"WARNING: Could not launch application 'metacity.desktop': Unable to start application: L'exécution du processus fils « metacity » a échoué (Aucun fichier ou dossier de ce type)"
But is it also there when it works, and anyway, I believe metacity is not xfwm4.

Somehow, I'm kinda glad it is reproducible from times to times : Is there something I should try ? What information should I provide ?

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Xubuntu better. Metacity is launched by Xfwm4. Could you please attach your ~/.xsession-errors log? Also, when logging in through GDM, when the password prompt is on your screen, you will see at the bottom, a prompt for session type. Make sure it is XFCE-SESSION, not XTERM. Thanks.

Changed in xfwm4 (Ubuntu):
status: New → Incomplete
Pasi Lallinaho (knome) wrote :

I can confirm this happens on Karmic. Just yesterday I ran an upgraded system and as the Kernel was updated to 2.6.31-16, I could log in but only the wallpaper and mouse pointer was shown. The session was definitely Xfce session (GDM had two different Xfce session items, and I tried both), but still the problem existed.

I don't have any logs from the situation, sorry. A clean installation fixed this problem.

Pasi Lallinaho (knome) wrote :

Oh, BTW, i didn't even get xfrun4 running with Alt+F2 so I couldn't start anything. The desktop enviroment was completely unusable. Also with older Kernel version, 2.6.31-10, I could get in the desktop.

Jerome (jerome-jolimont) wrote :

My bug description was a bit incorrect. Sorry about that.

I do mean
- no window borders (title, maximize, close,...)
- window top left of screen
- focus when mouse over the window (instead of clicking)

But the panel was there. (The only difference is the virtual desktop selector showing 2 desktops instead of 4.)

I do select Xfce-session in gdm. (I got two of them, by the way.)

I peeked into ~/.xsession-errors but should have copied it before rebooting twice, for now it is erased. Anyway I remember it saying the window manager was already launched. I'll copy it when it happens again.

Charlie Kravetz (charlie-tca) wrote :

Jerome - Thank you. Did you also upgrade to Xubuntu 9.10? This is normally a direct result of the upgrade. Unfortunately, the easiest fix I know does remove your configuration setup.

Before you log in, try the following:
1. Ctrl+Alt+F2 (go to a tty)
2. log in with your user name and password
3. go to ~/ (this is your /home directory)
    be careful to type the right things here, we are removing hidden directories, so they do start with dots
4. type rm ~/.cache and hit enter
5. type rm ~/.config and hit enter
6. Alt+F7 to go back to GDM
7. make sure you select XFCE-SESSION
8. log in

You should now only have one xfce-session to pick from on that gdm screen and you should get a desktop every time.

Jerome (jerome-jolimont) wrote :

I did the upgrade more than a month ago and this xfwm4 issue just happened twice in the last two says.

Besides, I don't think I actually need to remove all those files. The great majority of them have nothing to do with the issue.
(I suppose it would rather be an "rm -r".)

I'll keep it as it is until it happens again so that I can provide the ~/.xsession-errors

Charlie Kravetz (charlie-tca) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Jerome (jerome-jolimont) wrote :

Sorry, I've been moving and I have no internet acces yet.

It happenned again and I kept the ~/.xsession-errors

I try to provide it as soon as I can.

Changed in xubuntu-meta (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Lionel Le Folgoc (mrpouit) wrote :

Gerry C. > Will you stop adding a "xubuntu-meta" task to all bug report, please? The bug is definitely not in xubuntu-meta... Thank you.

Changed in xubuntu-meta (Ubuntu):
status: New → Invalid
Changed in metacity:
status: New → Invalid
marten (alexey-kv) wrote :
  • log Edit (3.1 KiB, application/x-trash)

Same here on fresh install of xubuntu 9.10 on EeePC 901

marten (alexey-kv) wrote :

Problem goes away after manually starting "xfwm4 --replace" from terminal. But login screen still has this problem

Jerome (jerome-jolimont) wrote :

Attaching requested log.

Charlie Kravetz (charlie-tca) wrote :

Thank you very much for the attachments. I am now going to confirm this bug so the developers can begin work to resolve it.

Changed in xfwm4 (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
status: Confirmed → Triaged
Jerome (jerome-jolimont) wrote :

Things are getting worse. Most of the time, though not everytime, I don't even get a panel. Which means I need to do :

Alt+F2 xterm
ps -me | grep panel
kill panel_PID_#
Alt+F2 xfce4-panel
Alt+F2 xfwm4

Still don't see anything relevant in .xsession-errors apart from :

/usr/bin/startxfce4: X server already running on display :0

** Message: To replace the current window manager, try "--replace"

** (xfwm4:1767): WARNING **: Another Window Manager is already running

Jerome (jerome-jolimont) wrote :

The problem has now become systematic. I generally have nothing on screen. I sometimes get the panel, but never the WM.

FWIIW, I thought I might have screwed up somthing while trying to configure VNC, so I commented the whole .vnc/xstartup. Doesn't make any difference.

I'm clueless. Anything I could do to help debugging ?

Jerome (jerome-jolimont) wrote :

I've been keeping my .xsession-errors for a while and the "Another Window Manager is already running" warning is the only thing different between when it works and when it fails.

Besides, i was about to close the bug as it had not happened for severeal days (whereas it used to be systematic), until the issue reappeared. I don't know if there's a direct link, but my computer was violently shut down (I switched the power off by mistake...) and now, the issue is systematic again : no window manager and invisible panel.

Again, I don't see what other information I can provide. Is there any optional log I can activate to get better traces ? Since it is reproducible, it could be investigated.

Jerome (jerome-jolimont) wrote :

Ok, now it's weird.

I created a new user accout, so as to test whether it was system-wide or user settings-related. It worked fine (for this test and the further ones, I tried 3 logins).

I removed ~/.config/xfce from my user files (I'm talking about the usual user, not the new one) -> issue still happened.
I removed all ~/.config/ from my user files -> no issue
I put back all the stuff piece by piece, trying to log in from times to times. I had no issue and I finally ended up with all my former config back and still no issue !

In the end, I couldn't isolate the guilty config file.

I suppose something was screwed in my panel config or something (which I believe is a bug in the first place since I don't remember messing much doing dodgy stuff with the command line), and while going through the process of isolating the bad file, I took the whole thing through a state where it got "cured". Sounds kinda silly, doesn't it ?

Anyway, while the issue was almost systematic, it has not happened since.

So long, bug. I guess I can close the report. I'll reopen if needed.

Again, I know the information provided is not worth much to the developper, but please tell us (users) what else to provide to help in such cases.

Changed in xfwm4 (Ubuntu):
status: Triaged → Invalid
osem8 (tomas-debnar) wrote :

Hi guys,

I see this is more than one year old issue and affects very few people, but unfortunately including me. I am Ubuntu user more than one year and one week later after upgrade to 11.04 I decided to switch to Xubuntu. I like Xubuntu, it's lighter and quicker. But, there is a bug, that is really annoying and it's actually this bug.

First time it happend was very next day I installed Xubuntu. I played with settings a lot that day installed various themes and programmes so I thougt I messed something up. It was a fresh install so after few reboots and attempts to fix it I reinstalled Xubuntu and everything was fine. Then I decided not to mess up with themes anymore I chose default theme and configured couple of keyboard shortcuts and thats it.

But today, one week later it happend again. And here are symptoms:

1. No border around windows (no maximize, minimize, close buttons)
2. No background image
3. I usually use 9 workspaces it reduced my workspaces to 1
4. I tried terminal, it loaded but I couldn't write anything to it
5. First time I lost mouse pointer ( just did not see it, clicking worked fine ), but today pointer was ok.

I found this bug report and tried to run xfwm4 manually and it fixed window borders and terminal. After reboot my background came back, only I had to manually set up number of workspaces.

I was thinking, my friend also switched to Xubuntu and has almost the same configuration as me. But it did not happen to him. Maybe it's driver issue, I don't know.
My graphic card uses NVIDIA accelerated graphics driver (version 173). (173.14.30)
Now I see there is new recommended version of the driver so I switch to it.

One strange thing i noticed when this happend to me. Both times I had problem to shut down Xubuntu. I pressed shut down button, but didn't react for more than 30 seconds. So I tried to shut down again and than it started shutting down sequence. Next time I turned on computer windows were messed up.

Let me know what kind of information do you need. I'll let know when it happens again.

Changed in xfwm4 (Ubuntu):
status: Invalid → Triaged
Nate Jones (coursekidz) wrote :

Hey, I have the same problem. I have been using xfce for a couple months, and am quite new to linux in general. I saw that some people provided their xsession-error files, so heres mine.

xraynorm (xraynorm) wrote :

Had the same problem today, after package updates. This as also happen previously.

Fixed by typing xfwm4 into the terminal.

VS (storvann) wrote :

I too was hit by this bug today. After manually launching xfwm4 (via alt+f2), the problem seems to have disappeared again.

Lionel Le Folgoc (mrpouit) wrote :

It should have improved in 11.10 (oneiric): the session isn't saved by default (on new installs), so even if xfwm4 crashes when logging out, it should be restarted the next time.

Changed in xfwm4 (Ubuntu):
status: Triaged → Incomplete
Changed in xfwm4 (Ubuntu):
status: Incomplete → Triaged

Title bar, buttons to diminish, expand, quit window - disappeared. Windows
stick to upper left-hand corner of screen with no way of moving them. A log out
and log-in solved the problem.

This has both been experienced in Magaeia XFCE version 4.8.1 and in Xubuntu XFCE version 4.8.0. In Xubuntu it has been necessary to force a restart of XFWM4, to solve the problem.

Looks like a dup of bug #7864 and bug #7866 but still the same problem, it works for me and I would need someone to get a core file if any, open that in gdb and do some initial investigation.

Maybe try to contact your distribution maintainers, I believe they should be able to assist you in getting a backtrace with symbols.

Also, the first thing to determine is if it's really an issue at startup (ie xfwm4 is listed in the session for next restart) or if it's with the logout, ie xfwm4 is removed from the session and therefore is not restarted later.

So when that happen, first thing is to check if xfwm4 is listed in your session in ~/.cache/sessions/xfce4-session-<display>

I'll look in the path the next time I experience the problem. The issue has also been posted to Mageia. They asked me to also pass a bug report on to you.

I have identified a potential crash which may occur at logout, which may cause
xfwm4 to not be restarted at next login, which would explain why it's not there
when you log in.

Fix is in git, both branches master and xfce-4.8, could you try that and
report?

Something else I've noticed (on my 4.8.2-1 debian sid package), is that if windows in a saved session are open in multiple workspaces, the symptoms do not manifest.

If the symptoms do manifest (saved session with application windows in a single workspace only), the workspace count is reduced to 1.

puchuu (aladjev-andrew) wrote :

I had this bug after upgrading xfce4 on debian. You should simply goto main console (alt + f2)
sudo invoke-rc.d gdm3 stop
rm ~/.cache/sessions/*
sudo reboot
And all will be good ^__^

Correction, symptoms still manifest if windows are open across every workspace. In fact, having windows open in every workspace seems to be a method to reproduce this.

Looks like xfwm4 is not in the sessions file.

See comment #4

Got the git build (HEAD off of the xfce-4.8 branch) done and installed it.

My testing indicates that the problem is gone (logoff/logon with applications open in all windows, followed by restart with applications open in all windows); I'll make another post in a couple days if I run into the symptoms again.

Symptoms still appearing using patched version. Any idea where a coredump might live so I can attach it?

(In reply to comment #9)
> Symptoms still appearing using patched version. Any idea where a coredump might
> live so I can attach it?

Location and naming of core files on Linux can be set using the kernel params:

  kernel.core_uses_pid
  kernel.core_pattern

You may want to check with your distribution what's the best place to set these (usually /etc/sysctl.conf)

It is not clear if the program segfaults in your case or else if this is a bug in the new implementation of session management added by Nick and Stefan in 4.8, so that should be determined first.

Note that a core file won't be useful in this bug report because I am not using the same distribution as you, so unless the core file contains all the debugging symbols and the binary statically linked (which is definitely not the case), I won't be able to make any sense of such a core file.

Brian's put some instructions on how to help debugging here:

  http://spurint.org/projects/xfce4-debugging/

Just checking, but did you install the build from source in the same path as the original build or in /usr/local (default)?

Was xfwm4 restarted after installation?

If not, can you check if the version used is the one from the source build and not still the original one, just in case?

I made sure to drop it in /usr/bin (overwriting my distro package).

>which xfwm4
/usr/bin/xfwm4

Here's the version string (xfwm4 -V):
This is xfwm4 version 4.8.2git.6c6d216 (revision 6c6d216) for Xfce 4.8
 Released under the terms of the GNU General Public License.
 Compiled against GTK+-2.24.8, using GTK+-2.24.8.

And to confirm, I've restarted xfwm several times after installing (system resets, logoffs, killing xfwm, etc).

If it crashes, I would really need at a bare minimum a backtrace to have an idea of where to look.

Lionel Le Folgoc (mrpouit) wrote :

Should be fixed when Xfwm 4.8.3 reaches precise. We'll evaluate the possibility to fix that in older releases as well when the fix get some testing.

Changed in xfwm4 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.8.3-1

---------------
xfwm4 (4.8.3-1) unstable; urgency=low

  [ Lionel Le Folgoc ]
  * New upstream release, including:
    - Fix crash in signal handler. lp: #495361
  * debian/patches:
    - 0001-Do-not-enforce-the-size-increment-only-if-the-size-r.patch: dropped,
      included upstream.
 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 03 Jan 2012 02:37:15 +0000

Changed in xfwm4 (Ubuntu):
status: Fix Committed → Fix Released

Hi,

I have almost the same problem since I started using XFCE few months ago (Gnome3 convinced me). Debian sid here (3.1.0-1-amd64).

On my side, I could not figure out exactly when it happens... maybe like 1/3 of the times. I don't think it's related to the number of open windows and/or workspaces, I would have noticed it. I guess its crashing at logout since there is no xfwm4 entry in ~/.cache/sessions (well, at least in the affected session). Also, my workspace count is not reduced to 1, but to 2 (instead of my usual 4).

It's getting pretty annoying to "ALT-F2 -> xfwm4" each time, so I'd like to help. I cannot reproduce it at command, though I think I could manage it anyway.

I've read http://spurint.org/projects/xfce4-debugging/. Good stufs, but before I did into building a reliable debug version, I wonder if there is a simpler way. If I install the xfwm4-dbg package provided in the Debian repository, isn't it enough? Then what should I do to make use of it? I'm a developper, but not very used to Linux dev, though I know how to use gdb. Can I launch xfwm4 in gdb with some arguments to make it use the xfwm4-dbg symbolic infos? Could you give me a hint or two?

The bug continues. This is affecting many more people than, perhaps, the devs realize. I just installed Xubuntu 11.10 on my wife's computer (not a week ago) and she just called me from work, unable to use her computer and me unable to help her because even if she calls up ALT+F2 or a terminal, she can't type or paste into them. I just installed Xubuntu 11.10 on a young woman's computer as she headed off to Egypt for the next year. I strongly and viscerally regret installing Xubuntu. The importance of this bug deserves to be much higher than "medium". It effectively renders the DE useless and I'm surprised that 11.10 was released without a fix. Is it possible to fix this bug in prior versions with an update?

(In reply to comment #2)
> Also, the first thing to determine is if it's really an issue at startup (ie
> xfwm4 is listed in the session for next restart) or if it's with the logout, ie
> xfwm4 is removed from the session and therefore is not restarted later.
>
> So when that happen, first thing is to check if xfwm4 is listed in your session
> in ~/.cache/sessions/xfce4-session-<display>

Same problem on Fedora 16 Xfce (no mod). But in my case the logout, login or reboot don't have solved the issue. Only removing ~/.cache/sessions/xfce4-session-<display> have restored to the 'normal' situation.
Running xfwm4 from terminal, restore the WM, but xfwm4 don't run at startup anyway..

I have hit this bug twice in the last two weeks. Is it going to be fixed for Oneiric?

Just ran into this bug. Executing "xfwm4 --display=:0.0 --replace" temporarily fixed the problem. I have the latest version of Oneiric and I just wish we would get xfmw4 version 4.8.3 pushed out to us sooner.
And yes, I agree that this bug should not be assigned "medium" importance. I was just a few seconds away from switching back to KDE.

Tom Oehser (tom-toms) wrote :

Isn't there a way to fix it without the newer xfmw4, maybe in the default startup scripts or something? This is an annoying one, for me I mean I know how to start a wm, but, now with Unity I want to be advocating xubuntu more, and, this one is problematic...

spiro2903 (spiro-ticic) wrote :

Same thing happens to me as well. No WM, can't type into Alt+F2, but use synaptics instead. Don't know if this is relevant but t is started happening after I installed Sound Juicer through Ubuntu software center. And I agree, this is quite a problematic bug, should be high priority!

Fabio Marconi (fabiomarconi) wrote :

Please open a new report typing in terminal
ubuntu-bug xfwm4
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Running Precise now, I have seen this bug 3 times in the last week following a shutdown failure, so as requested I have opened a new bug #978333

In one of the forums http://ubuntuforums.org/showthread.php?t=1930928 someone reported being told that "this problem is not with xubuntu really, but with xubuntu-desktop installed over a normal ubuntu install (oneiric)."

This is the case for my desktop, in fact I installed straight xfce and not xubuntu-desktop. Does anyone know what this mysterious problem with a normal install is?

There are similar reports of this issue on the xfce forums at http://forum.xfce.org/viewtopic.php?pid=25792#p25792

spiro2903 (spiro-ticic) wrote :

I am sorry, I am not at home at the moment so I can't report a new bug, however I did not install xfce or xubuntu-desktop, but Xubuntu OS from the start.

There are two bugs for this on launchpad https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/495361 https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/978333

I do not think that this is a segfault, as there is no core dump in /var/crash, unless something catches the signal? If so, then it shouldn't, as Ubuntu has apport to detect and upload crashes.

In my case, this seems to be a result of shutdown failing. I click the shutdown button, nothing happens, I click it again and it says "Failed to receive a reply from the session manager. Session manager must be in idle state when requesting a shutdown."

xsession-errors shows:

(xfwm4:2042): libxfce4ui-WARNING **: ICE I/O Error

(xfwm4:2042): libxfce4ui-WARNING **: Disconnected from session manager.
** Message: using fallback from indicator to GtkStatusIcon
** Message: xfsm-shutdown-helper.c:1472: Using ConsoleKit to Stop

I think I have a reproducible test case:

* log in
* xfce loads panel, begins to restore session, loads firefox etc.
* while this is happening, click on shutdown action button in panel
* click on shutdown again
* Get dialog popup ("Failed to receive a reply from the session manager. Session manager must be in idle state when requesting a shutdown.")
* ctrl-alt-f1 (we somehow broke shutdown, and sometimes it stops and sometimes the system still shuts down, switching to the console seems to prevent consolekit from shutting down)

The system will now be in a state where there is a zombie xfce4-session process, and most other xfce processes that would normally be running (the ones with --sm-client-id in the args) are not running (including xfwm4)

However, there is a new xfce4-session process, and (this is a guess) perhaps it is now responsible for removing xfwm4 from the session.

@spiro I already opened a new bug : bug #978333

s carr (imscarr) wrote :

I get this problem about every 3 weeks. Very ^%(*(&^)*&ing annoying!!!

I can't fix it. :(

Could this be caused by bug #5379 - "xfce session can't properly handle 2+ applications with interactive session save"?

The description there sounds the same as what I've seen ("Instead, it will wait 1 minute, and then forcibly close the session. During this period, a second logout attempt will say that the session manager must be idle when requesting shutdown.")

If you are still experiencing this bug please subscribe to bug #978333. I have found duplicate bug reports for Debian and Fedora, and I have found an upstream bug report for xfwm4-session where the description seems to match what I have seen when this bug occurs : https://bugzilla.xfce.org/show_bug.cgi?id=5379 - It would be interesting to know whether this "2+ applications with interactive session save" is the case when others see this problem )

I've upgraded to 12.04 so there haven't been any bugs so far.
Thanks

On Thu, May 17, 2012 at 2:55 PM, Chris Bainbridge <
<email address hidden>> wrote:

> If you are still experiencing this bug please subscribe to bug #978333.
> I have found duplicate bug reports for Debian and Fedora, and I have
> found an upstream bug report for xfwm4-session where the description
> seems to match what I have seen when this bug occurs :
> https://bugzilla.xfce.org/show_bug.cgi?id=5379 - It would be interesting
> to know whether this "2+ applications with interactive session save" is
> the case when others see this problem )
>
> ** Bug watch added: Xfce Bugzilla #5379
> http://bugzilla.xfce.org/show_bug.cgi?id=5379
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/495361
>
> Title:
> [Xubuntu] No window manager at startup
>
> Status in The Metacity Window Manager:
> Invalid
> Status in Xfce4 window manager:
> Unknown
> Status in “xfwm4” package in Ubuntu:
> Fix Released
> Status in “xubuntu-meta” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: xfwm4
>
> Sometimes (twice for the last 3 or 4 reboots), I get no window manager
> at startupt.
>
> By that, I mean
> - no window borders (title, maximize, close,...)
> - window top left of screen
> - focus when mouse over the window (instead of clicking)
> - no panel, etc...
>
> I can Alt-F2 to run xfwm4 and everything goes fine. Panels are
> created, just as normal.
>
> I run an up to date 9.10 Xubuntu.
> xfwm4 version 4.6.1 (revision 29817) for Xfce 4.6.1
>
> I don't see anything relevant in the syslog and other logs.
>
> There is this dodgy line :
> "WARNING: Could not launch application 'metacity.desktop': Unable to
> start application: L'exécution du processus fils « metacity » a échoué
> (Aucun fichier ou dossier de ce type)"
> But is it also there when it works, and anyway, I believe metacity is not
> xfwm4.
>
> Somehow, I'm kinda glad it is reproducible from times to times : Is
> there something I should try ? What information should I provide ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/metacity/+bug/495361/+subscriptions
>

I have seen this bug on 12.04.

spiro2903 (spiro-ticic) wrote :

Thanks for the info. If it reoccurs I will post the logs.

On Thu, May 17, 2012 at 3:10 PM, Chris Bainbridge <
<email address hidden>> wrote:

> I have seen this bug on 12.04.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/495361
>
> Title:
> [Xubuntu] No window manager at startup
>
> Status in The Metacity Window Manager:
> Invalid
> Status in Xfce4 window manager:
> Unknown
> Status in “xfwm4” package in Ubuntu:
> Fix Released
> Status in “xubuntu-meta” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: xfwm4
>
> Sometimes (twice for the last 3 or 4 reboots), I get no window manager
> at startupt.
>
> By that, I mean
> - no window borders (title, maximize, close,...)
> - window top left of screen
> - focus when mouse over the window (instead of clicking)
> - no panel, etc...
>
> I can Alt-F2 to run xfwm4 and everything goes fine. Panels are
> created, just as normal.
>
> I run an up to date 9.10 Xubuntu.
> xfwm4 version 4.6.1 (revision 29817) for Xfce 4.6.1
>
> I don't see anything relevant in the syslog and other logs.
>
> There is this dodgy line :
> "WARNING: Could not launch application 'metacity.desktop': Unable to
> start application: L'exécution du processus fils « metacity » a échoué
> (Aucun fichier ou dossier de ce type)"
> But is it also there when it works, and anyway, I believe metacity is not
> xfwm4.
>
> Somehow, I'm kinda glad it is reproducible from times to times : Is
> there something I should try ? What information should I provide ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/metacity/+bug/495361/+subscriptions
>

Esther Melander (melanes) wrote :

This bug has shown up on 12.04 again. My system started up as described above with the exception that I can click on the menu bar and close a program by clicking on File -> close - just no title bar or window decorations. In addition, the focus was not properly directed to open windows and I could not type in my password in Keepass, for example, but I could click on the cancel button. The top panel showed open windows that I had previously closed. I was able to restore the window manager by typing xfwm4 --replace in a terminal window. I can attach additional logs if that would be helpful, just not sure which ones.

Claude Duval (ae6fi) wrote :

A good suggestion, is in order? Re-install Xubuntu, and download all the Updates! That fixed my problems with Xubuntu.......Claude Duval <email address hidden>

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>]On Behalf Of
Esther Melander
Sent: Saturday, July 07, 2012 8:31 PM
To: <email address hidden>
Subject: [Bug 495361] Re: [Xubuntu] No window manager at startup

This bug has shown up on 12.04 again. My system started up as described
above with the exception that I can click on the menu bar and close a
program by clicking on File -> close - just no title bar or window
decorations. In addition, the focus was not properly directed to open
windows and I could not type in my password in Keepass, for example, but
I could click on the cancel button. The top panel showed open windows
that I had previously closed. I was able to restore the window manager
by typing xfwm4 --replace in a terminal window. I can attach additional
logs if that would be helpful, just not sure which ones.

--
You received this bug notification because you are subscribed to a
duplicate bug report (883706).
https://bugs.launchpad.net/bugs/495361

Title:
  [Xubuntu] No window manager at startup

Status in The Metacity Window Manager:
  Invalid
Status in Xfce4 window manager:
  Unknown
Status in “xfwm4” package in Ubuntu:
  Fix Released
Status in “xubuntu-meta” package in Ubuntu:
  Invalid

Bug description:
  Binary package hint: xfwm4

  Sometimes (twice for the last 3 or 4 reboots), I get no window manager
  at startupt.

  By that, I mean
  - no window borders (title, maximize, close,...)
  - window top left of screen
  - focus when mouse over the window (instead of clicking)
  - no panel, etc...

  I can Alt-F2 to run xfwm4 and everything goes fine. Panels are
  created, just as normal.

  I run an up to date 9.10 Xubuntu.
  xfwm4 version 4.6.1 (revision 29817) for Xfce 4.6.1

  I don't see anything relevant in the syslog and other logs.

  There is this dodgy line :
  "WARNING: Could not launch application 'metacity.desktop': Unable to start application: L'exécution du processus fils « metacity » a échoué (Aucun fichier ou dossier de ce type)"
  But is it also there when it works, and anyway, I believe metacity is not xfwm4.

  Somehow, I'm kinda glad it is reproducible from times to times : Is
  there something I should try ? What information should I provide ?

To manage notifications about this bug go to:
https://bugs.launchpad.net/metacity/+bug/495361/+subscriptions

Esther Melander (melanes) wrote :

This occurred on a clean install of 12.04 that I've been running for 2 months. I've had this problem occur 3-4 times since install.

In , Thvv (thvv) wrote :

I saw this too. Installed a grub update via yum.
Logged out and got a shutdown fail.. may have clicked shutdown again.
After a minute or so it logged me out.
No window manager after logging in again.

A quick workaround for me was to
   mv .cache bad.cache
log out and back in again.

Please see bug #5379 for a fix for the issue that caused this problem in my case (xfwm4 getting removed from session file on logout due to two apps both requesting interaction).

Jeremy Stephens (kindlyviking) wrote :

I've been having this problem on 12.10 using Xfce 4.10. It's happened at least twice since I upgraded.

The bug that causes this is now fixed upstream and in Ubuntu 13.04, see bug #978333 (hopefully it will also get fixed in Precise etc.)

Patrick O'Keeffe (launchpsd) wrote :

I recently installed Xubuntu 14.04 on a fresh machine and upgraded another from 13.10 -> 14.04. This issue appeared on the upgraded machine but the fresh install was totally fine.

The time it takes to login was extended and the display flickered for a second several times. No window manager after login, windows launched in top-left corner, focus follows mouse. Some applications (like Firefox) steal mouse focus regardless so Alt+F2 or a terminal wouldn't accept typing input until those apps were closed.

Launching `xfwm4` was enough to restore normality. I could close the terminal (no trailing ` &`) and xfwm4 continued running.

I tried to fix it by adding `xfwm4` to my start-up list via Settings Manager > Session and Startup > Application Autostart. After logging in, I could see the window manager start initially but it was closed several seconds later. My `.xsession-errors` file would only have these five lines:

    openConnection: connect: No such file or directory
    cannot connect to brltty at :0
    Script for ibus started at run_im.
    Script for auto started at run_im.
    Script for default started at run_im.

Ultimately I fixed this issue by deleting ~/.cache/sessions/. Sorry I didn't think to rename it, then work backwards to find the offending file.

xfwm4 was sometimes(rarely) terminating on startup, for me, and I had a focus follows mouse or something - fix was to restart startx.
The error is this (RenderBadPicture at the very end):
...
DBG[display.c:468] myDisplayGrabServer(): entering myDisplayGrabServer
DBG[display.c:475] myDisplayGrabServer(): grabs : 2
DBG[display.c:468] myDisplayGrabServer(): entering myDisplayGrabServer
DBG[display.c:475] myDisplayGrabServer(): grabs : 3
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:495] myDisplayUngrabServer(): grabs : 2
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:495] myDisplayUngrabServer(): grabs : 1
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:491] myDisplayUngrabServer(): ungrabbing server
DBG[display.c:495] myDisplayUngrabServer(): grabs : 0
XError: BadDamage (invalid Damage parameter)
==> XID 0x600350, Request 143, Error 151 <==
XError: BadDamage (invalid Damage parameter)
==> XID 0x60034c, Request 143, Error 151 <==
XError: BadDamage (invalid Damage parameter)
==> XID 0x60034c, Request 143, Error 151 <==
XError: RenderBadPicture (invalid Picture parameter)
==> XID 0x5f, Request 139, Error 143 <==
DBG[main.c:701] main(): xfwm4 terminated

I am wondering if this recent commit fixed that 3f1b7c02ddcbb686f6f227b09f6e3017445880bf because I seem to be unable to reproduce it again, although it was rare/hard to reproduce anyway. So either that fixed it, or it's just that rare and hard to reproduce.

This is from another log (also pre that commit):
...
DBG[display.c:468] myDisplayGrabServer(): entering myDisplayGrabServer
DBG[display.c:471] myDisplayGrabServer(): grabbing server
DBG[display.c:475] myDisplayGrabServer(): grabs : 1
DBG[display.c:468] myDisplayGrabServer(): entering myDisplayGrabServer
DBG[display.c:475] myDisplayGrabServer(): grabs : 2
DBG[display.c:468] myDisplayGrabServer(): entering myDisplayGrabServer
DBG[display.c:475] myDisplayGrabServer(): grabs : 3
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:495] myDisplayUngrabServer(): grabs : 2
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:495] myDisplayUngrabServer(): grabs : 1
DBG[display.c:483] myDisplayUngrabServer(): entering myDisplayUngrabServer
DBG[display.c:491] myDisplayUngrabServer(): ungrabbing server
DBG[display.c:495] myDisplayUngrabServer(): grabs : 0
XError: BadDamage (invalid Damage parameter)
==> XID 0xa002c1, Request 143, Error 151 <==
XError: RenderBadPicture (invalid Picture parameter)
==> XID 0x5f, Request 139, Error 143 <==
DBG[main.c:701] main(): xfwm4 terminated

Olivier, if you could confirm whether or not that commit fixes this, I would appreciate it very much, save me some time. Otherwise, if you have any suggestions on getting better debug for that, I'd be happy to.

Thanks.

PS: the logs were made with at least commit e97066e3171564b513e8211ec39c26d8381adfc3 if not a more recent one

(In reply to EmanueL Czirai from comment #22)
> xfwm4 was sometimes(rarely) terminating on startup, for me, and I had a
> focus follows mouse or something - fix was to restart startx.
> The error is this (RenderBadPicture at the very end):
> [...]
> XError: RenderBadPicture (invalid Picture parameter)
> ==> XID 0x5f, Request 139, Error 143 <==
> DBG[main.c:701] main(): xfwm4 terminated
>
> I am wondering if this recent commit fixed that
> 3f1b7c02ddcbb686f6f227b09f6e3017445880bf because I seem to be unable to
> reproduce it again, although it was rare/hard to reproduce anyway. So either
> that fixed it, or it's just that rare and hard to reproduce.
> [...]
> Olivier, if you could confirm whether or not that commit fixes this, I would
> appreciate it very much, save me some time. Otherwise, if you have any
> suggestions on getting better debug for that, I'd be happy to.

Nope, none of the XError are fatal. The commit you point out is completely unrelated and purely cosmetic.

Besides, the fact that you see "xfwm4 terminated" means it died gracefully, i.e. it's not a crash.

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed

Thanks Olivier, I'll investigate further.
The thing is, it only terminated when this message happened:

XError: RenderBadPicture (invalid Picture parameter)
==> XID 0x5f, Request 139, Error 143 <==
DBG[main.c:701] main(): xfwm4 terminated

When it doesn't terminate, there's no RenderBadPicture in the log, even though there are other many BadDamage ones.

I'll let you know if I find out anything. (should start a new bug(when I find something) ? because I think I was wrong to post here even though I thought the title matches my issue)

(In reply to EmanueL Czirai from comment #24)
> Thanks Olivier, I'll investigate further.
> The thing is, it only terminated when this message happened:
>
> XError: RenderBadPicture (invalid Picture parameter)
> ==> XID 0x5f, Request 139, Error 143 <==
> DBG[main.c:701] main(): xfwm4 terminated
>
> When it doesn't terminate, there's no RenderBadPicture in the log, even
> though there are other many BadDamage ones.

No, it's unrelated.

> I'll let you know if I find out anything. (should start a new bug(when I
> find something) ? because I think I was wrong to post here even though I
> thought the title matches my issue)

Correct, this bug is unrelated to your issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.