Could not install 'debconf' during System upgrade 7.04 to 7.10

Bug #147429 reported by reto.koenig on 2007-09-30
74
Affects Status Importance Assigned to Milestone
adept (Ubuntu)
Undecided
Unassigned
debconf (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Trying to upgrade from 7.04 to 7.10.

Michael Vogt (mvo) wrote :

Thanks for your bugreport. Please attach the files in /var/log/dist-upgrade/* to this report. Thanks, Michael

Changed in update-manager:
status: New → Incomplete

I'm upgrading using the cd. It also failed to install X11.

This is file 3 of 3 of the files requested from /var/log/dist-upgrade

James (james-ellis-gmail) wrote :

Hi

Upgrading from Kubuntu 7.04 to 7.10 RC1 using the Adept instructions on kubuntu wiki gave the same problem for me.

Adept version upgrader hung at libslang install (I think this is more to do with it being the package to install after debconf?)
I ended up having to kill all the adept and apt processes running, then completed upgrade of the system using

$ sudo aptitude dist-upgrade

about 3 times, which did the trick.

Logs to help debug the problem (dist-upgrade main.log)
===============
2007-10-13 06:30:30,894 DEBUG have: ['/tmp/kde-root/adept_managerlKxEYb.tmp-extract/backports/release-upgrader-dpkg_1.14.5ubuntu11.2_i386.udeb', '/tmp/kde-root/adept_managerlKxEYb.tmp-extract/ba
ckports/release-upgrader-apt_0.6.46.4ubuntu10.3_i386.udeb']
2007-10-13 06:30:30,894 DEBUG no file '/etc/apt/apt.conf.d/20archive'
2007-10-13 07:29:11,219 INFO cache.commit()
2007-10-13 07:29:18,178 DEBUG fork pid is: 11346
2007-10-13 07:50:45,460 ERROR got an error from dpkg for pkg: 'debconf': 'subprocess post-installation script killed by signal (Segmentation fault), core dumped
'
2007-10-13 07:50:45,930 ERROR got an error from dpkg for pkg: 'debconf': 'subprocess post-installation script killed by signal (Segmentation fault), core dumped
'
2007-10-13 07:52:04,047 ERROR got an error from dpkg for pkg: '/var/cache/apt/archives/x11-common_1%3a7.2-5ubuntu13_i386.deb': 'subprocess pre-installation script killed by signal (Segmentation fault), core dumped
'
2007-10-13 07:52:04,057 ERROR got an error from dpkg for pkg: '/var/cache/apt/archives/x11-common_1%3a7.2-5ubuntu13_i386.deb': 'subprocess pre-installation script killed by signal (Segmentation fault), core dumped
'
2007-10-13 07:52:13,915 ERROR got an error from dpkg for pkg: 'x11-common': 'dependency problems - leaving unconfigured
'
2007-10-13 07:52:13,984 ERROR got an error from dpkg for pkg: 'x11-common': 'dependency problems - leaving unconfigured
'
2007-10-13 07:56:19,193 WARNING no activity on terminal for 240 seconds (Configuring libslang2)

Michael Vogt (mvo) wrote :

@James: could you please check in /var/crash/ if there is a file that starts with "_usr_bin_debconf " and then please attach it to this bugreport. Please also run:
$ /usr/share/apport/apport-gtk -c /var/crash/_usr_bin_debconf*
and add the link to the apport bugreport.

Thanks,
 Michael

Michael Vogt (mvo) wrote :

@DavidValentine: Could you please do the same as I just asked James ?

simon.bauer (simon-bauer) wrote :

Hello I posted here the same Bug #150768 and in my /var/crash are 3 related files:

1) /var/crash/_usr_share_debconf_frontend.0.crash
  (This is empty one)

2) nano /var/crash/debconf.0.crash
ProblemType: Package
Date: Mon Oct 8 23:45:43 2007
ErrorMessage:
 ErrorMessage: subprocess post-installation script killed by signal (Segmentation fault), core dumped

Package: debconf
SourcePackage: debconf

3)/var/crash/x11-common.0.crash
ProblemType: Package
Date: Mon Oct 8 23:48:07 2007
ErrorMessage:
 ErrorMessage: dependency problems - leaving unconfigured

Package: x11-common
SourcePackage: xorg

Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :
Gary Wilson (gary-wilson) wrote :

$ /usr/share/apport/apport-gtk -c /var/crash/_usr_share_debconf_frontend.0.crash
Usage: apport-gtk [options]

apport-gtk: error: no such option: -c

Gary Wilson (gary-wilson) wrote :

Same problem for me today when upgrading from Kubuntu 7.04 to 7.10 following the instructions here http://kubuntu.org/announcements/7.10-release.php#upgrade.

And yes, https://bugs.launchpad.net/ubuntu/+source/debconf/+bug/150768 appears to be the same issue and exactly describes the errors I saw.

HI,
 I think I have same problem. Here are my logs

Here is the content of my /var/crash/

-rw-r--r-- 1 root root 267 2007-10-19 08:41 debconf.0.crash
-rw-r--r-- 1 root root 174 2007-10-19 08:43 libpam0g.0.crash
-rw-r--r-- 1 root root 180 2007-10-19 08:43 libpam-modules.0.crash
-rw-r--r-- 1 root root 174 2007-10-19 08:43 login.0.crash
-rw------- 1 root root 139413 2007-10-11 21:37 _sbin_usplash.0.crash
-rw------- 1 mk mk 4620427 2007-10-19 08:55 _usr_bin_kdesktop_lock.1000.crash
-rw------- 1 mk mk 37809818 2007-10-13 22:02 _usr_lib_firefox_firefox-bin.1000.crash
-rw------- 1 root root 8768261 2007-10-19 08:41 _usr_share_debconf_frontend.0.crash

debconf, libpam0g, ibpam-modules,login and debconf are the packages for which something went wrong during the update. I'm not sure these are related bugs. Should I file 5 different bg reports???!
Should I post those files here?

I'm back tonight.
Here is what I did after having the above problem to try and solve that (I'm not sure whether it's the right place, sorry if it is not).
I first made sure that no package manager program was running, then I typed the following:
sudo rm /var/lib/dpkg/lock
sudo rm /var/cache/apt/archives/lock
sudo apt-get install
#it gave me the following advice, which I followed:
sudo dpkg --configure -a
It restarted the installation for the above mentioned broken packages, starting with
"Paramétrage de debconf (1.5.14ubuntu1) ..."
(there are still dependency problems with 'gs-common' and 'gs-esp' ['ghostscript' lacking])

I checked that "debconf (1.5.14ubuntu1) " is for 7.10 (1.5.13ubuntu1 is for 7.04), so I guess it's a good sign.

Then I started again adept-manager (from the icon), clicking "update everything".
It started downoading eveything again.
When it'll be finished (in a few hours...) I'll try to reboot and I'll post here if it worked.

Before rebooting, saw in adept that many packages were broken. I tried to reload and update through adept, but, after a while, adept crashed.
I finished the job with the following:
sudo rm /var/lib/dpkg/lock
 sudo rm /var/cache/apt/archives/lock
 sudo apt-get install
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade

(I'm not sure on the exact sequence I used on the above for all this post).

I rebooted
Gutsy works...

Jet (poekie) wrote :

Same problems here. For the 'official' release, this is quite a serious bug.
Kubuntu here by the way, using adept

Jet (poekie) wrote :

and the other log

Jet (poekie) wrote :

and the last one.

While doing the 'fix' of Mr. Kauffmann, I get this:
root@jet:/home/jet# apt-get install
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
root@jet:/home/jet# dpkg --configure -a
dpkg: parse error, in file `/var/lib/dpkg/updates/0003' near line 2 package `libc6':
 `triggers-pendi' is not allowed for third (status) word in `status' field

so that one is not working for me. Please fix this bug!

Jet (poekie) wrote :

I have this same problem on Kubuntu 7.04 trying to upgrade to 7.10 using adept and using this 'howto'
https://help.ubuntu.com/community/GutsyUpgrades#head-3692aaaed415e3427f54ec62dd8659474516b525

Jan Schnackenberg (yehaa) wrote :

I have the same problem with the upgrade to Kubuntu 7.10.

I noticed, that the segfault happend right after my memoryusage skyrockets.

I have 1 GB of RAM. Right before the error-message the memory-usage jumps from approx. 250MB to >1GB (using at least 250MB of swap).

I have two crash-log-files in /var/crash:
-rw-r--r-- 1 root root 228 2007-10-20 20:18 debconf.0.crash
-rw------- 1 root root 9200155 2007-10-20 20:18 _usr_sbin_dpkg-preconfigure.0.crash
-rw------- 1 root root 9046462 2007-10-20 19:25 _usr_share_debconf_frontend.0.crash
-rw-r--r-- 1 root root 227 2007-10-20 20:20 x11-common.0.crash

the "x11-common.0.crash" says that that upgrade-process crashed, too. But there's no .crash-files for that.

Mike Perry (mike.perry) wrote :

Wow this is a horrible bug. I'm affected by it to and I am going to try to follow dpkgs advice and do the configure -a

I'm really afraid this is going to break my workstation. I'll keep ya posted.

Mike Perry (mike.perry) wrote :
Download full text (22.7 KiB)

Here is some scary output:
mwp@chimay:/etc/apt$ sudo dpkg --configure -a
Setting up libxdmcp6 (1:1.0.2-2) ...

Setting up x11proto-input-dev (1.4.2-1) ...
Setting up libgcrypt11 (1.2.4-2ubuntu2) ...

dpkg: error processing fontconfig (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
Setting up python2.5-dev (2.5.1-5ubuntu5) ...
Setting up libc6-dev (2.6.1-1ubuntu9) ...
Setting up python (2.5.1-1ubuntu2) ...

dpkg: dependency problems prevent configuration of libfontconfig1-dev:
 libfontconfig1-dev depends on libfontconfig1 (= 2.4.2-1.2ubuntu4); however:
  Version of libfontconfig1 on system is 2.4.2-1ubuntu1.
dpkg: error processing libfontconfig1-dev (--configure):
 dependency problems - leaving unconfigured
Setting up python-central (0.5.15ubuntu2) ...
Setting up kdelibs-data (4:3.5.8-0ubuntu3) ...
Installing new version of config file /etc/kde3/ui/ui_standards.rc ...
Installing new version of config file /etc/xdg/menus/kde-applications.menu ...

Setting up x11proto-core-dev (7.0.10-2) ...
Setting up libopencdk8 (0.5.13-2) ...

Setting up libartsc0 (1.5.8-0ubuntu1) ...

Setting up xtrans-dev (1.0.3-2) ...
Setting up libc6-i686 (2.6.1-1ubuntu9) ...

Setting up comerr-dev (2.1-1.40.2-1ubuntu1) ...

Setting up libvorbis0a (1.2.0.dfsg-1) ...

Setting up zlib1g-dev (1:1.2.3.3.dfsg-5ubuntu2) ...
Setting up libice6 (2:1.0.3-3) ...

Setting up libx11-data (2:1.1.1-1ubuntu4) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Setting up libsm6 (2:1.0.3-1) ...

Setting up apt-utils (0.7.6ubuntu14) ...

Setting up libkrb53 (1.6.dfsg.1-7build1) ...

Setting up cpio (2.8-1ubuntu2) ...

Setting up python-examples (2.5.1-1ubuntu2) ...
Setting up binutils (2.18-0ubuntu3) ...

Setting up idle (2.5.1-1ubuntu2) ...

Setting up libfreetype6-dev (2.3.5-1ubuntu4) ...

Setting up libglib2.0-0 (2.14.1-1ubuntu1) ...

Setting up libgnutls13 (1.6.3-1build1) ...

Setting up libxau6 (1:1.0.3-2) ...

Setting up libvorbisfile3 (1.2.0.dfsg-1) ...

Setting up libexpat1-dev (1.95.8-4ubuntu1) ...

Setting up libxdmcp-dev (1:1.0.2-2) ...
Setting up libdbus-glib-1-2 (0.74-1) ...

Setting up libice-dev (2:1.0.3-3) ...
Setting up libxau-dev (1:1.0.3-2) ...
Setting up libx11-6 (2:1.1.1-1ubuntu4) ...

Setting up pkg-config (0.22-1) ...
Setting up libxml2-dev (2.6.30.dfsg-2ubuntu1) ...
Setting up libssl-dev (0.9.8e-5ubuntu3) ...
Setting up libx11-dev (2:1.1.1-1ubuntu4) ...
Setting up libkadm55 (1.6.dfsg.1-7build1) ...

Setting up libkrb5-dev (1.6.dfsg.1-7build1) ...
Setting up libcupsys2 (1.3.2-1ubuntu7) ...

Setting up libxt6 (1:1.0.5-3) ...

Setting up libsm-dev (2:1.0.3-1) ...
Setting up libxt-dev (1:1.0.5-3) ...
Setting up libaudio2 (1.9-2) ...

Setting up perl-modules (5.8.8-7ubuntu3) ...
Setting up perl (5.8.8-7ubuntu3) ...

Setting up kdelibs4c2a (4:3.5.8-0ubuntu3) ...

Setting up dpkg-dev (1.14.5ubuntu16) ...
Setting up perl-suid (5.8.8-7ubuntu3) ...
Setting up adept-batch (2.1.3ubuntu17) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 fontconfig
 libfontconfig1-dev
mwp@chimay:/etc/apt$ sudo apt-g...

Jan Schnackenberg (yehaa) wrote :

@Mike:
I just finished upgrading via the "aptitude -v dist-upgrade" path.

I had similarly longish outputs by aptitude, and I had to run "aptitude dist-upgrade" 3 or 4 times, but now my system is up and running Gutsy.

Only problem I had was, that I had to reinstall the restricted-modules as the nvidia kernel modules didn't exist anywhere on my system after the upgrade. Other than that: Everything _seems_ to work (haven't done much, though).

Mike Perry (mike.perry) wrote :

I just finished my update. I have to say I am not impressed lately with Ubuntu. I have run into a total of 4 bugs so far (including this one) between 2 computers. All bugs were show stoppers for me and if I had not have had some decent experience with Linux my two machines would have been a bricks right now.

I know this isn't really the place for these complaints, but where is the proper place?

Anyway, things seem to go find with the dist-upgrade and then reboot. All hell seemed to break loose as I couldn't boot. When running in single user mode I saw a lot of references to "dm-linear" flashing by my screen. A quick google search told me to remove the evms package. Which I could do from a feisty kernel. After that, well, I'm typing this in KDE now... so it worked.

These bugs are serious, and now I'm a bit concerned that my machine is in an invalid state. How do I know if there are other Feisty packages that need to still be removed? How can I confirm Gusty is in place correct? Is there some sort of checksum function?

As a side note, World of Warcraft is still working. So this is good news.

I had the same problems upgrading Kubuntu 7.04 to 7.10.
Running "sudo dpkg --configure -a", running adept a few times and rebooting seems to have done the trick.

Only thing is, that now, every time I install an update, adept asks me if I want to upgrade my distribution.
If I decide to upgrade to this new distribution (7.10, which I am already running) the upgrade runs until I reach the 'modifying software channels' step, at which point I'm told that the system is already up to date and that the upgrade will be canceled .

My guess would be that there is some configuration file or some such that still lists my system as being 7.04. My system is running fine, so it's no big problem, but if anybody knows how I can resolve this without a full re-install, I'd like to know.

Mike Perry (mike.perry) wrote :

@Martijn
This morning when I updated OpenOffice adept complained about a new version available for me too. I have entered this information in:

https://bugs.launchpad.net/ubuntu/+source/adept/+bug/155175

It would be nice if you could add a comment to that bug also.

@Mike
This update comes from the gutsy-proposed repository which you had to
enable to do the upgrade.

If you disable this, the proposed (as in "not yet finalized") updates
won't be installed.

So this is probably not really connected to the problem with the
"existing but not really existing" upgrade from gutsy to gutsy. ;)

James (james-ellis-gmail) wrote :

Sorry, am a bit late back on this - I didn't get notified of all the updates ?? Is there an RSS feed or something I can subscribe to ?

There is no debconf file in /var/crash anymore. System is working normally now apart from disappearing network (bug 155603) and even had a tool around in kde4b3 :)

Matti Lindell (mlind) wrote :

@ James
RSS feed for gutsy updates: http://media.ubuntu-nl.org/rss/gutsy.xml
mailing list archives for gutsy updates https://lists.ubuntu.com/archives/gutsy-changes/

I just came a cropper of this one too. The good news is it seems to be survivable. After the bug appeared, the upgrade tool was frozen trying to upgrade the next package in the sequence.
I clicked the X to close the upgrader window and, IIRC, dismissed a warning.
I then opened a konsole window and did a $ ps ax | grep apt and $ ps ax | grep adept, to locate any package management apps still open. I killed them (one was python, as I recall).
I then removed the lock files as described by Mayeul KAUFFMANN further up the page.
I then ran various combinations of $ sudo dpkg --configure -a, $ sudo apt-get (with various arguments) and now I am back at my desktop. See attached portion of my ~/.bash_history (survive.txt) file to see exactly what I did in order to survive.

Mike Green (mikey-badpenguins) wrote :

I have been hit by the same bug during 3 different upgrades of kubuntu, from feisty to gutsy. The only thing I can add to the bug is that I noticed during the configuration of the new debconf app-armor killed it as a stack smashing attempt.... It all went downhill from there.

Mike Green (mikey-badpenguins) wrote :

Sorry, forgot to attach the logs... Also, if I recall correctly, app-armor was responding to a perl app. I saw the app-armor message in the terminal window but it does not appear to have shown up in any log entry.

edfardos (edfardos) wrote :

This is a me-too.

After a half-dozen packages upgraded (including libc6):
  Could not install 'debconf'
  subprocess post-installation script killed by signal (Segmentation fault), core dumped
  (saw prior mention of "perl stack squashed")

Continuing the upgrade fails on each additional package. Went through roughly four,
including xorg, then the installer hangs.

Workaround:

kill adept process (running in python interpreter)
# dpkg --configure -a
# apt-get dist-upgrade
# apt-get -f dist-upgrade

Nothing unusual was removed as a result of the -f upgrade, so it looks and
works like a clean gutsy system once those commands complete (1077 packages
are installed).

I really wish I found this bug before I clicked to upgrade my distribution though.

from kubuntu/gutsy,
-edfardos

Rob Hasselbaum (rhasselbaum) wrote :

Problem confirmed here as well, also with Kubuntu. I have never had an upgrade work without errors since Dapper. For a consumer-oriented distro, this is terrible.

Mike Perry (mike.perry) wrote :

What is the status of this bug? I'm surprised that bug is still "Undecided". If I had not being using Linux for a number of years I would have been dead in the water. Bugs like this definitely block bug #1.

Mike Green (mikey-badpenguins) wrote :

Does anyone have any idea of what packages need to be removed after manually recovering from a failed upgrade? Every kubuntu box I have upgraded failed, all of them still have ubiquity, casper, etc... installed.

It does seem pathetic that this bug has not been addressed. I have yet to perform a successful upgrade of kubuntu to gutsy. If ubuntu is not going to support kubuntu at least they should let the public know. I can't stand gnome and will never use it.

pepster (jheled) wrote :

I simply removed all packages which dpkg had problems with (i.e. unresolved dependencies). I think this is different from box to box, depending on the exact nature of installed packages. I reckoned I could always install them again later.

santana (burlen) wrote :

This bug only affected me when I used the pre-release repository. To recover did an apt-get dist-upgrade from bash and blindly followed apt's suggestions. As I recall I had to force the install, which I hate doing, but it worked. On my other box I waited for the official release and , although the upgrade had some bugs it worked out OK.

Changed in update-manager:
importance: Undecided → High
Juan Carlos Torres (jucato) wrote :

Is anyone still experiencing this problem when upgrading from Feisty to Gutsy? If I remember correctly this has been resolved with later updates.

Marking this bug report as Incomplete while waiting for new information.

Changed in adept:
status: New → Incomplete
Jan Schnackenberg (yehaa) wrote :

The last upgrade I did was 25th november. Actually it was my father who
finally got the message that theres an upgrade available. He startet the
upgrade. Fortunately I saw what he was doing and kept an eye on the
upgrade-process. Because as with every other Kubuntu I upgraded, this
debconf-bug hit him, too.

I don't know if it's been fixed since, it's been a month. But I really
don't want to know how many people hosed their system when they got the
"upgrade available" message from adapt-upgrader.

santana (burlen) wrote :

I think it has been fixed, because of the three systems I upgraded only the first had a problem.

Mike Green (mikey-badpenguins) wrote :

I just did a couple of test upgrades in a VM and for the first time the kubuntu upgrade from feisty to gutsy worked. I guess the mystery shall remain but the problem may have gone away!

Jay Gindin (jayg) wrote :

I can say that the bug is **NOT** gone :-(

I hit it tonight... I guess besides adding this, there's probably not much more for me to add...

Alexander Vorobiev (jdwx2ev02) wrote :

I have just encountered this bug trying to upgrade to Gutsy. And I thought that by now it should be mature enough :(

At this point none of the recipes given above work, all I am getting is

dpkg --configure -a
Setting up debconf (1.5.14ubuntu1) ...
*** stack smashing detected ***: /usr/bin/perl terminated
dpkg: error processing debconf (--configure):
 subprocess post-installation script killed by signal (Segmentation fault)
Setting up dash (0.5.4-1ubuntu3) ...
*** stack smashing detected ***: /usr/bin/perl terminated
dpkg: error processing dash (--configure):

etc no matter how many times I try. Both apt-get and aptitude refuse to do anything and tell me to run 'dpkg --configure -a' first. I deleted the dpkg lock files as well.

To me it looks like a problem with upgrading of perl packages since debconf is written is perl and it is clear that perl process crashes with stack corruption. Since everything else depends on debconf the upgrade logic is stuck. Not very nice coming from something released months ago...

Alexander Vorobiev (jdwx2ev02) wrote :

Ok, I was right, it was a mismatch between perl and libraries it depends on. Here is what I did. (This is all for Kubuntu but as the upgrade manager died early in the process and I did everything from the command line I presume this applies to Ubuntu as well). First I thought maybe it installed new libc but not perl so I installed new perl packages manually from /var/cache/apt/archive. That did not help so I decided to reboot. After the reboot the X did not come up but I expected that. 'dpkg --configure debconf' still crashed. So here we have old libc6 and new perl (which behaves exactly like the old one) and the debconf script makes perl crash with corrupted stack. It follows that there is some other library required by perl that has been upgraded for Gutsy and which really requires new libc but wasn't configured to depend on the new libc.

I installed the new libc6 packages manually. Finally 'dpkg --configure debconf' worked!

I went on to do the usual loop of 'dpkg --configure -a', 'apt-get -f install' and 'apt-get dist-upgrade' ad nauseum untill it installed all the packages. At one point I had to manually install acpid because it refused to restart it from the apt-get process.

I rebooted and got kernel panic and missing /dev/null. I unplugged the machine and booted it up again. Finally I have working Kubuntu 7.10.

So it all comes down to bad dependencies wich is really sad - both perl and libc are such a fundamental parts of the system that one would think they should have been tested to death.

Andrew Burns (home-a-burns) wrote :

Just to confirm that this bug is still cropping up (end of March 2008!). I am currently doing the apt-get dist-upgrade and will report on results.

James (james-ellis-gmail) wrote :

Sort of confirming what Rob_H said earlier - https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/147429/comments/42, I've been burnt by this twice now Edgy->Feisty, Feisty->Gutsy, for Gutsy to Hardy I won't be bothering with adept as I feel more secure using aptitude that I won't get a broken system.

this bug has still not been resolved. sorry for venting frustration, but this is a very unpleasant bug for which it is hard to find a solution. and upgrading was supposed to be easy.

Jonathan Thomas (echidnaman) wrote :

Adept doesn't do anything in the upgrade other than show the release announcement and launch update-manager-kde, which is in the update-manager source package, which is already marked as affecting this bug.

Changed in adept:
status: Incomplete → Invalid

I haven't noticed this debconf upgrade issue in Intrepid or Jaunty. Can this be confirmed whether this is a problem in a supported release, i.e. Hardy onwards? Thank you.

Changed in debconf (Ubuntu):
status: New → Incomplete

In one upgrade I did from 8.04 to 8.10 I did not encounter any issues.
However, without understanding why or what caused this, I cannot say whether
or not that one upgrade was a comparable test...it was on a different box
than when I saw the original issue.

jay

On Wed, Oct 14, 2009 at 3:54 PM, Teej <email address hidden> wrote:

> I haven't noticed this debconf upgrade issue in Intrepid or Jaunty. Can
> this be confirmed whether this is a problem in a supported release, i.e.
> Hardy onwards? Thank you.
>
> ** Changed in: debconf (Ubuntu)
> Status: New => Incomplete
>
> --
> Could not install 'debconf' during System upgrade 7.04 to 7.10
> https://bugs.launchpad.net/bugs/147429
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

--
"Never be afraid to try something new.
 Remember, amateurs built the ark.
 Professionals built the Titanic."
   - Found on the label of Honest Tea

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in update-manager (Ubuntu):
importance: High → Undecided
status: Incomplete → Invalid
Changed in debconf (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers