Ubuntu

Realtek Card Reader RTL8411 Device 5289 (PCI 03:00.0) Driver and udisks Rule

Reported by Carl Richell on 2012-04-02
156
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
High
Adam Lee
udisks (Ubuntu)
Medium
Martin Pitt

Bug Description

We have been provided with a new Realtek Card Reader driver for this device. The code is GPL licensed but we don't see it publicly available yet. This is a new driver module with the name "rts_bpp". As such a new udisks rule is necessary for automounting.

New driver is attached "rts_bpp.tar.bz2".

For automount, the following line needs to be added to '/lib/udev/rules.d/80-udisks.rules'

DRIVERS=="rts_bpp", ENV{ID_DRIVE_FLASH_SD}="1"

#########################

We created a DKMS module .deb to make install easier until the driver can be included in Ubuntu. Commands:

wget http://planet76.com/drivers/realtek/rts-bpp-dkms_1.1_all.deb
sudo apt-get install dkms
sudo dpkg -i rts-bpp-dkms_1.1_all.deb
echo 'DRIVERS=="rts_bpp", ENV{ID_DRIVE_FLASH_SD}="1"' | sudo tee -a /lib/udev/rules.d/81-udisks-realtek.rules

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: udisks 1.0.4-5ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
Date: Mon Apr 2 14:16:29 2012
HotplugNewDevices: /dev/sdb1
HotplugNewMounts: /dev/sdb1 /media/6331-6363 vfat rw,nosuid,nodev,relatime,uid=29999,gid=29999,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro 0 0
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: CLEVO CO. W240EU/W250EUQ/W270EUQ
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic root=UUID=596df159-fc9a-41b4-8528-5dca5215dbd5 ro quiet splash vt.handoff=7
SourcePackage: udisks
Symptom: storage
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/24/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: W240EU/W250EUQ/W270EUQ
dmi.board.vendor: CLEVO CO.
dmi.board.version: V3.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd02/24/2012:svnCLEVOCO.:pnW240EU/W250EUQ/W270EUQ:pvrNotApplicable:rvnCLEVOCO.:rnW240EU/W250EUQ/W270EUQ:rvrV3.0:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: W240EU/W250EUQ/W270EUQ
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO CO.

Related branches

Carl Richell (carlrichell) wrote :
Martin Pitt (pitti) wrote :
Changed in udisks (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.4-5ubuntu2

---------------
udisks (1.0.4-5ubuntu2) precise; urgency=low

  * Merge with Debian packaging git. Remaining Ubuntu changes:
    - debian/control: Change the "cryptsetup" suggests to a "cryptsetup-bin"
      recommends, so that LUKS functionality works by default. This change
      needs to be kept in Ubuntu until the cryptsetup package split goes into
      Debian as well. (LP: #343363)

udisks (1.0.4-6) UNRELEASED; urgency=low

  * debian/tests/control: Add mtools dependency for VFAT test. (LP: #976269)
  * debian/tests/control: Add policykit-1 dependency. (LP: #976266)
  * Add 00git_rts_bpp_sdcard.patch: Mark rts_bpp devices as SD card readers.
    Patch also committed upstream. (LP: #971876)
 -- Martin Pitt <email address hidden> Tue, 13 Mar 2012 09:57:01 +0100

Changed in udisks (Ubuntu):
status: Fix Committed → Fix Released
Colin Law (colin-law) wrote :

I have a Clevo laptop (W240EU/W250EUQ/W270EUQ) that appears to have this Realtec card reader. but the reader does not work, cards are not recognised at all, dmesg does not show anything when a card is inserted.
lspci reports:

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
 Subsystem: CLEVO/KAPOK Computer Device 0240
 Flags: bus master, fast devsel, latency 0, IRQ 11
 Memory at f7c00000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [b0] MSI-X: Enable- Count=1 Masked-
 Capabilities: [d0] Vital Product Data
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Virtual Channel
 Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00

Since this bug is marked Fix Released does that mean it should just work?
I am running Quantal Alpha and udisks is version 1.0.4-6
I have tried it with mainline kernel 3.6.0-030600rc2-generic #201208161835 32 bit, to no avail.

Colin Law (colin-law) wrote :

Should this bug be marked as also affecting the kernel (or something else) in order to get the driver itself included? Or am I missing something?

Jonathan Bishop (jtkbishop) wrote :

Same as comment #4. This seems to still be a problem. I tried the solution listed above but that hasn't worked either.

'm running the following:

udisks 1.0.4-5ubuntu2.1
3.2.0-29-generic x86_64

02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)
 Subsystem: Lenovo Device 5000
 Flags: bus master, fast devsel, latency 0, IRQ 11
 Memory at e4200000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Device Serial Number 00-00-00-01-00-4c-e0-00

Colin Law (colin-law) wrote :

@Jonathan I notice that yours is a 5229 whereas this bug is about 5289. Perhaps bug #1022497

Colin Law (colin-law) wrote :

I don't know whether this is the right thing to do, apologies if not. I am adding the kernel as an affected project as it seems the driver needs to be included somewhere in addition to the udisks changes.

tags: added: blocks-hwcert-enablement
Vylaern (vylaern) wrote : rts_bpp

Hi Colin

I realized that rts_bpp doesn't work with a new kernel 3.6.0 and 3.6.1, I
did report bugs.
Try 3.5.4 and yours cards reader should works fine.

regards
Vylaern

Colin Law (colin-law) wrote :

Hi Vylaern

I don't fully understand. I am running Quantal which is kernel 3.5.0-17 at the moment. In order to get the reader to work I did not have to do

echo 'DRIVERS=="rts_bpp", ENV{ID_DRIVE_FLASH_SD}="1"' | sudo tee -a /lib/udev/rules.d/81-udisks-realtek.rules

as described in the but description, but I did have to do

wget http://planet76.com/drivers/realtek/rts-bpp-dkms_1.1_all.deb
sudo apt-get install dkms
sudo dpkg -i rts-bpp-dkms_1.1_all.deb

so I feel the bug is not fixed (in ubuntu quantal). However I admit I do not understand exactly how all this works so am happy to be corrected if necessary.

Or are you saying the the driver /is/ included in kernel 3.5.4 and so will be fixed in ubuntu when it starts using that kernel?

Vylaern (vylaern) wrote :

Sorry, I have thought you are using 3.6.0
> I have tried it with mainline kernel 3.6.0-030600rc2-generic
#201208161835 32
bit, to no avail.

Try compile this manually, as a root or by sudo

wget
https://bugs.launchpad.net/bugs/971876/+attachment/2991730/+files/rts_bpp.tar.bz2tar
jxf rts_bpp.tar.bz2 cd rts_bpp make make install
 depmod
reboot

If after reboot your card reader still doesn't work, please copy what you
have after make install - eg:
# make install
 cp rts_bpp.ko /lib/modules/3.3.5-gentoo/kernel/drivers/scsi -f

Colin Law (colin-law) wrote :

Vylaern, yes I did try it with that kernel (I had forgotten that when I posted comment #10) in case it had already been sorted, but then reverted to the standard Quantal kernel. As I said above my reader is now working as I have installed the driver manually via

wget http://planet76.com/drivers/realtek/rts-bpp-dkms_1.1_all.deb
sudo apt-get install dkms
sudo dpkg -i rts-bpp-dkms_1.1_all.deb

What I don't understand is whether the driver should be automatically included in the kernel at some point, hence why I added Linux to the packages affected.

Raman Monorath (ramanmono) wrote :

cant install it with the current quantal kernel (3.5.0-18) on 64bit asus k55a.
with the deb file the dkms module is added but cant be installed:

First Installation: checking all kernels...
Building for 3.5.0-17-generic and 3.5.0-18-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed

so what do i need to build the module for this kernel??

bwat47 (bwat47) wrote :

@Raman, I was able to install it fine in a fresh install of mint 14 (based on ubuntu quantal and using the same kernel), and it installed fine here. Make sure you have the kernel headers installed, afiak thats all you should need.

Bruno Medeiros (brunojcm) wrote :

I'm using precise and rts-bpp-dkms_1.1_all.deb worked perfectly for me. I'm using the quantal kernel after install following packages:

linux-headers-generic-lts-quantal
linux-image-generic-lts-quantal
linux-generic-lts-quantal

Bruno Medeiros (brunojcm) wrote :

I also needed to load the module:
sudo modprobe rts-bpp

with
lspci
using mint14 64 on a new laptop whose card reader did not appear

and seeing
 ~ $ lspci

04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)

I downloaded
http://planet76.com/drivers/realtek/rts-bpp-dkms_1.1_all.deb
double-cliked it to install

then
sudo pluma /lib/udev/rules.d/80-udisks.rules

to add the line
DRIVERS=="rts_bpp", ENV{ID_DRIVE_FLASH_SD}="1"

and restart

the card-reader is active

I'm using Ubuntu 12.04 (3.2.0-36-generic-pae) on ASUS K55A, SD Card reader was the only hadware that does not work from the box.
Using rts_bpp module as described fixed the situation. Thanks a lot to the author.

Ekimia (u-contact-ekimia-fr) wrote :

We have a lot of probleme with rts_bpp 1.1 , any body had any updates from realtek ?

try to insert a Sony Memory stick and you'll get a kernel panic.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → Adam Lee (adam8157)
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: blocks-hwcert
szbab (szbab-club) wrote :

I tested the 13.04 alpha card reader works natively

sorry for my english

Colin Law (colin-law) wrote :

I can confirm that for me the reader is now working out of the box on 13.04 alpha.

Anthony Wong (anthonywong) wrote :

Change status to Fix Released according to 2 independent reports.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Dmitriy Kodanev (dkodanev) wrote :

I made all this steps as described above with Ubuntu 12.10 - no luck. So yesterday I've upgraded from 12.10 upto 13.04 beta. Unfortunately cardreader still doesn't work. In Windows 7 (I have dualboot) it works like a charm. Why doesn't it work in Ubuntu when people say it works natively in 13.04 alpha? How can I fix it?

Colin Law (colin-law) wrote :

Launchpad is not the place to ask for support. If it is still not working for you then you have a different problem. You could ask for help on the ubuntu-users mailing list.

Dmitriy Kodanev (dkodanev) wrote :

Maybe you understand me wrong but it isn't me who need support now. It's Ubuntu itself. Soon it'll be release of Raring and I think this release needs to be something stable and affordable for users. So it's me who give support to developers when I report a bug. I want to say that it is not so alright with this bug and it is probably not fixed.
So I'm opening new bug report: https://bugs.launchpad.net/bugs/1165324
Maybe it is dublicate but there you can see my logs and may say what I'm doing wrong. Thanks.

I must agree with Dmitriy. I have the exact same card reader (according to lspci) in my Clevo P150EM, and it does not work.

I did a fresh install of 13.04 just two days ago, and it's fully patched. The rule for rts_bpp is there, but the card reader is not working at all.

John (jm1) wrote :

The solution in #10 worked for a while ... and then stopped working.

It worked in 3.5.0-17-generic, but when I updated to 3.5.0-27-generic (with sudo apt-get dist-upgrade), it stopped working - even when I reinstalled rts-bpp-dkms_1.1_all.deb and rebooted it still didn't work.

I then rebooted into 3.5.0-17-generic, reinstalled rts-bpp-dkms_1.1_all.deb and now it works - in 3.5.0-17-generic AND when I boot into 3.5.0-27-generic

So if it doesn't work for you, try rebooting into an old version of the kernel, reinstall rts-bpp-dkms_1.1_all.deb, and then reboot into your updated kernel. Maybe it will fix your problem too.

hawezet@t-online.de (hawezet) wrote :

Hello,well in my PC doesnt work the sd-card.
Have tryed : wget http://planet76.com/drivers/realtek/rts-bpp-dkms_1.1_all.deb
sudo apt-get install dkms
sudo dpkg -i rts-bpp-dkms_1.1_all.deb
the answer:DKMS: ldtarball completed.

Creating symlink /var/lib/dkms/rts_bpp/1.1/source ->
                 /usr/src/rts_bpp-1.1

DKMS: add completed.
First Installation: checking all kernels...
Building only for 3.8.0-19-generic
Building for architecture x86_64
Building initial module for 3.8.0-19-generic
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms_packages.py", line 22, in <module>
    import apport
ImportError: No module named apport
Error! Bad return status for module build on kernel: 3.8.0-19-generic (x86_64)
Consult /var/lib/dkms/rts_bpp/1.1/build/make.log for more information.
here the make.log:DKMS make.log for rts_bpp-1.1 for kernel 3.8.0-19-generic (x86_64)
Sa 27. Apr 07:44:46 CEST 2013
make: Gehe in Verzeichnis '/usr/src/linux-headers-3.8.0-19-generic'
  CC [M] /var/lib/dkms/rts_bpp/1.1/build/src/rtsx.o
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:893:22: Fehler: expected »=«, »,«, »;«, »asm« or »__attribute__« before »rtsx_probe«
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1048:23: Fehler: expected »=«, »,«, »;«, »asm« or »__attribute__« before »rtsx_remove«
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1073:11: Fehler: »rtsx_probe« ist hier nicht deklariert (nicht in einer Funktion)
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1074:2: Fehler: Implizite Deklaration der Funktion »__devexit_p« [-Werror=implicit-function-declaration]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1074:24: Fehler: »rtsx_remove« ist hier nicht deklariert (nicht in einer Funktion)
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:255:34: Warnung: »rtsx_host_template« definiert, aber nicht verwendet [-Wunused-variable]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:450:12: Warnung: »rtsx_control_thread« definiert, aber nicht verwendet [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:559:12: Warnung: »rtsx_polling_thread« definiert, aber nicht verwendet [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:715:13: Warnung: »quiesce_and_remove_host« definiert, aber nicht verwendet [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:751:13: Warnung: »release_everything« definiert, aber nicht verwendet [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:761:12: Warnung: »rtsx_scan_thread« definiert, aber nicht verwendet [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:786:13: Warnung: »rtsx_init_options« definiert, aber nicht verwendet [-Wunused-function]
cc1: Einige Warnungen werden als Fehler behandelt
make[1]: *** [/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.o] Fehler 1
make: *** [rts_bpp.ko] Fehler 2
make: Verlasse Verzeichnis '/usr/src/linux-headers-3.8.0-19-generic'
...
can you help ???
thanks
Hans-Werner

Alexandrosg (alexandrosg) wrote :

The suggested fixe worked fine in Quantal, however after upgrading to Raring this is broken again, and as hawezet posted you cannot build the module anymore.

Alexandrosg (alexandrosg) wrote :

Apparently others also have a problem with the driver included in the new kernel, see https://bugzilla.kernel.org/show_bug.cgi?id=57061

Str3tLeer (str3tleer) wrote :

I have a System76 Gazelle system and I upgraded from 12.04 to 12.10 and then to 13.04. I get this error regarding rts-bpp-dkms so I tried the planet76.com fix but this is what I get:

Building initial module for 3.8.0-23-generic
Error! Bad return status for module build on kernel: 3.8.0-23-generic (x86_64)
Consult /var/lib/dkms/rts_bpp/1.1/build/make.log for more information.

Then I opened the make.log and this is inside:

DKMS make.log for rts_bpp-1.1 for kernel 3.8.0-23-generic (x86_64)
Fri May 31 11:58:22 EDT 2013
make: Entering directory `/usr/src/linux-headers-3.8.0-23-generic'
  CC [M] /var/lib/dkms/rts_bpp/1.1/build/src/rtsx.o
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:893:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtsx_probe’
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1048:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtsx_remove’
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1073:11: error: ‘rtsx_probe’ undeclared here (not in a function)
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1074:2: error: implicit declaration of function ‘__devexit_p’ [-Werror=implicit-function-dec$
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:1074:24: error: ‘rtsx_remove’ undeclared here (not in a function)
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:255:34: warning: ‘rtsx_host_template’ defined but not used [-Wunused-variable]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:450:12: warning: ‘rtsx_control_thread’ defined but not used [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:559:12: warning: ‘rtsx_polling_thread’ defined but not used [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:715:13: warning: ‘quiesce_and_remove_host’ defined but not used [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:751:13: warning: ‘release_everything’ defined but not used [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:761:12: warning: ‘rtsx_scan_thread’ defined but not used [-Wunused-function]
/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.c:786:13: warning: ‘rtsx_init_options’ defined but not used [-Wunused-function]
cc1: some warnings being treated as errors
make[1]: *** [/var/lib/dkms/rts_bpp/1.1/build/src/rtsx.o] Error 1
make: *** [rts_bpp.ko] Error 2
make: Leaving directory `/usr/src/linux-headers-3.8.0-23-generic'

I hope this helps troubleshoot the problem.

Bruno Medeiros (brunojcm) wrote :

Same problem here, rts-bpp-dkms doesn't build anymore on Linux 3.8.

Bruno Medeiros (brunojcm) wrote :

Same problem here, rts-bpp-dkms doesn't build anymore on Linux 3.8. Thought, the new driver built-in Linux 3.8, rtsx, do work for me!

Peter Funk (pf-artcom-gmbh) wrote :

I've one Samsung SDHC 8GB card that works, but most SD and SDHC card I own don't.
Messages in syslog are:
> kernel: [ ... ] mmc0: error -110 whilst initialising SD card
with some and
> kernel: [ ... ] mmcblk0: error -110 sending status command, retrying
> kernel: [ ... ] Buffer I/O error on device mmcblk0, logical block 0
with some other cards.
All these SD cards work in my old HP nw9440 laptop with Ubuntu 10.04
and within the laptop of my daughter.

The laptop (with the clevo board) contains according to lspci a
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
card reader chip. I've tried Ubuntu Linux raring kernel version 3.8.0-21-generic, 3.8.0-24-generic
and 3.8.0-25-generic (x86_64): No change in behaviour.

Best regards, Peter.

Ethan Hogue (clappboard) wrote :

I can't build the package, either on Linux 3.8.0-25-generic. This bug is very irritating, I don't have an external SD card reader, and need photos off my card. I can't find ANY fix out there for this on Ubuntu 13.04. Downgrading is not an option, as when I downgrade other things on my laptop don't work right.
[code]lspci
...
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
...[\code]
As far as I know, this should not be marked as fix released.

Giuseppe Cardone (ippatsuman) wrote :

The driver does not compile anymore because __devinit/__devexit macros have been deprecated in Linux 3.8 (see https://patchwork.kernel.org/patch/1766601/ ). Redefining __devinit, __devexit and __devexit_p as empty macros fixes the code, that can be successfully compiled and installed on Linux 3.8. I attached a patch that fixes the driver compilation.

Tested on Linux 3.8.0-25-generic x64.

Stéphane Alnet (stephane-2) wrote :

As a sidenote the Makefile in rts_bpp.tar.bz2 incorrectly does

    install:
     cp $(TARGET_MODULE).ko /lib/modules/$(shell uname -r)/kernel/drivers/scsi -f

where it should do

    install:
     cp $(TARGET_MODULE).ko /lib/modules/$(shell uname -r)/kernel/drivers/scsi -f

This looks like a typo, the other `cp` commands look just fine.

Stéphane Alnet (stephane-2) wrote :

Duh.

It should do:

    install:
     cp -f $(TARGET_MODULE).ko /lib/modules/$(shell uname -r)/kernel/drivers/scsi

tobiasBora (tobias-bora) wrote :

This solution given here : https://bbs.archlinux.org/viewtopic.php?pid=1263089#p1263089 works perfecly :

1. Download rts_bpp.tar.bz2 from launchpad (I tried with this one : https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/971876/+attachment/2991730/+files/rts_bpp.tar.bz2)
2. Extract archive, edit rtsx.c:
2.1. Remove __devinit from rtsx_probe in line 893
2.2. Remove __devexit from rtsx_remove in line 1048
2.3. Extract rtsx_remove from __devexit_p() in line 1074
3. Compile with "make"
4. As root, make install
5. Blacklist rtsx_pci in /etc/modprobe.d/rtsx_blacklist.conf (add "blacklist rtsx_pci")
6. 'modprobe rts_bpp'
7. run mkinitcpio -p linux (I'm not entirely sure this is necessary, but I run it, so I'm including it here).
8. Restart the machine
9. You're good to go.

tobiasBora (tobias-bora) wrote :

I forgot to remove the 7) which is useless (and which was for ArchLinux).

tobiasBora (tobias-bora) wrote :

( Tested with the Kernel 3.5.0-37-generic)

Dmitriy Kodanev (dkodanev) wrote :

tobiasBora, it didn't work for me.
I use Xubuntu 13.04 x64.
My errors are in Russian but maybe you could understand. So what I have when I do 'make' (step 3 from your instruction):

dima@ASUS-K55VD:~/install/rts_bpp$ make
cp -f ./define.release ./define.h
make -C /lib/modules/3.8.0-27-generic/build/ SUBDIRS=/home/dima/install/rts_bpp modules
make[1]: Вход в каталог `/usr/src/linux-headers-3.8.0-27-generic'
  CC [M] /home/dima/install/rts_bpp/rtsx.o
/home/dima/install/rts_bpp/rtsx.c:1074:2: ошибка: неявная декларация функции «__devexit_p» [-Werror=implicit-function-declaration]
/home/dima/install/rts_bpp/rtsx.c:1074:2: ошибка: элемент инициализатора не является константой
/home/dima/install/rts_bpp/rtsx.c:1074:2: ошибка: (где-то рядом с инициализацией для «driver.remove»)
/home/dima/install/rts_bpp/rtsx.c:1048:13: предупреждение: «rtsx_remove» определена, но нигде не используется [-Wunused-function]
cc1: некоторые предупреждения рассматриваются как ошибки
make[2]: *** [/home/dima/install/rts_bpp/rtsx.o] Ошибка 1
make[1]: *** [_module_/home/dima/install/rts_bpp] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-headers-3.8.0-27-generic'
make: *** [default] Ошибка 2

Then I tried sudo make:

dima@ASUS-K55VD:~/install/rts_bpp$ sudo make
[sudo] password for dima:
cp -f ./define.release ./define.h
make -C /lib/modules/3.8.0-27-generic/build/ SUBDIRS= modules
make[1]: Вход в каталог `/usr/src/linux-headers-3.8.0-27-generic'
make[2]: *** Нет правила для сборки цели `/usr/src/linux-headers-3.8.0-27-generic/arch/x86/syscalls/syscall_32.tbl', требуемой для `arch/x86/syscalls/../include/generated/uapi/asm/unistd_32.h'. Останов.
make[1]: *** [archheaders] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-headers-3.8.0-27-generic'
make: *** [default] Ошибка 2

Well, this bug not so long ago have stopped bothering me, 'cos I bought external card reader, and now it's alright with SD cards. But nevertheless it's a pity I can't use internal laptop cardreader in Linux.

Dmitriy Kodanev (dkodanev) wrote :

With new kernel 3.8.0-29-generic my laptop's cardreader now works!
I can see now 'rts8139.ko' file in directory 'kernel/drivers/staging/rts8139'.
Maybe it is the driver I've been needing so long?
I've inserted my SDHC card in the internal cardreader, and dmesg shows:
[34634.137349] mmc0: new high speed SDHC card at address b368
[34634.138406] mmcblk0: mmc0:b368 SD16G 14.7 GiB
[34634.140815] mmcblk0: p1

also with 3.8.0-19

mmc0: new SD card at address 0001
mmcblk0: mmc0:0001 SDMMC 976 MiB
mmcblk0: p1

rob (rwmster) wrote :

Thank you guys
This fix worked brilliantly on my ASUS X550CC running Kubuntu 12.04

exzemat (exzemat) wrote :

hello guy
fix no works on ubuntu 13.10
(the log is in french sorry)
mat@mat-W310CZ:~/Téléchargements/t$ make
cp -f ./define.release ./define.h
make -C /lib/modules/3.11.0-13-generic/build/ SUBDIRS=/home/mat/Téléchargements/t modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.11.0-13-generic »
  CC [M] /home/mat/Téléchargements/t/rtsx.o
/home/mat/Téléchargements/t/rtsx.c:259:2: error: unknown field ‘proc_info’ specified in initializer
  .proc_info = proc_info,
  ^
/home/mat/Téléchargements/t/rtsx.c:259:2: warning: initialization from incompatible pointer type [enabled by default]
/home/mat/Téléchargements/t/rtsx.c:259:2: warning: (near initialization for ‘rtsx_host_template.proc_dir’) [enabled by default]
/home/mat/Téléchargements/t/rtsx.c:1073:11: error: ‘rtsx_probe’ undeclared here (not in a function)
  .probe = rtsx_probe,
           ^
/home/mat/Téléchargements/t/rtsx.c:893:12: warning: ‘__devinitrtsx_probe’ defined but not used [-Wunused-function]
 static int __devinitrtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
            ^
make[2]: *** [/home/mat/Téléchargements/t/rtsx.o] Erreur 1
make[1]: *** [_module_/home/mat/Téléchargements/t] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-3.11.0-13-generic »
make: *** [default] Erreur 2

i installed build-essential, fakeroot, dkms and system is up to date.

I think keep ubuntu 13.10 one or two weeks, after I will reinstall ubuntu 12.04 (LTS) where the fix work (I will use sd card for chrismas time).
say me if you want that I test something
buy

exzemat (exzemat) wrote :

I forget to specify that the log above is the result of the solution proposed in post #41

Colin Law (colin-law) wrote :

This bug has been fixed, the 13.10 kernel should support this device without a workaround. Anyone still seeing a problem should report a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.