do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system without any warning (This kernel does not support a non-PAE CPU)

Bug #1160346 reported by Chris Bainbridge
698
This bug affects 113 people
Affects Status Importance Assigned to Milestone
Release Upgrader
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Invalid
Critical
Unassigned
ubuntu-release-upgrader (Ubuntu)
Fix Released
Critical
Brian Murray

Bug Description

Attempting to upgrade from Precise with a non-PAE kernel will result in a failed upgrade. do-release-upgrade should check whether the user is using a non-PAE kernel and refuse to run, rather than upgrading to a broken system with no installed kernel.

After downloading 1.5GB+ of data and over 1000 new packages, the upgrade will eventually report failure. Looking through the logs there is no kernel installed because of the error "This kernel does not support a non-PAE CPU.":

Selecting previously unselected package linux-image-3.5.0-26-generic.^M
Unpacking linux-image-3.5.0-26-generic (from .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
This kernel does not support a non-PAE CPU.^M
dpkg: error processing /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb (--unpack):^M
 subprocess new pre-installation script returned error exit status 1^M
No apport report written because MaxReports is reached already

Related bugs:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is dropping non-PAE flavour
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade from 12.04 to 12.10 on a sans-pae CPU leaves kernel broken

Related branches

summary: - do-release-upgrade upgrade from Precise > Raring fails : This kernel
+ do-release-upgrade upgrade from Precise > Quantal fails : This kernel
does not support a non-PAE CPU.
Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote : Re: do-release-upgrade upgrade from Precise fails : This kernel does not support a non-PAE CPU.

Also related:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/930447 Unable to start Ubuntu 12.04 live CD with syslinux loader on Pentium M x86 Laptop due to bug in PAE kernel, initramfs or syslinux

summary: - do-release-upgrade upgrade from Precise > Quantal fails : This kernel
- does not support a non-PAE CPU.
+ do-release-upgrade upgrade from Precise fails : This kernel does not
+ support a non-PAE CPU.
Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

For anyone who thinks this isn't a problem for normal users:

"I mistakenly upgraded to 12.10 in my t42 without realizing the pae/non-pae kernel conflict. now my system is kind of broken. i can not install you .dep package because the package manager breaks when loading. anything i do with apt-get update etc give me 'this kernel does not support non-pae' errors." - http://ubuntuforums.org/showthread.php?t=2113826&p=12545335#post12545335

"This worked perfectly for me on an old Toshiba with a Pentium M processor. I had also mistakenly upgraded to 12.10 before installing the fake-pae package." - http://ubuntuforums.org/showthread.php?t=2113826&p=12551097#post12551097

tags: added: dist-upgrade i386 precise raring
tags: added: quantal
removed: raring
summary: - do-release-upgrade upgrade from Precise fails : This kernel does not
- support a non-PAE CPU.
+ do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
+ without any warning
Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1160346

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote : Re: do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system without any warning

Confirming. This is a known issue, I have seen at least 4 reports from different Pentium M laptop users that their systems got broken when attempting an update from 12.04.

I have read the Ubuntu kernel irc meeting logs regarding this issue, and it seems that although it was noted at the time that upgrades would break and that something should be done about it, nothing actually was.

summary: do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
- without any warning
+ without any warning (This kernel does not support a non-PAE CPU)
Revision history for this message
Brian Murray (brian-murray) wrote :

The release upgrader for upgrades from P to Q is actually in a package called ubuntu-release-upgrader.

Changed in update-manager (Ubuntu):
status: New → Triaged
importance: Undecided → High
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Revision history for this message
Brian Murray (brian-murray) wrote :

This should be handled in DistUpgradeQuirks.py.

Steve Langasek (vorlon)
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Revision history for this message
Brad Figg (brad-figg) wrote :

This is not a kernel issue.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

I'm attaching a patch for DistUpgradeQuirks.py that aborts the upgrade if the pae flag is not in /proc/cpuinfo (the same check as used by the kernel package on install). It would be a good idea to release this fix before the 14.04 LTS is released in order to save thousands of people from ending up with a broken system when they try to upgrade from 12.04 LTS to 14.04 LTS

tags: added: patch
tags: removed: quantal
tags: added: pae
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "update_manager_quirks_pae.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Changed in ubuntu-release-upgrader (Ubuntu):
milestone: none → ubuntu-14.04-beta-2
Changed in linux (Ubuntu):
milestone: none → ubuntu-14.04-beta-2
importance: Undecided → Critical
Changed in ubuntu-release-upgrader (Ubuntu):
importance: High → Critical
Steve Langasek (vorlon)
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: Steve Langasek (vorlon) → Brian Murray (brian-murray)
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

As seen in <https://wiki.ubuntu.com/Bugs/Bug%20statuses>:

"Never assign bugs to others"

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: Brian Murray (brian-murray) → nobody
Revision history for this message
Steve Langasek (vorlon) wrote :

Thanks for respecting the Ubuntu bug management guidelines, but as Brian's manager, I get to assign bugs to him ;)

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Jajaja, ok :D

Revision history for this message
Brian Murray (brian-murray) wrote :

Chris, thanks for working on this. The code in the patch itself looks good but I think the error message for the user could be more informative regarding the corrective action necessary. Pointing at https://help.ubuntu.com/community/EnablingPAE would be one solution or including some text from there in the message. Do you want to work on this? If not I'll get the message updated. Thanks again!

Revision history for this message
sudodus (nio-wiklund) wrote :

... and the text in https://help.ubuntu.com/community/EnablingPAE will need updating too, and there are volunteers that can do that (for example I can do it, unless someone has 'adopted' that wiki page and wants to do it).

Revision history for this message
JohnWashington (ubuntu-johnwash) wrote :

Re #10 and #11, it gave me a chuckle! :) But actually there's something serious here as well. Not just that the wiki would seem to be not quite right, but also that some well-understood convention is needed, for use when one person justifiably assigns a bug to another.

Indeed, even assigning a bug to oneself needs looking at. A while ago, a bug I'm interested in, which had no assignee, a guy assigned to himself. Of course I was pleased, hope of light at the end of the tunnel! A month went by. And then it was assigned back to nobody. In fact, this guy, who had no track record, had assigned himself on 3 other bugs, same story.

So more than a month was wasted, when someone productive could have stepped forward.

PS: Great to see this Pentium-M stuff getting some love at last. I know that many devs with screaming fast i7 kit think it's a non-issue, too old to worry about, affects a tiny minority. But I've encountered a number of people tempted to dip their toe in the water, try out Linux for the first time and run away at the first hint of trouble, due to Pentium-M on old Thinkpads. They're certainly not signing up to Launchpad to be counted. I've even seen where a mag has published a book about Ubuntu and put a 64-bit CD on the cover -- the punter had no idea why it didn't work, same outcome, disgust and back to the arms of Redmond.

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

People mistakenly assign bugs to themselves all of the time. I really doubt better documentation would help in most of those cases...

Personally, I wouldn't mind seeing the 'Assigned to' field go away completely or have write access limited.

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 1160346] Re: do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system without any warning (This kernel does not support a non-PAE CPU)

> Not just that the wiki would seem to be not quite right, but also that
> some well-understood convention is needed, for use when one person
> justifiably assigns a bug to another.

The convention is already well understood among Ubuntu developers...

> So more than a month was wasted, when someone productive could have
> stepped forward.

That's not really anything that can be solved by policy or by technical
means. And frankly, if this went unnoticed for a month, it's not likely
that someone was going to step up to work on it during that period anyway.

> PS: Great to see this Pentium-M stuff getting some love at last. I know
> that many devs with screaming fast i7 kit think it's a non-issue, too
> old to worry about, affects a tiny minority.

Just to be clear, nothing we're doing here is going to change the
compatibility of Ubuntu 14.04 with non-PAE systems; only to stop users from
upgrading and accidentally winding up with a broken system post-upgrade.

Revision history for this message
Fscalc (fscalc) wrote :
Download full text (4.2 KiB)

Folks,

It probably isn't appropriate for me to jump in here as I am not a
developer or part of the team that squashes the bugs. I am just one of the
people who filed the bug report, but what John Washington wrote struck me.

I am a person who tries to be an advocate for Linux, Ubuntu in particular.
One of the most compelling messages I've had is that older notebooks can be
reborn as capable boxes. When I show someone their old ThinkPad running a
stable, easy-to-use, secure OS with a modern browser, I've won more than a
few converts.

What Mr. Washington said about all those great old ThinkPads that can stand
as persuasive examples of what is possible is so true. The Pentium M issue
is a roadblock.

I don't wish to distract from the process, so I will just say, "Thank you."
The work you folks do is important and is very much appreciated.

Best wishes,

- F. Stephen Costa.

On Tue, Mar 4, 2014 at 6:31 PM, JohnWashington <email address hidden>wrote:

> Re #10 and #11, it gave me a chuckle! :) But actually there's something
> serious here as well. Not just that the wiki would seem to be not quite
> right, but also that some well-understood convention is needed, for use
> when one person justifiably assigns a bug to another.
>
> Indeed, even assigning a bug to oneself needs looking at. A while ago,
> a bug I'm interested in, which had no assignee, a guy assigned to
> himself. Of course I was pleased, hope of light at the end of the
> tunnel! A month went by. And then it was assigned back to nobody. In
> fact, this guy, who had no track record, had assigned himself on 3 other
> bugs, same story.
>
> So more than a month was wasted, when someone productive could have
> stepped forward.
>
> PS: Great to see this Pentium-M stuff getting some love at last. I know
> that many devs with screaming fast i7 kit think it's a non-issue, too
> old to worry about, affects a tiny minority. But I've encountered a
> number of people tempted to dip their toe in the water, try out Linux
> for the first time and run away at the first hint of trouble, due to
> Pentium-M on old Thinkpads. They're certainly not signing up to
> Launchpad to be counted. I've even seen where a mag has published a
> book about Ubuntu and put a 64-bit CD on the cover -- the punter had no
> idea why it didn't work, same outcome, disgust and back to the arms of
> Redmond.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1280638).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in Ubuntu Release Upgrader:
> New
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "ubuntu-release-upgrader" package in Ubuntu:
> Triaged
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new pack...

Read more...

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

New patch with better error text (including url).

Revision history for this message
sudodus (nio-wiklund) wrote :

What about the boot option 'forcepae'?

Is it still available, and possible to use in order to make Pentium M and Celeron M run a PAE kernel?

In that case, I think that it should be described in the wiki page that the error text is referring to

https://help.ubuntu.com/community/EnablingPAE

instead of (or at least alongside with) the reference to ugrading from 12.04 which is cumbersome and prone to failure.

And is the tip about 'forcepae' still there in the error output? It is quite brief but will help people with some experience understand how to make the computer work. Others may need a more verbose help text (that I think should be in the wiki page).

-o-

I saw that you, Brian Murray, edited the wiki page March 3, so I don't want 'hijack' the page, instead I discuss here, what it could and should contain.

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

sudodus, "forcepae" isn't in the mainline kernel yet so it's up to the Ubuntu Kernel team as to whether they add the patch to the kernel now and/or backport it to 12.04. For someone with Pentium M who wants to upgrade from 12.04 the easiest way would be to do the fakepae trick of mounting a modified version of /proc/cpuinfo that contains the pae flag over the original, and then do the upgrade. Instructions for that could be added to the wiki.

Revision history for this message
Frogman (jporubek) wrote :
Download full text (3.2 KiB)

Like F. Stephen Costa, I interject here with some trepidation. I'm a user,
not a developer, who was bitten by the PAE bug when trying to upgrade my
Pentium-M Thinkpad from 12.04. It was very painful getting back to a
working, stable 12.04 after the aborted upgrade attempt.

I love my Thinkpad. I purchased it new in 2004 and it's still going strong,
although with a different hard drive and more RAM. I've invested in two
docking stations for home and work. Linux has extended it's usefulness well
beyond what the WinXP it came with would have. So John Washington's words
resonated with me, too.

I had resigned myself to leaving the Ubuntu fold when the long term support
for 12.04 finally ends. I was excited to read about the "fakepae trick" and
would really appreciate seeing howto instructions added to the wiki. Maybe
I can stick with Ubuntu after all!

-John Porubek

On Wed, Mar 5, 2014 at 7:41 AM, Chris Bainbridge <<email address hidden>
> wrote:

> sudodus, "forcepae" isn't in the mainline kernel yet so it's up to the
> Ubuntu Kernel team as to whether they add the patch to the kernel now
> and/or backport it to 12.04. For someone with Pentium M who wants to
> upgrade from 12.04 the easiest way would be to do the fakepae trick of
> mounting a modified version of /proc/cpuinfo that contains the pae flag
> over the original, and then do the upgrade. Instructions for that could
> be added to the wiki.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1094481).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in Ubuntu Release Upgrader:
> New
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "ubuntu-release-upgrader" package in Ubuntu:
> Triaged
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new packages, the
> upgrade will eventually report failure. Looking through the logs there
> is no kernel installed because of the error "This kernel does not
> support a non-PAE CPU.":
>
> Selecting previously unselected package linux-image-3.5.0-26-generic.^M
> Unpacking linux-image-3.5.0-26-generic (from
> .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
> This kernel does not support a non-PAE CPU.^M
> dpkg: error processing
> /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb
> (--unpack):^M
> subprocess new pre-installation script returned error exit status 1^M
> No apport report written because MaxReports is reached already
>
> Related bugs:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is
> dropping non-PAE flavour
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade
> from 12.04 to 12.10 on a sans-pae CPU leaves kernel broken
>
> To man...

Read more...

Revision history for this message
Brian Murray (brian-murray) wrote :

Chris - thanks for updating your patch. I committed a variation of it to trunk and will upload a new version of the release upgrader shortly.

Revision history for this message
awol (awol99) wrote :

i put OpenSuSE on my thinkPad t42 - it works well.

On Thu, Mar 6, 2014 at 5:58 AM, Brian Murray <email address hidden> wrote:

> Chris - thanks for updating your patch. I committed a variation of it
> to trunk and will upload a new version of the release upgrader shortly.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1068862).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in Ubuntu Release Upgrader:
> New
> Status in “linux” package in Ubuntu:
> Invalid
> Status in “ubuntu-release-upgrader” package in Ubuntu:
> Triaged
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new packages, the
> upgrade will eventually report failure. Looking through the logs there
> is no kernel installed because of the error "This kernel does not
> support a non-PAE CPU.":
>
> Selecting previously unselected package linux-image-3.5.0-26-generic.^M
> Unpacking linux-image-3.5.0-26-generic (from
> .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
> This kernel does not support a non-PAE CPU.^M
> dpkg: error processing
> /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb
> (--unpack):^M
> subprocess new pre-installation script returned error exit status 1^M
> No apport report written because MaxReports is reached already
>
> Related bugs:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is
> dropping non-PAE flavour
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade
> from 12.04 to 12.10 on a sans-pae CPU leaves kernel broken
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu-release-upgrader/+bug/1160346/+subscriptions
>

--
Sent from my recycled old computer.
[:C≡N:]− , I ≤ 2πrEħc ln 2

Revision history for this message
sudodus (nio-wiklund) wrote :

@Frogman - fakePAE trick

Until the new patches in the main-stream code trickle down (maybe it stays in 14.04 LTS), I suggest that you try

Lubuntu-fake-pae according to this link

https://help.ubuntu.com/community/Lubuntu-fake-PAE

or if you want some other flavour of Ubuntu, you have a wide choice if you install from a tarball with the One Button Installer

https://help.ubuntu.com/community/OBI

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.214

---------------
ubuntu-release-upgrader (1:0.214) trusty; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: On 12.04 stop the upgrade process if the
    system does not support PAE. Thanks to Chris Bainbridge for the initial
    patch. (LP: #1160346)
 -- Brian Murray <email address hidden> Wed, 05 Mar 2014 12:53:48 -0800

Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Frogman (jporubek) wrote :

@sudodus

Thanks for the info re: fakePAE trick

On Wed, Mar 5, 2014 at 4:01 PM, sudodus <email address hidden> wrote:

> @Frogman - fakePAE trick
>
> Until the new patches in the main-stream code trickle down (maybe it
> stays in 14.04 LTS), I suggest that you try
>
> Lubuntu-fake-pae according to this link
>
> https://help.ubuntu.com/community/Lubuntu-fake-PAE
>
> or if you want some other flavour of Ubuntu, you have a wide choice if
> you install from a tarball with the One Button Installer
>
> https://help.ubuntu.com/community/OBI
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1094481).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in Ubuntu Release Upgrader:
> New
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "ubuntu-release-upgrader" package in Ubuntu:
> Triaged
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new packages, the
> upgrade will eventually report failure. Looking through the logs there
> is no kernel installed because of the error "This kernel does not
> support a non-PAE CPU.":
>
> Selecting previously unselected package linux-image-3.5.0-26-generic.^M
> Unpacking linux-image-3.5.0-26-generic (from
> .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
> This kernel does not support a non-PAE CPU.^M
> dpkg: error processing
> /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb
> (--unpack):^M
> subprocess new pre-installation script returned error exit status 1^M
> No apport report written because MaxReports is reached already
>
> Related bugs:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is
> dropping non-PAE flavour
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade
> from 12.04 to 12.10 on a sans-pae CPU leaves kernel broken
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu-release-upgrader/+bug/1160346/+subscriptions
>

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

I added some text about Pentium M to https://help.ubuntu.com/community/EnablingPAE . There is now some overlap with https://help.ubuntu.com/community/PAE - they pages could probably do with being merged and cleaned up.

Revision history for this message
Fscalc (fscalc) wrote :
Download full text (3.3 KiB)

Folks,

At the risk of sounding in inappropriately (again), I wanted to
reiterate that the bug report I filed was when I tried to update my
Pentium M ThinkPad from Ubuntu 12.04 to 12.04.3 / 12.04.4.

http://askubuntu.com/questions/336527/how-to-upgrade-ubuntu-12-04-2-12-04-3-to-12-04-4-the-next-hardware-enablement/417581#417581

http://www.omgubuntu.co.uk/2014/02/ubuntu-12-04-4-released-new-kernel

http://www.ubuntuask.com/q/answers-why-12-04-2-to-12-04-3-didnt-upgrade-kernel-3-5-3-8-and-or-xorg-368181.html

That was where I created unmet dependencies and hosed my upgrade
manager until I undid via the Synaptic Package Manager.

Neither in the read me nor on any of the above pages did I understand
that I should not do such an upgrade on a notebook with non-PAE
processor. Also, as I was trying to perform the update, I did not get
an error message until the upgrade was partially complete.

Will the work done help people like me, those with a non-PAE processor
who try to upgrade to a more current version of the 12.04 LTS?

Again, I want to repeat how much respect and appreciation I have for
the work you folks do.

-F. Stephen Costa

On Thu, Mar 6, 2014 at 12:48 AM, Chris Bainbridge
<email address hidden> wrote:
> I added some text about Pentium M to
> https://help.ubuntu.com/community/EnablingPAE . There is now some
> overlap with https://help.ubuntu.com/community/PAE - they pages could
> probably do with being merged and cleaned up.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1280638).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in Ubuntu Release Upgrader:
> New
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "ubuntu-release-upgrader" package in Ubuntu:
> Fix Released
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new packages, the
> upgrade will eventually report failure. Looking through the logs there
> is no kernel installed because of the error "This kernel does not
> support a non-PAE CPU.":
>
> Selecting previously unselected package linux-image-3.5.0-26-generic.^M
> Unpacking linux-image-3.5.0-26-generic (from .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
> This kernel does not support a non-PAE CPU.^M
> dpkg: error processing /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb (--unpack):^M
> subprocess new pre-installation script returned error exit status 1^M
> No apport report written because MaxReports is reached already
>
> Related bugs:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is dropping non-PAE flavour
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade from 12.04 to 12.10 on a sans-pae CPU ...

Read more...

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

Stephen,

The work done in this bug should stop 12.04 systems getting hosed when updating to 14.04.

The work done in bug #930447 enables Pentium M systems to boot a PAE kernel with the forcepae parameter (this has to be manually enabled by the user). Hopefully this means the 14.04 release image will boot on Pentium M systems.

In your case (I assume you have Pentium M) you can install fakepae and then install the enablement stack and stay on 12.04 or (once 14.04 is released) follow the instructions in the wiki to upgrade to 14.04.

Revision history for this message
lampeoneon (fabricebonaparte) wrote :

Thanks
On Mar 3, 2014 5:40 AM, "Chris Bainbridge" <email address hidden>
wrote:

> I'm attaching a patch for DistUpgradeQuirks.py that aborts the upgrade
> if the pae flag is not in /proc/cpuinfo (the same check as used by the
> kernel package on install). It would be a good idea to release this fix
> before the 14.04 LTS is released in order to save thousands of people
> from ending up with a broken system when they try to upgrade from 12.04
> LTS to 14.04 LTS
>
> ** Patch added: "update_manager_quirks_pae.patch"
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1160346/+attachment/4004690/+files/update_manager_quirks_pae.patch
>
> ** Tags added: patch
>
> ** Tags removed: quantal
>
> ** Tags added: pae
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1103208).
> https://bugs.launchpad.net/bugs/1160346
>
> Title:
> do-release-upgrade from Ubuntu 12.04 on Pentium-M fails, breaks system
> without any warning (This kernel does not support a non-PAE CPU)
>
> Status in "linux" package in Ubuntu:
> Invalid
> Status in "ubuntu-release-upgrader" package in Ubuntu:
> Triaged
>
> Bug description:
> Attempting to upgrade from Precise with a non-PAE kernel will result
> in a failed upgrade. do-release-upgrade should check whether the user
> is using a non-PAE kernel and refuse to run, rather than upgrading to
> a broken system with no installed kernel.
>
> After downloading 1.5GB+ of data and over 1000 new packages, the
> upgrade will eventually report failure. Looking through the logs there
> is no kernel installed because of the error "This kernel does not
> support a non-PAE CPU.":
>
> Selecting previously unselected package linux-image-3.5.0-26-generic.^M
> Unpacking linux-image-3.5.0-26-generic (from
> .../linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb) ...^M
> This kernel does not support a non-PAE CPU.^M
> dpkg: error processing
> /var/cache/apt/archives/linux-image-3.5.0-26-generic_3.5.0-26.42_i386.deb
> (--unpack):^M
> subprocess new pre-installation script returned error exit status 1^M
> No apport report written because MaxReports is reached already
>
> Related bugs:
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/897786 Kernel is
> dropping non-PAE flavour
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1068862 upgrade
> from 12.04 to 12.10 on a sans-pae CPU leaves kernel broken
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1160346/+subscriptions
>

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:0.214

---------------
ubuntu-release-upgrader (1:0.214) trusty; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: On 12.04 stop the upgrade process if the
    system does not support PAE. Thanks to Chris Bainbridge for the initial
    patch. (LP: #1160346)
 -- Brian Murray <email address hidden> Wed, 05 Mar 2014 12:53:48 -0800

Changed in ubuntu-release-upgrader:
status: New → Fix Released
To post a comment you must log in.