Kernel is dropping non-PAE flavour

Bug #897786 reported by Tim Gardner
98
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Fix Released
Undecided
Colin Watson
base-installer (Ubuntu)
Invalid
Undecided
Unassigned
Precise
Invalid
Undecided
Unassigned
Quantal
Invalid
Undecided
Unassigned
debian-installer (Ubuntu)
Fix Released
High
Colin Watson
Precise
Fix Released
High
Colin Watson
Quantal
Fix Released
Low
Colin Watson
linux (Ubuntu)
Fix Released
Undecided
Tim Gardner
Precise
Won't Fix
Undecided
Tim Gardner
Quantal
Fix Released
Undecided
Tim Gardner
linux-meta (Ubuntu)
Fix Released
Medium
Andy Whitcroft
Precise
Fix Released
Medium
Andy Whitcroft
Quantal
Fix Released
Undecided
Tim Gardner
live-build (Ubuntu)
Fix Released
High
Colin Watson
Precise
Fix Released
High
Colin Watson
Quantal
Invalid
Undecided
Unassigned

Bug Description

Dropping the non-PAE ia32 kernel flavour has knock-on effects for installers.

Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
milestone: none → precise-alpha-2
Changed in debian-installer (Ubuntu Precise):
milestone: none → precise-alpha-2
Revision history for this message
Tim Gardner (timg-tpi) wrote :

This is scheduled for discussion at the Dec 12, 2011 Technical Board meeting.

Colin Watson (cjwatson)
Changed in debian-installer (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Precise):
status: In Progress → Won't Fix
Revision history for this message
Tim Gardner (timg-tpi) wrote :

The outcome of the Technical Board discussion was that non-PAE will be dropped for 12.10, and that PAE will become the default boot kernel for 12.04 (depending on the results of testing).

Changed in linux (Ubuntu Precise):
milestone: precise-alpha-2 → none
Changed in linux (Ubuntu):
milestone: precise-alpha-2 → none
status: In Progress → Invalid
Colin Watson (cjwatson)
Changed in debian-installer (Ubuntu Precise):
assignee: nobody → Colin Watson (cjwatson)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu91

---------------
debian-installer (20101020ubuntu91) precise; urgency=low

  * Switch i386 to the -generic-pae kernel flavour, and add a new
    netboot/non-pae build for i386 that uses the -generic flavour
    (LP: #897786).
  * Exclude checksum files themselves (MD5SUMS, SHA1SUMS, and SHA256SUMS)
    from the contents of checksum files.
 -- Colin Watson <email address hidden> Thu, 15 Dec 2011 15:36:01 +0000

Changed in debian-installer (Ubuntu Precise):
status: Triaged → Fix Released
Colin Watson (cjwatson)
Changed in live-build (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → precise-alpha-2
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a24-1ubuntu20

---------------
live-build (3.0~a24-1ubuntu20) precise; urgency=low

  * Use i386 -generic-pae kernel flavour on Ubuntu >= precise (LP: #897786).
 -- Colin Watson <email address hidden> Thu, 15 Dec 2011 16:24:29 +0000

Changed in live-build (Ubuntu Precise):
status: Triaged → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

My mistake; base-installer doesn't need to change, since it already prefers generic-pae if the installer itself is running on a generic-pae kernel.

Changed in base-installer (Ubuntu Precise):
status: New → Invalid
Revision history for this message
Colin Watson (cjwatson) wrote :

revno: 868
fixes bug: https://launchpad.net/bugs/897786
committer: Colin Watson <email address hidden>
branch nick: cdimage
timestamp: Thu 2011-12-15 16:26:13 +0000
message:
  use generic-pae kernel flavour on i386 (LP: #897786)

revno: 1730
fixes bug: https://launchpad.net/bugs/897786
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Thu 2011-12-15 16:31:31 +0000
message:
  use generic-pae kernel flavour on i386 (LP: #897786)

revno: 1731
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Thu 2011-12-15 16:32:11 +0000
message:
  drop base-installer/kernel/override-image forcing server installs to generic-pae, as that's now the default

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
Andy Whitcroft (apw)
Changed in linux-meta (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
milestone: none → precise-alpha-2
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 3.2.0.8.8

---------------
linux-meta (3.2.0.8.8) precise; urgency=low

  * linux-image should point to the recommended kernel, move it to
    generic-pae on 32bit to match the rest of the CD.
    - LP: #897786
  * Bump ABI
 -- Andy Whitcroft <email address hidden> Thu, 05 Jan 2012 17:44:26 +0000

Changed in linux-meta (Ubuntu Precise):
status: In Progress → Fix Released
Revision history for this message
BubbaJ (azstuenthome) wrote :

Ok, I'm sorry in advance if this is not the correct place to post this question. But, I tried downloading the latest 12.04 daily build and tried to boot after flashing it to a live usb. I was not able to boot on my Thinkpad T42 and received an error that my CPU did not support the PAE kernel. My understanding is that the default for the i386 image will be PAE, but that non-PAE will be supported until 12.10. How would I go about installing the non-PAE kernel?

Revision history for this message
Stéphane Graber (stgraber) wrote :

One way I know is by using the mini.iso image (netboot) which exists in a non-pae flavour at:
http://archive.ubuntulinux.org/ubuntu/dists/precise/main/installer-i386/current/images/netboot/non-pae/mini.iso

I know some flavours of Ubuntu chose to ship with non-PAE by default, using one of these (probably xubuntu and lubuntu) would work too.

Revision history for this message
BubbaJ (azstuenthome) wrote :

Thanks for the response and the link. Since I've only every used the cd iso to build a live usb, is it possible to use the "mini.iso", to build a live USB that I could use to evaluate 12.04 without installing it first?

Revision history for this message
cariboo (cariboo) wrote :

BubbaJ, the mini.iso is just a very basic installer, there is just enough there to start the installation and make a network connection, from there you have to choose almost everything, from the mirror to use, to what packages you want to install. So basically at this point you are out of luck if you want to install on a non-pae system.

Revision history for this message
Colin Watson (cjwatson) wrote : Re: [Bug 897786] Re: Kernel is dropping non-PAE flavour

Generally speaking the defaults in the netboot installer (mini.iso)
should be sufficient to install a system; you get asked a fair number of
questions, true, but it's mostly a matter of hitting Enter a lot. Just
select "Ubuntu desktop" when you get to the task selection question.
"Out of luck" is overstating the case a bit really.

Revision history for this message
Stéphane Graber (stgraber) wrote :

Regarding using mini.iso as a live media, no that won't work as mini.iso is a minimal debian-install images similar to what you'd load from a tftp server for a netinstall.

I don't think it's possible to test Ubuntu 12.04 on a non-PAE machine using a live media at this point, at least I couldn't find any image where the non-PAE kernel is listed in the manifest. Colin will probably correct me here if I'm wrong.

It'd probably be interesting for you to talk to the Xubuntu and Lubuntu folks who may target more the hardware that's old enough to miss PAE support and see if they'd consider changing their default kernel to the non-PAE variant.

I guess it wouldn't be impossible to ship both kernels on the DVD image (that's meant to be put on a USB stick) but would likely require some work in ubiquity to remove the right kernel and in gfxboot to show the option to the user, I doubt this will happen before the FeatureFreeze which is on the 16th of February.

Revision history for this message
BubbaJ (azstuenthome) wrote :

Ok, I guess I must just be a simple person, but would it be too difficult to build two separate image files, one with PAE and one with non-PAE kernel?

All of the forum posts and developer notes from the recent tech board are confusing. From what I understand, in the December meeting the tech board reversed their recommendation and agreed to support the non-PAE kernel until 12.10. I guess I must just be slow to grasp what's going on. If the decision was to support non-PAE, then why is there currently no way to install a non-PAE version of 12.04.

Seems like someone should be able to clear up the confusion. Why say that there is support if you can't do a fresh install of a 12.04 image with a non-PAE kernel?

I'm coming from the user side, who is somewhat technical. If I'm confused, then you can bet that the casual user will be more confused. Enough probably to pursue other alternatives. Never having used the mini.iso route to build a system, it sounds like it could be used to build a non-PAE kernel system, but is not the same user experience as installing from a full iso image. Is that correct? Is that what the board meant by "support"?

Revision history for this message
Erick Brunzell (lbsolost) wrote :

@ Stéphane and/or Colin,

I plan on doing some mini.iso testing in the near future, no help needed there as I've used it before. I just need to answer some of my own questions, such as whether "--no-install-recommends" is required when installing the various desktop environments. I'll just try both with and without, compare logs & results, etc.

My question is, in comment #9 Stéphane said, "I know some flavours of Ubuntu chose to ship with non-PAE by default, using one of these (probably xubuntu and lubuntu) would work too".

Based on that would it be improper to subscribe both lubuntu-dev and xubuntu-dev to this bug report so we could get a definitive answer regarding their decisions?

I personally have no effected hardware so my testing ability is limited, but ATM it looks like upgrades from Oneiric w/non-pae to Precise remain non-pae, and undoubtedly using the mini.iso will work, but I'd think both of those options would require fast ethernet (no problem here).

It would just be nice to know for sure what Lubuntu and Xubuntu plan to do ;^)

Revision history for this message
Erick Brunzell (lbsolost) wrote :

I'm just initially trying the 20120208 mini.iso and having a horrible time with networking. Based on previous experience this is not uncommon.

Even though I have a wired LAN, and a wired router, it can be very difficult to perform the initial installation w/o connecting directly to the modem. This means disconnecting all other devices in the house for several minutes :^(

I typically then complete the installation using a chroot ............. or better yet, just performing the installation on another machine, but that will likely not be an option for many of those with outdated hardware.

Given the need for "fast" ethernet combined with other complications the statement that non-pae will be supported throughout the Precise life cycle may need to be amended to "if you're willing to jump through a lot of hoops you'll still be able to install on hardware that does NOT support pae" :^)

If either Lubuntu or Xubuntu chose to use non-pae by default that would almost make the statement true that we're supporting non-pae throughout the Precise life cycle, but still not quite, since Xubuntu will have only a 3 year life cycle, and Lubuntu will have only an 18 month life cycle.

I'm basing those life cycles on what I've read recently, if they're wrong please do correct me. OTOH if we're going back on supporting non-pae throughout the Ubuntu Precise life cycle then we should just say so.

Revision history for this message
Colin Watson (cjwatson) wrote :

Erick, if you can boot the kernel at all, I don't see how PAE is your
problem. It's not the kind of thing that breaks just one subsystem.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

Colin, as I said in comment #15 "I personally have no effected hardware". So pae is not a problem for me personally. I find pae to run quite well on all of my hardware, even an old 335mhz PII that I pulled out of the closet.

But a few people on the forums have complained, AFAIK only BubbaJ has taken the effort to comment here, and I'm not aware of anyone reporting a bug.

I'm just trying to find a definitive answer as to whether or not Lubuntu and Xubuntu will rebuild with non-pae, and I'd like to create a how-to for installing Ubuntu with non-pae.

I'm just trying to find a solution for those who get the "kernel requires feature pae and won't boot" error, even though I'm not personally effected.

Revision history for this message
BubbaJ (azstuenthome) wrote :

I just posted another comment on the Pentium M specific topic. Rather than repeat it, here is the link: https://answers.launchpad.net/ubuntu/+source/linux-meta/+question/187166. If PAE runs on PII 335mhz hardware, it's just a shame that it won't run on Pentium M 1700Mhz 2GB ram hardware.

Isn't there anyway to just have two options for i386 users at time of release: the main primary PAE flavor which can be the default on the Ubuntu download page, and a secondary non-PAE image flavor in the cd image directory?

Revision history for this message
Erick Brunzell (lbsolost) wrote :

Colin, I just realized that I created some confusion. I was trying the non-pae mini.iso when I posted earlier.

I'll deal with errors regarding it separately after doing some research, and taking into account that I'm testing a daily image.

I have since learned that Lubuntu will NOT rebuild with the non-pae kernel.

I convinced BubbaJ to file bug 930447. I hope he'll take time to provide a hardware profile.

So, AFAIK there are two options for installing Precise on hardware that will not support pae:

(1) Upgrade from Oneiric (although I notice some bits of pae being pulled into installed packages).

(2) Use the non-pae mini.iso (or CLI from the alternate image) but that can be problematic.

Both of those options require fast internet so I'm not sure we're living up to our promise to support non-pae throughout the Precise life cycle.

Since all of my hardware works fine with the pae kernel I can't do much kernel related testing on my end, but I can certainly test installation procedures.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Revision history for this message
Luiz Angelo Daros de Luca (luizluca) wrote :

Hello guys,

I replaced the kernel in Livecd for i586 with the one that supports non-pae processor. It installs and update normally. Just download and be happy.

http://dl.dropbox.com/u/1286502/ubuntu-12.04-desktop-i386-nonpae.iso
MD5SUM 7435d1d1740dcf16fbbba2e746de4de1
SHA1SUM 4fb527b2e2c6a00499677102df36ec466e79c373
SHA256SUM a8e4427889fa6786e4cfe82ad578fcbf833fe66146a180f90abcc5caa6fe6dbb

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The non-PAE flavour has been dropped in Quantal. I'm marking the linux and linux-meta Quantal tasks Fix Released.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux-meta (Ubuntu Quantal):
status: Confirmed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

debian-installer (20101020ubuntu139) quantal; urgency=low

  * Remove the non-pae builds on i386, since the kernel no longer builds the
    -generic flavour there.

 -- Colin Watson <email address hidden> Fri, 04 May 2012 09:57:15 +0100

Changed in debian-installer (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Released
Revision history for this message
Shahar Or (mightyiam) wrote :

I've stumbled across the lack of a non-pae i386 kernel in quantal when I've tried to use an IBM Thinkpad T42 laptop as a thin client for quantal LTSP server.

Not being able to use that old laptop as a thin client would be a waste of hardware. That particular laptop is worn out but other users have the same model in good shape and it is otherwise capable of running quantal reasonably.

There must be other systems without pae which otherwise are quite useful to users today.

This is me complaining a little bit in the name of all those who still don't know that they will not be able to upgrade their systems to quantal.

Thanks and Blessings,
Shahar

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

@mightyiam

Did you notice that there were no i386 server images published for quantal?

Revision history for this message
Shahar Or (mightyiam) wrote :

On 15 August 2012 01:24, Dmitrijs Ledkovs <email address hidden> wrote:
>
> Did you notice that there were no i386 server images published for
> quantal?

Well, now I have.

Revision history for this message
Austin Leeds (firepowerforfreedom) wrote :

Is the non-PAE kernel really that much of a hastle to deal with that it needs to be dropped? Isn't there some way to support non-PAE machines?

I have an IBM ThinkPad T42 (2373-JXU) that will be out in the cold if PAE is no longer supported, and since the used laptop market is flooded with T40s, T41s, and T42s, I could see this turning off a lot of people. I know I'll be very displeased if my 15" 1400x1050 IPS display-equipped T42 isn't supported by 12.10 and onward.

Revision history for this message
MNLipp (mnl) wrote :

Maybe it is my English, but from the bug description "Dropping the non-PAE ia32 kernel flavour has knock-on effects for installers" I wouldn't have expected that this is marked as "fixed" with the non-pae kernel being removed from the installer disc in 12.10.

I have opened another bug #1072311 that clearly states what is wrong here. If you're affected, you might want to support this new bug.

Revision history for this message
MNLipp (mnl) wrote :

To anyone who happens to come here while searching for help with non-pae capable hardware: Note that this bug has the wrong state, it should be "Won't fix" (see Dave Lentz's comment on #1072311: "I agree that Fix Released status for Quantal is a bit confusing (should have been 'Won't Fix').")

I found in a report about the "Ubuntu Technical Board"'s discussion (http://www.phoronix.com/scan.php?page=news_item&px=MTAyNzM) that "Maintaining the extra flavour is not much extra work". So I wonder about the decision to no longer support a non-pae kernel. I spent some time googling for comments on this problem and it seems that it is not just me (and the currently 10 "also affected"). There are quite a lot of people with "older" (some actually less than 5 years) but still fully usable laptops who are affected by this.

As I stated in #1072311, my nc6000 is certainly not the fastest laptop around, but works very well and can still match the demands of a current Linux OS. I do not see why it (and similar) should be left out from new features coming with versions beyond 12.04.

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

MNLipp (mnl) wrote on 2012-10-28:
> my nc6000 is certainly not the fastest laptop around, but works very well and can still match the demands of a current Linux OS. I do not see why it (and similar) should be left out from new features coming with versions beyond 12.04.

I just posted a comment on bug #930447 which explains the two possible options right now. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/930447/comments/157

Your system is Pentium M so it will probably work fine with a PAE kernel, try installing one with fake-pae and then boot from it. The worst that can happen is that it doesn't work, but I haven't seen any reports of PAE kernel failing to boot on Pentium M.

Revision history for this message
floid (jkanowitz) wrote :

@Chris Bainbridge re comment #31:

> but I haven't seen any reports of PAE kernel failing to boot on Pentium M.

Does this go for Banias as well as Dothan Pentium Ms? My understanding is that Dothan actually supports PAE but was potentially crippled-by-chipset (but if so does that really touch cpuflags?) in common designs, while the original Banias supposedly completely lacks it [at least doesn't advertise it]... and the NX support that this is supposed to really be about came in with Dothan (which I assume will report under cpuflags in all circumstances?).

I have a couple Dell D600s which are Banias so would be interested to know what the real deal is. (Not thrilled to play guinea pig more after treating the hardware as bricked for a year when it *was* supported because I expected the rtl8180 driver to work, but if no one else steps up...)

Interesting that, per wikiality, Microsoft apparently made this same exact decision for Windows 8 and Fedora has apparently been enforcing it "where supported by the hardware" since c. 2009 but searching re: the Ubuntu issue never turned up screaming and rending of clothes from that camp. (Does Fedora do something more sane here?)

Revision history for this message
Josep Mª Vilargonter Lozano (vilargonter) wrote :
Download full text (22.5 KiB)

Información más completa
Computer
********

Summary
-------

-Computer-
Processor : Intel(R) Pentium(R) M processor 1400MHz
Memory : 2065MB (222MB used)
Operating System : Ubuntu 12.10
User Name : jose (JOSÉ Mª VILARGONTER LOZANO)
Date/Time : dom 31 mar 2013 10:54:03 CEST
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH4 - Intel 82801DB-ICH4
-Input Devices-
 Lid Switch
 Power Button
 Sleep Button
 AT Translated Set 2 keyboard
 Video Bus
 DualPoint Stick
 AlpsPS/2 ALPS DualPoint TouchPad
   USB Keyboard
   USB Keyboard
 SIGMACHIP Usb Mouse
-Printers-
No printers found
-SCSI Disks-
ATA WDC WD800UE-22HC
HL-DT-ST DVD-ROM GDR8082N
TDKMedia Trans-It Drive
 USB DISK 2.0

Operating System
----------------

-Version-
Kernel : Linux 3.5.0-17-generic (i686)
Compiled : #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012
C Library : Unknown
Default C Compiler : Unknown
Distribution : Ubuntu 12.10
-Current Session-
Computer Name : jose-Latitude-D600
User Name : jose (JOSÉ Mª VILARGONTER LOZANO)
Home Directory : /home/jose
Desktop Environment : LXDE (Lubuntu)
-Misc-
Uptime : 54 minutes
Load Average : 0,00, 0,00, 0,00

Kernel Modules
--------------

-Loaded Modules-
arc4 : ARC4 Cipher Algorithm
rtl8187 : RTL8187/RTL8187B USB wireless driver
mac80211 : IEEE 802.11 subsystem
cfg80211 : wireless configuration support
eeprom_93cx6 : EEPROM 93cx6 chip driver
nls_iso8859_1
rfcomm : Bluetooth RFCOMM ver 1.11
bnep : Bluetooth BNEP ver 1.3
hid_generic : HID generic driver
joydev : Joystick device interfaces
snd_intel8x0 : Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455
snd_ac97_codec : Universal interface for Audio Codec &apos;97
ac97_bus
snd_pcm : Midlevel PCM code for ALSA.
ppdev
snd_seq_midi : Advanced Linux Sound Architecture sequencer MIDI synth.
snd_rawmidi : Midlevel RawMidi code for ALSA.
snd_seq_midi_event : MIDI byte &lt;-&gt; sequencer event coder
snd_seq : Advanced Linux Sound Architecture sequencer.
dell_laptop : Dell laptop driver
dcdbas : Dell Systems Management Base Driver (version 5.6.0-3.2)
snd_timer : ALSA timer interface
snd_seq_device : ALSA sequencer device management
microcode : Microcode Update Driver
radeon : ATI Radeon
snd : Advanced Linux Sound Architecture driver for soundcards.
usbhid : USB HID core driver
pcmcia : PCMCIA Driver Services
hid
psmouse : PS/2 mouse driver
soundcore : Core sound module
serio_raw : Raw serio driver
ttm : TTM memory manager subsystem (for DRM device)
snd_page_alloc : Memory allocator for ALSA system.
drm_kms_helper : DRM KMS helper
yenta_socket
pcmcia_rsrc
lpc_ich : LPC interface for Intel ICH
drm : DRM shared core routines
btusb : Generic Bluetooth USB driver ver 0.6
pcmcia_core : Linux Kernel Card Services
i2c_algo_bit : I2C-Bus bit-banging algorithm
bluetooth : Bluetooth Core ver 2.16
shpchp : Standard Hot Plug PCI Controller Driver
irda : The Linux IrDA Protocol Stack
video : ACPI Video Driver
crc_ccitt : CRC-CCITT calculations
parport_pc : P...

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

floid (jkanowitz) wrote:

> Does this go for Banias as well as Dothan Pentium Ms?

I have Dothan, it does not advertise PAE in cpuflags, but PAE kernel works.

> the NX support that this is supposed to really be about came in with Dothan (which I assume will report under cpuflags in all circumstances?).

No, my Dothan Pentium M (Family 6 model 13 with 400mhz bus) does not have PAE or NX in cpuflags.

NX is supported via kernel patch (see https://lists.ubuntu.com/archives/ubuntu-devel/2011-November/034502.html Dropping i386 non-PAE as a supported kernel flavour in Precise Pangolin - "This is about dropping non-PAE support, not dropping non-NX support. The NX emulation patch must remain in the kernel since a large number of systems have PAE but not NX.")

> (Does Fedora do something more sane here?)

Fedora supports i686 kernels without PAE. The installer chooses to install a PAE kernel (or not) based on CPU and memory config - PAE capable systems with <4GB will get non-PAE kernel, as it is slightly faster and all memory is usable.

Revision history for this message
Austin Leeds (firepowerforfreedom) wrote :

Fedora's method sounds much more reasonable.

I agree with most of Ubuntu's decisions, but putting my ThinkPad T42 (1.7 GHz PM, 400 MHz FSB, Radeon 9600) out in the cold while my T43 (1.73 GHz, 533 MHz FSB, Intel GMA 900) remains supported is about the most ridiculous thing I've ever seen. The T42 can run circles around the T43!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions