Ubuntu

Unhelpful response when inserting encrypted DVD in default installation

Reported by nyékhelyi gábor on 2007-09-05
420
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Totem
In Progress
Low
totem (Ubuntu)
Low
Unassigned
Declined for Karmic by Brian Murray

Bug Description

Ubuntu 4.10, 5.04, 5.10, 6.06, 7.04, 7.10, 8.04, 8.10, 9.04, 9.10, 10.04, 10.10, 11.04, 11.10, 12.04, 14.04

1. Install Ubuntu.
2. Insert a standard movie DVD.

What happens:
* In Ubuntu 10.10 and earlier, "An error occurred" - "Could not read from resource."
* In Ubuntu 11.10, "An error occurred" - "Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed."

Without libdvdcss2, Totem, VLC, and others are unable to play my original DVD-s. I know it's illegal to ship Ubuntu with libdvdcss2, but it could be in multiverse repos, and totem's plugin installer could install it, OR add the medibuntu repo to the list (but leave unchecked), then Totem's plugin installer should give a hint, to use that repo's libdvdcss2 to play your DVDs. Newbies wont find out how to solve this problem by theirself, go back to win, and then it will be harder to solve the bug #1 :)

Not to be confused with:
* bug 502426, where DVDs don't play when libdvdcss is installed
* bug 745515, "An error occured location not found" while trying to play a DVD
* bug 747433, "Totem cannot play this type of media DVD because it does not have the appropriate plugins to be able to read from this disc"

Brian Murray (brian-murray) wrote :

The package libdvdread3, in universe, provides a script that you can use to install libdvdcss2 if it is legal in your country. I think that solves part of your bug report. Is that right?

nyékhelyi gábor (n0gabor) wrote :

I didn't know that, and the system didn't tell me about that script. So a newby, newcommer windows user won't know about it too. Totem should notify the user about this script, or the plugin installer should have a checkbox to run this script, or something like this.

This is complex, but at least everything is explained in the help.

What could be nice is to run the /usr/share/doc/libdvdread3/install-css.sh script when installing the libdvdread3 package: this would remove one step and make it easier to get DVD support. flashplugin-nonfree already does that. Or make a virtual package depending on libdvdread3, libdvdcss2, and possibly libdvdnav4 so that everything can be installed easily, by libgimme-codec for example.

Changed in libgimme-codec:
assignee: nobody → desktop-bugs

libdvdcss2 circumvents the CSS encryption found on DVDs. Circumvention is not legal in many countries even if it is for use of legally owned DVDs. A distribution can not make a choice for user when it is legal matter.

This is not same as flashplugin-nonfree. There is no question of legality in case of flash plugin provided by Adobe.

Apart from that, libdvdread3 is already a dependency of gstreamer0.10-plugins-bad. Also libdvdnav4 will be a dependency of gstreamer0.10-plugins-bad, by the time intrepid is released. So Gstreamer, which is default backend for totem, will have full support for playing non-encrypted (region-free) DVDs provided all plugins were installed.

Onkar Shinde (onkarshinde) wrote :

Why is this a bug against libgimme-codec?

Changed in libgimme-codec:
assignee: desktop-bugs → nobody
status: Confirmed → Invalid

It shouldn't be. Changing to a more appropriate place.

Changed in libdvdnav:
status: New → Invalid
Changed in libdvdread:
status: New → Invalid
Changed in totem:
importance: Undecided → Wishlist
status: New → Confirmed
Daniel Hollocher (chogydan) wrote :

Maybe we could ask the upstream guys to allow for a custom message on codecs that fail to install through totem's autoinstaller. Then, whoever packages totem can just customise the message for whatever distro they are using. For ubuntu, the message would probably include at least the following links/info:
http://blog.canonical.com/?p=37 (This one is good for those who want to pay money)
http://medibuntu.org/ (This one is good for those who don't)

The reason that the message needs to be custom is that different distros (like debian) handle these legal issues differently. (Before medibuntu was around, I used to use the debian mirrors on my ubuntu for these codecs)

I would not be surprised that what I'm doing breaks some law, since I live in the US. But, I don't care, since I would be able to do this stuff on windows. I don't care if legal technicalities make it illegal for me to do those things on linux. That's just me.

The issues of patents and copyrights is, and will probably continue to be, a contentious topic for the FOSS world, but providing information about the issues should not be. So that's my logic for a custom popup message.

Practically speaking, if an upstream bug does need to be filed, the maintainer of the totem package should probably file it. They are the ones are going to maintaining it anyway.

Tom (tom6) wrote :

Ubuntu 8.10 let me know that my screen would work better if i installed a restricted driver but advised me not to as there might be some legal issue.
I had to click 'Ok' to continue so presumably any legal issue would be my fault rather than the Ubuntu people. It worked great but, of course, i have uninstalled it now (honest guv), for legal reasons (although i didnt have any trouble at all while i was using it).

Milan Bouchet-Valat (nalimilan) wrote :

At least there's an easy part to fix here: you shouldn't have to run /usr/share/doc/libdvdread3/install-css.sh. Instead, it should be run automatically by the post-install script of libdvdcss2. This does not bring any new legal issue, and makes things way simpler.

wordsmyth (wordsmyth-netspace) wrote :

Hi There: I'm an Australian resident and I finally managed to solve my problems with Totem - and VLC - with patiene and diligence, by using Google to seek what I needed to know i.e downloading Ubuntu Restricted Extras and appropriate DVD codecs. But I'm a newbie, and it took a helluva lot of work. If these instructions were readily provided by Totem & VLC in their program, this wouldn't be necessary. Those with similar problems, download and install the Extras package and then go to Medibuntu : http://packages.medibuntu.org/ to download & install the extra codecs : libdvdcss2 and w32codecs. Easy enough. But it took me an unconscionably long time to get there ...

Change importance to LOW, I'v also reported bug upstream

http://bugzilla.gnome.org/show_bug.cgi?id=580396

Changed in totem (Ubuntu):
importance: Wishlist → Low
Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
wordsmyth (wordsmyth-netspace) wrote :

Even though I'm a newbie living in Australia, I soon figured out the problem with Totem. The annoying thing IS....Microsoft ships XP & Vista with their Windows Media Player which AUTOMATICALLY plays DVDs. And the puzzling thing IS, on a previous installation - Ubuntu 8.10 - I got a pop-up window on Totem that said: TOTEM CANNOT PLAY THIS DVD. SHALL TOTEM SEARCH FOR PROPER CODECS? Which it did...and then the DVD played. Curious, non? This didn't happened when I installed Jaunty 9.4....

wordsmyth: I guess the code installation dialog only appears when you try to read an *unencrypted* DVD for th first time. Then, if you try with an encrypted DVD, it only fails, and it's always been the case in Ubuntu. At least the problem is, the first codec prompt should also explain how to read encrypted DVDs, that would help most users.

Changed in totem:
status: Unknown → In Progress

Added hundred paper cuts as I feel this is a major issue with new users. I have read many articles written by journalists who are discovering Linux for the first time via Ubuntu, and they have all commented that playing a DVD film just doesn't work, and the OS doesn't offer any help to allow this.

I feel like this is something that could be solved fairly easily and would make new users have to do a lot less work to get a DVD going. I realise, however, that this is an issue that needs to be carefully debated, as it's not FOSS we're talking about here... but I'd like to offer it for discussion to the hundredpapercut team.

Daniel Hollocher (chogydan) wrote :

Hey Lumpy,
I think you may have the wrong idea about this bug. From the upstream report, it looks like the issue might be that gstreamer is simply not handling the situation correctly, and thus is a gstreamer bug. Unfortunately, the upstream report is not all that clear, but it is assigned! Hopefully, its on track.

Steve Dodier-Lazaro (sidi) wrote :

Fixing this bug doesn't look trivial at all, and even if it is currently a big issue, the One Hundred Paper Cuts project is devoted to easily fixable issues. Thus, I am marking this bug incomplete for One Hundred Paper Cuts.

If you can provide accurate guidance for making it easy to implement for the developers, feel free to set it back to New.

Changed in hundredpapercuts:
status: New → Incomplete
Mik3 (mc4100) wrote :

The current situation is awful. Not a lawyer.

I wont change status to new but, well, when the script to get the means to circumvent the css protection is already being provided, I hardly think running it would make matters worse.
You've provided the vector already, which I think is the legally questionable part, why not use it.

To be somewhat safer, manual input by the user -- it doesn't matter if you're clicking a button to agree or writing "I absolutely assert this is legal in my region", *something* should be presented when you try to play on encrypted dvd.
Something meaningful which should either resolve the problem:
(Window title: enable DVD playback)
Pick your location on this map.
[map widget]
[and in bold] Some regions have restrictive laws controlling playback of commercial DVDs, so be aware it may be illegal to enable playback if, for example, you do not live in X [where x is somewhere in which I can now declare I reside and have this problem go away]
or, at least, make it very, very clear what the problem is and provide a link to a web search.

Sounds good to me. Is it really more legally questionable to present these packages to people with a firm warning when the package is just a simple apt-get away?

Ari Torhamo (ari-torhamo) wrote :

I have to say I'm astonished that in 9.10, the eleventh version of Ubuntu, when a user tries to play a movie DVD, he's greeted with "Error occured, unable to read from the resource", instead of at least being given a pointer to the right help page. (The wrong help page would be the "Totem movie player manual", which is the first result you get (in Karmic) when you search with the word "dvd" in the Help). The right result, "Music, videos and photos", comes up seventh). I appreciate the difficulty to create a seamless user experience with media and codecs (on which a lot of great work has been done already), but at least we should lead the user forward to the next step. The further goal should be for example to let the user click a couple of OKs, be warned of possible legal aspects with understandable language and have the necessary codecs and other packages installed automatically.

glad (glad) wrote :

VLC should come by default in Ubuntu 10.04, since it reproduces any type of video and DVD, without any problem.

Totem codec support is awful.

Contemporaneo: This is not related at all wirh the present report. When CSS support is installed, Totem works just fine with DVDs, and recent versions have become quite good. Please report precise and documented bugs, rather than random rants.

Rich Jones (richwjones) wrote :

Ari Torhamo's comment is absolutely correct - that is simply unacceptable behavior, especially when the fix is simply to give the user a little bit more information.

Can we aim to get this fixed by Thursday? Dave?

Sam L. (somethinginteres) wrote :

This is a repost from the GNOME bug report:

If this has not yet been fixed I'd like to add my 2 cents. Obviously there's
legal issues surrounding encryption but is important to provide the user with
that knowledge.

  num = BVW_ERROR_DVD_ENCRYPTED;
   message = g_strdup (_("The source seems encrypted and
  can't be read. Are you trying to play an encrypted DVD without libdvdcss?"));

Just doesn't cut it because it is less than useful in providing "newbie friendly" information.

Something like essage = g_strdup (_("The source you're attempting to view seems
to be encrypted and therefore can't be read. It is probably a commercial DVD.
Please see: XYZ for more information regarding the issues involved."));

XYZ in this case would probably best link to the Ubuntu RestrictedFormats wiki in Ubuntu's specific case.

This is probably the most common issue I get asked about by new Linux users and
a small change like this could prevent a lot of headaches. Rich, you mentioned getting a fix committed.. any word on this? I don't ask to be pushy I just know what a difference in usability this would make for new users. Thanks.

Changed in totem:
importance: Unknown → Low
Chris Wilson (notgary) wrote :

Wouldn't it be acceptable to display a message along the lines of

"The DVD you have inserted cann't currently be played because the supporting software has not been installed. This is because it is not legal for Ubuntu to distribute this software in some countries. If you are certain that it is legal for you to install this software in your country, you can install it now. Would you like to install it now?

<yes button> <no button>"

Omer Akram (om26er) on 2011-01-30
Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Ivanka Majic (ivanka) on 2011-04-18
tags: added: fitandfinish
Ekimia (u-contact-ekimia-fr) wrote :

It seems nobody is Working anymore on this when reading the Gnome Bug page ?

John Lea (johnlea) on 2011-06-22
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: udo
Ekimia (u-contact-ekimia-fr) wrote :

thanks John. But No One can decide if it's legal or Not. But I agree it's still the best solution.

We could however make it shorter :

"To play this commercial DVD, you need to install the DVDCSS library

<yes install now> <no thanks>

*Using the DVDCSS library might not be legal in your country. please check before using it.

"

But does Ubuntu should fear legal threat with such an easy step ?

John Lea (johnlea) on 2011-06-30
Changed in ayatana-design:
status: Fix Committed → Fix Released

For Info , on 11.04 today the Error message is more explicit :

https://picasaweb.google.com/lh/photo/9-dclA7Phd2iT7SD-0mqOA?feat=directlink

Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed.

Timothy Arceri (t-fridey) wrote :

The original bug post was about making this problem easier to solve for beginners.

The message at this time was: "Error occured, unable to read from the resource"

It is now: "Could not read DVD. This may be because the DVD is encrypted and a DVD decryption library is not installed."

I think this is enough to close this bug as the user now has enough information to start googling a solution.

I don't think that telling the user to install libdvdcss2 is necessarily the right thing to do as it is not the only option they have, and also there is the legal issues surrounding it. Other options include buying a commercial DVD player from the Ubuntu store.

Changed in hundredpapercuts:
status: Incomplete → Fix Released
freechelmi (michel-memeteau) wrote :

@thimothy : I think you are a bit wrong.

We could have said the same thing 3 years ago when gnome-code-install ( Which propose to install a gstreamer package when a codec is needed) was developped.

the status here is a bit different as libdvdcss is not even in Universe but launching install-css.sh after the user have clicked on Ok should be an easy task.

However I see you point in telling the user that there are legal solution like the fluendo DVD player with is Payware, BUT it's only available on some architecture.

I guess Presenting both solution in the resulting dialog box could be great.

Timothy: That's not a reason to close the Paper cuts task and not the Totem task. If there's no problem, both have to be closed.

That said, I strongly disagree: the error message is clearly not enough to allow the user to make a correct choice. How would one find out that it can buy a codec or install libdvdcss2 without a link to a help page?

freechelmi (michel-memeteau) wrote :

if we stick to the bug subject "notify users about installing" , I understand timothy wants to close the bug.

But shouldn't the bug reporter wanted to tell that Totem should "propose to install" the require components ?

Ekimia (u-contact-ekimia-fr) wrote :

Tried in 11.10 ( in french) :

Impossible de lire le DVD. Il se peut que le DVD soit chiffré et qu'aucune biblithèque de déchiffrement ne soit disponible.

in other Words the user just know that it's missing a decrypting library but no clue on how to install it.

Isn't the pacth for Totem ready ? Why it's not included in ubuntu ? Legal threats ?

Yes. Developers upstream think we can't legally point users to instructions about installing illegal software. :-(

Ekimia (u-contact-ekimia-fr) wrote :

Interressting because the ubuntu man pages ,( which is the first google result for "play dvd ubuntu") suggest to launch the DVDread script which install the libdvdcss deb.

Why not ( a bit like for codecs) suggest that if it's legal in your country ( which is in France, for example ) , you could just Hit the right Button , and the other button would redirect to teh ubuntu Store for Buying Fluendo DVD .

if it's too risky , at least explain and propose to buy the fluendo DVD player, current situation is ridiculous and all the work at fluendo is then useless ...

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
summary: - Totem should notify users about installing libdvdread3 and libdvdcss2 to
- read encrypted DVD
+ Unhelpful response when inserting encrypted DVD in default installation
Matthew Paul Thomas (mpt) wrote :

The "Desired solution" could stand much improvement. The text should be much shorter (62 words is far too much for an alert); the button labels should not start with "Yes" or "No"; and it's not clear what should happen during or after installation.

Most importantly, though, it would be asking a question to which people couldn't reasonably be expected to know the answer. And if they didn't know the answer -- or even if they did know, and the answer was negative -- they would be steered towards having the DVD not play. All this while there's perfectly legal DVD-playing software available in Ubuntu Software Center!

I propose instead that, first, we let people who know about libdvdcss, and who understand the risk (or otherwise) of it in their country, install it by any method they like. Second, if Totem opens to play an encrypted DVD while no known DVD-playing software is installed, we offer the solution that will work in practically every country: purchasing the DVD player software in Ubuntu Software Center. Third, that USC be smart enough to close, or be replaced by a progress window, or something like that, once you've started installing the one thing that it was opened to present. And fourth, that Totem (or GStreamer?) be smart enough to start playback automatically once installation completes.

The third step is vague because it should be designed to be roughly consistent with the solution to bug 860536. And designing all four steps would require input from developers familiar with USC and GStreamer -- at least to decide which software should play which parts.

description: updated
Alex Korobkin (korobkin) wrote :

There could be two reasons for this error to occur: either libdvdcss not installed, or DVD region not set (frequent for new machines). Adding a DVD region check might help to resolve the problem for some users.

Matthew: the automated codec installation already exists in Totem actually. Just try to open a AAC file, and it will prompt you to install the codec. The Fluendo DVD plugin should just be registered with the correct information (to say: "hey, I read encrypted DVDs"), and Totem should query for such plugins. This is probably not done ATM upstream because only Ubuntu sells the Fluendo plugin by default, but would likely be easy to do.

AFAIK, Totem is already smart enough to start playing right after the codec has been installed.

For the technical details, see:
http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-base-libs/html/gst-plugins-base-libs-gstpbutilsinstallplugins.html

OK, the problem is, Fluendo doesn't sell a codec, but a full-fledged DVD player that competes with Totem. So we can't install the required codecs transparently. Something to check, though, is whether installing their DVD player is enough to allow GStreamer apps like Totem to read encrypted DVDs too. I suppose it's the case.

This would mean the Fluendo DVD player package could be technically advertised as a plugin, which would allow it to be installed from Totem. Users would be able to use Totem as usual, or start the newly installed Fluendo player if they prefer.

HI. Sorry I am not only a newbie to Ubuntu but I don't understand any of what you're saying, not being a techo of any description. Does this mean that I can install something to make this dvd work, or not? if so what, and how do I find it and if not then I guess I just have to play it on the telly!
Thanks

Alex: are you sure DVD drives with no region code set will trigger this error message in 11.10? That would need to be reported upstream as a separate bug.

Sally-Ann: see https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

John Lea (johnlea) on 2011-11-26
Changed in ayatana-design:
assignee: John Lea (johnlea) → nobody
assignee: nobody → Christian Giordano (nuthinking)
John Lea (johnlea) on 2011-11-26
description: updated
Changed in ayatana-design:
status: Triaged → Invalid
Matthew Paul Thomas (mpt) wrote :

Alex Korobkin, the DVD region problem seems to be bug 502426 (though it doesn't have steps to reproduce at the moment). If it's common, maybe its solution should be designed in tandem (e.g. part of the same alert box).

Alex Korobkin (korobkin) wrote :

Milan: I haven't tested it with 11.10, because it is difficult to find a DVD drive with a region not yet set, but it definitely was the case with 11.04 which I tested with a new drive.

no longer affects: ayatana-design
no longer affects: hundredpapercuts
no longer affects: libdvdnav (Ubuntu)
no longer affects: libdvdread (Ubuntu)
no longer affects: libgimme-codec (Ubuntu)
Ekimia (u-contact-ekimia-fr) wrote :

Still present in Ubuntu 14.04. it's a pity that we cannot at least explain to the user how to play his DVD, even if it means redirect him to a paying solution like fluendo like a Windows User would see.

description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.