External audio device shows up in the sound output options but the sound keeps being emitted from the internal laptop speaker, or none at all.

Bug #1866194 reported by Pierre Equoy on 2020-03-05
324
This bug affects 52 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
pulseaudio (Ubuntu)
Status tracked in Groovy
Focal
High
Daniel van Vugt
Groovy
High
Sebastien Bacher

Bug Description

[Impact]

Selected audio output device in Settings is ignored after upgrading to Ubuntu 20.04.

[Test Case]

Start with an older version of Ubuntu like 19.04 or 19.10 and upgrade to 20.04. When done, attempt to connect a Bluetooth or USB audio device and use it via Settings.

[Regression Potential]

Unknown/low. The fix is from upstream and has already been released to Ubuntu 20.10 without any problems. Only worth noting it works by detecting and removing audio configurations made via older versions of PulseAudio. So upon upgrading some old settings may be reset to defaults, but the idea is that's less bad than audio devices being unusable (this bug).

[Original Bug Report]

Ubuntu version: focal dev
Kernel version: 5.4.0-14-generic #17-Ubuntu SMP Thu Feb 6 22:47:59 UTC 2020
Pulseaudio: 1:13.99.1-1ubuntu1
Device CID: 201704-25503

Steps to reproduce:

1. Connect an audio interface. I tried with BT headphones and speakers as well as a USB microphone/output.
2. Make sure it's the one selected as "Output device"
3. Click "Test"
    -> the test sound outputs from the internal laptop speakers (NOK)
4. Select "Speakers - Built-in Audio" as Output device and click "Test"
    -> the test sound outputs from the internal laptop speakers (OK)
5. Try to switch back to the BT device and click Test
    -> same result as in step 3

Tested with 2 different BT devices (one headset and one speaker) as well as a USB audio interface (Zoom H2N microphone).

Attached are btmon logs captured during the procedure described above, and pactl logs capture after step 7.

I was previously using 19.04 and 19.10 on this device and never experienced this kind of issue.

Up to this morning, it was harder to connect the BT device, but once connected, the sound would output on it as expected. Now, the BT connection seems to work better, but I can't output the sound to the BT device...

I tried to reboot the device, and also to suspend/resume, but in each case, the BT device can connect back, but the sound is still output from the internal laptop speakers, even when the BT device is selected in the Sound settings.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: pulseaudio 1:13.99.1-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pieq 1566 F.... pulseaudio
 /dev/snd/pcmC0D0c: pieq 1566 F...m pulseaudio
 /dev/snd/pcmC0D0p: pieq 1566 F...m pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Thu Mar 5 22:15:50 2020
InstallationDate: Installed on 2020-01-17 (48 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200116)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/23/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.14.0
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.14.0:bd04/23/2019:svnDellInc.:pnInspiron7370:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 7370
dmi.product.sku: 07E9
dmi.sys.vendor: Dell Inc.

Pierre Equoy (pieq) wrote :
Pierre Equoy (pieq) wrote :
Pierre Equoy (pieq) wrote :
Pierre Equoy (pieq) wrote :
description: updated
description: updated
Pierre Equoy (pieq) on 2020-03-06
tags: added: ce-qa-concern rls-ff-incoming
tags: added: a2dp
Ken VanDine (ken-vandine) wrote :

This might be more of an issue with handing sound devices being added and removed that being bluetooth specific. Last week I experienced the same behavior when plugging in my USB headphones. Removing them and plugging them in again worked though. I haven't been able to reproduce this today though. I'll keep trying and report back.

Pierre Equoy (pieq) wrote :

Thanks a lot for the input, Ken!

You were right, it is not related to BT, but to the sound devices being added and removed.

I happend to have a Zoom microphone that can be connected as USB and creates a new audio interface (both input and output). Here are my new tests and findings:

1. Plug the Zoom USB device
-> it appears in the Sound Settings Output Device and is automatically selected
2. Press Test and check the sound output
-> the sound outputs on the internal speakers (NOK)

After some investigation using pactl, I found how to fix the issue, for both the USB audio interface and the Bluetooth speaker:

1. Make sure the audio interface you want is connected (in my case, I connected both the USB and the Bluetooth speaker):

$ pactl list short sinks
1 alsa_output.pci-0000_00_1f.3.analog-stereo module-alsa-card.c s16le 2ch 48000Hz SUSPENDED
6 alsa_output.usb-ZOOM_Corporation_H2n_000000000000-00.iec958-stereo module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
7 bluez_sink.88_C6_26_1A_9E_AF.a2dp_sink module-bluez5-device.c s16le 2ch 44100Hz SUSPENDED

2. Play an audio stream, for instance a Youtube video. The output should come from the internal speakers, and can be seen in pactl as well:

$ pactl list short sink-inputs
10 1 16 protocol-native.c float32le 2ch 44100Hz

3. Ask pactl to move the stream to the desired sink (output); for instance, the Bluetooth speaker:

$ pactl move-sink-input 10 7

-> The sound outputs to the Bluetooth device! \o/

However, going back to Sound Settings (where the "Output Device" shows my Bluetooth Speaker) and clicking Test still outputs to the internal speakers....

Do you think it could be a GNOME issue? What should I do next?

summary: - After connecting a Bluetooth headset or speaker, it shows up in the
- sound output options but the sound keeps being emitted from the internal
- laptop speaker
+ After connecting an external output device (USB audio interface,
+ Bluetooth speaker...), it shows up in the sound output options but the
+ sound keeps being emitted from the internal laptop speaker
tags: removed: a2dp

Daniel, could you have a look there to see if that's a known/new issue and if maybe you think is something we should rls target?

Changed in pulseaudio (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → High
Iain Lane (laney) on 2020-03-17
tags: removed: rls-ff-incoming
Daniel van Vugt (vanvugt) wrote :

I recommend making this bug unique to the machine model, and to the peripheral model. Most likely it's only triggered by one of them but while we don't know which it will help to avoid multiple people jumping on board the wrong bug.

I can't seem to reproduce this bug in focal right now, but I do see other bugs sometimes which some people could confuse for this one.

summary: - After connecting an external output device (USB audio interface,
- Bluetooth speaker...), it shows up in the sound output options but the
- sound keeps being emitted from the internal laptop speaker
+ [Zoom USB audio on Dell Inspiron 7370] shows up in the sound output
+ options but the sound keeps being emitted from the internal laptop
+ speaker

I'll unassign myself since I have no way to reproduce this right now.

We may yet group similar bugs with this one in future but generally it's more helpful to deter people from doing that too soon. Otherwise when a bug is declared fixed someone will pipe up and say it's not, when really they've just subscribed to the wrong bug.

Changed in pulseaudio (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Pierre Equoy (pieq) on 2020-03-19
description: updated
Pierre Equoy (pieq) wrote :

Daniel,

this bug is not a duplicate of lp:1850766. In lp:1850766, selecting the output device back and forth is an enough workaround to make it work. Here, doing so doesn't do anything, and the only workaround I found is by manually switching the sink-inputs as I described in comment #7.

Daniel van Vugt (vanvugt) wrote :

Please remember to report the issue upstream:

  https://gitlab.freedesktop.org/groups/pulseaudio/-/issues

and then mention the new bug ID here.

Pierre Equoy (pieq) on 2020-03-24
summary: - [Zoom USB audio on Dell Inspiron 7370] shows up in the sound output
- options but the sound keeps being emitted from the internal laptop
- speaker
+ [Dell Inspiron 7370] shows up in the sound output options but the sound
+ keeps being emitted from the internal laptop speaker
Pierre Equoy (pieq) on 2020-03-24
description: updated
description: updated
tags: added: rls-ff-incomong
tags: added: rls-ff-incoming
removed: rls-ff-incomong
Hui Wang (hui.wang) wrote :

I just tried to reproduce this problem, but couldn't.

Installed the ubuntu 20.04 daily built image on my Lenovo X1 Carbon 7th sudo apt dist-upgrade reboot and check the pulesaudio version, it is 1:13.99.1-1ubuntu1

Paring a bluetooth headset (Sony WL-1000X), it connected successfully check the gnome-sound-setting: the output device is Headset - WL-1000X the configuration is High Fidelity Playback (A2DP Sink)

Click test Front left and Front right, the sound output to my BT headset choose speaker - Cannon point-LP High Definition...(internal speaker), click test front left and front right,the sound output to internal speaker.

Disconnect the BT headset

plug a usb audio bar (one headphone and one microphone)

the output device is automatically changed to USB Speaker - Audio Adapter (Unitek Y-247A) click the test front left and front right, the sound output to usb headphone manually select internal speaker from gnome-control-center, click front left and front right, the sound output to internal speaker.

So looks like everything worked as expected. Didn't reproduce the problem.

Also added my testing result to pulseaudio/issues/832.

Changed in pulseaudio:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu Focal):
status: Confirmed → In Progress
assignee: nobody → Sebastien Bacher (seb128)
tags: removed: rls-ff-incoming
Rob Frohne (frohro) wrote :

As another work around (for those of us doing online lectures to avoid spread of Covid-19) you can use this gnome extension.
https://extensions.gnome.org/extension/906/sound-output-device-chooser/

Daniel van Vugt (vanvugt) wrote :

I can now reproduce this with Bluetooth headphones. And incredibly I can also reproduce the bug using a USB DAC... the same one that didn't have the bug when I tried last in comment #9.

summary: - [Dell Inspiron 7370] shows up in the sound output options but the sound
- keeps being emitted from the internal laptop speaker
+ Audio device shows up in the sound output options but the sound keeps
+ being emitted from the internal laptop speaker
summary: - Audio device shows up in the sound output options but the sound keeps
- being emitted from the internal laptop speaker
+ External audio device shows up in the sound output options but the sound
+ keeps being emitted from the internal laptop speaker

For me, deleting ~/.config/pulse did the trick. All external audio devices work again.

Hopefully it was just an upgrade issue that new installs won't hit?...

Daniel van Vugt (vanvugt) wrote :

Please try deleting your ~/.config/pulse and then also reboot for good measure. Can anyone still reproduce the problem after that?

Changed in gnome-control-center (Ubuntu Focal):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

@Daniel, even if that's the case we need to handle the problem for upgraders

Daniel van Vugt (vanvugt) wrote :

Yeah I wish I kept the old config dir so I could debug gnome-control-center.

summary: External audio device shows up in the sound output options but the sound
- keeps being emitted from the internal laptop speaker
+ keeps being emitted from the internal laptop speaker, or none at all.
Changed in gnome-control-center (Ubuntu Focal):
status: Incomplete → Invalid
Potet (5tein4rne) wrote :

@Daniel, not sure as this has been addressed yet, but I deleted .cache/pulse and rebooted. The issue is still the same.

My setup is listed in bug 1873005 in case anybody's interested.

blusa (corsiandr) wrote :

To put my 2 cents in, audio doesnt' work at all if I plug my analog headphones: it lets me choose what kind of device I am plugging in and then no sound at all.
Could I help somehow?

Jeffrey Bouter (jbouter) wrote :

This bug is affecting me as well, I have a USB pre-amp (which also works as audio card) and sounds emits just fine there. However, when I plug in my headphones directly into my laptop, only sometimes I get the gnome popup asking me what kind of device I plugged in.

When I click "headphones", sound of all applications is properly directed towards my headphones. However, the gnome-settings sound "test" button will still emit audio over my regular speakers. Selecting different audio cards does not resolve anything.

Matěj Valášek (valmatej) wrote :

Is normal that, when is music(sound) play to external speakers and I connect wired headset,music is still playing into the external speakers and into the headset?

Sebastien Bacher (seb128) wrote :

One workaround for upgraded systems having the issue is to remove ~/.config/pulse

Potet (5tein4rne) wrote :

Just noticed a typo in my previous comment, so to make it clear, deleting ~/.config/pulse did not work on my system.

It worked fine in 19.10, after upgrade playback is sent to computer speakers even when a Bluetooth headset is connected and selected as output device. AUX works fine, so does Bluetooth media buttons.

David Bridson (david-bridson) wrote :

I'm experiencing the same problem on a fresh install of Ubuntu Mate 20.04 on a Dell XPS 13 9350.

Sound works correctly using the internal speakers. If you plug in analog headphones to the 3.5mm jack, there is no sound from the headphones or the internal speakers. All relevant options are unmuted in Sound Settings. The Speaker Test exhibits the same behaviour.

Analog headphones worked correctly on this system under 18.04.

Download full text (3.9 KiB)

HI

My problem returned.
When I use analog I run pavucontrol-qt and then I select the correvt input device.

I don't know why but it seems like the default audio selector does not work

[Shaun .T - Chat @ Spike](https://spikenow.com/r/a/?ref=spike-organic-signature&_ts=hc2k8) [hc2k8]

On April 24, 2020 at 21:21 GMT, David Bridson <email address hidden> wrote:

I'm experiencing the same problem on a fresh install of Ubuntu Mate
20.04 on a Dell XPS 13 9350.

Sound works correctly using the internal speakers. If you plug in analog
headphones to the 3.5mm jack, there is no sound from the headphones or
the internal speakers. All relevant options are unmuted in Sound
Settings. The Speaker Test exhibits the same behaviour.

Analog headphones worked correctly on this system under 18.04.

--
You received this bug notification because you are subscribed to a
duplicate bug report (1872146).
https://bugs.launchpad.net/bugs/1866194

Title:
External audio device shows up in the sound output options but the
sound keeps being emitted from the internal laptop speaker, or none at
all.

Status in gnome-control-center:
Unknown
Status in PulseAudio:
New
Status in gnome-control-center package in Ubuntu:
Invalid
Status in pulseaudio package in Ubuntu:
In Progress
Status in gnome-control-center source package in Focal:
Invalid
Status in pulseaudio source package in Focal:
In Progress

Bug description:
Ubuntu version: focal dev
Kernel version: 5.4.0-14-generic #17-Ubuntu SMP Thu Feb 6 22:47:59 UTC 2020
Pulseaudio: 1:13.99.1-1ubuntu1
Device CID: 201704-25503

Steps to reproduce:

1. Connect an audio interface. I tried with BT headphones and speakers as well as a USB microphone/output.
2. Make sure it's the one selected as "Output device"
3. Click "Test"
-> the test sound outputs from the internal laptop speakers (NOK)
4. Select "Speakers - Built-in Audio" as Output device and click "Test"
-> the test sound outputs from the internal laptop speakers (OK)
5. Try to switch back to the BT device and click Test
-> same result as in step 3

Tested with 2 different BT devices (one headset and one speaker) as
well as a USB audio interface (Zoom H2N microphone).

Attached are btmon logs captured during the procedure described above,
and pactl logs capture after step 7.

I was previously using 19.04 and 19.10 on this device and never
experienced this kind of issue.

Up to this morning, it was harder to connect the BT device, but once
connected, the sound would output on it as expected. Now, the BT
connection seems to work better, but I can't output the sound to the
BT device...

I tried to reboot the device, and also to suspend/resume, but in each
case, the BT device can connect back, but the sound is still output
from the internal laptop speakers, even when the BT device is selected
in the Sound settings.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: pulseaudio 1:13.99.1-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu18
Architecture: amd64
AudioDevicesInUse:
USER PID ACCESS COMMAND
/dev/snd/controlC0: pieq 1566 F.... pulseaudio
/dev/snd/pcmC0D0c: pieq 1566 F...m pulseaudio
/dev/snd/pcmC...

Read more...

Pablo Catalina (xkill) wrote :

I had the same problem with a Thunderbolt audio device and BT. I removed .config/pulse and started working fine again.
Not sure if it will fail, but for the moment is working.

Adam Niedling (krychek) wrote :

Does any of you have distorted audio together with this bug?
I'm attaching a sample audio file to show what my system sounds like sometimes.

Original sound:
https://www.youtube.com/watch?v=wDdyn4Kbffs

Sebastien Bacher (seb128) wrote :

The distorted audio sounds like a different issue

Scott Neugroschl (redfloyd11) wrote :

Happens to me (headset recognized but no sound) XPS 13 9380

Kyrylo Bohdanenko (kyrboh) wrote :

Dell Precision 7510

Plugging headphones via AUX (3.5mm jack) disables the sound. Workaround: in pavucontrol switch profile of the default device ("Built-in Audio") from "Analog Stereo Duplex" to "Analog Stereo Output" and back (after switching back, audio in headphones starts working).

After removing ~/.config/pulse (and then rebooting) the workaround no longer works.

Kyrylo Bohdanenko (kyrboh) wrote :

Few more things for my case (Dell Precision 7510). AUX headphones' sound seems to be connected to active input device: switching input devices (headphone mic, built-in mic, dock mic (unplugged)) causes sound to appear in the headphones. Although heavily distorted by noise. But the distortion is not like in Adam's (krychek) case.

Although, getting headphones to work (w/ the distortion) and then logging in and out removes the noise. But touching input device settings in pavucontrol brings the noise (or the original issue) back.

Claudio Nasuti (cnasuti17) wrote :

The same bug affect my system xubuntu 20.04 over a DELL Precision 7510.

Manufacturer: Dell Inc.
Product Name: Precision 7510
Product Version:
Firmware Version: 1.16.3
Board Vendor: Dell Inc.
Board Name: 02H5GH

Kernel release: 5.4.0-29-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

snd_hda_intel
snd_hda_intel

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

 0 [PCH ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdfe48000 irq 141
 1 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdf080000 irq 17

With nominal installation fully updated when plugged-in any headphone no sound at all.

After the update of pulseaudio package as provided by https://launchpad.net/~kaihengfeng/+archive/ubuntu/fix-lp1869819

inserting a cheap no name headphone I'm able to hear the sound even if a rustle in background is present.
Inserting a SADES game headset no sound only distorted noise is audible.
To be noted that the pulsaudio mixer seems to work perfectly, having the headphone jack inserted
I'm able to move the output sound to laptop speakers and move back but without fixing the problem.

Last but not least the same configuration with xubuntu 16.04 worked perfectly.

Fábio Lima (fhl) wrote :

This also affects me!

Ubuntu Focal Fossa updated until right now;
Dell Inspiron 15 5590 Laptop;
Intel® Core™ i7-10510U CPU.

I just use a simple P2 headphone.
When plugged, audio doesn't sound out and mic doesn't capture in until I go to Gnome Control Center > Sound and change to the other input device created besides the default one.

Look this out happening at https://youtu.be/uLwrqPwByNk

Josh D (yummyfishy) wrote :

This also happens on a Dell XPS 9570. My workaround after reboots, or other events that disable the headphone audio, is to run this:

sudo alsactl restore

Then things are back to normal for a while.

Max Waterman (dwater) wrote :

I have a similar problem on my Dell XPS 13 - if I boot the laptop with the headphones (3.5mm) plugged in, then it essentially disabled the 3.5mm headphone jack - nothing I've tried re-enabled it again (eg unplugging/replugging the headphone, all the settings, etc). Only a reboot without the headphones plugged in and plugging them in after logging in, fixes the problem.
I don't have this problem on my Lenovo T480s.
Perhaps this is a different problem?

Fabrizio Gennari (fabrizio-ge) wrote :

I have a similar problem, but it involves headphones rather than Bluetooth

Cas (calumlind) wrote :

The workaround that worked for me from the pulseaudio #832 bug:

    mv ~/.config/pulse/ ~/.config/pulse.old
    systemctl --user restart pulseaudio

Also the bug has been found and a fix is in review: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/832#note_511010

Daniel van Vugt (vanvugt) wrote :

That's excellent news.

We can't ask for a better result than the PulseAudio developers to offer a direct fix against the original bug report. It hasn't landed upstream yet though so please wait.

salima (heartandwings) wrote :

just checking in to introduce myself.
here is something about my machine:
 salima@inspiron5559:~$ inxi -SMA
System:
  Host: inspiron5559 Kernel: 5.4.0-31-generic x86_64 bits: 64
  Desktop: LXQt 0.14.1 Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine:
  Type: Laptop System: Dell product: Inspiron 5559 v: N/A
  serial: <superuser/root required>
  Mobo: Dell model: 07JM0H v: A00 serial: <superuser/root required>
  UEFI: Dell v: 1.2.0 date: 05/20/2016
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-31-generic

about 3 years ago i bought the laptop, loaded with ubuntu, but i switched to lubuntu 14 which i had been using on the hcl desktop. the internal speakers are useless so i added f&d speakers with subwoofer. great sound! i had switched to 16.04 and had no problems with it on the laptop either. i got delayed in upgrading to 18 so i dont know what would have happened.

i recently upgraded to lubuntu 20.04 after testing with the live cd to make sure the wifi and sound connected. everything was fine. so i did a fresh install, but after that i had only internal speakers. i also tried my phillips headphones and they too had no sound. (i havent used bluetooth)

after installing the lxde desktop to 20.04, i was watching both versions of pulseaudio while i was experimenting with the settings. i could see them change in both windows. it seemed like they did what they ought to, but sound only came out through internal speakers.

i think my problem is this bug. all i have done so far is try to see what is happening. dell seems to have too many issues, so if anyone knows of any other make and build that this dist works good on, please let me know.

Pierre Equoy (pieq) wrote :

Hi Salima,

this bug has been identified as happening only for people who were upgrading from a previous version of Ubuntu (that came with a previous version of Pulseaudio). Daniel Van Vugt found a workaround (check comments 18 and 19 above), and a fix has been made by the Pulseaudio developers and is being reviewed (see comment 41 above).

In your case, it seems the issue happens on a fresh install, so I believe this issue is different. Please file a new bug for this.

Thanks!

Changed in pulseaudio:
status: New → Fix Released
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Committed
tags: added: fixed-in-13.99.2 fixed-upstream
no longer affects: gnome-control-center (Ubuntu Focal)
no longer affects: gnome-control-center (Ubuntu)
no longer affects: gnome-control-center
Daniel van Vugt (vanvugt) wrote :

Although the upstream fix claims to require packaging changes. So that's not quite a "Fix Committed". More work is required in Ubuntu after we get the next upstream release into git.

Changed in pulseaudio (Ubuntu Groovy):
status: Fix Committed → In Progress
salima (heartandwings) wrote :

hello pierre-
i wrote out the new bug report (#1881783).

good luck and thanks for all the hard work, it is appreciated.
salima

Daniel van Vugt (vanvugt) wrote :

Actually I think this bug comes and goes randomly. Not just on upgrades. So it's possible bug 1881783 is still this bug.

Marcos Alano (mhalano) wrote :

I had this problem these days. I wasn't upgrading, I was just migrating my /home user data around on ZFS. To fix I did the same thing, deleted the ~/.config/pulse directory.

salima (heartandwings) wrote :

The only time i got sound from my speakers is when i was using the live pen drive to test to make sure i had sound. i checked all i had-you tubes, mp3's, mscz, flv...on two different occasions. everything worked fine. i did the install and nothing after that.

except for One Night some time after the install...i swear they worked, and i listened to music four hours. the next time i logged in they were gone again and never came back. i thought maybe some update had been done and then it had to be removed, dont know what to think.

i didnt try the config thing because i was of the understanding that it wasnt a permanent fix-not to mention the fact that i am scared of messing with config files.

by the way, i never had the problem of 'no sound' described in the bug report, i always had the internal speakers.

Changed in pulseaudio (Ubuntu Focal):
milestone: none → ubuntu-20.04.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:13.99.1-1ubuntu6

---------------
pulseaudio (1:13.99.1-1ubuntu6) groovy; urgency=medium

  * debian/patches/git_config_upgrade.patch:
     -stream-restore: Forget pre-14.0 stream routing, old configurations are
      incompatible and create routing issues where e.g the speaker despite
      having headset selected (lp: #1866194)
  * debian/rules:
    - enable --enable-stream-restore-clear-old-devices
  * debian/rules:
    - don't let tests fail build on riscv

 -- Sebastien Bacher <email address hidden> Wed, 03 Jun 2020 17:28:51 +0200

Changed in pulseaudio (Ubuntu Groovy):
status: In Progress → Fix Released
Carl Greco (carl-greco) wrote :

The pulseaudio installed on my Ubuntu 20.04.1 systems is the following:
pulseaudio - 1:13.99.1-1ubuntu3.5
deleting ~/.config/pulse and reboot fixed the problem of sound being directed to builtin speakers instead of the headphones although headphones were selected as the output device. Verified this on a Dell XPS labtop and an AMD desktop. Until 1:13.99.1-1ubuntu6 is released, I recommend deleting the config file and rebooting.

John Dixon (jhncondix) wrote :

I have the same problem. I ran Pop!_OS 20.04 from USB and the bluetooth worked fine. And after doing a clean install, bluetooth also worked. But when I did the initial updates, I had the same problem: device appeared in settings and connected, but no sound. Something in the initial updates messed things up.

Daniel van Vugt (vanvugt) wrote :
Changed in pulseaudio (Ubuntu Focal):
assignee: Sebastien Bacher (seb128) → Daniel van Vugt (vanvugt)
milestone: ubuntu-20.04.1 → focal-updates
status: In Progress → Fix Committed
Sujit Kumar (therealsujitk) wrote :

I have the same issue. When will it be fixed?

Sujit Kumar (therealsujitk) wrote :

Like, when will the next milestone be released?

Daniel van Vugt (vanvugt) wrote :

No timeframe, but the fix is concretely queued up in the update *after* the next update.

Daniel van Vugt (vanvugt) wrote :

But you don't need to wait for the update. You can fix it yourself by removing:

  ~/.config/pulse

and restarting. If that doesn't work then please open a NEW bug and mention it's different to this one.

Sujit Kumar (therealsujitk) wrote :

Hi Daniel! are you sure I can just delete that folder? Will Ubuntu automatically download a later version?

Sujit Kumar (therealsujitk) wrote :

Can I not just update thee package using terminal?

Daniel van Vugt (vanvugt) wrote :

There is no update available right now. And yes you can just delete that folder because it gets recreated automatically.

description: updated
Daniel van Vugt (vanvugt) wrote :

Debdiff for focal SRU.

Sujit Kumar (therealsujitk) wrote :

Daniel, I deleted the pulse folder (~/.config/pulse) like you said and restarted my laptop, but the bug is still present. When I turn on headset, it says "Connected" and my laptop says it's connected in Bluetooth settings, but the audio still comes out of the laptop speakers, I have to disconnect and reconnect the headset from settings to get the audio to go to it.

Hello Pierre, or anyone else affected,

Accepted pulseaudio into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:13.99.1-1ubuntu3.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
Sujit Kumar (therealsujitk) wrote :

I enabled focal-proposed updates and upgraded 119 packages and installed 5 new ones. So far I can't see any major bugs that breaks my system so that's good, however the pulseaudio bug isn't fixed for me.

    Unpacking pulseaudio (1:13.99.1-1ubuntu3.7) over (1:13.99.1-1ubuntu3.6)

This was a line while upgrading in terminal, so pulseaudio is in 1:13.99.1-1ubuntu3.7

When I turn on headset, it says "Connected" and my laptop says it's connected in Bluetooth settings, but the audio still comes out of the laptop speakers, I have to disconnect and reconnect the headset from settings to get the audio to go to it. This was the bug I faced before as well.

Daniel van Vugt (vanvugt) wrote :

Sujit, your comments #62 and #64 suggest you are experiencing a different bug. Mostly because deleting ~/.config/pulse should eliminate this bug. If it doesn't then that's a different issue. Please open a new bug.

Daniel van Vugt (vanvugt) wrote :

Well, I've now spent a couple of hours starting from 19.10, upgrading to 20.04, trying to reproduce this bug and then testing the proposed package.

Somewhat predictably I cannot reproduce the bug. But I can confirm the focal-proposed package works well. So that's probably as good a verification as we can get.

Daniel van Vugt (vanvugt) wrote :

Verified on focal using 1:13.99.1-1ubuntu3.7

tags: added: verification-done-focal
removed: verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:13.99.1-1ubuntu3.7

---------------
pulseaudio (1:13.99.1-1ubuntu3.7) focal; urgency=medium

  [Daniel van Vugt]
  * Added d/p/git_config_upgrade.patch to resolve incorrect audio
    device selection (LP: #1866194).
  * Refreshed patches:
    - d/p/0001-alsa-mixer-Recognize-USB-audio-jack-mixer.patch
    - d/p/0036-device-port-queue-CARD-CHANGE-event-before-update-de.patch
    - d/p/0700-modules-add-snappy-policy-module.patch
    - d/p/gitlab_jack_identifier.patch

  [Kai-Heng Feng]
  * d/p/0001-alsa-mixer-Add-support-for-HP-Thunderbolt-Dock.patch
  * d/p/0002-alsa-mixer-Expand-comments-in-the-HP-Thunderbolt-Doc.patch
    Add profile-sets for HP Thunderbolt Dock (LP: #1894606)

 -- Kai-Heng Feng <email address hidden> Fri, 25 Sep 2020 13:00:28 +0800

Changed in pulseaudio (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pulseaudio has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.