After boot, NetworkManager indicator menu only shows four entries

Bug #965895 reported by Tomas Cassidy
842
This bug affects 245 people
Affects Status Importance Assigned to Milestone
ubuntu-nexus7
High
Unassigned
network-manager-applet (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre
Quantal
High
Mathieu Trudel-Lapierre

Bug Description

SRU INFORMATION: see comment 61

After I boot in to the LiveCD environment for Ubuntu 12.04, I click on the NetworkManager icon in the top-right of the screen and it's only showing four items:

--------------------------
| ✓ Enable Networking
| ✓ Enable Wireless
| ---------------------- |
| Connection Information
| Edit Connections...
--------------------------

If I then select the "Enable Networking" or "Enable Wireless" option to disable that interface and then re-enable it, then the NetworkManager populates with all the normal menu items (listing of all WiFi SSID, VPN connection, etc.).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.3.995+git201203152001.04b2a74-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CasperVersion: 1.312
Date: Tue Mar 27 03:23:48 2012
IfupdownConfig:
 auto lo
 iface lo inet loopback
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120325)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Tomas Cassidy (tomas-cassidy) wrote :
description: updated
Revision history for this message
Jeremie Tamburini (jeremie2) wrote :

I have noticed the same situation on a installed and up to date version of Ubuntu 12.04 (32bit).

Clicking the NetworkManager icon only four items were available. But after deactivating and then activating the "Enable Wireless" option, all the items were again available.

I tried to log out and start a new session and also to reboot the system. Everything fine in both cases, the NetworkManager was still showing all the items.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Jan Schürmann (visionfactory.net) wrote :

it's the same for me after upgrading to latest beta of 12.04

Revision history for this message
BubbaJ (azstuenthome) wrote :

It's the same for me in the released and updated version of 12.04. Sometimes after 3-4 minutes, I go back to the menu and all items are there without having to first disable/enable wireless.

Thomas Hood (jdthood)
summary: - WiFi/NetworkManager menu doesn't show all items after booting into
- LiveCD environment
+ After boot, NetworkManager indicator menu only shows four entries
Revision history for this message
Thomas Hood (jdthood) wrote :

Compare bug #1011073.

Karma Dorje (taaroa)
tags: added: quantal
tags: added: running-unity
Revision history for this message
Adam Taylor (tochinoki) wrote :

It's the same for me on a fresh 12.04 install.

Changed in network-manager (Ubuntu):
importance: Undecided → High
Revision history for this message
Karma Dorje (taaroa) wrote :

also affect me after upgrade from 12.04 to 12.10.
it's the same for me on a fresh 12.10 install.

Revision history for this message
Karma Dorje (taaroa) wrote :

`restart network-manager` fixes this

Revision history for this message
dimovnike (dimovnike) wrote :

affects me too on both fresh install 64bit and upgrade 32bit

Revision history for this message
Jim Leinweber (jiml-mail) wrote :

The easiest workaround for this bug I've found is to uncheck "Enable Networking" on the network dropdown, wait a few seconds, and pick "Enable networking". This seems to reliably toggle the missing entries back onto the menus, both wifi and VPN. I see this on multiple ubuntu boxes, particularly starting with 12.04, but not all of them.

Revision history for this message
Evan Huus (eapache) wrote :

I am seeing a very similar issue with the Dropbox indicator applet, and after much experimentation I believe both issues (network-manager and dropbox) are caused by a race condition within libindicate itself. I have opened a libindicate task for this bug, hopefully someone from that project will take a look.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libindicate (Ubuntu):
status: New → Confirmed
Changed in libindicate (Ubuntu):
status: Confirmed → Incomplete
Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → kevin roussel (kroussel2)
Changed in libindicate (Ubuntu):
assignee: nobody → kevin roussel (kroussel2)
Revision history for this message
Evan Huus (eapache) wrote :

Hi Kevin, please don't change the status of the bug without providing an explanation, and please don't assign the bug to yourself unless you plan to provide a fix.

Thanks,
Evan

Changed in libindicate (Ubuntu):
assignee: kevin roussel (kroussel2) → nobody
status: Incomplete → Confirmed
Changed in network-manager (Ubuntu):
assignee: kevin roussel (kroussel2) → nobody
status: Incomplete → Confirmed
Revision history for this message
Simone Lussardi (simone-lussardi) wrote :

This bug is still there and very annoying for an LTS version. Sometimes one is in the middle of a conf call and you just cannot disable/enable the network to make the missing items appear...

On one side, I noted that the bug shows itself 100% of the times when starting the computer with Wireless disabled (hardware switch), while on some rare occasions, with Wireless enabled it does not show. Lenovo T400 here, with iwlwifi driver.

Revision history for this message
Hang Fire (hangfirew8) wrote :

Restarting nm-applet workaround either doesn't display nm-applet or brings it back with VPN still missing. Command line instructions at https://help.ubuntu.com/community/VPNClient do not work for 12.04. This renders 12.04 pretty much useless in our environment.

This bug has been around for a while. Is there any plan to fix it?

Revision history for this message
Hrotkó Gábor (roti-al) wrote :
Revision history for this message
Chris Berst (cberst) wrote :

I am running Ubuntu 12.04 and was not experiencing this problem until I installed the following packages at which time the nm-applet began only showing the stated 4 menu items:

openconnect 3.15-0ubuntu2
libopenconnect1 3.15-0ubuntu2
network-manager-openconnect 0.9.4.0-0ubuntu1
network-manager-openconnect-gnome 0.9.4.0-0ubuntu1

Uninstalling these packages did not return the nm-applet to normal behavior.
The current solution(s) I am using, as described by others, is to either kill/restart nm-applet or toggle the "Enable Networking" menu selection of the applet.

Revision history for this message
Charles Kerr (charlesk) wrote :

our network-manager-applet doesn't use libindicate.

affects: libindicate → libappindicator
affects: libindicate (Ubuntu) → libappindicator (Ubuntu)
Revision history for this message
emptythevoid (emptythevoid) wrote :

This is occurring for me on Ubuntu 12.04 and 12.10 beta (both 32-bit builds).

Revision history for this message
Josep Pujadas-Jubany (jpujades) wrote :
Revision history for this message
Damir Butmir (d4m1r2) wrote :

Same issue with Ubuntu 12.04 LTS x64, with a hardwired desktop. Happens about 50% of the time on startup, but I have actually recently noticed that it might be fine at startup, but appear hours later as well....Created a thread on it on ubuntuforums.org for those interested (http://ubuntuforums.org/showthread.php?p=12278500).

Every time I see it, I go to my terminal and "sudo service network-manager restart" and it fixes it....

Linux damir-ubuntu 3.2.0-31-generic #50-Ubuntu SMP Fri Sep 7 16:16:45 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
Karma Dorje (taaroa) wrote :

strange, but I do not see anymore of this problem on my ubuntu 12.10.

Revision history for this message
Omer Akram (om26er) wrote :

This is very easily reprodicble on my netbook, does not happen on my Ultrabook. Confirmed on both 12.04 and 12.10

no longer affects: libappindicator (Ubuntu)
no longer affects: libappindicator
Changed in network-manager (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
affects: network-manager (Ubuntu Precise) → network-manager-applet (Ubuntu Precise)
Changed in network-manager-applet (Ubuntu Precise):
milestone: none → ubuntu-12.04.2
Changed in network-manager-applet (Ubuntu Quantal):
milestone: none → quantal-updates
Changed in network-manager-applet (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-applet (Ubuntu Quantal):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-applet (Ubuntu Precise):
status: Confirmed → In Progress
Changed in network-manager-applet (Ubuntu Quantal):
status: Confirmed → In Progress
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/965895

tags: added: iso-testing
Revision history for this message
emptythevoid (emptythevoid) wrote :

This is no longer happening on my main laptop with a clean install of 12.04 64-bit, but is still happening on my 32-bit netbook that was upgraded from 12.04

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

I see it often in my upgraded version.

Revision history for this message
Nikolaus Waxweiler (madleser) wrote :

It also happens often on my Netbook that I upgraded to 12.04. Happens rarely on my main desktop that always gets a fresh install.

Revision history for this message
Evan Huus (eapache) wrote :

The similar (identical?) dropbox bug has just been fixed in the latest stable dropbox [1].

Perhaps it's worth pinging them to ask what they changed?

[1] https://www.dropbox.com/release_notes

Revision history for this message
Said Babayev (phoenix49) wrote :

Same thing is happening to me on fresh Ubuntu 12.10 installation (64bit).

Revision history for this message
P Cantwall (p-cantwell) wrote :

This bug affects me on the v12.10 release. It does show again when I run "sudo service network-manager restart" per Damir Butmir.

Revision history for this message
P Cantwall (p-cantwell) wrote :

12.10 amd64. Sigh...

Revision history for this message
Patrick Roskelley (proskelley) wrote :

After being frustrated with NM-Applet not functioning correctly since I upgraded to 12.04, I wondered if it may be part of a larger problem.
I decided to rename the 'panel' directory for xfce4 inside of '/home/<user>/.config/', so that it would reset the defaults of the Panel, and then I rebooted. After that the Indicator Plugin functioned as expected with NM-Applet showing the VPN option.

I did not see any mention within this thread of people trying to reset their Panel to default, so I figured my solution may not be a just a fluke just for my configuration.

Revision history for this message
Timothy Arceri (t-fridey) wrote :

Have you compared the old and new config files?

Revision history for this message
Omer Akram (om26er) wrote :

Mathieu, could we please get this SRUed ?

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Do we even have a solution to SRU?

Revision history for this message
Patrick Roskelley (proskelley) wrote :

I've diff'd the xml files in xfconf and don't see much difference, except in the launcher items on the bottom panel. The behavior first occured when I removed the Indicator Plugin and added it back myself.

If you'd like I can remove the Indicator Plugin and add it back myself and archive the two directories (working & broken).
I'm really sorry I forgot to add the 'xfconf' directory as well in my previous post to the list of directories I renamed; which is pretty important.

Revision history for this message
Patrick Roskelley (proskelley) wrote :

I just rebooted this evening and it's back to the same old behavior, so I don't even know what's going on...

Revision history for this message
Patrick Roskelley (proskelley) wrote :

I started looking at what files nm-applet uses on startup and decided to delay the autostart of nm-applet to see if that would fix it.
I editted the following file '/etc/xdg/autostart/nm-applet.desktop' and change the following line from 'Exec=nm-applet' to 'Exec=sh -c "sleep 1; nm-applet" &'.
I have rebooted about a dozen times now and the VPN option has came up everytime.

I have a netbook where I have done the same as my desktop, upgraded from 11.10 to 12.04 to 12.10 and it functions as expected, although I have not removed the Indicator Plugin from the Panel like I did on the desktop.
Is there anything further I can do to replicate the Session from that netbook? I just don't understand why it works there and not on the desktop with what appears to be the same configuration.

Revision history for this message
Timothy Arceri (t-fridey) wrote :

Sounds like a classic race condition.
You probably wont see this on your Netbook as they generally have slow single core processors. This type of race condition is more likely to happen on a multi core computer were one process can starts up faster than another process.

Revision history for this message
palimmo (palimmo) wrote :
Revision history for this message
Bootch (di-man) wrote :

The same issue in Xubuntu 12.10 on netbook. "sudo service network-manager restart", https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1027638/comments/5 does no effect.
"nmcli con list" shows 4 connections:
$ nmcli con list
ИМЯ UUID ТИП ДЕЙСТВ. ВРЕМЕННАЯ МЕТКА
Beeline Mobile phone 1 5cdd8fc6-44ca-48f9-949f-da61bb4fe425 gsm никогда
Beeline Mobile phone fd18ef50-3676-4fbe-8ab2-dec0ee78ea93 bluetooth никогда
Yarga b07a0b03-c7a0-4216-a3d8-532b1f82bf1e 802-11-wireless Вс. 09 дек. 2012 21:21:55
Проводное соединение 1 5c86d7a0-5b63-4aac-92e0-72848d77830f 802-3-ethernet Вс. 09 дек. 2012 21:16:54

Revision history for this message
Veleno (veleno) wrote :

I also used the hint posted in
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1027638/comments/5
tested at first with "sleep 30", then decreased progressively until reached 1, as palimmo did.
Probably the matter is that nm-applet starts up just a bit too early to update/populate correctly its own connection list.

Changed in network-manager-applet (Ubuntu):
milestone: quantal-updates → none
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.6.2+git201211052130.2d666bc-0ubuntu2

---------------
network-manager-applet (0.9.6.2+git201211052130.2d666bc-0ubuntu2) raring; urgency=low

  * debian/patches/rebuild_menu_after_init.patch: Work around issues with
    menu initialization at session start by forcing a first menu update after
    30 seconds. (LP: #965895)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 14 Dec 2012 13:30:28 -0500

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Veleno (veleno) wrote :

Issue reappeared, increased sleep back to 30 seconds while awaiting Precise update release of Mathieu's patch.

Changed in ubuntu-nexus7:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

30 seconds is still a pretty long delay to be updating a menu...

Veleno; have you tested on raring? If so, does it help?

Revision history for this message
Marco (macoviz) wrote :

in my case 5 seconds appear enough

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

It sounds better to try to find what needs to be coordinated and sync on that instead of trying to try to use a timing between these.

Revision history for this message
Veleno (veleno) wrote :

Indeed Marius is right: those sleep are only a mere workaround.
I agree with Mathieu, but any lower setting didn't work so far and I cannot try it in Quantal or Raring due to PAE issues (#930447)
Today I had some spare time to do more tests and actually it's a 15 seconds delay, but with 10 seconds I got a partial change, i.e.:
--------------------------
| Wired Network
| Disconnect
| Auto eth0 (should be "Wired connection 1")
| ----------------------
| Wireless Networks
| wireless is disabled by hardware switch
| ----------------------
| VPN Connections -> Configure VPN
| Disconnect VPN
|(should be <Defined VPN profile(s)>
| Configure VPN
| Disconnect VPN)
| ----------------------
| ✓ Enable Networking
| Enable Wireless
| ----------------------
| Connection Information
| Edit Connections...
--------------------------

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

30 seconds is definitely too slow on the Nexus 7; and probably is on many other devices too.

Of course it's just a workaround, and I'm still looking into the actual issue, but it's not one that is easy to figure out.

Revision history for this message
Juan Carlos Arevalo (jca258) wrote :

Hi everyone, I've read the comment:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1027638/comments/5

He talks about changing the order of the processes, well I've changed the name from /etc/xdg/autostart/nm-applet.desktop to /etc/xdg/autostart/znm-applet.desktop and it did the trick for me.

My machine were not populating the menu every time I boot, at this moment I've rebooted 5 times and the menu was populated 5/5 times.

Sorry about my English, I hope you solve the problem like me.

Revision history for this message
Damir Butmir (d4m1r2) wrote :

I appreciate the workarounds, but I am waiting for an official fix instead of manually adding a delay as a workaround.

My only concern is if we have narrowed down exactly what the problem is caused by and its impact, but why is this bug marked as "fix released"? I believe my Ubuntu install is fully up to date and I have yet to pickup this fix...Anyway I can apply it manually?

Revision history for this message
Juan Carlos Arevalo (jca258) wrote :

Hi Damir,

You can apply my workaround writing on a terminal:

sudo mv /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/znm-applet.desktop

Please if it fix the problem, comment to let us know.

Revision history for this message
Juan Carlos Arevalo (jca258) wrote :

#54
PD: Then you have to reboot

Revision history for this message
Veleno (veleno) wrote :

Tried Juan workaround but on Precise didn't work so rolled back to the ol' sleep worakround.

Revision history for this message
Mikele (mikilion) wrote :

It sound like a problem of the "indicator-application-service".
I tryed to remove the "indicator-application" package, the Network Manager applet is showed as classic style with all items and wireless networks list.

Revision history for this message
emptythevoid (emptythevoid) wrote :

Juan, I tested your workaround on my Ubuntu 12.10 netbook and it corrected the problem. It's certainly doesn't actually fix the problem, but it allows everything to work normally in the meantime. Good work.

Colin Watson (cjwatson)
Changed in network-manager-applet (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
Revision history for this message
Chris J Arges (arges) wrote :
Revision history for this message
Chris J Arges (arges) wrote :
Revision history for this message
Ritesh Khadgaray (khadgaray) wrote :

[Impact]

 * NetworkManager's applet loses its menu.
 * User is unable to connect to wifi, and this affects the usability of Ubuntu

[Test Case]

Boot the system from live cd, and click on the NetworkManager icon in the top-right of the screen and it's only showing four items, and no wifi connections available

--------------------------
| ✓ Enable Networking
| ✓ Enable Wireless
| ---------------------- |
| Connection Information
| Edit Connections...
--------------------------

[Regression Potential]

* I dont see any regression potential

[Workaround]

Click "Enable Networking" or "Enable Wireless" option to disable that interface and then re-enable it, then the NetworkManager populates with all the normal menu items (listing of all WiFi SSID, VPN connection, etc.).

Revision history for this message
Martin Pitt (pitti) wrote :

Precise update uploaded. Unsubscribing sponsors.

description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Tomas, or anyone else affected,

Accepted network-manager-applet into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager-applet/0.9.4.1-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Damir Butmir (d4m1r2) wrote :

Awesome, thanks Brian. And for reference, how long generally before the package will be distributed/visible to us through Update Manager? I'd rather it update my network-manager automatically versus me downloading the package and overwriting my current install manually.

Thanks in advance.

Revision history for this message
Veleno (veleno) wrote :

Please release the fix also in Quantal.
I just updated using fake-pae workaround (issue #930447), and the anomaly is still present. Actually I'm using Gnome and not Unity 2d, which was the WM of choice in Precise and has the issue at first.
Indeed the sleep into autostart script is not quite the solution and sometimes it leads to a strange/inconsistent behavior in VPN connections usage. At first attempt the login box requires both username and group secret. If the window is closed (via Cancel button) and reopened, its behavior is back to normal, asking only for the user secret.
This happens if the VPN connection is invoked "too soon" after the start of nm applet or nm-applet state is not consistent: id est the wired connection appears as "Auto eth0" and not "Wired connection 1" which is the expected text label when the applet is working correctly.

Thanks and Happy Easter to all subscribers :D.

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

So, have people tried the package currently in -proposed on 12.04 and can confirm that it fixes the problem for them?

Revision history for this message
Stephan Springer (geryon) wrote :

Yes, the binary package network-manager-gnome 0.9.4.1-0ubuntu2.2 seems to fix this bug for me.

At least after the first reboot the applet menu is correct, whereas formerly this bug hit me after (almost?) every reboot.

Thanks!

Revision history for this message
James M. Leddy (jm-leddy) wrote :

verification-done based on comment #67

tags: added: verification-done verification-precise-done
removed: verification-needed
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu2.2

---------------
network-manager-applet (0.9.4.1-0ubuntu2.2) precise; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * debian/patches/rebuild_menu_after_init.patch: Work around issues with
    menu initialization at session start by forcing a first menu update
    after 30 seconds. (LP: #965895)
 -- Chris J Arges <email address hidden> Fri, 22 Mar 2013 07:55:29 -0500

Changed in network-manager-applet (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
bowser (bwbernard-wong1) wrote :

The fix doesn't work for me on Precise. Removing indicator-application and the full menu appears again. Also, somehow starting synaptic causes the full menu to appear again.

Revision history for this message
bowser (bwbernard-wong1) wrote :
Revision history for this message
Michael R. Bernstein (webmaven) wrote :

Just experienced this issue for the first time on an up to date 12.04 (32-bit OS, AMD Phenom(tm) II X4 955 Processor × 4, Realtek RTL8111/8168B PCI Express Gigabit Ethernet Controller), so it looks like the latest update is actually *causing* the issue for me.

Killing/restarting the nm-applet works around the issue, but it returns after a reboot.

Revision history for this message
emptythevoid (emptythevoid) wrote :

This does not seem to be a problem with Ubuntu 13.04, but if you've done the fix above where you've renamed /etc/xdg/autostart/nm-applet.desktop to /etc/xdg/autostart/znm-applet.desktop, and then you update from 12.10 to 13.04, you will see two network applets after login. Make sure to remove the znm-applet.desktop file you made to correct this behavior.

Revision history for this message
asala (asala) wrote :

I'm experiencing the bug in 13.04 Raring (upgraded from 12.10), with network-manager 0.9.8.0-0ubuntu6 and network-manager-gnome 0.9.8.0-1ubuntu2. I haven't applied any of the above workarounds.
This is just to say that "This does not seem to be a problem with Ubuntu 13.04" in #74 might not be correct...

Revision history for this message
Veleno (veleno) wrote :

I second #74.
After 13.04 upgrade (not a fresh install, due to 930447) the issue seems resolved.
Rebooted 2 times since now and nm-applet is behaving quite nicely.
I will keep it monitored anyway and give some feedback after a week use.

Revision history for this message
Kim Mason (kim-mason) wrote :

This still occurs in 13.04 on a fully updated system at the current date.

Revision history for this message
Veleno (veleno) wrote :

Confirmed after a week of intensive use, problem is no longer visible on a standard 13.04 Ubuntu installation.

Revision history for this message
Matthew Gregg (mcg) wrote :

I've not seen it since 13.04 was releases. Upgraded system.

Revision history for this message
Fabio Marzocca (thesaltydog) wrote :

I have 2 13.04 systems (desktop and a laptop).
This bug is no more showing in the desktop, but it is still there in the laptop.

Revision history for this message
EliCoten (launchpad-elicoten) wrote :

Just happened to me on 13.04 on a laptop.

Not sure what happened but all of a sudden when I looked a few minutes later all menu items were mysteriously back again?

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Support for Ubuntu 12.10 Quantal Quetzal officially ended on May 16, 2014.

Changed in network-manager-applet (Ubuntu Quantal):
status: In Progress → Invalid
Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Desktop images for nexus 7 is no longer developed.

Changed in ubuntu-nexus7:
status: Triaged → Invalid
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
To post a comment you must log in.