Ubuntu

1002:9553 [Dell Studio 1555] laptop runs hot, shorter battery life, fan always on

Reported by shinyblue on 2010-04-14
284
This bug affects 57 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by squiddy

Bug Description

On Karmic (2.6.31 kernel) my laptop ran silently (no fans unless really put through its paces), had long battery life (3.5 hours), and was cool.

Since upgrading to Lucid beta-2, it runs hot, the fan is always on (from cold start it's off, but quickly comes on and stays on) and battery life is less than 2 hours.

Lucid Kernel: 2.6.32-20-generic #30-Ubuntu SMP Mon Apr 12 15:20:57 UTC 2010 x86_64 GNU/Linux

Laptop: Dell Studio 1555 with ATI graphics (but using OS driver).

Happy to help try things -- be great to get my laptop working properly again!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-20-generic 2.6.32-20.30
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rich 1570 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc500000 irq 22'
   Mixer name : 'IDT 92HD73C1X5'
   Components : 'HDA:111d7675,102802be,00100103'
   Controls : 17
   Simple ctrls : 11
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfc010000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
Date: Wed Apr 14 17:09:00 2010
HibernationDevice: RESUME=UUID=239d369d-8a8a-4e3d-9770-7bb31c74f6af
InstallationMedia: Xubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Dell Inc. Studio 1555
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=edd57646-e882-4fe3-9eaa-68bf2f74ce09 ro quiet splash acpi=noapic
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
RfKill:

SourcePackage: linux
dmi.bios.date: 07/03/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0C234M
dmi.board.vendor: Dell Inc.
dmi.board.version: A07
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd07/03/2009:svnDellInc.:pnStudio1555:pvrA07:rvnDellInc.:rn0C234M:rvrA07:cvnDellInc.:ct8:cvrA07:
dmi.product.name: Studio 1555
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.

shinyblue (shinyblue) wrote :

Me too, Acer Aspire 5535 with ATI Radeon HD3200 running Lucid 64-bit and updated today.

Thanks for taking the time to report this bug and helping to make Ubuntu better.

If you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: New → Incomplete

I've installed 2.6.34rc4 (64-bit version) but it doesn't seem any better.

Just rebooted from Karmic into Lucid and the fan kicked in during bootup. The only major difference between the two is that I'm using fglrx in Karmic and in Lucid it's xserver-xorg-video-radeon which I'm convinced is the problem

shinyblue (shinyblue) wrote :

I've done the mainline test: I used the latest linux-image-2.6.34-999-generic_2.6.34-999.201004132352_amd64.deb

The temperature (TZ02) still rises fast and the fan comes on still.

(By the way, in case it affects it: the linux-headers-2.6.34-999... package would not install because of unmet dependencies. But I can confirm that I did the test using the new kernel because I booted into it and checked with uname -a.)

tags: removed: needs-upstream-testing
shinyblue (shinyblue) wrote :

@notoriousdbp yeah, I'm sure it's that, too. The new (OS) drivers are amazing, performance-wise, but I'm sure they're not scaling the frequency of the GPU according to need. I tried to install rovclock - an app. to under/over clock radeon cards - but that's broken, too! (https://bugs.launchpad.net/ubuntu/+source/rovclock/+bug/493220).

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Chase Douglas (chasedouglas) wrote :

Please test with the 2.6.32-21 kernel. There were some relevant changes from -19 to -20 and then to -21 in the embedded controller code that controls the fans.

Thanks

On 21/04/10 02:21, Chase Douglas wrote:
> Please test with the 2.6.32-21 kernel. There were some relevant changes
> from -19 to -20 and then to -21 in the embedded controller code that
> controls the fans.
>
> Thanks
>
>
Hi Chase

Where can I get that kernel? It's not listed at
http://kernel.ubuntu.com/~kernel-ppa/mainline/

?
thanks,
Rich

On Wed, Apr 21, 2010 at 7:01 AM, Rich <email address hidden> wrote:
> On 21/04/10 02:21, Chase Douglas wrote:
>>
>> Please test with the 2.6.32-21 kernel. There were some relevant changes
>> from -19 to -20 and then to -21 in the embedded controller code that
>> controls the fans.
>>
>> Thanks
>>
>>
>
> Hi Chase
>
> Where can I get that kernel? It's not listed at
> http://kernel.ubuntu.com/~kernel-ppa/mainline/

It's the latest Ubuntu kernel. When you run software update it should
download and install it for you.

-- Chase

I've been using that for a day or two: still same issues.
$ uname -a
Linux reech 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

Does this kernel update do anything about the fact that my laptop is at nearly 70 degrees Celsius by the time my desktop has loaded?

Update - I have upgraded to 2.6.32-21 and the laptop was still running hot by the time it booted up. However I noticed under 'Hardware Drivers' that fglrx has now been made available. I have installed it and the results are significantly better. The only disadvantage is that Plymouth runs in 800 x 600 instead of my native 1366 x 768 but I'll live with that and at least my 6 year-old wont suffer burns to her lap now.

shinyblue (shinyblue) wrote :

Think I broke my chance of fglrx - I upgraded to beta 2 at the time there were loads of dependency ("diversion") problems and it took a lot of hacking to get the thing to go away so that apt would even run. Now jockey doesn't even show it as available. :-/

Anyway, that's off-topic but I'm quite excited by the idea that there could be a open source driver that works well; I think this bug is still important, and I really appreciate that it's been marked as highly important. :-)

Devs: do let me know if I can try anything else!

Couldn't agree more. An open driver will always be a preferred option but it has to perform.

Dugan ONeil (doneil) wrote :

I would like to add that I see the exact same problem on an HP TX2000 which also has the Radeon HD3200 graphics. The fan runs constantly and the battery life is terrible compared to karmic. I am about to try switching to the commercial driver, but agree with the posts above...the OS driver is better! However, I cannot live with this battery life....

nimu (n-mussin) wrote :

I am experiencing the same problem on a dell mini 10v netbook (which does not hava an ati graphics card but intel!). It is getting extremly hot since I upgraded to lucid. What to try?

Scott Garman (sgarman) wrote :

I would like to report that my Dell Latitude D620 with Intel 945GM graphics has been running very warm since my upgrade to Lucid. In my case it seems like the system fan is not coming on as frequently as it used to in Karmic.

Etienne Tourigny (etiennesky) wrote :

I have the same problem on my Toshiba Portege M800 with Core2 duo T5800 and Intel GMA 4500MHD graphics.

The fan rarely comes on, and the temperature is about 10C higher than before upgrade from 9.04.
Under full load, the fan only stars to spin faster at 70C, and even there slower than maximum.

I'm seeing the opposite. Using the open source driver for ATI cards the laptop gets hot straight away and the fan kicks in. Using fglrx (the proprietary driver) I have no trouble at all apart from Plymouth being at a very low resolution. I wonder if we have two separate problems here, one affecting those with ATI and the other affecting those with Intel graphics chips

mexlinux (mcanedo) wrote :

Same problem here on Dell XPS M1330
Intel Graphics Card.

uname -a
Linux xps-mac 2.6.32-21-generic #32-Ubuntu SMP

Finbarr Taylor (finbarrtaylor) wrote :

I have a Dell Studio 1558 Laptop, running Lucid 64 bit full release.#

My laptop fan spins at max constantly. I am not the only one having this problem: http://ubuntuforums.org/showthread.php?t=1470129

Finbarr Taylor (finbarrtaylor) wrote :

One thing I noticed is that the temperature is coming back as 0 degrees at one temp point, and only 26.8C at other:
acpi -V
Battery 0: Discharging, 83%, 01:10:06 remaining
Battery 0: design capacity 447 mAh, last full capacity 364 mAh = 81%
Adapter 0: off-line
Thermal 0: ok, 0.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 100.0 degrees C
Thermal 0: trip point 1 switches to mode passive at temperature 95.0 degrees C
Thermal 0: trip point 2 switches to mode active at temperature 71.0 degrees C
Thermal 0: trip point 3 switches to mode active at temperature 55.0 degrees C
Thermal 1: ok, 26.8 degrees C
Thermal 1: trip point 0 switches to mode critical at temperature 100.0 degrees C
Thermal 1: trip point 1 switches to mode active at temperature 71.0 degrees C
Thermal 1: trip point 2 switches to mode active at temperature 55.0 degrees C
Cooling 0: LCD 8 of 15
Cooling 1: Processor 0 of 10
Cooling 2: Processor 0 of 10
Cooling 3: Processor 0 of 10
Cooling 4: Processor 0 of 10
Cooling 5: Fan 0 of 1
Cooling 6: Fan 0 of 1

Finbarr Taylor (finbarrtaylor) wrote :

Update:

I installed the restricted driver, and everything seems to be perfect now....

Etienne Tourigny (etiennesky) wrote :

Hmm how come I have only 2 trip points (critical and passive), and not an "active" trippoint?

How can I modify these values?

acpi -V
Battery 0: Full, 100%
Battery 0: design capacity 3700 mAh, last full capacity 4021 mAh = 100%
Adapter 0: on-line
Thermal 0: ok, 50.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 104.0 degrees C
Thermal 0: trip point 1 switches to mode passive at temperature 80.0 degrees C
Cooling 0: LCD 0 of 7
Cooling 1: Processor 0 of 10
Cooling 2: Processor 0 of 10

shinyblue (shinyblue) on 2010-05-05
summary: - laptop runs hot, shorter battery life, fan always on - lucid beta2
+ laptop runs hot, shorter battery life, fan always on - lucid

i have ATi radeon 3200HD and default driver (which performs better than the restricted one), and the temp is climbing up. the fan also running all the time.

mexlinux (mcanedo) wrote :

Can my laptop get damaged?
Shouldn't importance of this bug be changed from Hight to Critical?

Is there a workaround (install old kernel, etc)?

squiddy (squiddvault) wrote :

now thats what im affraid of. hoping for bug fix soon because i will not install the restricted driver

As it's a kernel module, you're unlikely to see anything in 10.04 unless anything is backported which as a long term support release is disappointing. So it will probably be in Maverick (of course Fedora 13 or OpenSuse 11.3 may include newer, better drivers in the meantime)

aprianta (kompielemoed) on 2010-05-09
description: updated
squiddy (squiddvault) wrote :

@notoriousdbp, so there will be no fixes on lucid ?

cimh (martin-briscoe) wrote :

Same problem here with lucid kernels from the std repositories ....32-21 & .....32-22

eeepc 901 I vbelieve it has a Intel 950 GMA graphics card

@squiddy, unlikely as Lucid uses the 2.6.32 kernel and will always use the 2.6.32 kernel and I believe the ATI driver and kernel version go hand in hand

(^_^)Smiley (kader-25) wrote :

I have this problem and it seems it still isn´t fixed!
My laptop gets very hot and the battery time is very low, also the fans are full time running. Lol it´s almost like my laptop gonna explode.
I never had this problem wit karmic my laptop was cool and quite.
I hope it can be fixed!
Sorry for my bad English!

(^_^)Smiley (kader-25) on 2010-05-15
Changed in linux (Ubuntu):
status: Triaged → New

Please don't change the bug status without knowing the impact. In changing the status back to new, you are telling the developers there is not enough information for anyone to work on this issue. In the case of this bug, there is enough for a developer to look at the issue and begin working to resolve it.

Thank you.

Changed in linux (Ubuntu):
status: New → Triaged
(^_^)Smiley (kader-25) wrote :

Sorry din´t know that!

nimu (n-mussin) wrote :

The overheating problem occured after an update from 9.10 to 10.04. I decided to reinstall 10.04 what solved any problems for me.

So in my case the upgrade from 9.10 -> 10.04 caused my laptop to constantly overheat but after a fresh install of 10.04 my netbook now works beautifully.

(UNE 10.04 on Dell Mini 10v)

Troken (martin-trokenheim) wrote :

My laptop (HP dv6) run hot, the fans are almost constantly on full speed. I try 10.04 from an USB-stick. Dont want to install before this is solved.

Andy Whitcroft (apw) on 2010-05-20
summary: - laptop runs hot, shorter battery life, fan always on - lucid
+ [ATI Graphics][Lucid] laptop runs hot, shorter battery life, fan always
+ on

This is not exclusive to ATI cards.
I don't have one, and do have this problem.

Andy Whitcroft (apw) wrote :

The issue originally reported appears to be an ATI Graphics specific issue, likely triggered by the new KMS drivers being less sensitive to power consumption on the graphics side and the fans for the GPU are coming on. The other issues specifically those with Intel graphics or those related to upgrades are highly likley different issues. The complexity in separating issues of this nature makes it much more sensible to file an individual bug with all of your symptoms and system information in one place. This allows the triagers and developers to more readily examine the information and make a determination if your issue is one and the same as another and then duplicate the bugs if appropriate. We would rather have too many bugs than not enough.

To this end, if you are not the original reporter of this bug we would appreciate you following the instructions on the page below, which will request you file a new bug and help you gather the right information:

    https://wiki.ubuntu.com/Kernel/Debugging/HighTemperatures

Thanks!

tags: added: kernel-therm
Manoj Iyer (manjo) on 2010-05-24
tags: added: kernel-reviewed
24 comments hidden view all 104 comments
oliver hazard perry (cmp914) wrote :

To Michael B

How did you get fglrx? i tried installing it through synaptic but it isn't working

System > Administration > Hardware Drivers. It should tell you if there's a driver for your card and go and fetch it for you

oliver hazard perry (cmp914) wrote :

I tried that, it says "No proprietary drivers are in use on this system." I'm not sure what to do, but my computer overheated yesterday and now i need the motherboard replaced so i would like to figure this out.

oliver hazard perry (cmp914) wrote :

sorry, I just realized it might be useful to include that the card is ATI mobility radeon x300

oliver hazard perry (cmp914) wrote :

I'm trying that but the hardware drivers method isn't working, it isn't finding any proprietary drivers. the ubuntu x team ppa is also not working, it give this result:
chris@chris-laptop:~$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 643DC6BD56580CEB1AB4A9F63B22AB97AF1CDFA9
gpg: requesting key AF1CDFA9 from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

I had the very problem specified in this bug, with carmic and until recently with and updated lucid. Battery life was just half of the one in Windows, and the laptop got really hot, T0 and T1 reported by acpi were around 55 and 61 C.
I use a lenovo t 500 with an ATI Mobility Radeon 3650. Driver initially was the free Radeon.

Installing and employing the up to date proprietary fglrx 2:8.723.1-0ubuntu4 (lucid updates) 2:8.723.1-0ubuntu3 (lucid) packages via the dpkg resolved my temperature problem. The temp is now down to about 41 - 43 C. And battery lifetime is even better than in Windows :-)

Performance is quite similar, though I still have to verify that. First Impression is nevertheless good.

So maybe it works for some of you guys. The hints here helped me a lot. Thank you.

[Update to the post above] on the proprietary drivers: well the 3D support is really not that good, and the makes the machine kind of slow when it reacts to new windows or switching between applications. On top of that the driver does not work properly with docking stations and additional monitors. Always have to set the right resolution after starting. But I think that would be another bug than this one.

rastl (rastlothers) wrote :

[HP 6540b, Mobility RADEON 4500, 2.6.32-24-generic-pae]
I can confirm that the proprietary driver helps. BUT when I run an application accessing opengl (e.g. fgl_glxgears) the problem is back. The temperature jumps to 85 C from 60 C and fan runs on full speed. The laptop turns off after a while.

bartee (bartee-natarajan) wrote :

I am having same problem. I upgraded from Hardy Heron to Lucid Lynx.

Thinkpad T60
ATI Mobility Radio X1300
Kernel: 2.6.32-24-generic

Using the open driver and laptops gets hot very quickly. Hovers around 75-80C and fan is at full speed. Occasionally the laptop just shuts down. Not good. :(

Unfortunately, AMD stopped supporting the driver for this card. The Catalyst 9.3 driver does not support this kernel version. And the fglrx driver in the repository does not support this card either.

aticonfig returns :No supported adapters detected.

So, I am stuck with the open source driver unless someone has a suggestion that I haven't tried.. Need help on this urgently..

bartee (bartee-natarajan) wrote :

I switched to using the open-source edge driver and the temperature seems to be hovering around 55-68C but the fan is still running fast..

obviously, there was never any real intention of canonical to help us in this case.
The case was openend in April, now we have September, it looks like, that they just waited until 10.10 has been released.

Chen Chen (aflyhorse) wrote :

obviously the 10.10beta did not fix this problem
i tried this version and then build a 2.6.35.5 kernel (newer then what with the beta, with lfs tutorial instruction) myself
and the fan is running constantly again (80% of the time) without fglrx binary

sorry i cannot give out the attachment
for the system will burning down and restart in a few minutes without the ATI proprietary driver

hope for resolving so i can sget my pretty console with 1366x768 again (now, shit 800x600)

While 10.10 is a massive improvement in terms of heat with the ATI driver, it's still nowhere near the levels seen with the proprietary driver. Only thing with the proprietary driver is that you don't get Plymouth looking pretty. Interesting that fglrx became available in hardware drivers the other day.

bartee (bartee-natarajan) wrote :

I don't see any proprietary drivers appear on my laptop. (Thinkpad T60, ATI Mobility Radeon X1300). No fglrx option for for us I suppose: just go back to 8.04/9.10?

I have to say that the Xorg PPA edgers driver does a better job (not great but better) especially with the flag dynpm=1 set in /etc/modprobe.d/radeon-kms.conf

Fan is still crazy fast and temperatures (while playing video) reaches a max of 70C but generally is between 50-60C (quite high but not dangerously so).

Any updates from folks at Canonical??

Maybe your video card has been deprecated by ATI-AMD, i got that it has
stopped supporting for some old cards, which is blamed by many people.
You can go downgrade or compile an older kernel yourself.
(Go ati.amd.com to see which is the oldest version of fglrx still
supported and compile a corresponding kernel.)

PS. my card is ATI Radeon HD4570

On Mon, 2010-09-27 at 21:47 +0000, bartee wrote:
> I don't see any proprietary drivers appear on my laptop. (Thinkpad T60,
> ATI Mobility Radeon X1300). No fglrx option for for us I suppose: just
> go back to 8.04/9.10?
>
> I have to say that the Xorg PPA edgers driver does a better job (not
> great but better) especially with the flag dynpm=1 set in
> /etc/modprobe.d/radeon-kms.conf
>
> Fan is still crazy fast and temperatures (while playing video) reaches a
> max of 70C but generally is between 50-60C (quite high but not
> dangerously so).
>
> Any updates from folks at Canonical??
>

--
Sincerely,
Chen Chen (LunarShaddow) <email address hidden>

Before reading this document, please verify the correctness and
completeness of the digital signature first.

Guarded by:
OpenPGP Key ID: 5A331A5D
and / or
VeriSign Class 1 Individual Subscriber CA - G2:
2F:9B:E5:70:1C:8E:67:15:23:68:0C:2A:66:C4:3A:36

Thanks Chen Chen. But I really don't wish to downgrade. And yes, from my previous post, ATI-AMD has deprecated the ATI Mobility Radeon X1300; So no fglrx option for my card. Hence the urgency to fix this issue.

This article: http://www.phoronix.com/scan.php?page=article&item=amd_r500_power&num=1 published in March of last year is happy with the open source driver on power management. Considers it comparable (or better) to fglrx. And it was tested in the same laptop (Thinkpad T60) that I have. Unfortunately that progress seems to have been stunted with 10.04. :(

Carlos Gonz (carlosjimy) wrote :

Same issue for my Toshiba L300D with a ATI Radeon X1250. Unfortunately it was a deprecated graphic card...
I have the Kernel 2.6.35-5.

metamemetics (metamemetics) wrote :

Same problem.
Dell XPS Studio 16.
ATi Radeon HD3760.

Has occurred in both 10.04 and 10.10, the only thing open could be a single web browser window and a text editor, and the heat, fan speed, battery life is similar to if a modern 3D video game was open in windows7.

metamemetics (metamemetics) wrote :

Switching from default open to proprietary driver fixes for me. Had a previous bad experience with the FGLRX+10.04 so was avoiding using it, but no problems with RadeonHD3760+FGLRX+Ubuntu10.10 so far.

after upgrading to 10.10 and switching back to the opensource driver nothing changed, temp still > 70° and fan was always running.
I know that the new kernel 2.6.35.x has some radeon specific powersaving features implemented, after searching a bit I've found the relevant information. It seems that the default powerprofile is the high one.
It is possible to override this, check the power method:
cat /sys/class/drm/card0/device/power_method
=> should be profile
echo auto > /sys/class/drm/card0/device/power_profile
=> enables auto profile switching, low on bat, high on AC
now check the GPU frequ:
  cat /sys/kernel/debug/dri/0/radeon_pm_info
default engine clock: 550000 kHz
current engine clock: 219370 kHz
default memory clock: 800000 kHz
current memory clock: 249750 kHz
voltage: 900 mV
PCIE lanes: 16

after setting the profile to auto, temp. goes down immediately.

For more detailed description of the power saving functions look at:
http://www.overclock.net/linux-unix/731469-how-power-saving-radeon-driver.html

cheers

bartee (bartee-natarajan) wrote :

Michael,
I upgraded to 10.10 (after a fresh install of 10.04) on my Thinkpad T60 with ATI Mobility Radeon X1300. Kernel: 2.6.35-22-generic-pae

My attempt at:
echo profile > /sys/class/drm/card0/device/power_method

results in No Such File or Directory. (run as root)

Apparently that folder does not allow files to be created in it even as root. I did notice that there seems to be a folder named 'power' in there and some files in it. Perhaps we're not meant to directly touch these but configure it from somewhere else? Might be bleeding edge work-in-progress.. Any ideas or links for updates?

bartee (bartee-natarajan) wrote :

Well, its /sys (the sysfs tree). How does one write to it?

bartee (bartee-natarajan) wrote :

Nevermind, I had disabled KMS. Once I enabled it (radeon.modeset = 1), I see radeon_pm_info and everything else. GPU Temperature at 62C and Fan at 3287 RPM after setting power_method profile/auto as mentioned earlier. Will monitor and provide feedback..

Luca Maranzano (liuk001) wrote :

I've been struggling with this issue since my upgrade to 10.4. I've an HP 8530p with ATI RadeonHD 3650, Ubuntu 64 bit.

Today I did the following and things seem to get better:
- Purged all the fglrx packages from Catalyst 10.10
- Installed Catalyst 10.11 (fglrx version 8.791)
- aticonfig --initial -f
- aticonfig --acpi-services=off
- from the Catalyst Control Center the PowerPlay option is enabled

Now the temperature is like this:
liuk@spock:~$ aticonfig --odgt

Default Adapter - ATI Mobility Radeon HD 3650
                  Sensor 0: Temperature - 49.00 C
liuk@spock:~$ acpi -t
Thermal 0: ok, 16.0 degrees C
Thermal 1: ok, 43.0 degrees C
Thermal 2: ok, 55.0 degrees C
Thermal 3: ok, 24.9 degrees C
Thermal 4: ok, 45.0 degrees C
Thermal 5: ok, 30.0 degrees C

Thermal 2 with 9.10 was always about 50, and before the reinstallation of today, Thermal 2 has always been around 60 or more.

So this could be a good trade off :-)

HTH
Luca

Koopee (koopee1234) wrote :

While Googling around to solve this problem with my Lenovo x100e, I stumbled into some random links about high pitch noise from the computer.

I think the missing sound could relate to this issue. In Windows I hear the high pitch regulator noise and the battery life span is much higher. And I recollect hearing the same sound with some previous version of Ubuntu. Those Ubuntu versions felt like being more power conservative.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/654475
http://forum.tabletpcreview.com/hardware/3516-i-think-i-got-rid-cpu-noise-good-core-duo-please-read.html

Chen Chen (aflyhorse) wrote :

I'm so sorry that I don't think this bug would be fixed until the kernel upstream updated the radeon-related code...
I've tried the latest kernel in my Gentoo dist (2.6.36-r5 I think), but no related problem improved...

Changed in linux (Ubuntu):
assignee: Canonical Kernel Team (canonical-kernel-team) → nobody

My motherboard recently 'died' and I can't discount the possibility that it may have been damaged due to this bug. It's disappointing that the bug has been de-assigned, are we to assume from that that the kernel team don't think there's a problem?

Due to what it would have cost to repair I have now purchased a new laptop and have avoided anything with ATI graphics (which these days is pretty much anything with an AMD CPU) as I don't want to go through all this again

Chen Chen (aflyhorse) wrote :

I installed the fglrx and disabled KMS to cool down the laptop
Maybe the kernel team think this is due to the problem of radeon driver developer but not their fault,

trampster (trampster) wrote :

This has a very high chance of DAMAGING HARDWARE and so should be given the highest possible priority.

My Dell Studio 1555 runs about 30 degrees hotter while idle using the opensource radeon driver then when using the FLGRX driver. If I actually use my laptop (playing games etc) the temperature goes straight into very unsafe territory .

The default ubuntu configuration for ATI Mobility Radeon cards is most likely permanently damaging peoples computers. I can't think of something higher priority then this (apart from it killing small children).

trampster (trampster) wrote :

Sorry I didn't say but this problem happens on ubuntu 10.10 and 10.04 for me.

Sandor Kiss (skiss) wrote :

Try Michael B's suggestion in post #85.
Based on his comments, I run the following command to reduce the GPU frequency (power and heat):

echo low | sudo tee /sys/class/drm/card0/device/power_profile

That drops the temperature for me significantly (by 10-25C).

Bassu Khan (bashukhan) wrote :

is a pain in the butt

Chris Halse Rogers (raof) wrote :

It should be noted that setting the “low” profile (as suggested by “echo low | sudo tee /sys/class/drm/card0/device/power_profile”) is not guaranteed to actually work at all. There are a large number of cards which cannot drive a monitor correctly with the lowest clock settings. “medium” should be regarded as the lowest profile that's certain to work.

tags: removed: regression-potential

Fixed installing catalyst driver from amd/ati.

Eugenio Perea (eugenio-perea) wrote :

Same here, Dell Studio XPS 16, HD Radeon 5670: Under 11.10 open source driver works very well except for extremely high temperature and constant, unbearable fan noise. I used the proprietary driver for six months with 11.04, with a lot of problems and tried to use it again this time around, but trying to get Catalyst working with an external monitor broke Unity thoroughly and I was forced to reinstall the entire thing.

Eugenio Perea (eugenio-perea) wrote :

This bug seems to be a duplicate of this one: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/748080

Any update on this?

I have a Dell Studio XPS 1645 with Core i7 720QM and Ati Radeon HD4670 graphics. I tried installing 64-bit versions of Ubuntu 10.04.4. 11.04. 11.10. 12.04 but almost same temperatures and fan state in all.

Installing the latest proprietary driver (catalyst 12.2) helped me reach the following levels, from 10 degrees above these (currently on Ubuntu 11.10 Gnome Shell Remix):

========================================
k4rtik@PlatiniumLight:~$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +26.8°C (crit = +127.0°C)
temp2: +66.0°C (crit = +85.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +65.0°C (high = +84.0°C, crit = +100.0°C)
Core 1: +65.0°C (high = +84.0°C, crit = +100.0°C)
Core 2: +65.0°C (high = +84.0°C, crit = +100.0°C)
Core 3: +66.0°C (high = +84.0°C, crit = +100.0°C)
========================================

========================================
k4rtik@PlatiniumLight:~$ aticonfig --od-gettemperature

Default Adapter - ATI Mobility Radeon HD 4670
                  Sensor 0: Temperature - 68.00 C
========================================

========================================
k4rtik@PlatiniumLight:~$ sudo hddtemp /dev/sda
/dev/sda: ST9500420ASG: 49°C
========================================

These are similar to what I get in Windows, but still slightly higher.

shinyblue, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

summary: - [ATI Graphics][Lucid] laptop runs hot, shorter battery life, fan always
- on
+ 1002:9553 [Dell Studio 1555] laptop runs hot, shorter battery life, fan
+ always on
tags: added: bios-outdated-a13 needs-bisect needs-upstream-testing regression-release
Changed in linux (Ubuntu):
importance: High → Medium
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers