[gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e (xorg crash when opening the laptop lid)

Bug #535640 reported by Nicolò Chieffo
830
This bug affects 138 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
High
Canonical Kernel Team
Lucid
High
Canonical Kernel Team

Bug Description

Binary package hint: xserver-xorg-video-intel

When I close the laptop lid (I have set it to blank the screen, NOT SUSPEND) and open it, the screen remains black for a while, the xorg is killed and gdm restarts.

ProblemType: Crash
Architecture: amd64
Chipset: gm45
Date: Wed Mar 10 11:49:22 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
DumpSignature: de05bf80bf83cd22541cb55f1a2ee99e
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InterpreterPath: /usr/bin/python2.6
MachineType: Dell Inc. Latitude E6400
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu12
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=aefb7f45-2b3b-432f-a5c0-a4900283c338 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xserver-xorg-video-intel
Title: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e
Uname: Linux 2.6.32-16-generic x86_64
UserGroups:

dmi.bios.date: 12/21/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A20
dmi.board.name: 0RX493
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA20:bd12/21/2009:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn0RX493:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
     Subsystem: Dell Device [1028:0233]

Revision history for this message
Nicolò Chieffo (yelo3) wrote :
Bryce Harrington (bryce)
tags: added: crash
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce)
description: updated
Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 535640] Re: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e (xorg crash when opening the laptop lid)

If quickly switching to the VT, Xorg does not crash.
If gnome-settings-daemon is not running, this bug does not exist.

This bug might be related to https://bugs.launchpad.net/bugs/488328

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Nicolò, unfortunately the automatic GPU dumps do not work very well on newer hardware, since a GPU reset is initialized before the dump is taken. In order to get the best logs it would be nice if you could reproduce with the newest drm-intel-next kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/ booted with the kernel option drm.debug=0x02 (after quiet splash), ssh in from another computer and grab /sys/kernel/debug/dri/0/i915_error_state, /var/log/Xorg.0.log, and the output of dmesg (which will have more information than usual, due to the drm.debug=0x02 option). Since this is triggered by the lid close/open, it may be useful to record the output of `sudo intel_reg_dumper` before and after lid close/open and also `sudo intel_gpu_dump` before you close the lid.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

Where can I find intel_reg_dumper?

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

> Where can I find intel_reg_dumper?

Sorry, I forgot that intel_reg_dumper hasn't made it into the
intel-gpu-tools package that currently is in Lucid. It was moved there
from the xserver-xorg-video-intel-dbg package, but the Lucid version
of this is new enough that it has been moved out. The best way to get
it now is probably to install intel-gpu-tools - 1.0.2-1~karmic6 from
xorg-edgers PPA
(https://launchpad.net/~xorg-edgers/+archive/ppa/+packages). I have
requested an update of Lucid's intel-gpu-tools because of this [1], so
I should have remembered.

You can also build it from source if you're comfortable with that.
Just get it from
http://cgit.freedesktop.org/xorg/app/intel-gpu-tools/snapshot/intel-gpu-tools-bfc2b5306fac21bda5fc09dbf031716fd53a0f78.tar.gz,
unpack it, run autogen.sh and make. Then you will find the program in
the tools subdirectory. Or you may skip that step for now. The other
files are more important.

[1]: https://lists.ubuntu.com/archives/ubuntu-x/2010-February/000785.html

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

pre.tar.gz = logs before doing anything
closed.tar.gz = logs when the lid was closed
open.tar.gz = logs immediately after the lid was opened

I've not yet added the intel_reg_dumper, so that log is empty now.
tell me if I will need to add it.

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Originally reported by Nicolò Chieffo at:
  https://bugs.launchpad.net/bugs/535640

[Problem]

When the laptop lid is closed, the GPU hangs at MI_WAIT_FOR_EVENT Display Pipe B Scan Line Window Wait Enable (0x01800020). Logs and i915_error_state from drm-intel-next kernel before close, after close, and after open are attached.

[Original report]

Binary package hint: xserver-xorg-video-intel

When I close the laptop lid (I have set it to blank the screen, NOT SUSPEND) and open it, the screen remains black for a while, the xorg is killed and gdm restarts.

If quickly switching to the VT, Xorg does not crash.
If gnome-settings-daemon is not running, this bug does not exist.

ProblemType: Crash
Architecture: amd64
Chipset: gm45
Date: Wed Mar 10 11:49:22 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
DumpSignature: de05bf80bf83cd22541cb55f1a2ee99e
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InterpreterPath: /usr/bin/python2.6
MachineType: Dell Inc. Latitude E6400
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu12
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=aefb7f45-2b3b-432f-a5c0-a4900283c338 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: xserver-xorg-video-intel
Title: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e
Uname: Linux 2.6.32-16-generic x86_64
UserGroups:

dmi.bios.date: 12/21/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A20
dmi.board.name: 0RX493
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA20:bd12/21/2009:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn0RX493:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-16-generic (with drm from 2.6.33)

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
     Subsystem: Dell Device [1028:0233]

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34169)
dmesg before closing lid

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34170)
Xorg.0.log before closing lid

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34171)
intel_gpu_dump output before closing lid (gzipped)

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34172)
dmesg (with drm.debug=0x02) after closing lid

Unfortunately, the beginning is missing, since the log has been filled with [drm:i915_add_request] lines.

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34173)
i915_error_state after lid close

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34174)
Xorg.0.log after closing lid

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34175)
intel_gpu_dump output after closing lid (gzipped)

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34176)
intel_error_decode output on the previously attache i915_error_state (gzipped, lid closed)

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34177)
dmesg (with drm.debug=0x02) after opening lid

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34178)
dmesg (with drm.debug=0x02) after opening lid

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34179)
i915_error_state after lid open

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Created an attachment (id=34180)
Xorg.0.log after opening lid

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Thank you for including the attached information in a very ordered fashion. It is clear from the files that the problem arises once the lid closes and not later when it opens. I have forwarded your bug upstream to the intel developers at https://bugs.freedesktop.org/show_bug.cgi?id=27146 . Please register at bugs.freedesktop.org and add yourself to the CC field of the bug report so that you can answer any questions the developers might have.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Nicolò Chieffo (yelo3)
tags: added: regression-potential
Revision history for this message
Robert Hooker (sarvatt) wrote :

This is due to a patch which got dropped when we merged 2.6.33 drm into the 2.6.32-16 kernel.

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commit;h=7b56712ff524ee55e38afaee3954d125f56a6070

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Revision history for this message
Robert Hooker (sarvatt) wrote :

Previously linked git commit in patch format.

Revision history for this message
Robert Hooker (sarvatt) wrote :

Sorry for that previous message, attached a patch to the wrong bug and removed it. What I said in comment #8 does still apply to this bug.

Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 535640] Re: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e (xorg crash when opening the laptop lid)

Robert, the patch in the commit you linked is very simple:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commitdiff_plain;h=7b56712ff524ee55e38afaee3954d125f56a6070;hp=104e76612666b063513cb7e12423d2c7117bfcc4

Can someone build a kernel without that patch applied, so I can test
if it works?
I currently have only 200MB free, so I'm unable to compile the kernel.

Changed in linux (Ubuntu Lucid):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Revision history for this message
In , unggnu (unggnu) wrote :

*** Bug 27267 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

The current (hanging) batchbuffer for this bug is (from running intel_error_decode on i915_error_state captured with drm-intel-next or 2.6.34-rcX kernel)

0x0ad96000: 0x09100000: MI_LOAD_SCAN_LINES_INCL
0x0ad96004: 0x00000384: dword 1
0x0ad96008: 0x09100000: MI_LOAD_SCAN_LINES_INCL
0x0ad9600c: 0x00000384: dword 1
0x0ad96010: 0x01800020: MI_WAIT_FOR_EVENT
0x0ad96014: HEAD 0x54f08806: XY_SRC_COPY_BLT (rgb enabled, alpha enabled, src tile 1, dst tile 1)
0x0ad96018: 0x03cc0600: format 8888, dst pitch 1536, clipping disabled
0x0ad9601c: 0x00000000: dst (0,0)
0x0ad96020: 0x038405a0: dst (1440,900)
0x0ad96024: 0x02522000: dst offset 0x02522000
0x0ad96028: 0x00000000: src (0,0)
0x0ad9602c: 0x00000600: src pitch 1536
0x0ad96030: 0x0360e000: src offset 0x0360e000
0x0ad96034: 0x02000000: MI_FLUSH
0x0ad96038: 0x00000000: MI_NOOP
0x0ad9603c: 0x05000000: MI_BATCH_BUFFER_END

Most of the 50+ automatically reported Ubuntu bug reports that are duplicates to this fail to record this batchbuffer with intel_gpu_dump. In the limited i915_error_state that is captured with the Ubuntu kernel, one can se IPEHR: 0x01800020 (header of last instruction) in all those reports.

This last instruction MI_WAIT_FOR_EVENT (Display Pipe B Scan Line Window Wait Enable) may (or may not) be related to the lines in dmesg output:

[ 3188.322798] [drm:gm45_get_vblank_counter], trying to get vblank count for disabled pipe 0
[ 3188.532922] [drm:gm45_get_vblank_counter], trying to get vblank count for disabled pipe 1

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

At https://bugs.freedesktop.org/show_bug.cgi?id=27146:
> Hardware: x86-64 (AMD64)
But it also appears on x86! See my bug #543519 for details.

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

The difference between x86-64 and x86 is not important here. What is more important is that you have a i945 chipset, and this bug only seems to happen on i965 and gm45 (which is somewhat a i965+).

This bug always hangs in this batchbuffer:

0x0ad96000: 0x09100000: MI_LOAD_SCAN_LINES_INCL
0x0ad96004: 0x00000384: dword 1
0x0ad96008: 0x09100000: MI_LOAD_SCAN_LINES_INCL
0x0ad9600c: 0x00000384: dword 1
0x0ad96010: 0x01800020: MI_WAIT_FOR_EVENT
0x0ad96014: HEAD 0x54f08806: XY_SRC_COPY_BLT (rgb enabled, alpha enabled, src tile 1, dst tile 1)
0x0ad96018: 0x03cc0600: format 8888, dst pitch 1536, clipping disabled
0x0ad9601c: 0x00000000: dst (0,0)
0x0ad96020: 0x038405a0: dst (1440,900)
0x0ad96024: 0x02522000: dst offset 0x02522000
0x0ad96028: 0x00000000: src (0,0)
0x0ad9602c: 0x00000600: src pitch 1536
0x0ad96030: 0x0360e000: src offset 0x0360e000
0x0ad96034: 0x02000000: MI_FLUSH
0x0ad96038: 0x00000000: MI_NOOP
0x0ad9603c: 0x05000000: MI_BATCH_BUFFER_END

even though most of the automatically reported bugs failed to capture this information. One trace of it is in i915_error_state:
IPEHR: 0x01800020
(the instruction before HEAD in the batchbuffer) and that is not the case in bug 543519.

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Sorry, looked at the wrong file. You have IPEHR: 0x01800020 in you i915_error_state, so it may be the same bug.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

I don't know really what it is.
Karmic sometimes also didn't come back from sleep, but (it's strange) only when ndiswrapper (WiFi drivers) was installed. Also it sometimes didn't boot correctly, and crashed somewhere between splash and xsplash.
(I have Lucid as new installation)

Revision history for this message
Jonathande2 (jonathan-slob) wrote :

have same bug on a gm965

Revision history for this message
Christopher Neville-Smith (chris-neville-smith) wrote :

Not sure if you're getting sick of Me Too comments yet, but if not, same here on Dell Insprion 6400 with Lucid Beta 1.

Revision history for this message
Boris (boris-woerner) wrote : Re: [Bug 535640] Re: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e (xorg crash when opening the laptop lid)

I'm having the same problem here, Dell Latitude D610.
OS is Lucid 32 bit.

Regards
 Boris

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Please don't add "me too" comments. They only contribute to making the bug report harder to read. Use the green link at the top to register that this bug affects you. If you want to provide more information, you can do it in a separate bug report and mark it as duplicate to this one (but we have more than enough already).

Revision history for this message
Robert Hooker (sarvatt) wrote :

The fix is commited and will be released in the 2.6.32-19 kernel shortly.

Changed in linux (Ubuntu Lucid):
status: Triaged → Fix Committed
Revision history for this message
Robert Hooker (sarvatt) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

 [ Andy Whitcroft ]

 * [Config] enable various multitouch devices
   - LP: #541453

 [ Chase Douglas ]

 * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
   - LP: #545307
 * SAUCE: Disable function tracing after hitting __schedule_bug
 * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
   cleanup
   - LP: #440470

 [ Jesse Barnes ]

 * SAUCE: drm/i915: don't change DRM configuration when releasing load
   detect pipe
   - LP: #488328

 [ John Johansen ]

 * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
   - LP: #539437
 * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
   load
   - LP: #458299
 * SAUCE: AppArmor: Return string len rather than the allocation size
   - LP: #551844
 * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
   fails.

 [ Luke Yelavich ]

 * [Config] Enable Nouveau DRM module on powerpc

 [ Stefan Bader ]

 * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
   - LP: #357673
 * [Config] Enable thinkpad-acpi ALSA volume control
   - LP: #357673

 [ Steve Conklin ]

 * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
   - LP: #492392, #539609

 [ Upstream Kernel Changes ]

 * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
   Dell Inspiron 700m"
   - LP: #515246
 * (pre-stable) softlockup: Stop spurious softlockup messages due to
   overflow
   - LP: #551068
 * backlight: mbp_nvidia_bl - add five more MacBook variants
   - LP: #511965
 * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
   - LP: #529130
 * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
   - LP: #544739
 * (pre-stable) USB: fix usbfs regression
 * drm/radeon/bo: add some fallback placements for VRAM only objects.
   - LP: #507148
 * drm/radeon/kms: don't print error on -ERESTARTSYS.
   - LP: #507148
 * Input: add the ABS_MT_PRESSURE event
   - LP: #541453
 * HID: Support for 3M multitouch panel
   - LP: #541453
 * HID: make 3M PCT touchscreen driver standalone config option
   - LP: #541453
 * HID: add support for Stantum multitouch panel
   - LP: #541453
 * HID: make Stantum driver standalone config option
   - LP: #541453
 * HID: add support for Acer T230H multitouch
   - LP: #541453
 * HID: add support for Pixart Imaging Optical Touch Screen
   - LP: #541453
 * HID: fixed bug in single-touch emulation on the stantum panel
   - LP: #541453
 * HID: add pressure support for the Stantum multitouch panel
   - LP: #541453
 * HID: Support for MosArt multitouch panel
   - LP: #541453
 * HID: hid-ntrig add multi input quirk and clean up
   - LP: #541453
 * HID: n-trig: remove unnecessary tool switching
   - LP: #541453
 * HID: hid-ntrig: multitouch cleanup and fix
   - LP: #541453
 * HID: hid-ntrig: Single touch mode tap
   - LP: #541453
 * hid: ntrig touch events
   - LP: #541453
 * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
   - LP: #531309
 * drm/i915: Part of: Add initia...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Steven McCoy (fnjordy) wrote :

This does not fix the 945GM lockup as per bug 546871, it has removed the display instability that 2.6.32-18 introduced.

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

This bug has been marked as fixed downstream. The patch that fixed it was

  [ Jesse Barnes ]
  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commit;h=0d2907f4bead56cff60f91068b3a3efa7149e702

I haven't seen this being applied upstream in linux-2.6.33.y or linux-2.6 git
trees, so I'm not closing this bug yet.

Revision history for this message
In , Chris Wilson (ickle) wrote :

Jesse, that patch is still MIA. However, at work I think we may have a move serious issue, namely we need to ensure that the gpu is idle prior to changing connectors lest we have a pending WAIT.

Revision history for this message
In , Chris Wilson (ickle) wrote :

Because I know Jesse is this ->||<- close to getting this patch upstream. :)

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

(In reply to comment #17)
> Because I know Jesse is this ->||<- close to getting this patch upstream. :)

Last message on the intel-gfx mailing list [1] was that this patch is not needed when the patch "drm/i915: cleanup lvds detection function" [2] is applied. So I suppose it is patch [2] that we will see upstream soon.

[1]: http://lists.freedesktop.org/archives/intel-gfx/2010-July/007383.html
[2]: http://lists.freedesktop.org/archives/intel-gfx/2010-July/007382.html

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

On Sat, 10 Jul 2010 07:47:11 -0700 (PDT)
<email address hidden> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=27146
>
> --- Comment #18 from Geir Ove Myhr <email address hidden> 2010-07-10 07:47:11 PDT ---
> (In reply to comment #17)
> > Because I know Jesse is this ->||<- close to getting this patch upstream. :)
>
> Last message on the intel-gfx mailing list [1] was that this patch is not
> needed when the patch "drm/i915: cleanup lvds detection function" [2] is
> applied. So I suppose it is patch [2] that we will see upstream soon.
>
> [1]: http://lists.freedesktop.org/archives/intel-gfx/2010-July/007383.html
> [2]: http://lists.freedesktop.org/archives/intel-gfx/2010-July/007382.html

No, the cleanup function is separate. If you still see issues with
current 2.6.35-rc and you need to apply the previous "disable unused"
patch, then we have some other issue going on as well.

Revision history for this message
In , Jesse Barnes (jbarnes-virtuousgeek) wrote :

Put another way; is the patch in http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commit;h=0d2907f4bead56cff60f91068b3a3efa7149e702 still required in current (i.e. 2.6.35-rc) kernels?

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

(In reply to comment #20)
> Put another way; is the patch in
> http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commit;h=0d2907f4bead56cff60f91068b3a3efa7149e702
> still required in current (i.e. 2.6.35-rc) kernels?

The Ubuntu 10.10 development version has been without this patch since late May, and we haven't got the storms of bug reports for this issue like we did for 10.04, but then again that started only later in the release cycle when more people started testing. The patch was apparently removed after one person confirmed that the patch was no longer needed for him [1].

We have had one recent bug report with Maverick with the same type of batchbuffer hanging in MI_WAIT_FOR_EVENT after two MI_LOAD_SCAN_LINES_INCL [2,3], but the circumstances seems to be different (watching video) and Chris Wilson has committed a DDX patch [4] which may solve this but it has not been tested yet.

I have asked for verification at the downstream bug report and I will report back here and clear the NEEDINFO flag when/if I get some feedback.

[1]: https://lists.ubuntu.com/archives/kernel-team/2010-May/010602.html
[2]: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/603064
[3]: http://bugs.freedesktop.org/show_bug.cgi?id=28964
[4]: video: apply the crtc box checks from dri. (http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=272d1c14a39c32ade39b5a8b080a891f2b3d6e8e)

Revision history for this message
In , Geir Ove Myhr (gomyhr) wrote :

Nicolò Chieffo, the original reporter has tested the 10.10 development version which is without this patch (and has a kernel based on 2.6.35-rc4), and the problem is gone. I'm marking this as FIXED.

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

The patch that fixed (or rather worked around) this problem in Lucid has not been applied upstream because the developers figure it is not necessary anymore due to some other fixes. The Maverick kernel has been without this patch for quite some time now. Could someone that was affected with this bug test Maverick to verify that this bug has not come back and we can close this bug report?

Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 535640] Re: [gm45] GPU lockup de05bf80bf83cd22541cb55f1a2ee99e (xorg crash when opening the laptop lid)

in maverick it's ok

Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Thank you for testing Nicolò. I will close the upstream bug report.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :
Revision history for this message
Geir Ove Myhr (gomyhr) wrote :

Dmitry, the Ubuntu bug already has status 'Fix Released'. The upstream task should be updated automatically from the upstream task.

Btw, I don't think it was the commit you mentioned that fixed this particular bug, since it has also been working in Maverick before that commit. That commit probably fixes bug 603064, though.

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.