[Upstream] Spell checking doesn't warn users if the selected dictionary isn't installed, but rather returns a potentially incorrect result

Bug #997934 reported by TenLeftFingers on 2012-05-11
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
LibreOffice
Confirmed
Wishlist
libreoffice (Ubuntu)
Undecided
Pooja bn

Bug Description

This has been the case since Beta 2.

To reproduce:

1) Type out a load of rubbish on the keyboard as well as a few correctly spelled words. I used "vmw;qbjk aoeuasnth aoeu house in the street"
2) Press F7 to initiate the spell check.

Actual Result: The spell check notifies the user of completion without any recognition of errors.
Expected Result: The spell check should highlight each misspelled word and offer alternatives.

WORKAROUND: Open the dash and run Language Support
2) Under the 'Language' tab, choose another variant of English and drag it above the US English so it takes precedence.
3) Click "Apply System-wide" and log out.

On logging back in, spell check will work.

Not reproducible in Xubuntu 32-bit.

lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice-writer 1:3.5.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Fri May 11 08:53:51 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcEnviron:
 LANGUAGE=en_IE:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_IE.UTF-8
 SHELL=/bin/bash
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

TenLeftFingers (tenleftfingers) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
TenLeftFingers (tenleftfingers) wrote :

I've just installed IBM Lotus Symphony hoping to work around this issue - but the exact same thing happens.

So either:
1) They both are depending on a service in Ubuntu 12.04 that is not available, or
2) IBM Lotus Symphony is a port of LibreOffice or one of its other incarnations.

TenLeftFingers (tenleftfingers) wrote :

Thanks to Bra|10n over in kubuntuforums.net (although this bug represents an Ubuntu install) I now have a working spell check.

Steps to fix this issue:
1) Open the dash and run Language Support
2) Under the 'Language' tab, choose another variant of English and drag it above the US English so it takes precedence.
3) Click "Apply System-wide" and log out.

On logging back in, spell check will work.

description: updated

possibly related -- same root cause as bug 957589.

Nathan Heafner (nathan1465-5) wrote :

This is also effecting firefox. Firefox doesnt spell check anything, even with updated settings "Check my spelling while i type" and language selected.

Nice one thank you very much worked like a charm.

Dave H (dave-hills-2009) wrote :

This bug affects me using Ubuntu 12.10 and Libreoffice Writer, Version 3.6.2.2 (Build ID: 360m1(Build:2)) .
Fixed by:

sudo apt-get install myspell-en-gb

Suggest myspell-en-gb is included in default Ubuntu install manifest.

Note: I always complete the language support install as in #4, so didn't work for me.

I had the same problem with 12.04, will it be fixed for Raring?

LibreOffice shouldn't pretend to spell check something when it's lacking the dictionary it's been asked to use. It should explicitly tell the user it can't proceed. There are many confused users encountering this issue, from what I've seen on many forum postings and many bug reports that have been submitted here.

LibreOffice should check for the presence of the required dictionary before starting the spell check and provide a meaningful error message if it's not found. Instead the spell check runs and reports no issues were found, which is quite misleading.

(The steps to reproduce are quite simple: just change the associated dictionary of selected text in a document to be any dictionary that isn't installed and run the spell check.)

I'm surprised no one's filed a bug that points this out already, but I couldn't find anything in the bug list. My apologies if I missed something. Responses are typically that users should download the necessary dictionary separately, which is all well and good, but the software itself should be telling them it can't complete the action requested. There'd be fewer duplicate bug reports about missing dictionaries if this was the case.

I should add, I realize there's more than one means to invoke spell checking, since a user could have the "check as you go" feature enabled, or they could explicitly start an interactive spell checking session. At a minimum, I think the latter should pop up a warning indicating it has no dictionary to work with. (And if a document has multiple languages, it could trigger multiple times, so I realize this isn't the simplest thing to make elegant...)

Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date: Tue Feb 25 19:58:48 2014 +0100
Platform: Ubuntu Linux 13.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
High - seems like a useful thing to have for many users, no dictionary should result in some kind of a warning if you try to do a spell check.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing - http://www.libreoffice.org/get-help/mailing-lists/.

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material

Problem description: Having updated to LibreOffice 4.0.1 on Fedora, I noticed that when I try to spell check a document with the English (Australia) dictionary, the spell check appears to function but doesn't do anything. If I were to check a document, it would always say that there are no errors, but when I manually check the document, there are clear spelling errors.

Steps to reproduce:
1. Open new Writer document and change language to English (Australia)
2. Type something with an obvious spelling error in it
3. Run spellcheck

Current behavior: The spellcheck will return no errors. If necessary it will show "continue from top" message, but no errors will be found. (Auto spellcheck also finds no errors.)

Expected behavior: The spellcheck should find the errors in the text and make correction suggestions.

Operating System: Fedora
Version: 4.1.0.4 release

Hello ofperkins83, *,
I cannot confirm your observation with LO Version: 4.1.6.1 Build-ID: a59ce81388f477fc89db57f0c27f222f31884eb (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) with Germanophone lang- as well as helppack) nor with LO Version: 4.3.0.0.alpha0+
Build ID: b7c7bd3de0fdadaf5e4769e0759d68ad17fb7bd0 TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-04-10_02:05:19 with installed en_US lang- as well as helppack under Debian Testing i686 ... :(

But as I only have learned British English in the past: Would you be so kind to attach a test document to this bug, please? And/or test it with a newer version than 4.1.0.4, please?

I have tested it this way:
1. "Tools – Language – For all Text – More..."
2. Selected "English (Australia)" at the dropdowmn menu "Western" below the header"Default language for document"
3. Closed the dialog
4. Entered a short German (my mother tongue) sentence and also the sentence "For colourful people you should use a color without a hidden meaning. (Maybe a really horrible sentence ... ;) )

I get "color" marked as wrong here. Could you confirm, that it is wrong in Australian English?

BTW: Is your version the one, which is provided with Fedora? If so, I think it is better to report a bug to their bugtracker and to their version of LO ... ;)

Sorry for the inconvenience
Thomas.

(In reply to comment #1)
> Hello ofperkins83, *,
> I cannot confirm your observation...

I can confirm the bug. The latest stable Mac OS X build is affected:
Version: 4.1.6.2
Build ID: 40ff705089...

>
> But as I only have learned British English in the past: Would you be so kind
> to attach a test document to this bug, please?

You can reproduce the problem by creating a new document and typing some garbage. The spell checker can find no problem and it always reports "Spell check complete."

The spell checker behaves exactly the same when you change the document language to "None" as when you change it to "English (Australian)".

> I get "color" marked as wrong here. Could you confirm, that it is wrong in
> Australian English?

Australian English is the same as British English (ignoring idioms). "Color" is the U.S. spelling. In Australia and the U.K. the spelling is "colour".

So one workaround is to switch the default language to English (U.K.) in settings. But changing the default may not help for documents already saved with language "English (Australian)".

has situation improved in 4.2.x?

(In reply to comment #3)
> has situation improved in 4.2.x?

We had to abandon 4.2 due to interoperability issues with Microsoft Office.

I can't speak for the original reporter of this bug on Fedora, but I think in my case this is partly user error.

I did some more research (that is, I actually RTFM) and the problem is that no dictionary is present for the default language, i.e. English (Australia).

By reading the manual, I discovered that a peculiar tick symbol having the letters ABC would indicate the presence of a dictionary. This appears to be a user interface failure. I doubt that any readily understood symbol conveys "no dictionary present" so why not just put the words there instead?

I tried to install an English (Australian) dictionary using the Tools -> Language -> More Dictionaries Online command. No additional English dictionaries were available from extensions.libreoffice.org for 4.1.

So we will keep using the English (UK) language default as a workaround.

(In reply to comment #4)
> (In reply to comment #3)
> I can't speak for the original reporter of this bug on Fedora, but I think
> in my case this is partly user error.
>
> I did some more research (that is, I actually RTFM) and the problem is that
> no dictionary is present for the default language, i.e. English (Australia).
>
> By reading the manual, I discovered that a peculiar tick symbol having the
> letters ABC would indicate the presence of a dictionary. This appears to be
> a user interface failure. I doubt that any readily understood symbol conveys
> "no dictionary present" so why not just put the words there instead?

This is absolutely right. I did not realise that the appropriate dictionary was not installed. I found the appropriate language package on the Fedora repos (I don't remember what it was called) and was able to install it. The spellcheck worked well after that. But I do agree - at the very least, when the spellcheck is run with a language that has no spellcheck dictionary, I think it should return and say "no dictionary installed" rather than just "spellcheck complete".

It's a common bug both here and on Ubuntu's bug tracker. Users for whatever reason do not have any dictionaries installed, but spellcheck still runs fine checking nothing.

https://bugs.freedesktop.org/show_bug.cgi?id=81569
https://bugs.freedesktop.org/show_bug.cgi?id=76238
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/997934

To reproduce I used a cloud instance, removed aspell and hunspell (using aptitiude), and did not install any of these packages:
libreoffice4.3-dict-en_4.3.0.4-4_amd64.deb
libreoffice4.3-dict-es_4.3.0.4-4_amd64.deb
libreoffice4.3-dict-fr_4.3.0.4-4_amd64.deb

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → New

(In reply to ofperkins83 from bug 76238 comment #5)
> This is absolutely right. I did not realise that the appropriate dictionary
> was not installed.... when
> the spellcheck is run with a language that has no spellcheck dictionary, I
> think it should return and say "no dictionary installed" rather than just
> "spellcheck complete".

Sounds like bug 76238 has proposed a similar remedy. Perhaps one of these two should be closed as a dupe of the other?

Status -> NEEDINFO

Changed in df-libreoffice:
status: New → Incomplete

> Sounds like bug 76238 has proposed a similar remedy. Perhaps one of these
> two should be closed as a dupe of the other?
>
> Status -> NEEDINFO

I'm fine with that solution, not sure which one to keep open though..

(In reply to Bryan Quigley from comment #2)
> > Sounds like bug 76238 has proposed a similar remedy. Perhaps one of these
> > two should be closed as a dupe of the other?
> >
> > Status -> NEEDINFO
>
> I'm fine with that solution, not sure which one to keep open though..

Bug 76238 is older, has more comments, and is already triaged to NEW, so that one seems like a reasonable choice, even if this bug is a bit more targeted to the specific problem.

Status -> RESOLVED DUPLICATE

Feel free to make a comment on that bug adding some of the links you provide below; it's very helpful to know that this is a common problem affecting multiple people.

*** This bug has been marked as a duplicate of bug 76238 ***

*** Bug 81921 has been marked as a duplicate of this bug. ***

*** Bug 81569 has been marked as a duplicate of this bug. ***

Changed in df-libreoffice:
status: Incomplete → Invalid
Changed in df-libreoffice:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

*** Bug 76238 has been marked as a duplicate of this bug. ***

Pooja bn (poojan-pn90) on 2015-10-04
Changed in libreoffice (Ubuntu):
assignee: nobody → Pooja bn (poojan-pn90)
assignee: Pooja bn (poojan-pn90) → nobody
assignee: nobody → Pooja bn (poojan-pn90)
Pooja bn (poojan-pn90) wrote :

The attachment "Solution.java" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pooja bn (poojan-pn90) wrote :

Perhaps this could be added to the "easy hacks" list? That is, I don't know if it is an easy job, but as I imagined it, it would just be a check to confirm a selected dictionary is installed when a spell check is invoked, with a message box popping up a warning if the dictionary is missing.

Requesting developer input to get code pointers - I'm not convinced this would be easy as it would have to somehow determine the language of a non-installed package...it sounds pretty daunting to me.

I certainly don't know either, but a typical complaint from users is that they've selected a language from a pre-existing list in LibreOffice that doesn't actually have the given dictionary installed (because the item doesn't have a tick symbol beside it, or what-have-you). Reporting that a list item previously selected/assigned has no actual dictionary installed doesn't seem difficult in theory. (But there is so often a gulf between theory and practice!)

Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]

Update to upstream bug tdf#75734

Changed in df-libreoffice:
importance: Medium → Unknown
status: Confirmed → Unknown
summary: - Spellcheck does not detect any mis-spelled words on 12.04
+ [Upstream] Spell checking doesn't warn users if the selected dictionary
+ isn't installed, but rather returns a potentially incorrect result
Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed

*** Bug 73036 has been marked as a duplicate of this bug. ***

That's a bad idea, as in a multilingual text it will break the spellcheck flow, showing a warning for each piece of unsupported language text.

Yes, quite true, I alluded to that potential problem of a flurry of warnings. But what's also a really bad idea is a software design that claims to have compared two data sets and reports no issues when in fact it failed to do so because it cannot retrieve one of the two sets. Something needs to be done to try and address this, even if it's less than perfect.

Another possibility would be to build a list of any dictionaries the document requires at the time it's loaded and determine if any are unavailable, and if so, provide a single, concise warning. This wouldn't be perfect either, since someone could change to or add a different language while editing, but at least that would be an improvement and might reduce user confusion when the spell check silently fails to work. Or maybe there's a better idea entirely. I don't claim to have all the answers, I just think this merits attention.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.