[Upstream] Writer AutoCorrect does not set superscript on ordinal numbers

Bug #992807 reported by Joshua O'Leary on 2012-05-01
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
libreoffice (Ubuntu)
Medium
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Writer in a blank document is when one types 1st, 2nd, or 3rd the text is converted to superscript automatically.

4) What happens instead is it does not. This is in spite of the options enabled as per screenshot https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992807/+attachment/3125667/+files/lo.png .

O.S: Xubuntu 12.04 LTS. Reproducible in Lubuntu.
I have installed the latest PPA version - 3.5.3-rc2-0ubuntu1~ppa2(precise), still happens.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice 1:3.5.2-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Tue May 1 20:12:16 2012
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
SourcePackage: libreoffice
UpgradeStatus: No upgrade log present (probably fresh install)

In Writer, Tools, Autocorrect Options, format ordinal numbers suffixes, with both M and T selected and saved: when typing into a new or old document, will not raise up the suffix (for example, 2nd will not lift the "nd" higher, as was done on previous versions of libreoffice). Note that in an older (pre-3.4.0) document the suffix will display raised unless it is deleted. Format-Character-Position-Superscript will force the characters to be raised, FWIW.

I too have confirmed this behavior in LibreOffice 3.4.1 OOO340m1 (Build:103).

Text characters of ordinals, such as 1st, 2nd, or 3rd, are NOT formatted as superscripts by autocorrect. I have unchecked and re-checked the Tools->AutoCorrect Options->Localized Options M[ ] T[ ] Format ordinal numbers ans suffixes (1st->1^st) and it does not work at all in writer. It used to work just fine. Dunno what broke it?

Failure to autoformat ordinal suffix still not fixed in 3.4.4

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Linux-specific bug
reproduced in LibO 3.6.0 master on Fedora 64 bit

Joshua O'Leary (jmoleary) wrote :
Joshua O'Leary (jmoleary) wrote :

Btw, I have tried unticking and re-ticking 'format ordinal numbers' under M and T in the libreoffice localised autocorrect options, and the problem still occurs.

summary: - Libreoffice: autocorrect does not set superscript on ordinal numbers
+ Libreoffice (writer): autocorrect does not set superscript on ordinal
+ numbers

This issue seems to be resolved in the 3.5.3 beta downloaded from the Libreoffice website, however this probably won't be packaged in ubuntu for quite some time.

Changed in df-libreoffice:
status: New → Invalid
Joshua O'Leary (jmoleary) wrote :

Could you justify your decision in marking this as invalid. It would be much more helpful - if the package affected should be changed, then say.

Joshua O'Leary (jmoleary) wrote :

Oh, sorry, ignore the last comment, will 3.5.3 be in the next ubuntu?

Joshua O'Leary, LibreOffice Productivity Suite is the upstream task. As per your comment https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992807/comments/3 changing to Invalid is justified as per https://wiki.ubuntu.com/Bugs/Status .

Joshua O'Leary (jmoleary) wrote :

Sorry, my apologies for the misunderstanding. I have done a bit more testing of Libreoffice, and it seems the bug is still present in the libreoffice ppa version 3.5.3, just not in the Libreoffice builds from the website. See attached screenshot. Which version would get finally merged into ubuntu - the ppa version, or the builds from Libreoffice.org?

Joshua O'Leary (jmoleary) wrote :

Dialog showing libreoffice version

LibreOffice 3.5.3 for precise is in the libreoffice ppa at https://launchpad.net/~libreoffice/+archive/ppa (rc2 is the final version of 3.5.3). Could you check if the problem still exists with it?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Joshua O'Leary (jmoleary) wrote :

Ok, I have installed the latest PPA version - 3.5.3-rc2-0ubuntu1~ppa2(precise). Here are some screenshots showing the problem.

Joshua O'Leary (jmoleary) wrote :
Joshua O'Leary (jmoleary) wrote :

Changed status to New in Ubuntu for now as the bug occurs in the PPA version. Would any of you be able to test this yourselves, to see whether or not it can be confirmed? Thanks in advance.

Changed in libreoffice (Ubuntu):
status: Incomplete → New
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: needs-bisect regression-release xubuntu

I can resproduce this with lastest stable (3.5.3.2, english (UK) localization, but only under linux. Windows version seems to work fine.

hvf (hvonfintel) wrote :

Experiencing same problem here on 3.5.3 from Ubuntu on 12.04 LTS

I also have this problem on Ubuntu 12.04 64-bit, LibreOffice 3.5.2.2.

Confirmed in Ubuntu 12.04 (precise pangolin) version 1:3.5.3-0ubuntu1

This is also affecting me in Ubuntu 12.04 (64 bit) using LibreOffice 3.5.3.2

Only started affecting me after upgrade from ubuntu 11.10.

*** Bug 48971 has been marked as a duplicate of this bug. ***

Version: most old version of office where bug reproduced.
Changing again to 3.4.4

I can confirm this bug on 32-bit Xubuntu 12.04 running LO 3.5.3.2. This did not affect me until after the updated from Ubuntu 11.10.

Changed in df-libreoffice:
importance: Undecided → Unknown
status: Invalid → Unknown
Joshua O'Leary (jmoleary) wrote :

Still occurs in Libreoffice 3.5.4.2 from the ppa (1:3.5.4~rc2-0ubuntu1~ppa1)

Still occurs in Ubuntu 12.04, using version from ppa 3.5.4.2

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

In bug report 993399 there is a description of what suffixes should be automated in french.

summary: - Libreoffice (writer): autocorrect does not set superscript on ordinal
+ [Upstream] Writer AutoCorrect does not set superscript on ordinal
numbers
Anna Clawson (seadeer) wrote :

it still occurs in Debian, libreoffice version 3.5.4.2.

no longer affects: libreoffice (Debian)

*** Bug 48936 has been marked as a duplicate of this bug. ***

cement_head (andorjkiss) wrote :

Bug is still present on 12.04 LTS AMD64 LibreOffice Build 3.5.5-rc2 (from PPA).

cement_head (andorjkiss) wrote :

sorry, that should be LibreOffice 3.5.5.2 Build 2.

John Farrar, please do not toggle the version. For more on this please see http://wiki.documentfoundation.org/BugReport_Details#Version .

reproduced in 3.5.5 on Fedora 64 bit
not reproduced in 3.3.4, setting keyword "regression"

Still present in 3.6.1 for windows

Its not sill present, it happens now in Windows too.

Cory J Koch (yunusabd786) wrote :

Reproduced in 3.5.5.3 on Gentoo GNU/Linux

I get it as well, Ubuntu 12.04 64 bit, with 3.5.5 and latterly 3.5.6. It was OK at some point in the past 6 months or so, but I can't confirm which release that was.

It's quite irritating.

I have a laptop running Mint Debian 32 bit and that's still OK on 3.5.6.

I think #52397 has been raised with the same problem.

*** Bug 52397 has been marked as a duplicate of this bug. ***

hvf (hvonfintel) wrote :

Still present in 3.6.0 Ubuntu 12.04 LTS, and 3.6.1 Windows XP.

it seems that the change is that this 2nd -> 2^nd replacement is now somehow language dependent:

OOo 3.4beta: 2nd will be autocorrected even if LC_ALL=de_DE and the currently active document language is German.

LO 3.4.6 and current 3.5:
 2nd will not be autocorrected if the locale LC_ALL=de_DE _or_ active document language is German, but will be document language is English (USA) _and_ LC_ALL=en_US

LO 3.6: can't get 2nd autocorrected at all here

LO master:
 2nd will not be autocorrected if the currently active document language is German, but will be if it is English (USA),
 the LC_ALL setting does not make a difference

is that language dependence a feature?

the problem in 3.6 is fixed by this commit from master:
defe079d455ccc958fd0128e8a8cf0e4aeb5cd9c

the git log indicates that there is apparently a feature to make
the autocorrect language dependent, OOo issue 20348, implemented by Cedric.

fixed on libreoffice-3-6 now:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6&id=966c1bd122d8258dd8b1abfe638de7b1ce0d3c98

it appears that the language dependence is intentional,
so i think this is FIXED now.

Yeah, the feature is supposed to now be language dependant. i.e. 1st, 2nd, 3rd
for English, while 1er, 2e, etc. for French.

3.6 is busted in that it carefully determines that e.g. "st" is indeed the
right suffix for English but then ignores it

http://cgit.freedesktop.org/libreoffice/core/commit/?id=defe079d455ccc958fd0128e8a8cf0e4aeb5cd9c

fixes that

The additional
http://cgit.freedesktop.org/libreoffice/core/commit/?id=a05357ab69712bec53c2d8d17efbbf25907ff9b8
makes the features safe against the unexpected

Thanks for explanations of how to use this feature properly

I'm sorry but I just don't get this!

This bug has been marked as Fixed but I still can't get it to work.

I have English UK set as my default language and it doesn't change the 1st or 2nd or anything else for that matter to the superscript. So what am I doing wrong?

Can someone please explain. I'm on version 3.6.0.2 using Ubuntu 12.04 64 bit.

Thanks

we only fixed it yesterday, it will be available in 3.6.2, there's a bot that's supposed to fill that info in, appears to have failed in this case.

Thank you - I thought I was going mad!

I'll await the next version to come out.

(In reply to comment #27)
> we only fixed it yesterday, it will be available in 3.6.2...

Will version 3.6.2 be loaded to the Libre Office PPA [1]? Version 3.6.1 (64-bit) has still not been put onto the PPA.

[1] https://launchpad.net/~libreoffice/+archive/ppa/

Paddy Landau, https://bugs.freedesktop.org is the upstream bug tracker for LibreOffice. If you have questions about the LibreOffice PPA, which is provided downstream by the LibreOffice Packaging team ( https://launchpad.net/~libreoffice ), you will want to E-Mail the PPA owners mailing list -> <email address hidden> .

Christopher M. Penalver: Thank you. I shall follow up there.

I emailed the guy who's in charge of the PPA to just let him know that the PPA failed to build the Libreoffice 3.6.1 and he replied that he was fully aware of the build fail but didn't have me any update on when it would be built successfully.

I didn't want to step on his toes but thought I would have had a better reply.

> I emailed the guy who's in charge of the PPA...

Thank you, Peter Sewell. You beat me to it! At least we know it's in hand.

Changed in df-libreoffice:
status: Confirmed → Fix Released

So... This is still an ongoing problem or not?
If so, why is it marked as Resolved/Fixed?
I am rumming Ubuntu 12.04(64bit) LO Version 3.6.0.2 (Build ID: 360m1(Build:102))
and STILL cant get the date fuction working properly...

<email address hidden>, regarding your comments https://bugs.freedesktop.org/show_bug.cgi?id=38242#c34 :

>"So... This is still an ongoing problem or not? If so, why is it marked as Resolved/Fixed?"

As you may notice reading the bug report, Comment 23 https://bugs.freedesktop.org/show_bug.cgi?id=38242#c23 , and 24 https://bugs.freedesktop.org/show_bug.cgi?id=38242#c24 note a commit addressing the problem reported about in the Description https://bugs.freedesktop.org/show_bug.cgi?id=38242#c0 was submitted to the master and 3.6 branch respectively.

>"I am rumming Ubuntu 12.04(64bit) LO Version 3.6.0.2 (Build ID: 360m1(Build:102))"

As per https://wiki.documentfoundation.org/ReleasePlan#3.6_release 3.6.0.2 is no longer a supported version of LibreOffice.

>"and STILL cant get the date fuction working properly..."

If you have found a bug in supported version of LibreOffice as per https://wiki.documentfoundation.org/ReleasePlan you are welcome to file a new report following http://wiki.documentfoundation.org/BugReport .

fixed in 3.6.2 which is in quantal

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released
cement_head (andorjkiss) wrote :

Can this be backported via the PPA to Precise?

Thanks,
CH

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

I confirm with LibreOffice 4.0.2.2 the bug is still there.

It shouldn't be marked as fixed

I'm running LibreOffice 4.0.2.2 on Ubuntu 13.04 and the bug is still there. Should I file a new report?

in 4.0.3 on Fedora (RFR) 64 bit in English text works properly
(this is English-specific functionality)

I am using 4.0.3.3 in Ubuntu 12.04, and it works correctly (tested both UK and USA English).

@Allessandro Ceschini - I suggest that you upgrade to the latest Libre Office.

(In reply to comment #38)
> in 4.0.3 on Fedora (RFR) 64 bit in English text works properly
> (this is English-specific functionality)

Hi sasha, I don't think it's English-specific, anyway, I tried with English in LO 4.0.2.2 on Ubuntu 13.04 and even that doesn't work. The bug isn't fixed. It should be reopened.

(In reply to comment #39)
> I am using 4.0.3.3 in Ubuntu 12.04, and it works correctly (tested both UK
> and USA English).
>
> @Allessandro Ceschini - I suggest that you upgrade to the latest Libre
> Office.

I supposed 4.0.2.2 was the current release, isn't it?

(In reply to comment #41)
> I supposed 4.0.2.2 was the current release, isn't it?

Download the latest version from the official website:
http://www.libreoffice.org/download

(In reply to comment #42)
> (In reply to comment #41)
> > I supposed 4.0.2.2 was the current release, isn't it?
>
> Download the latest version from the official website:
> http://www.libreoffice.org/download

If I do so I shall uninstall the version provided by the Software Centre. Is it worth the hassle? I'd better wait for this version to be released officially by Ubuntu. Thanks anyway for notifying me the bug has been fixed in version 4.0.3. Good to know.

in 3.6.5.2 it also works correctly.
Ensure that replacing is enabled in Tools->AutoCorrct options.
and in Format->Character on first tab language is English

(In reply to comment #44)
> in 3.6.5.2 it also works correctly.
> Ensure that replacing is enabled in Tools->AutoCorrct options.
> and in Format->Character on first tab language is English

Yes, I' done so, I'd changed language to English (U.K.) or even English (U.S.A.), but to no avail.

(In reply to comment #43)
> If I do so I shall uninstall the version provided by the Software Centre.

Yes. Uninstall the existing version (you don't say which distribution or version of Linux you are using). Then follow the instructions on the Libre Office download page and use your package manager to install from the terminal. It's pretty easy.

If you still have problems, this isn't the place to ask; instead, ask on your distribution's help forum, or on a generic Linux forum.

(In reply to comment #46)
> (In reply to comment #43)
> > If I do so I shall uninstall the version provided by the Software Centre.
>
> Yes. Uninstall the existing version (you don't say which distribution or
> version of Linux you are using). Then follow the instructions on the Libre
> Office download page and use your package manager to install from the
> terminal. It's pretty easy.
>
> If you still have problems, this isn't the place to ask; instead, ask on
> your distribution's help forum, or on a generic Linux forum.

As I said, I'm running LO 4.0.2.2 on Ubuntu 13.04, I'm going to check on the Ubuntu forum whether Ubuntu users are experiencing my same problem with the bundled version. Going through the installation process is something I'd like to avoid as far as it's possible since it's a nightmare tampering with dependencies afterwards, it' not advisable to uninstall the bundled version unless it's strictly necessary.

(In reply to comment #47)
> As I said, I'm running LO 4.0.2.2 on Ubuntu 13.04

Sorry, I missed that.

> … it's a nightmare tampering with dependencies afterwards

On 12.04, there are no dependency problems whatsoever. I have not tried LO on 13.04 recently, but when I did try, it was flawless. You just have to remember to uninstall the existing LO first. If it doesn't work to your liking, it's very easy to uninstall it and reinstall from the Software Centre.

Alessandro Ceschini, the bug reported about in the Description has been tested Fix Released in Raring. If you have a bug in LibreOffice, the LibreOffice Packaging team, LibreOffice in Ubuntu team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug libreoffice

For more on this, please see the LibreOffice Debugging article:
https://wiki.ubuntu.com/LibreOfficeBugWrangling

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

Mr. Penalver,

I filed a new bug report here: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1189634 and I subscribed you to it, as you requested.

Best wishes,

(In reply to comment #45)
> (In reply to comment #44)
> > in 3.6.5.2 it also works correctly.
> > Ensure that replacing is enabled in Tools->AutoCorrct options.
> > and in Format->Character on first tab language is English
>
> Yes, I' done so, I'd changed language to English (U.K.) or even English
> (U.S.A.), but to no avail.

Can you double-check if BOTH language settings in
   Tools > AutoCorrect Options
and
   Format > Character > Font
are set to the same English language?

(In reply to comment #49)
> (In reply to comment #45)
> > (In reply to comment #44)
> > > in 3.6.5.2 it also works correctly.
> > > Ensure that replacing is enabled in Tools->AutoCorrct options.
> > > and in Format->Character on first tab language is English
> >
> > Yes, I' done so, I'd changed language to English (U.K.) or even English
> > (U.S.A.), but to no avail.
>
> Can you double-check if BOTH language settings in
> Tools > AutoCorrect Options
> and
> Format > Character > Font
> are set to the same English language?

Hello Kumara,

I cannot change the language on Tools > Autocorrect, it's stuck on French, although the Format > Character > Font language is indeed English (U.K.). This on LO 4.1 on Ubuntu 13.04.

(In reply to comment #50)
> I cannot change the language on Tools > Autocorrect, it's stuck on French,
> although the Format > Character > Font language is indeed English (U.K.).
> This on LO 4.1 on Ubuntu 13.04.

I don't use Ubuntu, but let me assume it's the same on the Windows version for now.

By "stuck" do you mean it's dimmed (greyed)? If so, please click on the Replace tab first, and see if you can change it there. Then see if it works. In the Localised Options tab, the "Format ordinal number suffixes" must of course be ticked.

(FYI, it's already set in French probably because it is so at Tools > Options > Languages > Locale setting)

4.0.4.2 fixed Gentoo, English (US)

(In reply to comment #51)
> (In reply to comment #50)
> > I cannot change the language on Tools > Autocorrect, it's stuck on French,
> > although the Format > Character > Font language is indeed English (U.K.).
> > This on LO 4.1 on Ubuntu 13.04.
>
> I don't use Ubuntu, but let me assume it's the same on the Windows version
> for now.
>
> By "stuck" do you mean it's dimmed (greyed)? If so, please click on the
> Replace tab first, and see if you can change it there. Then see if it works.
> In the Localised Options tab, the "Format ordinal number suffixes" must of
> course be ticked.
>
> (FYI, it's already set in French probably because it is so at Tools >
> Options > Languages > Locale setting)

OK, I did so but ordinal numbers still don't receive the expected treating. :(

> OK, I did so but ordinal numbers still don't receive the expected treating.
> :(

I bet Ubuntu packagers did something fishy with the package. Why not try downloading the offical RPM, extract every rpm in the same directory and run LO from there?

(In reply to comment #54)
> > OK, I did so but ordinal numbers still don't receive the expected treating.
> > :(
>
> I bet Ubuntu packagers did something fishy with the package. Why not try
> downloading the offical RPM, extract every rpm in the same directory and run
> LO from there?

Indeed, I'm not running the RPM, but the PPA directly from LO site, Ubuntu 13.04's default version is actually 4.0 not 4.1. I've switched to the PPA version as suggested by someone in this thread in order to check whether the problem was due to the particular implementation in Ubuntu or not. The problem is still there.

checked with 4.1.1 from Ubuntu 13.10 (saucy) -- bug not reproducable, so not an Ubuntu issue. Either some weird deps/ppas or a dirty profile.

In that case try renaming ~/.config/libreoffice to something else.

DO NOT DELETE IT. It may be needed to see what's the issue.

https://www.jualtasmurahbbs.com/ jual tas murah bandung handbag pesta wanita murah onine terbaru hari gini ke pesta ga pakai handbag pesta? itulah pertanyaan yang mungkin muncul dibenak para wanita yang akan pergi menghadiri banyak barang https://www.jualtasmurahbbs.com/category/tas-sekolah-anak/ tas anak murah dapatkan di toko handbag ini daftar perusahaan toko distributor tas bandung supplier backpack indonetwork backpack wanita perusahaan temukan produk backpack wanita di wilayah indonesia https://www.jualtasmurahbbs.com/category/kipling/ jual tas kipling murah batam tas pria seperti ransel dan selempang dan masih banyak lagi grosir tas ransel wanita branded jual tas murah online tas online berkualitas belanja grosir tas ransel wanita pusatnya tas online https://www.jualtasmurahbbs.com/category/tas-ransel-wanita/ tas ransel wanita murah bagus atau tote bag sendiri ayo pelajaricaranya belanja membuat tas promosi atau tote bag nah selanjutnya sampailah kita di inti dari artikel ini yaitu tentang bagaimana caranya memproduksi tas https://www.jualtasmurahbbs.com/category/tote-bag/ jual tote bag bandung mendapatkan berbagai merk jenis dan warna tas tangan lipat tas souvenir seminar katun bahan berkualitas dan tebal tas tangan lipat cukup murah untuk harga banyak barang tas berjenis ransel https://www.jualtasmurahbbs.com/category/cath-kidston/ jual tas cath kidston murah longchamp toko jual tas longchamp kw super online storelongchamp terbaru • categories tas longchamp tas backpack tas cantik tas longchamp tas murah toko longchamp tas longchamp saddle https://www.jualtasmurahbbs.com/category/anello/ jual tas anello murah bandung toko tas agen tas pengrajin jual shoes tote tas handbag organizer isi pasang murah lucu unik murah shoes tote tas handbag organizer isi jual shoes tote tas handbag organizer isi pasang jika anda https://www.jualtasmurahbbs.com/category/jansport/ tas jansport murah batamkarta batamkarta dengan segala potensi di dalamnya menarik minat wisatawan dari berbagai kota dalam negeri maupun wisatawan manca negara untuk datang ke kota batam nama kota pelajar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.