package kdebase-runtime 4:4.2.1-0ubuntu1 failed to install/upgrade: conflicts with kdesudo (it tries to owerwrite file /usr/lib/kde4/libexec/kdesu)

Bug #345776 reported by duendetuc on 2009-03-20
218
This bug affects 26 people
Affects Status Importance Assigned to Milestone
kdebase-runtime (Ubuntu)
High
Harald Sitter
kdesudo (Ubuntu)
High
Harald Sitter

Bug Description

Binary package hint: kdebase-runtime

package kdebase-runtime 4:4.2.1-0ubuntu1 failed to install/upgrade: intentando sobreescribir `/usr/lib/kde4/libexec/kdesu', que está también en el paquete kdesudo

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: intentando sobreescribir `/usr/lib/kde4/libexec/kdesu', que está también en el paquete kdesudo
NonfreeKernelModules: nvidia
Package: kdebase-runtime 4:4.2.1-0ubuntu1
SourcePackage: kdebase-runtime
Title: package kdebase-runtime 4:4.2.1-0ubuntu1 failed to install/upgrade: intentando sobreescribir `/usr/lib/kde4/libexec/kdesu', que está también en el paquete kdesudo
Uname: Linux 2.6.28-11-generic i686

duendetuc (elduendemirande) wrote :
Marco Maini (maini10) wrote :

Try with the command sudo apt-get install -f to fix this issue. Please post the result of this operation.

Changed in kdebase-runtime:
assignee: nobody → maini10
status: New → Incomplete
duendetuc (elduendemirande) wrote :

juan@juan:~$ sudo apt-get install -f
[sudo] password for juan:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Se instalaron de forma automática los siguientes paquetes y ya no son necesarios.
  libexiv2-4
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
  kdebase-runtime
Se actualizarán los siguientes paquetes:
  kdebase-runtime
1 actualizados, 0 se instalarán, 0 para eliminar y 1 no actualizados.
Se necesita descargar 0B/1908kB de archivos.
Se utilizarán 4096B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
(Leyendo la base de datos ...
197197 ficheros y directorios instalados actualmente.)
Preparando para reemplazar kdebase-runtime 4:4.2.1-0ubuntu1 (usando .../kdebase-runtime_4%3a4.2.1-0ubuntu2_i386.deb) ...
Desempaquetando el reemplazo de kdebase-runtime ...
dpkg: error al procesar /var/cache/apt/archives/kdebase-runtime_4%3a4.2.1-0ubuntu2_i386.deb (--unpack):
 intentando sobreescribir `/usr/lib/kde4/libexec/kdesu', que está también en el paquete kdesudo
dpkg-deb: el subproceso paste fue terminado por la señal (Tubería rota)
Procesando disparadores para man-db ...
Se encontraron errores al procesar:
 /var/cache/apt/archives/kdebase-runtime_4%3a4.2.1-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Marco Maini (maini10) wrote :

Please retry with sudo dpkg --configure -a.
If it doesn't work, clean apt cache (with command sudo apt-get clean) and do again sudo apt-get upgrade.

Marco Maini (maini10) wrote :

When you install kdebase-runtime, it tries to owerwrite the file /usr/lib/kde4/libexec/kdesu. That file is also contained in package kdesudo.

Changed in kdebase-runtime:
assignee: maini10 → nobody
status: Incomplete → Confirmed
Changed in kdesudo:
status: New → Confirmed
Marco Maini (maini10) wrote :

This affects also intrepid-backports.

tuomask (tuomask) wrote :

I get this also (after updating with KPackageKit), but with never packages:
kdebase-runtime 4:4.2.1-0ubuntu2 --> kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb

dpkg --configure -a does nothing

wei (futurewayne) wrote :

I have the same problem.
My system is Kubuntu, upgraded from 8.04 directly to 9.04 beta. Yesterday I did a upgrade and found this error.
I tried "dpkg --configure -a", but nothing happenned.

The log:

~/tmp$ sudo aptitude upgrade
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages will be upgraded:
  kdebase-runtime
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/1906kB of archives. After unpacking 8192B will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 222050 files and directories currently installed.)
Preparing to replace kdebase-runtime 4:4.2.1-0ubuntu2 (using .../kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb) ...
Unpacking replacement kdebase-runtime ...
dpkg: error processing /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

~/tmp$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  kdebase-runtime
The following packages will be upgraded:
  kdebase-runtime
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/1906kB of archives.
After this operation, 8192B disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 222050 files and directories currently installed.)
Preparing to replace kdebase-runtime 4:4.2.1-0ubuntu2 (using .../kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb) ...
Unpacking replacement kdebase-runtime ...
dpkg: error processing /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

wei (futurewayne) wrote :

I have it fixed after reading this bug #324277
https://bugs.launchpad.net/ubuntu/+source/kdebase-runtime/+bug/324277
Hope it help and get it fixed in Jaunty final release.

LOGs:
wayne@Wayne-laptop:~$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb
(Reading database ... 222089 files and directories currently installed.)
Preparing to replace kdebase-runtime 4:4.2.1-0ubuntu2 (using .../kdebase-runtime_4%3a4.2.2-0ubuntu1_i386.deb) ...
Unpacking replacement kdebase-runtime ...
dpkg - warning, overriding problem because --force enabled:
 trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
Setting up kdebase-runtime (4:4.2.2-0ubuntu1) ...

Processing triggers for man-db ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place

Mike Toscano (moj0rising) wrote :

Thanks a ton, wei. That did the trick for me as well. After getting the kdebase-runtime package installed, I was able to use apt-get normally and am doing another dist-upgrade now.

Mike

Harald Sitter (apachelogger) wrote :

This issue occurs when kdesudo is installed but kdebase-runtime gets pushed on top of it, however it appears that only kdebase-runtime and then kdesudo (in that order) is support. Meaning that first runtime needs to be fully configured, so that then kdesudo can applies it's magic ot alter kdesu. If, however, kdesudo gets configured first it probably doesn't apply the magic, leading to this particular file clash.

Nixternal and I agree that this issue should be avoidable by making kdesudo pre-depend on kdebase-runtime. This way kdesudo should not be configured unless kdebase-runtime _is_ configured, which should make kdebase-runtime always be configured before kdesudo.
Then kdesudo gets configured and will do its magic tricks to replace KDE's kdesu with kdesudo.

That is only a theory though, so it should be tested very well and if it actually works out it needs to be applied to intrepid, jaunty and karmic.

If someone knows of a good way on how to cause this clash for testing purpose, please share this knowledge with us :)

Changed in kdesudo (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
SteBo (stebo) wrote :

I just had the same issue when upgrading from the official KDE 4.2.2 packages from Kubuntu to the 4.2.3 packages from

deb http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu jaunty main

The command

sudo dpkg -i --force-overwrite /var/cache/apt/archives/kdebase-runtime_4%3a4.2.3-0ubuntu1~jaunty1~ppa1_i386.deb

fixed the problem for me.

I’ve had this problem, too, when upgrading to 4.2.3. I suggest not using dpkg --force-anything though, most of time it’ll end up breaking something the next time you upgrade. A less intrusive solution is

dpkg-divert --package kdebase-runtime --divert /usr/lib/kde4/libexec/kdesu.not-kdebase-runtime --rename /usr/lib/kde4/libexec/kdesu

which causes all packages except kdebase-runtime to install kdesu under another name thus avoiding conflicts.

Harald Sitter (apachelogger) wrote :

This bug waited long enough.

I am replacing dpkg-divert with update-alternatvies

Changed in kdesudo (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Changed in kdebase-runtime (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
importance: Undecided → High
status: Confirmed → In Progress
Changed in kdesudo (Ubuntu):
status: Triaged → In Progress
Changed in kdebase-runtime (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdebase-runtime - 4:4.3.1-0ubuntu2

---------------
kdebase-runtime (4:4.3.1-0ubuntu2) karmic; urgency=low

  * Introduce update-alternatives for kdesu vs. kdesudo (LP: #345776)
  * Add preinst script to remove kdesudo's divert on the kdesu binary. kdesudo
    Pre-Depends on -runtime while -runtime Conflicts and breaks kdesudo. This
    causes an intermediate removal of kdesudo until -runtime is fully configured
    this removal in combo with the diversion removal should prevent any issue.

 -- Harald Sitter <email address hidden> Tue, 15 Sep 2009 08:30:17 +0200

Changed in kdebase-runtime (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdesudo - 3.4.2.2-0ubuntu1

---------------
kdesudo (3.4.2.2-0ubuntu1) karmic; urgency=low

  [ Florian Reinhard ]
  * New upstream release
    - Closes LP: #422919 set bugAddress to lp

  [ Harald Sitter ]
  * Drop phony dpkg-divert
  * Introduce update-alternatives for kdesu vs. kdesudo (LP: #345776)
  * kdesudo pre-depends -runtime while -runtime conflicts and breaks kdesudo,
    this causes an intermediate removal of kdesudo until -runtime is fully
    configured, in addition to that -runtime will remove the kdesu diversion.
    All in all those 2 features should prevent any issue.
  * Replace CDBS' kde4.mk with kde.mk from pkg-kde-tools

 -- Harald Sitter <email address hidden> Tue, 15 Sep 2009 08:25:45 +0200

Changed in kdesudo (Ubuntu):
status: In Progress → Fix Released
ejt (sytes) wrote :

E: /var/cache/apt/archives/kdebase-runtime_4%3a4.2.2-0ubuntu1.1_i386.deb: trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
this is what I get-don't know what it means. First time failure.

ejt (sytes) wrote :

I was able to correct the problem by uninstalling kdesudo then upgrade again.

emreakbas (emreakbas) wrote :

@ejt, how did you uninstall kdesudo? It doesn't let me do so.

ejt (sytes) wrote :

I uninstalled kdesudo by opening synaptic and doing a search for kdesudo, high-lighted it and marked it for removal and hit apply

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers