package kdebase-runtime 4:4.2.2-0ubuntu1 failed to install/upgrade: trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo

Bug #437683 reported by Larry Starr on 2009-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kdebase-runtime (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase-runtime

Appears similar to #345776, but different package release:

"apt-get upgrade" output:
Preparing to replace kdebase-runtime 4:4.2.2-0ubuntu1 (using .../kdebase-runtime_4%3a4.2.4-0ubuntPreparing to replace kdebase-runtime 4:4.2.2-0ubuntu1 (using .../kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb) ...
Unpacking replacement kdebase-runtime ...
dpkg: error processing /var/cache/apt/archives/kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
dpkg-deb: subprocess paste killed by signal (Broken pipe)
u1~jaunty1_i386.deb) ...
Unpacking replacement kdebase-runtime ...
dpkg: error processing /var/cache/apt/archives/kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
dpkg-deb: subprocess paste killed by signal (Broken pipe)

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
Package: kdebase-runtime 4:4.2.2-0ubuntu1
SourcePackage: kdebase-runtime
Title: package kdebase-runtime 4:4.2.2-0ubuntu1 failed to install/upgrade: trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
Uname: Linux 2.6.28-15-generic i686

Larry Starr (starrlg) wrote :
Jonathan Thomas (echidnaman) wrote :

It shares the same underlying issue.

Thank you.

Reading the messages on that bug I found that the "dpkg -i --force ..."
followed by "dbpk --configure -a", fixed the problem for me.

On Sun, Sep 27, 2009 at 12:56 PM, Jonathan Thomas <email address hidden>wrote:

> *** This bug is a duplicate of bug 345776 ***
> https://bugs.launchpad.net/bugs/345776
>
> It shares the same underlying issue.
>
> ** This bug has been marked a duplicate of bug 345776
> package kdebase-runtime 4:4.2.1-0ubuntu1 failed to install/upgrade:
> conflicts with kdesudo (it tries to owerwrite file
> /usr/lib/kde4/libexec/kdesu)
>
> --
> package kdebase-runtime 4:4.2.2-0ubuntu1 failed to install/upgrade: trying
> to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package kdesudo
> https://bugs.launchpad.net/bugs/437683
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “kdebase-runtime” package in Ubuntu: New
>
> Bug description:
> Binary package hint: kdebase-runtime
>
> Appears similar to #345776, but different package release:
>
> "apt-get upgrade" output:
> Preparing to replace kdebase-runtime 4:4.2.2-0ubuntu1 (using
> .../kdebase-runtime_4%3a4.2.4-0ubuntPreparing to replace kdebase-runtime
> 4:4.2.2-0ubuntu1 (using
> .../kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb) ...
> Unpacking replacement kdebase-runtime ...
> dpkg: error processing
> /var/cache/apt/archives/kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in
> package kdesudo
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> u1~jaunty1_i386.deb) ...
> Unpacking replacement kdebase-runtime ...
> dpkg: error processing
> /var/cache/apt/archives/kdebase-runtime_4%3a4.2.4-0ubuntu1~jaunty1_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in
> package kdesudo
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
>
> ProblemType: Package
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> ErrorMessage: trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is
> also in package kdesudo
> Package: kdebase-runtime 4:4.2.2-0ubuntu1
> SourcePackage: kdebase-runtime
> Title: package kdebase-runtime 4:4.2.2-0ubuntu1 failed to install/upgrade:
> trying to overwrite `/usr/lib/kde4/libexec/kdesu', which is also in package
> kdesudo
> Uname: Linux 2.6.28-15-generic i686
>

--
Larry G. Starr - <email address hidden>
===================================================================
There are only three sports: bullfighting, mountaineering and motor
racing, all the rest are merely games! - Ernest Hemingway

Jon Harley (jon-serf) wrote :

That solution didn't work for me (the dpkg -i --force-overwrite failed), but I used the dpkg-divert solution and that did seem to fix the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers