Comment 13 for bug 345776

I’ve had this problem, too, when upgrading to 4.2.3. I suggest not using dpkg --force-anything though, most of time it’ll end up breaking something the next time you upgrade. A less intrusive solution is

dpkg-divert --package kdebase-runtime --divert /usr/lib/kde4/libexec/kdesu.not-kdebase-runtime --rename /usr/lib/kde4/libexec/kdesu

which causes all packages except kdebase-runtime to install kdesu under another name thus avoiding conflicts.