Ubuntu

File chooser dialog doesn't provide network access

Reported by Kim d'Audretsch on 2008-12-02
334
This bug affects 57 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
One Hundred Papercuts
Undecided
Timothy Arceri
gtk+2.0 (Ubuntu)
Low
Unassigned
gtk+3.0 (Baltix)
Medium
Unassigned
gtk+3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: audacious

Audacious cannot open files samba shares. Just like Gringotts and Firefox it cannot open (save) to network share.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"

ii audacious 1.5.1-3ubuntu1.1 small and fast audio player which supports

agitdd99 (agitdd99) wrote :

yes...i'm experience the same bug too. i think it would be nice if audacious can play network-shared files.
please fix this...

agitdd99 (agitdd99) wrote :

bump...does anybody notice this yet? please

It looks like this has been fixed in version 2.0.1 which is in karmic right now. Can you check to see if it's fixed? If you use jaunty, the package maintainer has created a backport which can be found here:

https://launchpad.net/~bdrung/+archive/ppa

I am running Karmic here at home but in Audacious2 I cannot see the "Network
icon" when opening a file.
Even when I make a Bookmark of the share in Nautilus it doesn't show up.

Firefox, gedit, gringotts and openoffice same thing, no networking icon when
opening a file in Karmic (not sure if its like that in Jaunty). If you make
a bookmark of a smb share in Nautilus you can open it in some programs but
in others it doesn't even show up. Now I tend to open stuff directly from
Nautilus or if possible from a bookmarked share. Why isn't it everywhere the
same and I cannot browse directly from programs??? This is one of my biggest
gripes at the moment.

What if you
1. Browse with Nautilus to the samba share with all the audio files
2. Launch Audacious2
3. Drag n' drop audio files to playlist.
4. Play them.

This worked for me with Karmic and Audacious 2.1. Can you reproduce this?

Confirming though that network/samba/whatever icon is missing from the open file dialog. One could expect to be able to browse network from the that dialog. This however can be worked around by using drag n drop method.

Yes this works but its only a hack. It should be possible with any
application which opens files, its not just audacious, to open files on the
network.

On Tue, Jan 5, 2010 at 10:48 PM, Isak Frants <email address hidden>wrote:

> What if you
> 1. Browse with Nautilus to the samba share with all the audio files
> 2. Launch Audacious2
> 3. Drag n' drop audio files to playlist.
> 4. Play them.
>
> This worked for me with Karmic and Audacious 2.1. Can you reproduce
> this?
>
> Confirming though that network/samba/whatever icon is missing from the
> open file dialog. One could expect to be able to browse network from the
> that dialog. This however can be worked around by using drag n drop
> method.
>
> --
> audacious cannot open file from network share
> https://bugs.launchpad.net/bugs/304345
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Isak Frants (isakfrants) on 2010-01-10
summary: - audacious cannot open file from network share
+ File chooser dialog doesn't provide network access
affects: audacious (Ubuntu) → gtk+2.0 (Ubuntu)
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Anders (andersja+launchpad-net) wrote :

This also affects Deluge and fotoxx, see (duplicate) Bug #617892 and Bug #637682

Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Kabanov Dmitry (kabanovdmitry) wrote :

Yes, this is very frustrating.

I am using both Ubuntu (as host OS) and Windows on virtual machine and using network share to share my documents. It's annoying to copy documents on local disk before opening them in Firefox or Thunderbird.

Please, raise importance if possible.

Smonff (smonff) wrote :

Hi,

This fonctionnality is not implemented on every browsers (Firefox, Chromium, Opera).
I don't understand why, is it that hard?

It will be very helpful if it could be implemented.

We use Ubuntu at work and we loose time by "save-as-on-the-desktop-and-commit-with-another-client". I know "this is not really a Bug", and it don't really matter, but it would be really very great if you can implement the file chooser dialog network access, especially SFTP (I don't care of Samba but I think other users need it too).

Thanxxx

Smonff (smonff) wrote :

Something else,

When I must upload files from my computer to our online back office via our web interface, I cannot access to local network either. This is the most disturbing missing fonctionnality, more than "save as" I think.

WE REALLY NEED IT !!!
(if you want to do something & need help I can)

Sebastien

Smonff (smonff) wrote :

Ther is another very stupid Hack to access you local or distant Network.
If you use Gnome, go to /home/${USER_NALE}/.gvfs./

Access points are listed here, this is only symbolic links to distant places you wish to access.

Hope it will helps ya, but it is still only a Hack, fonctionnality should be implemented...

Mossroy (mossroy) wrote :

I also face this issue.
I would expect the file chooser dialog to allow me to access network bookmarks (including mounting them if they are not mounted already).
It's very annoying when you want to save a file on a network share from Firefox or Thunderbird : you have to save it locally, then transfer it with nautilus.

I found the following workarounds :
- mount permanently the network locations in /etc/fstab : it works, but is not adapted to all situations. In my case, the server that hosts the network share is a standard PC, not a 24/7 server. So, if this PC is not up at startup time, the share is not mounted
- add a bookmark for ~/.gvfs directory, as suggested by smonff : it appears in the file chooser, but is empty if the share is not mounted. So you have to mount it before
- add a bookmark for ~/.gvfs AND install/configure the package gigolo : this software can automatically mount network shares. If you declare it as a startup application, it will try to connect every minute. See http://www.borpin.co.uk/2011/03/29/map-network-drive-in-ubuntu-again/ . It's still a workaround but it's the best I found so far.

In any case, it would be much much easier to be able to open/save directly in a network bookmark.
It is a frequent use case at home or in small organizations (several computers with shares to exchange data, but no central server)

Mossroy (mossroy) wrote :

For Firefox, a separate bug seems to exist on launchpad : https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/31471

Mossroy (mossroy) wrote :

Another workaround that can fit some needs : use the package autofs
You can configure it so that it mounts your network shares in a location like /mnt/autofs/servername/share
You can then put a bookmark on this directory, and it seems to be always displayed in open/save dialogs (tested on Firefox and Thunderbird)

Autofs mounts and unmounts the shares automatically when they are used/unused
If you need to use credentials (login/password) to connect to your SMB share, it's less straightforward but seems to work with a bit more config. See http://doc.ubuntu-fr.org/autofs_avec_samba#acces_aux_partages_avec_authentification (in French)

Norbert (nrbrtx) wrote :

Ubuntu 12.04 is affected by this bug.
Samba share was mounted, it's shown in the Nautilus, added to its bookmarks. But there is no bookmark in the File Open dialog.

If I manually navigate to '~/.gvfs/share_name on 192.168.x.x' I can access files. If I manually try to add this bookmark again, dialog says:
 "Could not add a bookmark
smb://192.168.x.x/share_name/ already exists in the bookmarks list
".
Please fix. It is annoying.

Norbert (nrbrtx) on 2012-11-05
tags: added: precise
Changed in hundredpapercuts:
milestone: none → raring-misc
status: New → Triaged
Timothy Arceri (t-fridey) wrote :

Looks like this is working in gtk+3 so hopefully we can find what the fix was an backport it.

Changed in hundredpapercuts:
status: Triaged → In Progress
assignee: nobody → Timothy Arceri (t-fridey)
Timothy Arceri (t-fridey) wrote :

Turns out this was not fixed in gtk+3 either but I have submitted a patch upstream that allows mounted network locations to appear in the file chooser

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

@Timothy: thanks for your work ... are you sure it doesn't work in GTK3?
If I browse e.g ftp://ftp.debian.org in nautilus, then start gedit, click on open, the location is listed in gedit's fileselector sidebar and can be browsed fine from there

Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

@Sebastien Bacher

the problem is, even if working in GTK / gedit, this feature does NOT
work in Firefox which is why the bug report was first made (a long time
ago)

Gary Prosser
bug reporter

Hoeflerb (hoeflerb) wrote :

Re: Sebastien and Gary

Yes, the problem is application-specific. Core GNOME applications like GEdit and Evince include mounted network shares in the Volumes list. Other applications like Firefox do not. From what I understand about GtkFileChooser, this functionality has to be added explicitly because it requires GIO. The default GtkFileChooserDialog does not display network shares.

The other, related, problem mentioned by Mossroy is that bookmarked, but unmounted, network shares don't show up in any application except Nautilus. If you inspect the ~/.gtk-bookmarks file, you can see entries like smb://server/share in the file, but only Nautilus recognizes these URIs. On 12.04, GEdit and Evince also recognized them and displayed them with the other bookmarks (Documents, Downloads, etc), but Firefox did not. On 12.10, only Nautilus recognizes them.

Sebastien Bacher (seb128) wrote :

@Gary, Hoeflerb: firefox is using gtk2 which is known to be buggy, I was mostly reply to comment #17 which states that gtk3 is buggy as well

Hoeflerb (hoeflerb) wrote :

@Sebastien

Yes, gtk3 is new, but it is hard to say if the problem is with gtk+ or the way the applications themselves are implementing GtkFileChooserDialog. On the latest Ubuntu 12.10, there is a mix of gtk3 (GEdit, Evince, Nautilus) and gtk2 (Firefox, LibreOffice, GIMP, Inkscape, Gnumeric) applications, and the behavior is mostly the same. With the exception of Firefox, both the gtk2 and gtk3 applications seem to display mounted network shares in the Volumes list. None of the gtk2 or gtk3 applications, with the exception of Nautilus, display bookmarks of the network share variety (smb://, sftp://, etc).

Sebastien Bacher (seb128) wrote :

The fileselector can be used in local-only mode or not, it's likely that the applications not listing those mounts enable the "local" option. Not sure about the bookmarks issue but that seems a different one

Timothy Arceri (t-fridey) wrote :

@Sebastien

Yes you are right the applications that are not displaying mounts are using local only mode (which is the default) this is because they do not rely on the GIO backend and cannot be assumed to handle all the different network protocols. What my patch is about however is enabling FUSE mounts were available even when in local only mode as FUSE mounts provide network locations via a local path. I have not looked into the bookmarking issue as yet although its possible it could be solved using similar logic.

Timothy Arceri (t-fridey) wrote :

By the way when I say "when available" I mean FUSE mounts should always be available on a default Ubuntu install its just on other OS's that GTK runs we must check (also on systems where gvfs-fuse has been removed/ not installed).

Timothy Arceri (t-fridey) wrote :

Subscribed William as per Papercut meeting so that he can review the patch and help with getting committed upstream.

Chris Wilson (notgary) on 2012-11-28
Changed in hundredpapercuts:
milestone: raring-misc → raring-gtk
GaryProsser (gary-prosser) wrote :

Thanks for progressing this issue, however it continues to affect Ubuntu
12.04

GaryP

On Wed, 2012-11-28 at 21:51 +0000, Chris Wilson wrote:
> ** Changed in: hundredpapercuts
> Milestone: raring-misc => raring-gtk
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (372238).
> https://bugs.launchpad.net/bugs/304345
>
> Title:
> File chooser dialog doesn't provide network access
>
> Status in GTK+ GUI Toolkit:
> Confirmed
> Status in One Hundred Paper Cuts:
> In Progress
> Status in “gtk+2.0” package in Ubuntu:
> Triaged
> Status in “gtk+3.0” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: audacious
>
> Audacious cannot open files samba shares. Just like Gringotts and
> Firefox it cannot open (save) to network share.
>
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.10
> DISTRIB_CODENAME=intrepid
> DISTRIB_DESCRIPTION="Ubuntu 8.10"
>
> ii audacious 1.5.1-3ubuntu1.1
> small and fast audio player which supports
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtk/+bug/304345/+subscriptions
>
>

Timothy Arceri (t-fridey) wrote :

Gary, please read the bug report before posting. nowhere does it say that a fix has been committed for this bug report let alone released.

Sorry my English is not verry good, and I'm not sure to well understand what about “a fix has been committed...”.
I'm currently affected by this bug, in professional place, with Ubuntu 12.04 LTS. I want to know if the bug is fixed with 12.10? Thanks for your work!

Timothy Arceri (t-fridey) wrote :

This is not fixed in 12.04 or 12.10. The patch still needs to be reviewed upstream.

What do you expect, it's only been four years since reporting the bug.

Timothy Arceri (t-fridey) wrote :

@amay82

No need to be a smart arse. I don't get paid to fix Ubuntu bugs I just volunteer my time to fixing some bugs here and there its my way of giving back to the project. The upstream patch is just waiting on the upstream developer getting back from holidays, he has promised me he would review my patch when he gets back.

If your not going to make a constructive comment please don't make one at all.

Changed in gtk+3.0 (Baltix):
status: New → Triaged
importance: Undecided → Medium
Timothy Arceri (t-fridey) wrote :

My patch has now been commited upstream. It should land in the next versions of GTK 2 and GTK 3

Changed in hundredpapercuts:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

@Timothy: nice to see that upstream is reviewing and landing some of your patches, keep the good work! ;-)

Changed in gtk+3.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in gtk:
status: Confirmed → Fix Released
Changed in gtk+2.0 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.8.2-0ubuntu1

---------------
gtk+3.0 (3.8.2-0ubuntu1) saucy; urgency=low

  * New version update:
    - includes fix for wayland backend segfault (lp: #1113424)
    - don't use tick mark instead of apostrophe (lp: #896986)
    - we now support touch friendly popups on entries and text views
      in place of context menus, on touch devices
    - The print dialog now shows printers that are discovered
      using avahi (lp: #1082519)
    - File chooser dialog doesn't provide network access (lp: #304345)
    - selection is reported incorrectly in file chooser button (lp: #1041546)
  * debian/libgtk-3-0.symbols:
    - new version update
  * debian/patches/git_color_annotation_fix.patch,
    debian/patches/git_cssimage_load_when_needed.patch,
    debian/patches/git_dont_duplicate_bookmark.patch:
    - dropped, those fixes are in the new version
  * debian/patches/102_add_wayland_symbols.patch:
    - updated for new symbols

gtk+3.0 (3.7.12-1) experimental; urgency=low

  [ Sjoerd Simons ]
  * debian/patches/80_Fix-DND-with-frame-sync.patch:
    + Added. Temporary fix for DND when using mutter with the frame sync
    protocol (from upstream git, bgo#694217).

  [ Emilio Pozuelo Monfort ]
  * New upstream release.
    + debian/patches/*:
      - Refreshed.
    + debian/patches/80_Fix-DND-with-frame-sync.patch:
      - Removed, included upstream.
    + debian/libgtk-3-0.symbols:
      - Updated for new symbols.

gtk+3.0 (3.7.10-1) experimental; urgency=low

  * New upstream release.
    + debian/control.in:
      - Update build dependencies.
    + debian/patches:
      - Refreshed.
    + debian/libgtk-3-0.symbols:
      - Updated for the new symbols.
    + debian/gtk-3-examples.install:
      - Stop installing gtk3-demo files, no longer needed.
    + debian/patches/030_tests_skip_filechooser.patch:
      - New patch: skip filechooser tests as they are not designed to
        be run without gtk+ installed.
 -- Sebastien Bacher <email address hidden> Mon, 25 Feb 2013 16:29:19 +0100

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Chris Wilson (notgary) on 2013-05-28
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
dino99 (9d9) on 2013-05-28
Changed in gtk+3.0 (Baltix):
status: Triaged → Fix Released
Lanoxx (lanoxx) wrote :

Hello Timothy,

thank you very much for your contribution. Its great that this bug was finally fixed. Just a quick question, once this fix is also released for gtk+2 will that mean that I can use network shares in Thunderbird and Firefox?

nodiscc (nodiscc) wrote :

@lannox I have not tested this with audacious yet, but my (SMB, SFTP) network shares show up correctly in firefox's file chooser (that fix should affect any program that uses the GTK file chooser)

Lanoxx (lanoxx) wrote :

Hello Timothy,

thank you very much for your contribution. Its great that this bug was finally fixed. Just a quick question, once this fix is also released for gtk+2 will that mean that I can use network shares in Thunderbird and Firefox?

Timothy Arceri (t-fridey) wrote :

Hi Lanoxx,

That is correct network shares will work in Thunderbird, Firefox and any other gtk+2 apps that use the filechooser.

Enjoy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.