libssl.so.0.9.8: undefined symbol: EVP_idea_cbc

Bug #369471 reported by Gerrit on 2009-04-29
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
googleearth-package (Debian)
Fix Released
Unknown
googleearth-package (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: googleearth-package

Hi!
Just installed "googleearth-package 0.5.4.1~0ubuntu1" on Ubuntu 9.04 amd64, ran "/usr/bin/make-googleearth-package" and created "googleearth_5.0.11729.1014+0.5.4.1-1_amd64.deb" which installed fine. When trying to run googleearth it bailed out with:

....libssl.so.0.9.8: undefined symbol: EVP_idea_cbc

Renaming "libcrypto.so.0.9.8.removed-by-installer" in "/usr/lib/googleearth" resolved the problem. It seems, Google fixed the problem with "libcrypto.so.0.9.8" and renaming it by the installer is not necessary any more.

Matthew Moore (matthew-moore2) wrote :

I just hit the same issue, fresh install of 9.04, amd64, and the same versions of googleearth-package and Google Earth itself. The same workaround worked for me.

Rijk (rijk-stofberg) wrote :

I use Ubuntu Jaunty with a Nvidia card in TwinView mode.
Renaming the file /usr/lib/googleearth/libssl.so.0.9.8.removed-by-installer to /usr/lib/googleearth/libssl.so.0.9.8 solved this problem for me too. Thanks :)

wirechief (wirechief) wrote :

Ubuntu januty 9.04 64bit
Linux wirechief-laptop 2.6.30-020630rc2-generic #020630rc2 SMP Wed Apr 15 13:20:18 UTC 2009 x86_64 GNU/Linux
numerous warnings (see attachment)
ls libssl*.*
libssl.so.0.9.8

also i was missing msttcorefonts so ...sudo apt-get install msttcorefonts but the renaming of the errored libssl.so.0.9.8
fixed the issue of not starting for me..

sudo mv libssl.so.0.9.8 oldlibssl.so.0.9.8
googleearth
/usr/lib/googleearth/googleearth-bin: symbol lookup error: /usr/lib/googleearth/libssl.so.0.9.8: undefined symbol: EVP_idea_cbc

wijit (awijit) wrote :

Jaunty on ECS Green 733, 256Mb RAM:
I found libssl.so.0.9.8 in /lib/.
Here is my attemp:
1. rename the errored libssl to other name (or delete it):
wijit@wijit:/usr/lib/googleearth$ sudo mv libssl.so.0.9.8 tmp-libssl.so.0.9.8
2. make a symbolic link to the libssl located in /lib/
wijit@wijit:/usr/lib/googleearth$ sudo ln -s /lib/libssl.so.0.9.8 libssl.so.0.9.8
Thanks to all good guys.

Nick Hall (n-hall) wrote :

Ubuntu 9.04 i386 - nvidia with twinview.
I installed using googleearth-package to create a deb and had the same problem.
Renaming the file also fixed it for me.

This worked for me as well on Ubuntu 9.04....

Toshiba A100-OFH
Intel 945 integrated graphics

1) chappejw@codefu:/usr/lib/googleearth$ sudo mv libssl.so.0.9.8 tmp-libssl.so.0.9.8
2) chappejw@codefu:/usr/lib/googleearth$ sudo ln -s /lib/libssl.so.0.9.8 libssl.so.0.9.8

Applications > Internet > Google Earth

Works.!

sojourner (itsmealso2) wrote :

same problem on karmic koala (9.10) AMD64 same fix , renamed /usr/lib/googleearth/libssl.so.0.9.8 to /usr/lib/googleearth/libssl.so.0.9.8.bak and GE starts and runs OK .

Changed in googleearth-package (Ubuntu):
status: New → Confirmed
Gerrit (dabang) wrote :

I think things are getting mixed up here:
some of you obviously needed to rename/delete "/usr/lib/googleearth/libssl.so.0.9.8" to make GE work. In my originally reported bug it was the other way round: Ubuntu's "googleearth-package" built a package where "/usr/lib/googleearth/libssl.so.0.9.8" was already renamed to "/usr/lib/googleearth/libssl.so.0.9.8.removed-by-installer". With this setup on Ubuntu Intrepid AMD64 the above mentioned error appeared and GE refused to start. Renaming "/usr/lib/googleearth/libssl.so.0.9.8.removed-by-installer" to "/usr/lib/googleearth/libssl.so.0.9.8" solved my problem.
So, wijit, Nick Hall, chappejw and sojourner seem to have another problem. I guess it would be interesting which version of Google Earth you are running and did you use googleearth-package to build a Debian package? I know this is a problem with GE itself, but googleearth-package provided a fix which - at least in my case - would not be necessary any more.

Bremm (bremm) wrote :

Same here on mom's pc running Xubuntu 9.04 i386 (console messages in Portuguese):

$ sudo dpkg -i googleearth_5.0.11733.9347+0.5.4.1-1_i386.deb
Selecionando pacote previamente não selecionado googleearth.
(Lendo banco de dados ... 155620 arquivos e diretórios atualmente instalados).
Desempacotando googleearth (de googleearth_5.0.11733.9347+0.5.4.1-1_i386.deb) ...
Configurando googleearth (5.0.11733.9347+0.5.4.1-1) ...

Processando gatilhos para shared-mime-info ...

$ googleearth
/usr/lib/googleearth/googleearth-bin: symbol lookup error: /usr/lib/googleearth/libssl.so.0.9.8: undefined symbol: EVP_idea_cbc

$ sudo mv /usr/lib/googleearth/libcrypto.so.0.9.8.removed-by-installer /usr/lib/googleearth/libcrypto.so.0.9.8

$ googleearth (it works fine so far)

$ make-googleearth-package --help
Unrecognized command-line argument: --help
googleearth-package 0.5.4.1
usage: make-googleearth-package [options]
  Creates a Debian package from the Google Earth GNU/Linux installer.
  By default, will look for the installer in the current directory.
  If not found it will be downloaded automatically

Rey Tucker (rtucker) wrote :

Same deal here:

rtucker@arrogant-bastard:~$ googleearth
/usr/lib/googleearth/googleearth-bin: symbol lookup error: /usr/lib/googleearth/libssl.so.0.9.8: undefined symbol: EVP_idea_cbc
rtucker@arrogant-bastard:/usr/lib/googleearth$ sudo mv libssl.so.0.9.8 libssl.so.0.9.8.removed-by-rtucker-lp369471

And it's good now... googleearth Version: 5.0.11733.9347+0.5.4.1-1. Fascinating :-) -rt

Nicolas Albert (nicoa380) wrote :

For this problem, I just edit the file /usr/bin/googleearth and replace the last line by

LD_PRELOAD=/usr/lib/libssl.so.0.9.8 LD_LIBRARY_PATH=/usr/lib/googleearth /usr/lib/googleearth/googleearth-bin "$@"

Changed in googleearth-package (Debian):
status: Unknown → New

I downloaded the GE installer and also installed lib32nss-mdns as showed in this how to ( https://help.ubuntu.com/community/GoogleEarth ) and did this in terminal to fix the message error but didn't worked at all...
1- Installed GE from the installer
2- sudo apt-get install lib32nss-mdns
3- did : > mv ~/google-earth/libcrypto.so.0.9.8 ~/google-earth/libcrypto.so.0.9.8.bak
                > ln -s /usr/lib/libcrypto.so.0.9.8 ~/google-earth/libcrypto.so.0.9.8
4- Execute GE starts and flickers the earth view and then it crashes giving the following error:

santiago@hyperion:~$ google-earth/googleearth
./googleearth-bin: symbol lookup error: ./libssl.so.0.9.8: undefined symbol: EVP_idea_cbc
santiago@hyperion:~$

any help? HP 6735s ATI Radeon HD3200 with latest ATI driver downloaded from ATI website.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package googleearth-package - 0.5.6ubuntu1

---------------
googleearth-package (0.5.6ubuntu1) karmic; urgency=low

  * Fix bashism in make-googleearth-package (Closes: #524686)
  * Do not use the shipped libssl (Closes: #537837) LP: #369471

 -- Tormod Volden <email address hidden> Tue, 01 Sep 2009 23:19:45 +0200

Changed in googleearth-package (Ubuntu):
status: Confirmed → Fix Released
Changed in googleearth-package (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.