Ubuntu

System monitor causes Xorg to consume 100% CPU

Reported by Konstigt on 2008-01-30
350
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Fix Released
Critical
gnome-system-monitor (Debian)
Fix Released
Unknown
gnome-system-monitor (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-system-monitor

Just opening system monitor (not sure if it's always) causes one of my CPUs to go to 100% usage. The process Xorg is the one that actually has all the CPU usage but I guess it must be system-monitors fault.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
dpkg -l | grep xorg-core
ii xserver-xorg-core 2:1.4.1~git20080118-1ubuntu2 Xorg X server - core server
$ dpkg -l | grep gnome-system
ii gnome-system-monitor 2.21.5-0ubuntu1 Process viewer and system resource monitor f

I tried to find out what was going on and started a strace on the Xorg process and that completely locked upp my system. Tried to switch to a console with ctrl-alt-f1 but no success. Remotely connected to the system with SSH and found that the CPU usage was good and as soon as I killed -9 the strace process the system was OK again.

Konstigt (konstigt) wrote :
Konstigt (konstigt) wrote :

The system felt a bit slow so I logged out. This wasn't successful, only all icons any everything disappeared now only showing my background picture. I tried using the keyboard but nothing worked. I did a SSH to the machine and logged in without any problems. Noticed Xorg process taking 100% CPU. Also noted this in kern.log:

Jan 30 19:58:16 pc-thnov-ubuntu kernel: [ 1157.675889] [fglrx:firegl_free_mutex] *ERROR* mutex id 0x00000005 not found in mutex list
Jan 30 20:03:31 pc-thnov-ubuntu kernel: [ 1232.819179] [fglrx] interrupt source 10000000 successfully disabled!
Jan 30 20:03:31 pc-thnov-ubuntu kernel: [ 1232.819189] [fglrx] enable ID = 0x00000000
Jan 30 20:03:31 pc-thnov-ubuntu kernel: [ 1232.819193] [fglrx] Receive disable interrupt message with irqEnableMask: 10000000; dwIRQEnableId: 00000008

Tried to kill the Xorg process but wasn't successful, not even with -9. /etc/init.d/gdm stop was also useless. Managed to reboot it with ctrl-alt-delete.

$ dpkg -l | grep fglrx
ii fglrx-amdcccle 8.452.1-1 Catalyst Control Center for the ATI graphics
ii fglrx-kernel-source 1:8-01+2.6.24.6-5.16 ATI binary kernel module source
ii xorg-driver-fglrx 1:7.1.0-8-01+2.6.24.6-5.16 Video driver for ATI graphics accelerators

Konstigt (konstigt) wrote :

I'm not able to reproduce this on another computer with Nvidia card/drivers. Will try later to reproduce on the original computer, maybe this has been fixed?

Konstigt (konstigt) wrote :

This is still very much a problem on my computer with the ATI graphics adapter. As soon as I start system monitor I get 100% CPU.

Konstigt (konstigt) wrote :

Since this is 100% reproducible and the bug has duplicates, I'm setting it to confirmed.

Changed in gnome-system-monitor:
status: New → Confirmed
Charles Perreault (muganor) wrote :

I also happen to have this bug. I'm using hardy. When I choose the "resources" tab, the cpu hops up to 60% usage (Turion 2.2 ghz, ATI with fglrx drivers). I think it's the new graph engine (with white background) that has a problem, because the previous version (black background) was working correctly. Also, by reducing the interval of polling / update in the preferences, I can reduce the % of cpu used by Xorg/gnome-system-monitor:

update every 1s --> 60% usage
update every 2s --> 40% usage
update every 3s --> 20% usage

The bug is indeed 100% reproducible, and only occurs in the "resources" tab. Cpu goes back to 0% usage in any other tab. Hiding the gnome-system-monitor with another application does not lower the cpu usage. I don't know for sure under Linux/Xorg, but under Windoze a hidden window is not rendered (plain common sense). If the same logic applies to Xorg, that would mean the problem is not in the rendering/drawing of the resources tab.

Monestri (monestri) wrote :

Confirmed.

On a dual core system, moving to the resources tab causes a cpu to jump to 100%. After a certain period of time, it switches the other core to 100% and the first one back to 0%. It got me confused for a while hehe.

Sebastien Bacher (seb128) wrote :

Could users having this issue attach they xorg.conf and Xorg.0.log to the bug? That looks like slow cairo rendering and like and xorg or driver limitation

Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
Kenneth Mokkelbost (kmokk) wrote :

Since I experience the same, here's my Xorg-files.

Kenneth Mokkelbost (kmokk) wrote :
Kartik Mohta (kartikmohta) wrote :

Same problem here. (ATI with fglrx driver)

Kartik Mohta (kartikmohta) wrote :
arcange| (arcangel-web) wrote :

gnome-system-monitor 100% CPU

PC = Acer Aspire 5051 AWXMi

$cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
$ dpkg -l | grep xorg-core
ii xserver-xorg-core 2:1.4.1~git20080131-1ubuntu4 Xorg X server - core server
$ dpkg -l | grep gnome-system
ii gnome-system-monitor 2.21.5-0ubuntu1 Process viewer and system resource monitor f
ii gnome-system-tools 2.21.92-0ubuntu1 Cross-platform configuration utilities for G

Victor Osadci (victor-os) wrote :
Victor Osadci (victor-os) wrote :
kripken (kripkenstein) wrote :

I can also confirm this bug. 100% CPU usage on the 'Resources' tab.

I have a theory about it. It appears that the update interval is not obeyed correctly. When I have it set at 1, I get 100% CPU usage, and it is updating *much faster* than 1 time per second. When I set it to 3 I get 50% CPU usage and it updated about once per second. When set to 10, it updates around every 2 seconds at 25% CPU usage.

That is, it seems to try to update much faster than the user requests, which leads to extreme CPU usage.

I think it is linked to cairo rendering as I have the same problem on the same computer when loading some pages in firefox (I had no problem before upgrade).
I have an ATI card too, but the problem can be reproduced with both fglrx and radeonhd.

On my other computer (nvidia gpu) I have no such problem.

Possible duplicates :

#18055 https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/180055

Changed in gnome-system-monitor:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

could people stop abusing bug title to write informations that will be outdated when the next ubuntu will open, create extra work and makes the title harder to read?

Ben Garton (abgarton) wrote :

Confirmed here to on ATI and fglrx driver.

The problem only happens to me if the system monitor window is increased in size and the resources tab is open. When the window is smaller or at its default size the impact to CPU is less noticeable. I suppose thats due to the amount of graphics that need to be redrawn per cycle....

Anyway here are my Xorg files...

Ben Garton (abgarton) wrote :
ergo (ergo14) wrote :

can also confirm the bug on 2 pc one running 8.04beta with gf 8800gts other one is running beta on ati radeon 9600pro.

ligaard (kasperligaard) wrote :

I see this problem too. Not 100% load, but 70-80%.

System data:
- OS: Hardy Heron beta 1.
- Machine: Lenovo T61p, 2.2GHz, 4GB RAM
- Graphics: Nvidia 570M (using restricted drivers / Compiz).

A bug that might be related could be 125970, https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/125970

Steven Harper (stevenharperuk) wrote :

I see the same problem, however the CPU load is normal when the size of the window is about 400px high (normal) if I make it about 600px or full screen the cpu load goes higher the bigger the window the higher the load.

This is when I am on the Resources Tab (graphs)

I'm on Hardy beta 64bit
Linux uber-hardy 2.6.24-12-generic #1 SMP Wed Mar 12 22:31:43 UTC 2008 x86_64 GNU/Linux

I also see the same on 32bit - with or without the nvidia drivers

when I start it on command line I get this

** (gnome-system-monitor:7009): WARNING **: SELinux was found but is not enabled.

I do not know if thats relevant

Giorgos Logiotatidis (seadog) wrote :

I confirm the issue. Like Steven Harper noted the problem appears when different graph rendering method is automatically chosen from system monitor if the window is bigger than 600px.

Hardware:
Dell latitude D820
Nvidia Quadro 120M

Without compiz enabled

$ dpkg -l | grep gnome-system
ii gnome-system-monitor 2.22.0-1ubuntu1 Process viewer and system resource monitor f
ii gnome-system-tools 2.22.0-0ubuntu4 Cross-platform configuration utilities for G
$ dpkg -l | grep xorg-core
ii xserver-xorg-core 2:1.4.1~git20080131-1ubuntu5 Xorg X server - core server

Sitsofe Wheeler (sitsofe) wrote :

I also see this too (when the window is made larger) under Hardy on my machine using both the nv open source and nvidia-glx-legacy driver. The strange thing is that rather than just the program going slow it actually causes X itself to start going slow leading to the mouse pointer jumping across the screen while g-s-m is open...

Graphics card is a
nVidia Corporation NV10DDR [GeForce 256 DDR] (rev 10)

Ubuntu 8.04 Hardy fully upgraded and updated, same here...

Thank you

Changed in gnome-system-monitor:
status: Confirmed → Triaged
ba5e (willieham) wrote :

Yeah, I was following the post on the Ubuntu forums about this. Its a real pain, but as you can see from the screenshot, its much less worse now (not 100%cpu). What fix was released for this, or where can I find the changelog?

However you will see with the window at the smallest it will go, around 5-10% CPU usage, and when maximised to nearly 1680x1050 it will be 20-25% usage on a c2d@3ghz now. I agree this needs to be much lower, max 1% but it comes down to the efficiency of the code for graphs I suppose.

Andrew Conkling (andrewski) wrote :

Will, as Sebastian mentioned above, it has to do with the cairo rendering that was put into the Resources graphs for 2.22/Hardy. It doesn't always go to 100%; the CPU impact has a lot to do with your video driver.

Jon Leighton (jonleighton) wrote :

Same here.

Recently (last 2 days or less) I have experienced other slow performance in other areas, which might be related:

* Viewing translucent overlays in a browser (example: http://www.huddletogether.com/projects/lightbox/)
* Scrolling web pages with a fixed background image (example: http://thecoalhole.org/)
* Deleting emails/changing folders in evolution (seems to be the same as #203471)

Do other people experience these issues? Are there any workarounds?

Jon Leighton (jonleighton) wrote :

Please disregard the extra issues I listed above - it turns out my nvidia driver had become disabled. Enabling it makes things much better. However, I do still experience the original issue of high CPU usage in system monitor.

[bolduc] LinuxU8:/home/bolduc> cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

PC is MotherBoard ASUS P5S800-VM ver 1.01 Intel Celeron 2.8 GHz 1.5GB Ramm Video Card SiS built-in, no usage of Compiz

dpkg -l | grep xorg-core
ii xserver-xorg-core 2:1.4.1~git20080131-1ubuntu6 Xorg X server - core server

[bolduc] LinuxU8:/home/bolduc> dpkg -l | grep gnome-system
ii gnome-system-monitor 2.22.0-1ubuntu2 Process viewer and system resource monitor f
ii gnome-system-tools 2.22.0-0ubuntu6 Cross-platform configuration utilities for G

With Ubuntu 7.10 installed previously, the gnome-system-monitor 2.20 worked properly on the same PC.
The applet system-monitor for cpu put on the dashborad is OK, put the right CPU usage.

Nwallins (rick-hull) wrote :

System: Dual Opteron 246 (single core) 2GHz, 2GB ECC DRAM, ATi RAGE XL (onboard, crappy) graphics, 1280 x 1024 @ 60Hz
OS: Hardy Beta install, fully updated as of today (4/5/2008)

For me the CPU usage is dependent on the size of the System Monitor window. At its normal size, it consumes 0-20% of a single CPU. At, say, 1000 x 1000, it (well, Xorg) consumes 50+% of one and 100% of the other, maxing Xorg very unresponsive.

xorg.conf paste below -- quite vanilla -- I haven't touched it

>>>>>>>>>

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "vmmouse"
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
EndSection

<<<<<<<<<<

Nwallins (rick-hull) wrote :

As stated before, the CPU consumption increases with window size. Also, this is primarily (only?) for the Resources tab. After further examination, the CPU utilization is much more sensitive to horizontal increases. Stretching the window vertically does not affect things too much.

webjames (james-olney) wrote :

Hi, i have the same problem

please take a look at the screen shot i have taken, the lettering has been replaced by strange symbols, and as other people my cpu usage goes to 100%, another note the graphs seems distorted.

hope this helps. i have a P4 3.20 ghz, with hyper-threading turned off, when turned on comes up as two cores, but that's another problem!

Sebastien Bacher (seb128) wrote :

could you everybody stop commenting on this bug? there is no need for extra details, the bug is triaged, you are just spamming other people subscribed to this bug now

Kenneth Mokkelbost (kmokk) wrote :

Seems fixed on my system. Close bug?

kripken (kripkenstein) wrote :

This bug is still very much present on my system (which is fully updated).

Fixed here too.

On Sat, Apr 19, 2008 at 10:30 PM, Kenneth Mokkelbost <email address hidden> wrote:
> Seems fixed on my system. Close bug?
>
>
>
> --
> System monitor causes Xorg to consume 100% CPU
> https://bugs.launchpad.net/bugs/187383
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Kartik Mohta

schiebe (schiebe) wrote :

I have the same problem on my 800 Duron since the new fancy cairo interface for the gnome-system-monitor is used.

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)

System is 8.04 RC with Updates.

flyingian (idescoteaux) wrote :

Have the same problem here too, Hardy Heron freshly installed and updated, Intel Q6600 and NVidia graphics card.

The problem is happening only in the resources tab too. If I go to the process tab, wait a bit and go back to resources tab, the processor goes back to 100% instantly. It is at 100% only on one core.

Update @ 1s: Between 90 and 100%
Update @ 2s: Between 50 and 80%
Update @ 3s: About 30%
Update 4s+: No significant change

Andrew Conkling (andrewski) wrote :

schiebe, flyingian, others: See Sebastian's note on comment 36:
https://bugs.launchpad.net/ubuntu/+source/gnome-system-monitor/+bug/187383/comments/36
.

Mark (phenix1) wrote :

i agree with kripkenstein, the graphs are updated more often than they should

Milan Krivda (milan-krivda) wrote :

Same bug too.

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-system-monitor:
importance: Low → Medium
status: Triaged → Fix Committed
Reshey (ie) wrote :

I have the same problem. Around 100 % cpu usage and unresponsive when using system monitor. Terminal and "top" works fine.

Andrew Conkling (andrewski) wrote :

On Thu, Apr 24, 2008 at 2:05 PM, Reshey <email address hidden> wrote:

> I have the same problem. Around 100 % cpu usage and unresponsive when
> using system monitor. Terminal and "top" works fine.
>

This was just fixed upstream and hasn't been released in Ubuntu yet. Please
subscribe to the bug and keep posted; there will be an automatic message
sent when the updated package is released.

Changed in gnome-system-monitor:
status: Unknown → Fix Released
Rockfirm Bear (basal) wrote :

Same problem here with Hardy, standard-nvidia-driver (not from NV) on GForce EN8800GTX. Once started, almost nothing works.

I'm looking forward for the update. GSM is a good tool.

Sebastien Bacher (seb128) wrote :
Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in gnome-system-monitor:
status: Triaged → Fix Committed
Hew McLachlan (hew) wrote :

Xorg use has dropped from 60-70% to just 10-20% CPU (tested just before and after the update). Graph animation is now very smooth (and the lines also seem thinner, which is nice imo). Great success!

gnome-system-monitor 2.22.1-0ubuntu2
nvidia-glx-new 169.12+2.6.24.12-17.35

schiebe (schiebe) wrote :

On my machine from 90 % to ~40 %... better but in my opinion still to high for a system monitor.

nvidia-glx-legacy_71.86.04+2.6.24.12-16.34_i386.deb
gnome-system-monitor_2.22.1-0ubuntu2_i386.deb

ABE3K (abe3k) wrote :

when running the Resource monitor after the update I noticed that when the window is small the CPUs are running on almost 20% ( which is still higher than anticipated ). but when I maximize the window the CPUs start spiking to 80-90 % and the PC starts to get laggy again.

Shaun Dennie (sdennie) wrote :

The version in -proposed seems better but, I can confirm that maximizing the window causes it use a full CPU core. Keeping the window small still consumes about 20% of a CPU core.

Daniel van Vugt (vanvugt) wrote :

Yes gnome-system-monitor 2.22.1-0ubuntu2 is an improvement, but it only seems to be a relative improvement of around 33% to me.

So even at 2.22.1-0ubuntu2 gnome-system-monitor is causing Xorg to use 40% CPU on a "reasonable" Core Duo (was 60% before) just to draw the CPU graph. That's still almost one whole CPU core.

I wouldn't say this bug is fixed yet. Certainly *most* of the problem is still present.

(using xserver-xorg-video-intel 2:2.2.1-1ubuntu12)

Sebastien Bacher (seb128) wrote :

the change is not perfect but the performances issues are mainly due to cairo and xorg and not easy to fix, the update is supposed to make things slightly better though

Matt Price (matt-price) wrote :

On Thu, 2008-05-08 at 10:01 +0000, Sebastien Bacher wrote:
> the change is not perfect but the performances issues are mainly due to
> cairo and xorg and not easy to fix, the update is supposed to make
> things slightly better though
>
confirming an improvement on my core duo system -- usage with a
mid-sized window drops to 30%-ish, fortunately not a crushingly bad
situation, but still notso great if you're trying to measure cpu usage
in an already sluggish situation! it'd be great if any future updates
got posted to this bug report, i look forward to the complex xorg/cairo
issues being worked out in intrepid! thanks,
matt

--
Matt Price
<email address hidden>

Great improvement.
Screenshots before-after attached.

Anders Häggström (hagge) wrote :

The fix "2.22.1-0ubuntu2" did not fix this problem for me! It has been a little improvment but the system-monitor is still useless when I try to measure CPU usage compared to "% top". It is worst when the moitor is maximized, as stated above.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 1852.338
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts
bogomips : 3708.71
clflush size : 32

Anders Häggström (hagge) wrote :
Anders Häggström (hagge) wrote :
Anders Häggström (hagge) wrote :
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gnome-system-monitor:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Seriously, please do not leave this bug in Fix-anything state. Evidence from all involved shows there is still a significant CPU hit caused by running gnome-system-monitor which is not really good enough for something that's meant to be a CPU graph.

If you close this bug off, someone new is just going to log it again because it's not fixed. And then there will be contention over whether the new bug is a duplicate of something fixed when it is actually still a real problem.

atorch (atorch) wrote :

This bug is still a problem for me; it makes the system monitor useless/unusable, and instead I have to run "top" in a terminal if I want to monitor CPU usage.

I have dual-core processors, which seems to be the case with a lot of the people reporting this bug.

(Now, I don't know if that's because a large fraction of people using Ubuntu have dual-core processors to begin with, or if dual processors actually cause the problem. Is [ Probability( Experience problem given Dual Processors ) >> Probability( Experience problem given Single Processor ) ] ?

I also think that the CPU usage is still too high. But we can't take over this bug and reset it's status to "New" or whatever because a fix _has_ been released. And it probabably fixed the issue for some.
I created
Bug #230022 "gnome-system-monitor Resources tab CPU usage is unacceptable - disable fancy graphs?"
for the still-high CPU usage. Comment there on the CPU-usage issue please!

Sebastien Bacher (seb128) wrote :

maybe people could comment on the bugzilla bug and ask them to reopen the bug adding the details you are adding on launchpad? the issue is not ubuntu specific and should be discussed upstream too

cutlerite (cutlerite) wrote :

Why does this bug say "fix released?" the only programs I am running is firefox and gnome system monitor, and when I type it is hitting 100%?

How do I get this fix that has been released? I'm running 8.04 fully updated as of today.

Sebastien Bacher (seb128) wrote :

the situation is clearly not optimal yet but people should comment upstream about the issue

Changed in gnome-system-monitor:
status: Fix Committed → Triaged
Christopher Lees (leezer3) wrote :

Some of the blame for this needs to be pointed at shoddy video drivers- While there must be an issue with gnome-system-monitor underlying things, many video drivers don't seem to be helping things.
nv is a nasty culprit- Switching to vesa has reduced cpu from 100% maxed to 60% (Idle!)
Specs fwiw-
Athlon64 3000+ (S754)
756mb RAM

cutlerite (cutlerite) wrote :

However, even when I don't have a video card installed, I still
experience slowness. Even when the only program I run is
gnome-system-monitor, I reach about 45%.

Whatever is changing is not for the better. In the feisty days, I
could run many things all under 4%. Gutsy under 20%. and now Hardy
100%.

On Mon, May 19, 2008 at 9:40 AM, Christopher Lees <email address hidden> wrote:
> Some of the blame for this needs to be pointed at shoddy video drivers- While there must be an issue with gnome-system-monitor underlying things, many video drivers don't seem to be helping things.
> nv is a nasty culprit- Switching to vesa has reduced cpu from 100% maxed to 60% (Idle!)
> Specs fwiw-
> Athlon64 3000+ (S754)
> 756mb RAM
>
> --
> System monitor causes Xorg to consume 100% CPU
> https://bugs.launchpad.net/bugs/187383
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Andrew Conkling (andrewski) wrote :

On Mon, May 19, 2008 at 5:51 PM, cutlerite <email address hidden> wrote:

> However, even when I don't have a video card installed, I still
> experience slowness.
>

...and a decided lack of a screen? You will always have some sort of video
card installed.

And yes, Christopher, the problem with the new smooth graphs is likely not
caused by g-s-m itself, but probably by the cairo layer it's using to create
the graphs. Not much to be done about it here, IMO. I tried cleaning these
bugs up a while ago, but no one would have it.

There are some solutions to the problem. Dropping smooth scrolling (but not smooth curved lines) is one of them. Dropping the fixed-position vertical lines is another.
Please see the gnome Bugzilla (good idea anyway, no action there for a week).

Martin Pitt (pitti) wrote :

Unsub'ing ubuntu-sru. Please resubscribe if there is a new patch for Hardy.

Anil (anilkumar911) wrote :

I am facing similar problem from yesterday(9 jul 2008). xorg process consumes 99% cpu and system becomes less responsive.
My system is

1) T60 laptop
2) Dual core
3) Nvidia graphics card.

I logged out and logged in using XFCE desktop environment. and everything is fine. Xorg take only 5-15% OF CPU.

so it could be something to do with gnome.

psypher (psypher246) wrote :

still a problem in latest intrepid. changed my graphs refresh rate to 5, help a little. still not right though

Vlad Kamys (vkamys) wrote :

I think i may have the same problem.
HP Pavilion dv5 laptop
nvidia geforce 9600gt graphics
Core2 duo processor
centrino 2

ullix (ullix) wrote :

I have a similar issue with a Ubuntu Intrepid install on an Acer Aspire One netbook, where gnome-system-monitor plus Xorg consume 60+% CPU, shown both by top and g-s-m.

Running top in maximized gnome-terminal after cold start. CPU usage from Xorg:1-3%, total: 3-5%
Starting g-s-m and hiding behind the maximized terminal window: CPU usage slowly creeps up, becoming stable at CPU usage as reported by top of Xorg:~35% and g-s-m:~35%. All other processes combined <3%. Load average by top after ~10min is 0.73/0.78/0.56. Switching to the g-s-m window shows CPU1 and CPU2 each at 30-40%.

uname -a: Linux aa1 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux

and the very same after upgrade, now:
uname -a: Linux aa1 2.6.27-8-generic #1 SMP Thu Nov 6 17:33:54 UTC 2008 i686 GNU/Linux

goto (gotolaunchpad) on 2008-12-07
Changed in gnome-system-monitor:
status: Fix Released → Unknown
goto (gotolaunchpad) wrote :

I think that this has to do with the video driver. The new graph uses cairo (?) and this must be rendered. This has to do the graphic card, but it the driver does not support this, the CPU must do this, which results in a very heavy CPU usage.
That a new nvidia driver could fix this problem shows, that the graphics driver has to do with it.

I have for example and AMD/ATI radeonhd 3200 onboard and use the radeonhd driver and I suffer from this bug.

goto (gotolaunchpad) wrote :

Would it make sense to open an Xorg bug report for this?

Sitsofe Wheeler (sitsofe) wrote :

(apologies for the spam)

goto:
Please try avoid forward duping bugs (bug #104013 is far older than this one) without good reason. Forward duping kinda throws away reputation and age information (I say credit should go to the person who mentioned it first when possible).

goto (gotolaunchpad) wrote :

Sorry for that. I just wanted to help. And it is in fact a duplicate, so why not mark it as one?
There were two good reasons for doing so:
1. This bug had 18 duplicates or so, and every single one would must have been edited to the older duplicate bug.
2. This bug has more information.

I think it is the best for all to have only one bug report open for each bug. And I'm sorry for the reputation, but if reputation is so important for someone, one could search for duplicates and then mark them as duplicates of the own bug. In general you are of course right, the first bug should be the main bug, if there are no reasons against it.

Changed in gnome-system-monitor:
status: Unknown → Fix Released
Changed in gnome-system-monitor:
status: Triaged → Fix Committed
Changed in gnome-system-monitor:
status: Unknown → Fix Released
Bimme (joakim-launchpad) wrote :

I can see that a fix has been comitted for Ubuntu, but in which version is it included? 2.24.1?
I have the same problem in Jaunty using version 2.24.1. I used to have the ATI driver, but it made the complete system too slow. When I turned off the ATI driver the system is usable. With both drivers the CPU usage is going to 100% when displaying the resources tab in the System Monitor.

DougieFresh4U (butcheeyboy) wrote :

Having issue with 'gnome' Jaunty. Dual core AMD X2 5200
Jumping 100% back and forth between CPU's

KevinM (kevbert1) wrote :

Briefly had this with Jaunty Kubuntu kernel 2.6.28-8 64 bit, but was able to get rid of it with an update and reboot (see http://ubuntuforums.org/showthread.php?t=1076257).

lavinog (lavinog) wrote :

Looking at load-graph.cpp:
load_graph_expose() looks to be using cairo_curve_to() for every point on every refresh. This interpolation seems to me to be wasteful when there is no change in data. Memory usage tends to be a straight line.
I propose doing a quick check in the for loop to compare the current data with previous and if the difference is less than a certain amount, use cairo_line_to() instead.

The other option would be to offer a preference to use lines instead of curves.

Both options should be easy to implement.

You should probably rather discuss that upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=507797

l0l0l0l0l (matthewphiliphall) wrote :

just installed gloria 7 xfce. same problem.lspci:

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

alien8tive (science) on 2009-08-22
Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Hew McLachlan (hew) wrote :

It appears this was fixed some time ago.

Changed in gnome-system-monitor (Ubuntu):
status: Fix Committed → Fix Released
Locutus of Ork (b-broden) wrote :
Download full text (6.9 KiB)

I don't think this is fixed. Gnome-System-Monitor (System Monitor 2.28.0) sometimes consumes about 80% of one CPU Core.

My machine Core2Duo / 8 GB Ram / Ubuntu 9.10 Karmic

Additional information:

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:03.0 Communication controller: Intel Corporation 4 Series Chipset HECI Controller (rev 03)
00:03.2 IDE interface: Intel Corporation 4 Series Chipset PT IDER Controller (rev 03)
00:03.3 Serial controller: Intel Corporation 4 Series Chipset Serial KT Controller (rev 03)
00:19.0 Ethernet controller: Intel Corporation 82567LM-3 Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801JD/DO (ICH10 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a2)
00:1f.0 ISA bridge: Intel Corporation 82801JD (ICH10D) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801JD/DO (ICH10 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801JD/DO (ICH10 Family) SMBus Controller (rev 02)

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 046d:c313 Logitech, Inc.
Bus 001 Device 004: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Disk /dev/sda: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifi...

Read more...

tjk (tim-klassen) wrote :

While the CPU system monitor widget was on my KDE4 panel I had very high CPU usage. Added the widget just to see what would happen and the CPU % went up again.

Kangarooo Jānis (kangarooo) wrote :

Wow this bug is reallly old. and on clean install on 10.04 xubuntu its not fixed and also upgrading to 10.04 its not fixed
changing to 2.0sec cpu usage droped from 100% to 60%
I changed to 5.0sec and that made cpu to be 23-27 when doing nothing on that

Barakooda (barak00) wrote :

Same bug here.
Fresh Ubuntu 10.04 64bit installation
Same problem , 2 or 1 of my 8 core are running in 100%.

Changed in gnome-system-monitor:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.