duplex printing gone

Bug #885118 reported by dejot on 2011-11-02
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
Medium
ghostscript (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Unabl4e to do duplex printing using Ubuntu 11.10 , Brother 2170W printer. My set-up is dual booting with Win 7 and Ubuntu current version connected to the printer by wireless. Windows (Word) prints duplex without difficulty but I have been unable to duplex print with Ubuntu since leaving 10.04 where it worked fine. The problem seems to be program independent; I am using Libre in Ubuntu. I strongly suspect that the driver for the printer in Ubuntu is inappropriate. All advice will be appreciated.

I can confirm this problem with a Samsung ML-2580 Series printer.

Duplex printing worked flawlessly in Ubuntu 10.10. With Ubuntu 11.10 it still shows the Duplex-Print options in the print dialog, but the setting has no effect.

The problem occurs in all tested programs (Libre Office Writer, Evince).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Peter Adolphs (futzilogik) wrote :

There might be several issues here:

1) The Printer Setting tool in Ubuntu 11.10 doesn't show most printer configuration options. The only configuration which the Printer Setting tool exposes to me seems to be the list of allowed users. I cannot configure the availability of a duplex unit, the installed paper trays, paper sizes, etc, using this tool.

My workaround is to set all these options for your printer using the CUPS web interface (http://localhost:631/).

2) The Gnome print dialogs seem to ignore the duplex setting, even if the printer is configured to have a duplex unit. I have added two HP laser printers and they are configured to have a duplex unit, which I checked with the CUPS web interface. The Gnome print dialogs show the duplex options but changing the setting has no effect. Note that the duplex setting in the print dialog of Libre Writer is respected for me. So it really seems to be a Gnome print dialog bug.

My workaround is to set the printers options to always print in duplex mode via the CUPS web interface, since this is what I usually want.

@dejot & Andreas Stöckel: Can you check whether your printer is configured to have a duplexer using the CUPS web interface? Do my other observations also hold for your setup?

On 11/18/2011 03:05 AM, Peter Adolphs wrote:
> There might be several issues here:
>
> 1) The Printer Setting tool in Ubuntu 11.10 doesn't show most printer
> configuration options. The only configuration which the Printer Setting
> tool exposes to me seems to be the list of allowed users. I cannot
> configure the availability of a duplex unit, the installed paper trays,
> paper sizes, etc, using this tool.
>
> My workaround is to set all these options for your printer using the
> CUPS web interface (http://localhost:631/).
>
> 2) The Gnome print dialogs seem to ignore the duplex setting, even if
> the printer is configured to have a duplex unit. I have added two HP
> laser printers and they are configured to have a duplex unit, which I
> checked with the CUPS web interface. The Gnome print dialogs show the
> duplex options but changing the setting has no effect. Note that the
> duplex setting in the print dialog of Libre Writer is respected for me.
> So it really seems to be a Gnome print dialog bug.
>
> My workaround is to set the printers options to always print in duplex
> mode via the CUPS web interface, since this is what I usually want.
>
> @dejot& Andreas Stöckel: Can you check whether your printer is
> configured to have a duplexer using the CUPS web interface? Do my other
> observations also hold for your setup?
>
Thank you for your input on this problem. It is evident that you are a
more sophisticated user than I. Following receipt of your note I went to
the Ubuntu installation menu and installed "printers" as well as the
printing that was already installed. I got there by searching for
'cups'. Once installed it did nothing to improve the duplex problem.

I may be missing something due to my lack of understanding. I do not
know how to check the system further. When I click on print in the file
menu there is clearly an option to do duplex printing but it does not
work. Again, any helpful input will be appreciated---I'll try anything
that fixes the problem but the problem should not be present at all!

Till Kamppeter (till-kamppeter) wrote :

Can everyone who has this problem please attach the following for the printer and for a job where the problem occurs:

1. The PPD file of the printer: /etc/cups/ppd/<print queue name>.ppd
2. Original file which you tried to print
3. error_log as described in "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems
4. Captured print job as described in "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems

Do not compress or package together the attachments. It is no problem to post several comments to get all the files attached.

Please tell also how/with which application you printed the file.

Attach the above set of files for each printer with which you have the problem.

Tell also whether you have other printers on which the problem does not occur. Tell us make, model, and driver, and attach the PPD file of each of these printers: /etc/cups/ppd/<print queue name>.ppd

Changed in cups (Ubuntu):
status: Confirmed → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Tell us also which desktop (Unity or GNOME shell/Classic) you are using.

Dan Devor (ddevor) wrote :

On 11/18/2011 07:19 AM, Till Kamppeter wrote:
> Tell us also which desktop (Unity or GNOME shell/Classic) you are using.
>
Unity but the problem was the same when I used Gnome.

I greatly appreciate the fact that attention is being given to this problem.

Dan Devor

Dan Devor (ddevor) wrote :

On 11/18/2011 07:18 AM, Till Kamppeter wrote:
> Can everyone who has this problem please attach the following for the
> printer and for a job where the problem occurs:
>
> 1. The PPD file of the printer: /etc/cups/ppd/<print queue name>.ppd
> 2. Original file which you tried to print
> 3. error_log as described in "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems
> 4. Captured print job as described in "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems
>
> Do not compress or package together the attachments. It is no problem to
> post several comments to get all the files attached.
>
> Please tell also how/with which application you printed the file.
>
> Attach the above set of files for each printer with which you have the
> problem.
>
> Tell also whether you have other printers on which the problem does not
> occur. Tell us make, model, and driver, and attach the PPD file of each
> of these printers: /etc/cups/ppd/<print queue name>.ppd
>
>
> ** Changed in: cups (Ubuntu)
> Status: Confirmed => Incomplete
>
1. I have no idea of what you are talking about. I just use the
standard, automatic settings and "print queue name" is just whatever the
OS gives it.

2. I doubt that you really want the original file(s) unless you are
interested in a 96 page cookbook. I have tried to print it in .doc and
.odt and the result is the same. I have also done the same with a simple
2 page document (both .odt and .doc) and the result is the same of no
duplex printing. I have used Word XP and Libre and Open Office. All have
the same outcome.

3. and 4. I have never tried either of these. I would have to try again
to print a document to try to get this information for you. If you feel
it is critical, let me know and provide whatever instructions would be
helpful.

Till Kamppeter (till-kamppeter) wrote :

Dan, for each print queue a file named <print queue name>.ppd is stored in /etc/cups/ppd/. It describes the printer's properties, which driver is used, which user-settable options are there, and what are the default settings for the options. So with this file we can especially see which driver is used and whether all option defaults are set correctly by CUPS.

For (2) it is enough if you attach the 2-page file which also fails for you. The complete 96-page file is not needed. This can help us to reproduce the bug.

For (3) and (4) follow the instructions on the linked web page, sending the failing print job (the 2-page file is enough) again. Also this helps us to reproduce the bug and tells us what each CUPS filter is exactly doing when converting the print job data sent by the application to printer's native language.

Hi,

I'm going to attach all wanted information. I'm using Gnome 3 with the Gnome Shell. I used gedit to print the document.

Dan Devor (ddevor) wrote :

On 11/18/2011 08:52 AM, Till Kamppeter wrote:
> Dan, for each print queue a file named<print queue name>.ppd is stored
> in /etc/cups/ppd/. It describes the printer's properties, which driver
> is used, which user-settable options are there, and what are the default
> settings for the options. So with this file we can especially see which
> driver is used and whether all option defaults are set correctly by
> CUPS.
>
> For (2) it is enough if you attach the 2-page file which also fails for
> you. The complete 96-page file is not needed. This can help us to
> reproduce the bug.
>
> For (3) and (4) follow the instructions on the linked web page, sending
> the failing print job (the 2-page file is enough) again. Also this helps
> us to reproduce the bug and tells us what each CUPS filter is exactly
> doing when converting the print job data sent by the application to
> printer's native language.
>
The file that I attempted to print in duplex printing is enclosed as an
attachment.

The result of looking at /etc/cups/ppd is enclosed as an attachment. If
it does not come through or not what you want, please inform me and I'll
try again.

I have been using delete on re'cd messages and thus lost the previous
communication that gave the links to how to do 3) and 4). Kindly resend
that material and I will follow through as best I can. (And maybe I'll
stop using delete on messages.)

1 and 2 down, 3 and 4 to go.

Thank you for the files. I have investigated them and the problem seems to be in Ghostscript. I have reported it to the Ghostscript developers upstream:

http://bugs.ghostscript.com/show_bug.cgi?id=692691

affects: cups (Ubuntu) → ghostscript (Ubuntu)
Changed in ghostscript (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
milestone: none → oneiric-updates

Dan, your problem seems to be another than Andreas' (comment #14 was related to Andreas' files). So please send the files for (3) and (4) so that I can investigate your problem.

Dan Devor (ddevor) wrote :

Till,
I have tried unsuccessfully to follow the instructions in the wicki to
get the information you need. I have tried to follow the instructions
but they are for Gnome and not Unity. As far as I can tell the
instruction to go to Administration, etc. is no longer in Unity. I am
very frustrated by this. I tried to use the terminal and was able to
disable cups but then a dead end (see below).

I think there is a program to permit you to operate my computer remotely
and that may be the best way to work this out. If so, what is the
program and what information do we need to permit you to do this?

I have followed the instructions in capturing print job section but when
I follow instruction 2 ( cupsdisable) I can't complete instruction 3 to
print the job since the printer no longer responds. Only when I follow
instruction 6 does it respond.

Dan Devor

Dan Devor (ddevor) wrote :
Download full text (1.2 MiB)

W [18/Nov/2011:06:50:54 -0800] failed to AddProfile:
org.freedesktop.ColorManager.Failed:profile object path
'/org/freedesktop/ColorManager/profiles/Brother_HL_2170W_series_Gray__'
has already been added
W [18/Nov/2011:06:50:54 -0800] failed to AddProfile:
org.freedesktop.ColorManager.Failed:profile object path
'/org/freedesktop/ColorManager/profiles/Brother_HL_2170W_series_Gray__'
has already been added
I [18/Nov/2011:13:46:13 -0800] Listening to [v1.::1]:631 (IPv6)
I [18/Nov/2011:13:46:13 -0800] Listening to 127.0.0.1:631 (IPv4)
I [18/Nov/2011:13:46:13 -0800] Listening to /var/run/cups/cups.sock (Domain)
I [18/Nov/2011:13:46:13 -0800] Remote access is disabled.
D [18/Nov/2011:13:46:13 -0800] Added auto ServerAlias biostar
I [18/Nov/2011:13:46:13 -0800] Loaded configuration file
"/etc/cups/cupsd.conf"
I [18/Nov/2011:13:46:13 -0800] Using default TempDir of
/var/spool/cups/tmp...
I [18/Nov/2011:13:46:13 -0800] Configured for up to 100 clients.
I [18/Nov/2011:13:46:13 -0800] Allowing up to 100 client connections per
host.
I [18/Nov/2011:13:46:13 -0800] Using policy "default" as the default.
D [18/Nov/2011:13:46:13 -0800] load_ppd: Loading
/var/cache/cups/Brother-HL-2170W-series.data...
D [18/Nov/2011:13:46:13 -0800] Calling
DeleteDevice(cups-Brother-HL-2170W-series)
D [18/Nov/2011:13:46:13 -0800] failed to DeleteDevice:
org.freedesktop.DBus.Error.InvalidArgs:Type of message, `(s)', does not
match expected type `(o)'
D [18/Nov/2011:13:46:13 -0800] Using profile id of
Brother-HL-2170W-series-Gray..
D [18/Nov/2011:13:46:13 -0800] Calling
CreateProfile(Brother-HL-2170W-series-Gray..,temp)
D [18/Nov/2011:13:46:13 -0800] created profile
/org/freedesktop/ColorManager/profiles/Brother_HL_2170W_series_Gray__
I [18/Nov/2011:13:46:13 -0800] Registering ICC color profiles for
"Brother-HL-2170W-series"
D [18/Nov/2011:13:46:13 -0800] Calling
CreateDevice(cups-Brother-HL-2170W-series,temp)
D [18/Nov/2011:13:46:13 -0800] created device
/org/freedesktop/ColorManager/devices/cups_Brother_HL_2170W_series
D [18/Nov/2011:13:46:13 -0800] Calling
/org/freedesktop/ColorManager/devices/cups_Brother_HL_2170W_series:AddProfile(/org/freedesktop/ColorManager/profiles/Brother_HL_2170W_series_Gray__)
[soft]
W [18/Nov/2011:13:46:13 -0800] failed to AddProfile:
org.freedesktop.ColorManager.Failed:profile object path
'/org/freedesktop/ColorManager/profiles/Brother_HL_2170W_series_Gray__'
has already been added
D [18/Nov/2011:13:46:13 -0800]
cupsdRegisterPrinter(p=0x7f3764ea4540(Brother-HL-2170W-series))
D [18/Nov/2011:13:46:13 -0800] cupsdMarkDirty(---p--)
D [18/Nov/2011:13:46:13 -0800] cupsdSetBusyState: newbusy="Dirty files",
busy="Not busy"
I [18/Nov/2011:13:46:13 -0800] Partial reload complete.
I [18/Nov/2011:13:46:13 -0800] Listening to [v1.::1]:631 on fd 9...
I [18/Nov/2011:13:46:13 -0800] Listening to 127.0.0.1:631 on fd 10...
I [18/Nov/2011:13:46:13 -0800] Listening to /var/run/cups/cups.sock:631
on fd 11...
I [18/Nov/2011:13:46:13 -0800] Resuming new connection processing...
D [18/Nov/2011:13:46:13 -0800] cupsdSetBusyState: newbusy="Dirty files",
busy="Dirty files"
D [18/Nov/2011:13:46:13 -0800] Discarding unused server-restarted event...
D...

Dan Devor (ddevor) wrote :

Dan, I updated the Wiki now to tell users how to find system-config-printer on Unity desktops.

Dan Devor (ddevor) wrote :

A fix for this problem was proposed by the upstream developers (see upstream bug report). I have tested it and it works. I will prepare a Stable Release Update (SRU) of Ghostscript for Oneiric soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-2ubuntu3

---------------
ghostscript (9.04~dfsg-2ubuntu3) precise; urgency=low

  * debian/patches/020111122-cd8f397-ps2write-fix-handling-of-format-4-cmap-subtables-in-truetype-fonts.patch:
    ps2write: Fixed handling of format 4 CMAP subtables in TrueType fonte. This
    made several characters coming out as garbage when converting PDF to
    PostScript (LP: #891074).
  * debian/patches/020111122-5cce070-ps2write-postscript-duplex-command-insertion.patch:
    ps2write: Insertion of duplex printing commands from PPD files into
    ps2write-generated PostScript did not have any effect, making duplex
    printing on PostScript printers not work in many cases (LP: #885118).
 -- Till Kamppeter <email address hidden> Tue, 22 Nov 2011 10:46:59 +0100

Changed in ghostscript (Ubuntu):
status: Triaged → Fix Released

Uploaded a fixed Ghostscript package for Oneiric (fixing this bug and bug 891074) to -proposed. As soon as the upload gets approved you will be asked for testing the package by a separate comment. Please test the package then as otherwise it will not make it into the updates for everyone. debdiff of the changes is attached.

Changed in ghostscript (Ubuntu Oneiric):
status: New → Fix Committed
milestone: none → oneiric-updates
Changed in ghostscript (Ubuntu):
milestone: oneiric-updates → none
Changed in ghostscript (Ubuntu Oneiric):
importance: Undecided → High

Hello dejot, or anyone else affected,

Accepted ghostscript into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I have down loaded all updates that I am aware of and as yet no
improvement. I will follow up after the Thanksgiving holiday.

On 11/22/2011 03:27 AM, Till Kamppeter wrote:
> Uploaded a fixed Ghostscript package for Oneiric (fixing this bug and
> bug 891074) to -proposed. As soon as the upload gets approved you will
> be asked for testing the package by a separate comment. Please test the
> package then as otherwise it will not make it into the updates for
> everyone. debdiff of the changes is attached.
>
>
> ** Also affects: ghostscript (Ubuntu Oneiric)
> Importance: Undecided
> Status: New
>
> ** Changed in: ghostscript (Ubuntu Oneiric)
> Status: New => Fix Committed
>
> ** Changed in: ghostscript (Ubuntu Oneiric)
> Milestone: None => oneiric-updates
>
> ** Changed in: ghostscript (Ubuntu)
> Milestone: oneiric-updates => None
>
> ** Changed in: ghostscript (Ubuntu Oneiric)
> Importance: Undecided => High
>
> ** Patch added: "ghostscript_9.04~dfsg-0ubuntu11.1_9.04~dfsg-0ubuntu11.2.debdiff"
> https://bugs.launchpad.net/ubuntu/+source/ghostscript/+bug/885118/+attachment/2604831/+files/ghostscript_9.04%7Edfsg-0ubuntu11.1_9.04%7Edfsg-0ubuntu11.2.debdiff
>

Dan, your problem is not covered by the fix. The fix applies to a bug in PDF->PostScript conversion, where the generated PostScript does not allow duplex on PostScript printers. In your case there is a direct conversion from PDF to PCL. Please try as alternative driver for your printer "Generic PCL-5e printer" with the "Foomatic/ljet4d" driver for example.

I've upgraded to the -proposed package (ghostscript etc. were updated), yet the problem is not solved, even the captured printout is byte-identical to the one attached above.

I've tried it several times, restarted cups and the complete computer and double checked that the -proposed package is really installed.

Andreas, so your captured print data is byte identical to the attachment of comment #13? This is OK, as Ghostscript only acts in a later stage.

Please run the following commands in a terminal window:

dpkg -l | grep libgs
dpkg -l | ghostscript

Please also attach a new error_log. Thanks.

Changed in gs-gpl:
importance: Unknown → Medium
status: Unknown → Fix Released
Lars Karlitski (larsu) wrote :

I've just verified that the proposed ghostscript fix works.

However, there's a different bug when printing from the GTK+ dialog (all GNOME apps including firefox and thunderbird) which prevents the duplex option from being passed through to the printer if it isn't passed as the standard CUPS option. I'll file a separate bug about that shortly. This problem can be worked around by:

* enabling duplex by default (System Settings / Printing / right click on the printer: properties / Printer Options)
* re-configuring the printer as "Generic Postscript Printer Foomatic" (click on the "Change" button behind "Make and Model" in the printer settings)
* printing from LibreOffice

tags: added: verification-done
removed: verification-needed
Lars Karlitski (larsu) wrote :

Reported the other problem as bug #897723.

Dan Devor (ddevor) wrote :

I have tried all sorts of combinations with either no improvement or a
complete loss of the option to use duplex printing. I entered Generic
PCL-5e with Foomatic/ljet4d and it worked once (no duplex printing) and
wound up with the printer having no connection. Just to tell you where I
am now: Brother HL-2170W (dhcppc1, 192.168.1.100)...LPD network printer
via dns-sd (there are two other options but not tried)...Brother HL2170W
Foomatic/hpijs-pd5e...double sided printing on. Still no duplex printing
but connected to printer. Do I have some basic setting wrong? I'm down a
lot of paper and a lot of time. Your patience and input is appreciated.
Any more ideas?

On 11/23/2011 12:25 AM, Till Kamppeter wrote:
> Dan, your problem is not covered by the fix. The fix applies to a bug in
> PDF->PostScript conversion, where the generated PostScript does not
> allow duplex on PostScript printers. In your case there is a direct
> conversion from PDF to PCL. Please try as alternative driver for your
> printer "Generic PCL-5e printer" with the "Foomatic/ljet4d" driver for
> example.
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-0ubuntu11.2

---------------
ghostscript (9.04~dfsg-0ubuntu11.2) oneiric-proposed; urgency=low

  * debian/patches/020111122-cd8f397-ps2write-fix-handling-of-format-4-cmap-subtables-in-truetype-fonts.patch:
    ps2write: Fixed handling of format 4 CMAP subtables in TrueType fonte. This
    made several characters coming out as garbage when converting PDF to
    PostScript (LP: #891074).
  * debian/patches/020111122-5cce070-ps2write-postscript-duplex-command-insertion.patch:
    ps2write: Insertion of duplex printing commands from PPD files into
    ps2write-generated PostScript did not have any effect, making duplex
    printing on PostScript printers not work in many cases (LP: #885118).
 -- Till Kamppeter <email address hidden> Tue, 22 Nov 2011 12:03:59 +0100

Changed in ghostscript (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Dan, can you attach the following for each driver/print queue with which you are able to print, but not duplex, always for a job where you select duplex printing in the print dialog:

1. The PPD file of the printer: /etc/cups/ppd/<print queue name>.ppd
2. Original file which you tried to print
3. error_log as described in "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems
4. Captured print job as described in "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems
5. Clone the print queue via the commands

cupsctl FileDevice=yes
lpadmin -p <print queue name>-file -E -v file:/tmp/printout -P /etc/cups/ppd/<print queue name>.ppd

Print the same job to this queue and attach /tmp/printout (Use "sudo chmod 777 /tmp/printout" to make the file readable for normal users).

Dan Devor (ddevor) wrote :

Till,
I am at an impasse right at the beginning of instructions. For 1. I have
printed a 2 page document in duplex mode (comes out non-duplex) using
Libre and then tried to view the queue by going to
'printers/properties/view queue' but there is no entry there. I have
also gone to 'home' and etc/cups/ppd but there does not seem to be
anything with 'print queue name' but just the extensive file. I used
the terminal to enter /etc/cups/ppd/COOKBOOK_12-title page.doc.ppd but I
get 'no such document.' I must be missing something or not understanding
the instruction.

On 11/30/2011 12:30 PM, Till Kamppeter wrote:
> Dan, can you attach the following for each driver/print queue with which
> you are able to print, but not duplex, always for a job where you select
> duplex printing in the print dialog:
>
> 1. The PPD file of the printer: /etc/cups/ppd/<print queue name>.ppd
> 2. Original file which you tried to print
> 3. error_log as described in "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems
> 4. Captured print job as described in "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems
> 5. Clone the print queue via the commands
>
> cupsctl FileDevice=yes
> lpadmin -p<print queue name>-file -E -v file:/tmp/printout -P /etc/cups/ppd/<print queue name>.ppd
>
> Print the same job to this queue and attach /tmp/printout (Use "sudo
> chmod 777 /tmp/printout" to make the file readable for normal users).
>

Dan, note that <print queue name> has to get replaced by the name of the print queue not the name of the file which you have printed. You find the name of the print queue either under the icon representing the printer in system-config-printer or by running the command

lpstat -v

in a terminal window, getting the name of each print queue right after the "device for " and before the ":".

It is correct that the print queue is empty when the job is printed. Every printed job is removed from the queue.

Can everyone who has still problems with duplex printing have a look at bug 897723 and test the proposed package there (see comment #5 in that bug). Please give feedback on that bug.

This bug as bitten me at the upgrade to 12.04 --- in the printer settings "option" there are no options available, and double-side is marked as not available. I could have the functionality back by editing localhost:631 directly... should I open another bug?

Romano, this bug and bug 897723 are fixed. Your problem has most probably another origin. Please open a new bug report following the instructions on https://wiki.ubuntu.com/DebuggingPrintingProblems, especially also of the sections "CUPS error_log" and "Capturing print job data".

John Hiatt (johnwhiatt) wrote :

I just went through the same problem while installing Ubuntu 12.04 Unity. My printer is a Brother 2270DW, but it has been working perfeclty (duplex printing) using the 2170W driver under Linux Mint 11, 12, and 13. Selecting 2 sided printing in job options was possible, but the setting would revert to one sided when the apply or approve button was clicked. Under Mint 13 I had the same problem initially, but after logging out then logging back in, the 2 sided printer setting worked. This was not the case in Ubutu 12.04.

This is the printer setting that was selected by defalut:
Brother HL-2170W Foomatic/hpijs-pcl5e (recommended)

I found Peter's comment (#3 from 2011-11-18) about using the CUPS web interface (http://localhost:631/), and this solved my problem. It was under the "Modify Printer" section, which required inputting the Administrator password. This allowed changing the setting to 2 sided printing. Upon going back to the Printing Properties, that change was made!

Note: this setting is hidden under a "+More" button, which is just under the Pages per Side box.

Floris (fgjzoet) wrote :

I just reported a similar bug for 12.04 LTS, tagged 1081065

I confirm the above for my Epson printer.
Any file does not print in duplex (tested both pdf and office). The duplex option just is not selectable (either greyed-out or auto-resets to single page). 10.04 LTS gave no problems.

Since it is more printer brands and was not a problem on 10.04 I suspect it is not the printer brands drivers but Ubuntu that causes the flaw.

Printer: Epson SX535WD
Drivers I had installed on 10.04 LTS:
- epson-inkjet-printer-escpr_1.2.0-1lsb3.2_amd64.deb
- epson-inkjet-printer-201106w_1.0.1-1lsb3.2_amd64.deb

Drivers I have installed on 12.04 LTS (1 updated, 1 the same)
- epson-inkjet-printer-escpr_1.2.2-1lsb3.2_amd64.deb (newer)
- epson-inkjet-printer-201106w_1.0.1-1lsb3.2_amd64.deb (same)

Floris (fgjzoet) wrote :

I am now able to duplex print on the Epson SX535WD. Followed steps:

- go to http://localhost:631/
- select 'printers'
- select your printer (should list your printer). Printer will be shown with two buttons: 'maintenance' and 'administration'
- under the 'administration' button you have to select 'modify printer'
- click continue, twice
- select the epson inkjet printer 1.0.1-1lsb3.2 driver (instead of, in my case, epson inkjet printer escpr 1.2.2)
- click modify printer.

you should now be able to select duplex mode.

Floris (fgjzoet) wrote :

I guess it might be the epson driver after all...

gadLinux (gad-aguilardelgado) wrote :

Hello,

no it's not your epson driver. I have HP 7250 brand new. With HPLiP drivers and double side printing does not work in gnome.

Aside the fact that the printing control panel does nothing about configuring the printer. Doing a print job with gnome will not print double sided because gtk/gnome print config does not show the option. It shows just "One sided".

Seems to be a problem of the panel.

If I try it with lpr or libreoffice it works perfectly so it's not a driver problem.

In my configuration I have to choose the paper A4 autoduplex to be able to print double sided. Maybe this has something to do . But as I said it works. In libre office it shows "One sided" until I choose the autoduplex paper. Then the setting changes and lets me choose one or two sides.

So the problem is in gnome. It would be nice to have a control panel that lets you configure the printer instead of showing you a list of authorized users... :D

Best regards,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.