Videos tear and "blink" when enabling compiz [AMD Feature #7647] [EPR#257833]

Bug #179042 reported by Zenigata on 2007-12-28
430
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
fglrx
Fix Released
Wishlist
Unassigned
fglrx-installer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg-driver-fglrx

When using the proprietary ati driver that is in the hardy repository with compiz (using aiglx and not xgl), the opengl rendering is buggy :

    there is lots of blinking and every opengl window has an allways on top attribute that makes them (because of the blinking) visible half of the time.

I tried it with the hardy repository doing an upgrade from gutsy to hardy using aptitude dist-upgrade.

I have an amd64 installation

Regards.

--
Z.

Thanks for reporting this issue. Please attach your /var/log/Xorg.0.log, /etc/X11/xorg.conf, and the output from lspci -vvnn. A photograph of your screen showing the issue could be helpful, if that's possible.

Also, we've just uploaded a new version of -fglrx for hardy yesterday; could you update and re-test with version 8-01 to verify the issue is still occurring? Thanks ahead of time!

Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
andrewpmk (andrewpmk) wrote :
andrewpmk (andrewpmk) wrote :

Oops delete the above attachment wrong bug

Timo Aaltonen (tjaalton) wrote :

Again, please attach your xorg.conf and Xorg.0.log.

Zenigata (drebon) wrote :

Sorry for the delay, but I got back to gutsy for a while, now I am back to hardy, and still have some OGL issue with fglrx

Zenigata (drebon) wrote :
Zenigata (drebon) wrote :

Actually, using the fglrx driver and its composite extension to activate compiz result in having buggy rendering of most opengl apps :

 * glchess just gives a black window (it works if compiz is shut down)
 * glxgears is just as buggy as in bug 192550
 * other OGL apps I've tried are either black or with a bug like the one of glxgears 192550

Regards

Bryce Harrington (bryce) on 2008-04-02
Changed in linux-restricted-modules-2.6.24:
importance: Undecided → Medium
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

From your log I see AIGLX is enabled, which as I understand fglrx doesn't support - can you try adding to your server flags section to turn off aiglx and see if that makes the issue disappear?

Bryce Harrington (bryce) on 2008-05-28
Changed in linux-restricted-modules-2.6.24:
status: Triaged → Incomplete
radamo (rathergolf) wrote :

Has anyone done any work on this? I also have this same issue. All open gl apps play choppy or blink... when compiz is enabled.
I am using version 8.3 fglrx through EnvyNG and using the latest updates for Hardy.
Problems with glxgears
googleearth
Mplayer (non full screen)
etc...

Thanks for any help anyone can provide.
RA

treglia (marc-treglia) wrote :

Same problem here with Hardy 32-bit and the 8.3 fglrx driver.

Dim Zoom (dimzoom) wrote :

hello nice to write you :)
I also have blink problemes with openGL application such as googleearth. I am using Linux 2.6.24-18-generic i686 GNU/Linux on a laptop with fglrx driver and an ati radeon 9600 (latest stable). Thanks for your help.

For information I have the same probleme on my desktop computer with free driver R200 (ati radeon 9500)

Dim Zoom (dimzoom) wrote :
Dim Zoom (dimzoom) wrote :

lspci -vvnn

thanks again.

Mario Limonciello (superm1) wrote :

Marking confirmed as it was reproduced on 8-6 too. Nothing we can do about this other than wait for an updated driver.

Changed in fglrx-installer:
status: Incomplete → Triaged
strikton (ton-strik) wrote :

Just switch off compiz for the time being. I reported this bug from the very beginning of the Hardy release 64 bits
Have a Dell Inspiron 531, AMD X2 6000, 64 bit, ATI Radeon 2600 XT.

spandanj (spandanj) wrote :

I have ati mobility radeon x1400 on dell with Ubuntu 8.04.

This bug is SO disappointing. Other than looking at powerpoints, all I do on my computer is watch movies. CRAPPY rendering without OpenGL was such a turn-off for me. I like everything else about Ubuntu, especially Compiz effects. Thus, I dont want to turn off compiz just so i would be able to watch a movie in a decent quality. That is not why i switched to linux. I switched for "better". better support, less bugs.

PLEASE SOLVE THIS .............ASAP. There are lots of ppl with radeon cards

Gabriel Rota (gabriel-rota) wrote :

I have Inspiron 6400 with the same ati and ubuntu 8.04.1 AMD64
and the seme problem Hardy: Opengl flickering with Compiz enabled
http://ubuntuforums.org/showthread.php?t=766655
all ok with compiz off

Gabriel Rota (gabriel-rota) wrote :

I have try on Intrepid
Linux grota-laptop 2.6.27-3-generic #1 SMP Wed Sep 10 16:18:52 UTC 2008 x86_64 GNU/Linux
with xserver-xorg-video-radeon
OpenGL work good, but on close it desktop decoration is corrupted for repair them I must select all desktop area with mouse.
If the OpenGL game is in window and I mouse over on any button like on firefox many graphic defects displayed.

Does this bug need to be reported upstream? or has someone already done so?

strikton (ton-strik) wrote :

It should be reported upstream when that means some work will be done in trying to solve this bug. I didn't because I don't know how to do that.

Gabriel Rota (gabriel-rota) wrote :

I have resolve my problem of OpenGL corruption adding

Option "AccelMethod" "EXA"

vi /etc/X11/xorg.conf

Section "Device"
        Identifier "Configured Video Device"
+ Option "AccelMethod" "EXA"
EndSection

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/269357/comments/2

Gabriel Rota (gabriel-rota) wrote :

I'm sad ... the solution work only on Intrepid, on hardy Xorg.log say :
(WW) fglrx(0): Option "AccelMethod" is not used
and the problem persist ... I have tried also xorg-driver-fglrx-envy but with same result.

Murat Uenalan (muenalan) wrote :

I can absolutely confirm that this bug is *very very* annoying and seems to be independant of processor etc. I am running on an phenom.

Contact me for any debugging.

muenalan,
will this problem be solved in Ubuntu 8.10? will i be able to use google
earth, screensaver, and compiz - all opengl - without a glitch?

thanks.
On Fri, Sep 26, 2008 at 6:27 AM, muenalan <email address hidden> wrote:

> ** Also affects: ezvisage
> Importance: Undecided
> Status: New
>
> ** Also affects: compiz
> Importance: Undecided
> Status: New
>
> --
> [fglrx] fglrx, compiz and opengl conflict
> https://bugs.launchpad.net/bugs/179042
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Spandan Jansari - <email address hidden>

Stefano Maioli (smaioli) on 2008-09-26
Changed in ezvisage:
status: New → Invalid
Changed in compiz:
status: New → Invalid

Here is an instruction how to solve problem with video:

http://www.ubuntugeek.com/fix-for-video-playback-problem-in-compiz-fusion.html

(you must just set video output to X11)

spandanj (spandanj) wrote :

Solution by Omega does not work

for HD 720p movies

I use x11 in smplayer. when i run a 720p movie, it drops frames a Lot=unwatchable. when I select opengl instead, the video is smooth, but there's blinking and tearing.

I have no complains with x11 with normal resolution movies. but, i can't watch 720p movies with x11. it's too laggy. What should I do?

spandanj (spandanj) wrote :

the 720p movie i was trying to watch was TMNT. it was in .mkv format. If the problem is not in x11 in smplayer, it either is 1) corrupt file, 2) too high bitrate in the action scenes. I am encoding a lower resolution one.

However, can a developer assigned to this bug please send out an email to all the subscribers of this email what the status is on this bug. When (realistically) should we expect a proper (final) solution to this bug. Can a developer just do that....tell us in an email. I just want to know if I should move back to xp if the solution will take long to come, something to do with DRI2. Just need a summary in simple language from a developer.

thanks.

Bryce Harrington (bryce) wrote :

Good day Zenigata,

I've just uploaded a new 8.543 version of -fglrx to Intrepid which now should work with xserver 1.5. Would you mind testing this new version and reporting back whether this issue is still present? If it is, it would be helpful if you could (re-)post your Xorg.0.log from running with this version. Thanks ahead of time.

If you don't have Intrepid installed on your system, you can test this by booting an Intrepid LiveCD (available from cdimage.ubuntu.com), using either the -vesa or -ati driver, then update to the latest version of Ubuntu, install fglrx, and then logout and back in. Your /var/log/Xorg.0.log will confirm whether you've loaded FGLRX successfully.

If you find any new issues, please report them as separate bugs. You can use the tool `ubuntu-bug fglrx-installer` which will gather the necessary files and create the launchpad report for you to fill in more easily.

Changed in fglrx-installer:
status: Triaged → Incomplete

Hello.
I've upgraded from 8.04 to intrepid and I've this issue.
I join you the Xorg.0.log requested.
Thx

Changed in fglrx-installer:
status: Incomplete → Triaged
Benjamin Drung (bdrung) wrote :

As Celuldor mentioned in bug #284873, this bug is still not solved in intrepid. It is still flickering. I have attached his Xorg.0.log.

Celuldor (celuldor) wrote :

Übersetzung: Deutsch » Englisch (google)

I noticed at my TV card (FlyVideo A2) with no flicker occurs xdtv

---------
mir ist aufgefallen das bei meiner tv-karte (FlyVideo A2) mit xdtv kein flackern auftritt

Antoine Pairet (b-ly) wrote :

Hi!
If needed I can provide another Xorg.0.log or any other info. I'm running 8.543 version of -fglrx with Intrepid. I had the problem and solved it thanks to this guide:
http://www.ubuntugeek.com/fix-for-video-playback-problem-in-compiz-fusion.html (thx John Omega)

Bryce Harrington (bryce) wrote :

I've upstreamed this to AMD, and they recognize it as a feature request they are already tracking, number #7647.

OpenGL and video playback under desktop effects is not currently considered a supported feature with current -fglrx.

Changed in fglrx:
importance: Undecided → Wishlist
status: New → Triaged

Terminal :
gstreamer-properties

---
tab "Video"

output-plugin "X Window System (NO Xv)"

---
then is videos no "blink" when enabling compiz

---
tested by ati x1250

spandanj (spandanj) wrote :

I have a few questions to clear up my understanding of this problem. It would be great if You can answer them.

1) Does VLC or WMP in windows use opengl to playback video?
2) Does windows have the capability to use opengl in more than one software? or mac? Meaning, Is the problem that OpenGL cannot be used simultaneously (eg. compiz and google-earth) smoothly the major problem in ubuntu?
3) does x11 as a playback device for Mplayer show video with less quality than OpenGL?
4) What's the issue with DRI2? I have complete lack of understanding of DRI, what it is, etc. So, in better words, when can I expect a complete and true solution to this problem (OpenGL used by >1 soft. at a time? <--right?)

thanks

erlguta (gonzalomarcote) wrote :

I have the same problem with Intrepid 32bits and ATI Radeon HD 3450.

ii fglrx-kernel-source 2:8.543-0ubuntu4

Videos (totem, mplayer, vlc), Gogleearth and 3D applications are blinking all the time.

Gabriel says:
>I have resolve my problem of OpenGL corruption adding:
>Option "AccelMethod" "EXA"
>
>vi /etc/X11/xorg.conf

Gabriel your Option does not work for me.

I attach my lspci, Xorg.0.log and xorg.conf

erlguta (gonzalomarcote) wrote :

I forgot to say in the previous post that it only happens with compiz effects enabled.
If i disable it there is not blinking at all.

thom (tsk) wrote :

Running on 8.10 intrepid ibex now.

excerpt xorg.conf:
========================
ection "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "fglrx"
 Option "VideoOverlay" "on"
 Option "OpenGLOverlay" "off"
 BusID "PCI:1:0:0"
EndSection
=======================

while compiz enabled:
The GL problems with games seem to be solved (tested with open arena, pp-racer and sauerbraten).
The afore mentioned videoproblems with Xv are still there, also with GL and GL2 (tested with mplayer and vlc).

thom (tsk) wrote :

addendum:

Still some problems with OpenGL while compiz enabled (tested in googleearth) although drastically less than it used to be.
changed the overlaysettings in every possible way,: no difference

seems that the 8.54.3 driver in intrepid is better than it's predecessors athough not quite there yet ;-)

Zenigata (drebon) wrote :

@spandanj
1) Does VLC or WMP in windows use opengl to playback video?
Well WMP I do not know, but VLC, you can choose

2) Does windows have the capability to use opengl in more than one software? or mac? Meaning, Is the problem that OpenGL cannot be used simultaneously (eg. compiz and google-earth) smoothly the major problem in ubuntu?

Well yes, when I was using Windows, it was possible.
3) does x11 as a playback device for Mplayer show video with less quality than OpenGL?

Yes or no, actually X11 rendering is usually less smooth, sometimes laggy. xv or ogl renderers tends to be smoother, with no need to rescale te video.

jiapei100 (jiapei100) wrote :

Ubuntu 8.04
jia@jia-laptop:~$ uname -a
Linux jia-laptop 2.6.24-21-generic #1 SMP Tue Oct 21 23:43:45 UTC 2008 i686 GNU/Linux

Whenever enable System->Appearance->Visual Effects->Normal

the same phenomenon happens: Google Earth and other Java3D programs start blinking.

jiapei100 (jiapei100) wrote :
Wicked (livewickedly) wrote :

Bryce, to me this bug seems to be a regression, as I have a working 7.10 partition with FGRLX and Compiz. Maybe going back to an older driver would work. I would be happy to test it if you let me know which driver you think is best and provide a link to a download or .deb file.

Bryce Harrington (bryce) wrote :

Wicked, I don't believe any version of -fglrx prior to the current one will work against xserver 1.5.

Bryce Harrington (bryce) wrote :

AMD has accepted this bug as EPR#257833. As mentioned above, they suspect it matches one of their feature development items.

Of course, it is certainly possible that some of the users duped to this bug are actually seeing unrelated problems. If you are certain what you are seeing is something different than the original report, please feel free to un-dupe or file a new bug against fglrx-installer.

Did anybody try to disable compiz and run to opengl apps at the same
time if the tearing and blinking still occurs? like maybe google earth
and glxgears without compiz?

On Fri, 2008-10-31 at 15:55 +0000, erlguta wrote:
> orgot to say in the previous post that it only happens with compiz
> effects enabled.
> If i disable it there is not blinking at all.
>

erlguta (gonzalomarcote) wrote :

>Did anybody try to disable compiz and run to opengl apps at the same
>time if the tearing and blinking still occurs? like maybe google earth
>and glxgears without compiz?

Yes of course, and it works, but as you see in the title this is a problem related with ATI (fglrx) and applications (3D, videoplayers...) with compiz "Enabled".

Today most of us can not live without the normal compiz effects enabled.

They are very useful to switch between applications and desktops and have more productivity.

That's true. How sad that fglrx support is so slow. I have been going
back and forth from ati bugzilla and launchpad and I still haven't
receive any positive feed back. It is quite good for me that my laptop
is old such that when I upgrade I would choose something that don't have
ati driver I think that would be the best solution for now.

On Fri, 2008-11-07 at 07:13 +0000, erlguta wrote:
> Today most of us can not live without the normal compiz effects
> enabled.
>
> They are very useful to switch between applications and desktops and
> have more productivity.

barx (thebarx) wrote :

Ubuntu 8.10
_______________________________
Toshiba Satelite A215-S7437
AMD Turion64x2
ATI Radeon x1200
_______________________________

Guys I Love this version of Ubuntu, also the wifi IS WORKING!!! I am amazed.

The only bug is the tembling and blinking videos when Desktop Efects are activated.
And Games are horrible I can't also quit them, I have to restart sesion with crtl+alt+backspace

Any way, thanks for everything : )

..::The Barx::..

barx (thebarx) wrote :

Ahhh I didn't check, but games like Glest, puet chess nor Frets on fire works with desktop efects enabled or not. It's too sad. ;( I would like to send a screen in the last post, but I can't resize window I can't see the option. The manner I can describe it that seems like the screen is cutted in strips and pasted randomly.

So, add that bug for my last report that is not far from first

cd.kris (cd-kris) wrote :

comfirmed, 8.10 on Toshiba m302 laptop

Celuldor's trick works

but not the others

Benjamin Drung (bdrung) wrote :

It is the other way around. Bug #162541 is a duplicate of this bug (because this bug has more details).

barx (thebarx) wrote :

For the direction of the bug that cenora linked, mine is fresh installation of Ubuntu 8.10, thanks to Mandriva, that I Installed in a partition and I've never could remove it by gparted. I don't know if there's a Hardy Repository on a fresh Intrepid installation, I don't think so, but I can not be sure.

So, Is there a way to work in aiglx with my Ati-video card? I think that is slower, isn't it?

Alexander van Loon (avanloon) wrote :

My bug #296508 was marked as a duplicate of this bug, and I was asked to attach the output of `lspci -vvnn`, and attach my /var/log/Xorg.0.log file from after reproducing the issue. I'll attach them here instead of in my original bugreport.

Alexander van Loon (avanloon) wrote :

This is the Xorg.0.log file. Bryce, you asked me to reproduce the issue with video playback and then attach the Xorg.0.log after that. However, Xorg.0.log seems to be generated at Xorg startup only, so it doesn't record the problems with video playback? I attached the file anyway.

Michael Nagel (nailor) wrote :

confirming with intrepid, is this problem triaged completely or is there some information i could add?

When changing settings in CompizConfigSettingsManager, flickering on a running video stops for about a second. (For example that special option for "Video playback") Can anyone confirm that?
If yes, maybe Compiz-developpers could add an option that "changes settings every second" or something...

Dzidza (dzidza88) wrote :

I have the same blinking problem with ATI Radeon 3600 series.
There is a 100 comments but no solution.
Can anyone tell my is this solvable, becouse linux is not realy useble whit this bug???

Dzidza,

Disable Compiz (System > Preferences > Appearance > Visual Effects > None). Alternatively, if video is the only thing bothering you, change your preferences in your video player to output via "x11".

~Rusty

luvr (luc-vanrompaey) wrote :

> change your preferences in your video player to output via "x11".

An earlier comment here explained how to do that in various video players:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/179042/comments/25

This is really just a work-around, not a real fix, though.

Basically, this is an AMD/ATI problem, because AMD/ATI doesn't properly support the development of full-featured open-source drivers for their video adapters--even though they once appeared to promise that they would: see http://www.linux.com/feature/119049

We're, in effect, being held hostage by AMD/ATI; only they can resolve this mess. NVIDIA isn't any better, by the way; I decided to dump them because of the annoying bugs in their binary-only drivers, and because of the apparent promise from AMD/ATI.

In fact, the only vendor that seems to properly support open-source drivers for its graphics hardware, is Intel. My only computer that doesn't need a proprietary driver for its video adapter, is a Dell Studio 17 laptop--which has an Intel graphics chip built in. Unfortunately, there aren't any separate Intel graphics adapter cards available; if and when good Intel graphics cards (with full-featured open-source Linux drivers) ever became available, I'd rush out and buy one--No wait, I'd buy at least five!

Dzidza (dzidza88) wrote :

TNX Rusty and Luvr it worked,
tnx a lot

wolf (sv-mooby) wrote :

I found this thread: http://www.phoronix.com/forums/showthread.php?t=14458
Its about new beta drivers Catalyst 9.1 RC2, in this driver problem with flickering video players (under xvideo) solved.
I believe when new drivers released this problem will completely solved, and we must just wait for new release :)

Makoto (makotothedragon) wrote :

Confirming flickering video, ATI Radeon HD 4670, AMD Athlon X2 @2.7GHz, 4GB RAM, x86_64. Tweaking video players resolves issue; new 9.1 RC2 drivers do *not*.

Why is this such a big issue for ATI to get over? It isn't like their Windows drivers have this issue, nor is it like NVIDIA shows that they have this issue.

Gotta say, I'm not looking forward to waiting for DRI2, and only God really knows when that's coming out.

Successfully changed ATI to nVidia - it works great!

Flickering with Compiz enable here after upgrading to intrepid.

the fix at:
http://www.ubuntugeek.com/fix-for-video-playback-problem-in-compiz-fusion.html

Worked here

Another bump for this issue in 8.04. Under compiz *all* rendering is corrupted, video, OpenGL and regular compiz effects. It's as if the screen is split along the diagonal from the top left to bottom right and only one half of the screen on either side of this diagonal updates on any given painting of the screen. This causes a diagonal tear when, for example, dragging windows. For OpenGL and video the effect is more pronounced due the side not being rendered being blanked rather, this results in a terrible flicker.

rja (rajeshjadvani) wrote :

Shouldn't this bug be marked as a duplicate of #96991? AMD seems to only be tracking it as a feature similar to what NVidia's driver does, making up for the original X design issue. Also, #96991 is nearly fixed, so once that is done, this would be too.

Cameron W (cwill747) wrote :
erlguta (gonzalomarcote) wrote :

@Cameron W
>The fix at: etc

Cameron, again, this is not a fix, it is a temporary workaround.
This remains to be fixed by ati...or hope that the develop of the radeonhd driver wil be fast

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1

---------------
fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low

  * New upstream release. (Closes LP: #313027, #314600)
    - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
      #288620, #289628
  * README.Debian: Update the update procedure a bit

 -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42 -0700

Changed in fglrx-installer:
status: Triaged → Fix Released
erlguta (gonzalomarcote) wrote :

Ages with this bug.
Wow, if i don't see it i don't believe it.

Amit Kotlovski (amitbk) wrote :

Is there a way for me to install this new fglrx-installer package on intrepid?

i solved the problem with NVIDIA, hehe (sorry)... to mouch is to mouch
and enough.

Am Mittwoch, den 18.03.2009, 08:15 +0000 schrieb erlguta:
> Ages with this bug.
> Wow, if i don't see it i don't believe it.
>
> --
> Videos tear and "blink" when enabling compiz [AMD Feature #7647] [EPR#257833]
> https://bugs.launchpad.net/bugs/179042
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Compiz: Invalid
> Status in EZvisage, a simplified API to enthought's envisage: Invalid
> Status in AMD fglrx video driver: Triaged
> Status in “fglrx-installer” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xorg-driver-fglrx
>
> When using the proprietary ati driver that is in the hardy repository with compiz (using aiglx and not xgl), the opengl rendering is buggy :
>
> there is lots of blinking and every opengl window has an allways on top attribute that makes them (because of the blinking) visible half of the time.
>
> I tried it with the hardy repository doing an upgrade from gutsy to hardy using aptitude dist-upgrade.
>
> I have an amd64 installation
>
>
> Regards.
>

dirk (dirkmeissner72) wrote :

i solved the problem with NVIDIA, hehe (sorry)... to mouch is to mouch
and enough.

Am Mittwoch, den 18.03.2009, 08:43 +0000 schrieb Amit Kotlovski:
> Is there a way for me to install this new fglrx-installer package on
> intrepid?
>
> --
> Videos tear and "blink" when enabling compiz [AMD Feature #7647] [EPR#257833]
> https://bugs.launchpad.net/bugs/179042
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Compiz: Invalid
> Status in EZvisage, a simplified API to enthought's envisage: Invalid
> Status in AMD fglrx video driver: Triaged
> Status in “fglrx-installer” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xorg-driver-fglrx
>
> When using the proprietary ati driver that is in the hardy repository with compiz (using aiglx and not xgl), the opengl rendering is buggy :
>
> there is lots of blinking and every opengl window has an allways on top attribute that makes them (because of the blinking) visible half of the time.
>
> I tried it with the hardy repository doing an upgrade from gutsy to hardy using aptitude dist-upgrade.
>
> I have an amd64 installation
>
>
> Regards.
>

dirk (dirkmeissner72) wrote :

i solved the problem with NVIDIA, hehe (sorry)...enough,to mouch is to
mouch

Am Mittwoch, den 18.03.2009, 00:00 +0000 schrieb Launchpad Bug Tracker:
> This bug was fixed in the package fglrx-installer - 2:8.600-0ubuntu1
>
> ---------------
> fglrx-installer (2:8.600-0ubuntu1) jaunty; urgency=low
>
> * New upstream release. (Closes LP: #313027, #314600)
> - Fixes LP: #253988, #179042, #241176, #284408, #287229, #296497,
> #288620, #289628
> * README.Debian: Update the update procedure a bit
>
> -- Bryce Harrington <email address hidden> Tue, 17 Mar 2009 15:40:42
> -0700
>
> ** Changed in: fglrx-installer (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> Videos tear and "blink" when enabling compiz [AMD Feature #7647] [EPR#257833]
> https://bugs.launchpad.net/bugs/179042
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Compiz: Invalid
> Status in EZvisage, a simplified API to enthought's envisage: Invalid
> Status in AMD fglrx video driver: Triaged
> Status in “fglrx-installer” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xorg-driver-fglrx
>
> When using the proprietary ati driver that is in the hardy repository with compiz (using aiglx and not xgl), the opengl rendering is buggy :
>
> there is lots of blinking and every opengl window has an allways on top attribute that makes them (because of the blinking) visible half of the time.
>
> I tried it with the hardy repository doing an upgrade from gutsy to hardy using aptitude dist-upgrade.
>
> I have an amd64 installation
>
>
> Regards.
>

erlguta (gonzalomarcote) wrote :

It is possible with this fix to play 3D applications and games, like googleearth, in ATI without blinking?
Somebody has tested it?
This is one of the most annoying known bugs in Ubuntu for years which affects hundreds of thousands of users, and it would be very BIG news...and i don't see news published, about it, nowhere...

Dan Lenski (lenski) wrote :

Ditto here! Intrepid 64-bit, xv windows flicker horribly when Desktop Effects are enabled, no problems when Desktop Effects are disabled. It's not a big deal to disable Xv for video playback, but there seems to be no way to disable Xv for the proprietary Skype client, so it's virtually unusable for video chat with this bug :-(

Here's my lspci -vvnn for the onboard graphics card:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon HD 3200 Graphics [1002:9610]
 Subsystem: Biostar Microtech Int'l Corp Device [1565:0017]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 18
 Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
 Region 1: I/O ports at c000 [size=256]
 Region 2: Memory at fe9f0000 (32-bit, non-prefetchable) [size=64K]
 Region 5: Memory at fe800000 (32-bit, non-prefetchable) [size=1M]
 Capabilities: <access denied>
 Kernel driver in use: fglrx_pci
 Kernel modules: fglrx

And my Xorg.0.log is attached.

Chris Roddy (cmr) wrote :

this bug is present in xorg-driver-fglrx version 2:8.600-0ubuntu2 on ubuntu 9.04 RC on i386.

am i misreading the launchpad janitor notice?

rja (rajeshjadvani) wrote :

Just upgraded to 9.04 RC, and I have fglrx version 2:8.600-0ubuntu2.
FYI, I'm running 64-bit Ubuntu.

Specifically, while running Compiz - Played an AVI file in windowed mode (Totem movie player):
- First the video didn't show up, but then I switched to Metacity, and then back to Compiz, and the video is working fine now.
- Rotated the desktop cube, and the video moved perfectly, as expected.
- Switched to fullscreen mode, and movie continued to play well
- Rotated the desktop cube, and the rotation was still good - the video playing face of the cube showed the movie correctly.

Chris Roddy, are you having trouble with 3D or video? I think the issues with 3D aren't yet fixed:

1. Running glxgears, if I rotate the desktop cube, the window border moves with the desktop, but the gears themselves stay in the same spot on the screen.
2. Running glchess from gnome-games package, when switching to 3D-View, there is a lot of blinking and switching back to 2D mode.

But I think that's probably a different bug. Can someone point me the appropriate bug report?

Download full text (3.6 KiB)

I have 2 laptops:

One Lenovo Thinkpad R61 (with Nvidia graphics card) and a Fujitsu Siemens
Esprimo Mobile (with integrated intel graphics card).

I did a fresh Jaunty install on both machines and installed Google Earth.
The Nvidia PC runs smooth, the Intel doesn't.

Micro Müeller explains what happens in detail in the original BUG report for
this problem:

   - https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/162541

Summary: Wait for DRI2.

Full description from Müeller:

Every OpenGL-based application running under compiz (and being driven by
OpenSource Xorg-drivers or ATI's flgrx) will yield rendering glitches as
described, because the drivers in question are all still based on DRI and
not DRI2. What DRI lacks and DRI2 introduces - among other things - is
hw-accelerated indirect rendering. This affects composited window-managers
(like compiz) mostly. Currently with DRI the DRM does not care if the
desktop is composited or not and just hands any OpenGL-app, that asks for a
rendering-context to draw to, a pointer to the front-buffer. Thus the
OpenGL-app happy starts drawing to the front-buffer, ignoring the fact that
there might be a compositing manager running and it should rather render to
an off-screen area and let the compositing-manager do the work of blitting
the OpenGL-apps window-contents to the front-buffer. DRI2 is more
intelligent in that regard in fixes this.

All that is overly simplified of course, but should give an idea about what
is going on "under the hood".

On nvidia (using the proprietary driver) one does not run into this issue
because nvidia does not use any form of DRI but their own infrastructure,
which happens to have hw-accelerated indirect rendering for some time now.
If one would be so bold to use the OpenSource nouveau-driver, they'd see the
same rendering glitches. But nouveau will of course also switch to DRI2.

Over time all OpenSource Xorg-video-driver will switch to DRI2 of course. It
will take time. The first driver that is pretty far in development to adapt
to DRI2, is the intel-video driver (for i915, i945 and i965 that should work
already). Second in line will probalby be the OpenSource radeon-driver (the
one without HD in the name).

Regards,
Cenora

On Thu, Apr 23, 2009 at 3:31 AM, rja <email address hidden> wrote:

> Just upgraded to 9.04 RC, and I have fglrx version 2:8.600-0ubuntu2.
> FYI, I'm running 64-bit Ubuntu.
>
> Specifically, while running Compiz - Played an AVI file in windowed mode
> (Totem movie player):
> - First the video didn't show up, but then I switched to Metacity, and then
> back to Compiz, and the video is working fine now.
> - Rotated the desktop cube, and the video moved perfectly, as expected.
> - Switched to fullscreen mode, and movie continued to play well
> - Rotated the desktop cube, and the rotation was still good - the video
> playing face of the cube showed the movie correctly.
>
> Chris Roddy, are you having trouble with 3D or video? I think the issues
> with 3D aren't yet fixed:
>
> 1. Running glxgears, if I rotate the desktop cube, the window border moves
> with the desktop, but the gears themselves stay in the same spot on the
> screen.
> 2. Running...

Read more...

erlguta (gonzalomarcote) wrote :

That's what i thought.
Again...This bug is NOT fixed.
It is still present in Jaunty with fglrx and compiz effects enabled.
Videos with totem show complete black or blinking.
Googleearth sill show blinking.
3D apps still show blinking.
Yaers with this ugly bug.
This is unacceptable.

Amit Kotlovski (amitbk) wrote :

Like erlguta, I find this very problematic for my personal use of Ubuntu with my laptop. I understand that the work put in here is done by volunteers, and that is the reason why I just have to keep a Vista installation here and constantly boot to it for viewing media.

PowerUser (i-am-sergey) wrote :

As for me, AMD has *stopped* supporting my ATI x1300 card in their recent proprietary drivers. Including these used in Ubuntu.

Big "thanks", AMD! I always suspected I can't really trust to anything proprietary without getting backstabbed at some point, sooner or later. AMD has proven these worries were correct.

On other side, now Ubuntu uses open source driver for these ATI cards by default and playback over Xv using this driver is far superior to proprietary AMD stuff, as well as 2D performanse became much faster when compiz enabled. Hence, I no longer have any moron blinking with compiz even when playing video over Xv. However, this driver quite slow in some 3D stuff (but performs great with Compiz) and in some 3D-intense games like Nexuiz it could even lock-up. If you do not need decent 3D to play Nexuiz or similar games, it could be a good way to go.

erlguta (gonzalomarcote) wrote :

Please re-open this bug.
This bug is not fixed.
I have one Jaunty fresh install and i suffer the same problems with Compiz enabled and 3D applications (googleearth), blinking videos...and new problems, like black image in videos (totem).
So re-open it, please.

spontex (spontex) wrote :

Same here. This bug is still present: Google Earth cannot be used when the Compiz desktop effects are enabled.
See this blog post for more details: http://blogs.computerworld.com/the_ubuntu_and_ati_blues

Benjamin Drung (bdrung) on 2009-05-12
Changed in fglrx-installer (Ubuntu):
status: Fix Released → Triaged
strikton (ton-strik) wrote :

Thanks! This problem exists already for three releases, and nothing is done to it! I had loads of problems on my previous computer with an Nvidia card, so when I bought a new Dell I insisted on an expensive ATI card.
Result: these problems.
I really am a Linux fan, but this issue disappoints me deeply, esp. the way it was treated till now!
Maybe it has something to do with the AMD 64 bits architecture. The whole world convinced my that this architecture was much better, so now a lot of software I can't install, because it is the wrong architecture!

spontex (spontex) wrote :

Hello,
I do not think this is related to the AMD64 architecture.
However, ATI has been bought by AMD and it cannot be said that they have been working seriously on this problem.
Nvidia graphic cards have a much better reputation than ATI cards from the drivers point of view - see some comments above: "Successfully changed ATI to nVidia". I am about to do so... hope this helps!

Bryce Harrington (bryce) on 2009-08-13
tags: added: hardy
Bryce Harrington (bryce) wrote :

The original reporter of this bug reported it against a "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]". AMD no longer supports this card, thus this bug report is no longer valid.

I closed this bug with the 8.600 upload because the hardware is no longer supported with that release. 'WONTFIX' would have been more accurate but there's no way for the launchpad stuff to distinguish between "fixed" and "wontfix" in changelog entries.

Anyway, I can't reproduce this problem on hd2600 or hd4850 on karmic with 8.66 so guess whatever the issue was is gone now, for the hardware AMD actually still supports. Hopefully for everyone else -ati is working okay or if not that you have bug reports for your issues opened against that package instead.

Changed in fglrx-installer (Ubuntu):
status: Triaged → Invalid
erlguta (gonzalomarcote) wrote :

This, bug seems to be fixed in Karmic!. I have one ATI Radeon HD 3450 and now i can play GoogleEarth, 3D games and there is no video blank screens or blinking in Totem.
Amazing!. This bug has existed for many releases and a few years and now finally seems fixed!.

exactt (giesbert) wrote :

fixed for me too in karmic! can't believe i can finally use compiz effects.... thx

Roy Jamison (xteejx) wrote :

Marked as Fix Released, as this is now working in Karmic. Thank you guys for confirming this for us :)

Changed in fglrx:
status: Triaged → Fix Released
rja (rajeshjadvani) wrote :

Fixed at last!

Works for me too. Tried this with Youtube, and 3d Chess.

Jeremy Raines (obororainesfam) wrote :

I had to turn off acpi on my Toshiba laptop (HD 3650), but so far it appears
to be working.

On Mon, Nov 2, 2009 at 11:41 AM, rja <email address hidden> wrote:

> Fixed at last!
>
> Works for me too. Tried this with Youtube, and 3d Chess.
>
> --
> Videos tear and "blink" when enabling compiz [AMD Feature #7647]
> [EPR#257833]
> https://bugs.launchpad.net/bugs/179042
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Compiz: Invalid
> Status in EZvisage, a simplified API to enthought's envisage: Invalid
> Status in AMD fglrx video driver: Fix Released
> Status in “fglrx-installer” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: xorg-driver-fglrx
>
> When using the proprietary ati driver that is in the hardy repository with
> compiz (using aiglx and not xgl), the opengl rendering is buggy :
>
> there is lots of blinking and every opengl window has an allways on top
> attribute that makes them (because of the blinking) visible half of the
> time.
>
> I tried it with the hardy repository doing an upgrade from gutsy to hardy
> using aptitude dist-upgrade.
>
> I have an amd64 installation
>
>
> Regards.
>
> --
> Z.
>

strikton (ton-strik) wrote :

It's over in Karmic! Fantastic! Thanks to the team for their effort to solve this!

To post a comment you must log in.