Max GL texture size can break multi-head

Bug #824099 reported by Jeff Lane on 2011-08-10
118
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Won't Fix
High
Jay Taoko
Unity Distro Priority
High
Unassigned
compiz (Ubuntu)
High
Jay Taoko
Oneiric
Critical
Jay Taoko
Precise
High
Unassigned
gnome-desktop3 (Ubuntu)
High
Chris Halse Rogers
Oneiric
High
Chris Halse Rogers
Precise
High
Unassigned
unity (Ubuntu)
High
Jay Taoko
Oneiric
Undecided
Unassigned
Precise
High
Jay Taoko

Bug Description

There's a longstanding issue (see the duplicate bug #555641) with Compiz and multi-monitor setups with any combined dimension larger than the maximum GL texture size. It used to be the case that this would simply crash compiz, but mesa now has code to fallback to software rendering for those cases. Unfortunately, this rendering is unacceptably slow (on the order of 10s of seconds per frame), particularly since the only hardware that will realistically hit this limit is netbook hardware with the associated anaemic CPU. It also appears to be broken in some cases (see bug #830949), although I can't reproduce that myself.

The Compiz "Copy to Texture" plugin can break textures up into <= max texture size chunks, allowing hardware rendering to work with these large framebuffers. This is insufficient for Unity, though, which also needs a way to break up its FBOs.

For Oneiric we should patch g-s-d's xrandr plugin to disallow setting a multi-monitor configuration with any dimension >= max texture size when Unity is running. Additionally, the display capplet should not allow a resolution to be explicitly set that will break Unity. For P this should be dropped in favour of enabling Compiz's "Copy to Texture" plugin and fixing Unity.

String Freeze Exception Request:
This patch adds a new failure mode and explanatory error message to gnome-desktop's randr handling. This new message is required to explain to the user why their multi-head setup request has been rejected, and what can be done about it.

Original report:
THIS IS A MASTER BUG OF FOUR DIFFERENT BUGS:

[nVidia] https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830955
[Intel N10] https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830949
[Intel Arrandale, Mobile 4 Series] https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830952
[ATI] https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830953

Oneiric Alpha 3 installed on this system. Under testing, one test is to plug in an external monitor and ensure that external video functions properly. On this EeePC, it does not. (See photo attached to this bug).

Once the external montior is plugged in, both the primary display and the external display are horribly garbled. The only thing that exists on the screen that's remotely readable is the panel at the top. The rest of the desktop area is just a mess.

Affected systems and GPUs:

Dell Vostro 1014 (Intel Mobile 4 Series)
Dell Vostro 1015 (Intel Mobile 4 Series)
Lenovo Thinkpad Edge 11 (Intel Arrandale)
Lenovo Thinkpad Edge 14 (M92 [Mobility Radeon HD 4500/5100 Series])
Lenovo Thinkpad Edge 15 (Intel Arrandale)
Lenovo Thinkpad SL410 (Intel Mobile 4 Series)
Lenovo Thinkpad Edge 15 (ATI Technologies Inc M880G [Mobility Radeon HD 4200])
Lenovo Thinkpad L412 (Intel Arrandale)
Lenovo Thinkpad Edge 11 (ATI Technologies Inc: M880G [Mobility Radeon HD 4200])
Lenovo Thinkpad X220 (Intel Arrandale)
Dell Vostro 1520 (Intel Mobile 4 Series)
Dell Vostro 1720 (Intel Mobile 4 Series)
Dell Studio XPS 1340 (nVidia Corporation: GT218 [GeForce G210M])
Dell Inspiron 1545 (Intel Mobile 4 Series)
Dell Studio XPS 1340 (nVidia Corporation: G98 [GeForce 9200M GS])
Dell Vostro 3300 (Intel Arrandale)
Dell Vostro 3500 (Intel Arrandale)
Dell Vostro 3700 (Intel Arrandale)
Dell Precision M4500 (nVidia Corporation: GT215 [Quadro FX 1800M])
Dell Latitude E6410 (nVidia Corporation: GT218 [NVS 3100M])
Toshiba Tecra A11/M11 (Intel Arrendale)
Toshiba Tecra S11/M11 (nVidia Corporation: GT218 [NVS 2100M])
Dell Latitude 2110 (Intel Corporation: N10 Family Integrated Graphics Controller)
Dell Latitude 13 (Intel Mobile 4 Series)
Dell Vostro 3400 (Intel Arrandale)
Dell Vostro V13 (Intel Mobile 4 Series)
Dell Vostro 3500 (Intel Arrandale)
Dell Vostro V13 (Intel Mobile 4 Series)
Dell Vostro 3700 (Intel Arrandale)
Dell Precision M6500 (ATI Technologies Inc: M97 GL [ATI FirePro M7740])
Toshiba Tecra R700 (Intel Arrandale)
Dell Inspiron 15R (Intel Arrandale)
HP ProBook 6550b (Intel Arrandale)
Asus EeePC 1001PXD (Intel Corporation: N10 Family Integrated Graphics Controller)
Asus EeePC 1011PX (Intel Corporation: N10 Family Integrated Graphics Controller)
Asus EeePC 1015PX (Intel Corporation: N10 Family Integrated Graphics Controller)
Dell Mini 10 (Intel Corporation: N10 Family Integrated Graphics Controller)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Aug 10 13:38:33 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
LightdmGreeterLog:

MachineType: ASUSTeK Computer INC. 1001PXD
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-8-generic root=UUID=bbe0cd86-364f-4ba4-9c7d-7f9b165d66c1 ro quiet splash initcall_debug vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/12/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0105
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1001PXD
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0105:bd08/12/2010:svnASUSTeKComputerINC.:pn1001PXD:pvrx.x:rvnASUSTeKComputerINC.:rn1001PXD:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1001PXD
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.5.0-0ubuntu2
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :

Here's the promised photo showing the EeePC and it's external monitor and their funky garbledness...

Jeff Lane (bladernr) on 2011-08-10
tags: added: blocks-hwcert
Bryce Harrington (bryce) on 2011-08-10
summary: [EeePC 1001 PXD] Plugging in external monitor to VGA port makes both
- displays completely unusable
+ displays garbled
summary: [EeePC 1001 PXD] Plugging in external monitor to VGA port makes both
- displays garbled
+ displays corrupted with thick slanted lines
Changed in xorg (Ubuntu):
status: New → Confirmed
Robert Hooker (sarvatt) on 2011-08-11
affects: xorg (Ubuntu) → compiz (Ubuntu)

I can confirm this bug as I have observed it on every system I've tested Oneiric Alpha 3 on, this includes about 30 laptops of different makes and models, with chipsets from Intel, NVidia and AMD. Here are my observations:

1- On Intel N10 systems, such as the Eee PC 1001 reported by Jeff, I get the exact same corrupted pattern he describes. Note that there are already bugs covering compiz-related problems with external displays on N10-based systems (bug 807161 and bug 790824) so in that particular case we might actually be looking at two problems.

2- On other Intel systems I get a different pattern: the external screen is entirely black, except for the top panel, and the built-in display shows a "dead zone" on the top fourth of the screen, while the bottom 3/4ths are alive and well. I'm attaching a screenshot of the internal display of an affected Intel machine.

3- On NVidia systems I get blocks of solid white or blue, with specks of other colors scattered about. I'll try to get and attach a picture of this.

4- Here's the interesting bit: it happens only when running Unity. If I select Ubuntu 2d upon login, external screen functionality works fine. On my Ubuntu 2d system I did ps wwuxa |grep compiz and compiz seems to be running, so it would indeed appear to be Unity3D-related.

I confirmed this on an Oneiric A3 installation, fully dist-upgraded as of today, August 11th.

Please let me know if I should attach logs, perform some more tests, or maybe split this into different bugs, though it seems clear to me that this happens everywhere with two screens.

Daniel Manrique (roadmr) wrote :

Importance: Critical as it has a "severe impact on a large portion of Ubuntu users", potentially everyone needing to connect a laptop to an external display, be it a monitor or a projector. Driving external displays is a big use case for portable computers. This happens on every tested laptop when connecting an external screen, and while the workaround is to use Unity 2d, it should be ensured that the primary desktop environment for Ubuntu works for this vast group of users.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in compiz (Ubuntu):
importance: Undecided → Critical
Jeff Lane (bladernr) wrote :

This may be fixed in recent updates. I noted this on every laptop I've tested this week, but today, on the latest test system, a Lenovo L512 with integrated Intel graphics, this did not happen with either external VGA or DisplayPort. This system was installed and updated freshly this morning.

Jeff Lane (bladernr) wrote :

Nope... just rechecked on two freshly updated EeePCs. both display the corruption issue. The L512 is the only system I've tried so far that did not exhibit this behaviour.

Ara Pulido (ara) on 2011-08-15
summary: - [EeePC 1001 PXD] Plugging in external monitor to VGA port makes both
+ [~30 systems] Plugging in external monitor to VGA port makes both
displays corrupted with thick slanted lines
Ara Pulido (ara) on 2011-08-15
Changed in compiz (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

FTR, external display working fine here with compiz (Intel Arrandale).

Changed in compiz (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: regression-release
removed: single-occurrence
Jeff Lane (bladernr) wrote :

pitti: I wonder... of all the systems I tested that failed due to this issue, only ONE was successful, and that was a Lenovo L512. I wonder if there's something to that, if now you have a working system as well.

David Barth (dbarth) on 2011-08-16
Changed in compiz (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jay Taoko (jaytaoko)
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Critical
milestone: none → 4.8.0
Omer Akram (om26er) on 2011-08-17
Changed in unity:
status: New → Confirmed
Ara Pulido (ara) on 2011-08-22
description: updated
Ara Pulido (ara) on 2011-08-22
description: updated
David Barth (dbarth) wrote :

The problem has been further investigated and it was found to be due to an installation issue, as later confirmed by the various testers working on this issue.

Changed in unity:
status: Confirmed → Invalid
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Invalid
Jeff Lane (bladernr) wrote :

What was the installation issue? I personally observed this on 10 different systems, all installed the same way with the default install options for Ubuntu. If this is due to something in the way we were installing, it would be good to know how to prevent that in the future.

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
summary: - [~30 systems] Plugging in external monitor to VGA port makes both
- displays corrupted with thick slanted lines
+ Max GL texture size can break multi-head
Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Changed in compiz (Ubuntu Oneiric):
status: Invalid → Won't Fix
description: updated
description: updated
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: nobody → Chris Halse Rogers (raof)
description: updated
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Chris Halse Rogers (raof) wrote :

Ok, it looks like this will be relatively easy; there's already support for failing to configure displays when the framebuffer gets bigger than the maximum virtual size. Adding a check to fail when the framebuffer gets bigger than the max GL texture size *should* be straightforward.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Chris Halse Rogers (raof) wrote :

I've got a patch for this; I'm cleaning it up and will propose a merge.

affects: gnome-settings-daemon (Ubuntu Oneiric) → gnome-desktop3 (Ubuntu Oneiric)
description: updated

El dt 27 de 09 de 2011 a les 16:13 +1000, en/na Christopher James Halse
Rogers va escriure:
> Bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/824099
> requests a string freeze exception request for gnome-desktop3's XRandR
> support. The workaround for this bug requires that gnome-desktop
> refuses to configure a multi-head display with a size exceeding
> GL_MAX_TEXTURE_SIZE when Unity is running. This requires a new error
> message in gnome-rr-config.c, which will be shown to the user,
> explaining why their configuration request has been rejected and what
> they can do about it.
>
> Thanks,
> Chris Halse Rogers.
>

Thanks for notifying translators and documenters, Chris.

It makes sense to me if the error message is necessary and if it only
means adding a new string and not changing existing ones, so +1 from the
translations side, unless there is any objection.

Translators, this means adding the following string:

"Requested size (%d, %d) exceeds 3D hardware limit (%d, %d).\n"
"You must either rearrange the displays so that they fit within a (%d, %
d) square\n"
"or select the Ubuntu 2D session at login.")"

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Martin Pitt (pitti) wrote :

This is a rather big and not yet widely tested patch, but the only option we have right now to prevent people from breaking their screen config, so we need to take it. The error prone bits are in the separate callout, so the impact of bugs there is indeed rather limited.

Thanks for working on this, Chris!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.2.0-0ubuntu2

---------------
gnome-desktop3 (3.2.0-0ubuntu2) oneiric; urgency=low

  * debian/patches/02_refuse_to_break_GL_compositors.patch:
    - Check whether Unity is running and if so refuse to configure a multi-head
      setup larger than GL_MAX_TEXTURE_SIZE. Works around breakage when using
      Unity on such a setup, which is as much as we can do to fix (LP: #824099)
      at this point. In 12.04 this should be dropped in favour of making Unity
      work properly.
  * debian/control.in:
    - Add libgl1-mesa-dev and dh-autoreconf to Build-Depends for above patch.
  * debian/rules:
    - Use dh-autoreconf to regenerate build system to pick up changes from
      patch.
 -- Christopher James Halse Rogers <email address hidden> Wed, 28 Sep 2011 20:08:59 +1000

Changed in gnome-desktop3 (Ubuntu Oneiric):
status: In Progress → Fix Released
Eloy Paris (peloy-chapus) wrote :

The fix for this bug (in gnome-desktop3 3.2.0-0ubuntu2) seems to break my system: after getting the lightdm greeter and entering my user password to log in, I get a black screen, the screen flickers a few times like if X were crashing a few times. A few seconds later I do get the Unity interface but:

1. I see some things gone wrong in dmesg:

[ 41.741320] init: plymouth-stop pre-start process (1900) terminated with stat
us 1
[ 53.084817] init: lightdm main process (1271) killed by ABRT signal
[ 69.681566] show_signal_msg: 12 callbacks suppressed
[ 69.681570] check_gl_textur[2259]: segfault at 84 ip 080486bf sp bfa17a00 error 4 in check_gl_texture_size[8048000+1000]

2. Probably because of the message above about lightdm main process dying, I cannot logout (Unity is gone and nautilus stays running and in control of the root window).

I rebooted the machine twice to confirm. Downgrading libgnome-desktop-3-2 to 3.2.0-0ubuntu1 fixes the problem (rebooted after downgrading and didn't get the messages above).

Eloy Paris (peloy-chapus) wrote :

I am sorry for the lack of details -- I just don't know what information might be useful to provide. I don't even know if I should be filing a new bug for this. Here's something to get started but I am happy to provide more information if requested:

* I am not using a multi-head setup when this happens (this is a laptop with a single screen).

* nVidia driver.

* Might not be X crashing. Instead, it seems like whatever is running on top of X (lightdm) is crashing. I do see the typical X-shaped cursor for a bit.

Cheers,

Eloy Paris.-

Chris Halse Rogers (raof) wrote :

Ok. It's known that checking GL attributes might cause a crash, which is why it's done in a separate process, which shouldn't affect the main login sequence. Why is this stopping login, I wonder?

Does a file in /var/crash get generated when you try to login? That should contain useful debugging info.

Chris Halse Rogers (raof) wrote :

I'm not able to reproduce this, and from the logs you've posted it looks like lightdm aborts well before the new gnome-desktop codepath is reached. Could you please try upgrading back to libgnome-desktop-3-2 3.2.0-0ubuntu2 to see whether this was caused by an unrelated issue that got fixed with a package install?

Eloy Paris (peloy-chapus) wrote :

Hi Chris,

I upgraded back to libgnome-desktop-3-2 3.2.0-0ubuntu2 and I am no longer seeing the problem.

There are two other things that are different, though:

1. This time I turned the machine off instead of just doing a full restart. I don't know if this resets the hardware in some special way and makes the issue go away.

2. There were some package upgrades. There was nothing out of the ordinary with the possible exception of a unity upgrade.

In /var/crash, there was a core dump for check_gl_textur, but nothing else around the same time.

Cheers,

Eloy Paris.-

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: Invalid → Triaged

On Fri, 2011-09-30 at 11:17 +0000, Eloy Paris wrote:
> Hi Chris,
>
> I upgraded back to libgnome-desktop-3-2 3.2.0-0ubuntu2 and I am no
> longer seeing the problem.
>
> There are two other things that are different, though:
>
> 1. This time I turned the machine off instead of just doing a full
> restart. I don't know if this resets the hardware in some special way
> and makes the issue go away.
>
> 2. There were some package upgrades. There was nothing out of the
> ordinary with the possible exception of a unity upgrade.

I think I'll chalk this up as a broken package upgrade. I don't think
this is an issue with the libgnome-desktop-3-2 update.

If it looks like this is wrong, please feel free to report it here.

David Barth (dbarth) on 2011-10-06
Changed in unity:
importance: Critical → High
milestone: 4.8.0 → backlog
Changed in compiz (Ubuntu):
importance: Critical → High
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Vivek Sekhar (vivek-7) on 2011-10-06
description: updated
Changed in gnome-desktop3 (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: blocks-hwcert-enablement
Rena Kunisaki (i-am-inuyasha) wrote :

I should note that the description is somewhat inaccurate:
1) Multi-head isn't really the problem, just the easiest way to reproduce it. A single display with a high enough resolution can trigger it as well.
2) There are two separate limits: max texture size and max framebuffer size. The former can be worked around by breaking large windows into multiple textures, but this won't help the latter. GL init fails and all drawing operations do nothing, leaving the user with a display of random uninitialized VRAM (i.e. corrupted display, thick slanted lines, chunks of wallpaper etc).

David Barth (dbarth) on 2012-01-12
tags: added: rls-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.3.5-0ubuntu1

---------------
gnome-desktop3 (3.3.5-0ubuntu1) precise; urgency=low

  * Sync with Debian. Remaining changes:
  * New upstream release.
    - GnomeRR:
      - Use GDK to get work area
      - gnome_rr_screen_new() now creates a singleton for the specified
        GdkScreen
    - GnomePnpIds: Add object to get the vendor name from PNP IDs
  * debian/libgnome-desktop-3-2.symbols: Updated for above changes
  * debian/patches/02_refuse_to_break_GL_compositors.patch:
    - Check whether Unity is running and if so refuse to configure a multi-head
      setup larger than GL_MAX_TEXTURE_SIZE. Works around breakage when using
      Unity on such a setup, which is as much as we can do to fix (LP: #824099)
      at this point. In 12.04 this should be dropped in favour of making Unity
      work properly.
  * debian/control.in:
    - Add libgl1-mesa-dev and dh-autoreconf to Build-Depends for above patch.
    - Bump minimum xrandr to 1.3
  * debian/libgnome-desktop-3-2.install: Install check_gl_texture_size
  * debian/rules:
    - Use dh-autoreconf to regenerate build system to pick up changes from
      patch.
  * debian/watch: watch for unstable releases

gnome-desktop3 (3.2.1-3) unstable; urgency=low

  * Upload to unstable.
  * debian/control.in:
    - Tighten dependency on gnome-desktop3-data again.
    - Change section of gir1.2-gnomedesktop-3.0 to introspection.

gnome-desktop3 (3.2.1-2) experimental; urgency=low

  * debian/control.in:
    - Loosen the dependency on gnome-desktop-data for now such that
      libgnome-desktop-3-2 is installable in parallel with
      libgnome-desktop-3-0

gnome-desktop3 (3.2.1-1) experimental; urgency=low

  * New upstream release.
    - Link against -lm for sqrt. Closes: #640437
  * debian/watch:
    - Update to version 3.
    - Track .xz tarballs.
  * debian/control.in:
    - Use Section: libs for gir1.2-gnomedesktop-3.0.
    - Drop (Build-)Depends on libstartup-notification0-dev.
    - Add Build-Depends on libxext-dev.
    - Update Vcs-* URLs.
    - Bump Build-Depends on intltool to (>= 0.40.6).
  * debian/rules:
    - List missing files.
    - Include utils.mk for list-missing.
    - Drop clean-la.mk since we don't install any .la files.
  * debian/libgnome-desktop-3-dev.install:
    - Remove .a file, static libraries are no longer built by default.
  * Update libgnome-desktop-3 library package for the SONAME bump 0 → 2.
 -- Jeremy Bicha <email address hidden> Mon, 06 Feb 2012 13:25:25 -0500

Changed in gnome-desktop3 (Ubuntu Precise):
status: Triaged → Fix Released
David Barth (dbarth) on 2012-02-10
Changed in unity:
milestone: backlog → 5.6.0
Changed in unity (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Bryce Harrington (bryce) wrote :

Does the remainder of this bug then be essentially dupe with bug #830949?

David Barth (dbarth) on 2012-02-17
Changed in unity (Ubuntu Precise):
assignee: nobody → Jay Taoko (jaytaoko)
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
importance: Undecided → High
status: New → Fix Committed
Jay Taoko (jaytaoko) wrote :

Gnome display manager now shows a warning message and prevents the user form setting a resolution that is higher than the maximum supported.

Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
greg (grigorig) wrote :

I think it's unlikely this bug will ever be "solved", the warning is good enough. While it's possible to work around maximum texture size limitations, this does not come without overhead, and that's on old GPUs with limited performance to start with. All modern and most not-that-modern GPUs support at least 4096x4096 textures.

Didier Roche (didrocks) wrote :

Jay told it's not possible to do in unity-3d with a reasonable amount of effort. We will keep the workaround for now

Changed in compiz (Ubuntu Precise):
status: Triaged → Won't Fix
Changed in unity (Ubuntu Precise):
status: Triaged → Won't Fix
Changed in unity (Ubuntu):
status: Triaged → Won't Fix
Jay Taoko (jaytaoko) on 2012-03-15
Changed in unity:
status: Triaged → Won't Fix
greg (grigorig) wrote :

I investigated a little bit, here's what GPU generation brought 4K texture support, per manufacturer:

NVidia: GeForce FX series, released in 2003
AMD: Radeon X1000 series, released in 2005
Intel: this is the odd one out, again: GMA X4500, released in 2008

Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → nobody
Colin Law (colin-law) wrote :

On a laptop that supports 3d unless an attempt is made to extend the desktop onto a second monitor, when the attempt to use the second monitor is made a dialog pops up saying that unity is not supported and that unity-2d should be used instead. Since that is no longer an option the message should be changed to one giving an indication of the workaround.

Colin Law (colin-law) wrote :

In my naivity I had assumed that this bug would be sorted by the use of llvmpipe in the same way that it is to be solved for hardware that does not support 3d in the first place. Is that not the case?

Colin Law (colin-law) wrote :

This needs to be re-opened on gnome-desktop3 as on Quantal the error message shown is no longer appropriate as unity-2d is not available. As well as changing the error message is it not the case that on Quantal the underlying problem can be solved by the use of llvmpipe? I keep asking this question but no-one has responded.

The existing message is

"Requested size (%d, %d) exceeds 3D hardware limit (%d, %d).\n"
"You must either rearrange the displays so that they fit within a (%d, % d) square\n"
"or select the Ubuntu 2D session at login.")"

Daniel van Vugt (vanvugt) wrote :

Please note, compiz 0.9.8.0 (released yesterday and coming soon to quantal) will probably make this problem worse. That's because we use a single texture to blit the whole screen now. But there is a plan to fix that --> bug 1040478.

Fixing bug 1040478 should be considered a prerequisite to fixing this bug.

Scott Kitterman (kitterman) wrote :

It's too late for Quantal now. Removing release team subscription.

To post a comment you must log in.