Ubuntu

[MASTER] broken initial stacking (was: compiz hides quick loading windows at login)

Reported by Matt Jones on 2007-10-02
434
This bug affects 21 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Expired
Medium
compiz (Ubuntu)
High
Michael Vogt
Declined for Gutsy by Timo Aaltonen
gnome-panel (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Timo Aaltonen
xcompmgr (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Timo Aaltonen

Bug Description

Binary package hint: compiz-gnome

On my desktop, when I login to Gnome, (on a fully up-to-date Gutsy Beta) the bottom Gnome panel does not show up. It will show up once I click on its location. This only happens with Compiz running. Sometimes I can see the panel for a split second before Compiz turns on.

I have also had similar problems in Fesity with compiz and beryl: On my laptop, I have to sign in to the Gnome keyring to access my wireless network. But the Gnome keyring shows up just before Compiz/Beryl is loaded, and is then hidden right after it is loaded. It does not show in the Window List, but can be seen and restored with alt+tab.

I would love to have this fixed before Gutsy ships. I am open to trying your suggestions.

Related branches

Matt Jones (workhorsy) wrote :

Also. This may be helpful. A few times in Feisty, when I loaded up GDM, compiz was already running over GDM (which does not seem to be the desired operation), and I did not have any problems with the keyring-login not showing up.

sam tygier (samtygier) on 2007-10-02
Changed in compiz:
importance: Undecided → Medium
status: New → Confirmed
Wolfgang Silbermayr (silwol) wrote :

I seem to have the same problem. Compiz hides my bottom panel. It does however not show it if I click in the area, but maximized windows leave this space free. If I right-click on the plain area at the bottom, it behaves in the same way as if I click on the desktop.
I can get the panel back if I reload compiz by running 'compiz --replace'. After that, everything works as expected.

Michael Vogt (mvo) on 2007-10-03
Changed in compiz:
importance: Medium → High
Papamatti (matti-lx) wrote :

Same happens on my machine, after booting into gnome and desktop effekts are enabled by defailt, the bottom panel is not shown - disabling the desktop effekts just bring it back to screen.

D. Brodzik (amyrose) wrote :

Subscribing to this bug report.

D. Brodzik (amyrose) wrote :

I also wanted to mention that this bug is not GNOME-specific and that I sometimes see it on KDE.

I was the reporter of a duplicate of this bug. You can - as a workaround !!!! - kills gdm session with ctrl + alt + backspace.

On next try to login, all panels are shown.

sancheztavo (sancheztavo) wrote :

I notice this in my machine running Gutsy Beta. Compiz hides my only panel when it starts, and it reappears as soon as I make a click anywhere on the desktop.

I can confirm the "click on desktop" workaround for getting the bottom panel.

Michael Vogt (mvo) wrote :

compiz (1:0.6.0+git20071004-0ubuntu1) gutsy; urgency=low

  * new 0.6 snapshot:
    - do not crash if glGetString() returns NULL
    - don't restack desktop windows
    - fix window geometry comparison
    - Send synthetic configure notify events where needed (ICCCM spec)
  * debian/patches/026_fix_stacking:
    - never stack under the desktop window (LP: #147943)
  * debian/patches/024_add_config_notify.patch:
    - dropped, improved version now part of upstream source

 -- Michael Vogt <email address hidden> Thu, 04 Oct 2007 14:18:17 +0200

Changed in compiz:
status: Confirmed → Fix Released
Gavin Graham (gavingraham) wrote :

I have applied todays updates (of which compiz (1:0.6.0+git20071004-0ubuntu1) gutsy was included) and the problem still persists.

Joss Winn (josswinn) wrote :

Yes, applied the latest updates and the problem is still there for me, too.

This may be completely off the wall and absurd... but...

When I use Gnome-RDP I make machines load into full screen. Normally Ctrl+Alt+Enter, the RDP session SHOULD go out of full screen and lower itself to right below the panel. It will stay the same size screen, but I'm at least able to work with the rest of my system.

When Compiz is enabled, it flashes like it's going to lower itself and fades a little bit so I can see my desktop. However, it stays in the exact same spot. To the view, it looks like the key combo didn't work, but the glitch type behavior leads me to believe that it is working correctly.

This leads me to believe these two issues may be directly related. If they are, it might help point in the right direction. If it is deemed they are unrelated entirely, I will report it as a separate bug.

Mr Freeze (rockula-mike) wrote :

Hmmm......I've seen this bug supposedly FIXED 2 times so far.....but I'm still waiting for it to happen on my system. I'm still clicking on the desktop to get the bottom panel to appear and now...to top it all off....I've got an annoying flicker that wasn't there a few days ago.....simply amazing ;-p

Kansei (clauretano) wrote :

Mr Freeze --are you using nvidia-glx-new with compiz and experiencing said flicker? It appeared on the three computers I use with that configuration a few days ago. I searched for bug reports then, found nothing. I'll let you know if I find anything. .. and yes, still getting the broken initial stacking here, post update.

I can still see this bug on cold start of my computer. I thought the bug was gone, but not, it is still there.

If it helps : nvidia driver (latest glx-new version), AMD64, gutsy up-to-date (but without latest cupsys package).

Re-opening, not fixed.

Changed in compiz:
status: Fix Released → Confirmed
Michael Vondung (mivo) wrote :

Downloaded today's updates, including the Compiz one that allegedly fixed this bug, however, it still persists. Not fixed for me.

Not solved for me, too.

_oOMOo_ (hermann-blaxhall) wrote :

Here also - nvidia-glx-new (100.14.19) driver, with latest updates.

capricorn (ubuntuuser82) wrote :

same thing here with nvidia-glx-new, I always have to click somewhere on the desktop first in order to make the bottom panel appear. BUT: This problem wasn't there in tribe-5/6 for me! So what was changed?

Mr Freeze (rockula-mike) wrote :

I just downloaded lots of compiz updates via Update Manager about 30 minutes ago. So far there is no change in this bug...to see the bottom panel, I have to click the desktop after boot. Also no change in the flickering screen, which flickers at random intervals at the location of my desktop Conky. However, this flicker has nothing to do with the Conky refresh bug, it doesn't flicker at regular intervals (and it didn't do this a few days earlier...that's why I think it's a Compiz bug). This is a PC, 7.10-Beta1 with Gnome desktop, using an ATI Radeon 9600XT video card running the default Ubuntu driver and Compiz in the CUSTOM mode. The xorg.conf device section has "ati"...not "fglrx". If I set the Visual Effects to NONE....there is no problem with the panel and the flicker also goes away. I should mention that I'm using Emerald with Compiz when Visual Effects are enabled.

Gavin Graham (gavingraham) wrote :

Problem still persists with todays update:
ii compiz 1:0.6.0+git20071004-0ubuntu2 OpenGL window and compositing manager
ii compiz-core 1:0.6.0+git20071004-0ubuntu2 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.5.2+git20070928-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.6.0+git20071004-0ubuntu2 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.6.0+git20071004-0ubuntu2 OpenGL window and compositing manager - plug
ii compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1 Compiz configuration settings manager
ii libcompizconfig-backend-gconf 0.5.2+git20071005-0ubuntu2 Settings library for plugins - OpenCompositi
ii libcompizconfig0 0.5.2+git20070919-0ubuntu3 Settings library for plugins - OpenCompositi
ii python-compizconfig 0.5.2+git20070912-0ubuntu1 Compiz configuration system bindings

Neil Wilson (neil-aldur) wrote :

Not just Nvidia. Occurs here on an Intel 945GM.

Just started happening in the last day or so. Before that compiz has behaved OK.

Same issue as everybody else. The bottom panel is hidden on initial login, but reappears when you minimise windows and click in the area.

imase (imase) wrote :

I've got the same problem with an Nvidia GeForce 5200 Gnome and Compiz-Fusion.

Igor

Same here with an Intel Mobile 915GM/GMS/910GM, X.org module i810, compiz 1:0.6.0+git20071004-0ubuntu2.

Fredrik Sjögren (fsj) wrote :

My lower panel is hidden after login.

Papamatti (matti-lx) wrote :

After Updating from mainserver today and restart my machine the panels on top and bottom are hidden!

same problem

imase (imase) wrote :

Do you have the same problem as you can see in my screenshot?

imase: you confused this bug with bug 89741, I guess...

imase (imase) wrote :

Upps...Sorry to all of you.

Julien Aubin (gojulgarbmail) wrote :

Problem also occurs here on KDE : all the windows disappear until I right-click on the desktop and open the "run" window. Then, when I open a popup menu that covers my kicker window, all the windows disappear again until I re-open the "run" window.

It's tied to compiz, since when I deactivate it everything becomes find.

My config :
- Gutsy with latest update.
- Athlon 64x2 3600+
- NVidia 7900 GS

hexion (hexium) wrote :

Hi there...

I don't know if this has been already addressed, but in case not, here you've got some info:

It's already solved upstream:
http://smspillaz.wordpress.com/2007/10/05/compiz-fusion-community-news-edition-15-for-october-5th-2007-3d-fixed/

"The desktop window is no longer set as fullscreen as this can cause problems with panels"

So, I think the changes should be backported (due to the upstream freeze).

BTW, it has nothing to do with gnome-panel... just compiz.

Michael Vogt (mvo) wrote :

compiz (1:0.6.0+git20071006-0ubuntu1) gutsy; urgency=low

  * new 0.6 git snapshot:
    - fix initial stacking (LP: #147943)
    - fix crash in grab hanlding in wobbly (LP: #125981)
  * debian/patches/028_compiz_manager_blacklist:
    - add a missing i965 pci id (LP: #149751)
  * debian/patches/029_default_options:
    - disable vsync by default here so that the compiz and
      libcompizconfig do not fight over the default
  * debian/patches/024_add_config_notify.patch:
    - updated so that a extra configure notify is send in resizeWindow
      (LP: #140773)
  * debian/patches/023_ignore_hints_when_maximized.patch:
    - removed, no longer needed with latest git (LP: #145843)
  * debian/patches/030_fix_screensaver:
    - return InputOutput override_redirct windows in
      findTopLevelWindowAtScreen(), this fixes the focus problem
      in gnome-screensaver (LP: #122549)

 -- Michael Vogt <email address hidden> Sat, 06 Oct 2007 18:00:15 +0200

Changed in compiz:
status: Confirmed → Fix Released

not a gnome-panel bug

Changed in gnome-panel:
status: New → Invalid
Eric Donkersloot (ericd) wrote :

Problem persists with the latest update:

ii compiz 1:0.6.0+git20071006-0ubuntu1
ii compiz-core 1:0.6.0+git20071006-0ubuntu1
ii compiz-fusion-plugins-extra 0.5.2+git20070928-0ubuntu1
ii compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2
ii compiz-gnome 1:0.6.0+git20071006-0ubuntu1
ii compiz-plugins 1:0.6.0+git20071006-0ubuntu1
ii compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1
ii emerald 0.3~git20070717-0ubuntu1
ii libcompizconfig-backend-gconf 0.5.2+git20071005-0ubuntu2
ii libcompizconfig0 0.5.2+git20070919-0ubuntu3
ii libemeraldengine0 0.3~git20070717-0ubuntu1
ii python-compizconfig 0.5.2+git20070912-0ubuntu1

unggnu (unggnu) wrote :

Same problem here but after disabling and enabling desktop effects it works fine after restart. Maybe compiz settings have to be reseted.

On my box, it was fixed after the second reboot. This is strange, but if it is true, no need to worry. Is there anybody who still suffers from this bug after a few restarts?

unggnu (unggnu) wrote :

I still got the problem. It seemed to work because compiz crashed silently.

Mr Freeze (rockula-mike) wrote :

Well, the panel problem persists after latest update, but now compiz is crashing . I'm running an ATI Radeon 9600 video card, and with compiz enabled, I have a most annoying flicker. It wasn't there 2 weeks ago. But then again, the panel problem wasn't there either a couple of weeks ago. IMO, the two problems are related, since they both started at around the same time on my system. Anyway, I'm finished with compiz until the next "FIX" is released, then I might turn it on and see if it actually works.

Changed in compiz:
status: Fix Released → Confirmed
Michael Vogt (mvo) on 2007-10-10
Changed in compiz:
assignee: nobody → mvo
status: Confirmed → Fix Committed
Changed in compiz:
status: Fix Committed → Confirmed
Michael Vogt (mvo) on 2007-10-11
Changed in compiz:
status: Confirmed → Fix Released
52 comments hidden view all 132 comments
Savvas Radevic (medigeek) wrote :

rpgmaker do this in terminal: apt-cache policy compiz

Is the candidate and the installed "1:0.6.0+git20071008-0ubuntu1" ?
If not, wait for the updates to reach your repositories

Like this?
$ apt-cache policy compiz
compiz:
  Installed: 1:0.6.0+git20071008-0ubuntu1
  Candidate: 1:0.6.0+git20071008-0ubuntu1
  Version table:
 *** 1:0.6.0+git20071008-0ubuntu1 0
        500 http://uk.archive.ubuntu.com gutsy/main Packages
        100 /var/lib/dpkg/status

houstonbofh (leesharp) wrote :

Fix confirmed for me. nvidia 7950 with P35 chipset and core2duo. The last major bug for me is now fixed.

$ apt-cache policy compiz
compiz:
  Installed: 1:0.6.0+git20071008-0ubuntu1
  Candidate: 1:0.6.0+git20071008-0ubuntu1
  Version table:
 *** 1:0.6.0+git20071008-0ubuntu1 0
        500 http://us.archive.ubuntu.com gutsy/main Packages
        100 /var/lib/dpkg/status

cabernet54: You're English is much better than some people that only most, "mee tooo"

It's working here. If it's working for my crappy hardware, I think it will work for everybody. From Michael Vogt's description it sounds like the bug was fixed as much as possible and more so masked past that and being worked on for upstream.

7 days before release, congratulations. Hopefully the rest of the bugs are solved before release and equally well.

I know what you mean about video card being obscured. Not many people
run a X850 either. As far as bug reports go, I usually look to see if
someone else posted something about, and if not, creating a new bug
report. Alot of times it ends up as a duplicate of another bug with a
subject line that has nothing to do with the bug itself, similar to
this bug. My bug report had the title of something like, "Panels do
not show on desktop after logging in, running Compiz". Then when it
became a duplicate of this bug which could be nominated for "worst
subject line for a bug report".

But what I'm trying to say, is yes, you should file a bug report (as
long as it's not obviously a duplicate of another existing bug).

My experience with my card was strange to say the least. A fresh
install of Gusty + XGL had Compiz running. Then when I realized video
played very choppy, I installed the restricted drivers, which would
not run Compiz. So I uninstalled again. Rebooted, and reinstalled the
restricted drivers, and everything magically started working. I didn't
file a bug report because I figured I did something wrong.

So maybe try that and see if ity helps. Let me know and good luck,

Ross

On 10/10/07, Matt Jones <email address hidden> wrote:
> Ross Peoples wrote:
> > Matt, I have a X850 Platinum Edition and I have the proprietary drivers
> > installed, and compiz looks great...aside from these types of bugs, I've
> > never had it crash.
> >
> > Matt Jones wrote:
> >
> >> It is still broken. Even when I create a new user, roboot, and login as
> >> the new user.
> >>
> >> Please stop marking this as fixed!
> >>
> >> And thank you medigeek for nominating this for Gutsy. When I initially
> >> reported It, I thought it was in the list of Gutsy bugs.
> >>
> >> And, because I never mentioned it: I have an ATI X800XT Platinum Edition
> >> with no restricted drivers installed (because they don't have compiz
> >> extensions) on my desktop, and an NVidia Geforce Go 7700 with restricted
> >> drivers for my laptop.
> >>
> >> Both machines still give the same error with "stacking" windows.
> >>
> >>
> >
> >
> I didn't want to fill the thread with more posts, so I emailed this to you.
>
> That is interesting that it works for you. When I enable the restricted
> driver and reboot. it says that my card does not support composite
> extensions. I know it works, because I used to download the drivers and
> install them from the ATI site, years ago with older Ubuntu releases.
>
> Do you think I should file a bug report about it not working? I'm not
> quite up-to-speed on how all the bug report procedures work in
> launchpad. So I don't know if that is something they would care about.
> Just wondering since you have more experience with it.
>
> On a side note. I've often thought of just giving my video card to
> Ubuntu, so they can make sure it works. It is kind of an obscure card.
>
> --
> [MASTER] broken initial stacking (was: compiz hides quick loading windows at login)
> https://bugs.launchpad.net/bugs/147943
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Julien Aubin (gojulgarbmail) wrote :

Only partially fixed there. At startup, the desktop is over all the windows, and when I right-click over the desktop and my popup menu covers the KDE panel, everything disappears.
Thus, when I try to move a window such as Konsole, sometimes it's impossible to move due to this bug.

However this is better than it was.

Config : 7900 GS on Athlon 64, Gutsy 32 bits and the latest updates.

Mathieu Laurent (mla) wrote :

Fixed for me with this last update. Config : Intel Corporation Mobile 915GM/GMS/910GML and Gnome

This does not seem to be fixed on Gutsy RC, on a Dell Latitude X1 (intel graphics). For me, the upper panel is hidden when booting into Gnome (although I can see the Restricted Manager tooltip) and suddenly appears when I click on the desktop.

Michael Vogt (mvo) wrote :

Thanks for this additional feedback and testing! Everybody who still sees the problem, please check that you have 1:0.6.0+git20071008-0ubuntu1 of compiz-core installed (this version unfortunately did not make it on the -rc CD) . I have not tested the fix under kde (only gnome), if that is still a problem there, please let us know.

Thanks,
 Michael

Sorry Michael, I was not aware that there were already updates for the RC. Please ignore my comment.

Gavin Graham (gavingraham) wrote :

Last set of updates has fixed the issue for me. I am using the nVidia new drivers. Thankyou!

Packages installed:
ii compiz 1:0.6.0+git20071008-0ubuntu1 OpenGL window and compositing manager
ii compiz-core 1:0.6.0+git20071008-0ubuntu1 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.5.2+git20070928-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.6.0+git20071008-0ubuntu1 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.6.0+git20071008-0ubuntu1 OpenGL window and compositing manager - plug
ii compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1 Compiz configuration settings manager
ii libcompizconfig-backend-gconf 0.5.2+git20071010-0ubuntu1 Settings library for plugins - OpenCompositi
ii libcompizconfig0 0.5.2+git20070919-0ubuntu3 Settings library for plugins - OpenCompositi
ii python-compizconfig 0.5.2+git20070912-0ubuntu1 Compiz configuration system bindings

imase (imase) wrote :

Bug fixed! Let the Release come!

Thanks!

Best regards

imase

Matt Vickers (mattyv) wrote :

Latest fix has also worked for the nvidia-glx (9639, not glx-new) driver.

Gavin Graham (gavingraham) wrote :

Have also now test on two other PC's (one with proprietry nVidia and the other with Intel 945 graphics) and both are working.

Matt Jones (workhorsy) wrote :

Seems to work now on both my systems.

ATI X800XT Platinum Edition Desktop
and NVidia Geforce Go 7700 Laptop

Progress Nerd (progressnerd) wrote :

Works fine now with my ATI Radeon 9550 / X1050 Series card and fglrx driver. Thanks!

BenKochie (ben-nerp) wrote :

Updated to 1:0.6.0+git20071008, this is now fixed on my system (ThinkPad X60). No longer hides panel or keyring password prompt at login.

Thanks!

nacktmull (bernd-motzer) wrote :

I can confirm the bug is fixed.
On my desktop (nVidia), standard screen size it was fixed already last week.
With today's (Oct 12) updates, also my Sony Vaio with odd resolution (1280*800) and nVidia card (GeForce6), it works fine now!

Thank you!!

Julien Aubin (gojulgarbmail) wrote :

Michael > I use nvidia-glx-new on my configuration and I have the 1:0.6.0+git20071008-0ubuntu1 compiz-core version installed. But the bug still appears on KDE. Not tested on GNOME.
My config : NVidia GeForce 7900GS, CM Asus M2N-SLI Deluxe (NForce 570 SLI)
I cannot give you an lspci result now because I'm not in front of my computer.

Julien.

capricorn (ubuntuuser82) wrote :

For me it is fixed now in gutsy rc (nvidia-glx-new, GeForce 6100 onboard)

Forlong (forlong) wrote :

Please stop confirming this has been fixed for you. It _should_ be fixed, so it's certainly better only to report if it's _not_ fixed for you. Thank you.

Ahh, why do I have to be the loner? It was fixed for me, at first, but then last night I changed the theme of my windows a little bit in System --> Preferences --> Appearance, and today when I booted up and logged in, both of my panels were missing until I changed viewports. Bummer.

I just rebooted (because I wanted to make sure that it didn't just happen on the first boot after a theme change), but now it appears that the panels are still gone. Can someone else try changing some parts of your theme (maybe window border, controls, etc.), and then reboot? I wonder what the cause could be... is there something that gets overwritten when you change those aspects of a theme? Is the compiz fix simply focused on the theme that is active when you install it? That sounds unlikely, but I'm not sure why this happened.

Julien Aubin (gojulgarbmail) wrote :

I've put a copy of my lspci, if it can help.

As I've explained, I use KDE with driver nvidia-glx-new. The theme I use is kde-window-decorator, but the same thing actually occurs with Emerald as a window decorator, or with gtk-window-decorator.
Note that it does not happens on the first startup of KDE with Compiz, but it always happens if you log out and re-log in with the same login and password, even if compiz is set as an app that must not be restarted by the ksm server.

The manipulation I've used in order to set compiz consists in editing my ~/.bash_profile file and add the following line :
export KDEWM=/usr/bin/compiz --replace

Some command results :
julien@pcathlon64:~$ apt-cache policy compiz-core
compiz-core:
  Installé : 1:0.6.0+git20071008-0ubuntu1
  Candidat : 1:0.6.0+git20071008-0ubuntu1
 Table de version :
 *** 1:0.6.0+git20071008-0ubuntu1 0
        500 http://eu.archive.ubuntu.com gutsy/main Packages
        100 /var/lib/dpkg/status

Note that the same configuration works well if I use kwin as my window manager, and it worked also well under Feisty with Compiz enabled.

I've attached my lspci if it can help.

Rgds,

Julien.

Julien Aubin (gojulgarbmail) wrote :

I think I've found a remaining issue :
Start KDE, then start Compiz. Everything should be fine.

Now logout from KDE, and login with the same user, and set the KDEWM environment variable to /usr/bin/compiz --replace in your .bash_profile. The bug reappears. I think it's a memory issue because Compiz remains loaded.

Julien.

I thought this bug was really fixed, but I still have a very little problem. If I open some image with EOG, the program automatically fits the image size to the screen size between panels (if it is bigger) but now it does but taking the screen size as there was no bottom panel. May it be a bug of Compiz or Eog? Mmm, I think I should have taken a screenshot, maybe tomorrow that I will see my computer again.

Thanks for your effort.

Benjamín: I'm sure this already happened before the whole issue with the panels; I have been getting it since early in the Gutsy development cycle (maybe it happened even before, I didn't use Compiz on a regular basis back then) and I think I even filed a bug, but I can't find it.

Not sure if it's a Compiz bug or an EOG one, tho, as you said.

unggnu (unggnu) wrote :

@Davi Prieto
This has already been reported under bug #140860.

Not the same bug, I think: That one refers to fullscreen apps, while Benjamin and I are talking about an app that calculates available screen space wrongly, causing its state bar to appear behind the panel instead of above it.

unggnu (unggnu) wrote :

It is the same I guess, check the screen shots.

Well, unggnu, it seems that you are right, although I think that the description of the bug #140860 is not very good.

-----Original Message-----
From: David Prieto <email address hidden>
Sent: Tuesday, 16 October, 2007 04:22
To: <email address hidden>
Subject: [Bug 147943] Re: [MASTER] broken initial stacking (was: compiz hides quick loading windows at login)

Benjamín: I'm sure this already happened before the whole issue with the
panels; I have been getting it since early in the Gutsy development
cycle (maybe it happened even before, I didn't use Compiz on a regular
basis back then) and I think I even filed a bug, but I can't find it.

[The entire original message is not included]

I am still getting the original error, sort of. Whenever I start up my computer, I still don't get the panels on screen, unless I hit Ctrl+Alt+Right Arrow to switch viewports, and then they appear again. I have the latest updates as of 17 Oct 07, which is only one day away from the launch date, and I'm still getting this error.

organic (chris-currently) wrote :

With the desktop effects enabled the Blender GUI becomes unstable; window bars are missing and parts of the display disappear and reappear as I mouse over them. I assume it is related.

Ian B (ectogon) wrote :

This bug is marked as having a fix realeased, but running the current version of compiz (0.6.0+git20071008-0ubuntu1) still results in a missing panel upon initial login.

mrvanes (mrvanes) wrote :

As far as I could tell this wasn't fixed in Gutsy official release (using KDE). The strange thing was that on initial login, there were no problems, but a re-login caused the (quick-loading?) windows like wallet manager to stack under the desktop. I also observed strange behaveour for viewport 1: it didn't accept the middle-mouse button for cube rotation, as configured (and also middle mouse button scrolling didn't rotate the cube, as configured). Instead of cube rotation, I got a list of open windows for this desktop. Choosing one brought the windows in front and the kicker as well. Clicking on the window titlebar made it disappear like reported before.

This was all resolved by compiling and installing compiz 0.6.2 and compiz-fusion 0.6.0.

Soichi Hayashi (soichih) wrote :

I am experiencing the flicker issue that Mr Freeze has been reporting above.

I am using compiz with Emerald and when I have my appearance - > visual effect option set to anything other than "none", open GL application (such as many of the screensavers) flickers. I have run the command "sudo dpkg-reconfigure -phigh xserver-xorg" which was suggested in other thread but that didn't help.

I am not sure if related bug report has been submitted, but does anybody know anything about this issue?

Darryl (darryl-lbh) wrote :

The issue still exists with 1:0.6.0+git20071008-0ubuntu1.1 installed. The two default Gutsy's gnome-panels still remain invisible after desktop is displayed after login. And the workaround was either of the following:
1. Switch viewports;
2. Use Desktop Wall instead of Desktop Cube. When I disabled Desktop Cube, the issue no longer came about.

I'm using a Dell Inspiron 510M, on the 852/855GM chipset. However due to random freezes caused by the experimental intel drivers, I'm using the i810 driver.

Ken Sturmer (ksturmer) wrote :

Upon boot up, I have no taskbars at all. However I discovered when I pointed my mouse at the upper left corner of my screen I got a drop down tab. I was able to perform functions this way, but is very inconvenient. Have not tried rebooting as yet.

This is after desktop has behaved strangely. Mouse pointer disappears, screen pivots back and forth out of control. Then the next time I boot up everything will be fine. Seems to be something with the enhanced desktop features. I do not really understand them.

Jeremy Nickurak (nickurak) wrote :

I've also been able to hit this with openbox and xcompmgr or cairo-compmgr, and only with gnome-panel. It may not be a gnome-panel bug, but a common behavior in compositing managers that can be triggered by gnome-panel.

Changed in gnome-panel:
importance: Unknown → Medium
status: Unknown → New
Timo Aaltonen (tjaalton) on 2011-03-17
Changed in xcompmgr (Ubuntu):
status: New → Invalid
aries (sonagirbas) wrote :

I'm using Elementary OS which is based on Ubuntu 10.10. I've upgraded compiz to version 0.9.2.1 following an article on Webupd8. After upgrade and restart, top panel keeps disappearing as soon as it starts for the first time. It reappears by clicking the desktop. Also without clicking the desktop, Its tooltips pop up if I move the mouse pointer to the top left corner of the screen.

One interesting thing I discovered is that if I disable desktop icons using ubuntu-tweak or gconf-editor, the top panel stops disappearing and starts visible. I'm not sure it's related to compiz or not, but it was ok before the upgrade.

Changed in gnome-panel:
status: New → Expired
Displaying first 40 and last 40 comments. View all 132 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.