Ubuntu

Ubuntu 12.04/7.0.24/ Seti@home

Reported by Dave on 2012-06-06
88
This bug affects 28 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Medium
Unassigned
Precise
High
Unassigned

Bug Description

We already had a bug opened for this issue. But it was marked as "fix released" (I don't know why as no change ever happened to the repository package)

The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository doesn't work for seti@home, it just produces "computation errors".

The package needs to be changed, perhaps to Debians SID 7.0.27, or backported from Quantal if that package has been confirmed to be in good working order.

Currently, 12.04/seti@home and lhc@home users are still unable to run Boinc without using the PPA alternatives.

-Dave

[Edited for clarity]

Please SRU

[Impact]
This bug affects all users of Precise attempting to run Boinc 7.0.24 for the Seti@home project.

[Test case]
Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and connecting to the seti@home project.
Downloaded work-units will instantly error upon attempting to run. In other words the Boinc package currently in the precise repository is unusable for Seti@home, and a couple others.

[Regression Potential]
Quantal has had it's version of boinc changed to 7.0.27 from Debian SID. As far as I'm aware it fixes this bug.
7.0.27 has many upstream fixes for several issues, I think that the change may bring a few new bugs, but should fix far more issues than it causes, again the current package is unusable for one of the largest projects running on Boinc.

https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the upload for SRU

Dave (xclusive585) wrote :

Sorry to add you two, (Steffen, and Locutus) but I feel you should be kept aware of the situation.
Best regards
-Dave

thanks for your bug report, I'm marking this as confirmed and trying to look at the problem, but I really don't have any clue.
Steffen has some clue about this... right?

Changed in boinc (Ubuntu):
status: New → Confirmed
Dave (xclusive585) wrote :

I remember him saying something about issues with the boinc-app-seti for 7.0.28? But he's gonna have to put in his input here because I'm not a developer :-)

(Unfortunately I think they've been busy with other bugs)

Dave (xclusive585) wrote :

Locutus, is there a possibility of you making a "static" PPA for boinc, that can contain Debian's working SID (7.0.27) and NOT 7.0.28 from git, which I'm hearing has another bug coming from upstream that is yet-to be fixed...

Dave (xclusive585) wrote :

And I'll bring this up again. There is a fixed? 7.0.27 in Quantal, that fixed the "instant copmutation error bug".

There was talk of backporting that from Quantal into Precise.

This has NOT happened yet.

I tested the quantal package (which I believe is debians SID 7.0.27??) in Quantal, and had no errors for seti, if others can confirm the Quantal package seems to be error free for seti and other projects, it really really needs to be backported to precise as a fix for the broken 7.0.24 package...

Daniel Hahler (blueyed) wrote :

You might want to try the more official PPA from the pkg-boinc team:
https://launchpad.net/~pkg-boinc/+archive/ppa

This has 7.0.27+dfsg-3, which is the current version from Debian unstable.

boinc-app-seti is being uploaded to the pkg-boinc testing PPA now: https://launchpad.net/~pkg-boinc/+archive/testing (the previous upload failed to build there, I hope that version -2 from Debian addresses that).

Daniel Hahler (blueyed) on 2012-06-06
Changed in boinc (Ubuntu):
importance: Undecided → Medium
Dave (xclusive585) wrote :

Thank you Daniel. That PPA is Exactly what I was looking for. :-)

Markus Klyver (markusklyver) wrote :

This bug seems to also affect LHC@Home, so it is not only SETI, but Milklyway@Home and Einstein@Home works fine.

Dave (xclusive585) on 2012-06-18
description: updated
David Anderson (davea42) wrote :

Installed the PPA today on Precise and a Seti work unit ( 1013689114)
completed successfully. Good news.

Dave (xclusive585) wrote :

The PPA davea42 refers to is the boinc teams build of Debians SID 7.0.27.

...If only we could see the 7.0.27 package backported into 12.04's repository. Hint Hint

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/19/2012 06:49 AM, Dave wrote:
> The PPA davea42 refers to is the boinc teams build of Debians SID
> 7.0.27.
>
> ...If only we could see the 7.0.27 package backported into 12.04's
> repository. Hint Hint

This requires a SRU, see https://wiki.ubuntu.com/SRU

The diffstat for this (boinc_7.0.24+dfsg-1.dsc to
boinc_7.0.27+dfsg-3.dsc) is rather huge (without whitespace changes):
114 files changed, 6497 insertions(+), 2945 deletions(-)

I would be happy to sponsor the upload, but do not like to do the SRU
"paper work".

Can you help out with that?

- --
http://daniel.hahler.de/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iD8DBQFP4N51fAK/hT/mPgARAlsCAJ93yRmyZFTGZ0EEpybP3ZXGbl0dIgCg6dhh
QTW73MqsyZMssucHfwsiFMI=
=RXpN
-----END PGP SIGNATURE-----

Dave (xclusive585) wrote :

I will attempt this this weekend... thanks Daniel
On Jun 19, 2012 4:26 PM, "Daniel Hahler" <email address hidden> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 06/19/2012 06:49 AM, Dave wrote:
> > The PPA davea42 refers to is the boinc teams build of Debians SID
> > 7.0.27.
> >
> > ...If only we could see the 7.0.27 package backported into 12.04's
> > repository. Hint Hint
>
> This requires a SRU, see https://wiki.ubuntu.com/SRU
>
> The diffstat for this (boinc_7.0.24+dfsg-1.dsc to
> boinc_7.0.27+dfsg-3.dsc) is rather huge (without whitespace changes):
> 114 files changed, 6497 insertions(+), 2945 deletions(-)
>
> I would be happy to sponsor the upload, but do not like to do the SRU
> "paper work".
>
> Can you help out with that?
>
>
> - --
> http://daniel.hahler.de/
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iD8DBQFP4N51fAK/hT/mPgARAlsCAJ93yRmyZFTGZ0EEpybP3ZXGbl0dIgCg6dhh
> QTW73MqsyZMssucHfwsiFMI=
> =RXpN
> -----END PGP SIGNATURE-----
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Confirmed
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
>
> -Dave
>
> [Edited for clarity]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

urbaman (urbaman) wrote :

Hi,
Not having enough credits to post on s@h own forum, I try posting here.
any help would be appreciated.
Running Ubuntu 12.04, boinc 7.0.27, seti@home exists with following command many other projects exit with different messages:

<core_client_version>7.0.27</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/setiathome.berkeley.edu/setiathome_enhanced: error while loading shared libraries: libboinc_api.so.6: cannot open shared object file: No such file or directory

</stderr_txt>
]]>

Thanks, Nicola.

Dave (xclusive585) wrote :

Looking into the SRU process. I don't even know where to begin... This may be over my understanding.

Dave (xclusive585) on 2012-06-23
description: updated
David Anderson (davea42) wrote :

Urbaman, this 127 error is off topic. And your email address is hidden. But I would guess you built your own
7.0.27 boinc source (which creates libboinc_api.so.6 and some related links) and only partially installed it.
Get rid of that and follow the instructions provided by Daniel to install the ppa. Please don't
muddy this bug report with off topic posts. Thanks. Email me if you need to (not that I am
an expert in building boinc, I much prefer to install a prebuilt package...).

urbaman (urbaman) wrote :

Thank you very much,

As a helpful note, I installed from the ppa. Hope it helps.

Darr Darr (darr247) wrote :

This bug also affects the Docking@Home project, which uses the Charmm application in BOINC. ergo it may also affect the WorldCommunityGrid.org project, which uses the Charmm application on at least 2 active tasks.

Please push/release 7.0.27 to the repo.

(I did check the "precise-proposed" repo, but Synaptic found no BOINC versions there.)

Thanks!

Darr Darr (darr247) wrote :

OK...
$ sudo add-apt-repository ppa:pkg-boinc/testing
makes it show up in Synaptic... now I just have to wait another 50 minutes or so until the Docking@Home servers will give me more work units, since it already errored out its daily quota of 94 maximum.

Daniel Hahler (blueyed) on 2012-06-27
Changed in boinc (Ubuntu):
status: Confirmed → Triaged
Changed in boinc (Ubuntu Precise):
importance: Undecided → High
Daniel Hahler (blueyed) wrote :

Debdiff of upload to precise-proposed for this SRU.

I am not certain about this Debian change (just have asked Steffen by mail about it):
  * debian/boinc-client.init: increasing priority of boinc client, change nice
    value from 19 to 10.
The init file has this comment, and because of that I have left this change in:
  # BOINC client needs higher priority than scientific apps

I am away until next week, but have tried the build on my machine already, and made it available at:
https://launchpad.net/~pkg-boinc/+archive/testing/+sourcepub/2534432/+listing-archive-extra

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu Precise):
status: New → Confirmed
Dave (xclusive585) wrote :

Thank you Daniel. Much appreciated from everyone, especially me.

Darr Darr (darr247) wrote :

Apparently Docking@Home is the only project *not* running their servers on UTC time. Just got new D@H work units into 7.0.27 and they are not erroring out immediately as they were in 7.0.24... but it will be another 4 hours before the first set is done.
I'm going to bed now. :-)

Darr Darr (darr247) wrote :

I have not had any work units end with errors since upgrading to the 7.0.27 build in that PPA the evening of the 27th... so that's 5 straight days (24/7) of crunching with out error. [insert superstitious ritual here]

Therefore, in my opinion, the subject bug appears to be fixed, for the Charmm application, in the 7.0.27 build that is currently in the
http://ppa.launchpad.net/pkg-boinc/testing/ubuntu
PPA.

Thanks!

Daniel Hahler (blueyed) on 2012-07-11
Changed in boinc (Ubuntu):
status: Triaged → Fix Released
Dave (xclusive585) wrote :

Can I ask what "fix released" means?

Thomas Ward (teward) wrote :

See https://wiki.ubuntu.com/Bugs/Status for details.

On Thu, Jul 12, 2012 at 12:34 PM, Dave <email address hidden> wrote:

> Can I ask what "fix released" means?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (991179).
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Confirmed
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

Hello Dave, or anyone else affected,

Accepted boinc into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/boinc/7.0.27+dfsg-5ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in boinc (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
urbaman (urbaman) wrote :

Hi,

Installed the package: 13 out of my 14 projects are now working, SETI@HOME among them.
I'll get you more testing feedback as the work units end and I receive the right results.

Still trying to make Test4Theory working, but it's a different story (anyone done it?).

Thank you very much,
Nicola.

tags: added: verification-done
removed: verification-needed
TheDreamer (thedreamer-lhaven) wrote :

I have Test4Theory working on other systems (10.04LTS), even better now that it has a headless option...otherwise there was tweaking to allow boinc to pop the VM window onto my desktop, and have myself automatically log in...so it could maybe work if the system rebooted when I wasn't there.

But, VirtualBox & QuakeCatcherNetwork don't get along. Something about the USB sensor, causes the kernel to panic when VirtualBox is starting (and none of the VMs use USB and the presence or absence of the extension pack doesn't make a difference. )

This was the only reason I set up a 12.04LTS box to play with....

Matt Dittloff (mattdittloff) wrote :

Docking@home is a project that was giving computation errors. In 7.0.27, the work units run correctly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.27+dfsg-5ubuntu0.12.04.1

---------------
boinc (7.0.27+dfsg-5ubuntu0.12.04.1) precise-proposed; urgency=low

  * Stable Release Update to fix multiple bugs:
    - fixes regression with Seti, Docking@Home and maybe others
      (LP: #1009536)
    - fixes crash when adding projects (LP: #1001168)
    - fixes file descriptor leak (LP: #968021)
  * debian/control: enable building of boinc-amd-opencl again (disabled in
    7.0.27+dfsg-4 for Debian specific reasons)

boinc (7.0.27+dfsg-5) unstable; urgency=low

  * debian/rules: use dpkg-buildflags to get default flags.
  * debian/control: build-depend on dpkg-dev >= 1.16.1.1, because
    buildflags.mk and DEB_BUILD_MAINT_OPTIONS are needed.
  * debian/patches/add_hardening_flags.patch: pass CXXFLAGS, CPPFLAGS and
    LDFLAGS to hand-written Makefiles in samples/.

boinc (7.0.27+dfsg-4) unstable; urgency=low

  [ Steffen Moeller ]
  * Not building boinc-amd-opencl, for fglrx-driver is not in testing.
  * Adding hardening flags.
  * Addressed FTBFS on hurd (Closes: #672725)
  * debian/boinc-client.init: increasing priority of boinc client, change nice
    value from 19 to 10.

  [ Guo Yixuan ]
  * Add patch from Rom that fix the project category crash. (Closes: #641593)
  * debian/rules: fix to set sched/transitioner_catchup.php in
    boinc-server-maker executable.
  * Cherry-picking above commits from master to sid branch.
  * Add myself to uploaders.

boinc (7.0.27+dfsg-3) unstable; urgency=low

  * Now truly reconstituting compatibility with SETI
    (Closes: #672328, lp: #991179).
  * builds with gcc 4.7 (Closes: #671999)
    Thanks to Matthias Klose for his patch, had sadly only seen it after
    I patched it myself :o/ The NMU of his should not kick in because
    of the SETI incompatibility.

boinc (7.0.27+dfsg-2) unstable; urgency=low

  * Removed a couple of patches to help preventing crash in some
    scientific apps

boinc (7.0.27+dfsg-1) unstable; urgency=low

  * New upstream release
    - NVidia issue settled, presumably.
    - Some patches adopted by upstream.

boinc (7.0.26+dfsg-1) unstable; urgency=low

  * New upstream release
    - Comes with NVidia patches
    - Other incompatibilities with various projects fixed

boinc (7.0.25+dfsg-2) UNRELEASED; urgency=low

  * Added patch by Bernd Machenschalk to improve the uniqueness
    of clients when multiple instances are run.
  * Helping man page of stripchart.

boinc (7.0.25+dfsg-1) UNRELEASED; urgency=low

  [ Steffen ]
  * New upstream version (not yet with NVidia API improvements).

  [ Thorsten ]
  * Helping warnings in init scripts (Closes: #651278,#651303).
  * Fixing Python dir problem for boinc-server-maker (Closes: #657036)
  * Fixed warning for man page to stripchart.

boinc (7.0.24+dfsg-4) UNRELEASED; urgency=low

  * Improved support of NVidia cards - API incompatibility

boinc (7.0.24+dfsg-3) UNRELEASED; urgency=low

  * Support of clang through DEB_BUILD_OPTIONS

boinc (7.0.24+dfsg-2) UNRELEASED; urgency=low

  * More adjustments of patches.
 -- Daniel Hahler <email address hidden> Thu, 28 Jun 2012 01:17:04 +0200

Changed in boinc (Ubuntu Precise):
status: Fix Committed → Fix Released

Hi there,
I am currently running a new installed 12.04 LTS, with the following packages:

dpkg -l|grep boinc
ii boinc 7.0.27+dfsg-5ubuntu0.12.04.1 metapackage for the BOINC client and the manager
ii boinc-app-seti 5.13+cvs20060510-7ubuntu1 SETI@home application for the BOINC client
ii boinc-client 7.0.27+dfsg-5ubuntu0.12.04.1 core client for the BOINC distributed computing infrastructure
ii boinc-dev 7.0.27+dfsg-5ubuntu0.12.04.1 development files to build applications for BOINC projects
ii boinc-manager 7.0.27+dfsg-5ubuntu0.12.04.1 GUI to control and monitor the BOINC core client
ii boinc-nvidia-cuda 7.0.27+dfsg-5ubuntu0.12.04.1 metapackage for CUDA-savvy BOINC client and manager

With the following result, as recorded by SETI@Home here: http://setiathome.berkeley.edu/result.php?resultid=2570285385

<core_client_version>7.0.27</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/setiathome.berkeley.edu/setiathome_enhanced: error while loading shared libraries: libboinc_api.so.6: cannot open shared object file: No such file or directory
</stderr_txt>
]]>

So this bug does not seem to be "Fixed" in all situations.

This is really another bug, this is a bug about a missing library, and I think Steffen would provide a more accurare reply to you.

In the meanwhile I can suggest you to try my ppa [1] or paste here the result of command
ls -l /usr/lib/libboinc_api.so

I think during the upgrade the symlink hasn't been updated to /usr/lib/libboinc_api.so.7

[1] https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

(I'm building right now another shot but launchpad builders are gonna be updated so I think I'll have to wait for some idle builders)

Hi Jonathan,

On 08/20/2012 09:40 AM, Jonathan Harker wrote:
> Hi there,
> I am currently running a new installed 12.04 LTS, with the following packages:
>
> dpkg -l|grep boinc
> ii boinc 7.0.27+dfsg-5ubuntu0.12.04.1 metapackage for the BOINC client and the manager
> ii boinc-app-seti 5.13+cvs20060510-7ubuntu1 SETI@home application for the BOINC client
> ii boinc-client 7.0.27+dfsg-5ubuntu0.12.04.1 core client for the BOINC distributed computing infrastructure
> ii boinc-dev 7.0.27+dfsg-5ubuntu0.12.04.1 development files to build applications for BOINC projects
> ii boinc-manager 7.0.27+dfsg-5ubuntu0.12.04.1 GUI to control and monitor the BOINC core client
> ii boinc-nvidia-cuda 7.0.27+dfsg-5ubuntu0.12.04.1 metapackage for CUDA-savvy BOINC client and manager
>
> With the following result, as recorded by SETI@Home here:
> http://setiathome.berkeley.edu/result.php?resultid=2570285385
>
> <core_client_version>7.0.27</core_client_version>
> <![CDATA[
> <message>
> process exited with code 127 (0x7f, -129)
> </message>
> <stderr_txt>
> ../../projects/setiathome.berkeley.edu/setiathome_enhanced: error while loading shared libraries: libboinc_api.so.6: cannot open shared object file: No such file or directory
> </stderr_txt>
> ]]>
>
> So this bug does not seem to be "Fixed" in all situations.
I have to apologise for this one. The SETI client was already built
against 7.0.33 which ships that library. 7.0.31 should already feature
it. Debian unstable already has 7.0.33 in its archive, please take it
from there or there will instructions from others on where to find it.

Cheers,

Steffen

lrwxrwxrwx 1 root root 22 Jul 19 05:24 /usr/lib/libboinc_api.so -> libboinc_api.so.7.0.27
lrwxrwxrwx 1 root root 22 Jul 19 05:24 /usr/lib/libboinc_api.so.7 -> libboinc_api.so.7.0.27
-rw-r--r-- 1 root root 38896 Jul 19 05:24 /usr/lib/libboinc_api.so.7.0.27

It smells like a problem with the boinc-app-seti still trying to link to the old boinc API 6.x rather than 7.x

I'm not sure where to post this, since everything seems to be a dup of this bug and I don't want to open yet another.

Since if I install the current default packaged boinc-client and boinc-app-seti, it fails with computation errors complaining about a missing /usr/lib/libboinc_api.so.6 I consider this bug is NOT fixed.

If I install the packages from LocutusOfBorg's PPA I now get this:

Tue 21 Aug 2012 12:42:54 PM NZST | SETI@home | update requested by user
Tue 21 Aug 2012 12:42:57 PM NZST | SETI@home | Sending scheduler request: Requested by user.
Tue 21 Aug 2012 12:42:57 PM NZST | SETI@home | Requesting new tasks for CPU
Tue 21 Aug 2012 12:42:59 PM NZST | SETI@home | Scheduler request completed: got 0 new tasks
Tue 21 Aug 2012 12:42:59 PM NZST | SETI@home | No tasks sent
Tue 21 Aug 2012 12:42:59 PM NZST | SETI@home | Message from server: Your app_info.xml file doesn't have a usable version of SETI@home Enhanced.
Tue 21 Aug 2012 12:42:59 PM NZST | SETI@home | This computer has finished a daily quota of 1 tasks

Thomas Ward (teward) wrote :

According to Comment 30 here (https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/comments/30), this was uploaded into Precise-proposed. To the best of my knowledge, from there, it has to be tested and reviewed, before being included in Precise.

After poking both the release team and a few other sections of the Ubuntu IRC channels I found out that precise-updates (where this fix would likely end up) is frozen until post-12.04.1 release, so I would not expect a *quick* release-fix on this. The "Fix Released" status identifies that this exists in precise-proposed (per the first line of the changelog that was posted automatically in comment 30).

Hello, after rereading about that SETI issue I have to admit that my answer was wrong. Jonathan was right by pointing out that the SETI scientific app seeks older symbolic libraries.

This what it should look like

$ ldd `dpkg -L boinc-app-seti | grep setiathome`
        linux-vdso.so.1 => (0x00007fff73b71000)
        libboinc_api.so.7 => /usr/lib/libboinc_api.so.7 (0x00007f1d8825f000)
        libfftw3f.so.3 => /usr/lib/x86_64-linux-gnu/libfftw3f.so.3 (0x00007f1d87e5c000)
        libssl.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007f1d87bfd000)
        libcrypto.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f1d87819000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f1d87512000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f1d8728f000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f1d87079000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f1d86e5d000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1d86ad5000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f1d868d1000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f1d866ba000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f1d8849a000)

$ dpkg -S /usr/lib/libboinc_api.so.7
boinc-dev: /usr/lib/libboinc_api.so.7

$ dpkg -l boinc-dev|grep boinc-dev|awk '{print $2,$3}'
boinc-dev 7.0.27+dfsg-5

This is the boinc client from Debian Wheezy (testing) and boinc-app-seti just uploaded to sid (unstable). 7.0.27 should work for about everything. 7.0.33 is still in the Debian new queue, with the ftpmaters uncertain if they should let it in because of an uncertain transition to testing in those last freeze days. I am still hoping for it. 7.0.34 is in the git repository for the unfrozen Ubuntu to adopt. Works for me.

Steffen

@Jonathan with his SETI limitation - this is because SETI thinks that it has sent you enough workunits for that day. That limit will go up once the client works and workunits have been validated successfully.

I'm building 7.0.34 right now and it will be available in my ppa "boinc" hopefully tomorrow, unfortunately after a general build farm upgrade the queue of builders is really high and I really don't know how many days will take to empty it.

After this I'll upgrade boinc-app-seti too.

It can't be just in proposed if I installed 12.04 last Friday and I ended up with version 7.0.27+dfsg-5ubuntu0.12.04 as I noted in #31 since I don't have the proposed repo enabled.

Steffen: sounds like it's more than just that:

Message from server: Your app_info.xml file doesn't have a usable version of SETI@home Enhanced.

I suggest to change projects until locutus' PPA features boinc-app-seti
-3 from unstable.
Cheers,
Steffen

Sent with AquaMail for Android
http://www.aqua-mail.com

On August 21, 2012 3:19:24 PM Jonathan Harker
<email address hidden> wrote:
> It can't be just in proposed if I installed 12.04 last Friday and I
> ended up with version 7.0.27+dfsg-5ubuntu0.12.04 as I noted in #31 since
> I don't have the proposed repo enabled.
>
> Steffen: sounds like it's more than just that:
>
> Message from server: Your app_info.xml file doesn't have a usable
> version of SETI@home Enhanced.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions

Thomas Ward (teward) wrote :

After further reviewing:

Jonathan, Steffen, and all: Your "bug" you're reporting now, saying that this bug was not fixed, is actually not needed here.

According to Comment 32 (https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/comments/32) this is a different bug, and should be filed as such.

I disagree. The bug description states:

The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository doesn't work for seti@home, it just produces "computation errors". The package needs to be changed, perhaps to Debians SID 7.0.27, or backported from Quantal if that package has been confirmed to be in good working order. Currently, 12.04/seti@home and lhc@home users are still unable to run Boinc without using the PPA alternatives.

Since seti@home still produces computation errors and still doesn't run, then this is the same bug, and it is still not fixed. If the bug is still present, then it doesn't matter why, or what caused it, it's still the same bug, and it still needs fixing.

Dave (xclusive585) wrote :

But being as how this bug IS caused by a different issue, it is not the
same bug. Furthermore your bug only happens to some people where as the
7.0.24 boinc bug affects everyone running certain projects
On Aug 21, 2012 5:56 PM, "Jonathan Harker" <email address hidden>
wrote:

> I disagree. The bug description states:
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors". The
> package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in good
> working order. Currently, 12.04/seti@home and lhc@home users are still
> unable to run Boinc without using the PPA alternatives.
>
> Since seti@home still produces computation errors and still doesn't run,
> then this is the same bug, and it is still not fixed. If the bug is
> still present, then it doesn't matter why, or what caused it, it's still
> the same bug, and it still needs fixing.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Fix Released
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

So "Fix Released" means "still broken sometimes"?

Dave (xclusive585) wrote :

It means a fix was released for my bug. Not yours.
On Aug 21, 2012 8:15 PM, "Jonathan Harker" <email address hidden>
wrote:

> So "Fix Released" means "still broken sometimes"?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Fix Released
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

Dave (xclusive585) wrote :

The main thing is your bug is still an issue that needs to be dealt with.
If we push your bug then perhaps we could get a better version than the
7.0.27 put into the standard repository in the future. In the meantime use
locutus' ppa with 7.0.33 for now it should work for you.
On Aug 21, 2012 8:17 PM, "Xclusive Technology" <email address hidden>
wrote:

> It means a fix was released for my bug. Not yours.
> On Aug 21, 2012 8:15 PM, "Jonathan Harker" <email address hidden>
> wrote:
>
>> So "Fix Released" means "still broken sometimes"?
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1009536
>>
>> Title:
>> Ubuntu 12.04/7.0.24/ Seti@home
>>
>> Status in “boinc” package in Ubuntu:
>> Fix Released
>> Status in “boinc” source package in Precise:
>> Fix Released
>>
>> Bug description:
>> We already had a bug opened for this issue. But it was marked as "fix
>> released" (I don't know why as no change ever happened to the
>> repository package)
>>
>> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
>> doesn't work for seti@home, it just produces "computation errors".
>>
>> The package needs to be changed, perhaps to Debians SID 7.0.27, or
>> backported from Quantal if that package has been confirmed to be in
>> good working order.
>>
>> Currently, 12.04/seti@home and lhc@home users are still unable to run
>> Boinc without using the PPA alternatives.
>>
>> -Dave
>>
>> [Edited for clarity]
>>
>>
>> Please SRU
>>
>> [Impact]
>> This bug affects all users of Precise attempting to run Boinc 7.0.24
>> for the Seti@home project.
>>
>> [Test case]
>> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
>> connecting to the seti@home project.
>> Downloaded work-units will instantly error upon attempting to run. In
>> other words the Boinc package currently in the precise repository is
>> unusable for Seti@home, and a couple others.
>>
>> [Regression Potential]
>> Quantal has had it's version of boinc changed to 7.0.27 from Debian
>> SID. As far as I'm aware it fixes this bug.
>> 7.0.27 has many upstream fixes for several issues, I think that the
>> change may bring a few new bugs, but should fix far more issues than it
>> causes, again the current package is unusable for one of the largest
>> projects running on Boinc.
>>
>> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
>> upload for SRU
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>>
>

This bug is essentially this: the Boinc package in the 12.04 Ubuntu repository doesn't work for seti@home, it produces "computation errors."

This is still the case.

It does NOT matter what the underlying issue is. The suggested fix, update it to 7.0.27, was implemented and still does not completely fix the bug, which is that it produces computation errors.

Just because the fix that was suggested, implemented and released did not completely fix the problem, does not somehow transform this into a different bug. It just means that the fix did not completely address the root cause(s). Creating different bugs for different causes is just needless duplication of effort.

If you really think I should be commenting on a different bug, then by all means direct me to the right one.

Dave (xclusive585) wrote :

Um, the package in the repository is still the broken 7.0.24.... so yes its
still broken. The fix is released into PROPOSED. and as I said if you make
a case for your bug perhaps the package in PROPOSED can be changed before
it goes into the 12.04 repository
On Aug 21, 2012 8:45 PM, "Jonathan Harker" <email address hidden>
wrote:

> This bug is essentially this: the Boinc package in the 12.04 Ubuntu
> repository doesn't work for seti@home, it produces "computation errors."
>
> This is still the case.
>
> It does NOT matter what the underlying issue is. The suggested fix,
> update it to 7.0.27, was implemented and still does not completely fix
> the bug, which is that it produces computation errors.
>
> Just because the fix that was suggested, implemented and released did
> not completely fix the problem, does not somehow transform this into a
> different bug. It just means that the fix did not completely address the
> root cause(s). Creating different bugs for different causes is just
> needless duplication of effort.
>
> If you really think I should be commenting on a different bug, then by
> all means direct me to the right one.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Fix Released
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

Dave (xclusive585) wrote :

Your bug is caused by a broken dependency. THIS BUG YOU ARE POSTING IN IS
CAUSED BY A BAD PATCH. They ARE two DIFFERENT issues.
On Aug 21, 2012 8:45 PM, "Jonathan Harker" <email address hidden>
wrote:

> This bug is essentially this: the Boinc package in the 12.04 Ubuntu
> repository doesn't work for seti@home, it produces "computation errors."
>
> This is still the case.
>
> It does NOT matter what the underlying issue is. The suggested fix,
> update it to 7.0.27, was implemented and still does not completely fix
> the bug, which is that it produces computation errors.
>
> Just because the fix that was suggested, implemented and released did
> not completely fix the problem, does not somehow transform this into a
> different bug. It just means that the fix did not completely address the
> root cause(s). Creating different bugs for different causes is just
> needless duplication of effort.
>
> If you really think I should be commenting on a different bug, then by
> all means direct me to the right one.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Fix Released
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

Dave (xclusive585) wrote :
Download full text (3.3 KiB)

I know somewhere along the way, your bug has been mentioned in this bug.
But this bug is the sru for the old issue with 7.0.24 that was caused by a
bad patch.
On Aug 21, 2012 8:53 PM, "Xclusive Technology" <email address hidden>
wrote:

> Your bug is caused by a broken dependency. THIS BUG YOU ARE POSTING IN IS
> CAUSED BY A BAD PATCH. They ARE two DIFFERENT issues.
> On Aug 21, 2012 8:45 PM, "Jonathan Harker" <email address hidden>
> wrote:
>
>> This bug is essentially this: the Boinc package in the 12.04 Ubuntu
>> repository doesn't work for seti@home, it produces "computation errors."
>>
>> This is still the case.
>>
>> It does NOT matter what the underlying issue is. The suggested fix,
>> update it to 7.0.27, was implemented and still does not completely fix
>> the bug, which is that it produces computation errors.
>>
>> Just because the fix that was suggested, implemented and released did
>> not completely fix the problem, does not somehow transform this into a
>> different bug. It just means that the fix did not completely address the
>> root cause(s). Creating different bugs for different causes is just
>> needless duplication of effort.
>>
>> If you really think I should be commenting on a different bug, then by
>> all means direct me to the right one.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1009536
>>
>> Title:
>> Ubuntu 12.04/7.0.24/ Seti@home
>>
>> Status in “boinc” package in Ubuntu:
>> Fix Released
>> Status in “boinc” source package in Precise:
>> Fix Released
>>
>> Bug description:
>> We already had a bug opened for this issue. But it was marked as "fix
>> released" (I don't know why as no change ever happened to the
>> repository package)
>>
>> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
>> doesn't work for seti@home, it just produces "computation errors".
>>
>> The package needs to be changed, perhaps to Debians SID 7.0.27, or
>> backported from Quantal if that package has been confirmed to be in
>> good working order.
>>
>> Currently, 12.04/seti@home and lhc@home users are still unable to run
>> Boinc without using the PPA alternatives.
>>
>> -Dave
>>
>> [Edited for clarity]
>>
>>
>> Please SRU
>>
>> [Impact]
>> This bug affects all users of Precise attempting to run Boinc 7.0.24
>> for the Seti@home project.
>>
>> [Test case]
>> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
>> connecting to the seti@home project.
>> Downloaded work-units will instantly error upon attempting to run. In
>> other words the Boinc package currently in the precise repository is
>> unusable for Seti@home, and a couple others.
>>
>> [Regression Potential]
>> Quantal has had it's version of boinc changed to 7.0.27 from Debian
>> SID. As far as I'm aware it fixes this bug.
>> 7.0.27 has many upstream fixes for several issues, I think that the
>> change may bring a few new bugs, but should fix far more issues than it
>> causes, again the current package is unusable for one of the largest
>> projects running on Boinc.
>>
>> https://launchpad.net/~blueyed Dani...

Read more...

Fine, but how can I possibly have ended up with 7.0.27+dfsg-5ubuntu0.12.04.1 in my 12.04 install on two different PCs when I don't have precise-proposed enabled? A mystery. So shall I create another bug?

$ sudo apt-get source boinc-client
Reading package lists... Done
Building dependency tree
Reading state information... Done
Picking 'boinc' as source package instead of 'boinc-client'
NOTICE: 'boinc' packaging is maintained in the 'Git' version control system at:
git://git.debian.org/git/pkg-boinc/boinc.git
Need to get 33.8 MB of source archives.
Get:1 http://nz.archive.ubuntu.com/ubuntu/ precise-updates/universe boinc 7.0.27+dfsg-5ubuntu0.12.04.1 (dsc) [2,488 B]
Get:2 http://nz.archive.ubuntu.com/ubuntu/ precise-updates/universe boinc 7.0.27+dfsg-5ubuntu0.12.04.1 (tar) [33.6 MB]

>Fine, but how can I possibly have ended up with 7.0.27+dfsg-5ubuntu0.12.04.1 in my 12.04 install on two different PCs when I >don't have precise-proposed enabled? A mystery. So shall I create another bug?

no. this is an expected behavior.

According to [1] and [2] boinc has been automatically pushed on updates on 2012-07-26 01:33:40 CEST
(It has been published when I removed every verification-needed tag and wrote the verification-done one)

[1] https://bugs.launchpad.net/ubuntu/+source/boinc/
[2] https://bugs.launchpad.net/ubuntu/+source/boinc/+publishinghistory

Promise I won't make any more noise, but Locutus: I can happily report that your PPA boinc-app-seti is now running fine on one of my 12.04 machines, but it needed a reboot to fix the "app_info.xml file doesn't have a usable version of SETI@home Enhanced" error message :-)

On 08/22/2012 04:51 PM, Jonathan Harker wrote:
> Promise I won't make any more noise, but Locutus: I can happily report
> that your PPA boinc-app-seti is now running fine on one of my 12.04
> machines, but it needed a reboot to fix the "app_info.xml file doesn't
> have a usable version of SETI@home Enhanced" error message :-)
My hunch is that invoking "Reset project" for SETI after installation of
boinc-app-seti would have been sufficient.

@Jonathan, please skim though wiki.debian.org/BOINC . That is (not
unsurpringly) a bit Debian-centric, but either way some information on
how to work with boinc-app-seti could be put more prominently, now that
it is in such a nice shape again. If you have ideas - go for it.

Cheers,

Steffen

Dave (xclusive585) wrote :

I suppose yes start a bug with the error thrown by Boinc. I just checked
Ubuntu repo and see that 7.0.27 made it into precise updates I wasn't aware
that happened already. So I guess now we move on to dealing with the 7.0.27
bugs :-).
On Aug 22, 2012 7:31 AM, "Jonathan Harker" <email address hidden>
wrote:

> Fine, but how can I possibly have ended up with 7.0.27+dfsg-
> 5ubuntu0.12.04.1 in my 12.04 install on two different PCs when I don't
> have precise-proposed enabled? A mystery. So shall I create another bug?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1009536
>
> Title:
> Ubuntu 12.04/7.0.24/ Seti@home
>
> Status in “boinc” package in Ubuntu:
> Fix Released
> Status in “boinc” source package in Precise:
> Fix Released
>
> Bug description:
> We already had a bug opened for this issue. But it was marked as "fix
> released" (I don't know why as no change ever happened to the
> repository package)
>
> The Boinc package (7.0.24....precise1) in the 12.04 Ubuntu repository
> doesn't work for seti@home, it just produces "computation errors".
>
> The package needs to be changed, perhaps to Debians SID 7.0.27, or
> backported from Quantal if that package has been confirmed to be in
> good working order.
>
> Currently, 12.04/seti@home and lhc@home users are still unable to run
> Boinc without using the PPA alternatives.
>
> -Dave
>
> [Edited for clarity]
>
>
> Please SRU
>
> [Impact]
> This bug affects all users of Precise attempting to run Boinc 7.0.24 for
> the Seti@home project.
>
> [Test case]
> Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and
> connecting to the seti@home project.
> Downloaded work-units will instantly error upon attempting to run. In
> other words the Boinc package currently in the precise repository is
> unusable for Seti@home, and a couple others.
>
> [Regression Potential]
> Quantal has had it's version of boinc changed to 7.0.27 from Debian SID.
> As far as I'm aware it fixes this bug.
> 7.0.27 has many upstream fixes for several issues, I think that the
> change may bring a few new bugs, but should fix far more issues than it
> causes, again the current package is unusable for one of the largest
> projects running on Boinc.
>
> https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the
> upload for SRU
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1009536/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions