Ubuntu

7.0.24 "computation error" bug

Reported by Dave on 2012-04-29
This bug report is a duplicate of:  Bug #1009536: Ubuntu 12.04/7.0.24/ Seti@home. Edit Remove
114
This bug affects 21 people
Affects Status Importance Assigned to Milestone
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
Medium
Thomas Ward

Bug Description

Hi. Repository version 7.0.24...precise has a known bug which affects users running Ubuntu 12.04. The bug makes the boinc software unable to process any work-units for some projects.

This is a known bug by a growing group of Seti@Home Boinc users running Ubuntu 12.04 and other Debain variants.

As soon as there is a version out which overcomes this bug, the repository package may want to be changed.

Thanks.

Please SRU

[Impact]
This bug affects all users of Precise attempting to run Boinc 7.0.24 for the Seti@home project.

[Test case]
Bug can be reproduced by installing Boinc 7.0.24 in Ubuntu 12.04 and connecting to the seti@home project.
Downloaded work-units will instantly error upon attempting to run. In other words the Boinc package currently in the precise repository is unusable for Seti@home, and a couple others.

[Regression Potential]
Quantal has had it's version of boinc changed to 7.0.27 from Debian SID. As far as I'm aware it fixes this bug.
7.0.27 has many upstream fixes for several issues, I think that the change may bring a few new bugs, but should fix far more issues than it causes, again the current package is unusable for one of the largest projects running on Boinc.

https://launchpad.net/~blueyed Daniel Hahler has agreed to sponsor the upload for SRU

Please update to 7.0.26 from my ppa and tell if the problem is really fixed.
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

Changed in boinc (Ubuntu):
status: New → Incomplete
Dave (xclusive585) wrote :

I will do, but I already know from personal contact with the boinc developers that this bug is fixed in .26

Thanks

I ask you this because I don't see in the checkin notes [1] any reference to this

[1] http://boinc.berkeley.edu/svn/tags/boinc_core_release_7_0_26/checkin_notes

Dave (xclusive585) wrote :

Wow. Time to go harass the developers in my other forum :-)

It is indeed NOT fixed in this version.

Thanks for the ppa link and the correction. I'm sorry about the misinformation I was given

Changed in boinc (Ubuntu):
status: Incomplete → New
Dave (xclusive585) on 2012-04-30
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Dave (xclusive585) wrote :

I've updated the bug description to be more accurate. Some further input from others would be helpful.

description: updated
Dave (xclusive585) on 2012-05-01
description: updated

Ok Dave, so this seems to has nothing to do with upstream boinc.

I don't understand, if this bug is downstream (probably caused from some debian/patch) why upstream developers told you the bug was fixed?

could you please link here the thread which are you referring too?

because if the bug is really downstream I can build a boinc without patches, but I prefer to wait until you or somebody else confirm this.

thanks

*have

Dave (xclusive585) wrote :

Hi, it was misinformation I had gathered from the seti@home boards. The word I received was that 7.0.26 fixed the "computation error bug" for the seti crunchers.

Here's the link (you may need a seti account) where I gathered info that 7.0.26 had this bug fix, the second message is the "misinformation" I received (you can even see my last message, updating that 7.0.26 from your ppa still was borked):
http://setiathome.berkeley.edu/forum_thread.php?id=67670

But it appears only the upstream is currently working for seti@home in Ubuntu 12.04.

There is other talk in some other threads here but not ones that outsiders can access. I am desperately trying to get a (real) developer of Boinc in on this as they should know a lot more than us dumb ol users. :-)

I wish I knew more than this. And thanks for your help!

Dave (xclusive585) wrote :

And I too am trying to make sure of what will work and what doesn't. I still haven't confirmed that the upstream doesn't have this issue, and I'm hoping someone can confirm what the heck is broken.

Dave (xclusive585) wrote :

And this link:
http://setiathome.berkeley.edu/forum_thread.php?id=67864
Is where several of us have been discussing the issue, but you can't access it without having work credit (for crunching done) tied to your account.

Unfortunately now s@h is down for maintenance, I'll try to do some s@h work later as soon seti becomes available again.

Now I'm doing some Einstein@Home work and I didn't notice any problem so far.

But I have to say I'm using BOINC from berkeley download and not from ubuntu repo.

If you want to try a "clean" boinc install you can download .26 from [1]

and run it by doing
sh http://boinc.berkeley.edu/dl/boinc_7.0.26_x86_64-pc-linux-gnu.sh
BOINC/run_manager

it will create a new boinc profile, in the directory you run the script, so you can easily avoid collisions from both profiles, so just make sure when you run it no other boinc instances are running on your system.

[1] http://boinc.berkeley.edu/dl/boinc_7.0.26_x86_64-pc-linux-gnu.sh
      http://boinc.berkeley.edu/dl/boinc_7.0.26_i686-pc-linux-gnu.sh

Dave (xclusive585) wrote :

Yes, every Tuesday we lose the server for the day typically. As I said from what we've deduced, it's only the seti@home project that is affected. People that have been finding this issue have mentioned not having trouble running the other projects...

Another thing to note, is it's not ALL machines that are finding the crunching error with seti@home and 12.04/ 7.0.24etc: I have a p4 system that works fine, however boinc was installed on it during the daily build period, and I haven't purged and re-installed on that machine to test if it would still work. Also, it's not dependent on architecture, as we have users with 32 bit and 64 bit processors reporting the error.

I will try the scripted install method in a few minutes here, from what I've read from the other users it should work. I'll report back.

Dave (xclusive585) wrote :

Ok, I installed it and got the necessary dependencies. It's running. But as the project is down for its weekly maintenance I cannot connect my account or get work. As soon as they get back online I'll let you know how it goes.

But I'm hopeful. If this works, I'll just make a neat little script to launch it as it is. Until we figure out what's up with the repository version.

Dave (xclusive585) wrote :

Oh, and one more weird thing I found. The 12.04 repository version of BOINC 7.0.24(etc) is installing the BOINC data in two locations...

It installs it in /var/lib/... as I understand is the norm for the Ubuntu repo version. But it also installs doubles directly in the home/user folder which I found odd.

Dave (xclusive585) wrote :

OK.

The Berkeley (upstream) Linux version 7.0.26 works great on my 12.04 ubuntu box.

So something in the repository package or something specific to the seti@home app is the culprit. Seeing as how seti works fine with the Berkeley version, it is most likely specific to the repository package??

Anything else I can do to help here? I plan on bringing up the topic on the Boinc message boards in a little while.

Dave (xclusive585) wrote :

Hi Steffen sorry for adding you to this bug, but I think you can might have a clue of what is happening here, boinc was copied from debian sid, so I think some patch is causing this bug and I think debian is affected too. What do you think about?

Dave (xclusive585) on 2012-05-03
description: updated

HI Dave, I have just build a boinc 7.0.26 from another of my ppa's [1] and this is build with not patch at all (just three patch to make it build of course)

Could you give it a try?
With this version you shouldn't notice this bug, I'll release new version after you tell me if you see the bug or not until we figure out which of them causes the problem.

Thanks

[1] https://code.launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa

Hello,

I can confirm this problem. I have only a hunch what may be wrong, most likely the boinc-client now produces lines in its communication with the scientific app that are complete - but too long. But I have to prove that, still. The problem occurred while I was excluding potential issues with the Einstein@Home scientific app, which had eventually been identified and fixed in upstream code of 7.0.26. Einstein@Home is not affected by this issue, please consider running that or Rosetta@Home until the update is in the archive.

I had compiled the SETI App locally but that still shows that bug, so I am a bit puzzled. Go ahead with your patch-free version. For Debian I aim at 7.0.27 to have that addressed, which has seen a major update of our patches in the upstream codebase. ... should come out any time soon, now.

Cheers,

Steffen

-------- Original-Nachricht --------
> Datum: Thu, 03 May 2012 09:09:15 -0000
> Von: LocutusOfBorg <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> HI Dave, I have just build a boinc 7.0.26 from another of my ppa's [1]
> and this is build with not patch at all (just three patch to make it
> build of course)
>
> Could you give it a try?
> With this version you shouldn't notice this bug, I'll release new version
> after you tell me if you see the bug or not until we figure out which of
> them causes the problem.
>
> Thanks
>
> [1] https://code.launchpad.net/~costamagnagianfranco/+archive
> /locutusofborg-ppa
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions

Dave (xclusive585) wrote :

@Locutus. Will do, happily! It's just gonna take about 12 hours til some AP units finish up, I don't wanna risk ruining them. I'll report back.

@Steffen, I believe 7.0.27 was released in the last couple days. :-)

Thanks for the efforts guys! We all appreciate it. I can't wait to test the new ppa tonight Locutus.

Hello,

-------- Original-Nachricht --------
> Datum: Thu, 03 May 2012 16:11:35 -0000
> Von: Dave <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> @Locutus. Will do, happily! It's just gonna take about 12 hours til some
> AP units finish up, I don't wanna risk ruining them. I'll report back.
>
> @Steffen, I believe 7.0.27 was released in the last couple days. :-)
Yesterday night, I think?

> Thanks for the efforts guys! We all appreciate it. I can't wait to test
> the new ppa tonight Locutus.

I just uploaded something that runs SETI for me to the archive. It is in the git repo and on http://master.dermacloud.uni-luebeck.de/~moeller/oliver

I'll keep fiddling with it to locate the culprit.

Steffen

Changed in boinc (Ubuntu):
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
Dave (xclusive585) wrote :

OK
Locutus, that 7.0.26 from the ppa works wonderfully. No computation error bug.

(sorry about the delay I had workunits that took 20 hours to complete. I removed all my boinc related files and upgraded all my packages, then I waited to see how this was running)

I can't speak for everyone else's projects, but S@H is running great with this for me. :-)

Let me know if/when it gets pushed into the standard Ubuntu repository...

Dave (xclusive585) wrote :

and interesting, in the changelog for 7.0.27 I read "compile fix"... Don't really know what that means for you guys, but maybe it's good news?

Hello,

-------- Original-Nachricht --------
> Datum: Fri, 04 May 2012 17:22:10 -0000
> Von: Dave <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> and interesting, in the changelog for 7.0.27 I read "compile fix"...
> Don't really know what that means for you guys, but maybe it's good
> news?

The bug is fixed by undoing some presumed improvements of mine. This needs some further investigation, but even if we fix it, all scientific apps would need an update, so ...

Maybe we should just fine those aliens quickly and have them fix it all for us...or eradicate man kind.

Cheers,

Steffen

Hi Dave and Steffen, unfortunately the bug is fixed but I agree with Steffen that we need to know the EXACTLY patch that causes the problem, you might not notice this bug, but every patch is here to fix a bug, to increase stability, to make a better boinc experience.

So just removing patches isn't the solution, what I'm doing is enabling some of them, build boinc again and ask you to test it.

I have enabled 10 more patches and I'm currently building boinc - 7.0.26+dfsg-0~827~precise1, it will be hopefully available in a few hours, it would be nice if you can test it and report back here.
thanks

Dave (xclusive585) wrote :

All set to test it once it's available. Says "waiting to build" currently. I'll check back in a few hours.

I'm currently building the x64 version, the i386 one is already published.

Dave if you didn't disable my repository you will notice that an update is available, so just update and check for the bug ;)

many thanks

Dave (xclusive585) wrote :

Another successful build. I'm not seeing the bug with this one either. :-)

I'll be waiting for your next test.

Hello,

Have many thanks for all your energies going into it. The patches are listed in
http://anonscm.debian.org/gitweb/?p=pkg-boinc/boinc.git;a=blob;f=debian/patches/series
and of those my personal hunch is the have a second look at the
app_ipc_uninitialised.patch, where I had improved (so I thought) initialisations of variables. Had you tried that one, yet? I have changed the order of lines in the init file ... not thinking that this makes much of difference .. but I may be wrong.

If you have located the issue - fine. If not I suggest to leave it.

Best,

Steffen

-------- Original-Nachricht --------
> Datum: Sat, 05 May 2012 15:37:27 -0000
> Von: Dave <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> Another successful build. I'm not seeing the bug with this one either.
> :-)
>
> I'll be waiting for your next test.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions

Hi Steffen et all, I'm building I think the latest build, I have enabled almos every patch but not app_ipc_uninitialised.patch so based on Steffen comment we will find the patch that causes this problem :)

Dave (xclusive585) wrote :

Sounds good, I'll let you know.

Dave (xclusive585) wrote :

This seems fine as well.

So far so good.

And I just read Dave's reply that this would be just fine, indeed.
If it is not the order of lines, then my hunch is that it is the size of the buffer that I had increased, which may create larger (too large) files for the client to read.

I will split that patch in two halves - buffer and reorder - so we can test it all more easily. But I would do so for 7.0.28 and ... maybe even only through upstream and not within Debian/Ubuntu.

Steffen

-------- Original-Nachricht --------
> Datum: Sun, 06 May 2012 00:13:12 -0000
> Von: LocutusOfBorg <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> Hi Steffen et all, I'm building I think the latest build, I have enabled
> almos every patch but not app_ipc_uninitialised.patch so based on
> Steffen comment we will find the patch that causes this problem :)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions

Hi Dave and Steffen, based on your latest comment I'm building just now the (I hope) latest version, which includes the app_ipc_uninitialised.patch

I wait for your feedback. :)

thanks

Dave (xclusive585) wrote :

another good one.....

Dave (xclusive585) wrote :

I got on another Ubutu 12.04 box just to try out that standard repository version (7.0.24) with seti@home- to verify it's still broke. It is. And what's surprising is that box worked with 7.0.24/s@h, during daily builds, but not anymore.

Dave (xclusive585) wrote :

@ Locutus....

If this ppa has the patch Steffen thought was breaking it, we made need to re-think things a little...

What are the differences, if any, between THIS ppa 7.0.26 that works (with that patch included), and the very first one I tried that was broke?

Dave (xclusive585) wrote :

I just double checked on two machines to be sure your current 7.0.26 works for s@h, it does. Even on my older p4 that errored when tested with the 7.0.24 today, works great with this ppa 7.0.26! :-)

hope it helps.

Thanks Dave for your comment and your help, I'm building another shot, there are only for patch left to check.

So the problem is this: in ubuntu/debian we have added some patch to improve boinc stability, one of those patch causes this problem.

The first build you tryed was with every patch included, just an updated version (.24 was your version, .26 was the version in my ppa)

What I have done is to package .26 without patch and include some of them to find the wrong patch.

So the first build was "clean", the second one had 10 patch, the third one other 10 patch and so on.

This build that is coming is almost the same as the official build, just without 10 patch.

So there are two scenarios now:
1) you will encounter the problem and so we have found the patch
2) the wrong patch is in the 10 patch left to check.

In my opinion this build won't work as expected.

Daniel Manrique (roadmr) on 2012-05-10
Changed in boinc (Ubuntu):
importance: Undecided → Medium
80 comments hidden view all 160 comments

Hi Steffen, I repeat, your latest boinc doesn't build from source. https://launchpadlibrarian.net/104761349/buildlog.txt.gz

I'll try to branch it and build without this patch.

Dave (xclusive585) wrote :

Locutus, I see your changing packages around in that PPA, is there going to be that "proven to work" 7.0.27 in a ppa, because people are already coming back on my end about the bug being back, with the version currently in ppa:costamagnagianfranco/boinc

Dave (xclusive585) wrote :

(Unfortunately I have to go to make some money, so) I won't be able to test anything out right now.

Thomas Ward (teward) wrote :

I'd recommend you pull something out of my book in terms of your PPA(s): create a staging PPA for you to test your builds in, and then when you have a working one, you upload to the deployment PPA (the PPA the public should use).

I find it useful for when you are constantly messing with packages to make em work. I do this for other projects in which I do packaging for them, and it prevents a lot of hassle when the community relies on a specific PPA.

Just my two cents on that.

Also, once the latest push to Debian gets accepted and published in Debian, I believe I have some of the MOTUs support to sync that to Quantal with the FTBFS errors, and then backport that to Precise where it does work (Locutus, please confirm if it builds in Precise).

I know this, but what I'm doing is only to package 7.0.27 from Steffen's git, since it has disabled the patch causing this bug, so this update shouldn't trigger this bug anymore, it should be working and Steffen has confirmed this too.

So I'm just updating the package in my ppa because this update fixes so many GPU bugs and doesn't trigger this bug.

If somebody has this bug again the cause should be looked in another part.

Dave please when you can confirm that this build 7.0.27+dfsg-0~829~precise1 hasn't this bug.

I'm building for oneiric, precise and quantal, so it can be synced whenever you want.

And BTW the 7.0.27 hasn't been published right now, so any people experiencing this bug has a different bug.

Ben Giacalone (benjg011) wrote :

Dave,

I did what you recommended below and installed Boinc. After a couple of hours Seti@home finally connected and I got the following message:

Seti@home: Notice from Server

Your app_info.xml file doesn’t have a usable version of Seti@home enhanced

Thanks,

Ben

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Dave
Sent: Thursday, May 10, 2012 10:25 AM
To: <email address hidden>
Subject: [Bug 991179] Re: 7.0.24 "computation error" bug

Ben I'm wondering if it's possible you ended up with double files or just a borked install..

you should "apt-get remove boinc", "apt-get autoremove", and then install boinc again. You are the first to have this error with that package you are using.

--

You received this bug notification because you are subscribed to the bug report.

 <https://bugs.launchpad.net/bugs/991179> https://bugs.launchpad.net/bugs/991179

Title:

  7.0.24 "computation error" bug

Status in “boinc” package in Ubuntu:

  Confirmed

Bug description:

  Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a

  known bug which affects users with various hardware running Ubuntu

  12.04. The bug makes the boinc software unable to process any work-

  units.

  This is a known bug by a growing group of S@H Boinc users running

  Ubuntu 12.04 and other Debain variants.

  As soon as there is a version out which overcomes this bug, the

  repository package may want to be changed.

  Thanks.

  [edit] it seems this bug is only caused by the repository installs of Boinc. When one installs Boinc from the Berkeley website the issue does not exist.

  Also, the bug only seems to exist for seti@home users, apparently all other projects are unaffected? (I'm now curious it may affect "Quake Catcher Network")

To manage notifications about this bug go to:

 <https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions

Dave (xclusive585) wrote :

@ Locutus.

I can gladly confirm "7.0.27+dfsg-0~829~precise1" does not have our bug. I am running some units right now (i386)

:-)

I'll let you know about am64, but we already know our bug is not architecture dependent.

Boinc 7.0.27+dfsg-0 building in quantal.
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

So I think we are ready for a SRU just now.

Thomas Ward (teward) wrote :

The MOTU SRU team isn't going to support an SRU in this case (because of a version change, according to the MOTUs I spoke to yesterday). They are more likely to be willing to support a sync to Quantal for the Debian version of the package, and then a backport of that to Precise (the repository that will contain the updated BOINC is therefore precise-backports).

On May 11, 2012, at 5:50 AM, LocutusOfBorg <email address hidden> wrote:

> Boinc 7.0.27+dfsg-0 building in quantal.
> https://code.launchpad.net/~costamagnagianfranco/+archive/boinc
>
> So I think we are ready for a SRU just now.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> Status in “boinc” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
> known bug which affects users with various hardware running Ubuntu
> 12.04. The bug makes the boinc software unable to process any work-
> units.
>
> This is a known bug by a growing group of S@H Boinc users running
> Ubuntu 12.04 and other Debain variants.
>
> As soon as there is a version out which overcomes this bug, the
> repository package may want to be changed.
>
> Thanks.
>
> [edit] it seems this bug is only caused by the repository installs of Boinc. When one installs Boinc from the Berkeley website the issue does not exist.
> Also, the bug only seems to exist for seti@home users, apparently all other projects are unaffected? (I'm now curious it may affect "Quake Catcher Network")
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions

Dave (xclusive585) wrote :

Isn't this last build the debian package? Or does it not count because it's GIT?

At least if we get the package in Quantal, its a start I guess.

But don't be surprised if people keep saying things like:
"I encountered the bug and was quite unhappy with it... I gave up on Ubuntu/Kubuntu and moved on over to OpenSUSE"
(actual Boinc user's advice to another)

Sorry for that, I have not the power of Master Of The Universe, so I can't help for that.

The only thing you can do is to help in downloading the official package or use my ppa
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

I'll try to keep it up to date and bug free.

Dave (xclusive585) wrote :

It's not your fault locutus. You have been more than helpful, and we figured out an issue. There is nothing more you can do. :-)

I just get mad at those flamers on my end of the net. I'm defensive of Ubuntu vs other distros because I feel it has the most support... Anyways I'll keep the Ubuntu users over on my boards updated with your boinc ppa Locutus.

Thanks Locutus, Steffen, and Thomas. All your efforts are very much appreciated.

I tryed to be menber of bug squad, but I wasn't ready. now I'm learning a little bit, and one day, maybe after my master degree I'll try to apply again for bugquad and maybe for the official boinc ppa here... But now I have to do my master thesis and the time is always a problem :) I need a 25 hours day ;)

regards, Hope they'll fix the problem soon.

Thomas Ward (teward) wrote :

Dave: no problem, happy to help where I can.

All: I'm testing whether the package would build with a direct sync from Debian, and then am testing the backport locally, i'll help get the sync request and backport requests done for ya.

Thomas Ward (teward) wrote :

Sync request from Debian Sid to Quantal for 7.0.27+dfsg-3 (in Debian): https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/998195

Once this goes through, i'll look into getting this backported to precise-backports

Dave (xclusive585) wrote :

And it's verified that package doesn't have the "bad" patch enabled?
On May 11, 2012 3:20 PM, "Thomas Ward" <email address hidden> wrote:

> Sync request from Debian Sid to Quantal for 7.0.27+dfsg-3 (in Debian):
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/998195
>
> Once this goes through, i'll look into getting this backported to
> precise-backports
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> Status in “boinc” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
> known bug which affects users with various hardware running Ubuntu
> 12.04. The bug makes the boinc software unable to process any work-
> units.
>
> This is a known bug by a growing group of S@H Boinc users running
> Ubuntu 12.04 and other Debain variants.
>
> As soon as there is a version out which overcomes this bug, the
> repository package may want to be changed.
>
> Thanks.
>
> [edit] it seems this bug is only caused by the repository installs of
> Boinc. When one installs Boinc from the Berkeley website the issue does not
> exist.
> Also, the bug only seems to exist for seti@home users, apparently all
> other projects are unaffected? (I'm now curious it may affect "Quake
> Catcher Network")
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions
>

Thomas Ward (teward) wrote :

Dave: that will need testing, but afaict the changelog for the version in Debian closes this bug here.

lemme get you an excerpt.

(also, assigned to myself since i'm working on the sync request and the backport, which will ultimately close this bug)

debian/changelog for the version being synced to quantal (notice where it closes this bug, which is number 991179):

boinc (7.0.27+dfsg-3) unstable; urgency=low

  * Now truly reconstituting compatibility with SETI
    (Closes: #672328, lp: #991179).
  * builds with gcc 4.7 (Closes: #671999)
    Thanks to Matthias Klose for his patch, had sadly only seen it after
    I patched it myself :o/ The NMU of his should not kick in because
    of the SETI incompatibility.

 -- Steffen Moeller <email address hidden> Thu, 10 May 2012 10:59:30 +0200

Changed in boinc (Ubuntu):
assignee: LocutusOfBorg (costamagnagianfranco) → Thomas Ward (trekcaptainusa-tw)
Thomas Ward (teward) wrote :

bah, IRC lingo.

"afaict" should be "as far as i can tell"

Thomas Ward (teward) on 2012-05-11
Changed in boinc (Ubuntu):
status: Confirmed → In Progress

Hello, yes, and I had one report from Debian in the meantime, too, who had already confirmed this version to be fine with him (and SETI). Cheers, Steffen

> debian/changelog for the version being synced to quantal (notice where
> it closes this bug, which is number 991179):
>
> boinc (7.0.27+dfsg-3) unstable; urgency=low
>
> * Now truly reconstituting compatibility with SETI
> (Closes: #672328, lp: #991179).

Dave (xclusive585) wrote :

Hi guys. Thanks for the verify Steffen.

Thomas if you update here when a repository change happens for Quantal: I have got my server's virtual machines up and running today (since my server's change to 12.04) and I installed a Qualtal-desktop-64, so I can test the updated quantal-64 boinc when it comes around.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.27+dfsg-3

---------------
boinc (7.0.27+dfsg-3) unstable; urgency=low

  * Now truly reconstituting compatibility with SETI
    (Closes: #672328, lp: #991179).
  * builds with gcc 4.7 (Closes: #671999)
    Thanks to Matthias Klose for his patch, had sadly only seen it after
    I patched it myself :o/ The NMU of his should not kick in because
    of the SETI incompatibility.

 -- Steffen Moeller <email address hidden> Thu, 10 May 2012 10:59:30 +0200

Changed in boinc (Ubuntu):
status: In Progress → Fix Released
Thomas Ward (teward) wrote :

the fix in Quantal is released, the package will be in Quantal as soon as the synced version is published in the repos (should be very soon).

I'll get to work on backporting this to Precise, so the people who are having this problem in Precise can have a (fixed) version. But someone should check to see whether that patch that had to be removed *is* actually removed in Quantal (I didn't check, since i've been busy fixing my system)h

Dave (xclusive585) wrote :

Thomas I'll check it out. Is there a link or somewhere I can see the repository package status, like when I was checking Locutus' PPA waiting for builds to finish?

Thomas Ward (teward) wrote :

I confirmed with MOTUs and the archives that the version from Debian is imported already.

You can just install it in Quantal.

The "Bad" patch is in the package, so the package'll need ubuntu-only changes, I'll work with the MOTUs on that, but I'll need a summary of why that patch is bad (i dont have the time to search through 144 comments :P)

Thomas Ward (teward) wrote :

Check, though, to see if the bad patch is still a troublemaker, if it is, file a bug specific for that patch's removal with the summary, i think i can get the ubuntu-only changes to be sponsored if there's a linked bug.

Thomas Ward (teward) wrote :

Actually, on further checks, the package correctly builds in Quantal with the trouble-patch included.

LocutusOfBorg: Do me a favor and pull a copy of the package as it exists in Quantal, and see if it builds. Since it (so far) builds correctly with the 'parse_issues.patch' patch you referenced in the sync request as being a troublemaker.

Dave (xclusive585) wrote :

well whichever patches are enabled or not, I am not getting the computation error in Quantal-64 (virtual box). Crunching away at a unit right now.

I can gladly report. :-)

Hello,

-------- Original-Nachricht --------
> Datum: Sun, 13 May 2012 16:54:19 -0000
> Von: Thomas Ward <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 991179] Re: 7.0.24 "computation error" bug

> I confirmed with MOTUs and the archives that the version from Debian is
> imported already.
>
> You can just install it in Quantal.
>
> The "Bad" patch is in the package,
No, it is not.

> so the package'll need ubuntu-only
> changes,
This should not be required. And whenever there happen to be additional requirements for Ubuntu, please forward them to our shared git archive so they go through Debian.

> I'll work with the MOTUs on that, but I'll need a summary of
> why that patch is bad (i dont have the time to search through 144
> comments :P)

:o)

I consider the issue closed. Something we should now address together is the backporting to releases older than Precise with the notify 0.5 library (now at 0.7) . I will contact Daniel and Locutus about it.

Cheers,

Steffen

Thomas Ward (teward) wrote :

Steffen, the patch reported to have the problem, the 'parse_issues.patch' exists in the Quantal package, and the Debian package (I dissected the package myself, its still there).

Backporting to older than Precise may be a tiny bit difficult, but before I help out wiht the backports to Oneiric and earlier, it has to be backported to Precise.

I'm working on the paperwork now, but i have to finish fixing my dev environment. Once I fix my development environment, i'll test a no-changes backport to Precise, and then from there work my way onto Oneiric. Natty is going out when Quantal gets released, so I will look into backporting to that, but the backport priority order on that for me is as follows:

1) Precise
2) Oneiric
3) Natty
4) Lucid

Dave (xclusive585) wrote :

Just for clarification. I believe that patch Thomas refers to was believed
to be causing issues building the package for Ubuntu.
The patch found to cause the computation error was
moreinformativeappstart.patch or something like that.
On May 13, 2012 3:25 PM, "Thomas Ward" <email address hidden> wrote:

> Steffen, the patch reported to have the problem, the
> 'parse_issues.patch' exists in the Quantal package, and the Debian
> package (I dissected the package myself, its still there).
>
> Backporting to older than Precise may be a tiny bit difficult, but
> before I help out wiht the backports to Oneiric and earlier, it has to
> be backported to Precise.
>
> I'm working on the paperwork now, but i have to finish fixing my dev
> environment. Once I fix my development environment, i'll test a no-
> changes backport to Precise, and then from there work my way onto
> Oneiric. Natty is going out when Quantal gets released, so I will look
> into backporting to that, but the backport priority order on that for me
> is as follows:
>
> 1) Precise
> 2) Oneiric
> 3) Natty
> 4) Lucid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> Status in “boinc” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
> known bug which affects users with various hardware running Ubuntu
> 12.04. The bug makes the boinc software unable to process any work-
> units.
>
> This is a known bug by a growing group of S@H Boinc users running
> Ubuntu 12.04 and other Debain variants.
>
> As soon as there is a version out which overcomes this bug, the
> repository package may want to be changed.
>
> Thanks.
>
> [edit] it seems this bug is only caused by the repository installs of
> Boinc. When one installs Boinc from the Berkeley website the issue does not
> exist.
> Also, the bug only seems to exist for seti@home users, apparently all
> other projects are unaffected? (I'm now curious it may affect "Quake
> Catcher Network")
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions
>

Thomas Ward (teward) wrote :
Download full text (3.6 KiB)

That was the confusion, because Locutus referred to a different patch.

On May 13, 2012, at 3:31 PM, Dave <email address hidden> wrote:

> Just for clarification. I believe that patch Thomas refers to was believed
> to be causing issues building the package for Ubuntu.
> The patch found to cause the computation error was
> moreinformativeappstart.patch or something like that.
> On May 13, 2012 3:25 PM, "Thomas Ward" <email address hidden> wrote:
>
>> Steffen, the patch reported to have the problem, the
>> 'parse_issues.patch' exists in the Quantal package, and the Debian
>> package (I dissected the package myself, its still there).
>>
>> Backporting to older than Precise may be a tiny bit difficult, but
>> before I help out wiht the backports to Oneiric and earlier, it has to
>> be backported to Precise.
>>
>> I'm working on the paperwork now, but i have to finish fixing my dev
>> environment. Once I fix my development environment, i'll test a no-
>> changes backport to Precise, and then from there work my way onto
>> Oneiric. Natty is going out when Quantal gets released, so I will look
>> into backporting to that, but the backport priority order on that for me
>> is as follows:
>>
>> 1) Precise
>> 2) Oneiric
>> 3) Natty
>> 4) Lucid
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/991179
>>
>> Title:
>> 7.0.24 "computation error" bug
>>
>> Status in “boinc” package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
>> known bug which affects users with various hardware running Ubuntu
>> 12.04. The bug makes the boinc software unable to process any work-
>> units.
>>
>> This is a known bug by a growing group of S@H Boinc users running
>> Ubuntu 12.04 and other Debain variants.
>>
>> As soon as there is a version out which overcomes this bug, the
>> repository package may want to be changed.
>>
>> Thanks.
>>
>> [edit] it seems this bug is only caused by the repository installs of
>> Boinc. When one installs Boinc from the Berkeley website the issue does not
>> exist.
>> Also, the bug only seems to exist for seti@home users, apparently all
>> other projects are unaffected? (I'm now curious it may affect "Quake
>> Catcher Network")
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/991179
>
> Title:
> 7.0.24 "computation error" bug
>
> Status in “boinc” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
> known bug which affects users with various hardware running Ubuntu
> 12.04. The bug makes the boinc software unable to process any work-
> units.
>
> This is a known bug by a growing group of S@H Boinc users running
> Ubuntu 12.04 and other Debain variants.
>
> As soon as there is a version out which overcomes this bug, the
> repository package may want to be changed.
>
> Thanks.
>
...

Read more...

Download full text (4.6 KiB)

Ah! I need to invest the github repository, I presume. Locutus checks out from there and apparently some adjustment of mine with the latest updates of BOINC has not made it back into the remote git repository....or something like it. What has found entry to the Debian archive comes from my local repository .. and that apparently just builds.

Cheers,

Steffen

-------- Original-Nachricht --------
> Datum: Sun, 13 May 2012 20:45:54 -0000
> Von: Thomas Ward <email address hidden>
> An: <email address hidden>
> Betreff: Re: [Bug 991179] Re: 7.0.24 "computation error" bug

> That was the confusion, because Locutus referred to a different patch.
>
>
> On May 13, 2012, at 3:31 PM, Dave <email address hidden> wrote:
>
> > Just for clarification. I believe that patch Thomas refers to was
> believed
> > to be causing issues building the package for Ubuntu.
> > The patch found to cause the computation error was
> > moreinformativeappstart.patch or something like that.
> > On May 13, 2012 3:25 PM, "Thomas Ward" <email address hidden> wrote:
> >
> >> Steffen, the patch reported to have the problem, the
> >> 'parse_issues.patch' exists in the Quantal package, and the Debian
> >> package (I dissected the package myself, its still there).
> >>
> >> Backporting to older than Precise may be a tiny bit difficult, but
> >> before I help out wiht the backports to Oneiric and earlier, it has to
> >> be backported to Precise.
> >>
> >> I'm working on the paperwork now, but i have to finish fixing my dev
> >> environment. Once I fix my development environment, i'll test a no-
> >> changes backport to Precise, and then from there work my way onto
> >> Oneiric. Natty is going out when Quantal gets released, so I will look
> >> into backporting to that, but the backport priority order on that for
> me
> >> is as follows:
> >>
> >> 1) Precise
> >> 2) Oneiric
> >> 3) Natty
> >> 4) Lucid
> >>
> >> --
> >> You received this bug notification because you are subscribed to the
> bug
> >> report.
> >> https://bugs.launchpad.net/bugs/991179
> >>
> >> Title:
> >> 7.0.24 "computation error" bug
> >>
> >> Status in “boinc” package in Ubuntu:
> >> Fix Released
> >>
> >> Bug description:
> >> Hi. Repository versions 7.0.24, (I assume 7.0.25) and 7.0.26 have a
> >> known bug which affects users with various hardware running Ubuntu
> >> 12.04. The bug makes the boinc software unable to process any work-
> >> units.
> >>
> >> This is a known bug by a growing group of S@H Boinc users running
> >> Ubuntu 12.04 and other Debain variants.
> >>
> >> As soon as there is a version out which overcomes this bug, the
> >> repository package may want to be changed.
> >>
> >> Thanks.
> >>
> >> [edit] it seems this bug is only caused by the repository installs of
> >> Boinc. When one installs Boinc from the Berkeley website the issue does
> not
> >> exist.
> >> Also, the bug only seems to exist for seti@home users, apparently all
> >> other projects are unaffected? (I'm now curious it may affect "Quake
> >> Catcher Network")
> >>
> >> To manage notifications about this bug go to:
> >>
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/991179/+subscriptions
> >>
> >
> > --
>...

Read more...

Sorry for misunderstanding I wasn't so clear.
This bug is triggered (as Dave said) by moreinformative... patch.

This patch has been removed upstream so no changes "ubuntu1" is needed.

I personally DON'T want to diverge brances of boinc from debian to ubuntu, the collaboration between those distros is so close, so I don't think we have to diverge. Patches can be accepted into debian if we find a patch here and maybe sent upstream (I have close collaboration with upstream developers too)

The parse_error.patch has been a problem for me, since I build with a recipe boinc directly synced from steffen's git.

For some reason quilt doesn't apply on bzr server correctly.
I filed a bug against bzr https://bugs.launchpad.net/ubuntu/+source/bzr/+bug/998889

So to everybody I personally think boinc can be backported until oneiric with no changes at all. I built it for oneiric, precise and quantal, so for now earlier backports can wait a little bit.

Sorry for misunderstanding, I hope this post will clarify everything.

Changed in boinc (Debian):
status: Unknown → Fix Released
Dave (xclusive585) wrote :

I don't wanna beat a dead horse, but can someone update here if/when "apt-get install boinc" will install the working 7.0.27 in Precise?

thanks. :-)

Hi Dave a bug has been opened against backport [1]

please test ppa [2] and tell which of test case from bug 1000492 works :)

thanks

[1] https://bugs.launchpad.net/precise-backports/+bug/1000492
[2] https://launchpad.net/~micahg/+archive/sru-test/

Dave (xclusive585) wrote :

I've tested the SRU package from Micah's ppa: (7.0.24+dfsg-1ubuntu0.1~ubuntu12.04.1~ppa1 boinc package), and it seems fine.

I do not see the "computation error bug", or any other issues so far. (I'll mention again I do not use a GPU for crunching so I cannot speak for that)

I haven't had time to test your 7.0.28 Locutus. Ill get to it soon.

Dave (xclusive585) wrote :

I think it's funny that after we decide to get the fix into quantal for a backport to precise, then they go the route of an SRU fix. LOL

Dave (xclusive585) wrote :

Items marked with an [X] have been confirmed/tested.

* precise:
[X] Package builds without modification
[X ] boinc-manager installs cleanly and runs
[ ] boinc-dbg installs cleanly and runs ***seemed to install cleanly, unaware how to "run" it.
[ ] boinc-cgi-stripchart installs cleanly and runs ***seemed to install cleanly, unaware how to "run" it.
[X ] boinc-client installs cleanly and runs
[X ] boinc installs cleanly and runs
[ ] boinc-dev installs cleanly and runs ***seemed to install cleanly, unaware how to "run" it.
[ ] boinc-app-examples installs cleanly and runs ***seemed to install cleanly, unaware how to "run" it.
[ ] boinc-server-maker installs cleanly and runs ***seemed to install cleanly, unaware how to "run" it.
[ ] boinc-nvidia-cuda installs cleanly and runs
[ ] boinc-amd-opencl installs cleanly and runs

That's the best I can offer (in all my noobish glory)

Dave (xclusive585) on 2012-06-23
description: updated
Dave (xclusive585) on 2012-06-23
description: updated
description: updated
description: updated
description: updated

Hello Dave, or anyone else affected,

Accepted boinc into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/boinc/7.0.27+dfsg-5ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Displaying first 40 and last 40 comments. View all 160 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.