[DisplayPort] monitor shows black screen and "no input signal" after turning the monitor off and on manually

Bug #1313539 reported by palomino on 2014-04-28
This bug affects 53 people
Affects Status Importance Assigned to Milestone

Bug Description

I upgraded my xubuntu 13.10 to 14.04 recently. When I turn the monitor off and on, it only shows "no input signal". I have to restart x to bring it back to work. This never happened on 13.10.
Booting from xubuntu 14.04 livecd or a clean installion of xubuntu 14.04 gives the same problem.
I tried xset dpms force off/suspend/standby, the monitor works fine after resuming. So i suppose it's not dpms to blame.
My graphics card is Intel HD4600 and my monitor is Dell UP3214Q. The monitor is connected with a displayport cable.
Enable or disable the displayport 1.2 setting of the monitor doesn't change anything.
This issue does not occurs on another computer (with nVidia gfx card+Dell U2713HM+DVI cable)

Reinstall 13.10 solved the problem.
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.340
DistroRelease: Ubuntu 14.04
LiveMediaBuild: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
Package: xfce4-power-manager 1.2.0-3ubuntu4
PackageArchitecture: amd64
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Tags: trusty
Uname: Linux 3.13.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)

_MarkForUpload: True

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1313539/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Adam Lee (adam8157) on 2014-04-28
affects: ubuntu → gnome-settings-daemon (Ubuntu)
affects: gnome-settings-daemon (Ubuntu) → xfce4-power-manager (Ubuntu)
Jörg Frings-Fürst (jff-de) wrote :


we need some more information. From a terminal window please run:

sudo apport-collect 1313539

and then change the status of the bug to 'Confirmed'.


Changed in xfce4-power-manager (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated
Changed in xfce4-power-manager (Ubuntu):
status: Incomplete → Confirmed

Does this also happen while not logged in into a graphical user session (login greeter screen)?

palomino (palominoforever) wrote :

Login screen is not affected. It just happens after logging in.

affects: xfce4-power-manager (Ubuntu) → xfce4-settings (Ubuntu)

Following Straximus's lead (https://bugs.launchpad.net/mythbuntu/+bug/1308105/comments/18), I downgraded to the xfce4-settings package from Saucy. I left the machines allow all weekend long, and this morning the video on both machines worked as expected.

There is a regression bug between xfce4-settings 4.11.0-1ubuntu1 (saucy) and 4.11.2-1ubuntu2 (trusty).

Andy Bauer (knnniggett) wrote :

just tried xfce4-settings_4.11.3-0ubuntu1 recently made available on launchpad.
I can report that it does *not* solve this issue so I've rolled back again to xfce4-settings_4.11.0-1ubuntu1 and will continue to wait.

Is this report a duplicate of bug 1308105?

Steve (whatever-steve) wrote :

+1 - I'm also affected. I've been struggling with this since I've installed 14.04.


david6 (andrew-dowden) wrote :

This issue is possibly specific to DisplayPort, and not just a duplicate of bug #1308105.

I have just upgraded my monitor, and due to higher screen resolution, was forced to change from DVI (and a KVM) to DisplayPort.

The monitor will NOT sleep, and attempting to workaround by power-off/on (when unneeded) hits THIS bug. Setting the monitor to sleep (eg. powersave timer) also triggers THIS bug. The ONLY fix being to power cycle the PC.

However, the most common workaround I have found generally says: "Don't use DisplayPort, use DVI Dual-Link".

ALSO, if bug 1308105 is the cause, where is the fix? When will it arrive?

This appears to be a xfce4 regression bug, and specific to DisplayPort ..

david6, I suggest that you file a separate report on the Xfce bug tracker and help with resolving the issue. We may then remove the duplicate status of this report.


If you have a question specifically related to bug 1308105, please forward it accordingly.

John R (h-ubuntu-3) wrote :

This affects me too. I have a GTX 660 connected to a HP LP2475w monitor with Ubuntu Desktop 14.04 over a DisplayPort cable. Switch the monitor off and on again, and it says no signal. I have to reboot to get the machine back. This makes DisplayPort unusable. The problem goes away with a DVI cable. See my question here:


John R (h-ubuntu-3) wrote :

I think the duplicate status is wrong. I see this behaviour with a DisplayPort monitor (and no other screens connected) on standard Ubuntu Desktop 14.04 - I am not running Mythbuntu and I don't have xfce4-settings installed. See my post above.

summary: - monitor shows black screen and "no input signal" after turning the
- monitor off and on manually
+ [DisplayPort] monitor shows black screen and "no input signal" after
+ turning the monitor off and on manually
affects: xfce4-settings (Ubuntu) → ubuntu

This affects me too. I have a Radeon HD 7970/8970 OEM / R9 280X and the display is a Samsung U28D590D. Using an HDMI cable works perfectly. Using DisplayPort makes the display be disconnected when light-locker kicks in. I have to manually reconfigure the display until it shows me images again. I do notice that the display receives some sort of signal when I active my computer. But it shows no image and then goes back to idle.

I have a seconday monitor connected via DVI and that monitor keeps working perfectly.

Ben (9-admin-bm91-net) wrote :

This affects me too. I have a Radeon HD 7970/8970 OEM / R9 280X and the display is a Samsung U28D590D. The display disconnects on entering standby or when manually switched off. Siwtching manually to tty1 before switching the display on again solves this sometimes but is not reliable and not a usable solution.

Joe Wein (joewein-s) wrote :

Same problem here - running on a Core i3-2100T with Intel HD Graphics 2000 on 14.04 LTS. After switching off the monitor connected via DisplayPort only a reboot or a "sudo service lightdm restart" will get the screen back. It does not happen with DVI.

Bugs Bunny (bugsbunny-) wrote :

I also have the problem with the blank screen after monitor power cycle.
I'm running Xubuntu 14.04 on a Dell Optiplex 7010 with a Radeon HD 7570 VGA card that is attached to an LG ultrawide monitor (2560x1080) via DisplayPort, my desktop is XFCE4.

As this problem is very annoying I googled quite a bit and found this and that but nothing really helped.
I also stumbled upon the fact that there must be something weird with xfsettingsd: at least under some circumstances this daemon was said to be responsible for leaving a blank screen while crashing when the monitor gets switched on.

So I had a look whether this is also true in my situation but xfsettingsd was still happily running while the screen refused to come back on.

Don't know exactly why (maybe the anger at xfsettingsd to fail somewhere ;-)) but I just killed the running instance and was completely stumped to see the display turning on again ...

Even stranger is: I tried that several times - monitor switch off/on - and suddenly it wouldn't lead to a blank screen any more =:-O

Only thing that could happen then was a flickering display; but I could get rid of that by a forced dpms cycle (via xset dpms force off/on with a "sleep 1" in between).

When killed with a hangup (SIGHUP/1) xfsettingsd will normally be restarted automatically (by XFCE session handling I guess); if it doesn't you might recognize this by different window decorations or so, just start it manually then.

Hopefully my experiences help someone else, and maybe I have the time sometimes to dig into the problem ...

reddaly (reddaly) wrote :

I'm also experiencing this with an NVidia card and a Samsung s27a850 monitor. Can someone who is knowledgable about the software advise about what a fix would require?

For me, the main symptoms are
1) pressing power button on monitor causes Ubuntu to drop the screen from list of displays, rearranging my meticulously positioned windows.
2) monitor doesn't go to sleep when 2 other monitors go to sleep. It stays on indefinitely.

reddaly (reddaly) wrote :

Here is a related thread on the nvidia site. Some monitors do not respond to DisplayPort power management commands properly.


Mark O'Sullivan (mos182) wrote :

I had this both on Elementary OS and Xubuntu. I've got an AMD card and tried using additional drivers, so I selected one of the video drivers, in my case I picked the following option in eOS 'Using Video driver for the AMD graphics accelerators from fglrx-updates (proprietary)'.

This solved the problem of not being able to consistently use a secondary monitor which was using a display port. However I'm now not able to screenshot anything as it only shows the wallpaper now.

dhd (daniel-heiserer) wrote :

I experienced this problem when I switched from DVI to Display-port due to purchase of a a new monitor "LG 34UC97" running a resolution of 3440x1440.
- (K)Ubuntu version is 15.10
- drivers installed are "plain" out of the box, more or less beside the usual "apt-get upgrade".
- GPU is definetly a "nvidia geforce gtx 750 TI", however ubuntu reports it as a "GTX 970". My previous ubuntu (?) reported the card correctly.
- nvidia drivers are the one installed via kubuntu, namely 352.63. I tried to "handinstall" the latest from nvidia but that screwed up so I rolled back.

1) The problem occurs in the following cases:
a) user must be logged in. screen-log or not, does not matter.
b) display-port attached monitor is switched off (e.g. over night).
c) monitor is switched on but complains now about not receiving a display.

2) The problem does NOT occur when:
a) no user is logged in, e.g. only kdm/lightdm login screen is there.
b) on windows 10 ( I have installed parallel)

I assume the GPU switches off its "service" via display-port to the monitor once the monitor is switched off.
However it does not resume "service" when the monitor comes back again.

The problem cannot be so difficult to solve as it does not happen in 2b) and especially in 2a) mentioned before.

Are there any consolidated updates and solutions for the topic?


dhd (daniel-heiserer) wrote :

I just upgraded to Kubuntu 16.04 LTS.
Problem resolved - case closed.

Giuseppe D'Angelo (dangelo) wrote :

This is still open for Ubuntu 16.04, by the way (confirmed on a GTX 970).

Dane Mutters (dmutters) wrote :

I'm experiencing this issue in Ubuntu 16.04 on a Dell XPS 13 L321X. I'm connecting to a TV using a mini displayport to HDMI adapter. Ubuntu Settings > Display shows only the built-in laptop monitor.

Thanks for your work.

Dane Mutters (dmutters) wrote :

In case it's needed, here is my lspci output.

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation QS67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
03:00.0 USB controller: Fresco Logic FL1009 USB 3.0 Host Controller (rev 02)

Martin Blais (blaism) wrote :

I'm also experiencing this problem.
I had the following configuration:

MacbookPro 8,1 13" laptop (2011)
Dell UltraSharp U2715H LED monitor
Ubuntu 14.04
Mini-Displayport (computer) to Displayport (monitor) connector

I had those annoying 2-3 second unpredictable intermittent blanks, driving me crazy.

I used to have the problem with a Dell 24in monitor 2408WFP as well (same computer).
I figured it was something to do with the monitor and bought the new monitor (since we needed a second one anyhow).

But the problem persisted with the U2715H.

I figured it might be something to do with the computer (anecdotally it seemed to occur more often when it heats up, though I'm not certain).
I needed to change that old computer anyhow, so I bought an Intel NUC to replace the laptop.

New configuration:
Intel NUC NUC6i5SYH w/ 32GM of RAM
Dell UltraSharp U2715H LED monitor
Ubuntu 16.04
Mini-Displayport (computer) to Displayport (monitor) connector (same cable).

Lo and behold... same problem!

All that leaves is
- the cable, or
- the software.

Now I just got myself an HDMI to HDMI cable to the Intel NUC.
Just began testing. Hopefully the problem will be gone.

Happy to test again later if someone fixes the bug--contact me <email address hidden>

Kurt von Finck (mneptok) wrote :

This bug is still present in Xubuntu 16.04.1. It is not specific to nVidia or DisplayPort hardware.

If I power off the Sony TV to which the Xubuntu machine is connected via HDMI, when the TV is powered on there is no signal to the TV.

Restarting lightdm will return video output, but not audio.

I am using embedded Intel graphics. Output of lspci and xrandr are below:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080 60.00*+ 59.94 24.00 23.98
   1920x1080i 60.00 59.94
   1280x1024 60.02
   1280x720 60.00 59.94
   1024x768 60.00
   1440x480i 59.94
   800x600 60.32
   720x480 60.00 59.94
   720x480i 60.00 59.94
   640x480 60.00 59.94
HDMI2 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Santiago Velasco (sanxiago) wrote :

This is still present in Xubuntu 16.04.1 LTS

I am using something very similar to last poster, embededd intel graphics driver.

I have this motherboard: ASROCK Q9000

00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)

I am also connected to a Sony TV, but I am using the DVI output with HDMI to DVI cable.

Switching to the virtual terminal 1 with alt+f1 works and I can restart lightdm from there and everything works, once I do.

Dejan (dejan-rodiger) wrote :


When is this going to be fixed?
I am planning to by new monitor and new monitors only have displayport or hdmi. My laptop only has displayport and it will not work. BTW, I tested my laptop with several monitors through displayport and none is working.
Laptop: HP Zbook with Intel and NVidia graphics on Ubuntu 16.04 latest.
Using Intel graphics, since NVidia doesn't work correctly on boot (another bug...)

Dejan (dejan-rodiger) wrote :

If you are interested why DisplayPort doesn't work, but soon should ;-)

What I understood from presentation, is:
- Intel graphics card don't work with DisplayPort 1.2 and 4k monitors, because there is no bandwidth?
- So, I should make my NVidia card working on my laptop ... HP Zbook 15

Gary Wu (gary-wu) wrote :

I'm also having this issue on Xubuntu 16.04.1 LTS fresh install, Intel graphics.

xaxazak (xaxazak) wrote :

Also affects me on both Linux Mint XFCE 18 and Fresh install of Xubuntu Yakkety.

This prevents me using either my main monitor or my new graphics card.
As it's been hanging around a while and can cause major problems I think it should be assigned a high priority.

Thomas (moreaudio) wrote :

I have the same problem with Ubuntu 16.04.1. After turn of and turn on the monitor there is no signal from Ubuntu. My motherboard is Asus Z97M Anniversary with Intel Grafik onboard.

Jonas Moody (halcaeon) wrote :

Same issue with Ubuntu 16.04.1.

Same issue when installing Debian 8 (Jessie) 64-bit. I was able to install Debian by using Basic Graphics mode install, and installing proprietary NVIDIA drivers after basic graphics install.

Ubuntu goes straight to black screen, followed by a no signal message, monitor wake up, no signal message, repeat.

Asus PB287 monitor, NVIDIA 970 GPUs

eezacque (eezacque) wrote :

Same issue with Dell P2314H on Ubuntu 16.04.

Every now and then when the monitor falls into power saving mode, when I wake it up, it shows a 'entering power saving mode' and blacks out. When I try to access the monitor menu, it says there is no signal, and so does my connected Cintiq. Only a reboot helps.

Adel Abula (magebinary) wrote :
Download full text (5.2 KiB)

Same issue with Dell P4317Q GTX 960 with nvidia-370 drivers on Ubuntu 16.04.

One thing that I can be sure is, it is only happening when you connect the screen with display port. It happens with or without nvidia drivers. Looks like it is linux kernel or ubuntu desktop issues.

The screen blacks out occasionally and comes up on immediately. I hope below helps.

adel@Adel:~$ uname -a
Linux Adel 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
adel@Adel:~$ sudo lshw -short
H/W path Device Class Description
                                system Z170MX-Gaming 5 (To be filled by O.E.M.)
/0 bus Z170MX-Gaming 5
/0/0 memory 64KiB BIOS
/0/3d memory 128KiB L1 cache
/0/3e memory 128KiB L1 cache
/0/3f memory 1MiB L2 cache
/0/40 memory 8MiB L3 cache
/0/41 processor Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
/0/42 memory 32GiB System Memory
/0/42/0 memory 8GiB DIMM Synchronous 2133 MHz (0.5 ns)
/0/42/1 memory 8GiB DIMM Synchronous 2133 MHz (0.5 ns)
/0/42/2 memory 8GiB DIMM Synchronous 2133 MHz (0.5 ns)
/0/42/3 memory 8GiB DIMM Synchronous 2133 MHz (0.5 ns)
/0/100 bridge Sky Lake Host Bridge/DRAM Registers
/0/100/1 bridge Sky Lake PCIe Controller (x16)
/0/100/1/0 display GM206 [GeForce GTX 960]
/0/100/1/0.1 multimedia NVIDIA Corporation
/0/100/1.1 bridge Sky Lake PCIe Controller (x8)
/0/100/1.1/0 wlp2s0 network Wireless 7260
/0/100/14 bus Sunrise Point-H USB 3.0 xHCI Controller
/0/100/14/0 usb2 bus xHCI Host Controller
/0/100/14/0/5 bus USB5734
/0/100/14/0/5/3 bus USB3.0 Hub
/0/100/14/1 usb1 bus xHCI Host Controller
/0/100/14/1/5 bus USB2734
/0/100/14/1/5/2 multimedia Logitech Webcam C930e
/0/100/14/1/5/3 bus USB2.0 Hub
/0/100/14/1/5/3/2 input USB Receiver
/0/100/14/1/5/3/3 multimedia USB Multimedia Audio Device
/0/100/14/1/5/3/4 input MECH
/0/100/14/1/5/5 input Hub Controller
/0/100/14.2 generic Sunrise Point-H Thermal subsystem
/0/100/16 communication Sunrise Point-H CSME HECI #1
/0/100/17 storage Sunrise Point-H SATA controller [AHCI mode]
/0/100/1b bridge Sunrise Point-H PCI Root Port #17
/0/100/1b.2 bridge Sunrise Point-H PCI R...


Jelle De Loecker (skerit) wrote :

This still happens in Ubuntu 16.10.

I have an AMD Radeon RX480, using the open-source drivers.

I'm using three 4K LG screens.

Igor (theyozh) wrote :

Still happens in Ubuntu 16.04.2 with Intel graphics. Moreover, after using of DisplayPort 1.2 monitor won't get back even after PC restart.

tags: added: xenial yakkety
Andy McCallum (mandoonandy) wrote :

I have this problem on Ubuntu 17.04 using nvidia-381 driver on a Gigayte GTX 1060 card.

After screen blanking from a dpms command or the screensaver power saving, my HP Z27s (3840x2160 pixels) monitors only show black then "no signal".

Both monitors are connected via DisplayPort.

The monitors immediately turn on when I switch to a text console. Returning to the graphics display shows no signal.

santoshbs (santoshbs) wrote :

I am having the same issue in Lubuntu 17.04 using AMD Firepro W4100 GPU. Switching off the monitor (Dell) and switching it back on results in monitor displaying no DP signal. No key combinations or mouse movements help. The only way I can get it back is hard restart of the computer. Quite frustrating issue!

Éric (twiked) wrote :

On archlinux up-to-date (linux 4.12.12), I hit the same problem on the following hardware :

- AMD HD5850
- Benq GW2765HE (DP 1.2)

Solutions I've tried :

- Disabling/enabling DDC/CI
- Disabling/enabling DP Auto Switch (Benq-specific feature I suppose)
- Downgrading to DP 1.1 on the screen

What worked for me is to load the kernel with radeon.audio=0 as per :


chrisl (chrisl-r) wrote :

I just ran into this problem when finally moving from a VGA KVM to StarTech Displayport dual KVM. I switch between my win10 work laptop and my Ubuntu Mate 17.10 desktop with GeForce GTX 1060. I can start up Ubuntu and display is as expected, then switch to the laptop and all ok there too.

When I switch back to Ubuntu the display is highly distorted. I switch to command line and restart, but the display will not come back initially, I'll have to hard power the machine and start it again, then my display returns. This only happens when using Displayport KVM. When I tried switching back to the VGA KVM all normal again.

Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

description: VGA compatible controller
product: GP106 [GeForce GTX 1060 6GB]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:26 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

Xav Paice (xavpaice) wrote :

Seeing this on Bionic also, with 2 external screens and the built in laptop display.

       product: UX303UA
       vendor: ASUSTeK COMPUTER INC.
product: HD Graphics 520
configuration: driver=i915 latency=0

I've attached my Xorg.log if that's helpful.

On first boot, or after unplugging the external displays (e.g. to walk away), then reconnecting them, one or the other screen (or both) refuse to power on, even if I fiddle with the power button. Sometimes unplug/replug helps, mostly not. Eventually, after turning the screens on and off via xrandr/arandr, multiple times, I can usually get them both back on. I see the same thing if I connect two screens via a MST hub, or one screen there and one via the HDMI port. It's got that race condition feeling about it, in that I can do the same thing several times over and one of the times it works fine, but the others not.

Xav Paice (xavpaice) wrote :

It really didn't like me trying to attach the log file. Here's a pastebin: https://paste.ubuntu.com/p/mm4cwkGv4z/

Xav Paice (xavpaice) wrote :

FWIW, seeing this using any desktop environment, and at the login screen. Have tried, i3, awesomewm, Gnome and Unity.

Dane Mutters (dmutters) wrote :

Issue persists in 18.04. All OS upgrades installed as of June 25, 2018.

Dell XPS 13" L321X Mini Displayport -> HDMI adapter -> HDMI cable -> LG 43lx570h television.

Interestingly, I was able to get this setup to work on a different model of television, just a few days earlier. I don't currently have access to that TV, but when I get back to where it is, I'll do another test.

FiNeX (finex) wrote :

Hi, the same bug is reproducible even on Archlinux with Nvidia drivers 418.43-4, Linux Kernel 4.20.13, Xorg 1.20.4, NVIDIA GeForce GTX 660 and a couple of ACER BE270Ubmjjpprzx monitor connected using Display port with daisy chain.

Luis (luis-panadero) wrote :

This anoying bug keeps happening on Ubuntu 19.04 Disco. I have two DELL monitors connected via DisplayPort, and when I powerup my workstation with the screens off (via BIOS alarm), the screens are black. However, I verify that text consoles keep working. So I log in and run systemclt restart display-manager to restart the whole display subsystem, and keeep back the graphical logging screen.

Anyone have idea why this happens ? Reading the comments, looks that is years old and is independent from the GPU.

Benny (bennybenjaman) wrote :
Download full text (5.1 KiB)

I am using Debian Bullseye and I have been hunting down a resolution to my display port issue. The monitor connected to the display port turns off and on randomly. I replaced my dvi > display adapter as well as the monitor and graphics card. I am using KDE not xfce, and the issue started happening out of no where. I checked my .xsession-errors and whenever it happens I get this output:

kscreen: Requesting missing EDID for outputs (87, 88)
kscreen: Requesting missing EDID for outputs (87, 88)
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54814, resource id: 31458240, major code: 19 (DeleteProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54817, resource id: 31458240, major code: 19 (DeleteProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54818, resource id: 31458240, major code: 18 (ChangeProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54819, resource id: 31458240, major code: 19 (DeleteProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54820, resource id: 31458240, major code: 19 (DeleteProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54821, resource id: 31458240, major code: 19 (DeleteProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54822, resource id: 31458240, major code: 7 (ReparentWindow), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54823, resource id: 31458240, major code: 6 (ChangeSaveSet), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54824, resource id: 31458240, major code: 2 (ChangeWindowAttributes), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54825, resource id: 31458240, major code: 10 (UnmapWindow), minor code: 0

My dmesg look like this ever time it happens :

[ 1632.206060] radeon_dp_aux_transfer_native: 32 callbacks suppressed
[ 1681.619089] radeon_dp_aux_transfer_native: 116 callbacks suppressed
[ 1691.035261] radeon_dp_aux_transfer_native: 620 callbacks suppressed
[ 1751.408510] radeon_dp_aux_transfer_native: 116 callbacks suppressed
[ 1788.349239] radeon_dp_aux_transfer_native: 116 callbacks suppressed
[ 1867.122756] radeon_dp_aux_transfer_native: 116 callbacks suppressed
[ 1884.547082] radeon_dp_aux_transfer_native: 368 callbacks suppressed
[ 2173.600344] radeon_dp_aux_transfer_native: 620 callbacks suppressed
[ 2184.684924] radeon_dp_aux_transfer_native: 368 callbacks suppressed
[ 2240.267642] radeon_dp_aux_transfer_native: 242 callbacks suppressed
[ 2247.776015] radeon_dp_aux_transfer_native: 368 callbacks suppressed
[ 2256.276441] radeon_dp_aux_transfer_native: 426 callbacks suppressed
[ 2261.280666] radeon_dp_aux_transfer_native: 410 callbacks suppressed
[ 2266.304866] radeon_dp_aux_transfer_native: 578 callbacks suppressed
[ 2271.321115] radeon_dp_aux_transfer_native: 662 callbacks suppressed
[ 2307.710745] radeon_dp_aux_transfer_native: 74 callbacks suppressed
[ 2317.267183] radeon_dp_aux_transfer_native: 242 callbacks suppressed

my syslog lookg like this:
Dec 5 02...


Benny (bennybenjaman) wrote :

ATI HD6850 , 3 Dell monitors

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers