Minimum window size is too large

Bug #168648 reported by Bug Importer on 2007-05-18
230
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Jon A. Cruz
inkscape (Debian)
Fix Released
Unknown
inkscape (Fedora)
New
Undecided
Unassigned
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

The minimum size of the application window is too large to be practical. It
should at least be possible to fit four Inkscape windows on screen, but
ideally the window should not have a minimal size at all beyound the one
imposed by the operating system. (In my case this is 111 px x 30 px, but it
depends on system settings.)

JiHO (jiho) wrote :

Originator: NO

I guess it depends on your use case: I am perfectly happy with large
windows ;) In which situation would you want the window to be very small?
Did you try recent development builds? There was a change in the code that
allowed the main toolbars to be "folded", effectively reducing the minimum
window size. The tools toolbar iw still statis however, which implies that
the windows height cannot be very small yet.

Bug Importer (bug-importer) wrote :

There is no reason why Inkscape should restrict it's window size at all,
and it's very annoying that it does, because this makes it impossible to
for example compare two drawings side-by-side, or copying and pasting
objects around between several drawings. Part of the joy of having a large
monitor with lots of pixels is that you can fit more things on screen; when
an application forces a window size this ability is restricted. And I don't
even want to imagine what it must be like to run Inkscape on an older
display... would it even fit?

Bruno Santos (bsantos) wrote :

And with the introduction of one more tool icon (3d boxes) it became difficult to use in GNOME with the default panels, on screens with a vertical resolution of 800 or less (wide screen laptops using 1280x800 for example), unless the tool panel is removed from the main window. Maybe the tool panel could adjust to window size like the horizontal tool panels do and be used as a horizontal panel too.

nightrow (jb-benoit) wrote :

I just tried with the last svn version, and the conclusion are the following (on win XP SP2):
 - minimum height is bigger in svn than in 0.45.1
 - minimum width is smaller in svn than in 0.45.1
That's still 581*677 pixels.

Changed in inkscape:
importance: Low → Wishlist
status: New → Confirmed
LostInBrittany (lostinbrittany) wrote :

Currently using linux, 1024x768 screen resolution.

Last dev Ubuntu package, http://people.ubuntu.com/~bryce/Testing/inkscape-Gutsy/inkscape_0.46~svn20080104-0ubuntu1_i386.deb, and last snapshot autopackage, inkscape20080101rev16897AOCV.package, both have a minimal height too big for my computer. I have only a small Gnome panel at top and a small application bar at bottom, and Inskcape minimal size is really too big for my screen (see attached screenshot).

I think that 1024x768 is still a fairly used resolution, and I think that Inkscape new version should be able to run on it. For me, it's a critical problem, because using website stats, almost 50% of people still use that resolution, and not fixing it will make them unable to use Inskcape properly.

Toolbars size seems also too big. I've tried to use Setting/Misc to force small icons in toolbars but it doesn't work.

Changed in inkscape:
importance: Wishlist → High
yeKcim (yekcim) wrote :

Same problem than LostInBrittany with a wide screen 1280x800. An idea : a small theme like in gimp => smaller icons => smaller window

LostInBrittany (lostinbrittany) wrote :

A small theme would be a nice solution, it would allow using Inkscape with most of actual screen sizes.

I don't know if it needs a lot of coding (I've never tried to enter in Inkscape's code... yet), but if the only needed thing is to get small version of current icons, I can help.

I think it would be a true true for Inkscape 0.46 not to be able to run smoothly in 1024x768 and 1280x800, more than 50% of screens today use that resolution.

mahfiaz (mahfiaz) wrote :

It would be nice if the tools toolbar gets such a expand button like horizontal toolbars have, this is the one which helds vertical size back.

Horizontal size seems to be held by statusbar. Something from this list should simply disappear when window is resized. For example, the rightmost diappears first (zoom and x;y position, then description field and so on).

arckuk (1-launchpad-keat-co-uk) wrote :

I would like to back up the above comments. I use an Asus eee pc, which has an 800 x 480 screen, which means I cannot use inkscape effectively. OK, I'm not going to do large drawings, but the chance to polish illustrations on the move would be good.

ScislaC (scislac) on 2008-01-21
Changed in inkscape:
assignee: nobody → jon-joncruz

I would love to see this problem solved for 0.46, for me it's very important, as I use Inkscape every day.

I have never touched Inkscape code, but I'm a developper by trade and hobby. I have experience in C/C++, and I've played a bit with GTK+.

If somebody knowing Inkscape wants to mentor me and to guide me a little with the bug (for exemple, telling me what part of code I must look for, or how to build patches), I have some spare time and I propose myself to try to solve this bug.

So anybody wants to guide me?

Tom Davidson (tjd-mit) wrote :

Bug 186541 (now marked as a dupe of this one) notes that since 0.46, window maximization fails when screen resolution is 1280x768. Hiding the toolbox 'rescues' the situation... That user was on Ubuntu 7.10 with the Metacity wm. My rig is also Metacity--can anyone confirm this on another WM? If so, the maximization issue should be probably be milestoned as a regression...

I confirm it in Metacity too, I'll try to test with another WM.

On Jan 28, 2008 10:28 AM, Tom Davidson <email address hidden> wrote:

> Bug 186541 (now marked as a dupe of this one) notes that since 0.46,
> window maximization fails when screen resolution is 1280x768. Hiding the
> toolbox 'rescues' the situation... That user was on Ubuntu 7.10 with the
> Metacity wm. My rig is also Metacity--can anyone confirm this on another
> WM? If so, the maximization issue should be probably be milestoned as a
> regression...
>
> --
> Minimum window size is too large
> https://bugs.launchpad.net/bugs/168648
> You received this bug notification because you are a direct subscriber
> of the bug.
>

John Baer (j.baer) wrote :

Re-submitting from bug #170410

* - On my Ubuntu hardy running with an 1280x1024 lcd monitor Inkscape operates as expected.

On my Dell latitude running with an 1024x768 lcd screen is where I see the issues. The following pertains to this environment.

(Can not select options from the left panel)

The left panel issue occurs when the window is maximized and a left panel [button] is clicked. This actions results in inkscape window moving in a jerk like motion resulting in the wrong action occurring. For example, attempting to exit inkscape results in loading a new instance of the program.

John

mairin (mairin) wrote :

Hi,

Have you considered using smaller icons for the toolbars in order to save space? E.g., have you ever tried Gimp's smaller icon theme? It makes the gimp windows much smaller and easier to work with.

Jon A. Cruz (jon-joncruz) wrote :

GIMP uses fixed-size bitmap icons, Inkscape uses scalable SVG icons.

Under the "Misc" preferences there are now options to make the topmost and left toolbars use smaller sizes (as long as the theme is set with sizes you'd like). On OS X this gives me currently a minimum size of 573x546.

For extreme situations (such as the Asus Eee PC) the gtk rc file can be edited to have specific, smaller, icon sizes for Inkscape.

Jon A. Cruz (jon-joncruz) wrote :

Progress in this area was made for 0.46, and a conclusion should be in for the next version after.

Changed in inkscape:
status: Confirmed → In Progress
John Baer (j.baer) wrote :

Mairin,

Thanks for the suggestion. On a 1024x768 screen setting the icons to small resolved the bug. IMO a better solution is to make a system call to determine the available space (or size of the desktop) and then re-size Inkscape to fit. :)

In addition, upon first time startup some tweaks could be performed relative to icon size and such (ie. 1024x768 or less, smaller icons) and then save the settings. In my case I did not know icon size was a choice.

Thanks again ...

Shane R. Spencer (whardier) wrote :

I'm a big fan of support for smaller icons (are they svg to begin with?) and the possibility of a smaller or no minimum window size. Smaller toolbar icons may help with that.

The new layout in 0.46 is nice, but I need to hide my Gnome toolbars to use Inkscape on my main laptop running at 1024x768. That may not seem like an ideal graphics development setup - but its all I gots.

Shane R. Spencer (whardier) wrote :

Quick Fix!

Setting both "Make the commands toolbar icons smaller" and "Make the main toolbar icons smaller" under "Inkscape Preferences" -> "Misc" changes the minimum height to ~680 pixels depending on your GTK theme. I feel sheepish for overlooking this in the first place - In my situation Inkscape now operates cleanly under a 1024x768 Gnome session.

John Baer (j.baer) wrote :

The quick fix suggested by "whardier" on 2008-02-21 stopped working under 1024x768 Gnome session. On my Dell Laptop running Hardy Alpha5 (upgraded to Alpha6) changing the icon size as suggested does not seem to change anything.

The only way to operate the product in this environment is to set the upper and lower Gnome menu bars to "auto hide".

- Perhaps one solution would be to have left menu bar dockable. If this menu where moved to the top this issue may go away.

- If the icons where "svg" and scaling is not an issue they could grow/shrink to the available space.

- Last, provide smaller icons [16x16; 22x22; 24x24, 32x32, etc].

John Baer (j.baer) wrote :

Update to comment made on 2008-03-07.

Installed Kubuntu Hardy alpha6 on the Dell Laptop noted and inkscape loaded as desired.

john

John Baer (j.baer) wrote :

Update to comment made on 2008-03-09

If appears with the latest version under Ubuntu hardy alpha6 selecting small icons from the configuration menu has no effect on icon size. The result is inkscape on a 1024x768 screen is does not work.

john

Slythfox (slythfox) wrote :

Regarding j_baer's comment from 2008-03-16:
That is a "known" bug that was supposed to be fixed. I ran into a similar problem under Windows. (I'm sure a quick search should give you what bug number it was...)

tumolsky (tumolsky-gmail) wrote :

Hi!
I have the same problem - in ubuntu 8.04 with screen resolution 1024x768 it's too large and i can't maximize the inkscape window.

tumolsky (tumolsky-gmail) wrote :

Hi!
I have the same problem - in ubuntu 8.04 with screen resolution 1024x768 it's too large and i can't maximize the inkscape window.

Tina Russell (tinarussell) wrote :

1. Oddly, when I upgraded to Ubuntu 8.04 "Hardy Heron" a few weeks ago, this stopped happening. Now I can maximize the window on my 1280x768 screen all I want.

2. I've had the same problem as j_baer since before upgrading (and still have this problem): clicking "use small icons" in the preferences menu does nothing. Hunh...

Loell Anthony Erecre (loell) wrote :

same symptoms, i have 1024x768 , i still can't maximize in my hardy beta.

John Baer (j.baer) wrote :

Just Checking In

Loaded the Ubuntu RC and Inkscape and this issue is still present. Don't know what the priority may be or if it can be fixed before the release date, but this is a real problem for folks using a computer with a 1024x768 monitor.

Thanks ...

Luca Livraghi (luca91) wrote :

I confirm it. I have this bug in Ubuntu 8.04 rc1 with 1024x768 screen resolution.

Jon A. Cruz (jon-joncruz) wrote :

I've figured out that Ubuntu has a specific complication that is probably causing the main issue on 1024x768

221676 Preferences to make toolbars smaller have no effect on Ubuntu
https://bugs.launchpad.net/inkscape/+bug/221676

It's a different issue, and one that can be addressed in a much quicker timeframe.

MukiEX (mukisign) wrote :

Personally, I think shrinking Icons shouldn't be the only solution available (I don't mean as a stopgap, that's fine, I mean in the next version). This isn't an uncommon problem in desktop applications, and most employ one or both of two sollutions:

- Allow for a wider (resizable?) toolbox. e.g. 2-3 icons wide, so you can fit more icons in less vertical space.
- Allow for the toolbox to turn 90 degrees and be added to the "top" set of boxes. It's just as easy to access and then relies on horizontal resolution, which 99.99% of the time is higher than the vertical resolution.

Just a suggestion.

Tina Russell (tinarussell) wrote :
  • unnamed Edit (2.4 KiB, text/html; charset=ISO-8859-1)

Yeah, the toolbox needs to be more customizable in general. On my widescreen
tablet, I can either choose (a) landscape mode, where the window doesn't
maximize properly because of the low vertical resolution, and (b) portrait
mode, where the toolbox takes up entirely too much space with my limited
horizontal resolution ("widescreen" becomes a very skinny screen in portrait
mode, and a toolbox that insists on being arranged vertically adds to that
problem).

On GIMP, I can have the toolbox windows float and place them wherever I like
(though the configuration interface is very confusing and counterintuitive).
Inkscape relies entirely too much on sidebars, which waste space and make
the interface nearly unusable on a tablet computer in portrait mode, which
ought to be a well-supported environment for Inkscape.

It sounds like this might end up being a big coding project--cleaving up the
interface code to make it more modular--but it's necessary. (I guess I mean
that toolbox windows and such ought to be tear-off-able, resizable,
dockable, etc. It's the difference between productivity and endless
frustration, in some situations.)

On Thu, Jun 5, 2008 at 1:31 PM, MukiEX <email address hidden> wrote:

> Personally, I think shrinking Icons shouldn't be the only solution
> available (I don't mean as a stopgap, that's fine, I mean in the next
> version). This isn't an uncommon problem in desktop applications, and
> most employ one or both of two sollutions:
>
> - Allow for a wider (resizable?) toolbox. e.g. 2-3 icons wide, so you can
> fit more icons in less vertical space.
> - Allow for the toolbox to turn 90 degrees and be added to the "top" set of
> boxes. It's just as easy to access and then relies on horizontal resolution,
> which 99.99% of the time is higher than the vertical resolution.
>
> Just a suggestion.
>
> --
> Minimum window size is too large
> https://bugs.launchpad.net/bugs/168648
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Fibonacci (fibonacci-prower) wrote :

Using a 1024×768 resolution, I am also experiencing the problem of having a (vertically) huge window and being unable to maximize it. Either selecting smaller icons on the Inkscape prefs, or detaching the left toolbar by dragging it away from its original position, work to solve both issues.
I remember experiencing a similar problem under 0.43 - though the window was too wide instead of too high. Floating the toolbars would also work back then. I was told that it would be addressed after 0.44 was released, but apparently it still hasn't.

Jon A. Cruz (jon-joncruz) wrote :

Changed committed to SVN that switches the vertical tools toolbar to use a stock GtkToolbar, including the overflow "show more" arrow.

Minimum size is now 523x460

Changed in inkscape:
status: In Progress → Fix Released
sylvsteph (sylvsteph) wrote :

Smaller window for eeepc701 would be great.

wombalton (wombalton) wrote :

for me it worked to move the vertical toolbox out of the locked position on the left. now i was able to resize the main window as i wanted.

JadeMatrix (jadematrix) wrote :

IMHO, there are several options:

• Make the buttons smaller. Don't scale them, though - they're designed to work at a certain dpi, and look terrible if scaled up/down.
• 'More' button. AFAIK, already implemented.
• Consolidate similar tools into one button, similar to what Adobe products do. Click & hold to select the proper tool.
• Allow an optional double-rowed/columned setup for lower resolutions.

Luca Invernizzi (invernizzi) wrote :

I think that the options that JadeMatrix was mentioning (previous post, https://bugs.launchpad.net/inkscape/+bug/168648/comments/38) is really a necessity. As notebooks grow more powerful, it will be possible to use inkscape on them. Of course, you can undock the vertical toolbar to make inkscape window resize nicely (but the toolbar itself will not resize, anyway).
I had the same problem on Ubuntu 9.04, and the "small icons" trick that everybody is mentioning worked fine, but I've a 13.3 inches screen. What about 9 inches?

Vovanium (vovanium) wrote :

The size is too large for me too. It seems that tools bar struts window vertically so it doesn't fit to my 1024x768 screen and status line hides beyond bottom screen edge.

Jagash (lordjagash) wrote :

I have a more extreme condition with regards to small screen size myself; I use a Acer Aspire One which has a max screen size of 1024x600 runni9ng in Ubuntu. I would really appreciate if it was even remotely possible to use Inkscape, possibly with the main toolbars vertically to one side of the screen.

Niko Kiirala (kiirala) wrote :

In the upcoming 0.47 release Inkscape is usable on 1024x600 netbook display. From my experience with similar computer (eeepc 901), there are two nuisances, but that's it. First, if the drawing fits on the screen, it's too small to work with details. This is unavoidable with such a small screen, though. Second, picking some tools requires one extra click. Possible solutions to this have been given in comments above.

jtakalai (jutakala) wrote :

Same here as LostInBrittany, using Ubuntu and screen resolution 1280x800. Fairly annoying since many good things get cropped below the screen.

Suggestions:
* customizable toolbars (could remove some useless tools)
* scrollable toolbars (might be bad...)
* hide the extra that didn't fit behind a button (OpenOffice, bad solution)

Changed in inkscape (Debian):
status: Unknown → Fix Released
Changed in inkscape (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.