Italian translation updates for 0.92.x

Bug #1574561 reported by FirasH on 2016-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
FirasH

Bug Description

This bug will be used to upload Italian translation updates for Inkscape 0.92.x

FirasH (firashanife) wrote :
FirasH (firashanife) wrote :
FirasH (firashanife) on 2016-04-25
Changed in inkscape:
status: New → In Progress
assignee: nobody → FirasH (firashanife)
jazzynico (jazzynico) on 2016-05-01
tags: added: translation ui
jazzynico (jazzynico) wrote :

Translation updated rev. 14865.
Thanks!<email address hidden>

Changed in inkscape:
status: In Progress → Fix Committed
FirasH (firashanife) wrote :

Hello!
Here is the first part for string freeze, includes string updates.

Thanks!

jazzynico (jazzynico) wrote :

Hi,

Translation updated rev. 14943. Thanks!

I just noticed that the Keys and mouse reference string still leads to the 0.91 version, so I'm going to correct the PO template file soon.

FirasH (firashanife) wrote :

Some new stuff updated!
Thanks jazzynico!

FirasH (firashanife) wrote :

Uploaded some new translations, the last update can be skipped.

jazzynico (jazzynico) wrote :

Translation updated rev. 14958.
Thanks!

FirasH (firashanife) wrote :

This is a new update,
88% complete at the moment.

Thanks again jazzynico!

jazzynico (jazzynico) wrote :

Translation updated rev. 14967.
Thanks!

Changed in inkscape:
milestone: none → 0.92
importance: Undecided → Low
FirasH (firashanife) wrote :

jazzynico, I have a few question for you as I'm not confident of my current translation process and I'm not used to inkscape development:

1) I update it.po using "update_po_files.sh" provided in inkscape/po directory, is it correct to use it?
I used to build inkscape with ./configure, but now I'm using cmake (simply $cmake then $make, do not use $make install as the binary is in /bin directory).

2) How can I get UI translations updated according to my local it.po file?

I'm rebuilding everything but new strings added in it.po do not appear or, even worse, some already translated strings are not translated in .ui... I can build as many times as needed, I prefer to actually see how UI is set as I'm working on translations.

Thank in advance!

FirasH (firashanife) wrote :

I've rebuilt everything with make install this time and my local stuff is fine.

I noticed that:
1) Filter menu dialogs keep English UI except for drop-down menus
2) "Do geometric constructions" tool items are not all translated in Control bar.

Thanks again!

Just want to make sure everything is working correctly for 0.92!!

jazzynico (jazzynico) wrote :

Hi Firas,

> I update it.po using "update_po_files.sh" provided in inkscape/po directory, is it correct to use it?

It's correct, but it updates all the PO files, which takes some time.
You can also use a faster command: # msgmerge -Uv it.po inkscape.pot
As long as both commands update your file correctly, it's up to you to decide which one you prefer.

> How can I get UI translations updated according to my local it.po file?

With make install. You can also change the current directory to po/ and then run make install for a faster install.

> Filter menu dialogs keep English UI except for drop-down menus

Confirmed with the French translation. The internal extensions (Filters, Bitmap extensions...) are no longer translatable. Investigations in progress.

> "Do geometric constructions" tool items are not all translated in Control bar.

Some items don't even have names. I'm going to take a look.
Note that the feature is still experimental and won't be activated in 0.92.

Thanks for your findings!

jazzynico (jazzynico) wrote :

Follow-up report: Bug #1591230 "Internal extensions parameters are no longer translatable"
https://bugs.launchpad.net/inkscape/+bug/1591230

FirasH (firashanife) wrote :

I thought my computer was crazy :)

If I find more issues will report immediately! Thanks!

FirasH (firashanife) wrote :
FirasH (firashanife) wrote :

Noticed that with Measure tool, hovering over the start/ending point of the ruler the message in the status bar is not translated (Measure start, Shift+Click for position dialog). Is that an issue?

jazzynico (jazzynico) wrote :

Translation updated rev. 14993.

> the message in the status bar is not translated

There was an error with the gettext keyword that prevented the translations to be used. It's now fixed (as of 14992). That's great your translating *and* testing ;)

Thanks!

FirasH (firashanife) wrote :

Perfect!
I started working on LPE dialog, but the strings of "Angle bisector" effect are greyed out in .po file (like dropped translation).
Even after .po update strings are not available to translate.

FirasH (firashanife) wrote :

Just noticed another one:
"Paint Bucket" drop down options of "Filly by:" and "Close gaps:" in Tool Controls Bar are not translated in UI. Strings are present in translation file though.

Thanks!

FirasH (firashanife) wrote :

Mostly completed with some refinements here and there.
Still need to check LPE effects translations + new text features.

jazzynico (jazzynico) wrote :

Translation updated rev. 14996.
I'm going to investigate the issues you found a bit later.

Thanks!

jazzynico (jazzynico) wrote :

Paint bucket issues fixed rev. 14997.

jazzynico (jazzynico) wrote :

As for the LPE strings, the missing ones are all in experimental effects that will be disabled in 0.92. So there's no need to translate them for now. (skipped files are in po/POTFILES.skip)

FirasH (firashanife) wrote :

Hello!
Here are some new updates!

Thanks!

jazzynico (jazzynico) wrote :

Translation updated rev. 15009 (now 90%!).

Thanks!

FirasH (firashanife) wrote :

Minor bump with some refinements
Thanks!

jazzynico (jazzynico) wrote :

Translation updated in the trunk (rev. 15030) and 0.92.x branch (rev. 15026).
Thanks! (and sorry for the delay)

FirasH (firashanife) wrote :
FirasH (firashanife) wrote :

Here are some new updates, simply skip the last update!
Thanks!

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x rev. 15079 and lp:inkscape rev. 15115.
Thanks!

FirasH (firashanife) wrote :

Hello!
Uploaded some very small updates to keep in sync my local translation with current stable branch.
Probably going to complete some other strings before release.

jazzynico (jazzynico) wrote :

Hi Firas,

Translation updated in lp:inkscape/0.92.x (rev. 15125) and lp:inkscape (rev. 15178).
Thanks for the patch!

FirasH (firashanife) wrote :

Small refresh from inkscape.pot, preparing for next week translation work (hopefully).

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x (rev. 15141) and lp:inkscape (rev. 15196).
Thanks!

FirasH (firashanife) wrote :

In "Attach path" LPE effect dialog some strings are not available to translate:

1) "Angle:"
2) "Distance:"

As I noticed they were missing since last .po update from .pot, this time I guess there is something missing in source code.

Thanks in advance!

FirasH (firashanife) wrote :

Also "Rotate copies" LPE effect dialog strings are not available.

Jabiertxof (jabiertxof) wrote :

We need to run a script to regenerate po files. I forget move the effect copy_rotate from pot skip file to in file. Now is correct but not sure how to exec the script to regenerate all to commit.

Jabiertxof (jabiertxof) wrote :

Anyway Attach path dont have the strings angle and distance, are you sure is the lpe-attach-path.cpp file?
Cheers, Jabier.

Jabiertxof (jabiertxof) wrote :

Forget my last 2 comments. The code is now fixed but we cant execute an update of the po files because on string freeze. This strings go in english :( sorry!!!

FirasH (firashanife) wrote :

Ok thanks Jabiertxof, I was expecting a string freeze.
Anyway updated Italian translation of LPE effects.

When I build with cmake I am not able to change UI language. More precisely I can change language in the dropdown list, but UI keeps English as default on my openSUSE and FreeBSD machines (so my guess I'm missing a building option? NLS is ON).

Windows development builds work as expected and I use them to check translation.

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x (rev. 15162) and lp:inkscape (rev. 15228).
Thanks!

Note that the new cmake system doesn't provide rules to update the inkscape.pot file and thus it's quite difficult to reflect all the recent string changes in the trunk (for 0.92.x we can still use autotools that still works to update the pot).

FirasH (firashanife) wrote :

Thanks you jazzynico!

I have some new updates available, before release there will be probably a new update for Italian (during this weekend hopefully).

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x (rev. 15213) and lp:inkscape (rev. 15270).
Thanks!

FirasH (firashanife) wrote :

Hi jazzynico!

Revised some details of LPE translations and Mesh Gradients.

Thanks again

FirasH (firashanife) wrote :

Made some changes, simply skip last update.

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x (rev. 15230) and lp:inkscape (rev. 15287).
Thanks!

Now 92% translated (and 17 updates in 7 mouths -probably the most active translation report for 0.92!). Congratulations!

FirasH (firashanife) wrote :

Here are some new strings translated!

The biggest part is complete, some extensions are not translated at all as I prefer English to a wrong translation.

Thanks jazzynico!

jazzynico (jazzynico) wrote :

Translation updated in lp:inkscape/0.92.x (rev. 15233) and lp:inkscape (rev. 15299).
Thanks!

FirasH (firashanife) wrote :

Revising some string I noticed that "Close gaps:" spinbox in toolbar of "Paint Bucket" tool is not translated.

Can you confirm jazzynico?

jazzynico (jazzynico) wrote :

Confirmed, and fixed in lp:inkscape/0.92.x (rev. 15281) and lp:inkscape (rev. 15351).

For your information, the strings were correctly contextualized when initialized, but not at runtime (using contextualized arrays of strings is one of the trickiest thing with gettext).

Thanks for noticing the bug!

FirasH (firashanife) wrote :

Thanks, super fast!

Noticed some strings where missing for Windows installation.
Uploaded Italian update for that.

FirasH (firashanife) wrote :

Also here are some updates for Mesh tool, still not complete, but mostly done.

FirasH (firashanife) wrote :
jazzynico (jazzynico) wrote :

Translations updated in lp:inkscape/0.92.x (rev. 15282/15283) and lp:inkscape (rev. 15354/15355).
Thanks!

FirasH (firashanife) wrote :

This is the last update for 0.92 as there is no time left.

I have a question as there is a tooltip I don't know how to translate:
Select text tool, next to character size there is an icon with tooltip "Show style of outermost..."

What does that do?

jazzynico (jazzynico) wrote :

There's something in the release notes about the new text button: http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92#Line_Spacing

Translations updated in lp:inkscape/0.92.x (rev. 15295) and lp:inkscape (rev. 15377).
Thanks!

Hachmann (marenhachmann) wrote :

@Firas: As far as I understand, it sets / displays the styling that was made to the text object as a whole, in contrast to parts of it, that can have different styles.

(That's why I translated it as 'Display style of the whole text object', which I found easier to understand in German.)

FirasH (firashanife) wrote :

Thanks, that clears a lot the meaning of the tooltip!

Other (and last) question on translation:

In "Perspective/Envelope" Path Effect there is a checkbox "Overflow perspective", what does that do?
I'll submit a patch as soon as possible with those 2 translations.

Hachmann (marenhachmann) wrote :

I asked Jabier about it, but as I don't know too much about the maths behind it, I had difficulties translating even with the new knowledge. Maybe you know what to make of it?

This is what he wrote:
"The 4 knots of the perspective can have positions not in real
perspective if this option is checked."

FirasH (firashanife) wrote :

Thanks Maren!
I made a translation in the "middle" between English/Your suggestions/What I understood ;).

For 0.92 I think this is my very last update at 93%.

jazzynico (jazzynico) wrote :

Translations updated in lp:inkscape/0.92.x (rev. 15301) and lp:inkscape (rev. 15384).
Thanks!

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
FirasH (firashanife) wrote :

This is a small update for 0.92.2

Thanks!

Patrick Storz (ede123) wrote :

Hi FirasH,

thanks for the update!

Unfortunately it seems you used an outdated .po file:
 - "POT-Creation-Date: 2017-01-24 21:21+0100\n"

The current version is
 - "POT-Creation-Date: 2017-07-24 23:11+0200\n"

Do you think you could have a look at the new strings, too? (You'd need to be fast, but bryce promised to include translations up to 24 hours from now).

Did you see my mail to the inkscape-translator mailing list?
https://sourceforge.net/p/inkscape/mailman<email address hidden>/

One more note:
If you submit a translation at the very least re-open the bug report (otherwise it's hidden from the default listing).
Better yet drop a mail to inkscape-translator or create a merge request at our new GitLab repo.

Changed in inkscape:
status: Fix Released → In Progress
FirasH (firashanife) wrote :

Ok thanks I'll upload an update as soon as possible (this evening or tomorrow).

btw the new strings "stack up" and "stack down" should start with capital?

Patrick Storz (ede123) wrote :

In the German translation Maren and I even decided to leave the "stack" out completely as it's a concept which is used nowhere else in Inkscape and a user likely does not know what "stack" is supposed to mean.

At this point it's too late to change anything in 0.92.2 anyway, but this certainly can be revisited for master and (if there will be a 0.92.3) also in 0.92.x

FirasH (firashanife) wrote :

This is the updated file for 0.92.2

Thanks!

Patrick Storz (ede123) wrote :

Great, I created a MR for Bryce to merge:
https://gitlab.com/inkscape/inkscape/merge_requests/65/commits

Patrick Storz (ede123) on 2017-08-06
Changed in inkscape:
status: In Progress → Fix Committed
milestone: 0.92 → 0.92.2
jazzynico (jazzynico) on 2017-08-31
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.