Internal extensions parameters are no longer translatable

Bug #1591230 reported by jazzynico on 2016-06-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Patrick Storz

Bug Description

All the internal extensions' parameters now show in English, even when a translation is available.
External extensions are not affected.

Apparently a regression introduced rev. 14955 (http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14955). Reverting it fixes the issue.

jazzynico (jazzynico) wrote :

@Eduard, could you please take a look?
If it's too difficult to fix quickly, could you please revert you commit and plan further improvements for 0.93 (the regression is too important to be ignored IMHO)?
Thanks!

Patrick Storz (ede123) wrote :

Sure, I'll have a look at it.

I know what the cause of this issue is and I think a fix shouldn't be too hard (depending on how internal extensions use parameters).

Fixing would definitely be preferable since the previous behavior was pretty broken (each and every string was translated, regardless of whether it was marked for translation or not)

Patrick Storz (ede123) wrote :

I looked into it and it is *not* a regression.

The change in r14955 rather revealed, that most of the internal extensions were not properly written: Since they often don't use the underscored ("_") paramter/attribute names they are not translated anymore, which is absolutely correct.

It can be easily fixed by including the underscore in the XML representation of the extension where translated strings are desired. I'll get to that now.

Patrick Storz (ede123) wrote :

This patch adds the underscore where necessary.

Did I catch everything or do you still notice missing translations anywhere?

Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

> I looked into it and it is *not* a regression.

Well, from the user's point of view, it is... But I understand what you mean and agree.

Tests in progress. Thanks for the big patch!

jazzynico (jazzynico) wrote :

Tested successfully on Xubuntu 16.04, Inkscape trunk rev. 14977.
I didn't live test every extensions, but my sample worked perfectly and a grep confirmed there's no more gui_text without underscore.

Thanks again, it was a fast fix!

jazzynico (jazzynico) on 2016-06-11
Changed in inkscape:
status: In Progress → Fix Released
milestone: 0.92 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers