Cannot click on left-most indicator on panel if a systray icon appears

Bug #761409 reported by Bilal Akhtar
896
This bug affects 179 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Neil J. Patel
Baltix
In Progress
Undecided
Unassigned
unity (Ubuntu)
Fix Released
Medium
Unassigned
Natty
Fix Released
High
Unassigned

Bug Description

Using Unity 3.8.8

BUG IMPACT
Users that have set the systray whitelist to tray will not be able to click on indicators directly right of the systray.

TEST CASE
1. set systray whilte list to 'all' by this command:
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
2. restart unity
3. start an app that uses notification area.
4. test the indicators (like network indicator) cannot be opened.
5 now test the proposed unity and see the issue is not there.

BUG FIX
The children of the panel in the systray are now in a different data structure and the width is calculated differently.

PATCH
http://bazaar.launchpad.net/+branch/unity/3.0/revision/1211 is a backport from unity 4 found in
http://bazaar.launchpad.net/~njpatel/unity/fix-panel-tray/revision/1458 and
http://bazaar.launchpad.net/~njpatel/unity/fix-panel-tray/revision/1459

ORIGINAL DESCRIPTION
See attached screenshot. In the screenshot all the icons are indicators except for the Shutter icon (the left-most icon). I have added it to the whitelist. But when the shutter icon came on the panel, I can't click the mosque indicator icon in the area enclosed under the red rectangle in the image. If I want to access the mosque indicator, I have to click it's icon near its right edge (a very small area where it accepts clicks) or click on the Dropbox indicator or any other indicator on the right and move mouse leftwards.

This problem goes away if I remove Shutter from the whitelist. FYI Shutter is the only application which utilizes the old-style notification area on my system.

Related branches

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :
Didier Roche (didrocks)
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 3.8.10
David Barth (dbarth)
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Neil J. Patel (njpatel)
Changed in unity:
assignee: Gord Allott (gordallott) → Neil J. Patel (njpatel)
status: Triaged → Fix Committed
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
bitles (ubi-dzier) wrote :

Unity 3.8.10-0ubuntu2 haven't fixed this problem for me.

Revision history for this message
Jonathan Almeida (jonalmeida) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

Same for me.

On Sun, Apr 24, 2011 at 4:23 PM, bitles <email address hidden> wrote:

> Unity 3.8.10-0ubuntu2 haven't fixed this problem for me.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (764314).
> https://bugs.launchpad.net/bugs/761409
>
> Title:
> Cannot click on left-most indicator on panel if a non-indicator icon
> appears
>
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Using Unity 3.8.8
>
> See attached screenshot. In the screenshot all the icons are
> indicators except for the Shutter icon (the left-most icon). I have
> added it to the whitelist. But when the shutter icon came on the
> panel, I can't click the mosque indicator icon in the area enclosed
> under the red rectangle in the image. If I want to access the mosque
> indicator, I have to click it's icon near its right edge (a very small
> area where it accepts clicks) or click on the Dropbox indicator or any
> other indicator on the right and move mouse leftwards.
>
> This problem goes away if I remove Shutter from the whitelist. FYI
> Shutter is the only application which utilizes the old-style
> notification area on my system.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/761409/+subscribe
>

--
Jonathan

Revision history for this message
Jonathan Almeida (jonalmeida) wrote :

Bug isn't fixed for me either.

Revision history for this message
yemu (yemu) wrote : Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

same here, the problem persists in unity 3.8.10-0ubuntu2

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
milestone: 3.8.10 → 3.8.12
Didier Roche (didrocks)
Changed in unity:
milestone: 3.8.12 → 3.8.14
Revision history for this message
Jonathan Almeida (jonalmeida) wrote :

I'm not a programmer, but I think if it was possible to get the systray to load first, before the indicator icons. it might work. Since restarting unity temporarily fixes the bug (until next restart), maybe adding the command to restart unity (unity --replace) at start up would solve the problem.

Again, I'm not experienced in code.

Revision history for this message
Josh Burghandy (kid1000002000) wrote :

Definately not fixed yet

Changed in unity:
status: Triaged → New
Revision history for this message
Ivan S. (freeazy) wrote :

This bug also occurs to me, unity 3.8.12.

When I add Shutter on the whitelist, some indicators such as battery and network manager does not respond when clicked.

This occurs when changing the whitelist into ['all'].

so I tried tips #7, I add a shutter on the front of the sequence:
['Shutter', 'JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'scp-dbus-service']

Logout & Login, then everything becomes normal. I just tried it on Shutter not in other applications.

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

@Josh: Please don't change the status of the bug if you don't know what the statuses mean. You set the upstream bug task back to NEW, and now it can't be changed easily to Triaged as it needs someone with bug supervising privileges.

Changed in unity (Ubuntu):
status: Triaged → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Josh Burghandy (kid1000002000) wrote :

Sometimes I have trouble clicking on things outside of the indicator applet as well. This is especially apparent in firefox, where certain links simply can not be clicked. The effect can be duplicated in Chrome and some gtk confirmation dialogs ("Ok" can not be clicked, but "cancel" can, for instance). When this happens, keyboard functions act normal.

I am not sure if this is machine specific, and would be curious if this problem affects others on this bug report too.

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

@Josh: Your issue seems to be an invisible window issue. Is there a properly defined rectangle area where clicks aren't accepted? Try moving the window out of that region and see if it accepts clicks. In any case, it isn't related to this bug.

Revision history for this message
DJ (ke7mbz) wrote :

I'm having the same issue.

Natty Narwhal
Acer AS1410
Everything's up to date on my system.

It only occurs if there's a non-system applet on the left end of the tray. The indicator to the right of it is unresponsive to right or left click. Sometimes the next indicator to the right is semi-unresponsive, except on it's far right side. Also, sometimes all the indicators except for the power/logout menu become unresponsive. I can work around it by clicking a menu on the right and then hovering left or using the arrow key. The non-system applets have no affect on each other. It seems like it may get worse after a few suspend/resumes, but not sure.

I've heard the plan is to eliminate the systray, but there's many very frequently used apps that don't work right without it, eg, Skype and Truecrypt. I hope they choose to fix it instead. I've set the whitelist to 'all' because it's not that bad in Linux, like Windows where every program wants to put something there. What's needed is a simple GUI where you can see the list of apps that want to use the systray and choose which ones to allow. Overall, though I thing NN is a step in the right direction.

Revision history for this message
Martin Gontovnikas (gonto89) wrote :

I'm having this same issue when adding to the auto-start icons that have old tray icons.
However, if i do unity --reset, it gets fixed.

Also, i setted the property to whitelist every tray icon for the panel as i need them.

Regards

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

confirm that this occurs when changing the whitelist into ['all'].
hot workaround is:
$ unity --replace

Revision history for this message
DJ (ke7mbz) wrote :

Confirmed. I changed the whitelist entry back to default and did a unity --replace, and the problem went away.

Revision history for this message
Jonathan Almeida (jonalmeida) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

With the white list changed to ['All'] and using unity --replace the problem
goes away for that session only (i.e until next restart) Changing white
list back to default is not necessary in order to fix the bug.

On Thu, May 5, 2011 at 3:43 PM, David Jones <email address hidden>wrote:

> Confirmed. I changed the whitelist entry back to default and did a unity
> --replace, and the problem went away.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (764314).
> https://bugs.launchpad.net/bugs/761409
>
> Title:
> Cannot click on left-most indicator on panel if a non-indicator icon
> appears
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity” source package in Natty:
> Confirmed
>
> Bug description:
> Using Unity 3.8.8
>
> See attached screenshot. In the screenshot all the icons are
> indicators except for the Shutter icon (the left-most icon). I have
> added it to the whitelist. But when the shutter icon came on the
> panel, I can't click the mosque indicator icon in the area enclosed
> under the red rectangle in the image. If I want to access the mosque
> indicator, I have to click it's icon near its right edge (a very small
> area where it accepts clicks) or click on the Dropbox indicator or any
> other indicator on the right and move mouse leftwards.
>
> This problem goes away if I remove Shutter from the whitelist. FYI
> Shutter is the only application which utilizes the old-style
> notification area on my system.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/761409/+subscribe
>

--
Jonathan

Revision history for this message
DJ (ke7mbz) wrote : Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

It may be different on your system, but on mine I haven't had the problem since changing the whitelist entry back to default, and then manually adding apps I want to allow. I logged in and out, restarted the computer, whatever, and it's still good. If I change the whitelist back to 'all' the problem immediately comes back. Obviously, though, this is just a workaround and does not resolve the bug.

What's really needed is a simple gui that lets you decide what entries to allow. I may try creating one myself. It shouldn't be too complicated, providing this bug is resolved.

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

I have the same experience as #17. A unity --replace solves the problem, with or without changing the whitelist.

Revision history for this message
DJ (ke7mbz) wrote :

I still haven't had the problem since changing the whitelist back to default. However, the left most icon is only responsive from the center right. The left side of the icon doesn't respond when clicked. So this is clearly some kind of boundary issue, which for some reason is worsened by using 'all' in the whitelist. Why this is temporarily fixed by unity --replace I have no idea.

Revision history for this message
Alfred (alfred-egger) wrote :

I have the same problem here, a unity --replace helps, but this shouldn't be standard procedure.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

just FYI: such issue can't be reproduced in unity-2d.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

just FYI: such issue cant be reproduced in unity-2d.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

just FYI such issue can't be reproduced in unity-2d.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

just FYI: such issue can't be reproduced in unity2d.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

just FYI: such issue can't be reproduced in unity-2d.

Revision history for this message
Vitaliy Kulikov (slonua) wrote :

sorry pals for spam .. LP have issue Bug #783948

Revision history for this message
Hồng Quân (ng-hong-quan) wrote :

Still be there

Revision history for this message
Josh Burghandy (kid1000002000) wrote :
Revision history for this message
David Barth (dbarth) wrote :

Re-assign to Gord?

Changed in unity:
milestone: 3.8.14 → 3.8.16
Revision history for this message
AMTQ (amtq) wrote :

@Josh Burghandy: jop, does not work for me. Plus it is very bizarre that this list is displayed even though i did a whitelist all before...

Revision history for this message
Nick (soapduk) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

Strangely enough, for me the gnome panel applets/indicators work as they
should while the unity-panel indicators display this buggy behaviour.

Nick

On Tue, May 31, 2011 at 17:42, Josh Burghandy <email address hidden>wrote:

> Anybody tried this?
> http://ubuntuforums.org/showthread.php?t=1756700
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (775224).
> https://bugs.launchpad.net/bugs/761409
>
> Title:
> Cannot click on left-most indicator on panel if a non-indicator icon
> appears
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity” source package in Natty:
> Confirmed
>
> Bug description:
> Using Unity 3.8.8
>
> See attached screenshot. In the screenshot all the icons are
> indicators except for the Shutter icon (the left-most icon). I have
> added it to the whitelist. But when the shutter icon came on the
> panel, I can't click the mosque indicator icon in the area enclosed
> under the red rectangle in the image. If I want to access the mosque
> indicator, I have to click it's icon near its right edge (a very small
> area where it accepts clicks) or click on the Dropbox indicator or any
> other indicator on the right and move mouse leftwards.
>
> This problem goes away if I remove Shutter from the whitelist. FYI
> Shutter is the only application which utilizes the old-style
> notification area on my system.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/761409/+subscribe
>

Didier Roche (didrocks)
Changed in unity:
status: Confirmed → Triaged
Revision history for this message
markba (mark-baaijens) wrote : Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

This has everything to do with displaying non-indicator icons:
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

By setting the default setting:
gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray']"
..... the indicators are clickable again.

Revision history for this message
freezeloud (freezeloud) wrote :

Well, not all of them, most left indicator is still unclicable if there is few systray (nonidicator) icons as default whitelisted...
More systray (nonidicator) icons are there, more of the indicators is unclicable, whitelist 'all' just spread the nonresponsive area.

Again, it could be fixed by warkaround > unity --replace, but that's not so pleasant way

Revision history for this message
sierra indigo (sierraindigo-accounts) wrote :

with whitelist 'all' my indicators were unclickable for me except power button on far right but were scrubbable backwards from there.

for me this appears to have been solved when i removed screenlets daemon from the tray.

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

I have no screenlet daemon running and I see the problem. It is related with changing whitelist, definitely.

Revision history for this message
Chris (kyfho23) wrote :

Another couple of pieces of data from a non-programer: Adding "unity --replace" to Startup Applications seems to work for a while, but fails after a few hours. I've also tried "unity --replace &" in a minimized terminal (even with the Startup Applications hack going), and it seems to help, but after a few hours, I'm back to non-responsive indicators.Not sure what event causes them to stop responding. Note that I'm using Tilda, a Guake-style drop down terminal.

Also, my volume indicator has disappeared. Unsure if this is related.

Again, all this is just info for the bug hunters.

Revision history for this message
Le Galéanthrope (nyamiou) wrote :

I have the same problem, I have whitelisted all systray icon and I have 4 of them. I can't click on most of my indicator, I can click on those that on the right and if I click on the right side of the clock it work but if I click on the left side it don't. I can acces them by clicking on those on the right and moving my mouse hover the one on the left I want to access. It's not only left click because scrolling on sound indicator doesn't work either.

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

Even after unity --replace &, some (standard) icons are not clickable. For example, bluetooth. It is as ever accessible by clicking on the rightmost icons and then scrolling to it.
I have the whitelist set to "all" and the following icons showing (left to right):

Jupiter Tracker Touchpad-indicator bluetooth battery network-manager sound mail clock presence logout

after login just the logout one is clickable. After doing the unity --replace trick, all minus touchpad-indicator and bluetooth are clickable.

Revision history for this message
eZFlow (breakdevize) wrote :

i can confirm the same issue

Revision history for this message
Mikaela Suomalainen (mikaela) wrote :

I am having the same issues sometimes. When I have it I'll click shutdown button in the right corner and scroll to left. This way I can left click every indicator.

Revision history for this message
che--- (hcguersoy) wrote :

Has someone checked if this is fixed in the latest unity 3.8.16 ?

BTW, they've added a ppa for unity (ppa:ubuntu-desktop/ppa).

Revision history for this message
Sebastien Bacher (seb128) wrote :

> BTW, they've added a ppa for unity (ppa:ubuntu-desktop/ppa).

no, it's not a ppa for unity, it's the ubuntu-desktop packager who needed a place to put a test version before doing the SRU and who used his team ppa for it, it's not planning to be an official ppa for unity ;-)

Revision history for this message
gdi2k (gdi2k) wrote :

che: Yes I have tested the latest Unity from said PPA and the issue is still present.

Changed in unity (Ubuntu Natty):
status: Confirmed → In Progress
status: In Progress → Confirmed
Revision history for this message
non (federico-gazaba) wrote :

Hello people. I have the same problem. Not only with shutter, but audacious, monitor icon, printer icon, etc. It seems like this bug affect on any icon applet. The way to select it is to clic on the icon applet on the right and then move de mouse to the left this selection. Cant say if this bug affect on me from instalation, i noticed of that when use shutter. After that i probe with other aplications and confirm this behavior.

Sorry about my english.

Revision history for this message
AMTQ (amtq) wrote :

The bug seems to have disappeared with the update I downloaded this week, I'm running now 3.8.16-ubuntu1~natty ... all indicators are clickable again.

Revision history for this message
gdi2k (gdi2k) wrote :

The update made no difference for me. As soon as an old-style app indicator icon is added (KeePassX in my case), the left-most Ubuntu indicators are not clickable (Notes, Bluetooth, keyboard language selector, NetworkManager, Volume, Chat). The clock is clickable and I can drag across to the left to access the other icon's menus.

Revision history for this message
che--- (hcguersoy) wrote :

I'm running today in a dual monitor mode (nvidia, TwinView mode). On my scnd. display, the additional indicators are not displayed and in this panel i can select all icons. In my 1st display, the buggy behaviour (and with the newest update).

Revision history for this message
Alexander (xwolf-live) wrote :

Have the same issue using 3.8.16-0ubuntu1~natty1 (unity) on amd64 Laptop Dell Studio 1537 when setting ['all'] to whitelist, meanwhile if use a specified application name insted it has no problem. It's like a general release bug since many people reported this issue. Please give priority :) and good luck!

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

Confirm, not fixed in current Natty --- 32 bit install on an Asus eeePC.

Revision history for this message
Kemel Zaidan aka Legendario (kemelzaidan) wrote :

I still have this bug with unity 3.8.16-0ubuntu1~natty1

Revision history for this message
Jonathan Almeida (jonalmeida) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

Me too.

On Tue, Aug 2, 2011 at 12:27 AM, Kemel Zaidan aka Legendario <
<email address hidden>> wrote:

> I still have this bug with unity 3.8.16-0ubuntu1~natty1
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (764314).
> https://bugs.launchpad.net/bugs/761409
>
> Title:
> Cannot click on left-most indicator on panel if a non-indicator icon
> appears
>
> Status in Unity:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity” source package in Natty:
> Confirmed
>
> Bug description:
> Using Unity 3.8.8
>
> See attached screenshot. In the screenshot all the icons are
> indicators except for the Shutter icon (the left-most icon). I have
> added it to the whitelist. But when the shutter icon came on the
> panel, I can't click the mosque indicator icon in the area enclosed
> under the red rectangle in the image. If I want to access the mosque
> indicator, I have to click it's icon near its right edge (a very small
> area where it accepts clicks) or click on the Dropbox indicator or any
> other indicator on the right and move mouse leftwards.
>
> This problem goes away if I remove Shutter from the whitelist. FYI
> Shutter is the only application which utilizes the old-style
> notification area on my system.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/761409/+subscriptions
>

--
Jonathan Almeida

Revision history for this message
Markward Kufleitner (mkufleitner) wrote : Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

Running unity 3.8.16-0ubuntu~natty1 on x64 with nvidia TwinView, same problem on left main monitor.

On the right monitor all indicator icons work fine.

Revision history for this message
UncleLaz (andrei-lisnic) wrote :

Same here, unity --replace fixes it until next boot

Revision history for this message
Mbarak A. Bujra (mbarak) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if anon-indicator icon appears

I should mention that I have in dconf indicators-whitelist=[all]
I.E, I allow all programs to go in the panel and not just the appindicator ones.

I don't know if that makes any difference
------Original Message------
From: Lisnic Andrei
Sender: <email address hidden>
To: Mbarak Bujra
ReplyTo: Bug 761409
Subject: [Bug 761409] Re: Cannot click on left-most indicator on panel if anon-indicator icon appears
Sent: Aug 11, 2011 7:21 AM

Same here, unity --replace fixes it until next boot

--
You received this bug notification because you are subscribed to a
duplicate bug report (741423).
https://bugs.launchpad.net/bugs/761409

Title:
  Cannot click on left-most indicator on panel if a non-indicator icon
  appears

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/761409/+subscriptions

Revision history for this message
Omer Akram (om26er) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

isn't the cause of this issue the whitelist for systray to be set to 'all'??

Revision history for this message
Vivek Kapoor (marquivon) wrote : Re: Cannot click on left-most indicator on panel if a non-indicator icon appears

@mbarak Yes, that makes a difference. If you individually whitelist the items in the indicator panel, then you'll not face this issue.

Omer Akram (om26er)
summary: - Cannot click on left-most indicator on panel if a non-indicator icon
- appears
+ Cannot click on left-most indicator on panel if a systray icon appears
Revision history for this message
freezeloud (freezeloud) wrote :

@Vivek well not entirely... as i wrote in comment #36 whitelist all just spread unresponsive area of indicators... but this issue is still present with default whitelist apps, it just isn't so clearly noticeable, unclickable is like a 1/3 of a most left indicator or so...

Revision history for this message
Torsten Spindler (tspindler) wrote :

A PPA with a possible fix is up at ppa:tspindler/unity-761409 .

Revision history for this message
Omer Akram (om26er) wrote :

I believe this branch committed today might have fixed this issue as well https://code.launchpad.net/~njpatel/unity/fix-panel-tray/+merge/73374

Revision history for this message
Tom Ellis (tellis) wrote :

@Omer - This is the same fix, but backported for Unity 3.x in Natty. The original patch you mention above has some Oneiric Unity 4.x specifics

Revision history for this message
Tom Ellis (tellis) wrote :

After adding the repository on a Natty system with:
sudo apt-add-repository ppa:tspindler/unity-761409
sudo apt-get update
sudo apt-get upgrade

and logging out and back in again, I no longer see the problem where indicators become unclickable when using the fallback notification area and the dconf systray-whitelist setting set to 'all'.

I do notice a slight overlapping of the area with the indicators once I have over six systray icons launched but the indicators are still clickable.

The patch fixes it for me!

Thanks Neil & Torsten!

Revision history for this message
Omer Akram (om26er) wrote : Re: [Bug 761409] Re: Cannot click on left-most indicator on panel if a systray icon appears

Tom could you propose it to lp:unity/3.0 once its approved and merged
there I would be happy to work on the SRU for this fix as quite a big
number of people is affected.

@all please test the fix from the ppa and let us know if the issue is
fixed for you without any regressions.

Revision history for this message
Omer Akram (om26er) wrote :

slight mis-understanding with the names there, since we have the fix confirmed by Tom I have proposed the branch to lp:unity/3.0 myself.

Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity (Ubuntu Natty):
status: Confirmed → Triaged
Omer Akram (om26er)
Changed in unity:
milestone: 3.8.16 → none
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
aaron-bru (aaron-bru) wrote :

the updated ppa fixes the problem for me.

there is an issue where a very rapid triple-click on the indicator icon when there is a program maximized sometimes results in the indicator's menu going under the window. (actually, I've only reproduced this with firefox)
I think i also saw it go under the desktop background when there were no programs open.
But it was intermittant and I checked after using ppa-purge to remove the ppa and it still happened, so i think the ppa is fine. its something you would really only notice if you testing out the indicator icons :)

Omer Akram (om26er)
description: updated
description: updated
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Hi Omer! The upload looks good, *except* the addition of

--- unity-3.8.16.orig/.bzrignore.THIS
+++ unity-3.8.16/.bzrignore.THIS

Please re-upload without this extra file and we should be able to accept it into natty-proposed.

Revision history for this message
Omer Akram (om26er) wrote :

Not really sure what happened there, my diff was very clean and did not had anything to do with .bzrignore the issue might have happened on my sponsor's end. I'll change the version number and get it re-uploaded

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Excerpts from Omer Akram's message of Mon Sep 12 21:33:34 UTC 2011:
> Not really sure what happened there, my diff was very clean and did not
> had anything to do with .bzrignore the issue might have happened on my
> sponsor's end. I'll change the version number and get it re-uploaded
>

Yes, probably just a sponsor flub.. it happens.

You can actually re-use the same version number because the upload
was rejected.

Revision history for this message
thomasn80 (thomasn80) wrote :

Switched to Linux Mint Debian and the problem went away :)

Revision history for this message
Omer Akram (om26er) wrote :

On Tue, Sep 13, 2011 at 12:18 PM, ThomasNovin <email address hidden> wrote:
> Switched to Linux Mint Debian and the problem went away :)
you do know that mint does not have anything to do with unity don't you ?

Revision history for this message
markba (mark-baaijens) wrote :

For me, this bug has lesser significance because two major problems are solved in 11.10:
- printer icon is showing again in the indicator region, like it used to be, prior to 11.04
- update notifier icon (I forced this with gconf-editor) is not needed anymore, because this function is now handled by the new system-menu

Revision history for this message
Markward Kufleitner (mkufleitner) wrote :

With ppa:tspindler/unity-761409 the Problem went away, but since 2 oder 3 days the problem came back. What the heck is going on there. That's far away from a usable system. I know now, why Linux only has 1% users on the desktop.

Revision history for this message
Magnes (magnesus2) wrote :

Right now I have to be very careful not to close Clementine or Pidgin or Amule windows because the tray icons are not only not clickable - they are also not showing at all (to get them to show I have to restart Unity - but after a few minutes they disappear again). My report about it was ignored. Ubuntu 11.04 right now is simply not usable - I manage only because I'm a "techperson" and can workaround almost every obstacle. But the 1% will fall to less with the mess that is the most popular Linux distro. I stopped recommending Ubuntu to people - more, I have to recommend to them other systems right now (Windows 7 is quite nice for example).

Revision history for this message
Magnes (magnesus2) wrote :

Also right now the launcher is flickering when I watch movies (partially visible on all full screen apps). It's annoying as hell.

Andrea Azzarone (azzar1)
Changed in baltix:
status: New → Invalid
Revision history for this message
Tom Ellis (tellis) wrote :

does anyone know if this reached natty-updates yet?

Revision history for this message
Federico Gazaba (federico-gazaba-6) wrote :

The problem is back again! But in other machine... (before in dell mini 1012, now in sony vaio serie Y) I added the ppa but the bug is still there. Any sugest for manual configuration of the famous "white list"?

Revision history for this message
Torsten Spindler (tspindler) wrote :

@Federico: Can you do a '$ apt-cache policy unity' and a '$ dpkg -s
unity | grep Version' and let us know the result? Thanks.

Revision history for this message
Juan Simón (simonbcn) wrote :

Is this bug supposedly fixed in Natty!? o_O

Revision history for this message
Edvinas (ikonitas) wrote :

to: Torsten Spindler my problem is back to please take a look:

ed@ubu:~$ dpkg -s unity |grep Version
Version: 3.8.16-0ubuntu1~natty2
ed@ubu:~$ apt-cache policy unity
unity:
  Installed: 3.8.16-0ubuntu1~natty2
  Candidate: 3.8.16-0ubuntu1~natty2
  Version table:
 *** 3.8.16-0ubuntu1~natty2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.16-0ubuntu1~natty2~tetet1 0
        500 http://ppa.launchpad.net/tspindler/unity-761409/ubuntu/ natty/main amd64 Packages
     3.8.10-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages

Revision history for this message
Juan Simón (simonbcn) wrote :

Ok, my question is auto-answered with my tests: it works to me! :-) Thanks.

Revision history for this message
Juan Simón (simonbcn) wrote :

Sorry but it still fails. I have to click several times to the left-most indicator on panel works.

$ apt-cache policy unity
unity:
  Installed: 3.8.16-0ubuntu1~natty2
  Candidate: 3.8.16-0ubuntu1~natty2
  Version table:
 *** 3.8.16-0ubuntu1~natty2 0
        500 http://ubuntu.grn.cat/ubuntu/ natty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.10-0ubuntu2 0
        500 http://ubuntu.grn.cat/ubuntu/ natty/main amd64 Packages

$ dpkg -s unity | grep Version
Version: 3.8.16-0ubuntu1~natty2

It works for a while but then it fails again.

Revision history for this message
Torsten Spindler (tspindler) wrote :

@Edvinas: I've rebased the package in ppa:tspindler/unity-761409 against 3.8.16-0ubuntu1~natty2 and the packages are being built now.

@Tom, @Simon: It seems there was no update with the patch included for Natty yet. Maybe Omer has some information on the upgrade process.

Revision history for this message
Tom Ellis (tellis) wrote :

A package in -updates superseded the package in Torsten's PPA, so the package got updated. The update didn't contain the fix for this bug. Torsten's new version includes the fix based on this newer unity version.

It seems although it's been merged into lp:~ubuntu-desktop/unity/natty it has not yet been pushed into a package for -proposed.

Revision history for this message
Juan Simón (simonbcn) wrote :

I've added his PPA and I'll test now.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Bilal, or anyone else affected,

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Juan Simón (simonbcn) wrote :

The modified Unity in Torsten's PPA worked well.
Now I have activated Natty-Proposed repository and I've updated. Now I have the next version:
$ apt-cache policy unity
unity:
  Installed: 3.8.16-0ubuntu1~natty3
  Candidate: 3.8.16-0ubuntu1~natty3
  Version table:
 *** 3.8.16-0ubuntu1~natty3 0
        500 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive/ natty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.16-0ubuntu1~natty3~tetet0 0
        500 http://ppa.launchpad.net/tspindler/unity-761409/ubuntu/ natty/main amd64 Packages
     3.8.16-0ubuntu1~natty2 0
        500 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive/ natty-updates/main amd64 Packages
     3.8.10-0ubuntu2 0
        500 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive/ natty/main amd64 Packages

I'll test it.
Thanks.

Revision history for this message
Simon Déziel (sdeziel) wrote :

I'm not 100% sure if it's related to this bug but since I upgraded to unity 3.8.16-0ubuntu1~natty3 I have trouble with my external LCD screen.

I can get to the login prompt but once authenticated, the screen goes black. When this occurs, I still can have my display back if I unplug my external monitor, my laptop's screen goes on and all work fine on this screen.

Note that I normally only use my external monitor as my primary and my laptop's screen is turned off by default. This seems to trigger the bug. I was able to find workaround to have my external LCD working :

# Set my external LCD as primary
$ xrandr --output VGA1 --primary

# Turn off laptop's screen
$ xrandr --output LVDS1 --off

Revision history for this message
Magnes (magnesus2) wrote :

This is another bug, I have it too. I reported it - but got no response. Using xrandr could leave you with all displays turned off. On my computer "xrandr --output LVDS1 --off" will turn off both displays most of the time. :)

Revision history for this message
Simon Déziel (sdeziel) wrote :

@Magnes, please let me know which bug you reported as I'd like to subscribe to it. Thanks.

Revision history for this message
Magnes (magnesus2) wrote :

https://bugs.launchpad.net/unity/+bug/823099 - it's a little different, but the problem is probably the same. I hope it's already fixed in 11.10.

Revision history for this message
Simon Déziel (sdeziel) wrote :

Please disregard my comment in #89 as downgrading to 3.8.16-0ubuntu1~natty2 didn't help.

Omer Akram (om26er)
tags: added: verification-done
removed: verification-needed
Revision history for this message
aaron-bru (aaron-bru) wrote :

still not fixed for me in 11.10.
can that ppa be used in 11.10?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1~natty3

---------------
unity (3.8.16-0ubuntu1~natty3) natty-proposed; urgency=low

  * src/PanelTray.cpp:
  * src/PanelTray.h:
    - make systray behave nice when the whitelist is on (LP: #761409)
  * src/IndicatorObjectEntryProxyRemote.cpp:
    - Fix leak of GMemoryInputStream. (thx hyperair) (LP: #816632)
 -- Omer Akram <email address hidden> Tue, 06 Sep 2011 00:09:33 +0500

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Revision history for this message
aaron-bru (aaron-bru) wrote :

just incase anyone stumbles across this, I am actually not experiencing this bug, instead i am experiencing
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/833397
where there are 2 battery indicators, i didn't notice the duplication at first.

Changed in baltix:
status: Invalid → In Progress
Revision history for this message
Juan Simón (simonbcn) wrote :

I have similar problem in Ubuntu 11.10 64 bits with Unity 4.24.0-0ubuntu2b1

Sometimes the "old style" tray icons don't respond.

Revision history for this message
Konstantin (a-konstantin) wrote :

not fixed in 11.04

Revision history for this message
Magnes (magnesus2) wrote :

Also tray icons still disapear sometimes (sometimes are visible and sometimes not) in 11.10. (it's probably related)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions