[SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are incomplete/missing

Reported by Nicolas Delvaux on 2012-08-07
304
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Test Case]
1. Start a unity session (unity --replace works too)
2. Mouse-hover any icon in the launcher
   -> Verify that the tooltip appears
3. Move the mouse on another icon and then get back to the first icon.
   -> Verify that the tooltip appears

[Regression Potential]
Visual regressions, shell drawing problems. Part of a big change, many regression potentials.

Original description:

Since the last proposed Unity/Compiz/Nux update, launcher tooltips don't appear immediately after starting the session.

Test case:

- Start a unity session (unity --replace works too)
- Mouse-hover any icon in the launcher and notice that there is no tooltip
- Move the mouse on another icon and then get back to the first icon. Now the tooltip appears immediately.

Same problem with FGLRX (from Ubuntu repositories) and with an updated Mesa stack (from https://launchpad.net/~oibaf/+archive/graphics-drivers/ ).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,compiztoolbox,mousepoll,grid,resize,gnomecompat,wall,move,place,snap,imgpng,vpswitch,regex,session,annotate,unitymtgrabhandles,animation,expo,workarounds,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Tue Aug 7 23:21:51 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-27-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-29-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV635 [Mobility Radeon HD 3650] [1002:9591] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:30e7]
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120425-15:28
MachineType: Hewlett-Packard HP EliteBook 8530p
PccardctlStatus:
 Socket 0:
   3.3V
  16-bit
  PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=050d83be-2ad9-459a-8dcd-283a11f96b25 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/08/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PDV Ver. F.11
dmi.board.name: 30E7
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 90.26
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PDVVer.F.11:bd12/08/2009:svnHewlett-Packard:pnHPEliteBook8530p:pvrF.11:rvnHewlett-Packard:rn30E7:rvrKBCVersion90.26:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8530p
dmi.product.version: F.11
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.7.8-0ubuntu1.3
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.37+git1208031102.7e3f08~gd~p
version.libgl1-mesa-dri: libgl1-mesa-dri 8.1~git1206081121.640409~gd~p
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.1~git1206081121.640409~gd~p
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99+git1207131153.6ef1ad~gd~p
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.2+git1208031103.146959~gd~p
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1+git1207120855.d1bc38~gd~p

Related branches

lp:~thumper/unity/regional-damage-sru
Merged into lp:unity/5.0 at revision 2394
Łukasz Zemczak: Approve on 2012-08-02
Marco Trevisan (Treviño): Approve on 2012-08-01
Daniel van Vugt: Approve on 2012-07-27
Nicolas Delvaux (malizor) wrote :
Omer Akram (om26er) wrote :

Not an issue on intel here, that might need testing on AMD GPU.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Øyvind Stegard (oyvinst) wrote :

Confirming rendering issues with tooltips for launcher icons . On first hover after "initialization" of some kind (for instance changing the size of the icons or just after having logged in), the tooltip will not render properly, but instead appear as a thin line. On second hover, the tooltip is "corrected" and is then subsequently shown correctly. It is individual for each icon's tooltip, and most of them exhibit the rendering problem on first hover.

I have precise-proposed enabled, and don't remember seeing this issue before the latest updates, so suspect regression.

unity 5.14.0-0ubuntu1
compiz 1:0.9.7.8-0ubuntu1.3

Nvidia binary blob (295.71), NVS 3100M graphics card.
Ubuntu 12.04, x64

Nicolas Delvaux (malizor) wrote :

I can confirm this bug when using the latest daily-live of 12.04.1 (with the default R600g driver).
I tested on the same laptop as the one I used to report this bug.

Omer Akram (om26er) wrote :

Could anyone please test and let us know if the issue also appears on any of the intel GPU? Just wanting to confirm if its a GPU issue or maybe its just not reproduce able for me.

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: New → Incomplete
Øyvind Stegard (oyvinst) wrote :

Easily reproduced on a machine with Intel 945G graphics running Ubuntu 12.04 x86-64 (unity 5.14.0-0ubuntu1, compiz 1:0.9.7.8-0ubuntu1.4). Launcher tooltips are cut off horizontally at different points on "first" rendering. Looks like this bug is independent of graphics hardware/driver.

Reproduce:
1. Change size of launcher icons using for instance wallpaper settings. (Or make some other change in the launcher, like re-arranging icons.)
2. Hover the launcher icons one by one and look at the tooltips.

palimmo (palimmo) wrote :

Same error.
Tooltips don't appear immediately (usually I can see a small black triangle over the icon)... like a fragment of the tooltip.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Nicolas Delvaux (malizor) wrote :

No problem on the latest Quantal daily-live.
So this is really a regression from the last Precise updates.
(oh, and no problem on Unity 2D)

Daniel van Vugt (vanvugt) wrote :

I had this briefly a few days ago. But not at all since then.

Strange, because I'm not aware of any fixes having been released in precise that could cause this. Can someone try installing the old Unity 5.12 packages? Does that fix it?

summary: - Launcher tooltips don't appear immediately the first time
+ [precise] [unity 5.14] Launcher tooltips don't appear immediately the
+ first time

Downgrading libnux-2.0-0 from 2.14.0 to 2.10.0 (precise/main) fixes the tooltips issue.

Omer Akram (om26er) wrote :

Oyvind, Can you install nux 2.12.0-0ubuntu2 from here https://launchpad.net/ubuntu/quantal/+source/nux/2.12.0-0ubuntu2 and see how it goes, so we are sure between what packages the issue started

Øyvind Stegard (oyvinst) wrote :

I got into a bit of dependency ickiness when installing the 2.12 deb for quantal on precise. Can build from source when I have some more time later.

Looking at the changelog for libnux, I would guess the problem was introduced between 2.12 and 2.14: for 2.12 only keyboard-related fixes are mentioned, but for 2.14 there are some performance fixes and drawing related stuff.

Øyvind Stegard (oyvinst) wrote :

Found precise build of 2.12 here: https://launchpad.net/ubuntu/+source/nux/2.12.0-0ubuntu1/+build/3435836

I have now verified that this issue is not present in 2.12, but was introduced with 2.14.0-0ubuntu1 in precise-updates.

Daniel van Vugt (vanvugt) wrote :

OK, I suspect this might be caused by the Nux fix for bug 1014610.

That fix was developed because the fix for Unity bug 988079 requires it. However the fix for bug 988079 has not been released in precise yet (coming soon in Unity 5.16). So maybe the issue here is that the old Unity rendering code is not fully compatible with the fix for Nux bug 1014610.

I guess we will get an answer when Unity 5.16 is ready for testing. This bug may well vanish in Unity 5.16.

Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → 5.16.0
Øyvind Stegard (oyvinst) wrote :

Great, I'll be sure to test this when new Unity/Compiz lands in Precise-proposed. Will report back on this bug.

Øyvind Stegard (oyvinst) wrote :

Following up, the problem vanishes when using unity build 5.14.0+bzr2397ubuntu0+704 from the Unity SRU channel PPA (https://launchpad.net/~unity-team/+archive/sru). If I have not misunderstodd something, this is the version/branch that will eventually land in precise as Unity 5.16 ?

Omer Akram (om26er) on 2012-08-19
Changed in nux (Ubuntu):
importance: Undecided → High
no longer affects: unity (Ubuntu)
Changed in unity:
importance: Undecided → High
summary: - [precise] [unity 5.14] Launcher tooltips don't appear immediately the
- first time
+ [SRU Regression] Launcher tooltips don't appear immediately the first
+ time
Omer Akram (om26er) on 2012-08-19
Changed in nux:
importance: Undecided → High
Changed in nux (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
milestone: none → ubuntu-12.04.2

Hello,

Bug for me too...

Both on my intel video GPU and my nVidia GPU... same problem with tooltips. Once dash is launched, tolltips appear correctly, without this example of action, i have the same descrition before.

This is not a "huge" bug but it is not very eye-candy... ;-)

When the fix for precise is expected? 12.04.2 seems to be too far away.. for an LTS distrib. ;-)

Thank's for your great job!

Omer Akram (om26er) wrote :

sacha, as soon as we have a fix we'll make sure it makes into 12.04 much before 12.04.2 comes out :-)

Changed in nux (Ubuntu):
status: Confirmed → Invalid
Omer Akram (om26er) wrote :

Issue does not exisit in Quantal so I closed the main bug, its still being tracked in 12.04. Thanks

Marco Scannadinari (zheoffec) wrote :

Can anyone else confirm the bug in not in Quantal, especially after apt-get upgrade?

Changed in nux (Ubuntu):
status: Invalid → Confirmed
sacha@ubuntu (sacha-b77) wrote :

@Omer : thank's for this information!

Kaze (kazeu666) wrote :

Error in video capture.
Sucede tanto con drivers libres o privativos.

Marco Scannadinari (zheoffec) wrote :

Gerado's video is also exactly my experience with the new unity/nux update.

summary: - [SRU Regression] Launcher tooltips don't appear immediately the first
- time
+ [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
+ incomplete/missing
Daniel van Vugt (vanvugt) wrote :

Linked the branch that I think might/should fix this bug.

Omer Akram (om26er) wrote :

Anyone facing this issue please test unity from this ppa https://launchpad.net/~unity-team/+archive/sru and let us know if the issue is fixed for you.

William Ranvaud (wiranvaud) wrote :

The PPA mentioned by Omer #26 solved the problem for me. Thx.

Omer Akram (om26er) on 2012-08-23
no longer affects: nux
Changed in nux (Ubuntu):
status: Confirmed → Invalid
Jared Sot (ravefinity) wrote :

My Apologizes for duplicating this bug, I couldn't find it for the life of me :D

So far I'm seeing this issue on:

Nvidia Geforce 450 (Proprietary Drivers)
Intel GMA 950
Intel GMA 965 or X3100
Intel HD 3000 (Sandy Bridge GPU) *Same Laptop
AMD Radeon HD 670 (Proprietary Drivers) * Same Laptop

So it doesn't appear to be graphics card specific. I don't have a Intel HD 4000 (Latest Generation So I can't comment on that)

I would like to add:
Not only do the labels not render on first mouse over, but they randomly get choppy or don't render properly randomly after that. EG. Its a continuous regression.

I have observed it will happen again if you have alot of programs on the panel and you have to scroll through them... EG. Mouse over icons and haveing them expand and compress will make the labels display improperly again and again.

I have tested this on 4 Systems with the specs above.

This isn't a show stopper bug BUT it's a regression It may give users a bad impression of the user experience.

How much testing is needed? before a fix can be pushed to all LTS users?

When adding the: https://launchpad.net/~unity-team/+archive/sru PPA can one easily revert back to mainline after it is fixed?

Thanks All.

Fix worked for me on three affected 12.04 laptops:

Sony VAIO (Core Duo) + ATI Catalyst drivers
Sony VAIO (Core i7) + nVidia drivers
Lenovo T500 + ATI Catalyst drivers

On 08/23/2012 04:36 AM, Omer Akram wrote:
> Anyone facing this issue please test unity from this ppa
> https://launchpad.net/~unity-team/+archive/sru and let us know if the
> issue is fixed for you.
>

Omer Akram (om26er) on 2012-08-24
affects: nux (Ubuntu) → unity (Ubuntu)
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
eden6000 (eden6000) wrote :

Omer's fix works for me too on a Lenovo desktop with intel graphics

Marco Scannadinari (zheoffec) wrote :

PPA fixes bug with AMD Radeon HD 6570.

Omer's (#26)
Way of working.
But adding a repository ... confused.

Destain Duckert (dduckert) wrote :

PPA fixed bug for me as well. Dell Laptop with Intel Graphics.

palimmo (palimmo) wrote :

PPA fixed bug for me as well. Packard Bell TJ65, Nvidia GeForce G105M.

Yanski (yanski) wrote :

Fujitsu Siemens Li3410G - Nvidia GeForce 7100 / nForce 630i - Ubuntu 12.04.1
Omer's PPA fix has worked on my set up too... Thanks.

Omer Akram (om26er) wrote :

Everyone have been busy with the Beta freeze for Quantal so a little delay in the SRU. I hope we will have it ready the coming week.

New Ubunty (new-ubunty) wrote :

I can confirm this bug (launcher tooltips are incomplete or missing and I can see a small black triangle over the icon, and labels get randomly choppy or don't render properly). I started seeing this bug about 1 month ago on one brand new desktop and two netbooks I have, all with Intel graphics and Ubuntu 12.04, Kernel 3.2.0-29-generic, Unity version 5.14.0.

sacha@ubuntu (sacha-b77) wrote :

Hello Omer!

The new SRU will be pusched into proposed for testing or directly into precise-updates?

Thank's!

Kaze (kazeu666) wrote :

AMD Radeon HD6670 1GB GDDR5 - Omer's PPA fixed bug for me as well. Thanks.

Sergio Benjamim (sergio-br2) wrote :

The “Unity Team” team PPA fixed this bug here too!

Thanks!

Jaymos (jtubu) wrote :

The Unity Team ppa fixed this for me too:
sudo add-apt-repository ppa:unity-team/sru

Nicolas Delvaux (malizor) wrote :

When can we expect the next SRU?
This bug is visible for each user of Unity 3D since more than a month...

description: updated
sacha@ubuntu (sacha-b77) wrote :

Same comment than Malizor.

When can we expect the fix in precise-updates?

Hello Nicolas, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Nicolas Delvaux (malizor) wrote :

I confirm that this bug was fixed by Unity 5.16.

tags: added: verification-done
removed: verification-needed
eden6000 (eden6000) wrote :

Unity 5.16 fixed it for me too

Tomeu Canals (tomeuari) wrote :

Sorry for the stupid question, but how could I update to Unity 5.16?
I tried using the unity-team/sru ppa, but it didn't work (at least for me). Installing that PPA updates Unity to 5.16?

eden6000 (eden6000) wrote :

Gaitz, you have to enable the "proposed" updates in your update settings...but, if you prefer, I believe that in a few days unity 5.16 will be pushed to regular updates, so you can just wait...

Luc Bruninx (luc2005) wrote :

Hi,

The proposed Unity 5.16 works for me too.

Hi,
I enabled the proposed updates, updated unity (only), did "unity --replace" and it seems to be corrected.
Thanks !
(just to confirm : "unity --version" is correct, 5.16)

Ari (ari-lp) wrote :

Great to see this fixed at last.

ViViD (vivnet) wrote :

After testing unity 5.16.0-0ubuntu1 from the precise-proposed repository, this issue is fixed for me on single monitors.

However, it seems to be present when my second monitor is attached and receiving output. Can anyone else confirm this?

I'm at kernel 3.2.0-31 with nvidia 304.43 drivers and unity 5.16.0.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Autohide panel broke. Not appear when the cursor is over the left.

eden6000 (eden6000) wrote :

On my machine it works...dumb question, did you push the cursor "beyond" the left?

The launcher does not appear when Autohide. Only by pressing "Win" button, along with Dash
When the AutoHide it is hidden and does not appear.
(Sorry my english - i use google translate)

Omer Akram (om26er) wrote :

The autohide issue is NOT unity's fault. That is caused by the very latest nvidia driver. We never recommend using ppa's

Thanks for the tip. The driver did deactivate after the updates, it turns out.

Changed in unity:
status: Fix Committed → Fix Released
New Ubunty (new-ubunty) wrote :

I have just reported a similar bug that affect the launcher tooltips https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1098044

To post a comment you must log in.