EXA is balls-achingly slow

Bug #177492 reported by Scott James Remnant (Canonical) on 2007-12-19
230
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

The default acceleration mode in hardy, which I understand is EXA, is incredibly slow. The experience of running compiz with it is awful.

Changing to XAA in the config file solves the issue, though then I obviously lose video.

Timo Aaltonen (tjaalton) wrote :

True, to some extent. I didn't think it was too slow with the Thinkpad X60 I had for awhile (i945GM or so), apart from scrolling in firefox.

Changed in xserver-xorg-video-intel:
status: New → Confirmed
Id2ndR (id2ndr) wrote :

Adding the line bellow to Section "Device" currently works better (like describe in the freedesktop bug) :
        Option "AccelMethod" "XAA"

Timo Aaltonen (tjaalton) on 2008-01-08
Changed in xserver-xorg-video-intel:
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

Unfortunately, to make EXA performance better it needs the new memory manager upstream is working on (TTM). It's too intrusive for hardy, so we'll probably switch back to XAA after alpha3.

Bryce Harrington (bryce) wrote :

Timo, can you give a reference (or IRC log snippets) for this info about the TTM requirement?

Timo Aaltonen (tjaalton) wrote :

The upstream bug report mentioned on comment #2, and this from #xorg-devel:

01:51 < tjaalton> is there hope seeing it fixed in the next few months?
01:51 < tjaalton> since switching back to XAA is tempting
02:18 < airlied> tjaalton: probably .. hopefully it'll be fixed for Fedoora 9..
09:23 < tjaalton> airlied: ok, that doesn't help ubuntu 8.04 though :/
09:43 < tjaalton> and patching the driver to use XAA again seems to be the only option now
09:48 < airlied> tjaalton: I'd go with that option really..
09:48 < airlied> EXA by default == bad idea on 965
09:48 < airlied> other option is to turn of EXA compositing .. but that'll make rotation
                 really slow
09:48 < tjaalton> bad idea on any intel it seems..
09:48 < tjaalton> at least 945 is just as slow

so unless I've misunderstood, to make it work better we need the batchbuffer stuff which in turn requires TTM.

zdzichu (zdzichu-gmail) wrote :

Switch back to XAA is bad because:
1) Ubuntu users will be deprived of textured video and power saving (by the way of fb compression) for a year¹
2) XAA is basically deprecated and its bugs are fixed as second priority. Do you want to release LTS with driver abandoned by upstream?

¹ textured video was disabled on intel driver shipped in 7.10. EXA will be disabled in 8.04. This way Ubuntu users will get those features no sooner than 8.10.

Bryce Harrington (bryce) wrote :

Bumping up importance. I agree reverting back to XAA on 965, and we should explore alternate solutions if there's any out there.

Changed in xserver-xorg-video-intel:
importance: High → Critical
Changed in xserver-xorg-video-intel:
status: Unknown → In Progress
Lukas Hejtmanek (xhejtman) wrote :

You could try this option in the Device section.

Option "MigrationHeuristic" "greedy"

Vincenzo Ciancia (vincenzo-ml) wrote :

I have this problem on a video card with the following id:

00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)

which should be i945 according to the following line in Xorg log:

(--) Chipset 945GM found

I confirm that using XAA I have no XV video, just a blue window, under compiz.

Che Guevara (che-guevara-3) wrote :

The TTM bits are in -mm kernel right now and should be merged for 2.6.25, it would be much better if this can be backported, instead of releasing a LTS with XAA. I am actually thinking of building a mm kernel to see how the performance increases.

Giovanni Masucci (gio-grifis) wrote :

here's what I made:

Option "AccelMethod" "exa"
Option "MigrationHeuristic" "greedy"
Option "ExaNoComposite" "true"

In hardy with these options in xorg.conf with an intel i945 card, I get a system that is about as fast as with xaa. So why should exa be disabled?

I've also added this:
INTEL_BATCH="1"
in /etc/environment

Even scrolling in firefox works great!
That's wonderful!! :))
Try it out! Maybe we can still have exa+intel in hardy!

PS: now that exa works for me I'd like to try textured video, which is disabled by ubuntu in hardy...
Giovanni Masucci

Giovanni Masucci (gio-grifis) wrote :

btw: compiz works great too :-)
I'm happy now!

Giovanni Masucci (gio-grifis) wrote :

err...sorry. I have
Option "ExaNoComposite" "false"
in xorg.conf, not true.
My mistake, forgive me.

Id2ndR (id2ndr) wrote :

Lukas's solution works great for me (scroll is OK, compiz is OK) : in the Device section, add

Option "MigrationHeuristic" "greedy"

Vincenzo Ciancia (vincenzo-ml) wrote :

Giovanni, ld2ndR: does xv video work for you?

Giovanni Masucci (gio-grifis) wrote :

xv works for me, with video overlay and textured video (textured video is disabled in hardy for now, so I've tested it with debian sid driver).
Video overlay is efficient and fast as with xaa.
Textured video works (perfect compiz integration) but tends to be slow on my system.

Adding the options "AccelMethod" "exa", "MigrationHeuristic" "greedy", and
"ExaNoComposite" "false" to the device section of xorg.conf allows compiz to
work for me without the boarder glitches in compiz and video works. This is
a first for me with my x3100 graphics card.

May I ask what these three options do?
Also I did not add INTEL_BATCH="1" to /etc/environment. What does this do
and sholud I?

Giovanni Masucci (gio-grifis) wrote :

@Elias
In my system the INTEL_BATCH="1" option give me a great performance boost on glxgears.
Try to run in a terminal glxgears and then:
INTEL_BATCH=1 glxgears
and compare the results.

Elias K Gardner (zorkerz) wrote :

With glxgears originally 524.789 FPS. After adding INTEL_BATCH="1" and
rebooting 900.732 FPS. You are right this seems to be a definite performance
boost.

jerrylamos (jerrylamos) wrote :

This might be off the wall, however on one of my systems I got a BIG performance boost by setting:

System, Preferences, Apperance, Visual Effects, to None.

As installed none of the choices were checked, None, Normal, or Extra. Pretty sluggish.

I tried all three choices and for me, None gave the best performance.

Cheers, Jerry

Jacob Peddicord (jpeddicord) wrote :

jerry:

"None" doesn't apply here. No effects simply means running your desktop without any 3D acceleration at all, at which point neither XAA nor EXA is required. All drawing is done by the CPU in this mode.

Vincenzo Ciancia (vincenzo-ml) wrote :

On my i945, the fix works and setting INTEL_BATCH makes everything faster.

Id2ndR (id-2ndr) wrote :

Vincenzo Ciancia a écrit :
> Giovanni, ld2ndR: does xv video work for you?

I don't know how to test if xv video works or not. Can you give me a
command please ?

Vincenzo Ciancia (vincenzo-ml) wrote :

ld2ndR: install mplayer and run

mplayer -vo xv FILENAME

where FILENAME is any movie which is supported by ubuntu codecs (if you want to have more codecs, you have to look for unofficial packages, e.g. medibuntu).

To test if your file is working _without_ xv accelerated video, just do

mplayer -vo x11 FILENAME (if your system is fast enough, this should also work during 3d effects, while with xv you'll see a blue window when rotating cube, zooming etc.)

Vincenzo

Id2ndR (id2ndr) wrote :

mplayer runs perfectly elephant dreams movie with xv. It also works great with x11, but uses 2 or 3 times more CPU.
(I only use Option "MigrationHeuristic" "greedy")

I've also seen what you said about 3D effects ;).

Mika Fischer (zoop) wrote :

I can also confirm that on my Samsung !45 with Intel X3100 graphics adding INTEL_BATCH="1" to /etc/environment and putting the following into my xorg.conf:
        Option "AccelMethod" "EXA"
        Option "ExaNoComposite" "false"
        Option "MigrationHeuristic" "greedy"

solved my problems with X!

Scrolling firefox is fast as in gutsy, compiz works, no window shadow corruption and videos work as well.

Maybe this should be considered instead of just reverting to XAA.

Thom Pischke (thom-pischke) wrote :

+1 to the EXA workaround confirmation party

sibidiba (sibidiba) wrote :

Can confirm bug and workaround with further details.

On current Hardy with chipset and video card:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

With xorg (1:7.3+10ubuntu4) and intel driver (2:2.2.0.90-2ubuntu2):

2D acceleration, especially text scrolling is fast, even with compiz enabled.

Xv video playback works fine, but when compiz enabled it is slow and drops a lot of frames.

When having a virtual display (even below or equal to 2048x2048) with multiple display devices (regardless of clone or extended mode), a system hang doesn't occur anymore when running 3D apps.

sibidiba (sibidiba) wrote :

System still hangs when running 3D apps, if one of the displays is smaller than the virtual display.

sibidiba (sibidiba) wrote :

After a longer period of testing of the workaround, I experienced
that the system still occasionally hangs when running 3D apps, even having just one screen.

Also Xv playback is still unusable, when compiz enabled. Although slow text scrolling is completely resolved.

I have to fall back to XAA. (Xv and compiz won't work together this where either, but is at least stable until now.)

Bryce Harrington (bryce) wrote :

Hmm, here's a first draft at a couple patches (one against xserver, one against -intel) to allow forcing greedy mode on i965 with exa:

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

Here's an alternate form of the intel patch, which is a tad cleaner, but basically does the same thing.

Bryce Harrington (bryce) wrote :

Sorry, the test in the xserver patch was incorrect, leading to FTBS; I think the patch needs to look more like this.

Zack Cornelius (zcornelius) wrote :

Can confirm this bug and workaround on hardy with GM965.

Also to note, that with the workaround (EXA with MigrationHeuristic greedy and the INTEL_BATCH env. variable set), Xv video in mplayer works properly during 3D effects (No blue screen, instead proper video), including on the cube while turning.

Bryce Harrington (bryce) wrote :

We're uploading a tested fix for this issue which switches greedy mode on for i965. .dsc's and such are at:

http://people.ubuntu.com/~bryce/Uploads/

-intel 2ubuntu5 turns greedy mode on for i965 when using EXA.
-intel 2ubuntu6 switches us back to XAA for all chipsets except i965.

Also, attached is a proposed alternative patch to use greedy for all chipsets when using EXA; in which the 2ubuntu6 patch (and optionally 2ubuntu5, although line numbers might need tweaked) would be reverted. I don't have a solid feel for whether EXA+greedy on all intel chipsets is safer or better than XAA-on-all-except-EXA-for-i965, but these patches should allow us to go either way. All else being equal, it would be nice to ship EXA on by default for everything since we'd be more consistent with upstream.

William Grant (wgrant) wrote :

I've been running greedy EXA on my i915 for months, and it works flawlessly.

Bryce Harrington (bryce) on 2008-02-20
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Committed
assignee: nobody → bryceharrington
unggnu (unggnu) wrote :

I can confirm this issue on i915. The line " Option "MigrationHeuristic" "greedy" " fixes it for me and compiz seems to be faster than under Gutsy but that might be subjective and/or related to the INTEL_BATCH thing.
Maybe EXA and greedy could be enabled on all supported Intel hardware for Hardy 5 with confirming question for all releated Intel bugs. If it doesn't fix them or makes new problems XAA could be still the fallback option.

Bryce Harrington (bryce) wrote :

unggnu, thanks for the feedback about that; Ng also said he thought greedy improved things on 855 as well, and I've noticed numerous bugs against 945, etc. that sound suspiciously similar to the 965 issues. If we can confirm greedy addresses issues on more chipsets, then I think forcing greedy for all intel chips would probably be worth doing.

ungnu, could you test with and without the INTEL_BATCH option and see if you can definitively show whether the performance effects are true? (Scrolling firefox on a large web page seems to be a good way to detect performance differences; I wish we had an automated test we could run to do this.)

Bryce Harrington (bryce) on 2008-02-20
Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
unggnu (unggnu) on 2008-02-24
Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
sibidiba (sibidiba) on 2008-03-11
Changed in xserver-xorg-video-intel:
status: Fix Released → New
Changed in xserver-xorg-video-intel:
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2008-03-12
Changed in xserver-xorg-video-intel:
status: Fix Released → In Progress
Bryce Harrington (bryce) on 2008-03-13
Changed in xserver-xorg-video-intel:
importance: Critical → High
Bryce Harrington (bryce) on 2008-03-25
Changed in xserver-xorg-video-intel:
status: In Progress → Fix Committed
Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
91 comments hidden view all 171 comments
Conn O Griofa (psyke83) wrote :

Bryce,

Can I make a request re: 05_intel_exa_force_greedy.patch? Currently this patch forces the "greedy" heuristic which is currently the best option for many Intel cards (mine included). However, it effectively disables EXA acceleration for most cases, as far as I understand.

Wouldn't it be better to revise the patch so that the Intel driver's MigratonHeuristic *defaults* to "greedy" rather than forcesit? That way, if I want to test the "smart" or "always" heuristics to see if improvements are made in future versions of Xorg, I can specify them in my xorg.conf. That won't break user's setups and will make this patch more future-proof.

Bryce Harrington (bryce) wrote :

dsyates, that is correct. Also it looks like upstream will not be supporting TTM, but instead will focus on GEM. This is particularly evidenced by yesterday's libdrm release which also omitted TTM. So TTM looks like a dead end and we won't be pursuing it ourselves. Hopefully GEM will develop rapidly, however we don't anticipate it to be delivered in time for Intrepid. But we'll see.

Changed in xserver-xorg-video-intel:
status: In Progress → Confirmed
Conn O Griofa (psyke83) wrote :

Following up on my previous post - the "force greedy" patch was disabled in version 2:2.3.2-2ubuntu2 of the intel driver (although only because it was causing a segmentation fault). I hope this patch doesn't get re-introduced, as my Intel 855GM seems pretty snappy using the "always" MigrationHeuristic - even scrolling with compiz enabled seems faster now.

I would suggest that during the development cycle, the migration heuristic is left untouched, as it seems the new release of the Xorg server has improved EXA performance with the default migration heuristic. I have been following the Xorg mailing list, and Xorg 1.5 (including the release candidates) use the "ExaOptimizeMigration" parameter by default, which supposedly improves EXA's "always" heuristic to match "greedy" in some cases.

If it causes slow-downs for too many users, however, then the (fixed) patch can be re-introduced later.

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress

This bug reappeared for me since the migration to the 2.6.27 kernel

Guido Conaldi (guido-conaldi) wrote :

The bug seems to be reappeared to me too in Intrepid 64bit up-to-date with intel x3100.

reacocard (reacocard) wrote :

I've also recently noticed slowness on the x3100 in Intrepid

Andrew (andrewabc) wrote :

Odd, running intrepid livecd alpha 6 compiz seems to run faster than hardy (less CPU, can scroll in firefox without 90% CPU, it is only around 50-60% CPU and very responsive).
But I had similar experience when running hardy alphas. Compiz would work fine, then I would get an update causing massive CPU being used for xorg rendering compiz unusable and I havn't been able to get it working good since (until intrepid alphas).

Intel g965 x3000

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
Johnny Levai (digistyl3) wrote :

I too have this problem in Intrepid, I'm using an Intel X3100 on a Dell Studio 15. My glxgears fps is around 600 and I can't run Google Earth properly. Should this bug be reopened?

Tim (timothy-malone) wrote :

I'm also seeing this on my x3100. I went from 1200 fps in glxgears with Hardy to 450 in Intrepid.

void* (bohdan200) wrote :

I can also confirm performance regression after upgrading from 8.04 to 8.10 Beta. glxgears shows 1100fps on Hardy and only 650fps on Intrepid. It looks like INTEL_BATCH is not supported in Intrepid. I'm using Acer Aspite One laptop with Intel 945GME GPU

Kevin (kevinshlee) wrote :

I had this problem and tried to solve it with adding those three lines of Option to xorg.conf file. However, it did not solve my problem and I still had very slow scrolling and other performance issues.

I eventually decided to try the new version that is Intrepid so upgraded from 8.04 to 8.10 beta version, and now it works.
I don't seem to have the problem anymore.

Cre8or (jasoncop) wrote :

I have given up
I am using a T60 with intrepid with a Intel 945 graphics card

Tried all the options EXA / XAA, intel_batch and nothing seems to improve the speed
running at 222fps using glxgears

Any suggestions ???????

Please help

Biji (biji) wrote :

I noticed slow in Intrepid too....... intel X3100

Biji (biji) wrote :

My laptop is lenovo with this vga card using intrepid beta (updated daily)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

tried INTEL_BATCH=1, and some xorg.conf config but no luck

glxgears with compiz on:
2412 frames in 5.0 seconds = 482.269 FPS

without compiz:
2785 frames in 5.0 seconds = 556.983 FPS
2862 frames in 5.0 seconds = 572.289 FPS

Juan Carlos Torres (jucato) wrote :

Someone requested me to share this link. Might be relevant: https://bugs.freedesktop.org/show_bug.cgi?id=18128

citizenofnowhere (annafil) wrote :

Juan Carlos: thanks for the link! seems to have solved the issue for some, but i'm still getting much lower fps than I should be on my 945 (350 instead of 900). with compositing on its an abysmal 270... :( no stranger to getting direct rendering working so i've tried all the usual.. seems there is still a bug here

For those interested in the fix, try running "vblank_mode=0 glxgears -info" and if that improves your speed, follow the instructions in the above posters link

citizenofnowhere (annafil) wrote :

Actually scratch that, vblank_mode actually makes my performance worse by about 100fps, consistently with compositing both on or off... that's odd

Götz Christ (g-christ) wrote :

I have also the performance problem in Intrepid with an Intel 865G using EXA, with XAA acceleration it is much more faster. Scrolling was not slow, but in Firefox, and in Dolphin tab switching was slow, also switching to another window was slow and I got graphics corruption (screenshot attached), all this with EXA.

Intrepid with EXA
x11perf -aa10text
560000 reps @ 0.0100 msec ( 99900.0/sec): Char in 80-char aa line (Charter 10)

Intrepid with XAA
x11perf -aa10text
560000 reps @ 0.0102 msec ( 49700.0/sec): Char in 80-char aa line (Charter 10)

With and GEM Kernel and Intel 2.5 would it be better?

René (rkrell) wrote :

The same loss of EXA performance compared to XAA on an Intel 865G I have also on OpenSUSE 11.0 with kernel 2.6.25.XX. There a quiet longstanding issue on that at freedesktop.org I reported:
http://bugs.freedesktop.org/show_bug.cgi?id=17605

Short summary:
- Don't mess with the MigrationHeuristic server option (message of Intel)
- Kernel 2.6.27 (at least on OpenSUSE 11.1 Beta2 LiveCD) solves the problem without a configuration change.
- Intel driver 2.5 doesn't solve the issue
- It is not clear to this time, why the EXA acceleration with Intel video drivers on a 865G work beginning with 2.6.27

I used Kubuntu and OpenSUSE as well and this is NOT a propagation of a certain distribution, but only for referring to my test environment, where occur the same problems as described.

But as you said, the problem still remains in Intrepid, which is already delivered with 2.6.27?
So take this as a hint only...

citizenofnowhere (annafil) wrote :

Curley: Thanks a lot for your input! I'm glad too see people starting to pay attentin again... But I'm afraid things are a bit more messed up.

MigrationHeuristic is the ONLY thing preventing my system on my 945gm from crawling when I use compositing (and i do a lot its part of my workflow so yes I do need it).

XAA is not useable at all with Intrepid because compositing is completely broken since I think early Betas.

Intrepid is already using 2.6.27. I'm also using a kernel I compiled myself from the latest sources available in the repositories...

I guess I have to try the OpenSuse disk and figure out what they did - have you run any benchmarks between opensuse and ubuntu? what does "glxgears -info" show? (yes I know its not an accurate measurement, but in this case it will do)

Conn O Griofa (psyke83) wrote :

Apparently "MigrationHeuristic" shouldn't be changed anymore, at least for Intel users. One settings that may help performance is:

Option "ExaOptimizeMigration" "true"

See "man exa" for more details.

citizenofnowhere (annafil) wrote :

Yeah I understand the concept :) The point of the bug report is when its not working like its supposed to :)

Your suggestion provides a similar boost that greedy does minus some compositing elements going haywire so yay, but it's still not being configured properly by default. Your suggestion (and the older greedy) provide visible performance increases (at least on such low framerates as we're getting with the new configurations)...

But the real problem isn't even there, its here it seems https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/284082

René (rkrell) wrote :

@citizenofnowhere: Benchmarks you can find in the bug report at freedesktop.org, which I referred to. The glxgears I'll deliver later. Fortunately, the OpenSUSE's package maintainers are very actively tracking the problem together with Intel and issuing updates of drivers, Mesa and Xorg every couple of days in a special repository. I hope there will be a change soon.

citizenofnowhere (annafil) wrote :

curley: that's good to hear! i was starting to worry after trying the 2.5 driver version and libdrm version 2.4.1 and getting like 70fps.

fingers crossed that they come up with something soon!

René (rkrell) wrote :

Here are the diagnostic files for both cases, EXA and XAA on OpenSUSE 11.0, using XX.Org X Server 1.5.2, libdrm 2.4.1 and the latest Mesa 7.2 patches. Regardless of what these files say,
- the overall performance using EXA is still horribly slow on my 865G compared to XAA
- starting X server and switching to KDE after logon flickers in EXA mode and shows for about half a second (plus minus) an uninitialized video buffer)
- switching on KDE Desktop Effects (Composite) crashes the X server with a backtrace leading to libdrm (happens already for some months even in libdrm 2.3, for both XAA and EXE acceleration).
Not really useful at the moment.

On the other hand, what people recommended in this thread, and ignoring the recommendations of Intel developers, using MigrationHeuristic "greedy" leads to a broken systray, where are no icons visible, but only some kind of "colored trash".

Lorenzo Bettini (bettini) wrote :

I'm experiencing performance problems also with Sabayon, on a Intel Corporation 82G33/G31, with compiz (but also with ubuntu)...

for the moment the best performances seem to be with the

INTEL_BATCH=1

and this

Section "Device"
    Identifier "VESA"
    Driver "i810"
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
    #Option "AccelMethod" "XAA"
    Option "UseEvents" "True"
        Option "AccelMethod" "exa"
        Option "MigrationHeuristic" "greedy"
        Option "ExaNoComposite" "false"
        Option "ExaOptimizeMigration" "true"
EndSection

but the performance is not good enough yet...

in particular, when selecting log off in KDE the "darkening" effect is really slow...

has a solution been found for this problem yet?

I'm having the same problem in intrepid.
it has improved with Option "MigrationHeuristic" "greedy"
        Option "ExaNoComposite" "false"
        Option "ExaOptimizeMigration" "true"
intel batch has done nothing
thinkpad T60

Alan Tam (at) wrote :

Can any Ubuntu developer explain what does "Fix Released" mean?
Like others, in intrepid, I still need to add "MigrationHeuristic greedy" to fix EXA making everything slow when compiz is running. So what has been fixed?

1 comments hidden view all 171 comments

Who are you, and why are you spamming me?

On Thu, Dec 11, 2008 at 7:28 PM, Elias K Gardner <email address hidden> wrote:

>
> I think you will like it.
>
> Please accept or reject this invitation by clicking below:
>
> http://www.bebo.com/in/8284883029a71428419b135
>
> ......................................................................
> Please do not reply directly to this email.
>
> This email was sent to you at the direct request of Elias K Gardner
> <email address hidden>. You have not been added to a mailing list.
>
> If you would prefer not to receive invitations from ANY Bebo members
> please click here - http://www.bebo.com/unsub/8284883029a71428419
>
> Bebo, Inc., 795 Folsom St, 6th Floor, San Francisco, CA 94107, USA.
>
> --
> EXA is balls-achingly slow
> https://bugs.launchpad.net/bugs/177492
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Dan Quade (danquade) wrote :

I'm not spamming you I'm getting the same shit myself.

On Thu, Dec 11, 2008 at 7:52 PM, Thom Pischke <email address hidden>wrote:

> Who are you, and why are you spamming me?
>
> On Thu, Dec 11, 2008 at 7:28 PM, Elias K Gardner <email address hidden>
> wrote:
>
> >
> > I think you will like it.
> >
> > Please accept or reject this invitation by clicking below:
> >
> > http://www.bebo.com/in/8284883029a71428419b135
> >
> > ......................................................................
> > Please do not reply directly to this email.
> >
> > This email was sent to you at the direct request of Elias K Gardner
> > <email address hidden>. You have not been added to a mailing list.
> >
> > If you would prefer not to receive invitations from ANY Bebo members
> > please click here - http://www.bebo.com/unsub/8284883029a71428419
> >
> > Bebo, Inc., 795 Folsom St, 6th Floor, San Francisco, CA 94107, USA.
> >
> > --
> > EXA is balls-achingly slow
> > https://bugs.launchpad.net/bugs/177492
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
> --
> EXA is balls-achingly slow
> https://bugs.launchpad.net/bugs/177492
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Zack Cornelius (zcornelius) wrote :

The EXA Bug thread is not the time nor the place for self promotion.

On Thu, Dec 11, 2008 at 12:28 PM, Elias K Gardner <email address hidden> wrote:

>
> I think you will like it.
>
> Please accept or reject this invitation by clicking below:
>
> http://www.bebo.com/in/8284883029a71428419b135
>
> ......................................................................
> Please do not reply directly to this email.
>
> This email was sent to you at the direct request of Elias K Gardner
> <email address hidden>. You have not been added to a mailing list.
>
> If you would prefer not to receive invitations from ANY Bebo members
> please click here - http://www.bebo.com/unsub/8284883029a71428419
>
> Bebo, Inc., 795 Folsom St, 6th Floor, San Francisco, CA 94107, USA.
>
> --
> EXA is balls-achingly slow
> https://bugs.launchpad.net/bugs/177492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in "xserver-xorg-video-intel" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> The default acceleration mode in hardy, which I understand is EXA, is
> incredibly slow. The experience of running compiz with it is awful.
>
> Changing to XAA in the config file solves the issue, though then I
> obviously lose video.
>

Götz Christ (g-christ) wrote :

I'm also getting the same spam from <email address hidden>!
We should open a bug in lauchpad!
It seems that all this email are sent to gmail accounts.
What are the doing with our email address? That is not privacy.

On Thu, Dec 11, 2008 at 9:08 AM, unimatrix <email address hidden> wrote:

> I'm not spamming you I'm getting the same shit myself.
>
>
> On Thu, Dec 11, 2008 at 7:52 PM, Thom Pischke <<email address hidden>
> >wrote:
>
> > Who are you, and why are you spamming me?
> >
> > On Thu, Dec 11, 2008 at 7:28 PM, Elias K Gardner <email address hidden>
> > wrote:
> >
> > >
> > > I think you will like it.
> > >
> > > Please accept or reject this invitation by clicking below:
> > >
> > > http://www.bebo.com/in/8284883029a71428419b135
> > >
> > > ......................................................................
> > > Please do not reply directly to this email.
> > >
> > > This email was sent to you at the direct request of Elias K Gardner
> > > <email address hidden>. You have not been added to a mailing list.
> > >
> > > If you would prefer not to receive invitations from ANY Bebo members
> > > please click here - http://www.bebo.com/unsub/8284883029a71428419
> > >
> > > Bebo, Inc., 795 Folsom St, 6th Floor, San Francisco, CA 94107, USA.
> > >
> > > --
> > > EXA is balls-achingly slow
> > > https://bugs.launchpad.net/bugs/177492
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> >
> > --
> > EXA is balls-achingly slow
> > https://bugs.launchpad.net/bugs/177492
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
> --
> EXA is balls-achingly slow
> https://bugs.launchpad.net/bugs/177492
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Götz

I believe all of you have received an invite to bebo sent on my behalf. This
was a mistake.

This morning I joined the social networking site bebo which has recently
been bought by AOL Time Warner. They asked to search my email contacts for
people who already use bebo. I allowed this and selected three of my friends
who apparently currently have bebo accounts and clicked "add friends". Below
this button bebo had kindly listed and selected every email in my
addressbook which they promptly sent invites to without my knowledge.

Again I am deeply sorry.

I hope this is an appropriate way to attempt to correct the situation (I
realize it does mean getting two emails from me).

thanks for your understanding
elias k gardner

PS I am trying to contact bebo so that I may express to them how
*angry *(understatement
of my life) I am at being decieved like this. I have now spent the better
part of an hour copying the email addresses of who I believe bebo sent this
SPAM to and will doubtlessly never get my email address off of peoples spam
filters.

It actually looks like someone "Commented" on the EXA is balls achingly slow
bug with this spam.

On Thu, Dec 11, 2008 at 1:27 PM, G. Christ <email address hidden> wrote:

> I'm also getting the same spam from <email address hidden>!
> We should open a bug in lauchpad!
> It seems that all this email are sent to gmail accounts.
> What are the doing with our email address? That is not privacy.
>
>
> On Thu, Dec 11, 2008 at 9:08 AM, unimatrix <email address hidden> wrote:
>
> > I'm not spamming you I'm getting the same shit myself.
> >
> >
> > On Thu, Dec 11, 2008 at 7:52 PM, Thom Pischke <<email address hidden>
> > >wrote:
> >
> > > Who are you, and why are you spamming me?
> > >
> > > On Thu, Dec 11, 2008 at 7:28 PM, Elias K Gardner <email address hidden>
> > > wrote:
> > >
> > > >
> > > > I think you will like it.
> > > >
> > > > Please accept or reject this invitation by clicking below:
> > > >
> > > > http://www.bebo.com/in/8284883029a71428419b135
> > > >
> > > >
> ......................................................................
> > > > Please do not reply directly to this email.
> > > >
> > > > This email was sent to you at the direct request of Elias K Gardner
> > > > <email address hidden>. You have not been added to a mailing list.
> > > >
> > > > If you would prefer not to receive invitations from ANY Bebo members
> > > > please click here - http://www.bebo.com/unsub/8284883029a71428419
> > > >
> > > > Bebo, Inc., 795 Folsom St, 6th Floor, San Francisco, CA 94107, USA.
> > > >
> > > > --
> > > > EXA is balls-achingly slow
> > > > https://bugs.launchpad.net/bugs/177492
> > > > You received this bug notification because you are a direct
> subscriber
> > > > of the bug.
> > > >
> > >
> > > --
> > > EXA is balls-achingly slow
> > > https://bugs.launchpad.net/bugs/177492
> > > You received this bug notification because you are a direct subscriber
> > > of a duplicate bug.
> > >
> >
> > --
> > EXA is balls-achingly slow
> > https://bugs.launchpad.net/bugs/177492
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
> --
> Götz
>
> --
> EXA is balls-achingly slow
> https://bugs.launchpad.net/bugs/177492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in "xserver-xorg-video-intel" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> The default acceleration mode in hardy, which I understand is EXA, is
> incredibly slow. The experience of running compiz with it is awful.
>
> Changing to XAA in the config file solves the issue, though then I
> obviously lose video.
>

Alan Tam wrote:
> Can any Ubuntu developer explain what does "Fix Released" mean?

I am not an Ubuntu developer but Fix Released means that the appropriate
fix for the bug has been released as part of the latest (usually
development) version of the package in question.

Shriramana Sharma.

Dan Quade (danquade) wrote :

Why is #193318 a dupe of this one? They are not related. #193318 concerns all video cards while this one is ATI-specific. Doesn't anyone moderate the dupes? How do you remove a dupe?

Søren Holm (sgh) wrote :

Why is the driver not fixed for the respective chipsets ?

kdawgud (kleber) wrote :

I had to use the Option "MigrationHeuristic" "greedy" in Jaunty to get reasonable performance on the intel GM45

juky (juraj-belina) wrote :

Just to confirm that:

        Option "AccelMethod" "EXA"
        Option "ExaNoComposite" "false"
 Option "MigrationHeuristic" "greedy"

did the trick for me on Fujitsu-Siemens and i945 chipset.

Athough, I tried only

 Option "MigrationHeuristic" "greedy"

and it also worked.

Cheers,
juky

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 171 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.