Ubuntu

[regression][rv280] black screen and console freeze when X starts - drm lockup

Reported by Quash on 2006-10-22
182
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned
Edgy
Undecided
Unassigned
Feisty
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
Edgy
Undecided
Unassigned
Feisty
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Critical
Kyle McMartin
Edgy
Critical
Unassigned
Feisty
Critical
Kyle McMartin

Bug Description

[Update by kyle@ for SRU, the problem is the ATI driver can cause the machine to lock up on AGP-based systems. This is important since effected users cannot start X. Further information is below including the debdiff for the fix:
https://launchpad.net/ubuntu/edgy/+source/xserver-xorg-video-ati/+bug/67487/comments/173]

Problem: Failure in booting in to Live Desktop 6.10.

Result: Screen Goes Black after boot phase, right as it enters the Desktop phase. Must power off to remedy.

Steps to Reproduce:
1) boot x386 CD and DVD (I've tested both)
2) choose either default Start/Install or Safe Graphics Start/Install
3) 6.10 boots and goes along without issue with the new Ubuntu boot splash.
4) It finishes the boot process, then goes to the standard momentary black screen with the white cursor in the upper-left corner.
5) Then, the screen goes black.

Using F4 VGA options doesn't solve the issue.

note: a signature of this particular bug is that selecting ctrl+alt+F1 through F6 does NOT bring up console either before or after you get a black screen. As a result, commands to change drivers as a workaround will not work with this bug, increasing its severity.

Test Specs:
ATI Radeon 9200 SE video card (AGP)
Compaq P1100 21' monitor and Acer 54e monitor
ASUS K8V SE Deluxe mobo
AMD Athlon XP 64 3000+ (I only load the 386 OS on to it, though)
512mb RAM.

note: when noting your specs in your report, please note if your video card is AGP or PCI-E, if you have an AMD 32 or 64 bit system (or Intel) and which Edgy OS you are loading. The more info, the better.

Known workarounds: Disable DRI or set AGP speed to 4x in BIOS settings.

Quash (quashed) on 2006-10-23
description: updated
Quash (quashed) on 2006-10-23
description: updated

I've done some more testing and I believe this is a real bug in the upcoming Edgy release.

I've used two monitors: Acer 54e (pretty generic monitor that works with everything) and my Compaq P1100, which is a more exotic 21" professional monitor, although the Compaq works with Breezy, Dapper, and recent Fedora and SuSE distros.

I ran a Dapper 6.06 CD with both monitors.
-The default Start/Install did not boot in to the desktop, going black after the boot sequence, identical to the above bug reported.
-The Safe Graphics mode did work with the Acer 54e monitor. It also worked with the Compaq P1100 when I chose VGA (I used the 768x1024 16 option).

The Edgy 6.10 CD or DVD does not get past the Ubuntu boot splash with either monitor, in either the Default or the Safe Graphics options, with or without using VGA mode options. It just doesn't boot in to the Desktop (formerly called Live CD).

Something has changed between Dapper and Edgy that will make it difficult for a certain number of people to boot in to the Desktop off the CD when checking out Ubuntu starting on Oct. 26th.

If people respond with possible workarounds (I need concrete steps), I'm happy to try to eliminate causes.

Quash (quashed) on 2006-10-23
description: updated
description: updated
description: updated
Quash (quashed) on 2006-10-23
description: updated
Quash (quashed) wrote :

Update: Tried doing Ctrl+Alt+F6 when my screen went blank. Didn't work. This is what I had planned to do:

Reconfigure X from CD and re-start:
alt + ctrl + F6
sudo dpkg-reconfigure xserver-xorg (reconfigure)
sudo /etc/init.d/gdm restart
Then ctrl+alt+f7 to go back to GDM

But, I can't bring up terminal.

Quash (quashed) on 2006-10-23
description: updated
arcanon (dvysor9) wrote :

I'm getting the blank screen problem using the release desktop CD. (ubuntu-6.10-desktop-i386.iso)

The system boots but instead of a login screen the display is blank. This problem occurs with the standard and safe graphics mode boot options.

Hardware: Ati Radeon 9800 pro, 19" LCD in DVI mode.

Noam Mor (noam-mor) wrote :

I have that problem too - The same black screen at start/install.

ATI Radeon 9800, LG L1932TQ (19" LCD) connected via DVI. It might be a drivers issue.

Eric Brissette (eric-brissette) wrote :

Same problem: UBUNTU logo shows, progress bar reaches the end, then the system hangs. Sometimes a black screen, sometimes some garbled pixels, sometimes a message that X couldn't start followed by a blinking cursor and no access to the command line.

I've got an AMD64 system, but I'm installing the i386 version of Edgy.

Processor: AMD64 3400+
Motherboard: DFI Lanparty NF4 Ultra-D
Video Card: ATI Radeon X800 XL

tcybulski (tcybulski) wrote :

Same problem, in general: UBUNTU boot splash shows, progress bar reaches the end, system will hang for a while with a flashing cursor, then I get the blue screen that says X could not start. Checked the error messages, got:
"ATI: PCI Mach64 in slot 1:0:0 could not be detected
ATI: PCI Mach64 in slot 1:0:1 could not be detected
Fatal server error
No screens found"

Neither Install nor Safe Graphics Mode work. Changing the VGA settings manually doesn't work either. With 6.06, I would have to go into safe graphics mode to get the live CD's X to start, but it would work. This one won't.

6.10 i386 Live CD

Processor: 3.2GHz Intel Core Duo
Video Card: ATI Radeon X600
Monitor: 20" Dell Wsomething2007

Quash (quashed) on 2006-10-28
description: updated

Unable to boot into 6.10 live desktop.

Tried standard both standard and safe install but all I get is a black screen with flashing cursor at top left.

I do hear sound when you would expect it to change to the login screen so I suspect that it's a graphics driver problem.

System specs are as follows.

AMD Athlon64 X2
Twin nVidia 6800GS graphics cards
Twin Western Digital 80GB SATA Drives
1GB Corsair RAM
Hyundai B91A monitor

whu (whu) wrote :

Just adding a comment to say I just re-install the 6.06 as my system completly hang on splash screen...

I've try to describe my config in : https://launchpad.net/distros/ubuntu/+bug/61064, but tonight I'm running out off idea...

My Siemens Scaleo HA 1313 Pro08, (see the complete config. within the bug report above) is running perfectly the 6.06 version.

Braker (samuele-innocenti) wrote :

I have the same problem: black screen after Start/Install from live CD with ATI Radeon 9550 SE. I update the distro 6.06 to 6.10 with apt-get but may be the results are not completely sound

sutur (bernhard-oberfichtner) wrote :

same here. i've tried every boot parameters i could think of, but cannot boot the live cd.
acer aspire 1692 laptop
1,73Ghz Celeron
Ati Radeon x700 256Mb

cam8001 (cameron-tod) wrote :

Similar problem here. I try to boot to the live environment. The menu starts up ok, and then kubuntu logo and loading progress bar show fine. At the point where I assume the x server starts, I geta green bar on the screen and the PC locks up. This happens in normal and safe graphics. I have tried disabling power management in the boot options.

Hardware:

MSI K8N Neo-F (nForce 4)
A64 3000+
Ati Radeon X850XTPE

JaFFa (bf5) wrote :

yep same here. Installed 6.10 fine, past the splash screen i get a black screen/no signal

I am using
Core Duo e6600
DS3 Gigabyte mobo
ATi X1900GT
2gb ram
2x monitors both on DVI both 19"

I am experiencing this problem with the Live CD as well.

AMD AthlonXP 2500+
ABIT NF7-S mobo
ATI Radion 9600XT (AGP)
1.5GB RAM
19" ViewSonic CRT on VGA

grkravi (grkravi) wrote :

I too have the same problem, i am using Dell Inspiron 5160 Laptop (855 chipset)
Dapper was working fine, using the vesa driver.
Is this black screen related to 855/915resolution ?
Both never worked with my laptop, failing with "unable to determine bios type" error.

pvande (pvande) wrote :

Same issue: booting from the LiveCD (Desktop) with any set of options causes the system to lock just as X should be starting.

Both the x86 and x86-64 CDs exhibit the same problem (notable: the usplash on the 64-bit version appears in shades of grey, with graphical artifacts).

Test Specs:
ATI Radeon 9200 SE video card
ViewSonic 19" LCD monitor
ASUS K8V SE Deluxe mobo
AMD Athlon XP 64 3200+
1GB RAM

Jonquil (vixenk) wrote :

I'm having this issue as well.

Intel Pentium 4 Northwood core processor
Sapphire Atlantis Radeon 9600 video card
Compaq 7550 flatscreen crt monitor
Abit A17 motherboard
2 x 512mb pc2700 ddr G. Skill ram

Downloaded the ISO three times and confirmed the MD5 checksum. Burned the ISO to disc 3 times and checked the data on the disc. Tried installing probably about 6 times, sometimes on the default vga setting and other times on a manual 1280x1024 vga setting.

Max Bossino (j-k9) wrote :

I am also experiencing this problem with the ATi Mobility Radeon X700XL. I have tried booting into the live CD using both the standard and safe install options, but after the bootsplash appears and the bar reaches the end I am presented with a black screen. I am able to hear Ubuntu's loading sound, but I can't see anything, so it must be a driver issue.
I cannot change to another runlevel either, as the black screen doesn't budge.

The only 'workaround' I found was to download the alternate CD, install Ubuntu 6.10 using the CLI installer, and then boot into a *different* live CD (Ubuntu locked up with this black screen whether I booted into its live CD or into the installed version), mount Ubuntu's root partition, chroot into the Ubuntu root directory, and install the proprietary ATi driver (first download the links web browser, browse to the ATi website, download the Linux driver, build a package for Ubuntu/edgy with it, install the package, restart). Then, when I restarted and booted into the installed version of Ubuntu, the GUI worked without any problems.
The ONLY issue I have found with this is that my system still locks up when I am shutting down, restarting, or changing runlevel, and I have to turn the laptop off manually (using the power button). Whenever I do one of those three things, I get a flurry of pinks, oranges and yellows on the screen, and I can't do anything but hit the power button.

carlos (carlos-porto) wrote :

Getting the same exact issue as everyone else. Get the splash screen and then all black. But I do hear the start up music.

My config is nvidia 6600gt with dual lcd monitors. On a P4 3ghz w/ gig of ram.

Slogger (slogger) wrote :

I have this problem too.
Specs:
Acer Ferrari 4005 Turion 64 2ghz 1gigRAM x700mobility radeon
Scree res 1650x1080
Starts up, see loading screen, then everything dies, though I hear sound.

Does this for safe mode and regular mode.

Suspect that specifying a custom boot resolution isn't working properly.
I saw on the forums that there is some sort of xorg.conf overide trying to set resolution to 1080x1080, or something?

1 comments hidden view all 243 comments

I think I struck a similar issue under a slightly different situation:

Running the 6.10 desktop CD under MS Virtual PC.

It does most of the boot as above, flickers, then changes to a very very strange resolution that Virtual PC complains is too big for my monitor (but ubuntu thinks is 800x640, I think).

I tried most of the options from the vga menu (F4) and played with framebuffer and fb advanced options to see if that made any difference (some but not adequate).

I found that with sufficient squinting and cursing you could just about read what was on screen, and run through the installation process (with a few restarts because you can't see the install buttons at all).
Once it's installed I could boot in recovery mode and edit xorg.conf - the only change I needed to do was set the default color depth to 16 bit and it boots up beautifully.

From the documentation:
"Virtual PC emulates the S3 Trio 32/64 PCI video card. Virtual PC also supports VESA 2.0. Specify one of the two supported video cards when programs require manual configuration."

Screendump of virtual PC after the above issue.

With sufficient squinting you can read the menu bar
"Applications Places System "

I managed to install using this resolution, edit xorg.conf change color depth and now it's good

Quash (quashed) on 2006-10-31
description: updated
Mehdi (mehdid) wrote :

yep same here. Installed 6.10 fine, past the splash screen i get a black screen/no signal. and no way to get terminal with Ctrl+Alt+F{1-6} :'(

test specs :
Laptop Asus M6VA
Intel Centrino 1.7 Ghz
1024 mb ram
ATI Radeon Mobility X700 128mb

Slogger (slogger) wrote :

Notice that we all have ATI graphics? Someone wasn't paying atention to ATI graphics when they made the live disk. I'm adding ATI words to the keywords.

Slogger (slogger) wrote :

And I think this should be critical because I'm betting its got a quick fix and because it causes a major problem if you are trying to convert people:

insert live cd... hums along. Then everything dies. Then they'll REALLY want to install Ubuntu, lol.

The strangest thing happened to me the other day. I decided to give
downloading and burning the live cd one more shot. And... *gasp!* it
worked! Does anyone know why this would have happened? I verified both
the MD5 checksum and the data on each disc I tried downloading and
burning.

Note:

I scanned the comments above and the vast majority were in fact configurations with ATI graphics. There were two comments referring to nVidia graphics cards, but in both cases the users could here the startup music; this indicates that it is NOT the same problem.

I concur with the assessment that this is a configuration issue between the LiveCD and a large number of Radeon cards.

-Scott

Rob Oxspring (roxspring) wrote :

I found exactly the same problem with the live CD (ATI Radeon 9200, Athlon64, Edgy x86_64) but decided I'd try installing via the alternate CD's text mode anyway and saw exactly the same again. I've managed to get in to recovery mode via grub and changing the graphics driver to use 'vesa', or installing and switching to 'fglrx' works fine. As far as I can see this points pretty strongly to the 'ati' driver currently not working with a bunch of Radeon cards out in the wild.

Quash (quashed) wrote :

-This bug first filed Oct 22/06.
Since that time:

-Zero acknowledgment from Ubuntu bug maintainers of this bug report.
Status: Still Unconfirmed Importance: Still Undecided Assigned: Still Not Assigned.

-Over 20 bug reports from other users experiencing similar issues to this bug since that time in this bug report, along with countless similar reports on Ubuntu Forums, other forums, on chat rooms, on blog and filings to Digg and Slashdot.

Bug Severity: Critical. People simply can't load Edgy Live Desktop.

Workaround: You can't work around it with ctrl-alt-F1 to get to console.

Solution: Please continue to report this bug here, even though Ubuntu Devs are ignoring it. As part of this, please read the initial report closely to ensure you are experiencing the same bug and not a similar variation. Please all your hardware specs and clearly outline the steps you took up to experiencing the bug.

Joppe Bos (jwbos) wrote :

The same here, installing with the Edgy Eft AMD64 installation CD. After the boot menu I see a very vague Ubuntu logo and after 3 a 4 minutes of loading my monitor reports "No signal" and everything is black. I cannot jump to another shell.
Running in safe graphic mode is of no use just as with the suggested -noapic kernel boot option.
I also have a ATI card: a Radeon 9600 which work fine with Dapper (the upgrade failed miserably so to get a working system I tried to install from scratch with this ISO). I also really really think more testing should be performed in the future to avoid these situations since this will scare away potential new users!

I am downloading the Dapper ISO right now, I will try Edgy Eft in a few months when all the nasty bugs are (hopefully) fixed.

I'm sorry this bug has gone unnoticed for so long. This wasn't a failing of the devs, but rather of bug triagers (like myself!). Looking over the comments on this bug, it seems several people have the exact same problem, so I'm going to go ahead and bump it to confirmed and let whatever dev wants to jump on it handle it from here.

Many apologies, and much thanks!

Tollef Fog Heen (tfheen) wrote :

Most likely an xorg bug.

As a workaround, could you try to remove "splash" from the command line when booting the CD? (Press F5 to get an editable command line) and see if that helps?

Quash (quashed) wrote :

Tollef, have tried changing the boot parameters to get rid of splash. Hasn't helped. If you provide a specific boot parameter line/example, that might help. But, all my efforts to change boot parameters and remove the splash failed.

Slogger (slogger) wrote :

So going back over this, and after trying out the disk on multiple dorm-mates comps, I have come to the conclusion that there are 2 separate bugs here:

People who get a flashing black cursor in the top left (possibly not waiting long enough for system to load?)
and people who have ALL displays (1-8, including x-windows) go dead, though they may be running (sounds seems to work).
The ones with the dead screens almost ALL seem to be combination of AMD processor and ATI graphics.

Anybody else agree?

Quash (quashed) wrote :

Slogger, I seem to be experiencing both issues.
1) I see the flashing cursor in top left for a brief moment.
2) I then move in to dead black screen.

Can't confirm if I actually go in to the system and just can't see it, as I don't hear any sounds.

Seems to be a number of us who having AMD64, ATI and Edgy386OS combos, though.

Slogger (slogger) wrote :

Workaround: getting to console:
OK. I tried that. (suggestion of removing splash from boot line.) GDM monitor died, but it did let me get into consoles on the other x-windows, which didn't work with splash in the line. I checked out the xorg.conf, and it set the setting under device that normally reads driver "fglrx" (for ati proprietary on my comp) said "ati". I have never seen/had a working x with "ati" listed under driver. (Is this the driver for non proprietary?) That's probably the problem. Anyhow, it seemed ot work by changing it back to a non-hardware driver. What I don't understand is why everyone I know with an Intel doesn't have this problem and everyone I know with an AMD does.

Anyhow, that should allow people to work around and do a custom xorg.conf.

description: updated
description: updated
Slogger (slogger) wrote :

Yeah, using this method you can change your display driver for the live CD to vesa, and then reload gdm, which will run, though somewhat slowly (IMO). It checked out.

So pretty much at boot screen, you hit f6 or whichever button brings up custom boot line.

Then delete the "[COLOR="Blue"]splash[/COLOR]" from it. Hit enter.

Sit there while it looks like it's doing nothing, eventually some console stuff will roll past, it will switch to screen 7, which will then power off.

At this point you have use of your console screens still, thankfully. ([COLOR="Lime"]ctrl-alt-f1[/COLOR]) then change xorg.conf to use [COLOR="Blue"]vesa[/COLOR]

([COLOR="Blue"]sudo nano /etc/X11/xorg.conf[/COLOR]). Change this by adding a [COLOR="Blue"]load "vesa"[/COLOR] under [COLOR="Blue"]module[/COLOR] section, the same section as load glx and dri and all the other ones.

next, under "Device" section:

change [COLOR="Blue"]Driver "ati"[/COLOR] to [COLOR="Blue"]Driver "vesa"[/COLOR] and write out the changes.

go back to screen 7 ([COLOR="Lime"]ctrl+alt-f7[/COLOR]) and hit [COLOR="Lime"]ctrl-alt-bkspc[/COLOR] to reload gmd.

My machine then loaded a laggy vesa powered gdm session @ 1400x1050 res (who knows how it came up with that res, possible I didn't enter vesa stuff correctly in xorg.conf) which worked fine until I tried to switch resolutions, which made it crash again.

Anyhow, I guess that gets the live cd "working."

Well SLogger, I'm glad that worked for you, but removing 'splash' from the boot line (or any other modification of it I've been able to dream up so far) has not had any effect for me; I still cannot access any of the console screens.

I still get the same blank screen after the cursor shows up for a second in the top left corner, no sound, and not able to do anything.

It's a workaround worth trying if you're experiencing this problem, but it is by no means a solution; at least not until we get several other success stories from using it.

Slogger (slogger) wrote :

Scott, are you the only one listed with AGP graphics?

If I haven't posted I have
Turion64 2.0ghz +1gig ddr333+ati Mobility Radeon x700 (PCIE)

Quash (quashed) on 2006-11-02
description: updated
Quash (quashed) wrote :

Slogger, I am also AGP graphics and have update the big report to reflect this. You tease out a good point that people need to list when they post their specs.

I just tried out your commands. No dice. This is what happens:

1) F6 at start screen to bring up boot parameters.
2) Remove "splash" and hit enter.
3) I see the following for a few minutes:
"[17179576.380000] usb 1-1:device not accepting address 2, error -71"

4) scroll after a few minutes that quickly leads to login: ubuntu@ubuntu:
5) However, whether I type ctrl+alt+F1 through F6, or "GDM" or "sudo nano..." the screen flips over to, I think, X (before I can even finish typing a command often) and I hit the same black screen again.

Not sure how to proceed.

description: updated
Slogger (slogger) on 2006-11-02
description: updated
description: updated
Changed in xorg:
importance: High → Critical
Changed in xserver-xorg-video-ati:
assignee: nobody → ubuntu-kernel-video
Quash (quashed) on 2006-11-03
description: updated
Changed in linux-meta:
assignee: ubuntu-kernel-video → nobody
robepisc (robepisc) on 2006-11-04
Changed in linux-meta:
status: Unconfirmed → Rejected
Changed in linux-meta:
status: Rejected → Unconfirmed
description: updated
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed
Kyle McMartin (kyle) on 2007-01-26
Changed in linux-source-2.6.17:
status: Unconfirmed → Rejected
Kyle McMartin (kyle) on 2007-01-26
Changed in xserver-xorg-video-ati:
status: Confirmed → Fix Released
assignee: nobody → kyle
Changed in xorg:
status: Unconfirmed → Rejected
Kyle McMartin (kyle) on 2007-01-26
Changed in linux-source-2.6.17:
status: Unconfirmed → Rejected
Changed in xorg:
status: Unconfirmed → Rejected
Kyle McMartin (kyle) on 2007-01-26
Changed in xserver-xorg-video-ati:
importance: Undecided → Critical
status: Unconfirmed → Confirmed
description: updated
163 comments hidden view all 243 comments
Tormod Volden (tormodvolden) wrote :

Kyle, I had applied both fd.o git 295823d0879a5b574bb79843a6acd43adb9259e5 (radeon: Default to leaving AGP transfer mode and fast writes unchanged) and c54a31565e3ea50f1af7b81b1bf0c0e437099f47 (radeon: fixup fastwrites to be always off). I believe your patch was one line taken from the latter. Do you think AGP mismatch is fine as long as one turns off fastwrites?

(for completeness, my test package also had f5ffb9fb3bdd7cec020240c5831ae92ee744972c (ati: fix detection of some newer radeons using ati wrapper) for bug #28925, which came in the official 1:6.6.2-0ubuntu5)

Arthur Penn (arthur-penn) wrote :

Monica/Tormod, thanks for your instructions. Before testing, I applied Kyle's latest package at http://people.ubuntu.com/~kyle/xserver-xorg-video-ati_6.6.2-0ubuntu6_i386.deb.

> - If you set the AGP speed in the BIOS from 8x to 4x, does the bug disappear?

My BIOS only recognizes 1x and 4x AGP, and it's set to 4x.

> - If you comment out the line
# Load "dri"
in the modules section of your xorg.conf (while AGP speed is set to 8x in the BIOS), does the bug disappear?

Yes. I have restarted X ten times in a row after doing this without fail. This is the only thing that has corrected the intermittent problem. In any other case, within 2-3 X restarts it goes to the black screen and hangs.

- If you add
Option "AGPMode" "8"
to the device section of the graphics card in the xorg.conf (while AGP speed is set to 8x in the BIOS and dri is not commented out) does the bug disappear?

It does not unless the dri load is also commented out.

What do you think? Is it the same bug, or should I reopen the other issue (how would I do that?). Thanks!

I tried the Herd 3 CD, and the bug is fixed for me as well!
(8x agp, and no freeze. no additional tweaks needed.)

Thanks to everyone who contributed :)

On 2/2/07, Arthur Penn <email address hidden> wrote:
> Monica/Tormod, thanks for your instructions. Before testing, I applied
> Kyle's latest package at http://people.ubuntu.com/~kyle/xserver-xorg-
> video-ati_6.6.2-0ubuntu6_i386.deb.
>
> > - If you set the AGP speed in the BIOS from 8x to 4x, does the bug
> disappear?
>
> My BIOS only recognizes 1x and 4x AGP, and it's set to 4x.
>
> > - If you comment out the line
> # Load "dri"
> in the modules section of your xorg.conf (while AGP speed is set to 8x in the BIOS), does the bug disappear?
>
> Yes. I have restarted X ten times in a row after doing this without
> fail. This is the only thing that has corrected the intermittent
> problem. In any other case, within 2-3 X restarts it goes to the black
> screen and hangs.
>
> - If you add
> Option "AGPMode" "8"
> to the device section of the graphics card in the xorg.conf (while AGP speed is set to 8x in the BIOS and dri is not commented out) does the bug disappear?
>
> It does not unless the dri load is also commented out.
>
> What do you think? Is it the same bug, or should I reopen the other
> issue (how would I do that?). Thanks!
>
> --
> [regression][rv280] black screen and console freeze when X starts - drm lockup
> https://launchpad.net/bugs/67487
>

Daniel Moyne (dmoyne) wrote :

All this has become very very confusing ! ; can we split bug reports between i586 machines and AMD 64 machines ; also some people about fix speak about AGP cards but most of the new ATI video cards are PCIE can we here sort out the types of video cards ?
Thanks.

Monika Eggers (monikakrug) wrote :

It has not become confusing because there are 32bit and 64bit reports, nor because there are AGP and PCI-E users, and there is no need to split the reports. Each time both groups experience the same problems.

It has become a little confusing because of people with x600 and x700 cards, who really experience a problem with usplash (they can hear the startup sound and removing splash from the boot parameters solves the problem), but that's not their fault (it appears like the same problem first).

It has also become confusing because of people like you who obviously experience a different problem but insist on posting here again and again. It should have been painfully obvious for you from the beginning, but as it isn't, I will point it out in detail to you:
- This bug is only about the ati driver, yet you use the fglrx driver.
- This bug is only about computers that freeze each and every time, but yours only freezes occassionally.
- This bug is about the Live CD, but you have installed. You never even tried if the Live CD caused problems for you, or if you did, you didn't mention it here.

So now can you please unsubscribe from this bug, never post to it again, and try to get help for your totally unconnected problem in an Ubuntu forum or IRC channel?

For those who actually do something helpful here: I made a list of the video cards and CPUs that have been posted and what the people said which workarounds worked for them, like this:

name:
video card:
AGP / PCI:
CPU:
i386 / AMD64 Ubuntu CD:
commenting out 'load "dri"' in xorg.conf helps?
setting AGP speed in BIOS to 4x helps?
adding 'Option "AGPMode" "8"' to xorg.conf helps?
Feisty Herd 3 works?

Marking as fixed, reports say it did help.

Daniel Moyne (dmoyne) wrote :

Sorry :

I entirely disagree with your diagnosis :

"It has also become confusing because of people like you who obviously experience a different problem but insist on posting here again and again. It should have been painfully obvious for you from the beginning, but as it isn't, I will point it out in detail to you:
 - This bug is only about the ati driver, yet you use the fglrx driver.
 - This bug is only about computers that freeze each and every time, but yours only freezes occassionally."

On the manifestation of the bug FROM TIME TO TIME on my AMD 64 MACHINE with RADEON X300 VIDEO CARD it is exactly the same diagnosis : I CANNOT ACCESS CONSOLE MODE ON BLACK SCREEN.

This is the reason I said it is copnfusing simply because the spectrum of occurances on that very same diagnosis is very wide !

I tried a live CD from time to time to fix my system and as far as I know I never experienced the bug though nobody asked me to do so and anyways the live CD is now a different system compared to my installed one with plenty of upgrades.

I plan to test Feistry in parallel.

If you think that I have nothing to say about my bug that has been on from the very beginning of Edgy on #67487 topics you simply tell my so.

Tormod Volden (tormodvolden) wrote :

As can be read in the bug description, this bug is only about AGP cards. Please don't mix up diagnosis with symptoms: a black screen can have very many reasons, which are not the same bug. We need to pinpoint each of these reasons in order to fix them, and this must be done in separate bug reports.

With the risk of repeating myself, I would like to encourage as many as possible to read https://wiki.ubuntu.com/Bugs/AtiDriver before posting more here.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
rsampaio (rafaicm) wrote :

Same error on my machine. I try to load the latest feisty release and I am contemplated with a black screen and a white cursor in the corner right after the ubuntu logo disappears.

My specs are as follows:

Dell Optiplex GX260
Intel Pentium 4 1.8ghz
1GB Ram
Ati Radeon 9200

Hi, you should file a separate bug report, as the problem you are
having is different (this one doesn't have a cursor in the corner) and
this bug seems to have been fixed in feisty.
Eric

On 2/14/07, rsampaio <email address hidden> wrote:
> Same error on my machine. I try to load the latest feisty release and I
> am contemplated with a black screen and a white cursor in the corner
> right after the ubuntu logo disappears.
>
> My specs are as follows:
>
> Dell Optiplex GX260
> Intel Pentium 4 1.8ghz
> 1GB Ram
> Ati Radeon 9200
>
> --
> [regression][rv280] black screen and console freeze when X starts - drm lockup
> https://launchpad.net/bugs/67487
>

HomeUser (dirk-p) wrote :

Same problem. AMD 64 (3000+) / Asus moterhbord VIA chipser / ATI RADION 9800 PRO
Desktop disk (i386) should work, gave the Gnome desktop on another pc (still, mouse didn't move, 2 X bad luck with trying Ubuntu)

If I remove splach+quit from the command line I get all the message and no longer only the cursor on top of the screen before the screen blanks.

Those messages looked normal:
There was one message about weird date for the ATI remote control.

After a message that X or Gnome was started , I don't remember, two messages about the printing system (cups) appaered. Then the screen blanks completly.

For me the system is alive looking at the disk-activity led. And if I touch the power button to soon (to force the system down by keeping is pressed for some time) I get instantly a sound.

What would happen if the root parameter for the kernel would be set to an existing ext3 partition. Would we be able to retrieve the Xorg logfile afterwards?

Would it be possible to use the CD and with an other Linux distribution, installed on my system, to install Ubuntu on a partion (ext2?)? So I could try to debug the problem on that installation.

Tormod Volden (tormodvolden) wrote :

homeuser, did you try Kyle's packages from comment #193?

HomeUser (dirk-p) wrote :

I think I understand now.
Either I use
feisty-desktop-i386.iso (or 64 bit version) herd 4
or
I change the bios-settings for AGP from 8X to 4X and/or disable fast writing, then install the ubuntu-6.10-desktop-i386.iso (or 64 bit version)
and then install the fix from http://people.ubuntu.com/~kyle/xserver-xorg-video-ati_6.6.2-0ubuntu5_i386.deb (or 64 bit) as a package so I can set the bios to its original AGP settings.

Both live CD’s are starting the graphic shell now.

I downloaded only a week ago the ISO image. Google send me first to this page. I red some of these comments. But I missed that a fix was already available from the beginning of February . I suppose somewhere else a shorter notification is exists.

Thanks.

cropr (ruben-decrop) wrote :

I am experiencing the same black screen with an XGI Volari card in Edgy. In Dapper there are no issues to boot

Tormod Volden (tormodvolden) wrote :

It seems like AGPFastWrite is again enabled by default in Feisty. I installed Feisty Beta and upgraded March 31st on a friend's PC with ATI Radeon 8500 (R200) and it would always hang after using for instance glxgears. I added Option "AGPFastWrite" "false" and now it runs stable. The man page says the option is off by default, but I am pretty sure it helped to disable it explicitely. Unfortunately I didn't save the log files. Maybe someone else can confirm this?

Benoit Chesneau (bchesneau) wrote :

I have the same problem on my computer. The sceen is blank after load of kernel. I have 2 cards on this pc :
1 pci ati and 1 agp : nvidia

Screen was pliugged only on nvidia but xorg was condigured to use ati card. Screen was good in xorg. After edited xorg.conf and replace the device line from ati and nvidia + busid line it worked.

Something is wrong in screen detection.

Tormod Volden (tormodvolden) wrote :

Benoit, you have another problem, please file a new bug. You have a PCI ATI card and this bug is only about AGP cards.

Tormod Volden (tormodvolden) wrote :

Checking the src/radeon_driver.c and src/radeon_dri.c did not confirm my suspicions. On the contrary, AFAICT, fast writes are always off (not just by default, and whatever xorg.conf says) because of patch 102_radeon_fix_agp_fastwrite.diff. However, it seems that the default is off (without this patch) so I suggest dropping the patch. It was relevant in the older versions, where the driver would read the setting from the BIOS and use that as a default (unless xorg.conf said differently), but nowadays the driver just uses its own default (off).

Since my own experience from my previous comment contradicts my analysis of the source code, it would be good if someone else would check as well :)

Mani (saberimba) wrote :

I'm not sure if it is related but during tweak testing, I've found that the combination of setting the AGPMode and AGPFastWrite somehow conflict. For me setting them both locks up xorg. So I leave out AGPFastWrite which makes it default to off on both Edgy and Feisty.

S.Rey (s.rey) wrote :

I confirm this same problem in Feisty beta 7.04

My laptop is a Fujitsu-Siemens Amilo PI1536, Core Duo T2300 1,66, 1Gb RAM, ATI Mobility Radeon X1400

Neither safe mode, vga options nor noapic, nolapic makes any difference.
I can't access TTYs (there's no login), so I cannot make the trick of modifying the xorg.conf

If it's related to xserver-xorg-video-ati, AFAIK, that driver doesn't work at all with x1000 series ATI cards, so i think the vesa driver should be used instead.

Maybe a xorg vesa option could be added in the boot menu for these situations ?

Tormod Volden (tormodvolden) wrote :

> Maybe a xorg vesa option could be added in the boot menu for these situations ?
The "Safe Graphics Mode" in the CD boot menu is supposed to do exactly that, to force the use of the "vesa" driver. Anyway, since the X1?00 cards are not supported by the "ati" driver, the "vesa" driver should automatically be picked. (And the user can then later install the "fglrx" driver by using the Restricted Drivers Manager.

Note that any issues with X1?00 cards are totally off-topic for this bug for the same reasons.

hohead (x2002ugp) wrote :

I'd like to add that this bug is still an issue in Feisty Final 7.04.

Downloaded Desktop AMD64 version using bittorrent, and burnt to both DVD and CD using slow burn speeds.

AMD64 3500, 2GB RAM, Radeon X800 PCIE, ASUS A8V (I think).

No matter what I hit in the main Ubuntu boot screen, it shows that it loads the kernel, then suddenly my screen goes blank and DVD drive spins down.

I'm attempting to download the "alternative" install CD now.

Tormod Volden (tormodvolden) wrote :

> No matter what I hit in the main Ubuntu boot screen,

If it crashes with the "safe graphics mode" (-> vesa driver instead of ati) it means it has nothing to do with this bug. From what you explain, it crashes before X is even started.

S.Rey (s.rey) wrote :

In Feisty final, the same symptoms occur.

The only different thing is that when X fails to initialize, I somehow managed to reach the login in tty ( I couldn't do it before).
From here I could edit the xorg.conf, and confirm that vesa driver was being used.

Since this bug is related to ati driver, I suppose what I see is another unrelated bug. Maybe a vesa driver bug?

Niels tijssen (tijssenn) wrote :
Download full text (4.6 KiB)

I have a similar bug on my ubuntu test box with the following specs.

Specificiations

Ubuntu Feisty 7.04
RevisMion history /
Initial install Dapper Drake, Upgraded From Dapper To Edgy and from Edgy to Feisty.

CPU AMD athlon 64 3200 +
Video card Ati Radeon X800 pro.
Installed FGLRX driver.
Monitor Samsung 940BF tft screen connected via a DVI cable.

Installed dapper without problems, and was able to perform the upgrades during one year.
During my Linux use i tried to tame X but I encountered some problems.

1. When my monitor is auto detected as "Plug and play" in the options, the black screen of death appears and only single user mode enables me to restore xorg.conf
2. Manually defining my monitor as a 1280X1024 monitor with a 74 hz refresh rate solves my problem.
3 Defining my monitor as a generic TFT screen with a resolution of 1280X1024 leads to image corruption and a non-working mouse.

But the tricky part was, that I wanted to reinstall feisty from CD, to start anew to solve some other problems, the black screen appears again when booting from the installer CD.
And of course X dies a horrible death. But at least I encounter a similar prolem with a functional X system, so here are some xorg.0.log entries from a "black screen situation".

First Xorg.0.log from my working system (note, it already contains errors).

Xorg.0.log from working system

tijssenn@tijssenn-desktop:/var/log$ cat Xorg.0.log.old | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 7
(EE) fglrx(0): GART is not initialized, disabling DRI
(EE) AIGLX: Screen 0 is not DRI capable
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) AIGLX: Screen 0 is not DRI capable
(EE) ...

Read more...

Mike Agnew (magnew-euronet) wrote :

I have a (Club 3d) ATI Radeon 9250 PCI 128MB (in an old Dell Optiplex GX1 with 384MB so PCI was the only option). Am running feisty with xserver-xorg-video-ati 1:6.6.3 installed. Same problem. vesa driver works OK. ati driver gives the black screen and console freeze every time I try. If I disable ¨dri¨ in xorg.conf then I can use the ati driver but then I guess thats almost the same as vesa. So not good performance of any kind since it is not direct to the Radeon 9250 card. Have attached the xorg,cong that I am using which has ¨dri¨ disabled. I did look at my /var/log/Xorg.0.log and really did not see any errors when I had the back screen.

PS I did try fglrx but was not successful due to version incompatibilities. (Could not really install the last ATI Radeon driver 8.28.8 that works for the 9250 in feisty - the new ATI Radeon driver is too new for the 9250). Ended up re-installing feisty to get back to where I am now.

Tormod Volden (tormodvolden) wrote :

Mike, you have another problem, please file a new bug. You have a PCI card and this bug is only about AGP cards.

Mike Agnew (magnew-euronet) wrote :

Resubmitted Radeon 9250 PCI error as bug # 114520

Tormod Volden (tormodvolden) wrote :

> Checking the src/radeon_driver.c and src/radeon_dri.c did not confirm my suspicions. On the contrary, AFAICT, fast writes are always off (not just by default, and whatever xorg.conf says) because of patch 102_radeon_fix_agp_fastwrite.diff. However, it seems that the default is off (without this patch) so I suggest dropping the patch. It was relevant in the older versions, where the driver would read the setting from the BIOS and use that as a default (unless xorg.conf said differently), but nowadays the driver just uses its own default (off).

I have posted a corrected patch in bug #115517.

I have a Dell Dimension E310 with an Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04) and a PCI ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] (prog-if 00 [VGA]) I can use the Intel 915 (it only has one output) or I can use the Radeon 7000 in Single and Dual screen configurations. But when I try to use both (like I always do in Windows XP) X11 crashes. Here is the error:
...

(WW) intel(1): ESR is 0x00000010, page table error
(WW) intel(1): PGTBL_ER is 0x00100003, host gtt pte, host pte data, CS instruction GTT PTE
(WW) intel(1): PGTBL_CTL (0x00000000) indicates GTT is disabled
(WW) intel(1): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(1): PRB0_HEAD (0x00000000) and PRB0_TAIL (0x00000008) indicate ring buffer not flushed
(WW) intel(1): Existing errors found in hardware state.
Error in I830WaitLpRing(), now is 339769, start is 337768
pgetbl_ctl: 0x0 pgetbl_err: 0x100003
ipeir: 0 iphdr: 0
LP ring tail: 8 head: 0 len: 1f001 start 0
eir: 0 esr: 10 emr: ffff
instdone: ffc1 instpm: 0
memmode: 10f instps: 800f08c0
hwstam: ffff ier: 0 imr: ffff iir: 0
space: 131056 wanted 131064

Fatal server error:
lockup
...

Anyone know if it is possible for me to use all three screens at once in Kubuntu Feisty? If I am posting to the wrong forum, can someone tell me where I should post? Attached you'll find the xorg.conf file. I'll attach the complete log file in other post since I don't think this allows me to attach two files.

1 comments hidden view all 243 comments
Timo Aaltonen (tjaalton) wrote :

We won't be updating the driver on edgy anymore. Closing the bug.

Changed in xserver-xorg-video-ati:
status: Confirmed → Invalid
DarkMageZ (darkmagez) wrote :

but edgy is still supported apparently... "April 2008". if this is how the "supported for 18 months" are "supported" then you might as well not bother "supporting" them at all.

Timo Aaltonen (tjaalton) wrote :

"support" means more like security updates... driver updates are risky, and the focus is always on the current development version.

Tormod Volden (tormodvolden) wrote :

In this case there is also an easy workaround available: Disable fastwrites and adjust AGP speed in the BIOS settings and/or xorg.conf

(Those who have been running Edgy for years probably know this by now. This issue was most critical for new installations and live CDs.)

G'day,

I believe I am experiencing this same problem so many years later. My install is Hardy Heron, amd64. I have rebuilt most of the system without replacing the video card. Before the rebuild and under 32-bit gutsy the card appeared to function correctly. After the rebuild and under 64-bit hardy I get nowhere.

From lspci:
04:01.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
04:01.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary) (rev 01)
More detailed output attached.

It's hard to get diagnostics out as the console is inaccessible from the moment gdm starts. I cannot change back to a text console. Caps-lock is non-responsive. From a remote machine I have managed to log in and observe X sitting at 100% load on one of my cores, and the machine runs slowly.

I have tried adding Option "DefaultConnectorTable" "on", hoping this was a dupe of Bug 157408. My current workaround is to add Driver "vesa" to the Device section of xorg.conf.

I can supply more details if required.

Benjamin.

1 comments hidden view all 243 comments
Tormod Volden (tormodvolden) wrote :

fuzzyBSc, please open a new bug for your issue. This bug is closed and the issue here was fixed in Feisty.

centx (centx) wrote :

I think I'm affected by this bug, got it first time with 9.04, but since fglrx worked (installed it from console alt+f1), I didn't care much.

Only difference is that I actually can change to vt's, but it freezes if I change back to X after being a vt.

Edmond Thiebaud (thiebaude) wrote :

I have fixed this problem for me. Dell Optiplex GX-150 1gz, 512mb ram, Intel I815 graphics card. Ubuntu 9.04

I did a gksudo gedit /etc/X11/xorg.conf

added to the Device: section

Option "DRI" "off"

and save

This is the only way i found fixes the problem, and yes if i take that out of the Xorg.conf then X will freeze and then the mouse freezes up.

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Changed in xserver-xorg-driver-ati:
importance: Medium → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 243 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.