Some windows do not render with "Desktop Effects" enabled on some hardware

Bug #89189 reported by Jussi Schultink on 2007-03-02
280
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

The "XAANoOffscreenPixmaps" option is required to be on in xorg.conf on some graphics hardware/driver configurations, otherwise many windows either show up blank or their rendering freezes.

Known affected hardware:
 • ATI R300 (radeon)
 • ATI R350 (radeon)
 • ATI RV250 (radeon)
 • Intel (i810)

-- Original Description --

Binary package hint: gedit

When saving in gedit, no text appears in "save as" dialog box. This also happens with other applications such as keyring on startup.

ProblemType: Bug
Date: Fri Mar 2 13:57:49 2007
DistroRelease: Ubuntu 7.04
Uname: Linux jussi-laptop 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Related branches

Jussi Schultink (jussi01) wrote :
Daniel Holbach (dholbach) wrote :

Thanks for your bug report. Do you use beryl or compiz? Which video driver do you use? Can you check the output of ~/.xsession-errors for anything interesting?

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Jussi Schultink (jussi01) wrote :

Hi, I use compiz (desktop effects) included with feisty. Attached is the output of my ~/.xsession-errors after a clean restart.

Jussi Schultink (jussi01) wrote :

Also, I am using the built-in driver for the Intel 915.

Sebastien Bacher (seb128) wrote :

Does it happen without using compiz?

Jussi Schultink (jussi01) wrote :

No, without compiz all is ok.

Sebastien Bacher (seb128) wrote :

compiz or xorg bug then

Changed in gedit:
assignee: desktop-bugs → nobody
status: Needs Info → Unconfirmed
Travis Watkins (amaranth) wrote :

This is an xorg bug. You need XAANoOffscreenPixmaps turned on in your xorg.conf to work around it.

Alexander Jones (alex-weej) wrote :

Please update bug title and description. Also affects ATI R350 and R250 on r200 DRI.

Brian Pitts (bpitts) wrote :

I can confirm that XAANoOffscreenPixmaps fixed the issue on a 15" Powerbook with the radeon driver.

Is there a set back to having that option enabled by default?

Travis Watkins (amaranth) wrote :

Yes, it makes performance really bad when you aren't using compiz.

Brian Pitts (bpitts) wrote :

Either
1) XAANoOffscreenPixmaps needs to be added at install if the radeon driver is chosen
2) Desktop Effects should be disabled for radeon
3) Desktop Effects should warn the user, add XAANoOffscreenPixmaps, then restart X

As it stands, users turn on Desktop Effects, think it is working, then realize the contents of newly-opened applications do not appear. This means that desktop effects can't be turned off, short of switching to another virtual console or opening a terminal and blindly typing pkill compiz.

description: updated

If I'm understanding things correctly this will actually be fixed in a much better way in a couple days.

This does happen on my Intel i810 card.

Since it's not radeon specific, I changed the summary.

Travis Watkins (amaranth) wrote :

This should be fixed with xserver-xorg-core 2:1.2.0-3ubuntu5 and compiz 1:0.3.6-1ubuntu10.

Changed in xorg:
status: Unconfirmed → Fix Released

A new xserver and compiz version have been uploaded to the repository a few hours ago.

Using the latest versions, one does not have to add the XAANoOffscreenPixmaps option anymore.

Works for me.

Works for me as well.

Huge thanks for fixing this to everybody who was involved. This was really needed (even though the workaround was easy).

Alexander Jones (alex-weej) wrote :

Blaaa, my email is lagging. Will check this fix out!

description: updated
Nicolò Chieffo (yelo3) on 2007-03-27
description: updated
description: updated

This new update broke something for me.
I have an i915 GM graphic card and for the first time I can't get Gnome working. The screen is clipping and appear to freeze Gnome or make it unusable...

My xsession-errors shows :
/usr/bin/compiz: ... Segmentation fault (core dumpled) /usr/bin/compiz.real $COMPIZ_OPTIONS "$@" $COMPIZ_PLUGINS
libGL warning : 3D driver claims to not support visual 0x5b
/usr/bin/compiz.real: No stencil buffer. Clipping of transformed windows is not going to be correct when screen is transformed.

After more investigation, I found out that what it causing this clipping problem is the compiz-extra package.

zeddock (zeddock) wrote :

I am on a Dell Dimension D800 with nv28, GeForce4 4200 and am seeing problem tonight after fresh install and complete update.

Zeddock

Sebastian Breier (tomcat42) wrote :

The fix works for me, but it seems only until I need to log out and log in again. After that it just stops working. I have to use the XAANoOffscreenPixmaps workaround to make it work reliably.

Can anybody confirm that this is indeed not fixed? (Try by logging out and logging in again)

Changed in xorg:
status: Fix Released → Needs Info
Gautam (gautam-cox) wrote :

I have this problem as well.

Sebastian Breier (tomcat42) wrote :

In that case, I'll reopen. Problem is not fixed completely.

Changed in xorg:
status: Needs Info → Confirmed
Michael B. Trausch (mtrausch) wrote :

That sounds like an issue with i810. I know that I have had that problem (with various other things, not directly with Desktop Effects) on an i810 setup with my Toshiba laptop. For example, sometimes switching from dual-head to single-head and back would make it so that a reboot was required before the X server would start back up again. X.org 7.2 seemed to fix most of those problems, though. Just a comment on the situation.

Bryn Hughes (linux-nashira) wrote :

This issue suddenly happened again out of nowhere on my i810 system - I now have XAANoOffscreenPixmaps enabled again in my config.

Not sure if this is related but I'm also having window drawing issues with some Java-based apps on an nVidia system - some application windows just show up plain grey while others draw properly but don't resize - the window frame resizes and the empty space is filled with grey, the application believes the window has resized but it never gets drawn.

Thom Pischke (thom-pischke) wrote :

I'm also seeing this consistently with some app windows on an HP zd7000 with Nvidia binary drivers. It happens consistently in certain apps. So far I've noticed it only in java programs.

I'm using Java 6. Azureus works fine, but IntelliJ Idea behaves VERY badly with desktop effects. I see everything from blank grey window to missing window decorations.

Bryn Hughes (linux-nashira) wrote :

I can confirm Thom's experience with Java applications... On both i810 and nVidia I've got a Java application that behaves VERY badly - many windows do not draw properly (plain grey window with no contents) and resizing windows doesn't work properly either. A few windows do draw but resizing them just results in grey space filling the additional space added to the window.

tamagoji (rpompei) wrote :

same problem for me:
some windows occasionally stop to refresh when desktop effects are enabled. i have a x300 ati video card.
i'm using the new ubuntu 7.4, should i add the option in xorg.conf as well?

Frost (frost-email) wrote :

Same problem here (Dell Inspiron 1300 with Intel915 video chip) : everything was running fine with the i810 driver under edgy (including compiz with cube etc) -- after upgrading to Feisty 7.04, I cannot run compiz anymore :(

I got this error first:

 gnome-window-decorator &GLX_EXT_texture_from_pixmap is not available with direct rendering.

If I uncomment the lines of /usr/bin/compiz script to get the recognition of direct/indirect rendering (I had no need for this under edgy...), I still have this errors when I run compiz:

frost@michelinux:~$ compiz --replace gconf

 gnome-window-decorator &GLX_EXT_texture_from_pixmap is not available with direct rendering.
GLX_EXT_texture_from_pixmap is available with indirect rendering.
/usr/bin/compiz.real: No stencil buffer. Clipping of transformed windows is not going to be correct when screen is transformed.
inotify_add_watch: No such file or directory
Segmentation fault (core dumped)
Avviso del window manager: Il valore «» nel database di configurazione non è valido per la scorciatoia «toggle_shaded»

(last line in italian says: value <<>> in configuration database is not valid for the shortcut << toggle_shaded>>)

any hints?

BTW: if I try to run compiz thru desktop-effects, i get the same errors but the first lines say:

nvidia hardware not available
gtk-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"

and then again:

gtk-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"
GLX_EXT_texture_from_pixmap is not available with direct rendering.
GLX_EXT_texture_from_pixmap is available with indirect rendering.
/usr/bin/compiz.real: No stencil buffer. Clipping of transformed windows is not going to be correct when screen is transformed.
inotify_add_watch: No such file or directory
Segmentation fault (core dumped)
Avviso del window manager: Il valore «» nel database di configurazione non è valido per la scorciatoia «toggle_shaded»

Alexander Papaspyrou (lxndrp) wrote :

I can confirm this issue on a ATI Fire GL notebook (IBM ThinkPad T42p, model 2373-GTG) graphics card, using the ati driver.

Enabling the XAANoOffscreenPixmaps options leaves me with a completely white screen, so this is (at least for me) no feasible workaround.

Alexander Papaspyrou (lxndrp) wrote :

The Java-related problem (blank windows) can be circumvented by doing an

# export AWT_TOOLKIT="MToolkit"

before starting the Java app. However, I am unsure whether this is a Java/AWT or X11/Compiz problem.

Sebastian Breier (tomcat42) wrote :

The Java-related problem is indeed a Java problem, because somehow Java needs to know the WM on Linux, but doesn't know beryl & compiz (yet).

The Java bug is located here: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6509038
Several workarounds are located here: http://wiki.beryl-project.org/wiki/Java

Bryce Harrington (bryce) wrote :

xorg-server 1.3 advertises that it fixes this bug. Please test on gutsy's xserver 1.3 and reopen if it reoccurs.

Changed in xorg:
status: Confirmed → Fix Committed

When will the fix be available for Feisty then?
Thanx!
zeddock

On 5/15/07, Bryce Harrington <email address hidden> wrote:
>
> xorg-server 1.3 advertises that it fixes this bug. Please test on
> gutsy's xserver 1.3 and reopen if it reoccurs.
>
> ** Changed in: xorg (Ubuntu)
> Status: Confirmed => Fix Committed
>
> --
> Some windows do not render with "Desktop Effects" enabled on some hardware
> https://bugs.launchpad.net/bugs/89189
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nicolò Chieffo (yelo3) wrote :

Sorry but I don't see any xorg-server 1.3 in gutsy... the current
version is 1.2.0-3ubuntu8...
has it been uploaded yet?

Timo Aaltonen (tjaalton) wrote :

yes it has, and built also.

Nicolò Chieffo (yelo3) wrote :

are you sure? I have archive.ubuntu.com in my sources.list but it's
not appeared yet!

zeddock (zeddock) wrote :

I too would like to know how to apply fixes when the status changes to fix
committed.
It is still a mystery to me and leaves me thinkiing that I must wait until
the next ubuntu version. That's not the case, right?

Thanx!
zeddock

On 5/16/07, Nicolò Chieffo <email address hidden> wrote:
>
> are you sure? I have archive.ubuntu.com in my sources.list but it's
> not appeared yet!
>
> --
> Some windows do not render with "Desktop Effects" enabled on some hardware
> https://bugs.launchpad.net/bugs/89189
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nicolò Chieffo (yelo3) wrote :

when the fix is committed it is firstly released to the developement
version (Gutsy) and if it works it *might* be uploaded to
feisty-updates too.

Nicolò Chieffo (yelo3) wrote :

I've tested it, video files are still not working (black screen)
any suggestion of a java software to test if it works?

Bryce Harrington (bryce) wrote :

Nicolo, can you elaborate? Does xserver 1.3 provide a partial fix, or not at all?
Anyone else able to confirm whether this fixes it?

zeddock, I doubt we'll be backporting xserver 1.3 to feisty. It is possible that this specific fix could be backported to feisty, but not unless we're absolutely certain it fixes the issue and causes no additional issues.

Nicolò Chieffo (yelo3) wrote :

sorry but after having read the changelog for the package it is always
written that the option XAANoOfscreenPixmaps is enabled by default, so
I don't really know how to test it...

Alexander Jones (alex-weej) wrote :

Guys, this bug is long fixed. Please open new bugs for your issues, however related they may seem.

Please can someone change the status to "Fix released"?

xorg-1.3 is in Gutsy. If you find that the problem persists in Gutsy, please reopen.

@Nicolo: Your post is not clear. If running xorg-1.3 as it installs in Gutsy doesn't fix the problem of windows failing to render, then please reopen. Otherwise please file a new bug report.

Changed in xorg:
status: Fix Committed → Fix Released
Nicolò Chieffo (yelo3) wrote :

Sorry, I was wrong. I thought that the patch that disables Offscreen
Pixmaps hadn't been dropped.

Gabriel Rota (gabriel-rota) wrote :

Java software like sqldeveloper have this defect with sun-java-5-bin use sun-java-6-bin is a good fix for me.

For details see this : https://bugs.launchpad.net/ubuntu/+bug/152040

Omega-xis (nieknooijens) wrote :

got the same problem on nvidia 9600GT!

To post a comment you must log in.