upower (devkit-power) reporting bad data when AC cable is unplugged

Bug #531190 reported by Konstantin Lavrov on 2010-03-03
878
This bug affects 223 people
Affects Status Importance Assigned to Milestone
DeviceKit-Power
Fix Released
Medium
upower (Debian)
Confirmed
Unknown
upower (Fedora)
Won't Fix
Critical
upower (Ubuntu)
High
Unassigned
Nominated for Lucid by Mark Williams

Bug Description

Binary package hint: upower

upower reports enormous energy-rate for first time after cord is unplugged.
GPM reacts on this first event not checking subsequent events.

This bug is started because I found no ways to collect data for bug #473552.
I have no devkit-power package.

=== EFFECTS ===

This is the underlying cause to gnome-power-manager immediately reporting critical battery after unplug even while charge is good. It is not a gnome-power-manager problem, the root is here in upower. Please do not report bugs against gnome-power-manager for this!

To workaround the effects execute:

gconftool-2 --type bool --set /apps/gnome-power-manager/general/use_time_for_policy false

(from <https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/572541/comments/1>)

=== apport information ===

ProblemType: Bug
Architecture: i386
Date: Wed Mar 3 11:15:13 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/upower/upowerd
InstallationMedia: Lubuntu 10.04 "Lucid Lynx" - Alpha 3 i386 (20100225)
Package: upower 0.9.0+git20100216.b9bb78-0ubuntu1
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: upower
Uname: Linux 2.6.32-15-generic i686
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Lubuntu 10.04 "Lucid Lynx" - Alpha 3 i386 (20100225)
Package: upower 0.9.0+git20100216.b9bb78-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
Tags: lucid
Uname: Linux 2.6.32-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

When I unplug AC, I get a warning from g-p-m that I only have 3 min. remaining time left, although my battery is fully charged and usually lasts for ~2-3h.

As you can see from the attached log, it takes a few seconds, until dk-power reports plausible values for remaining time.

Created attachment 30606
output of dk-power --monitor-details while unplugging AC

170 comments hidden view all 176 comments
Konstantin Lavrov (lacosta) wrote :

apport information

tags: added: apport-collected
description: updated
Konstantin Lavrov (lacosta) wrote :

AC cable was unplugged then after about 5 sec. plugged back then
wait until suspend
and after wake up I stop it with Ctrl-C

tekstr1der (tekstr1der) wrote :

upower --dump thinks I'm still on AC power with 100% charge.

This is after 5 minutes unplugged and running on battery.

This was previously reported as a regression in devicekit-power which I followed in Bug #384304. It was finally working properly just in time for the switch to upower. This has regressed again.

tekstr1der (tekstr1der) wrote :

Still seeing this on lucid. Any info I can add to help out?

Changed in upower (Ubuntu):
status: New → Confirmed

Immediately after AC unplug, upower is showing incorrect numbers for remaining time.
In my particular case, the battery is fully charged, I then unplug, and g-p-m pops up a dialog, saying that I have 3 minutes left before my battery is empty (which is obviously bogus). After a short period of time (usually a matter of 30+ secs), the values reported by upower are correct.

This might actually be a kernel/hardware problem, reporting incorrect current_now values (as shown in the referenced downstream bug reports [1][2])

Nonetheless, upower should probably workaround this by either:
a/ having some sanity checks to ignore unreasonable high/low (static) values
b/ ignore current values for say 60secs after ac unplug
c/ compute the mean values for properties like current_now and filter values which exceed a certain ratio
d/ other ideas?

Please also see the relevant downstream bug reports:
[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571161
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574850

Changed in upower (Debian):
status: Unknown → Confirmed
Konstantin Lavrov (lacosta) wrote :

It seems that log from gpm I attached in #3 has no related information.

In fact I post logs in bugs filled against g-p-m by others.

Need I provide more logs to this bug?

Last days more testers of Lucid had filled bugs against g-p-m but the root is here:

badly calculeted remaining time.

Changed in upower (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2010-04-16
Changed in upower (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
David Tombs (dgtombs) on 2010-06-12
description: updated
David Tombs (dgtombs) wrote :

Note from duplicates that this occurs often on MSI Wind laptops, but not exclusively.

description: updated
Kris Marien (kris-marien) wrote :

Same problem on my netbook with UNR 10.04, fully updated.

When I unplug the power cable the system goes standby after displaying the time message (2 minutes left). When I press the power to revive the system everything is alright again.

The workaround did not work for me. I also did set the action for critical battery to nothing in gconf-editor but that don't work either.

If I have to take an action or post an output of some kind here let me know.

Kris Marien (kris-marien) wrote :

I also found out that:

if I change the value for suspend from yes to no in /usr/share/polkit-1/actions/org.freedesktop.upower.policy

that I can unplug the power cable without problems (after 1 reboot)

but then the following occurs:

if I change the value for behaviour when I close my laptop screen from blank to hibernate

then when I unplug the power cable my laptop does suspend with the screen open.

For now I leave the option for closing the screen to blank and I can work with the cable unplugged without problems.

I don't know if this information is related to the bug but maybe it can help.

I also could change the settings for critical battery back to hibernate, wich I set to nothing as trying to work around the bug.

Ken Yagen (ken-yagen) wrote :

I finally discovered my issue was due to a bad battery. My laptop has 2 batteries in it and the 2nd one (replaces the dvd) had gone bad. So while I could run on battery, if I pulled the power cord, I think it tried to power from the bad battery first somehow and the power was cut. Once I removed the defective battery, everything works fine.

Hi,

I have Windows XP and Ubuntu 10.04 LTS on my laptop. XP works fine, but Ubuntu does not. At this point, I am not convinced that it is a hardware problem.....

--- On Mon, 6/14/10, Ken Yagen <email address hidden> wrote:

From: Ken Yagen <email address hidden>
Subject: [Bug 531190] Re: upower (devkit-power) reporting bad data when AC cable is unplugged
To: <email address hidden>
Date: Monday, June 14, 2010, 3:34 PM

I finally discovered my issue was due to a bad battery. My laptop has 2
batteries in it and the 2nd one (replaces the dvd) had gone bad. So
while I could run on battery, if I pulled the power cord, I think it
tried to power from the bad battery first somehow and the power was cut.
Once I removed the defective battery, everything works fine.

--
upower (devkit-power) reporting bad data when AC cable is unplugged
https://bugs.launchpad.net/bugs/531190
You received this bug notification because you are a direct subscriber
of a duplicate bug.

The bios version of my netbook was not compatible to linux at all. When the
bios was flushed to a compatible version the power issues were resolved. It
seems most of the cheap netbook have proprietary firmware that works
exclusively on a ms win platform

On Jun 14, 2010 3:25 PM, "meshellwm" <email address hidden> wrote:

Hi,

I have Windows XP and Ubuntu 10.04 LTS on my laptop. XP works fine, but
Ubuntu does not. At this point, I am not convinced that it is a hardware
problem.....

--- On Mon, 6/14/10, Ken Yagen <email address hidden> wrote:

From: Ken Yagen <email address hidden>
Subject: [Bug 531190] Re: upower (devkit-power) reporting bad data when AC
cable is unplugged
To: <email address hidden>
Date: Monday, June 14, 2010, 3:34 PM

I finally discovered my issue was due to a bad battery. My laptop has 2
batteries in it and the 2nd...

David Tombs (dgtombs) wrote :

@meshellwm: This bug is always triggered by quirky hardware, but upower could do a better job of hiding the quirky effects from the user. (See upstream report for details.)

Hey,

It's possible that my laptop has a hardware issue that Windows can handle but Ubuntu can't. It doesn't seem right that Windows would do better than Linux in any area ;-)

--- On Mon, 6/14/10, David Tombs <email address hidden> wrote:

From: David Tombs <email address hidden>
Subject: [Bug 531190] Re: upower (devkit-power) reporting bad data when AC cable is unplugged
To: <email address hidden>
Date: Monday, June 14, 2010, 6:38 PM

@meshellwm: This bug is always triggered by quirky hardware, but upower
could do a better job of hiding the quirky effects from the user. (See
upstream report for details.)

--
upower (devkit-power) reporting bad data when AC cable is unplugged
https://bugs.launchpad.net/bugs/531190
You received this bug notification because you are a direct subscriber
of a duplicate bug.

David Tombs (dgtombs) on 2010-06-16
tags: added: metabug
Kris Marien (kris-marien) wrote :

For clearing up some things:

if I set options for "closing the laptop screen" to suspend or hibernate

then, when I unplug the AC power cable:

my laptop goes into suspend or hibernate mode

even if I set the options for critical battery to "nothing"

Kris Marien (kris-marien) wrote :

Addendum to my previous post:

this happens with the laptop screen open

Kris Marien (kris-marien) wrote :

Another addendum to previous posts:

I even could reset the value of event when "critical battery" to suspend (I also changed policy of upower suspend back to yes).

So it seems that unpluggin the power cable puts the system to suspend/hibernate/blank screen only because it thinks that the laptop screen is being closed.

I also get the warning message of "2 minutes left" when unpluggin the power cable but there is no action because of this.

Maybe there is a better way to let the system check that the laptop screen is open/closed.

David Tombs (dgtombs) wrote :

Kris, it sounds like you're affected by a different bug, like bug 481312. Please report your own bug against upower (ubuntu-bug upower) and feel free to email me the bug # so I can take a look at it. Thanks!

Kris Marien (kris-marien) wrote :

@David

You are right. bug 481312 is the same problem as I have. I marked the bug as affecting me and I will follow the posting there.

Thanks.

I think I have this problem too...
I've my AC cable unplugged and in gnome-manager it says that is charging.
Look at this:
$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ADP1
  native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:09/PNP0C09:00/ACPI0003:00/power_supply/ADP1
  power supply: yes
  updated: Wed Jun 30 20:04:11 2010 (303 seconds ago)
  has history: no
  has statistics: no
  line-power
    online: no

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:09/PNP0C09:00/PNP0C0A:00/power_supply/BAT1
  vendor: MSI Corp.
  model: MS-1221
  power supply: yes
  updated: Wed Jun 30 20:08:47 2010 (27 seconds ago)
  has history: yes
  has statistics: yes
  battery
    present: yes
    rechargeable: yes
    state: charging
    energy: 468.964 Wh
    energy-empty: 0 Wh
    energy-full: 619.569 Wh
    energy-full-design: 53.28 Wh
    energy-rate: 16.9608 W
    voltage: 27.692 V
    time to full: 8.9 hours
    percentage: 75.692%
    capacity: 75.2708%
  History (charge):
    1277924927 75.692 charging
    1277924897 68.812 charging
    1277924867 26.617 charging

Daemon:
  daemon-version: 0.9.1
  can-suspend: yes
  can-hibernate yes
  on-battery: no
  on-low-battery: no
  lid-is-closed: no
  lid-is-present: yes

I've a LG E500

C de-Avillez (hggdh2) wrote :

Marking Triaged/Medium.

Changed in upower (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Just confirming this bug on a Toshiba Satellite L455-S5975. The workaround worked fine for me.

David Tombs (dgtombs) wrote :

@Daniel: that looks like a different bug, please file a new report with "ubuntu-bug upower" or look for an existing report. Thanks!

Matthew East (mdke) wrote :

I have seen what I think is this bug with an HP Mini 2133 - GPM tells me that the battery is critically low when I unplug the AC and offers to hibernate, even though the battery is at 100%. Happy to add any hardware or debugging information if that is useful.

Also happens on my Dell Vostro 1710. Unplug, and instant hibernate at 100% power.

Matthew East (mdke) wrote :

This is a regression in Lucid and from the number of duplicates appears to affect quite a few people with a serious symptom in an essential hardware component (laptop battery) so I'm increasing the importance to "High" in line with the guidelines at https://wiki.ubuntu.com/Bugs/Importance

tags: added: regression-release
Changed in upower (Ubuntu):
importance: Medium → High
Ben de Mora (ben-demora) wrote :

Also happens on my eMachines 350 Netbook, using both the standard battery and the extended 6-cell battery. Very annoying.

I have this problem on a Samsung Q45. I've replaced the battery once (about 6 months ago) and I now (again) get the 'battery may be damaged' message. Running time has been extremely poor even from the initial replacement of the battery. 1:50 if I'm lucky, sometimes only 40 minutes. The workaround has not worked for me. When i first bought this laptop i was using Hardy, and the battery life was in excess of 4 hours. This is a serious issue for me, as I spend a lot of time on the road.

Still present on Maverick for me

Changed in devicekit-power:
importance: Unknown → Medium
status: Unknown → Confirmed
JimD (jndeakin) wrote :

I have a Sony Vaio VGN-NR21S with the above problem.
the "gconftool-2 --type bool --set /apps/gnome-power-manager/general/use_time_for_policy false" seems to be a workaround, but using upower -d tells me the energy rate reading is wrong.
Running on A/C :
    state: charging
    energy: 50.23 Wh
    energy-empty: 0 Wh
    energy-full: 53.28 Wh
    energy-full-design: 53.28 Wh
    energy-rate: 782.82 W
    time to full: 14 seconds
    percentage: 94.2755%
    capacity: 100%
    technology: lithium-ion

I get a warning that there is only four minutes power when I unplug. The info corrects itself when on D/C
    state: discharging
    energy: 49.98 Wh
    energy-empty: 0 Wh
    energy-full: 53.28 Wh
    energy-full-design: 53.28 Wh
    energy-rate: 24.396 W
    time to empty: 2.0 hours
    percentage: 93.8063%
    capacity: 100%
    technology: lithium-ion

The error returns if plugged in again.

JimD (jndeakin) wrote :

Forgott to say.. It's running fully patched Lucid.

Larraby (crain) wrote :

I've got a MSI Wind U100 and have the same issue. While on 10.04 I've tried to deselect use_time_policy but it didn't worked, upgraded to 10.10 - same thing. But in 10.04 netbook ed. everything worked right. Is there any way to solve this?

I've installed the new Ubuntu 10.10 version and the same old problem...

meshellwm (meshellwm5) wrote :

Hey,

I went back to Ubuntu 9.04, then I unpluged my laptop. I have not had any power problems! (It was nice to go back to 9.04!) Windows XP also works fine.

Before going back to Ubuntu 9.04, I tried the following, all failed:

Ubuntu 9.10,
Ubuntu 10.04 LTS,
LinuxMint 9
PCLinuxOS Zen Mini
Fedora 12.

The code in Ubuntu 9.04 is obviously more robust. There may be a hardware problem with this laptop, but it is clear from Ubuntu 9.04, that it can be solved.

I hope this information helps.......

--- On Thu, 10/14/10, Daniel Botelho <email address hidden> wrote:

From: Daniel Botelho <email address hidden>
Subject: [Bug 531190] Re: upower (devkit-power) reporting bad data when AC cable is unplugged
To: <email address hidden>
Date: Thursday, October 14, 2010, 2:14 PM

I've installed the new Ubuntu 10.10 version and the same old problem...

--
upower (devkit-power) reporting bad data when AC cable is unplugged
https://bugs.launchpad.net/bugs/531190
You received this bug notification because you are a direct subscriber
of a duplicate bug (490632).

meshellwm (meshellwm5) wrote :
Download full text (13.8 KiB)

I just wanted to include some more info. (below). Oh, I noticed that Ubuntu correctly identified my video, the others did not.

Laptop: Compaq Presario X1000, 1 Mb RAM, Centrino.

Ubuntu 9.04

vmlinuz-2.6.28-11-generic

and

vmlinuz-2.6.28-19-generic

Work fine when laptop is unpluged and is running on battery power.

lshw output: -----------------------------------------------------------------

laptopwgl
    description: Notebook
    product: Compaq Presario X1000 DK571A#ABA
    vendor: Hewlett-Packard
    version: F.09
    serial: CND32802JC
    width: 32 bits
    capabilities: smbios-2.3 dmi-2.3
    configuration: boot=normal chassis=notebook uuid=D9DE7020-3EC3-D711-02A0-669906293129
  *-core
       description: Motherboard
       product: 0860
       vendor: COMPAL
       physical id: 0
       version: 8051 Version 24.1B
     *-firmware
          description: BIOS
          vendor: Hewlett-Packard
          physical id: 0
          version: 68BAL Ver. F.09 (08/15/2003)
          size: 128KiB
          capacity: 960KiB
          capabilities: pci pcmcia pnp apm upgrade shadowing cdboot bootselect edd int13floppy720 int5printscreen int9keyboard int14serial int17printer acpi usb agp ls120boot smartbattery biosbootspecification netboot
     *-cpu
          description: CPU
          product: Intel(R) Pentium(R) M processor 1300MHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: 6.9.5
          slot: U10
          size: 600MHz
          capacity: 1300MHz
          width: 32 bits
          clock: 100MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 tm pbe up bts est tm2 cpufreq
        *-cache:0
             description: L1 cache
             physical id: 5
             slot: Internal L1 Cache
             size: 64KiB
             capacity: 64KiB
             capabilities: burst internal write-back unified
        *-cache:1
             description: L2 cache
             physical id: 6
             slot: Internal L2 Cache
             size: 1MiB
             capacity: 1MiB
             capabilities: burst external write-back unified
     *-memory
          description: System Memory
          physical id: 9
          slot: System board or motherboard
          size: 1280MiB
        *-bank:0
             description: SODIMM DDR Synchronous
             physical id: 0
             slot: DIMM #1
             size: 1GiB
             width: 64 bits
        *-bank:1
             description: SODIMM DDR Synchronous
             physical id: 1
             slot: DIMM #2
             size: 256MiB
             width: 64 bits
     *-pci
          description: Host bridge
          product: 82855PM Processor to I/O Controller
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 03
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel module=intel_agp
        *-pci:0
             description: PCI bridge
             product: 82855PM Processor to AGP Controller
             vendor: Intel Corporation
             phy...

Konstantin Lavrov (lacosta) wrote :

@meshellwm: There was no upower in Ubuntu 9.04. but hal

ToRA (wadritora) wrote :

gconftool-2 --type bool --set /apps/gnome-power-manager/general/use_time_for_policy false

OMG, THANKS!!!! thansk thanks thanks and thanks.

I love this company! :)

ArchLinux Gnome Kernel 2.6.35 i686 And the same problem, but no more!

I have the same problem in Ubuntu 10.10 with a Dell Vostro 3300 with a 8-cell Lithium Ion battery.

Anders Hall (kallebolle) wrote :

I have the same problem in Ubuntu 10.10 with a Lenovo x201, Lithium Ion battery.

132 comments hidden view all 176 comments

I'm not sure what the best course of action here is. Usually introducing heuristics causes more issues that working out why the hardware / kernel reports invalid values.

Richard.

Maybe the heuristic can be as simple as simply waiting for 10 to 30 secs after unplug before reading the values and just use the old values from before the unplug for that time frame

Paul Sladen (sladen) on 2011-01-14
description: updated
Changed in devicekit-power:
importance: Medium → Unknown
tags: added: patch
Changed in devicekit-power:
importance: Unknown → Critical
Changed in devicekit-power:
status: Confirmed → Fix Released
36 comments hidden view all 176 comments
Chris Morgan (chris.morgan) wrote :

Michael:

- I've been seeing the phantom battery since, I believe, at least Ubuntu 10.10 (InstallationMedia 9.10).
- I've been experiencing this problem in Ubuntu 11.10; I think I did in 11.04 but can't remember. Earlier information is useless as I replaced the battery some time during having 11.04, the earlier battery I had was faulty and reported itself as critically low whenever unplugged (in spite of really having half an hour's life in it).
- The use_time_for_policy workaround seemed to improve the situation for me at first, but it still does it generally in the unplug-then-wake-up situation. I'm actually not sure now whether it improved anything, whether my usage pattern just changed.
- I'm not going to test your patch (well, if you put it in a PPA I'd test it, but I'm too slack to try it out myself).

If there's any more information you'd like from me, I'm happy to try to provide it.

Michael (michaeljt) wrote :

I could upload the amd64 package I built somewhere (no clue about PPAs, but if there is a way to do it which doesn't take too much time I could do) if people would like, though I must admit I am not too keen, as I don't like to encourage people to use random binaries from people they don't know.

I have the same problem with 11.10. The message of battery critically low appears after unplug AC cable, but the battery monitor itself shows the battery is fully charged.

Changed in upower (Ubuntu):
status: Triaged → Confirmed
zac.roesch (zac-roesch) wrote :

David Tombs: This battery is brand new, though it started with an older battery that could have been bad. At this point, I won't know, though it would be nice to have two batteries.

Part of the irregularity I experience with the bug is that sometimes the machine will work fine until, as others have mentioned, the lid is closed of it goes to sleep. Once it's woken up, crit bat.

Thinking about reinstalling, because wth. I'd like to know if that would be a reasonable solution before I create a lot of extra work for myself (and may still end up with the same problem).

Has there been any solid progress with this yet?

And happy new year.

lasher (lasher) wrote :

I also have this problem. Have stayed with Natty (well, Linux Mint 11) to avoid it, however a recent update has caused it to sleep every time and an added displeasure of wifi failing after waking (anther bug?). Before wifi would fail only sometimes and require reboot now it is all the time. Quick fix was to disable use_time_for_policy in gconf-editor thanks to this bug report.

Gustavo Veloso (gjmveloso) wrote :

It's unbelievable how a HUGE bug can't be handled by Ubuntu developers properly. Sad, very sad.

Michael (michaeljt) wrote :

Actually this is fixed for me - see bug 852406. It was an upstream kernel workaround for bad ACPI events sent by the hardware. I really wouldn't blame the Ubuntu developers for that, as fixing any bug of this sort (of which there are far too many) takes an enormous effort - see all the comments on these bug tickets, many of which are actually users actively working to track down the problem, and it involves hardware they may not own and a component (the kernel) which they package but certainly didn't develop themselves.

statquant (statquant) wrote :

Damn, I truied the quick fix proposed and that did not work.
I am surprised to see that this bug is considered as fixed... IT IS NOT
There are still tens of us who cannot use their laptop because of this... I now use Windows XP because of this...

I have upower 9.13, ubuntu 11.10.

Is there anywhere an actual FIX to that problem?
Thanks if somebody can help

22 comments hidden view all 176 comments
21 comments hidden view all 176 comments
Greg Conquest (gregconquest) wrote :

Statquant, "tens of us who cannot use our laptops"? I've been trying to deal with this problem since 11.04 (or before) on my DELL mini 9 also, but I haven't posted anything about it. I just have been shutting down everytime I have to move from an outlet, and I imagine a LOT of other people are continuing to do likewise.

For us potentially thousands of users who are reading this but don't have anything to add and don't know what to do and don't don't which bug is afflicting us, can someone update this and say if anything is working, please? Has the bug(s) actually been clearly diagnosed? This is a big inconvenience for a lot of people.

Thank you in advance for the guidance.

Michael (michaeljt) wrote :

Greg, I suspect that this bug is actually several related ones, as for my system it does seem to have been fixed upstream. I would also not be surprised if it is due to (various cases of) quirky hardware which was deemed to work because it tested successfully under Windows. It might be worth your while though going upstream (e.g. to the kernel bugzilla) with this, as you are more likely to get the people who really understand this stuff (no offence to Canonical and their kernel engineers - no one can understand more than a small cross section of the kernel code).

Workaround no longer works with oneiric on msi wind

efa (efa) wrote :

As asked at:
http://upower.freedesktop.org/
I tried to post something on the upstream mail list for upower (on freedesktop):
<email address hidden>
my posts was ignored. So I think Canonical is not responsible as they inherit the code.
Try yourself to writo to them.

tags: added: maverick natty oneiric

Good news, folks. I just installed Precise Beta 1 and the bug seems to be fixed. As commented before, probably was a kernel-related issue. So, since - apparently - is not necessary install Precise, would be nice if we get more people testing this to see if this bug is still occurs in the new kernel.
PS: I think that's not necessary install Precise in HDD to test this, because - at least in my case - the bug didn't appear in the boot from USB too.

cherep (acherep) wrote :

it seems to be working on my msi x340 with Precise Beta 1. After unpluging the cable, there are no more wrong reports about critical battery.

HousieMousie2 (housiemousie2) wrote :

Still present on 11.10, fully updated.
Toshiba NB505
(Dell)Alienware M17x

Vladimir Hidalgo (vlad88sv) wrote :

VAIO Series E (VPCEB15EL), 11.10 fully updated and still not working.

Had to use this workaround:
gconftool-2 --type bool --set /apps/gnome-power-manager/general/use_time_for_policy false

Kris Marien (kris-marien) wrote :

Additional information about this bug:

the incorrect readings of gpm only occure 2 me when I unplug the cable that is connected to my laptop and they don't occur when I unplug the power cable from the wall contact.

Maybe this helps solving the problem and maybe some people can try it and use it as a workaround.

Kris Marien (kris-marien) wrote :

Can anyone confirm previous post #153 that it happens on other laptops too?

efa (efa) wrote :

seems incredible, but charged capacitors in the external power supply can make the difference, let voltage dropping at very slow rate. I will test this on my netPC

David Tombs (dgtombs) wrote :

So, same behavior in 12.04 Precise?

Actually, I haven't seen this bug since upgrading to Precise.

On Mon, Jul 16, 2012 at 7:51 PM, David Tombs <email address hidden> wrote:

> So, same behavior in 12.04 Precise?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (558627).
> https://bugs.launchpad.net/bugs/531190
>
> Title:
> upower (devkit-power) reporting bad data when AC cable is unplugged
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/devicekit-power/+bug/531190/+subscriptions
>

Nor have I. Could the original reporter come in and see if 12.04 has fixed it?

Konstantin Lavrov (lacosta) wrote :

Well. I'm not experiencing this bag on that my laptop anymore.
But I need to say that now I have lubuntu installed on it.
So here now xfce4-power-manager is used instead of gnome-power-manager.
This was upower bug but it was G-P-M who turned off power on unplug events.

David Tombs (dgtombs) wrote :

OK, based on the upstead "Fix Released" status, I'll assume this is fixed in 12.04. Thanks everyone for your patience!

Changed in upower (Ubuntu):
status: Confirmed → Fix Released
David Tombs (dgtombs) wrote :

upstream*

6 comments hidden view all 176 comments

Appears to be fixed in Ubuntu (see linked Ubuntu report).

5 comments hidden view all 176 comments
efa (efa) wrote :

with 11.10 still happen also after full packages upgrade.
Disconnecting main power supply from wall socket or DC plug from the NetPC (MSI Wind 90), same effect, always switch off after 10 seconds for "low battery"

For those on pre-12.04 releases, this bug will likely remain as the codebase is frozen for that release. The fix will need to manually be backported either by upstream or by someone willing to submit a patch to Ubuntu 11.10.

efa (efa) wrote :

this bug was opened against Ubuntu 10.04, at first should be fixed for this

Fito Hoyos (fitohoyos) wrote :

i still have the problem in a Dell mini 1010. I fresh-installed 12.04 several times with no success.

David Tombs (dgtombs) wrote :

If anyone is still encountering this problem on 12.04 or later, please use 'ubuntu-bug upower' to report a new bug. This one has been fixed.

2 comments hidden view all 176 comments

(In reply to comment #14)
> Appears to be fixed in Ubuntu (see linked Ubuntu report).

Closing as a dupe of 24667, which is the same bug from the same reporter.

*** This bug has been marked as a duplicate of bug 24667 ***

5 comments hidden view all 176 comments

*** Bug 27399 has been marked as a duplicate of this bug. ***

Closing as fixed as per bug 27399. Reopen if you still see the problem with UPower 0.9.23.

Changed in devicekit-power:
status: Fix Released → Invalid
5 comments hidden view all 176 comments
David Tombs (dgtombs) wrote :

Linked correct upstream bug report.

Changed in devicekit-power:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in devicekit-power:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in upower (Fedora):
importance: Unknown → Critical
status: Unknown → Won't Fix
Displaying first 40 and last 40 comments. View all 176 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.