Update Manager list items are messy and chopped short in height.

Bug #273184 reported by kyleabaker on 2008-09-22
112
This bug affects 8 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.
Description: Ubuntu intrepid (development branch)
Release: 8.10
Alpha 6 (currently up-to-date)

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.
update-manager:
  Installed: 1:0.93.17
  Candidate: 1:0.93.17
  Version table:
 *** 1:0.93.17 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
The list items should be clean and clear and not meshed together.

4) What happened instead
The list items for updates are occasionally crammed together and the height of each item is smaller than it normally should be, making the list look terrible and almost unreadable (for the descriptions).

One solution that I have found if I open Update Manager and the list appears in this way is to close Update Manager and reopen it. This typically resolves the problem and the list appears fine and with no abnormalities.

I've attached screenshots of what I am talking about.
This topic has also been discussed and confirmed in the Ubuntu Intrepid Development forums:
http://ubuntuforums.org/showthread.php?p=5831192#post5831192

Links to screenshots of this bug:
http://img301.imageshack.us/img301/2848/screenshotupdatemanagerik1.png
http://img143.imageshack.us/img143/4223/screenshotupdatemanagerbo6.png

Also, in that forum thread about this bug, forumache says it may be triggered by the following:
"I think (not at home right now) that, if I remember correctly, I can trigger it in a simple way: once it displays updates (looking fine), just press "Check for updates" again. The resulting display will look like the picture."
http://ubuntuforums.org/showpost.php?p=5833007&postcount=4

kyleabaker (kyleabaker) wrote :

I have also experienced this issue, although I have no way to reproduce it reliably. It seems to only happen occasionally.

Changed in update-manager:
importance: Undecided → Low
status: New → Confirmed
Hew (hew) wrote :

I got this the other day as well. I cannot reproduce the issue by choosing "check" again, though.

Changed in update-manager:
status: Confirmed → Triaged

I installed 8.10beta on the 4th of October, but this issue started happening to me this morning after updating.

Closing update-manager, and then reopening it seems to make the problem go away, I do not see the problem until there are new updates to take in.

®om (rom1v) wrote :

It happened for me this morning.

®om (rom1v) wrote :

It happened to me this morning.

botticchio (botticchio-gmail) wrote :

I am also affected by this bug. It isn't the first time it happened, but today I decided to report it. I am not able to reproduce it precisely. This time I noticed that the first time I pressed the Check button the field's heights were correct. After pressing the Check button another time, I noticed that only the lower items in the listing were stretched, as shown in the attached screenshot:

"update_manager_bug1" shows the upper part of the list, which has the firs two item displayed correctly; starting from the third item the height is lowered.

"update_manager_bug2" shows the lower part of the list.

After checking a third time, every item was stretched, as shown in the screenshot "update_manager_bug-after_checking_again".

Closing and reopening the Update Manager window partially solves the issue. I tried every combination: closing and reopening the window, closing and opening the Descriptions of the update, and checking again many times. Sometimes the list is displayed correctly, sometimes only the first items are displayed correctly, and sometimes every item is stretched.

kernel: 2.6.27-7-generic
Ubuntu: Intrepid(8.10)
Gnome: 2.24.1
update-manager: 1:0.93.34

XXXXXXX (yddraiggoch) wrote :

This appears to be caused by the fixed-height-mode being set to enabled. It either causes the top row to be too high which isn't so bad, or it causes all rows below it to be too small which is problem. The patch attached seems to fix it.

sam tygier (samtygier) wrote :

i am seeing this too. i shall try the patch

Changed in update-manager:
status: Triaged → Confirmed
sam tygier (samtygier) wrote :

i can confirm richie's patchs fixes the issue for me. i checked with version-numbers disabled and enabled.

Hew (hew) on 2009-01-14
Changed in update-manager:
status: Confirmed → Triaged
Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "bug273184.patch" was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. Thanks for your contribution Richie!

kyleabaker (kyleabaker) wrote :

This is still present in Ubuntu 9.04 Jaunty Jackalope alpha 5.
http://ubuntuforums.org/showthread.php?p=6806457

Originally discussed for Intrepid alphas last year:
http://ubuntuforums.org/showthread.php?t=926258

Luke Orland (orluke) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.100

---------------
update-manager (1:0.100) jaunty; urgency=low

  [ Andy Whitcroft ]
  * DistUpgrade/cdromupgrade:
    - if cdromupgrade is run with a relative path we will fail to find the
      installer components and error out. Ensure that the path is absolute.
      (LP: #335360)

  [ Michael Vogt ]
  * fix crash when help is not avaialble (LP: #338098)
  * data/glade/UpdateManager.glade:
    - remove the "Keep your system up-to-date" text (design team,
      LP: #336800)
  * fix crash when no network is avaialble for changelog fetching
    (LP: #334002)
  * debian/control:
    - add conflict against update-manager-kde to update-manager-hildon
      (LP: #333464)
  * UpdateManager/Core/MyCache.py:
    - show proper urls for sources with epochs (LP: #328164), thanks
      to Richie
  * UpdateManager/ChangelogViewer.py:
    - support copy to clipboard for URLs (LP: #85644), thanks to
      Richie
  * UpdateManager/UpdateManager.py:
    - disable fixed-hight mode, it can cause incorrect height
      calculation (thanks to Richie), LP: #273184
  * DistUpgrade/DistUpgradeController.py:
    - do not allow gtk/kde upgrades over ssh session (LP: #322482)
  * merged aufs branch (disabled by default but useful for testing)

 -- Michael Vogt <email address hidden> Tue, 10 Mar 2009 20:25:55 +0100

Changed in update-manager:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.