update manager lines are unreadable

Bug #249335 reported by Fernando Miguel on 2008-07-17
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Michael Vogt

Bug Description

Binary package hint: update-manager

update manager, in intrepid, lines are unreadable.
please see screenshot.

it seems that the last update has fixed this.

Changed in update-manager:
status: New → Fix Released

well, it just showed up again with today's update.

please fix this.

thanks in advance

Changed in update-manager:
status: Fix Released → Confirmed

update-manager (1:0.91.10) intrepid; urgency=low

  * UpdateManager/Core/DistUpgradeFetcherCore.py:
    - improved error handling for people who run
      /tmp with noexec (LP: #219518)
  * DistUpgrade/ReleaseAnnouncement:
    - fixes in the announcement text (thanks to
      Brian Murray, LP: #250693)
  * DistUpgrade/removal_blacklist.cfg:
    - remove nvidia-glx from the removal blacklist,
      the naming schema changed in intrepid and the
      old packages need to go way (LP: #249329)

 -- Michael Vogt <email address hidden>  Tue, 22 Jul 2008 12:04:34 +0200

Michael Vogt (mvo) wrote :

thanks for your bugreport.

That looks like a bug in the video driver, what xorg driver do you use?

Changed in update-manager:
status: Confirmed → Incomplete

> That looks like a bug in the video driver, what xorg driver do you use?

nvidia binary 173.
Today update-manager looks fine.
I would close this ticket, but i'm afraid it will appear again, as it as happen in the past.

 status new
--
BUGabundo :o)
(``-_-´´) http://Ubuntu.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Changed in update-manager:
status: Incomplete → New
Michael Vogt (mvo) wrote :

Thanks for this additional information.

Could you watch out for it and when it happens again, please switch to a different theme and see if that helps? I strongly suspect this is not a update-manager but a theme and/or video driver bug.

Changed in update-manager:
assignee: nobody → mvo
status: New → Incomplete
Download full text (20.8 KiB)

Michael it just reappear.

 status new

Here is my list of changes from yesterday:

apt-listchanges: changelogs
 Date: Yesterday 18:00:00

python2.4 (2.4.5-5ubuntu1) intrepid; urgency=low

  * Merge with Debian; remaining changes:
    - Include pregenerated documentation.
    - Build the -doc package from this source.

 -- Matthias Klose <email address hidden> Thu, 31 Jul 2008 17:37:40 +0200

python2.4 (2.4.5-5) unstable; urgency=medium

  * Update to 20080731, taken from the 2.4 release branch, only change:
    - Fix issue #2620, CVE-2008-3142, overflow checking when allocating or
      reallocating memory was not always being done properly in some python
      types and extension modules.
  * CVE-2008-3143 was fixed in 2.4.5-1.
  * Fix issues #2588, #2589, CVE-2008-3144, fix potential integer underflow
    and overflow conditions in the PyOS_vsnprintf C API function.
  * Fix CVE-2008-2315, more overflow checking in extension modules.

 -- Matthias Klose <email address hidden> Thu, 31 Jul 2008 07:28:47 +0200

python2.4 (2.4.5-4) unstable; urgency=low

  * Fix sections for documents registered with doc-base.
  * python2.4-minimal: Recommend python2.4 (suggested by Neil McGovern).

 -- Matthias Klose <email address hidden> Sun, 20 Jul 2008 20:15:21 +0200

python2.5 (2.5.2-10ubuntu1) intrepid; urgency=low

  * Merge with Debian; remaining changes:
    - Include the pregenerated documentation.
    - Set priority of python2.5-minimal to required.
    - Build python2.5-doc from the pregenerated documentation.

 -- Matthias Klose <email address hidden> Thu, 31 Jul 2008 17:46:11 +0200

python2.5 (2.5.2-10) unstable; urgency=medium

  * Update to 20080731, taken from the 2.5 release branch, only change:
    - Fix issue #2620, CVE-2008-3142, overflow checking when allocating or
      reallocating memory was not always being done properly in some python
      types and extension modules.
  * Issues #2588, #2589, CVE-2008-3144, fixed in 2.5.2-7.
  * Fix CVE-2008-2315, more overflow checking in extension modules.

 -- Matthias Klose <email address hidden> Thu, 31 Jul 2008 07:14:36 +0200

python2.5 (2.5.2-9) unstable; urgency=low

  * python2.5-minimal: Recommend python2.5 (suggested by Neil McGovern).
  * Update to 20080726, taken from the 2.5 release branch.
    - Fix issues #2242, #3360.

 -- Matthias Klose <email address hidden> Sat, 26 Jul 2008 00:34:50 +0200

python2.5 (2.5.2-8) unstable; urgency=low

  * Update to 20080712, taken from the 2.5 release branch.
    - Fix issues #1792, #2906, #3088, #3110, #3116, #3117, #3157, #3243.
  * Fix bashisms in Tools/faqwiz/move-faqwiz.sh. Closes: #489649.
  * Fix issues with turkish locale. Closes: #489740.

 -- Matthias Klose <email address hidden> Sat, 12 Jul 2008 11:30:19 +0200

apt-xapian-index (0.14) unstable; urgency=low

  * Added --batch-mode to produce machine-readable output, to use for GUI
    feedback in package managers. Thanks to Petr Rockai.
  * Reformatted debian/copyright
  * Shortened short description

 -- Enrico Zini <email address hidden> Thu, 31 Jul 2008 14:57:32 +0200

apt-xapian-index (0.13) unstable; urgency=low

  * Upload properly.

 -- Enrico Zini <email address hidden> Sun, 20 Jul 2008 07:55:50 +0100

apt-xapi...

Changed in update-manager:
status: Incomplete → New

it seems to be quite stable until now. if i see it reappearing until release, i'll let you know.

Changed in update-manager:
status: New → Fix Released

it just reappeared today.

update-manager: version 0.93.4

Changed in update-manager:
status: Fix Released → New

I have same problem. I didn't find this bug first. My is bug 267209. I'm using Ubuntu Intrepid on Asus M6000 Laptop. My graphic card is Ati Mobility Radeon X700. I can confirm this bug.

Heki (jhfischer) wrote :

Same here!

Brian Murray (brian-murray) wrote :

Could somebody please try changing to a different theme when they experience this bug? Thanks in advance.

Changed in update-manager:
status: New → Incomplete

Right now mine is fine, but I'll do as you requested next time (if we ever get one)

I tried change theme but it didn't help. Only possible is change default font maybe.

Mine is still fine.
Matti was your's already "damage" or did it just started in the last few days?

Changed in update-manager:
status: Incomplete → New

I changed theme to Ubuntu Clear and back. After this all is showed right. Maybe this bug can be closed now.

Brian Murray (brian-murray) wrote :

I experienced this bug today when performing an update with Intrepid. Incidentally, it was the second time I had run update-manager in my session. The first run was a partial upgrade. I was also using the Human theme.

I've attached a screenshot of my desktop.

Brian Murray (brian-murray) wrote :

I've been able to recreate this using the following steps on Intrepid:

1) Run update manager
2) Install updates
3) Kill update-manager 'sudo pkill update-manager'
4) Start update-manager again
5) Press Check (I'm not positive this is necessary)

The package information will now be compressed. I believe switching the theme to anything fixes it.

Changed in update-manager:
importance: Undecided → Low
milestone: none → later
status: New → Confirmed
Alejandro J. Cura (alecu) wrote :

I briefly experienced the same problem, on Intrepid. There was only one package to be installed, and I clicked on the "Check" button, and it appeared after it checked the repos and found a few packages more. See the screenshot.

It happened only once and I took the screenshot. I closed Update Manager and restarted and everything was fine again. I cannot reproduce it, not even following the 5 steps above.

ATI Radeon XPRESS 200M, fglrx driver.
GTK+ widgets using the standard "Human" theme, font resolution set to 89 dpi.

Kiwinote (kiwinote) wrote :

This bug still occurs in jaunty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers