"Show copy dialog" right click launcher entry doesn't work (on nautilus copy)

Bug #887821 reported by Steven Leiphart on 2011-11-08
510
This bug affects 142 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
5.0
Won't Fix
High
Unassigned
nautilus (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Precise
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned

Bug Description

Impact:
the nautilus copy dialog don't get properly focussed by unity

Test Case:
- log into an unity session
- copy a not too small file (so you have time to interact with the copy dialog)
- minimize the copy dialog
- right click on the corresponding unity-launcher's icon, and pick "show copy dialog"
-> the dialog should be displayed

Regression testing:
Check that there is no focus issue with that dialog and the launcher

------

While copying a large (8 gig) file across an SMB network, I minimized it. The right click on the Nautilus Unity bar showed a "Show copy dialog" item. Clicking on that item did nothing. The only way to get the dialog back up was to open one of the two minimized Nautilus windows and then minimize the one on top. After that minimize, then the copy dialog was displayed on top of the other Nautilus window. I couldn't find any way to get the copy dialog back on screen without clicking around somewhat aimlessly displaying and minimizing Nautilus windows until it appeared. The "Show copy dialog" right-click menu appeared to have no affect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Tue Nov 8 18:12:10 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~3v1n0/unity/quicklist-activate-timestamp
PS Jenkins bot: Approve (continuous-integration) on 2013-03-12
Andrea Azzarone: Approve on 2013-03-12
lp:~3v1n0/nautilus/progress-quicklist-improvements
Ubuntu Desktop: Pending requested 2013-03-12
lp:~3v1n0/nautilus/progress-ql-present-fix
Ubuntu Desktop: Pending requested 2013-09-10
Sebastien Bacher (seb128) wrote :

Confirming the issue on current Oneiric

affects: nautilus (Ubuntu) → unity (Ubuntu)
summary: - File copy dialog appears to get lost if minimized during large copy
+ "Show copy dialog" right click launcher entry doesn't work
summary: - "Show copy dialog" right click launcher entry doesn't work
+ "Show copy dialog" right click launcher entry doesn't work (on nautilus
+ copy)
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
milestone: none → 5.12.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0

I didn't find a way to get the copy dialog back on the display again at all.
I am using Precise with Nvidia.

I have the same issue, However, after clicking the "show copy dialog", I am able to use Alt + Tab to make the copy dialog reappear.

Ethan Hogue (clappboard) wrote :

Same issue here on 12.04. Why was the importance set to low? This bug makes it impossible to cancel single copy jobs, view the copy speed, etc. Much higher priority in my opinion.

florin (florin-arjocu) wrote :

True, it is a very important functionality bug, it should have a greater importance.

Sebastien Bacher (seb128) wrote :

happier? (tip: arguing over bug settings is not very useful though and will not make the issue automagically be resolved when the problem is too much work,not enough people to do it)

Changed in unity (Ubuntu Precise):
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High
Changed in unity:
importance: Low → High
florin (florin-arjocu) wrote :

Sorry, the plan is not to make people angry, but to realize that at least psychologically, for the users this is an important usuability bug. We always copy files, we always move files, of course we see this bug "in action" and it affects the way we work on the computer. In the end, the computer is a tool and is as good as one can use it.

Sebastien Bacher (seb128) wrote :

is the issue specific to copy dialogs that are minimized? if so the workaround is easy, just don't minimize the dialog, just focus whatever else you work with and let the copy on the background?

Changed in unity:
milestone: 5.14.0 → 5.16.0
Cobolt (cobolt-exe) wrote :

I've encountered this bug twice, each time on a different install of 12.04 on quite different hardware.
Has this seriously not been fixed yet? I would do it myself next week if I knew how but i'm just a php programmer... I do plan on getting inolved in the nearest possible future :)

surya prakash (suryabvsp1996) wrote :

yes,the alt+tab feature works shows the dialog after I pressed the "show copy dialog" option.
Seems the option works for small file transfers like around 100mb

alexsavio (alexsavio) wrote :

None of the above worked on my computer, running Ubuntu 12.04.1 amd64.
The transfer icon on the Unity panel shows up, but can't access the copy dialog in any way.

Changed in unity:
milestone: 5.16.0 → 5.18.0
Changed in unity:
milestone: 5.18.0 → 7.0.0
The Bright Side (me-knowingme) wrote :

Still occurs as described by alexsavio on Sep 8. Ubuntu 12.04 64-bit, Nautilus 3.4.2.

Daniel Haas (saahleinad) wrote :

Still occurs on my fresh (32bit) Ubuntu 12.04 install, Nautilus 3.4.2.

Are there any workarounds or fixes for users doing a lot of copy work (like me), not involving the terminal ?

EliCoten (launchpad-elicoten) wrote :

Bizarrely, I have found that using ALT+TAB to switch to the Desktop seems to bring back the copy dialog.

cacula (cacula) wrote :

same here on rairing x64 with all updates installed as of today

tags: added: raring
Lisa Schmidt (boxnotify) wrote :

Same here. Ubuntu 12.10 64-bit. I cannot get the copy dialog back at all.

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
lighten (workangelov) wrote :

Reproduced on 13.04 (x32)

tags: added: precise
adonet (jeroen-adolfse) wrote :

Same problem here with Ubuntu 12.04.2 64 bit running nautilus 3.4.2 (Nvidia) (Unity 3d)

eden6000 (eden6000) wrote :

So, if unity 7.0.1 (or at least some part of it) won't be backported to precise, how will this bug be solved??

The two unity and nautilus patches (linked above) need to be backported to 12.04... It's quite trivial to do that, so patches welcome :)

pcworld (pcworld) wrote :

Not even Ubuntu 13.04 ships Unity 7.0.1, it's still on 7.0.0.

eden6000 (eden6000) wrote :

Marco, if I was a programmer I would do that with much pleasure...best I can do is offer to you a beer if you come to Venice :-)

Changed in nautilus (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nautilus (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nautilus (Ubuntu):
status: New → Fix Released
Changed in nautilus (Ubuntu Precise):
status: New → In Progress
Changed in unity (Ubuntu Precise):
status: Confirmed → Invalid

eden6000, ok... Done that. I'll ping you when I'm in Venice :D

eden6000 (eden6000) wrote :

Quando vuoi Marco!

Sebastien Bacher (seb128) wrote :

I've uploaded the nautilus fix, it's in the precise SRU queue, up for review

description: updated

Hello Steven, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.4.2-0ubuntu9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Le 23/10/2013 03:40, David B a écrit :
> This should be backported to 12.04 (you know, the stable LTS ubuntu).
It has been backported, see the bug comments

I think this still appears at Unity 7.1.2 in OS: Saucy 13.10 64bit

I can confirm #30, still running into this issue with Nautilus 3.8.2

verify condition: ubuntu 12.04.3 in virtualbox

----------------------------------
Test Case:
- log into an unity session
- copy a not too small file (so you have time to interact with the copy dialog)
- minimize the copy dialog
- right click on the corresponding unity-launcher's icon, and pick "show copy dialog"
-> the dialog should be displayed.
----------------------------------

enable precise-proposed & install nautilus package.

$ sudo apt-get install -t precise-proposed nautilus
upgrade nautilus 1:3.4.2-0ubuntu8 1:3.4.2-0ubuntu9

----------------------------------
verification case:
- log into an unity session
- copy a file & folder about 500MB on nautilus.(copy dialog appear)
- minimize the copy dialog
- right click on the corresponding unity-launcher's icon, and pick "show copy dialog"
-> minimized copy dialog was appear(restored).
----------------------------------

good works & thank you.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for nautilus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu9

---------------
nautilus (1:3.4.2-0ubuntu9) precise; urgency=low

  * debian/patches/12_unity_launcher_support.patch:
    - Present the transfer window with server timestamp (lp: #887821)
 -- Marco Trevisan (Trevino) <email address hidden> Tue, 10 Sep 2013 16:28:29 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Marcus E (marcus+e) wrote :

I believe this issue still exists today in a fully updated 13.10.

nautilus --version
GNOME nautilus 3.8.2

unity --version
unity 7.1.2

The copy progress window seldom or never appears on my install neither on the desktop nor in alt-tab super-1. Not on any of the four virtual desktop spaces either. The right-click show copy window (or whatever it says on English-language installs) does not do anything. This has on several occasions made me think the copying was finished so I deleted the source files and only found out about my misstake after being greeted with the "error while copying" dialog window when the file that is apparently being copied has been removed.

Interestingly enough the side-bar seems to appear and shake the file manager icon when the copying has finished, not sure how useful that is on its own though, and I don't know if that notification stays on screen if I am AFK or just looking away for a moment.

Also copying seems to be very taxing on my computer -(i7 CPU with samsung 530 SSD) the UI becomes somewhat unresponsive while copying large files to backup USB-disks. This could possibly affect the main issue of the progress window not being displayed.

Sebastien Bacher (seb128) wrote :

@Marcus, please don't comment on old closed, open a new bug if you have a similar issue. Though it might be bug #1170647 which happens on external drives

no longer affects: unity/6.0

Bug is still present in fully update ubuntu 14.04.

Rob (surfdemon) wrote :

This is still present in 15.04 just installed and ran updates, copying from ext4 to ext4.

The copy status window did show until hidden by selecting "Show Desktop" in the switcher and then nothing would bring it back, status bar was showing on the files icon in the launcher but right clicking and selecting show copy dialog did nothing, also couldn't get it to open form the switcher.

Sorry if this is not in the correct place, this just seemed to be the main report for the problem that best matched, others I looked at said they were just copies of this bug report.

Kunjomachen (gitsythomas) wrote :

Still occurs on 15.04

Still occurs on 14.04

anatoly techtonik (techtonik) wrote :

How to bring it back to visible state on 14.04?

IbeeX (ibrkanac) wrote :

Still occurs on 16.04

Confirming for 16.04 (Xenial), the status needs to be changed to reflect this - or a new bug needs to be created. Please advise.

fix this bug for 16.04 LTS.

I got this bug on machines with 16.04 LTS.
On 14.04.4 LTS it's working fine.

wingman358 (wingman358) wrote :

Still experiencing this on fully updated 16.04 LTS

Bent Haase (bent-haase) wrote :

+ 1 Bug still occurring almost every time on Ubuntu 16.04 (latest updates)

William Clark (williclarkam) wrote :

This bug still happens most of the time on Ubuntu 16.04

Donald A. Dade (donald-dade) wrote :

I too see the same thing on Ubuntu 16.04. Using the Show Copy Dialog doesn't help because it just brings up another instance of Nautilus, not the copy dialog. Alt-Tab cycles through that, not the copy dialog.

hansl@vollbio.de (hansl-a) wrote :

Ctrl + Super + D brought the dialog back on Ubuntu 12.04.5 LTS x64. I hope this helps some of you.

Still experiencing this issue on 16.04.1. Please don't ignore!

Ben Capewell (tm-mbxntu-0x) wrote :

I'm having this problem on 16.04 LTS.

I did not minimise the copy dialog, but it seems that something triggered Kodi to come to the foreground while my TV was switched off overnight, after which I was unable to return to the copy dialog by any of the suggested means.

drps (alexandr-w) wrote :

faced up with this issue on 16.04

Mark Rowland (mr267) wrote :

also seeing this issue on 16.04.1

Siim Seestrandt (xiios) wrote :

I'm using 16.04.1 and once I've used "Show Desktop" while copying something there's no way to get progress windows back unless I logout/login (or was it reboot even?). Tried all workarounds I could find, messed around with wmctrl (which worked nicely on everything else except progress windows) and tried out "window-list" applet to no avail.

However, I found one way -- to install compizconfig-settings-manager and under "General Options" untick "Hide Skip Taskbar Windows". After logout/login or reboot when I'm yet again able to produce any progress windows, this setting leaves the progress windows open while hiding everything else which is ok for me/now.

Siim Seestrandt (xiios) wrote :

And if I explicitly minimize a progress window, it isn't shown in switcher but I can raise it using either "Show copy dialog" or from window-list applet.

Siim Seestrandt (xiios) wrote :

This disappearance also happens to delete confirmation windows. So I wrote a little bash script and made it autostart to always immediately remove "skip_taskbar" from these kinds of windows which makes them behave. Attached.

OzzyFrank (ubuntu-ozzyfrank) wrote :

Happens to me on a fresh install of 16.04.1. The progress dialogue was there until I hit Show Desktop - no keyboard shortcuts bring it back - right-click launcher in Unity panel and "Show Copy Dialogue" does absolutely nothing - I do not have an arrow-in-folder app-indicator on the top panel - nothing listed here or and web pages I've looked at. The only way I know it is still copying is that in the Unity launcher there is a small progress-bar across it, and if I bring up Properties for the target folder I can briefly see the number of files increase.

I really hoped this would have been fixed by now - this problem has plagued my brother since 12.04, and is one of the main reasons I ended up going KDE. But I figured I'd give Unity another shot on my new PC with a fresh install, and I'd really like to stick with it (but having no visible file operation progress basically kills it for me).

michalje (michalje) wrote :

ubuntu 16.04 still have this bug. this is fucking joke

Pierre (split-pierre) wrote :

Yeah, moving 14gb set of files, web projects, which means there are a LOT of small code files and the transfer takes quiet a LONG time, i'm at it for more than half an hour right now, suddenly, no transfer dialog. Don't know where it is, if it's ongoing, if its not, at least the progress bar is still showing and i guess it will finish, i just don't know when or where it is.

This bug may be small, for developers, but it's not for users man, it's a simple thing that makes all the difference. I'll never be sure if all the files of my clients where successfully transferred. Sad. So, again, a few more hours, again.

Ubuntu 16.04.1 - Bug is still alive.

eltimbalino (eltimbalino-org) wrote :

I believe I have the same issue in 16.04. But often, when copying files, disk-activity stops. I expect a notification, but there is none. So I minimise each window, looking for it, nothing. Then I have found that by switching to my nautilus file browser windows and then resizing them with ctrl+cmd+[arrows] one of them will not respond. Then by switching workspaces, finally my error notification turns up saying I have duplicate files, or a file could not be copied.

Once I say 'skip all' or what ever, the operation continues. Though sometimes I am then unable to get the copy dialogue to show again after trying everything.

I don't know if this is multiple bugs that show the same symptoms, but it seems to have been a problem in Ubuntu for a very long time. And file operations are a fundamental feature of an OS.

Julian Alarcon (alarconj) wrote :

This issue is still in Ubuntu 16.04.1 iso.

htrex (hantarex) wrote :

I'm seeing this problem with Ubuntu 16.04.2

Grzegorz (gregors) wrote :

Does anybody care about this? This bug is present in the system for a long time. Sometimes it occurs, sometimes works OK. Any known workaround?

Hassan Williamson (hazrpg) wrote :

This bug seems to still be present for me too - normally I'm not copying/moving files that are large enough for me to care. However it is home time at the office, I'm copying a large number of files onto an external drive, and I can no longer see the copy dialogue... this is frustrating because I don't know how long is left to be able to let my wife know when I'll be home.

It seems to happen more once there is an external drive is plugged in - for me at least - especially if I have nautilus tabbed. Hope this helps to replicate the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints