Launcher: icon pips are not always updated properly

Bug #1283775 reported by Doug McMahon on 2014-02-23
254
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Christopher Townsend
7.2
Fix Released
High
Christopher Townsend
unity (Ubuntu)
High
Christopher Townsend
Trusty
High
Unassigned

Bug Description

[Impact]

The number of pips next to the Launcher icon may not be accurate and lead the user to believe that the number of open windows for a particular app is not what is true in reality.

[Test Case]

1. Open up 2 Firefox windows.
2. Close one of the windows.

Pips (the little arrows) next to the Launcher icon should reflect the number of open windows.

[Regression potential]

None identified.

Original Description:

Only occurs when there is just 1 app's windows (unmaxed), assumes multiple workspaces is enabled
Test case:
Open nautilus (1 pip shows up
R. click nautilus icon > open another nautilus window (a 2nd pip does not show, likely due to Bug 1281816
Drag the 2nd naut window fully into current ws, 2nd pip still not shown
Click on Desktop, 2nd pip shows up

Close one of the naut windows, icon still shows 2 pips.
Click again on Desktop, 2nd pip is then removed

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20140220-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Sun Feb 23 12:28:18 2014
InstallationDate: Installed on 2014-02-22 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140222)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Sebastien Bacher (seb128) wrote :

Thanks, I can confirm those issues, no need to move workspace here, sometimes it just happens by doing "left click on nautilus in the launcher, right click on the icon -> open new win"

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Low → High
Sebastien Bacher (seb128) wrote :
Changed in unity:
importance: Undecided → High
milestone: none → 7.2.0
status: New → Confirmed
Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1

I would add that if for example I have opened Terminal and Nautilus and the focus is on Nautilus opening new Terminal with Ctrl+Alt+T shortcut or by right clicking on icon will result in pips updated properly.

Pips will not update if I open another window for the app that I have in focus.

For example I have Terminal window in focus and in the background maximized Chrome window and Nautilus then I open second and third Terminal window but launcher still displays one pip. Changing focus to another window or other interaction with environment will update pips.

Also pips update properly when you open new windows in Spread Mode or Expo Mode (Super + S).

Benjamin Sperisen (lasindi) wrote :

No one's mentioned this, but it's super-noticeable (and annoying) for Firefox as well (this is almost always how I experience it). To reproduce:

1. Start Firefox.
2. Press Ctrl+N.
3. See new window pop up, but just one pip on the launcher.

It's kind of sad that this very visible bug managed to get out in the new LTS release (it wasn't in 13.10) and still hasn't been fixed (not to be mean or anything, I still love Ubuntu). Is this because there are a lot of people who this does *not* affect?

If there's someone out there without this problem who stumbles across this, please comment?

JaSauders (jasauders) wrote :

I hate to sound abrasive as I too, like mentioned above, am an Ubuntu fan, but I'm somewhat surprised to see this hasn't been addressed yet. I'm finding it to be a common question that comes up as users want to know how to tell when an application needs attention. "You mean that faint line color is how I see that I just got a message??" (caused by the mismatched highlight) or "I can't see the dots to see how many firefoxes I have open. How do I adjust it?" I understand this issue was fixed in another report for 7.2.1, but A) where is it? And B) why on earth was this not pushed ASAP? As somebody who lives in the Ubuntu world I can tell you it's not a small frustration by any stretch. Given the fact this makes for a less consistent feeling interface, this turns into a hard sell for users who are used to the nice orange glow of the windows 7 icons needing attention or the continually bouncing icons in osx. That brings up another point as the icon highlights are a far cry from convenient when alerting users they just received a message. On screen popup is great but what about when I wasn't present when I received the message and come back a minute later? It needs to be more obvious without question. The envelope is no where near a logical answer either since few applications support it, plus it makes no sense to look on the upper right side to the envelope just to tell what application from the left side unity bar needs attention. Surely that should raise an eyebrow...

Benjamin Sperisen (lasindi) wrote :

jasauders, can you elaborate on the supposed fix that exists? Do you know anything else about where it is or what it is?

JaSauders (jasauders) wrote :

I apologize, I might have been semi incorrect with my post. According to this bug

https://bugs.launchpad.net/unity/+bug/1309739

the highlighted offset is a work in progress. It's my understanding that the pips and the highlighted edges are similarly controlled, as in if you fix one you fix the other. That said, it would stand to reason that some of these pips vs highlights bugs would be merged into one, but that doesn't appear to be the case, so maybe they're different.

Either way, I cannot put into words enough how soon I want to see that fix land. You'd think it's something that users wouldn't notice, but when it's already a poor way (highlighted edges, that is) to tell that an application needs attention AND they face a bug like this where it has offset highlighting and one pixel sized pips, it makes you realize how much bigger the problem is from a usability standpoint. I mean, just take a look at Skype (really this applies to any application but I'll pick on Skype here). Compare Skype idle vs Skype needing attention. The blue color differences might be two hex shades off, and the thickness is hardly a pixel wider when it needs attention. I mean, THIS is how we tell that we have a notification? This is one area where Windows 7 and OSX got it right. (man it hurts to say that)

Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)

Hi JaSauders,

I appreciate that you'd like to have better Launcher icon notifications, but let's please use bug #1319542 to track that and leave this bug to just track the Launcher icons pips not being properly updated when opening new windows of an already running app.

Thanks for your understanding!

Peter Roos (roospeteristvan) wrote :

Hi Christopher,

I am happy to see you assigned to this bug. Is there anything we can do in order to speed up the debugging process?

@Peter Roos as you can see in the "Related branches" Christopher already have a fix for this bug and the branch has been approved several hours ago.

Now we have to wait for SRU (Stable Release Update) of Unity with this fix. Unfortunately the SRU process sucks from user perspective and the fix might be weeks away from actually hitting Trusty repositories.

https://wiki.ubuntu.com/StableReleaseUpdates

JaSauders (jasauders) wrote :

I don't mean to turn the bug tracker into a Q&A session, but I am curious... is that to say that this fix will be in Unity 7.2.1 and Unity 7.2.1 will land as part of the next SRU? Do SRU's land on a consistent or scheduled basis (i.e. is this another term for say 14.04.1, 14.04.2, etc) or just as soon as logically possible to address certain issues?

Changed in unity:
milestone: 7.2.1 → 7.3.0

Since there is some question on how this fix will get out, this is what will happen.

First, we need to get this into trunk, which is the 7.3 branch. This will occur on what I believe will be the next landing into Utopic. After that occurs, we will then get the SRU process under way for Trusty. As Mateusz points out, this process can take a bit of time to finally get into trusty-updates, but we will keep pushing to get it done.

Thanks!

Benjamin Sperisen (lasindi) wrote :

Great, thanks for working on this and keeping us informed, Christopher!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140607-0ubuntu1

---------------
unity (7.2.0+14.10.20140607-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)

  [ Marco Trevisan (Treviño) ]
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general. (LP:
    #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)
 -- Ubuntu daily release <email address hidden> Sat, 07 Jun 2014 16:27:46 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Doctor Rover (doctor-rover) wrote :

Thanks for fixing this annoying bug!
Is there any estimate of when the fix can be expected in trusty?

Changed in unity:
status: In Progress → Fix Committed
Yanpas (yanpaso) wrote :

Why fix isn't commited to milestone 7.2.2 "14.04 SRU2"? Unity 7.1 is related to Saucy Salamander, ubuntu 13.10.

@Yanpas,

Sorry, I targeted it to the wrong milestone. We have this marked to be fixed in the next 14.04 Unity SRU which we will be working on soon.

Thanks!

Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated

Hello Doug, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

The version in trusty-proposed fixes this issue.

tags: added: verification-done
removed: verification-needed
Jorge Morais (jorgemorais) wrote :

Unity version from trusty-proposed fixes this issue. I have tested it for several days and did not notice and regression.

Peter Roos (roospeteristvan) wrote :

Today, I installed Ubuntu 14.04 64bit on a spare HDD, and applied all updates. I checked whether the bug still affected the system. It did. After that, I enabled the proposed repository and updated the system. I can also confirm, that the new version of unity fixes the issue (I don't have time for 'long term' testing, but as I see Jorge Morais's results are also promising).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
Benjamin Sperisen (lasindi) wrote :

This bug still affects me on 15.10. Is anyone else also experiencing it?

It works as it should for me on 15.10. I also checked LiveCD in VirtualBox and pips update properly.

Even in case when I have window opened in first workspace and then I open another window in second workspace and move it into first workspace and then back again to second. Pips are updated properly.

Maybe you should specify if it affects all programs or only some of them and other specific details. For example is this a problem with unmaximized windows or maximized, does it have anything to do with workspaces, any settings for Unity out of the default.

Benjamin Sperisen (lasindi) wrote :

I think it may be specific to having dual monitors, but it doesn't seem to be application specific: I have the issue when I've tried it with both Chromium (as below) and gedit.

Here's how I reproduce it on my system:

1. Start Chromium, which opens a window. (Launcher updates properly at this point with one pip.)
2. Move the window to the monitor that does not have the launcher (I have a launcher on my left monitor but not my right).
3. Open a new second Chromium window on the launcher-less monitor. There is still only one pip on the launcher.

Moving the window back to the monitor with the launcher makes the pips update correctly to 2 pips. Performing the whole procedure on the monitor with the launcher also makes it update properly.

Anyone else with dual monitors find similar behavior?

Changed in unity (Ubuntu Trusty):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers