Unity launcher icon edge illumination is offset

Bug #1309739 reported by Aibara Iduas on 2014-04-18
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Christopher Townsend
7.2
Fix Released
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Many users tend to change the size of the Launcher icons to better fit the screen resolution of their monitor or for personal tastes and workflow reasons. This issue causes the "edge glow" of icons to be offset at sizes less than 40 and greater than 56. This looks really ugly and unprofessional.

[Test case]

* Open CCSM->Ubuntu Unity Plugin->Launcher
* Change "Launcher Icon Backlight Mode" to "Edge Illumination Toggles"
* Change "Launcher Icon Size" to some value in the range described above such as 38.
* Make sure an application is open on the Launcher to see the edge glow around the icon.

[Regression Potential]

The texture itself may not look as nice on hi DPI screens when rescaling, but when the texture is offset from the icon, it would be hard to tell anyways.

Original Description:

In Unity, when using the edge illumination effect on launcher icons is offset. It shows to the top and left of the icons, but barely at all to the right and bottom.

This was not a problem before Trusty; in Saucy and previous releases the edges were aligned properly. See attached screenshots.

Related branches

Aibara Iduas (aibaraiduas) wrote :

I should add I'm using Unity 7.2.0, and that the edge illumination actually lines up if the icon size is set to the default 48. Going above or below that setting, however, causes the problem.

Daniel Woodworth (hdastwb) wrote :

Specifically, according to some testing I just did via CCSM (the slider in System Settings doesn't seem to work with my installation of Trusty for whatever reason…), edge illumination is not present for sizes up to 20, for sizes 21-39 it's offset, for sizes 40-58 it works perfectly, and for sizes 59 and up it's offset again (albeit without the small gap this time).

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 7.2.1
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
description: updated
Changed in unity:
milestone: 7.2.1 → 7.3.0
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140606.1-0ubuntu1

---------------
unity (7.2.0+14.10.20140606.1-0ubuntu1) utopic; urgency=low

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 13:55:32 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released

Hello Aibara, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

Edges are correctly illuminated with the version from trusty-proposed.

tags: added: verification-done
removed: verification-needed
Aibara Iduas (aibaraiduas) wrote :

Yes, that works. Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers