Ubuntu One crashed on launch

Bug #441039 reported by Matthew Nestor on 2009-10-03
This bug affects 604 people
Affects Status Importance Assigned to Milestone
Android's Fortune
Undecided
Unassigned
Ubuntu One Client
High
dobey
ubuntuone-client (Ubuntu)
High
dobey

Bug Description

Binary package hint: ubuntuone-client

Ubuntu One crashed when I attempted to launch it. No window appeared, only bug report window.

ProblemType: Crash
Architecture: i386
Date: Fri Oct 2 19:07:05 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/ubuntuone-client-preferences
InterpreterPath: /usr/bin/python2.6
Package: ubuntuone-client-gnome 0.96.0-0ubuntu1
ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-client-preferences
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
PythonArgs: ['/usr/bin/ubuntuone-client-preferences']
SourcePackage: ubuntuone-client
Title: ubuntuone-client-preferences crashed with IOError in save_config()
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Matthew Nestor (mtthw-nestor) wrote :
tags: removed: need-duplicate-check
dobey (dobey) on 2009-10-05
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → In Progress
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
milestone: none → w25-karmic-finalfreeze
status: New → In Progress
tags: added: ubuntuone-karmic
dobey (dobey) on 2009-10-05
visibility: private → public
RichardN (ricnmn) wrote :

I starts fine now. First time and second time I started it it crashed.
I remember that I have also started the client itself, after the prefernces app crashed two times....

Possible solution:
start 'ubuntuone-client-applet' from a commandline and close it
start 'ubuntuone-client-preferences' from the system->preferences menu.

I suspect that the first command creates some configuration (file) so that the preferences command can save some preferences to that file....

Can someone confirm this?

On Mon, Oct 5, 2009 at 12:04 PM, RichardN <email address hidden> wrote:

Possible solution:
> start 'ubuntuone-client-applet' from a commandline and close it
> start 'ubuntuone-client-preferences' from the system->preferences menu.

ubuntuone-client-applet threw an error that it can not start
ubuntuone-client-preferences.

Now the preferences widget launches okay from the menu.

Now things apparently run okay. When I launch the applet it takes me to a
launchpad site to log in . . . .

-d

--
http://dannyman.toldme.com

Danny Howard (dannyman) wrote :

On Mon, Oct 5, 2009 at 12:27 PM, Daniel Howard <email address hidden> wrote:

>
> Now things apparently run okay. When I launch the applet it takes me to a
> launchpad site to log in . . . .

. . . except I get this ubuntu one "Launchpad Login Service" which knows who
I am. I click "Sign In" and the page re-renders itself.

https://login.launchpad.net/+openid

Is this Ubuntu One stuff really ready for production?

-d

--
http://dannyman.toldme.com

John Carlyle-Clarke (jpcc) wrote :

I get the same problem with an endless sign-in loop.

BCboy (hans-urbanerosion) wrote :

Confirmed RichardN.. it worked for me anyway.

On Mon, Oct 5, 2009 at 12:04 PM, RichardN <email address hidden> wrote:

> I starts fine now. First time and second time I started it it crashed.
> I remember that I have also started the client itself, after the prefernces
> app crashed two times....
>
> Possible solution:
> start 'ubuntuone-client-applet' from a commandline and close it
> start 'ubuntuone-client-preferences' from the system->preferences menu.
>
>
> I suspect that the first command creates some configuration (file) so that
> the preferences command can save some preferences to that file....
>
> Can someone confirm this?
>
> --
> Ubuntu One crashed on launch
> https://bugs.launchpad.net/bugs/441039
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu One Client: In Progress
> Status in “ubuntuone-client” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: ubuntuone-client
>
> Ubuntu One crashed when I attempted to launch it. No window appeared, only
> bug report window.
>
> ProblemType: Crash
> Architecture: i386
> Date: Fri Oct 2 19:07:05 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/ubuntuone-client-preferences
> InterpreterPath: /usr/bin/python2.6
> Package: ubuntuone-client-gnome 0.96.0-0ubuntu1
> ProcCmdline: /usr/bin/python /usr/bin/ubuntuone-client-preferences
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> PythonArgs: ['/usr/bin/ubuntuone-client-preferences']
> SourcePackage: ubuntuone-client
> Title: ubuntuone-client-preferences crashed with IOError in save_config()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

dobey (dobey) wrote :

Then "sign in" looping is a separate issue with the OpenID system, and is being looked at. I don't recall the bug # for it right now though.

Changed in ubuntuone-client:
status: In Progress → Fix Committed
lemonpeel (froggoy) on 2009-10-08
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
win7guru (win7guru) on 2009-10-09
Changed in ubuntuone-client (Ubuntu):
assignee: Rodney Dawes (dobey) → nobody
dobey (dobey) wrote :

On Fri, 2009-10-09 at 16:48 +0000, win7guru wrote:
> ** Changed in: ubuntuone-client (Ubuntu)
> Assignee: Rodney Dawes (dobey) => (unassigned)
>

Please explain.

Andrea Pennelli (pennelli) wrote :

Rodney,

it's easy to explain, simple ubuntu one crash.
I'm using a localized (italian) version of karmic.

Ciao
Andrea

> On Fri, 2009-10-09 at 16:48 +0000, win7guru wrote:
>> ** Changed in: ubuntuone-client (Ubuntu)
>> Assignee: Rodney Dawes (dobey) => (unassigned)
>>
>
> Please explain.
>
> --
> Ubuntu One crashed on launch
> https://bugs.launchpad.net/bugs/441039
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

dobey (dobey) wrote :

On Fri, 2009-10-09 at 17:35 +0000, Andrea Pennelli wrote:
> Rodney,
>
> it's easy to explain, simple ubuntu one crash.
> I'm using a localized (italian) version of karmic.
>
> Ciao
> Andrea

Hi Andrea,

Yes. I've already fixed the problem in TRUNK. I was asking for
explanation on why someone seemingly uninvolved in the process decided
it was necessary to remove me from the "Assigned To" for the bug against
the package. :)

Thanks.

Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
ingenieropatito (ferrettolove) wrote :

You right Andrea I am using the English version of Karmic running in a
IBM thincentre P4
with 2 Gb mem, I check on internet what is this program for and I gave
it a try and just when I tried to open a window indicating the
ubuntuone client has crashed appear.
On Fri, Oct 9, 2009 at 2:00 PM, Rodney Dawes <email address hidden> wrote:
> On Fri, 2009-10-09 at 17:35 +0000, Andrea Pennelli wrote:
>> Rodney,
>>
>> it's easy to explain, simple ubuntu one crash.
>> I'm  using a localized (italian) version of karmic.
>>
>> Ciao
>> Andrea
>
> Hi Andrea,
>
> Yes. I've already fixed the problem in TRUNK. I was asking for
> explanation on why someone seemingly uninvolved in the process decided
> it was necessary to remove me from the "Assigned To" for the bug against
> the package. :)
>
> Thanks.
>
>
> ** Changed in: ubuntuone-client (Ubuntu)
>     Assignee: (unassigned) => Rodney Dawes (dobey)
>
> --
> Ubuntu One crashed on launch
> https://bugs.launchpad.net/bugs/441039
> You received this bug notification because you are a direct subscriber
> of the bug.
>

S1 (blin) wrote :

Let's wait for updatings and we will check up work of the client.

Changed in ubuntuone-client:
assignee: Rodney Dawes (dobey) → nobody
dobey (dobey) wrote :

Please explain this change to this bug. Why do you think it should be
unassigned?

On Sat, 2009-10-10 at 14:11 +0000, Andrea Pennelli wrote:
> ** Changed in: ubuntuone-client
> Assignee: Rodney Dawes (dobey) => (unassigned)
>

Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.0-0ubuntu1

---------------
ubuntuone-client (1.0.0-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Limit log messages, file size, and rotate more often (LP: #435137)
    - Rotate oauth-login.log and cap the file size (LP: #445514)
    - Remove pycurl usage in favor of urllib and better errors (LP: #411029)
    - Save the syncdaemon settings for bw limiting (LP: #418882)
    - Fix NoSuchDatabase when pairing desktopcouch (LP: #438411)
    - Fix IOError when launching preferences window (LP: #441039)
    - Update icons to remove Ubuntu logo, better names (LP: #434886)
    - Use ngettext for the possibly singular notification (LP: #449269)
    - Only create Places bookmark when first authorizing (LP: #397749)
    - Don't always recreate the bookmark (LP: #401211)
    - Handle showing emblems better (LP: #440839)
    - Remove the System->Preferences menu item (LP: #443342)
    - Remove NotOnlineError usage (LP: #404550)
    - Set a default share name in the Nautilus sharing UI (LP: #369488)
    - Simplify some state handling (LP: #420354)

 -- Rodney Dawes <email address hidden> Mon, 28 Sep 2009 18:15:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Garrido (andgarrido) wrote :

my computer is um dual core, but the cpu2 100% and cpu1 20% or less

2009/10/12 Rodney Dawes <email address hidden>:
> Please explain this change to this bug. Why do you think it should be
> unassigned?
>
> On Sat, 2009-10-10 at 14:11 +0000, Andrea Pennelli wrote:
>> ** Changed in: ubuntuone-client
>>      Assignee: Rodney Dawes (dobey) => (unassigned)
>>
>
>
> ** Changed in: ubuntuone-client
>     Assignee: (unassigned) => Rodney Dawes (dobey)
>
> --
> Ubuntu One crashed on launch
> https://bugs.launchpad.net/bugs/441039
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

dobey (dobey) on 2009-10-13
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Luc (luc-lirette) on 2009-10-21
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Tom Dison (fretinator) wrote :

I am updated to the release 9.10, and Ubuntu One still crashes when I try to launch it. There are no updates available, and it seems this is marked fixed, so is there anything I can do?

dobey (dobey) wrote :

Hi Tom, I think you are experiencing a different issue, for which the
fix is currently in proposed updates for Karmic, and should make it to
the updates archive soon.

The issue in this bug was that the preferences app
(ubuntuone-client-preferences) was having an issue starting up, when the
config directory or file didn't already exist. And this specific issue
has been fixed.

If you want to file a new bug, using the "Report a Problem" menu item on
the applet, or by running "ubuntu-bug ubuntuone-client" we can look at
your issue individually and determine if it's a new issue or if it's a
dup of an already existing issue.

Thanks.

On Thu, 2009-10-29 at 14:07 +0000, Tom Dison wrote:
> I am updated to the release 9.10, and Ubuntu One still crashes when I
> try to launch it. There are no updates available, and it seems this is
> marked fixed, so is there anything I can do?
>

Bupyc (bupycnet) on 2009-10-29
Changed in ubuntuone-client:
status: Fix Released → Incomplete
Tom Dison (fretinator) wrote :

I restarted, and saw that I am now receiving the error, "Capabilities Mismatch". It complains that my version of the client is newer than the server. I opened this as a separate bug.

Matt Griffin (mattgriffin) wrote :

The "Capabilities Mismatch" is a known issue that we're working to resolve. If you're using the beta PPA, you can run Update Manager and get the fix. Non-beta users will have the fix soon. Follow bug 462828 or our blog (http://one.ubuntu.com/blog/) for further updates.

dobey (dobey) wrote :

Please do not go round changing bugs from Fix Released to Incomplete. If
you think the status should be changed, then please instead add a
comment suggesting so, and why you think so. The original issue in this
bug has been fixed. If other people think they have similar issues, they
need to file new bugs, so we can determine what issues they are having.
Thanks.

On Thu, 2009-10-29 at 15:50 +0000, Bupyc wrote:
> ** Changed in: ubuntuone-client
> Status: Fix Released => Incomplete
>

Changed in ubuntuone-client:
status: Incomplete → Fix Released
Juan Sorroche (juan-sorroche) wrote :

I have the same problem on my MSI Wind U100x. My netbook is up-to-date.

If you need more information, please contact me.

dobey (dobey) on 2009-12-03
affects: calculator-generator → null
Changed in androidsfortune:
status: New → Invalid
Changed in null:
status: New → Invalid
dobey (dobey) wrote :

Ajay, I don't know what you think this has to do with Calculator Generator or Android's Fortune, but there is nothing related to them in this report. You've just created unneccessary work and spam for developers of all 3 projects. Please don't go around adding additional projects to bugs without validating with developers that the same bug is actually in other projects first. Thanks.

dobey (dobey) wrote :

Hi Juan,

I'm not sure why you think you're having this bug... You're getting a traceback when you run "ubuntuone-client-preferences" from the command line? If not, this is not your bug. Thanks.

Juan Melendez (juanmelendez) wrote :

Hi Rodney,

Back when I reported this, UbuntuOne was indeed crashing and bringing up the error dialog when I invoked the preferences dialog. A few updates later (now) I've not seen a crash again since. Whatever crashed then is not occuring now... I can say that Python was updated at least once since then. Thanks Rodney.

Lindy (lindy) wrote :

I see the icon .. but it usually crashes after a while, showing an "!".

I guess I maybe should have created a new bug report after all. :/

Juan Sorroche (juan-sorroche) wrote :

Mea Culpa !

In fact, I have the same bug that Lindy. :-s

Sorry for the inconvenience. Thanks.

Prabhpreet (prsinghdua) wrote :

Ubuntu automatically filed the report for this and then I manually started Ubuntu one and now it seems to work fine. I am using 64 bit ubuntu karmic and the english version.

shoguneagle (shoguneagle) wrote :

Evidently problem not fixed; just crashed on startup; using English Version; 64 bit Ubuntu Karmic

AceKing (acviper) wrote :

I still can't connect using 9.10 32 bit. The cloud just sits with an exclamation point through it. When I click on it the "Disconnect" button quickly flashes as if it's looping and trying to connect.

Eric Desre (edesre) on 2010-03-10
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: Fix Released → Fix Committed

Hi,

I'm having the same problem, for no reason, the ubuntu one client crashes if i try to connect with the tray
I tried to launch it from the console without success

tagir (tagir-raimov) on 2010-04-07
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Sandro (sandroid) wrote :

Just added my voice to this. I've just updated to most recent packages etc available, and I got this crash for the first time actually, when I came back from the reboot. gwibber-accounts crashed at the same time

I had this issue as well on my laptop. It took me 3 fresh installs to get it working. This may not be any help, but here are the things I did different in the last install...
1. Had my laptop hardwired into the network throughout the entire install. I noticed that it would try to sync time and timezones with servers at the begining, and i didn't have it plugged in so it couldn't reach them.
2. I logged into my Ubuntu one account before I set up the client on my laptop and removed all the registered computers.
3. I was patient. It took a minute or two but it finally started syncing...

I hope the time sync thing helps in the resolution of this bug. In the past I have experienced all kinds of wierd bugs in Windows when the time was off...

Good Luck to you all.

Giovanni G. (giovanni-g) wrote :

giovanni@pc-giovanni:~$ ubuntuone-preferences
/usr/share/themes/Murrine-Sky/gtk-2.0/gtkrc:45: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
/usr/share/themes/Murrine-Sky/gtk-2.0/gtkrc:51: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/Murrine-Sky/gtk-2.0/gtkrc:54: Murrine configuration option "gradients" is no longer supported and will be ignored.
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 1146, in <module>
    prefs_dialog = UbuntuOneDialog()
  File "/usr/bin/ubuntuone-preferences", line 538, in __init__
    self.__construct()
  File "/usr/bin/ubuntuone-preferences", line 978, in __construct
    self.devices.list_devices()
  File "/usr/bin/ubuntuone-preferences", line 382, in list_devices
    fsync_enabled = self.sdtool.is_files_sync_enabled()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/tools.py", line 708, in is_files_sync_enabled
    return get_user_config().get_files_sync_enabled()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 148, in wrapped
    return meth(self, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 321, in get_files_sync_enabled
    return self.get_parsed(MAIN, 'files_sync_enabled')
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/config.py", line 266, in get_parsed
    return self.default.get(section, option).value
  File "/usr/lib/python2.6/ConfigParser.py", line 311, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: '__main__'

dobey (dobey) on 2010-08-27
Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.