DVD playing is not working correctly with totem-gstreamer

Bug #41335 reported by Toby Smithe on 2006-04-25
480
This bug affects 26 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
Totem
Invalid
Medium
totem (Baltix)
High
Mantas Kriaučiūnas
totem (Debian)
Fix Released
Unknown
totem (Ubuntu)
Medium
Jack
Declined for Feisty by Sebastien Bacher
Declined for Gutsy by Henrik Nilsen Omma
Nominated for Hardy by Philipp Schlesinger

Bug Description

I have the current version of Dapper installed on my Dell Inspiron 6000. When I insert a DVD it begins to play successfully; however, there are no menus. If I try to see a menu (with an option in the Go menu), it fails. If I try to stop and restart the DVD, it fails. If I exit, reopen Totem and try to play the DVD it tells me the I "do not have the correct plugins to handle it." I have got libdvdcss2, libdvdnav4, and totem(-gstreamer) installed. I've seen bugs similar to this, but none the same. I've tested this issue with my Region 2 LOTR: The Two Towers disc.

Thanks for your bug. Do you use totem-gstreamer or totem-xine?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

totem-gstreamer

On 25/04/06, Sebastien Bacher <email address hidden> wrote:
>
> Thanks for your bug. Do you use totem-gstreamer or totem-xine?
>
> ** Changed in: totem (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs
> Status: Unconfirmed => Needs Info
>
> --
> Totem refuses to play DVDs in some situations with Dapper
> https://launchpad.net/bugs/41335
>

That's a known issue, totem with gstreamer0.10 doesn't support subtitles nor menus yet...

Changed in totem:
status: Needs Info → Confirmed

So why isn't it playing?

On 26/04/06, Sebastien Bacher <email address hidden> wrote:
>
> That's a known issue, totem with gstreamer0.10 doesn't support subtitles
> nor menus yet...
>
> ** Changed in: totem (Ubuntu)
> Status: Needs Info => Confirmed
>
> --
> Totem refuses to play DVDs in some situations with Dapper
> https://launchpad.net/bugs/41335
>

playing what? maybe your comment describe different issues, please use different bugs if that's the case. No menu is due to the feature not being worked yet

Sorry, I thought the no menu effect was part of the same problem. If it's
known, I'm not going to file it as a different bug. However, my originaly
bug was that if I put a DVD in the drive, and it automatically played, I
could not "fast forward","rewind", or skip tracks. If I quit Totem, and
tryed to play the disc manually, it told me it was unable, with the message
I orignallly filed in the bug. Obviously, I have the correct plugins
installed, as the disc played in the first place.

On 26/04/06, Sebastien Bacher <email address hidden> wrote:
>
> playing what? maybe your comment describe different issues, please use
> different bugs if that's the case. No menu is due to the feature not
> being worked yet
>
> --
> Totem refuses to play DVDs in some situations with Dapper
> https://launchpad.net/bugs/41335
>

As said before totem with gstreamer0.10 has no subtitle nor menu feature, so you can't change the track, language, etc, that's known and being worked upstream. There is bug #27951 about that

Ah, OK. That's excellent.

On 27/04/06, Sebastien Bacher <email address hidden> wrote:
>
> As said before totem with gstreamer0.10 has no subtitle nor menu
> feature, so you can't change the track, language, etc, that's known and
> being worked upstream. There is bug #27951 about that
>
> --
> Totem refuses to play DVDs in some situations with Dapper
> https://launchpad.net/bugs/41335
>

This still doesn't explain why DVDs work when inserted through totem-gstreamer but do no work when you tell totem "Play Disc". Why does totem work in one instance but not the other?

I just think that upstream support is very poor. Probably those
functions are not complete, or are badly implemented by totem-gstreamer.

On Tue, 2006-05-30 at 00:49 +0000, jond wrote:
> This still doesn't explain why DVDs work when inserted through totem-
> gstreamer but do no work when you tell totem "Play Disc". Why does totem
> work in one instance but not the other?
>

totem-gstreamer needs to work to play DVD finely, that will probably be done upstream next cycle

Onkar Shinde (onkarshinde) wrote :

I have also faced this issue on my Dad's laptop. The model is HP Compaq NX6120 (if that matters).

Hi

Has this bug been reported to upstream?

Thanks

Le vendredi 03 novembre 2006 à 07:40 +0000, kmon a écrit :
> Hi
>
> Has this bug been reported to upstream?

what bug? totem-gstreamer doesn't implementing menus, subtitles
selection and other features too? They know about it, no need of bugs
for that

Ok thanks

Adam Ambrose (aambrose99) wrote :

I note that the upstream bug 27951 has been marked as fixed with totem (1.5.92) and gstreamer 0.10.4, but this bug still occurs on totem 2.18.0 with gstreamer 0.10.12. Hence, I think this issue is a separate one from 27951.

John Leach (johnleach) wrote :

I'm still having the autoplay problem with the latest Feisty updates. If I insert a dvd ,it autoplays with no problem (minus the menus) but I can't get Totem to start playing it again manually.

If I open Totem, and click Movie -> Play Disc 'FIGHT_CLUB' I get a message box saying: "Totem cannot play this type of media (DVD) because you do not have the appropriate plugins to handle it."

It's a bit confusing considering that autoplay works well enough.

I still see this bug too. It seems that, with the default media player (totem-gstreamer), DVD playback isn't very usable. Some menu options (Play Disc) fail with cryptic error message, fast forward and rewind buttons don't work, and DVD menus don't work. In fact, depending on the DVD structure, some DVDs play the extras first.

Assuming there isn't now time to get these features into gstreamer, perhaps it would be worth considering totem-xine as the default for the Feisty release? Totem-xine seems to have all this functionality already and resolves these issues as far as I can see.

Failing that perhaps disabling DVD playback in totem-gstreamer and warning the user to switch to totem-xine would be better than this partial support?

Eugenia Loli-Queru (eloli) wrote :

Totem-gstreamer does not have DVD support. Unless someone sits down and adds full support for it, you are all better off with totem-xine or VLC. The company that does a lot of gstreamer work (sorry, can't remember the name) can't add DVD support for legal reasons. It will have to be a community member who will have to do the work.

Eugenia, you are bringing a lot of light into this issue for me by your last comment, thanks. Could you point to a link regarding that "Fluendo cannot do it, it must be community-made" thing? That's the first time I hear it and I could not find traces of it on the Net.

Surely if they can ship Windows Media codecs (for a fee, because Microsoft would not let them distribute them for free), why couldn't they do the same for DVD playback?

Sebastien Bacher (seb128) wrote :

They can't work on opensource code because they are working on a binary version and they signed a non disclosure clause.

Sebastien Bacher (seb128) wrote :

We will not use totem-xine, gstreamer is integrated with GNOME, work correctly on most videos, has reactive upstream and is the way to go and the code required to read encrypted DVD can't be shipped on the CD anyway

Sebastien Bacher (seb128) wrote :

the target option is meant to be used when a bug doesn't apply to the current version, no need to use it on 7.04

just voicing my support here for the gstreamer backend; I truly feel it is the "right" way and that we should keep it even if that means crappy DVD support at the moment (for which you can install gxine alongside totem).

Eugenia Loli-Queru (eloli) wrote :

Jeff, as Sebastien said, Fluendo is not allowed to do that work (I know this for a fact). It will have to be a community member who adds the DVD support to gstreamer.

Onkar Shinde (onkarshinde) wrote :

IMHO, this bug is not about 'not able to play DVD with gstreamer backend'. It is about not being able to play it one particular way (File->Play Disc) while it plays properly in another way (automatic start of totem when DVD is inserted).
Taking into account the fact that there is no menu, subtitle support, I think Totem should be able to play DVD with File -> Play Disc. And the user expects this behavior because he can see the DVD playing when totem starts up automatically when DVD is inserted.

Carlos Laviola (claviola) wrote :

I'm experiencing the same problem on feisty.

Insert DVD. It starts playing automatically thanks to autoplay.
Close totem.
Start totem.
Go to Movie -> Play Disc "foo".

Receive the following error:

"Totem cannot play this type of media (DVD) because you do not have the appropriate plugins to handle it.
 Please install the necessary plugins and restart Totem to be able to play this media."

philb28 (philb28) wrote :

I have this problem too. Also Feisty. Exactly the same procedure ate Carlos has said above.

kseise (kevin-seise) wrote :

Same problem here. Other players work OK. Ogle works fine. Totem refuses to play the DVD.

pchunt (pchunt) wrote :

I would just like to add that launching a DVD using:

# totem dvd://1

works fine, what would be the difference in how 'Go to Movie -> Play Disc "DISC_NAME"' launches the DVD?

David Jaša (dejv) wrote :

Can somebody point me to gstreamer upstream bug about dvd menu, please?

Hi, I have the same problem on my Ubuntu/Dell XPS 410: generally DVDs play just fine in auto-play, but if I stop the playing and then try to 'Play Disk' it gives me the "do not have the correct plug-ins to handle it." Finally, also for me typing "# totem dvd://1" from a a terminal works flawlessly all the times. By the look of it (it works in auto-play and from a terminal using "# totem dvd://1", but "Play Disk" doesn't) it seems more like a minor problem to fix that has nothing to do with the proper plug-ins being installed. This is my very first bug report, but I couldn't try to follow up upstream if some gentle soul would indicate my the way to :-)

Martin Olsson (mnemo) wrote :

I've heard several people complain about this particular bug. I suppose desktop Linux has come a long way since dapper.

Tiede (marcarthur) wrote :

Sadly, it has not come far enough. I am still having the same problem in Feisty... TODAY.
Dvd autoplays fine, but brings up an error message if opened from File->Play Disk.
Doesn't display subtitles or bring up any menus...
After a whole year...

I know it's not recommended, but I am afraid I am going to have to do what I always did before: Install totem-xine... :(

Tiede wrote:
> Sadly, it has not come far enough. I am still having the same problem in Feisty... TODAY.
> Dvd autoplays fine, but brings up an error message if opened from File->Play Disk.
> Doesn't display subtitles or bring up any menus...
> After a whole year...
>
> I know it's not recommended, but I am afraid I am going to have to do
> what I always did before: Install totem-xine... :(
>
>

Try following magic first...

sudo apt-get install xine-ui && xine --auto-scan dvd --auto-play=fhq
--no-splash

...to work around the problem.

  --Toni

David Jaša (dejv) wrote :

Toni, your magic works problem around. It changes nothing on fact, that dvd playing with totem-gstreamer just sucks and somebody should fix it. IMNSHO it's a shame for Canonical, that their favoured player can't play DVD seamlessly after three and half years of Ubuntu distribution's existence.

Eugenia Loli-Queru (eloli) wrote :

David, exactly. Ubuntu supports totem-gstreamer, not totem-xine. Therefore, they must fix the DVD support, instead of waiting for the community to do that. I have emailed the guys behind gstreamer and they said they WON'T do it because they have NDAs and they can't possibly touch DVD code. This is something for the ubuntu guys to do if they want their OS to be more complete.

Sebastien Bacher (seb128) wrote :

Ubuntu can't ship with DVD support for legal reason

Eugenia Loli-Queru (eloli) wrote :

Sebastian, please, we know that. But so you can't ship with AAC or even MP3 either. But you DO provide a way for users to download these codecs on their own accord when such files are popping up. I am asking for the same trick to be employed here. But for totem-gstreamer, not the much unsupported now totem-xine. Proper DVD support must be added on totem-gstreamer and when the user pops up a DVD disk, the right files should be downloaded, after the user has agreed to your disclaimer/license.

Toni Ruottu (toni-ruottu) wrote :

Sebastien Bacher wrote:
> Ubuntu can't ship with DVD support for legal reason
>
>

Sure it can. It just can't ship with support for breaking
Content Scrambling System, which is used in some DVDs
to limit market areas. There are lots of "areacode 0" DVDs
that work fine without it.

Even DeCSS is illegal only in some parts of the world. Such
packages are the reason why Medibuntu exists.

  --Toni

Onkar Shinde (onkarshinde) wrote :

I don't think the debate is about whether Ubuntu can ship libdvdcss2. The debate is that even after user installs libdvdcss2, DVD playing works one way (put DVD in drive, totem starts playing it) and not the other (Movie->Open Disc menu of totem).

That menu items needs to be fixed and this is the same thing that original reporter is expecting. Please correct me if I am wrong.

Sam Morris (yrro) wrote :

Ubuntu and DVD playback

Well, I guess there are really three issues here.

First, Canonical feels they cannot ship libdvdcss because doing so would be illegal in various countries due to their implementations of the WIPO Copyright Treaty[0]. For instance, the United States has the Digital Millennium Copyright Act; various European countries have implemented the European Union Copyright Directive[1] which has the same effect in the United Kingdom, Spain, the Czech Republic, Finland and France.

[0] http://en.wikipedia.org/wiki/WIPO_Copyright_Treaty
[1] http://en.wikipedia.org/wiki/European_Copyright_Directive

I presume that Canonical does this based on sound legal advice; they would probably only consider changing this policy if somehow the UK's Copyright and Related Rights Regulations (2003) is overturned or amended to legalise the production and distribution of devices or software that permit the circumvention of DRM, and if the same happened in the US and the other countries listed. As this is a legal problem and not a technical problem, this bug tracker is probably not the appropriate forum to discuss it. Ideally this bug would be marked FORWARDED to the bug trackers of the parliaments of the countries where this legal minefield exists.

The second problem will be easier to fix; it is the fact that GStreamer itself has incomplete support for DVD playback. The major stumbling block in this area is the support for DVD menus, and the fact that the GStreamer developers do not seem to be willing or able to work on this area themselves.

The third problem is totem-gstreamer's incomplete support for DVD playback via the GStreamer API. The impression I get from upstream is that this will not be worked on until the DVD playback functionality of GStreamer itself is finished. IMO, this is a shame as Totem could currently be usefully improved to work with the functionality that GStreamer currently provides. For instance, when the user tries to play a DVD, Totem could construct a playlist consisting of dvd://1, dvd://2, and so on, one entry for each chapter on the DVD. DVD menu support would still be missing, but that is not a huge problem (some may even call it a benefit). I started to work on this myself, but I discontinued the effort because I got the impression that such a patch wouldn't be accepted by upstream anyway.

David Jaša (dejv) wrote :

Sam, thank you for your comment. IMO the only illegal part, CSS decrypting stuff, has been solved in acceptable way for a long time already. You can install a package and if you confirm that CSS is not illegal in your case, some script installs it for you or alternatively, you can add external Medibuntu repository and install necessary stuff on your own accord.

The real problem is unsupported DVD menu in Gstreamer, which can't be coded by Fluendo folks (who AFAIK are most of gstreamer developers) due to signed NDA's. But this is not be problem for people connected with Ubuntu project or employed in Canonical Ltd, is it?

Sebastien, could you reply to this or Sam's comment, please?

Sebastien Bacher (seb128) wrote :

Canonical has limited ressources and doesn't do lot of upstream work for the moment, I agree that the feature would be nice to have though

dark2star (dark2star) wrote :

Hi,

> Dvd autoplays fine, but brings up an error message if opened from
> File->Play Disk.
> Doesn't display subtitles or bring up any menus...
> After a whole year...
>
> I know it's not recommended, but I am afraid I am going to have to do
> what I always did before: Install totem-xine... :(

well, I can't really comment on the topic, because I didn't dive into the depths of gstreamer/xine for a really long time. But I can say a few words on DVD playback. I really like VLC (Video Lan Client), so I've been using it. It does play DVDs with menu support (IIRC) once vlc and libdvdcss are installed. Also it's a rather slim media-player, so I like it ;-) Although I think, it doesn't integrate as well as gstreamer, so it's not really an option. But probably it could be associated with DVD playing (only)? Just as a temporary solution until gstreamer is complete in that function?

Ciao.
--
Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kanns mit allen: http://www.gmx.net/de/go/multimessenger

flamboyant (flamboyant) wrote :

Sam Morris wrote on 2007-10-19:
... I started to work on this myself, but I discontinued the effort because I got the impression that such a patch wouldn't be accepted by upstream anyway.

why that impression, Sam? why wouldn't they accept such a patch? even if so, can you please place your patch just here? thank you

davidc (scienceinthegreen) wrote :

I got confused by this. Totem-gstreamer properties in synaptic clearly states (wrongly?) amongst its many features : "DVD (with menus)". Please assume ubuntu users are idiots. Ok, please assume I am:-)

I insert my dvd movie (not commercial or encrypted) in drive. All codecs, etc installed ok, just in case. Hit the button. Few seconds later an error message: pops up. Which makes me sad:(

Please, for your next upgrade, state clearly and simply that I require totem-xine before I can watch a dvd. If I knew what I was doing I would still be a Debian user. I have now installed totem-xine, along with some other players and (sometimes after a little playing around) am now able to play just about every video and audio format I have found.

Thanks everyone, I know you do your best:-)

Mantas Kriaučiūnas (mantas) wrote :

davidc wrote 13 hours ago:
> Totem-gstreamer properties in synaptic clearly states (wrongly?) amongst its many features : "DVD (with menus)". Please assume ubuntu users are idiots.

I think the best way to solve the problems in open source software is to report and fix the bugs ;)
So, I've reported a bug about lie in totem-gstreamer package description - look at bug #161826
I think it's very easy to fix totem-gstreamer package description in next upload ;)

So, it seems one developer started to fix DVD playing problems with totem-gstreamer - look at http://bugzilla.gnome.org/show_bug.cgi?id=476149

There are bugfixes and adds of missing some important features like seeking for dvdnavsrc. Developers, please read the comments and improve the patch code from http://bugzilla.gnome.org/476149

Changed in totem:
status: Unknown → Confirmed
amano (jyaku) wrote :

It is good to see at least some movement here.

But if these efforts come to nothing (possible patches not accepted,...), I like dark2star's proposal most: If the vlc package is installed, make vlc the default DVD program.

I think that option should be doable for the Ubuntu team without having to get involved with upstream things.

Sebastien, would that be doable? At least Totem shouldn't pop up when inserting a dvd.

Changed in gstreamer:
status: Unknown → New
Changed in totem:
status: Unknown → Confirmed
Fernando Botelho (my-lists) wrote :

The first time I inserted a DVD, Toten came up and it worked fine. The second time I tried to watch a DVD it failed as others have described above, but the second DVD was from a different region. Could this be a factor?

Eugenia Loli-Queru (eloli) wrote :

no

I have created a tracker bug about this issue in Gnome Bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=502609

The GStreamer and Totem bugs that this bug is currently linked to
http://bugzilla.gnome.org/show_bug.cgi?id=350311
and http://bugzilla.gnome.org/show_bug.cgi?id=344415
are not really on point (in that, even if they are solved, this bug would not be fixed). Could somebody please remove those bug watches and link this Launchpad bug to http://bugzilla.gnome.org/show_bug.cgi?id=502609 ? Then we can correctly depend on that upstream bug's status etc.

That bug has links to the other two bugs anyway.

Changed in gstreamer:
status: Unknown → Confirmed
Changed in totem:
status: Unknown → New
Changed in totem:
status: New → Confirmed
Benoît Rouits (brouits) wrote :

on gutsy, totem-gstreamer still cannot read DVD since gstreamer0.10-dvd has disapeared, i guess.
I have libdvdread3 and libdvdcss2 so mplayer and totem-xine can play DVD flawlessly.

Changed in gstreamer:
status: Confirmed → Fix Released
Changed in totem:
status: Confirmed → Invalid
zombiepig (nyall-zombiepigs) wrote :

Looks like there may be a solution to part of the problem, with the latest totem svn supporting playback via gstreamer.

As per http://www.hadess.net/2008/02/new-tla-features.html
"Totem GStreamer in SVN got 2 new acronym-laden features. First is DVD playback. Unfortunately, we still don't do menus, but now you'll be able to play the films on your DVD. The support is on-par with the old GStreamer 0.8 code. Thanks to Tim for the guidance in writing this code."

Hopefully these changes get included in totem in hardy, then all we'll need is gstreamer support for dvd menus for playback to work correctly!

Sam Liddicott (sam-liddicott) wrote :

Until totem-gstreamer has menus working, can we please NOT have it set as the default, but use totem-xine instead.

I'm using Hardy and my children keep getting frustrated because totem-gstreamer keeps getting installed with updates.
It's a load of crock and stops them watching their DVD's, please don't make half-baked packages the default when there is another alternative that has worked for years.

Eugenia Loli-Queru (eloli) wrote :

Gstreamer is where the community is going, Xine-lib is not. Yes, it's frustrating that DVD menus don't work on totem-gstreamer, but I would suggest you keep that package, and use VLC to watch your DVDs, not Totem.

I don't think updating is supposed to turn your totem-xine into
totem-gstreamer, if that is really
the case, then I suggest you file a bug against
that.

  --Toni

On Sat, 2008-02-16 at 08:24 +0000, Sam Liddicott wrote:
> Until totem-gstreamer has menus working, can we please NOT have it set
> as the default, but use totem-xine instead.
>
> I'm using Hardy and my children keep getting frustrated because totem-gstreamer keeps getting installed with updates.
> It's a load of crock and stops them watching their DVD's, please don't make half-baked packages the default when there is another alternative that has worked for years.
>

AL (altash) wrote :

This is my second posting. After adding and removing Gstremer and Xine packages I finally managed to get audio from Totem using Gstreamer but still no video. I been at it for days still no success. Is there a Linux Codec(plug-in) for purchase ? The video that came with the O.S. plays fine, but using DVD player and movie DVD is the problem.
My computer is a 7 years old desktop, self assembled with ATI rage 128 meg memory, and 384 meg system memory .FIC motherbord with Awards bios(bios date is 2000). If Cononical wants this O.S. to enter corporate and consumer market they must quickly solve this kind of problems in order to be taken seriously. As of today this O.S. is not ready for any kind of market and this is very strange after many years of development.Why they released Totem when they know it doesn't work? strange! I tought I discovered something fantastic. Mr.Sutterland needs new technical and corporate strategies if he wants to compete with Microsoft.

AL (altash) wrote :

MY third posting. If you are wondering , yes I read the entire Ubuntu website and all the information that they had to offere, I even did google search on Totem problem. Still no solution . I wonder why they recommend using terminal commands as oppose to using synaptic package manager or using Add/Remove option. As Ubuntu recommended I typed this at the termina but I got error message:
sudo /usr/share/doc/libdvdread3/examples/install-css.sh

Messages says: Command not found.

so I added this using synaptic manager.

After doing this I added extra Codecs for Gstreamer from Universe and multiverse reposotory.
still no luck , Now I'm only getting sound from Totem, but no video.
I hope all of you can share your experiences in step by step manner if you managed to solve the problem. Thanks

bhuvi (bhuvanesh) wrote :

similary avi video playback is little bit slower in totem it seems totem skips some frames during playback

exactt (giesbert) wrote :

i think the problem is (half-way) solved in hardy. see https://bugs.launchpad.net/ubuntu/+source/totem/+bug/192542 which might be a duplicate after all.

*This* is the sort of problem Canonical should be working on...

Not making it easy for Windows users to switch (new Ubuntu 8). People will
switch on their OWN if the system just works.

My 2 cents.

cenora

On Tue, Mar 25, 2008 at 10:23 AM, exactt <email address hidden> wrote:

> i think the problem is (half-way) solved in hardy. see
> https://bugs.launchpad.net/ubuntu/+source/totem/+bug/192542 which might
> be a duplicate after all.
>
> --
> DVD playing is not working correctly with totem-gstreamer
> https://bugs.launchpad.net/bugs/41335
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

fyew@earthlink.net (fyew) wrote :

I Think the main problem is that files VIDEO_TS.VOB and VIDEO_TS.IFO are not read (I think file VIDEO_TS.IFO would contain some frame information). As results:

1. Not showing menue.
2. Can not jump to next chapter.
3. Fast forward/Backward problem.

Frank

phinn (phinnvr6) wrote :

As of Ubuntu 8.04 with Totem Movie Player 2.22.1 (version that installs with 8.04) this problem is far from fixed. Totem (seemingly randomly) either crashes, freezes, tells me my CDROM isn't responding (yea right).

VLC on the other hand works a lot better, but still isn't perfect.

Mantas Kriaučiūnas (mantas) wrote :

Added link to correct bugreport for DVD menus support in Gstreamer

Changed in gstreamer:
status: Unknown → Confirmed

Im' subscriber of bug 272955. Totem still refuses to read dvds. In terminal following phrases appear:

** (totem:20673): DEBUG: Init of Python module
** (totem:20673): DEBUG: Registering Python plugin instance: YouTube+TotemPythonPlugin
** (totem:20673): DEBUG: Creating object of type YouTube+TotemPythonPlugin
** (totem:20673): DEBUG: Creating Python plugin instance

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1678 ***
*** for info_length % sizeof(uint32_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

libdvdread: Invalid title IFO (VTS_01_0.IFO).
*** Zero check failed in ifo_read.c:1539
    for c_adt->zero_1 = 0x0038

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1678 ***
*** for info_length % sizeof(uint32_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

libdvdread: Invalid title IFO (VTS_01_0.IFO).

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1678 ***
*** for info_length % sizeof(uint32_t) == 0 ***

*** libdvdread: CHECK_VALUE failed in ifo_read.c:1543 ***
*** for info_length % sizeof(cell_adr_t) == 0 ***

libdvdread: Invalid title IFO (VTS_01_0.IFO).
** Message: Error: Impossibile leggere dalla risorsa.
dvdreadsrc.c(919): gst_dvd_read_src_create (): /play/source

So what now?

Changed in totem:
status: Confirmed → Triaged
Changed in gstreamer:
status: Confirmed → Unknown

Situation improved after upgrade to 8.10...

Changed in gstreamer:
status: Unknown → Fix Released
Michael Nagel (nailor) wrote :

i dont know if my problem is a duplicate of this... but totem-gstreamer still does not play retail dvds with a up-to-date ubuntu intrepid ibex. it displays a dialog with *"internal dataflow error"*

situation has definitely not improved for me with intrepid.

Michael Nagel (nailor) wrote :

besides this report looks like a dump for all "ubuntu still does not handle dvd playback properly"-bugs

it is not clear if this is about having to install obscure libraries to have any chance, or about totem crashing with messages to stdout/error/debug or about totem refusing to play with "internal dataflow error" or about the mess as a whole. besides the summary/desciption in the first post is very outdated considering this problem has been dealed with since dapper...

i'd suggest to try to seperate the problems, open new reports (that dont get marked as duplicates) and see if something can be done about the different aspects of the problem.

ps: i am of the opinion that not being able to watch dvds is a major showstopper for many casual desktop users and should be addressed more thoroughly -- even if there are licensing problems.

I'm closing this bug report because it's sheerly a mix of different issues (there are many), and will not lead to any fix by developers. Please continue to report bugs about DVD playback, but separately. We need precise informations and feedback to track bugs. And there are already several reports that should cover the bugs you're experiencing: see bug 260765, bug 41335, bug 219062, bug 137527, or others...

And great work is going on about thaThanks!

Changed in totem:
status: Triaged → Invalid

[Manual error] And great work is going on about that, and it's likely that things will be much improved in Jaunty!

Michael Nagel (nailor) wrote :

a) part of the problem is -- in my opinion -- that there is not one defined part that is broken but that it is -- more or less -- still a big mess but i'll try to report more precise bug-reports

b) could you provide me a pointer to what is going on?

Toni Ruottu (toni-ruottu) wrote :

Milan, have you checked the "duplicates" for this bug. People used to report all kinds of issues, but many of them where marked as duplicates for this bug because playing dvd's wasn't supported "at all". Maybe one should check, if those are really duplicates and setting correct statuses for the ones that are actually different.

Michael: I definitely agree with a. But precisely because there's work to get out of this mess, I'd like to separate issues so that we can sort out the ones which correspond to Intrepid, where the DVD playback system is completely different in Totem.

If you want informations about that, see bug 260765, and http://gstreamer.freedesktop.org/wiki/DvdPlayback. The new GStreamer plugin is called resindvd and has been blogged about this summer. It's not considered as stable for now, and only included in gsteeamer-plugins-bad (itoften breaks DVD playback when used).

Toni: It could be nice to browse all duplicates here, but it can be a real pain. I'd rather wait for new bugs to be reported in Intrepid and Jaunty, since it's only there that we'll be able to improve resindvd. I don't expect upstream developers to work much on issues present in the old plugin. Still, totem-specific issues may still be present when using resindvd, so it may be good to find them...

shawn (rice2442) on 2009-01-17
Changed in totem:
status: Invalid → New

shawn: Please don't reopen this bug without giving a precise reason to. I'm absolutely willing to investigate if you have a precise problem with DVD playback, but then please open a new report. This one is going nowhere because of the mess, and you can be sure no developer will work on it.

Changed in totem:
status: New → Invalid
importance: Unknown → Undecided
status: Confirmed → New

Debian bug is outdated too, and was requested to be closed.

Changed in totem:
status: New → Invalid
Michael Nagel (nailor) wrote :

can the baltix task on this be closed as well so we can move on and concentrate on the newer, more individual bugs?

Michael Nagel (nailor) wrote :

closing, as suggested, to concentrate on more individual bugs

Changed in totem (Baltix):
status: In Progress → Invalid
ojybmw (ojybmw) on 2009-06-15
Changed in totem (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
Changed in totem (Ubuntu):
status: New → Invalid
Diane Perez (coolitgirldd) wrote :

please fix this problem for me because my favorite movies can not play at all. And I am very sad. Can you please help me. Thank You from Diane

Toni Ruottu (toni-ruottu) wrote :

@Diane: Do you have any idea about what exactly is not working? Do some movies work correctly?

If you are trying to watch a film protected by a regional code, it will not work out of the box. There are approximately two solutions to that problem.

1) install package libdvdcss2 from Medibuntu ( see http://www.medibuntu.org/ ). It does not cost anything, but may be legally questionable under some countries, which is why the package is not already part of your current Ubuntu installation.

2) buy a dvd player product for your Ubuntu from Fluendo ( see http://www.fluendo.com/ ).

In case you go with option 1, this bug thread may still be relevant to you. However, please, note that dvd playback has improved slightly with the latest version of Ubuntu. So in case you are using a version older than 9.04 upgrading to the latest edition may help a bit.

Patrick M (prmillius) wrote :

Forget GStreamer. Install VLC player. GStreamer has issues with menus.

Toni Ruottu (toni-ruottu) wrote :

@Patrick: You know we ought to fix the default player instead of pointing people towards different applications. That way we'll end up having one application for each format.

Hi

funny thing is, that even the VLC play does not show display. it works, and gives audio- but no picture!!

GS streamer simply crashes.

so I found a way out- I start the VLC player- and put it in pause mode.
then start the GS streamer, and the GS streamer works !! with picture, and audio both with most formats (mp4, flv etc)

therefore it means that the VLC player is loading something, which then is utilized by the GStreamer player?

Best
mayank

> Date: Thu, 16 Jul 2009 06:42:41 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 41335] Re: DVD playing is not working correctly with totem-gstreamer
>
> Forget GStreamer. Install VLC player. GStreamer has issues with menus.
>
> --
> DVD playing is not working correctly with totem-gstreamer
> https://bugs.launchpad.net/bugs/41335
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
NEW! Get Windows Live FREE.
http://www.get.live.com/wl/all

Reinhard Tartler (siretart) wrote :

mayank <email address hidden> writes:

> funny thing is, that even the VLC play does not show display. it works,
> and gives audio- but no picture!!
>
> GS streamer simply crashes.
>
> so I found a way out- I start the VLC player- and put it in pause mode.

probable explanation: This causes vlc to allocate an xv port, which is
then unavailable to GS

> then start the GS streamer, and the GS streamer works !! with picture,
> and audio both with most formats (mp4, flv etc)

GS fails then to open an xv port, and falls back to X11 video.

> therefore it means that the VLC player is loading something, which then
> is utilized by the GStreamer player?

no, I rather assumes it blocks access to "something". you can try if
starting vlc with 'vlc -V x11' to check if I'm right.

This should also be configurable in totem somewhere, but I don't know
how the video output module can be selected.

If I am right, this is most certainly a problem in your videodriver.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Hello

solved the problem:

selected default output plug-in x window system (no xv) in Gstreamer and now it works !!
thank you for your help!

best
mayank

> Date: Fri, 17 Jul 2009 05:21:36 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Bug 41335] Re: DVD playing is not working correctly with totem-gstreamer
>
> mayank <email address hidden> writes:
>
> > funny thing is, that even the VLC play does not show display. it works,
> > and gives audio- but no picture!!
> >
> > GS streamer simply crashes.
> >
> > so I found a way out- I start the VLC player- and put it in pause mode.
>
> probable explanation: This causes vlc to allocate an xv port, which is
> then unavailable to GS
>
> > then start the GS streamer, and the GS streamer works !! with picture,
> > and audio both with most formats (mp4, flv etc)
>
> GS fails then to open an xv port, and falls back to X11 video.
>
> > therefore it means that the VLC player is loading something, which then
> > is utilized by the GStreamer player?
>
> no, I rather assumes it blocks access to "something". you can try if
> starting vlc with 'vlc -V x11' to check if I'm right.
>
> This should also be configurable in totem somewhere, but I don't know
> how the video output module can be selected.
>
> If I am right, this is most certainly a problem in your videodriver.
>
> --
> Gruesse/greetings,
> Reinhard Tartler, KeyID 945348A4
>
> --
> DVD playing is not working correctly with totem-gstreamer
> https://bugs.launchpad.net/bugs/41335
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
NEW! Get Windows Live FREE.
http://www.get.live.com/wl/all

Jack (unclexjack) on 2009-07-25
Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Jack (unclexjack)
status: Invalid → New
Changed in gstreamer:
status: Fix Released → Fix Committed
Jack (unclexjack) on 2009-07-25
Changed in totem (Debian):
importance: Undecided → Unknown
status: Invalid → Unknown
Changed in gstreamer:
status: Fix Committed → Fix Released
Griffen Gowan (wiccamon) on 2009-07-31
Changed in gstreamer:
status: Fix Released → Confirmed
Changed in gstreamer:
status: Confirmed → Fix Released
Binasio (binasiow) on 2009-08-04
Changed in gstreamer:
status: Fix Released → Incomplete
Changed in gstreamer:
status: Incomplete → Fix Released
Changed in totem (Ubuntu):
status: New → Invalid
sean (seanmirsh) on 2009-09-08
Changed in gstreamer:
status: Fix Released → Incomplete
status: Incomplete → Confirmed
status: Confirmed → Fix Committed
Changed in gstreamer:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
Changed in gstreamer:
importance: Unknown → Medium
Changed in totem (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.