synaptic crashed with SIGSEGV in File() (or in pkgRecords::Lookup()) when trying to remove residual config files for packages without the fields: "Lastest Version" and "Description"

Bug #1097532 reported by siucdude on 2013-01-09
488
This bug affects 150 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
High
Michael Vogt

Bug Description

Synaptic crashes when clicking on a row under "Status" -> "Not installed (residual config)" that is missing a "Latest Version" and "Description".

Package doesn't seem to matter when above condition is met.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: synaptic 0.80~exp1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Tue Jan 8 18:41:57 2013
ExecutablePath: /usr/sbin/synaptic
InstallationDate: Installed on 2010-05-17 (967 days ago)
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MarkForUpload: True
ProcCmdline: /usr/sbin/synaptic
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7f91ca9eb534 <_ZN10pkgRecords6LookupERKN8pkgCache15VerFileIteratorE+20>: mov (%rax),%eax
 PC (0x7f91ca9eb534) ok
 source "(%rax)" (0x7f97fce82000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: synaptic
StacktraceTop:
 pkgRecords::Lookup(pkgCache::VerFileIterator const&) () from /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: synaptic crashed with SIGSEGV in pkgRecords::Lookup()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

siucdude (siucdude) wrote :
information type: Private → Public

StacktraceTop:
 File (this=<optimized out>) at ../build/include/apt-pkg/cacheiterators.h:394
 pkgRecords::Lookup (this=0x2aac310, Ver=...) at pkgrecords.cc:62
 RPackage::srcPackage (this=0x4ebc560) at rpackage.cc:123
 RGPkgDetailsWindow::fillInValues (me=0x27f0380, pkg=0x4ebc560, setTitle=<optimized out>) at rgpkgdetails.cc:255
 updatePackageInfo (pkg=0x4ebc560, this=0x27f0380) at rgmainwindow.cc:414

Changed in synaptic (Ubuntu):
importance: Undecided → Medium
summary: - synaptic crashed with SIGSEGV in pkgRecords::Lookup()
+ synaptic crashed with SIGSEGV in File()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
pablomme (pablomme) wrote :

From duplicate:

The problem was with selecting (clicking on) libtelepathy-logger2 in "Not Installed (Residual Config)". libtelepathy-logger2 shows no "Installed version", "Available version", etc, in the listing. This package was just replaced, if I remember correctly, by libtelepathy-logger3 in an update (with lt-l2 remaining installed as far as I could tell), but beyond that I don't know what about this package should cause synaptic to misbehave. The package was successfully removed after the crash with apt-get remove --purge libtelepathy-logger2, and synaptic no longer misbehaves.

tags: added: bugpattern-needed

Crashes when clicking on a row under "Status" -> "Not installed (residual config)" that is missing a "Latest Version" and "Description".

Package doesn't seem to matter when above condition is met.

==11483== Invalid read of size 4
==11483== at 0x4EA3994: pkgRecords::Lookup(pkgCache::VerFileIterator const&) (in /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12.0)
==11483== by 0x44D3E1: ??? (in /usr/sbin/synaptic)
==11483== by 0x4428EB: ??? (in /usr/sbin/synaptic)
==11483== by 0x4349D7: ??? (in /usr/sbin/synaptic)
==11483== by 0x434FED: ??? (in /usr/sbin/synaptic)
==11483== by 0x6461A16: _g_closure_invoke_va (gclosure.c:840)
==11483== by 0x647B7EF: g_signal_emit_valist (gsignal.c:3225)
==11483== by 0x647BF21: g_signal_emit (gsignal.c:3370)
==11483== by 0x5940842: gtk_tree_view_real_set_cursor (gtktreeview.c:13228)
==11483== by 0x5944431: gtk_tree_view_button_press (gtktreeview.c:3129)
==11483== by 0x582D49B: _gtk_marshal_BOOLEAN__BOXED (gtkmarshalers.c:85)
==11483== by 0x646174F: g_closure_invoke (gclosure.c:777)
==11483== by 0x647374C: signal_emit_unlocked_R (gsignal.c:3604)
==11483== by 0x647B449: g_signal_emit_valist (gsignal.c:3324)
==11483== by 0x647BF21: g_signal_emit (gsignal.c:3370)
==11483== by 0x595C77D: gtk_widget_event_internal (gtkwidget.c:6303)
==11483== by 0x582B44D: propagate_event (gtkmain.c:2403)
==11483== by 0x582D184: gtk_main_do_event (gtkmain.c:1716)
==11483== by 0x5DA45E1: gdk_event_source_dispatch (gdkeventsource.c:358)
==11483== by 0x66E9E84: g_main_context_dispatch (gmain.c:3054)
==11483== by 0x66EA1C7: g_main_context_iterate.isra.22 (gmain.c:3701)
==11483== by 0x66EA639: g_main_loop_run (gmain.c:3895)
==11483== by 0x582C4A4: gtk_main (gtkmain.c:1160)
==11483== by 0x4165E7: ??? (in /usr/sbin/synaptic)
==11483== by 0x79BFEA4: (below main) (libc-start.c:260)
==11483== Address 0x6619cb000 is not stack'd, malloc'd or (recently) free'd
==11483==
==11483==
==11483== Process terminating with default action of signal 11 (SIGSEGV)
==11483== Access not within mapped region at address 0x6619CB000
==11483== at 0x4EA3994: pkgRecords::Lookup(pkgCache::VerFileIterator const&) (in /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12.0)

papukaija (papukaija) wrote :

Unduplicating and making this bug the master bug as this one has a valgrind log.

tags: added: metabug
description: updated
summary: - synaptic crashed with SIGSEGV in File()
+ synaptic crashed with SIGSEGV in File() (or in pkgRecords::Lookup())
+ when trying to remove residual config files for packages without the
+ fields: "Lastest Version" and "Description"
papukaija (papukaija) on 2013-04-11
tags: added: i386
description: updated
tags: removed: bugpattern-needed

This patch solves it for me.

Returning name() instead of "" might be a good idea. I don't see any difference but there's a logic in it. Maybe I'm just blind.

The attachment "rpackage.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Brian Murray (brian-murray) wrote :

Could you take a look at this Michael? There is a patch in the comments.

Changed in synaptic (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Michael Vogt (mvo) on 2013-04-18
Changed in synaptic (Ubuntu):
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

Thanks for the patch, it looks fine. I merged it into trunk and uploaded to debian/experimental. Once its available there I will send a sync request to raring and hope it can still make it.

Changed in synaptic (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.80~exp2

---------------
synaptic (0.80~exp2) experimental; urgency=low

  [ Robert Roth ]
  * merged lp: ~bkerensa/synaptic/fix-for-1153409
    thanks to Benjamin Kerensa:
      - Fix Typo
      - Add Homepage Field to debian/control

  [ Michael Vogt ]
  * po/de.po:
    - fix typo, thanks to Zac Diggum

  [ Patrik Lundquist ]
  * common/rpackage.cc:
    - fix crash when srcPackage does not have a version
      (LP: #1097532)

 -- Michael Vogt <email address hidden> Thu, 18 Apr 2013 20:05:02 +0200

Changed in synaptic (Ubuntu):
status: In Progress → Fix Released
Mario Rugiero (mrugiero) wrote :

Just to inform the fix works for me.

MMlosh (mmlosh) wrote :

Confirming, no more crashes with 0.80~exp2

No more that I can recall

On Mon, Apr 22, 2013 at 9:35 AM, MMlosh <email address hidden> wrote:

> Confirming, no more crashes with 0.80~exp2
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1158962).
> https://bugs.launchpad.net/bugs/1097532
>
> Title:
> synaptic crashed with SIGSEGV in File() (or in pkgRecords::Lookup())
> when trying to remove residual config files for packages without the
> fields: "Lastest Version" and "Description"
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/1097532/+subscriptions
>

--
He who does not cultivate his own fields, shall die of hunger.
Giunean Proverb

One who looks for a friend without faults will have none.
Hasidic Proverb

Jane Atkinson (irihapeti) wrote :

This problem, or something very similar, is still happening in 13.10 with synaptic v. 0.80~exp2

Daniel Hartwig (wigs) wrote :

On 6 May 2013 06:54, Jane Atkinson <email address hidden> wrote:
> This problem, or something very similar, is still happening in 13.10
> with synaptic v. 0.80~exp2
>

Or something very similar? Is it a crash under the same conditions,
at the same point or not?

Use apport to report a new bug with required stack traces, etc. so
that this can be determined.

Jane Atkinson (irihapeti) wrote :

New bug filed at Bug #1176700

To post a comment you must log in.