skype experiences lag with pulseaudio

Bug #311497 reported by atreju on 2008-12-26
100
This bug affects 13 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

Hello,

I also experience the bug reported by other people in ubuntu forums (http://ubuntuforums.org/showthread.php?t=976850) and skype forums (http://forum.skype.com/index.php?s=ff9fe7109c9a98db249b5c6a6c334883&showtopic=237601&st=0&p=1059071&#entry1059071):

The problem is that when making a call on skype outgoing audio lags by several seconds; incoming is fine. This is clearly not due to any network latency issues. One possible workaround mentioned in the forums above apparently is to use plughw or hw devices in skype instead of pulseaudio. For me plughw does not work at all, I'm still investigating hw;

I know that skype is horrible and closed source and I don't want to start a discussion about whether it is skypes fault or pulseaudios fault, but it would be nice if this would just work...

This is running Ubuntu 8.10 with the latest updates.
pulseaudio: 0.9.10-2ubuntu9.1
skype: 2.0.0.72-1
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Thanks,

atreju

Daniel T Chen (crimsun) wrote :

Two workarounds:
1) use jaunty,
2) use pasuspender -- skype

Changed in pulseaudio:
importance: Undecided → Low
status: New → Confirmed
willhollins (will-hase) wrote :

I can confirm that this bug is in jaunty too. I have a Dell M1530 and experienced this bug combined with https://bugs.launchpad.net/ubuntu/+source/linux/+bug/275998 and was very frustrated, neither of these affected me in Ibex.

Åskar (olskar) wrote :

I can confirm that this bug is still in Jaunty 5 february. What info is needed on this bug?

dmuir (dmuir) wrote :

Changing your sound in to hw or plughw for Sound In (Skype options) may help for skype-to-skype calls. The problem here is two fold, and is affected by pulseaudio (in particular, its buggy ALSA plugin) as well as the network stack. Skype uses two different audio encodings. One for skype-to-skype, and another for skype-out. The former uses larger packets and works fine, while the latter uses smaller packets, and the network stack is unable to handle it. So for me, calling skype-to-skype works fine, but skype out still has major lag (sometimes over 10 seconds).
There should be a new linux version of Skype out sometime soon... maybe... crossing fingers... which is supposed to work better with pulseaudio. But if I'm right about the network stack, then it might only solve issues with skype-to-skype calls, and not skype-out calls.
Haven't tried pasuspender yet though. Will try that later today.

mabawsa (mabawsa) wrote :

Got this problem too in Jaunty.

Ara Pulido (ara) wrote :

This is happening in Jaunty as well.

The only working workaround that I found useful is to have the audio configuration set as follows:

Sound In: hw0
Sound out: pulse
Ringing: pulse

Botond Szász (boteeka) wrote :

Sound In: hw0
Sound out: pulse
Ringing: pulse

Although this is the only way that you can make Skype produce and accept any sound, it doesn't work for me. After a couple of seconds sound starts to break up, and finally Skype freezes. I only can close it by killing it. Basically Skype in this current Jaunty configuration is unusable. There is no way I can make a call. It used to work with the Jaunty Alphas and Intrepid. But from since around the first beta or the 6th alpha it doesn't work anymore.

Pierpaolo Follia (pfollia) wrote :

I ended removing pulse audio package. It's the only solution that allow me to use skype without problems.

Liam (liamgarvey) wrote :

Same problem, getting up to 120 seconds of lag on some calls. Did not have this problem on 8.04 which I have just migrated from.

temp fix by directing skype audio i/o to hw devices instead of pulse.

Jan Krčál (jan-krcal-gmail) wrote :

Upgrade to skype 2.1 beta solved this problem for me.

dmuir (dmuir) wrote :

Solved it for skype to skype calls, but not skype to phone. No lag, but no sound in that case.

Alex Gaynor (alex-gaynor) wrote :

I am still experiencing this problem on the latest 9.10 beta, prior to this I wasn't using pulse for Skype, after upgrading I am and the problems have started since.

olegio (olegio) wrote :

Skype CPU usage increases after certain time. Chat messages cannot be delivered.
$ pkill skype-real -- doesn't work.
Prior to this I wasn't using pulse for Skype, after upgrading I am and the problems have started since.

Additional observations: Under Karmic, audio input seems unaffected, but audio output is. Video is actually faster than audio. Upgrading to upstream versions of PA and ALSA (0.9.21 and 1.0.21 respectively) does not resolve the issue.

Identical lag is observed in Empathy's Google Talk voice chat plugin.

My earlier comment contradicts the original report, but is confirmed to be the case. Further experimentation has revealed that the lag is device dependent (!) -- using a Logitech USB audio dongle, the audio input has no appreciable lag, but the Skype and Google Talk output is behind by about 2 seconds. Using the internal sound device of my laptop, both have no appreciable lag, but other PulseAudio issues make Skype unusable. When the lag is occurring, syslog continuously logs messages like the following:

Dec 18 11:18:13 jturner-tablet pulseaudio[2266]: ratelimit.c: 496 events suppressed

... with different numbers of events being suppressed.

Have you tried using the latest skype beta? It supports pulseaudio natively.

I did *not* have this bug in Karmic, but it appeared after upgrading to Lucid. Both incoming and outgoing audio is laggy. This is with skype 2.1.0.47 on a Dell Inspiron 1420.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
tjk (tim-klassen) wrote :

I'm currently using Karmic. I need the fixes in this current version of PA because it seems to have fixed the problems of outgoing landline calls in Skype. But... do I HAVE TO upgrade to lucid to get these fixes?

Pax Unix (paxunix) wrote :

I had the issue of audio lag with Skype; pulseaudio 1:0.9.19-0ubuntu4.1

Upgraded Skype to the latest version, 2.1.0.81, and my lag is gone. It may be worthwhile for those experiencing the problem to upgrade Skype before trying to install the latest pulseaudio.

amadues (throwbaca) wrote :

Step #18 states that this bug was fixed in 1:0.9.22~0.9.21+341-g62bf. However, with the latest version of pulseaudio on lucid (1:0.9.21-32-g8478) and skype 2.1.0.81 the bug is still present.

"pacmd list-sink-inputs" shows current latency of 2020.00 ms compared to 16.00 ms requested latency for skype client.

I am also seeing the ratelimit.c error during this time:

Feb 21 10:36:37 localhost pulseaudio[1992]: ratelimit.c: 928 events suppressed

It looks like https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/511558 is tracking a similar issue.

amadues (throwbaca) wrote :

Update:

commenting out "load-module module-suspend-on-idle" in /etc/pulse/system.pa and /etc/pulse/default.pa and restarting pulseaudio solved the problem for me.

I'm running the same versions as amadues and also still have this problem.

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Daniel T Chen (crimsun) wrote :

Which actual package version of pulseaudio do you have installed in Lucid?

Changed in pulseaudio (Ubuntu):
status: Confirmed → Incomplete

I was running 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu1 and still had this problem, but when I tried again today it worked fine, so a recent update must've fixed it for me. I believe the update was

[UPGRADE] libpulse-browse0 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu1 -> 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu4

Sorry for the noise.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers