Ubuntu

internal mic capture very low volume when routed through pulseaudio

Reported by hendrikwout on 2008-09-29
396
This bug affects 55 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
PulseAudio
Unknown
Unknown
alsa-lib (Fedora)
Won't Fix
Unknown
alsa-lib (Ubuntu)
Wishlist
Daniel T Chen
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Nominated for Lucid by alexsimps
linux (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Nominated for Lucid by alexsimps
pulseaudio (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Nominated for Lucid by alexsimps
pulseaudio (openSUSE)
Invalid
Undecided
Unassigned

Bug Description

Hi,

I have a dell xps m1530 laptop with the following internal audio device:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

In hardy, sound recording from the internal mic works great, but in Ibex sound recording with the internal mic is very silent. I can't make it louder with the gnome volume control and alsamixer.

See https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275998/comments/109 for a temporary solution

description: updated
description: updated
description: updated
description: updated
description: updated
Srix (srix) wrote :

Recording with the internal mic. on a Dell Vostro 1500 (Intel Corporation 82801H (ICH8 Family)) used to work in Hardy, but stopped working with Intrepid Alpha 6 in most applications.
Recording in Audacity works, but with the recording device set to OSS:/dev/dsp. Sound Recorder, Empathy, Ekiga, etc. (using Alsa) do not work.
When attempting to stop the recording Sound Recorder hangs for a long time before coming back to life, and recorded file is completely silent.
In the Volume Control applet, with the Device set to HDA Intel (Alsa mixer), the Recording tab shows all controls (Capture, Digital, Mux) with the audio recording toggled OFF (small red cross on the mic. icon under each vertical slider). Even after toggling the icon, it goes back to toggled off the next time the volume control is opened.

hendrikwout (hendrikwout) wrote :

Srix: I think you discribed another bug. I can record, but it is very silent.

shadowed (shadowedings) wrote :

same problem here...
xps m1530
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

internal mic works well with hardy (on and loud)...but not in ibex (on but silent...too silent it's almost impossible to hear)...i tryed everything with all mixers...

Binoy (mailbinoyv) wrote :

same problem here. I noticed ubuntu 8.10 is missing the Mic boost option. My hardy install had that option and the mic volume was essentially controlled using that

Vitaly (vbabiy86) wrote :

I can also confirm This I am Also on a XPS m1530

Thomas (thomas-scheffler) wrote :

Same here with XPS m1530. While 8.04 is fine, the internal mic on 8.10 is not usable anymore.

abePdIta (abepdita) wrote :

Same here! Also line recording works fine, both on hardy and on intrepid. Internal mic recording on Intrepid gives a full range signal that results in silent files.

Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Acer Incorporated [ALI] Device 0130

liviococcia (liviococcia) wrote :

I can also confirm the very low recording level form the built-in internal mic of a Dell inspiron 1720, no '+20 mic boost' options are present under my version of HDM intel (alsamixer)

talent03 (talent03) wrote :

I confirm this problem on the Dell XPS m1330. The problem is with pulse-audio as I had the same problem in Hardy. I was hoping the problem would be fixed in Intrepid, but the same problem persists. Alsa works just fine recording but when everything is going through pulse-audio, the sound records but at a very low volume. Hopefully we can finally get this resolved.

talent03 (talent03) wrote :

I failed to mention that this problem is only with my internal mic. The line in works perfectly.

Pezz (p3zz) wrote :

I also have this issue with my Inspiron 1420N (same card as mentioned above, also with the built-in Mic):

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

I did have it working fine under Hardy, although I remember it taking a lot of messing around initially.

So for me it's "here we go again" under Ibex where trying to get the Mic working properly is a baffling ordeal...

usr (oesterle-matthias) wrote :

Same problem here (line in mic):

ChipTyp: HDA-Intel - HDA VIA VT82xx
CodecTyp: VIA VIA VT1708

It`s already bad in Hardy (silent with scratchy background noise) but it got worse in Intrepid. It`s nearly impossible to hear voice after recording and it doesn`t work in Skype or Audacity either.

usr (oesterle-matthias) wrote :

Same problem here (line in mic):

ChipTyp: HDA-Intel - HDA VIA VT82xx
CodecTyp: VIA VIA VT1708

It`s already bad in Hardy (silent with scratchy background noise) but it got worse in Intrepid. It`s nearly impossible to hear voice after recording and it doesn`t work in Skype or Audacity either.
Sorry for my bad English.

Greets,
Matthias

hendrikwout (hendrikwout) wrote :

there is also forum thread about this bug: http://ubuntuforums.org/showthread.php?t=956565&page=3

shadowed (shadowedings) wrote :

I got microphone working by using alsa instead of pulseaudio

http://ubuntuforums.org/showpost.php?p=6139576&postcount=36

talent03 (talent03) wrote :

@shadowed
That would be a known workaround, we still need a fix for pulseaudio.

Jack Deslippe (jdeslip) wrote :

I was a subscriber of the duplicate bug. I want to add a 'me too' here on a Dell 1420n laptop. Recording worked in Hardy and works in intrepid if I turn off pulseaudio (which is not really an acceptable solution). But, recording is really low if pulseaudio if on (even if I choose the hw device in skype).

jixuanliu (liujx83-hotmail) wrote :

Same problem with me. I installed kubuntu 8.10 on my desktop PC but skype fails to work because no input device is detected. (The error log says: ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed : 输入/输出错误(5))

Besides skype, all other applications requiring audio input can't work neither. Recording in Audacity fails, no matter if I choose OSS:/dev/dsp or other ALSA devices as the recording device.

hendrikwout (hendrikwout) wrote :

I'm the original poster of the bug.

This bug report is NOT about a sound device that is not detected. It's about a detected recording device wich has a very low recording level (no mic boost).

Disabling pulse audio didn't work for me: recording level is still too low. I have a dell xps m1530.

Allan (allan-2bc) wrote :

I can confirm exactly the same problems. I also have a Dell XPS M1530.
In addition my mic is always muted. When I try to unmute it it keeps defaulting back to muted.

Allan (allan-2bc) on 2008-11-18
Changed in linux:
status: New → Confirmed
Michele (mikelito) wrote :

I am experiencing the same problem in Intrepid, on a DELL Inspiron 1525.
Basically it seems that all the sound recording settings (both through gnome volume control and alsamixer) don't affect the actual volume at all.

Attaching lspci output

Michele (mikelito) wrote :

amixer -Dhw

jixuanliu (liujx83-hotmail) wrote :
Download full text (7.3 KiB)

amixer -Dhw on my machine gives:

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [-4.50dB] [on]
  Front Right: Playback 28 [90%] [-4.50dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [on]
  Front Right: Playback 23 [74%] [0.00dB] [on]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%]
  Front Right: 0 [0%]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 25 [81%] [-9.00dB] [on]
  Front Right: Playback 25 [81%] [-9.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 25 [81%] [-9.00dB] [on]
Simple mixer control ...

Read more...

botticchio (botticchio-gmail) wrote :

Same problem here. In addition, I noticed a very strange thing. I tried to make a Skype call, and I saw that the Capture mixer level in Volume Control-->Recording tab doesn't stay fixed to a value but it moves up and down apparently in a random way.

The digital Input Source is set to "Digital Mic 1" and in Skype-->Options-->Sound Devices I've set all the three combobox to pulseaudio, because I found that this is the only way to pass the test sound and test call.

Can anyone confirm this strange behaviour?

Tim Black (tim-alwaysreformed) wrote :

The sliders moving is due to a setting in Skype that allows Skype to automatically adjust the sounds levels in your mixer.

botticchio (botticchio-gmail) wrote :

Oops, sorry, I didn't know that.

In my previous message I didn't tell that my system is an XPS 1330.

mabawsa (mabawsa) wrote :

This has gotta be marked as confirmed with so many similar symptoms

Changed in pulseaudio:
status: New → Confirmed
mabawsa (mabawsa) wrote :

Does this bug only effect ICH7/8 sound systems? I have an Dell M1330 and ABIT IX38 based desktop and the record was faint in both (ICH8 on both) before i completely removed pulseaudio using synaptic and switched to ALSA. Now everything is hunky dory; but I would love to see a better solution.

I think I am also experiencing this bug. I cannot get the internal mic working despite all my efforts. Sound works though...

bigbrovar (bigbrovar) wrote :

i have the same problem too a dell m1330 . hope its resolved soon so i can continue talking to my girlfriend as i always do on hardy :)

Tomek Bury (tomek-bury) wrote :

Hi all,

I can confirm the bug on Dell XPS M1330 and 1530.

The workaround that works for me is to remove pulseaudio from the system.

I've noticed that after removing puldeaudio alsamixer shows additional track "Digital" with settings ranging from -30dB to +30dB. Perhaps puldeaudio sets the "Digital" to 0dB, thus removing mic boost and causing the problem?

Cheers,
Tomek

It appears that nearly all affected machines are Dell laptops. Any
non-Dell users experiencing this same issue?
--
Kristian Erik Hermansen
Yogi Berra - "I never said most of the things I said."

I believe i have the same issue with ASUS s96s and the HDA Intel sound card. Good sound in 8.04, in 8.10 the internal mic doesn't work (or it's volume is to low). I had to revert to 8.04.... but I still ahve 8.10 and I'm willing to provide more info.

Nikola

botticchio (botticchio-gmail) wrote :

I think I resolved the low mic volume in Skype by uninstalling pulseaudio, but first I updated it to the Intrepid-proposed version, to prevent broken audio after the uninstallation. Before removing it I tried to disable it, with no luck.

I know it is an extreme decision, but i really need to use Skype.

chrisp (chx-cvmx) wrote :

Hi, I think I have the same issue with an ASUS X51L, Intel 82801H:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
Sound OK - but no Mic. Ibex on 2.6.27-7-generic. Maybe its less Dell more InDell related? ;-)

Motin (motin) wrote :

With so many testers (including myself) only experiencing this when using PulseAudio (ie without pulse-audio or when pulse-audio is suspended in favor of jack recording etc), I believe we can conclude that this is not a kernel-related bug.

Changed in linux:
status: Confirmed → Invalid
status: New → Invalid
Motin (motin) wrote :

Does all testers that are experiencing this have a ICH7 or ICH8 card?
Can all testers verify that this bug is not evident if suspending/uninstalling pulseaudio?
Is this bug only evident when using Skype?

Clarifications:

- this bug affects me only when recording through pulseaudio. If I kill pulseaudio and record directly through alsa it works fine (using both gnome-sound-recorder and skype).

- it is NOT a skype-specific bug. The same problem exists with gnome-sound-recorder when recording through pulseaudio.

- it is NOT a 8.10-specific bug for me (as other people report). With 8.04 I had the same issue.

- I do have an ICH8 card

Jesper de Jong (jespdj) wrote :

I do not have this issue with 8.04, but I do with 8.10. I have a Dell XPS M1530.

As Kostas says, this bug is not specific to Skype, it happens also with for example gnome-sound-recorder.

RomanIvanov (ivanov-jr) wrote :

I have Dell Vostro 1510 - 82801H (ICH8 Family) (rev 03).
I use Xubuntu 8.10, and I presume there is no pulseaudio.
Internal Mic does not work even for "Sound Recorder" and "Audacity". External mic works fine after some magic with sliders in Volume control (http://ubuntuforums.org/showthread.php?t=976877).

Changed in pulseaudio:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in pulseaudio:
status: Unknown → New
Daniel T Chen (crimsun) on 2008-12-13
Changed in linux:
status: Invalid → Incomplete
Changed in alsa-lib:
status: Unknown → Confirmed
Changed in pulseaudio:
status: New → Invalid
Changed in pulseaudio:
status: Invalid → New
Daniel T Chen (crimsun) on 2009-01-06
Changed in alsa-lib:
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → crimsun
Javier Jardón (jjardon) on 2009-01-08
description: updated
Changed in pulseaudio:
status: New → Unknown
Changed in pulseaudio (openSUSE):
status: New → Invalid
146 comments hidden view all 226 comments

Hello guys, may be you want to look at this post. https://bugs.launchpad.net/ubuntu/+bug/391926. Try applying the patch mentioned there (just in case). I don't know if installing them helped, but I guess it worked for me :P . Make sure to follow this: https://bugs.launchpad.net/ubuntu/+bug/391926/comments/2 . Probably it works for you as well. Do it carefully, since I don't know sh..t about anything. All I know is that it worked very well. :)

tags: added: review-request
talent03 (talent03) wrote :

I suppose nobody involved in any of these projects have any care for this bug. This is just bullshit. Trying to talk to the different projects leads to nothing, as nobody wants to say it is their problem. Whatever. This just adds to the problem people have when trying to switch to linux. I know all these developers would rather not to deal with bugs that are troubling and continue adding features but this is the stuff that needs to be done for the general public to join in on linux, let alone Ubuntu. We had to figure out our own workarounds that are literally workarounds that do not provide anything of quality. I am mainly looking at PulseAudio as this problem is not present when working without it. Even if it may not be their problem, they still should be involved in this bug and take the steps to move this bug upstream to wherever it needs to be fixed. /rant

I am done with this bug. Please somebody tell me that I am wrong in my rant.

You are right in your rant, but wrong at the top of your voice.

With open source, we must either do the work ourselves or use the art
of persuasion to get other people to volunteer their time and
resources to meet our needs.

Lastly, I don't think the overarching goal of open source development
is to get people to switch to Linux. In fact, development it is so
chaotic, it seems that there is never any coordinated effort toward
any goal. It is frustrating to watch years pass, with significant
software gaps still unfilled while people rewrite window managers,
desktop interfaces, and so on.

On Tue, Aug 11, 2009 at 8:58 PM, talent03<email address hidden> wrote:
> I suppose nobody involved in any of these projects have any care for
> this bug. This is just bullshit. Trying to talk to the different
> projects leads to nothing, as nobody wants to say it is their problem.
> Whatever. This just adds to the problem people have when trying to
> switch to linux. I know all these developers would rather not to deal
> with bugs that are troubling and continue adding features but this is
> the stuff that needs to be done for the general public to join in on
> linux, let alone Ubuntu. We had to figure out our own workarounds that
> are literally workarounds that do not provide anything of quality. I am
> mainly looking at PulseAudio as this problem is not present when working
> without it. Even if it may not be their problem, they still should be
> involved in this bug and take the steps to move this bug upstream to
> wherever it needs to be fixed. /rant
>
> I am done with this bug. Please somebody tell me that I am wrong in my
> rant.
>
> --
> internal mic capture very low volume when routed through pulseaudio
> https://bugs.launchpad.net/bugs/275998
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Dell Project: New
> Status in The Linux Kernel: Invalid
> Status in PulseAudio sound server: Unknown
> Status in “alsa-lib” package in Ubuntu: Triaged
> Status in “linux” package in Ubuntu: New
> Status in “pulseaudio” package in Ubuntu: Incomplete
> Status in “alsa-lib” package in Fedora: Confirmed
> Status in “pulseaudio” package in openSUSE: Invalid
>
> Bug description:
> Hi,
>
> I have a dell xps m1530 laptop with the following internal audio device:
>
> 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
>
> In hardy, sound recording from the internal mic works great, but in Ibex sound recording with the internal mic is very silent. I can't make it louder with the gnome volume control and alsamixer.
>
> See https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275998/comments/109 for a temporary solution
>

Susan Cragin (susancragin) wrote :

Pulseaudio has other problems, other than this one. It stutters with many applications and sound cards. With some the sound quality is poor. With others, the applications get timeout errors and freeze or crash.
Check the bug reports.
It also is incompatible with the sound applications I use: wine and audacity.
And it runs on top of alsa, rather than in place of it, adding latency.
If you are comfortable without pulseaudio, right now it is impossible to remove it (I've tried) without causing major problems and having gnome programs chew up 50% of your CPU.

However, open a terminal
enter killall pulseaudio
and you are safe for a session.

Pulseaudio may someday become useful. Right now, asking it to work perfectly is a waste of typing time.

mike hancock (javaiscoolmike) wrote :

I think it is kind of sad/embarrassing to have this bug still open, since it effects the dell xps1330 with ubuntu pre-installed(well only after you upgrade....). there are only a few computers that dell has with Ubuntu preinstalled and this is one of them. I bought this computer so I would NOT have to deal with these kinds of problems(or at least see them get fixed very quickly). but this has remained for quite some time. I don't mean to sound rude, but I think bugs that effect hardware for any of the computers that have Ubuntu pre-installed on them should get special treatment. Period. I really feel... well let down with the Ubuntu community. You might ask, well what am I doing to fix this issue... well nothing. But I am a computer science major and I want to contribute code(in the future) to kde and kubuntu project(and I have been working to learn that). So I am no lazy slacker with FOSS that just wants my bug fixed. There really should be a group of people that make sure that any computer that is pre-installed with Ubuntu works correctly. If I can't trust a computer that came with Ubuntu pre-installed to work correctly with Ubuntu, what is the point of there being computers with Ubuntu pre-installed? How can this be marked wish-list. Yes I wish the hardware of the computer I bought with Ubuntu pre-installed would 'just work'. If it did, then I could recommend Ubuntu to other people and tell them to buy a dell it has Ubuntu pre-installed. But I can't recommend that if I know there might be problems like this!

The problem is not 'just this bug' but really the fact the on-one stood up and said "we need to make _DAMN_ sure that any computer that comes with Ubuntu pre-installed 'just works' ." This bug just shows that what I am saying IS a real problem. and I think it is a very serious one. This problem is pushing Ubuntu back to the idea of "it's just an OS for hobbyists or computer science nerds, not regular people."

before any one mentions "dell ubuntu project" well it turns out they only make sure that the system works with _exactly_ what was pre-installed, but they do care about after the system is upgraded....

ok, so I might not have all the facts, but I think I have enough to justify this rant. One thing is clear, people that bought dell computers with ubuntu pre-installed....

We need some answers, as to what the heck is going on here!!??

Rocko (rockorequin) wrote :

@talent03: seriously, just install the 2.6.30 kernel. It fixes the microphone problems and has the welcome side effect of not hanging the kernel while deleting files from an ext4 partition. It should really be the default kernel for Jaunty.

1. Go to http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.4/

2. Download the appropriate kernels, eg if you're using 32 bit, you need:

linux-headers-2.6.30-02063004_2.6.30-02063004_all.deb
linux-headers-2.6.30-02063004-generic_2.6.30-02063004_i386.deb
linux-image-2.6.30-02063004-generic_2.6.30-02063004_i386.deb

(choose the amd64 deb files for 64 bit)

3. Install these files using 'sudo dpkg -i <name of file>' from a gnome-terminal.

4. Reboot into the new kernel.

The only drawback is that if you're using the restricted nvidia drivers, they won't compile for the new kernel so you'll get lowres mode in X. In this case, you could use the envy-ng driver to build the driver for the new kernel, or you could download the 185.18.31 driver directly from nvidia (ftp://download.nvidia.com/XFree86/Linux-x86/ for 32 bit, ftp://download.nvidia.com/XFree86/Linux-x86_64/ for 64 bit) and install it manually. I've also found that the 190.18 beta driver works fine.

bigbrovar (bigbrovar) wrote :

@Mike Hancock

I can confirm that its almost impossible to get the internal mic working
on the dell m1330 xps with the vanilla install of ubuntu 9.04. However
if you use the custom dell image of jaunty which can be downloaded here
http://linux.dell.com/wiki/index.php/Ubuntu_9.04 its what i use and the
internal mic works out of the box even with skype i didn't have to do
any further configuration. perhaps you should try it. Its really the Job
of an OEM to see that the OS there ship works with their Hardware and in
the light Dell has provided a custom Ubuntu image for their hardware.

talent03 (talent03) wrote :

Thanks for the comment Rocko.

As far as I have checked on this bug I have not heard that the 2.6.30 kernel fixed this problem. Was this fixed with the drivers, alsa, or something else in the kernel? Well either way... before I go on to upgrade the kernel on Jaunty, I want to know whether anybody else has confirmed that this has been fixed. If you are right then this is great. As far as I know alsa is built into the kernel now, so I would have to upgrade the kernel to fix it if it is alsa. If that is the case then this bug can be closed when karmic comes out; crosses fingers. Is there anybody with an idea on what fixed it though? Can we backport those fixes into this kernel. All questions for people more experienced than me. Thanks for the info Rocko, I just want confirmation before continuing.

talent03 (talent03) wrote :

@Mike Hancock

Do you know what packages of dell fixes the problem? Does the custom iso have certain kernel packages somewhere, like their repository. The last time I used their jaunty repository they did not have any fixes for this. Please be more informative if possible.

talent03 (talent03) wrote :

My last comment is actually directed @bigbrovar

bigbrovar (bigbrovar) wrote :

@talent03
Nope afaik there is was no custom package or patch from dell on their custom image. the dell ppa repo for jaunty had no package the time i checked. according to the dell ubuntu wiki page

* Additional audio mixer volumes will be set to default at 100% (such as Front or PCM).
  Main will still be at 80%. Lots of Dell laptops audio is improved by this, and now the
  full range of audio is controllable by the hotkeys.

http://linux.dell.com/wiki/index.php/Ubuntu_9.04#Dell_OS_Factory_Recovery_9.04_DVD_ISO

hence i feel what they did was set adjust the settings of alsamixer to something that works best on dell laptops
The problem of pulse as always been settings

I now use kubuntu 9.04 with kde 4.3 and i can confirm that i use my internal mic with little hassle i can even make skype calls

mabawsa (mabawsa) wrote :

I think I may also have found a different approach from a Kernel Update, which I could never get working as well as Rocko. Indeed I buggered up my system and had to re-install (probably cause i am a technical Neanderthal):

I added the http://philip.magicalforest.se repository, updated the repos, installed the default ubuntu-desktop package (to get a minimal pulseaudio) and updated the system.
Everything now works. Skype for some reason (probably a blacklist somewhere) avoids using pulse all together so you need to set this to default.
 I only did this last night so I am unsure how stable things are but I can always go back to a pulse only installation.

I am however still unsure on what use pulseaudio is. I read through their wiki and I am still none the wiser.... It seems like its just a wrapper for the various sound standards, but I am more than likely wrong. Maybe canonical could make it an recommend rather than a requirement for ubuntu.

Rocko (rockorequin) wrote :

@talent03: yes, it's the updated alsa drivers which fix the bug (see https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275998/comments/184). The version of alsa that ships with 2.6.30.4 had a lot of work done in it for the ICH8 chipset. Instead of installing the new kernel, you could alternatively install just the latest alsa drivers to fix it (see https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/275998/comments/89). But it's much easier to install the new kernel.

The bug is also fixed in Karmic because it's using the 2.6.31 kernel. You could also install Karmic's kernel (and restricted nvidia drivers) by (1) adding the karmic repository in Synaptic, (2) refreshing, and (3) searching for and upgrading linux-image (nothing else, though!). After you do this, I recommend disabling the Karmic repository so you don't inadvertently upgrade to the rest of Karmic, which is still only in alpha.

I'd recommend just using the 2.6.30.4 kernel though since it's stable. I've been using 2.6.30 since May now without issues.

talent03 (talent03) wrote :

@Rocko; If this is truly the case, then jaunty can never be fixed unless the driver is somehow provided in a backported way. It should be noted on the status I figure, including Karmic. Would there be anyway to get this into backports? I am not as involved as I would like to be with this project, so someone with more experience can possibly get this fix into backports if possible. I would like to see people have this problem resolved better than just upgrading to the next version. If the driver is the issue I hope we can have somebody compile the kernels with the new alsa, possibly, or one of us can have a ppa set up with the fix. I hope we can have a stable and fairly easy fix for people who are much less knowledgeable.

After looking at the bug https://bugs.launchpad.net/dell/+bug/309508 and https://bugzilla.redhat.com/show_bug.cgi?id=498612#c4 - I am wondering if the mic works for Intrepid using proposed? If that is the case, it would be great if that could get pushed into jaunty. The redhat link seems to me to be a hint towards bigbrovar's pointing out of the quote in the dell wiki. Although, I think I will have to take a better look at all of this new information after I get some sleep. Thank you Rocko and bigbrovar for being very informative. My only hope is that we can find a simple way to solve this issue and have it at the top with the initial report. Some of the info from Rocko would be nice to see at the top for now.

talent03 (talent03) wrote :

So I am here to report my progress with this. I followed what Rocko recommended and upgraded the kernel to 2.6.30.4. To do this I had to upgrade nvidia binary driver to 180.60 as well because the current one will not work with the jaunty kernel. Sound is definitely better because I don't get crackling anymore and latency issues so far. I almost want to apologize to the PulseAudio developer but when I upgraded the sound was still low on the mic, but when boosting it through paman I definitely had a better quality input. Since things work much better for me, I will just post the steps to getting there for me. There is no support for this, so be aware of that. Make sure to get rid of any workarounds to get this working. I hope this helps.

First install the nvidia driver if needed... I have m1330, so I needed it.
Install in order from this mirror since the archive for ubuntu no longer has it: http://ubuntu-mirror.cs.colorado.edu/ubuntu/pool/restricted/n/nvidia-graphics-drivers-180/
nvidia-180-kernel-source_180.60-0ubuntu1_i386.deb
nvidia-180-libvdpau_180.60-0ubuntu1_i386.deb
nvidia-glx-180_180.60-0ubuntu1_i386.deb

Install the kernel in order from here that I give for packages: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.4/
linux-headers-2.6.30-02063004_2.6.30-02063004_all.deb
linux-headers-2.6.30-02063004-generic_2.6.30-02063004_i386.deb (or amd64)
linux-image-2.6.30-02063004-generic_2.6.30-02063004_i386.deb (or amd64)

Once all this is installed you can restart and everything should be functioning. You can adjust the mic sound through paman in the devices tab and click on properties for the input source. Set skype to pulse.

Rocko (rockorequin) wrote :

@talent03: brilliant! Now open gnome-volume-manager's Preferences (ie double click on the volume icon in the gnome panel) and see if there is now a setting for 'Digital Recording'. If so and you enable it via the check box, a level control will appear in the Recording tab and you should be able to directly control the microphone volume instead of using paman.

talent03 (talent03) wrote :

@Rocko: I looked for something like that as soon as I restarted, but I did not have a setting such as 'Digital Recording'. That is why I had to do it through paman. I am fine with this though, since I only set it once. Thank you for the help.

Rocko (rockorequin) wrote :

It might be something to do with your /etc/asound.state file, which I think is created by alsa. I think I had to reboot a couple of times and possibly even run a configuration command before the new alsa recognised the digital mike control. Now there is an entry at the end of asound.state that says:

 control.29 {
  comment.access 'read write user'
  comment.type INTEGER
  comment.count 2
  comment.range '0 - 120'
  comment.tlv '0000000100000008fffff44800000032'
  comment.dbmin -3000
  comment.dbmax 3000
  iface MIXER
  name 'Digital Capture Volume'
  value.0 96
  value.1 96
 }

ie this is control 29 out of 29 controls.

talent03 (talent03) wrote :

@Rocko: Do you remember the configuration command? Maybe you installed a newer version of alsa that may have done this for you. I am not sure of a way to reconfigure alsa on Ubuntu. There is no alsaconf and ubuntu does not recommend using it.

Rocko (rockorequin) wrote :

I think the configuration command might have been 'alsactl store', which creates a new asound.state file. I think you have to delete or move the old asound.state file first. As well, there is an /etc/asound.state file and also a /var/lib/asound.state file - I don't recall if you have to move both, but I've only got a backup in /etc so this might be the key one. The one in /var/lib/alsa might just be the one that alsa uses when restoring values after reboot.

Rocko (rockorequin) wrote :

@talent03: I tried installing a fresh Jaunty and upgrading the kernel to 2.6.30.4, and it didn't detect the digital capture volume, just like you found. Issuing alsactl stored didn't help either. Also, it seems that I must have made a link from /var/lib/alsa/asound.state to /etc/asound.state, because the default install puts the file only in /var/lib/alsa/asound.state.

However, I did finally get my new Jaunty install with the upgraded 2.6.30.4 kernel to recognise the digital capture volume via the following:

1. I copied the asound.state file across from my previous installation to /var/lib/alsa/asound.state. (It includes the Digital Capture Volume control, which either alsa detected at some point by itself or which I must have copied from a Hardy installation a year ago.)

2. I did "sudo alsactl restore" and then "sudo alsactl store" while in the /var/lib/alsa folder. (The first one is probably the important one - it loads the configuration from asound.state. The second command might not be necessary, as it should just save the volume settings back to asound.state).

3. When I opened up the gnome-volume-control, "Digital" then appeared as an option under the Capture, Capture1, and Capture2 controls. This is the Digital Capture Volume that alters the hardware microphone level.

I've attached my asound.state file in case it helps. It's for an Dell XPS M1530 with the ICH8 high definition audio chipset.

Jerone Young (jerone) on 2009-10-21
Changed in dell:
status: New → In Progress
Tobias Krais (tux-spam) wrote :

Same problem here, its very weird: Dell XPS M1530 with Karmic. With pulseaudio the internal mic does not work, even if I plug in an external one, nothing to here. Uninstalling pulseaudio solves the problem. But now I have no volume control applet in gnome. really weird. Please, please fix it.

The described workaround does not work for me...

hendrikwout (hendrikwout) wrote :

in Karmic Koala 9.10: the gnome-volume-control now has a standard input gain feature to amplify the volume. Allthough the input volume is very low on a fresh install, the volume can be easily gained to an acceptable volume with gnome-volume-control.

Great work of the pulseaudio team!

Offtopic, but related: I still have another problem on the dell xps m1530 (recording from input jack doesn't work), see bug #461732.

Changed in alsa-lib (Fedora):
status: Confirmed → Won't Fix
Wolter Hellmund (wolterh) wrote :

For all of you whose problem hasn't been solved, and whose sound input cannot be detected by pulseaudio yet, I think I have the solution.

NULL SOUND INPUT
=================
1. Install [audacity]
2. Go to [preferences/devices] and select your sound card from the combobox under the [Recording] section.
NOTE: I have [ALSA] in the [Interface] section, [default] in the [Playback] section and [HDA Intel: ...] in the [Recording] section.
3. Back in the main window, play around with the microphone combobox and record until you get the right microphone (you replay what you recorded to see if you were successful)
NOTE: [Digital Mic:0] worked for me just fine.
4. Install [padevchooser] (PulseAudio Device Chooser) and open it. You will see an applet in your panel.
5. From its menu, select [Manager...]. Now go to the [Devices] tab and select your input source. Then click on [Properties] button.
NOTE: My input source's name is [alsa_input.pci-0000_00_1b.0.analog-stereo].
6. Click on [Show Volume Meter]. Here you are supposed to record as you did with [audacity], now that [audacity] sets the mic for pulse.

QUIET SOUND INPUT
==================
1. (Follow last guide from step #4).
2. Play with the [Volume] slider until you have decent settings.
NOTE: I have my slider at 200%.

LETTING GSTREAMER ENJOY THE GLORY
===================================
1. Run [gstreamer-properties].
2. Select [PulseAudio Sound Server] as your default input.
NOTE: I have [Default] as my [Device]. There are two other devices labeled as [Unknown]. One is the same as [Default] (the mic) and the other one is the default output. Use this second one when you want to record what your computer plays.

CREDITS
========
If this guide worked for you, feel free to come by to #<email address hidden> and say hi to mezquitale and wolter. But mezquitale is the real mage here. He helped me out and gave me the audacity technique.

Wolter Hellmund (wolterh) wrote :

PS: I used the default settings, which means no altered [/etc/pulse/default.pa] and no [/etc/asound.conf] at all.

Felix (apoapo) wrote :

#128 works for me on a dell xps m1330. thank you.

tags: added: iso-testing
Jeremy Foshee (jeremyfoshee) wrote :

Hi hendrikwout,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 275998

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
alexsimps (alexsimps84) wrote :

@Jeremy Foshee This issue is still bothering me in lucid 10.04 if that answers your question?

Jeremy Foshee (jeremyfoshee) wrote :

alexsimps,
     It does. :-) would you mind running "apport-collect -p linux 275998" per the above so I can get some debugging info from your machine?

Thanks!

~JFo

alexsimps (alexsimps84) wrote :

Jeremy Foshee,
I tried but got
"You are not the reporter or subscriber of this problem report, or the report is a duplicate or already closed.
Please create a new report using "apport-bug". "
So im not sure if it went thru... or how to make it work if it did not, as i am already subscriber to this problem?

Jeremy Foshee (jeremyfoshee) wrote :

alexsimps,
     That is strange indeed. Let me look into this a bit and let you know what I find.

Thanks!

~JFo

alexsimps, this works fine for me in Lucid. Are you sure it's not just a matter of turning up the mic volume?

Right-click on the volume applet, choose "Sound preferences" , click on the "Input" tab and turn up the volume.

Jerone Young (jerone) on 2010-04-18
Changed in dell:
status: In Progress → Invalid
lemmy (lemmyg) wrote :

Hi,
This problem still persists in karmic and lucid. to record the sound, I have to put the microphone recording volume to 200% with "pulse audio manager". In jaunty this bug was fixed but in karmic appears again.

Dell inspiron 1720
Linux VLAN01 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 04:38:19 UTC 2010 x86_64 GNU/Linux

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Krzysztof Debski (fantom15) wrote :

I am using Lucid and I have Dell M1530.
When volume of microphone is set to 100% it is almost inaudible.
gnome-volume-control let me rise the volume up to 150% which is still not enough.
With paman (PulseAudio Manager) I can rise it up to 480%. 200% is fine.

Workaround:
1. sudo apt-get install paman
2. paman
3. Go to devices
4. Double click alsa_input.pci-0000_00_1b.0.analog-stereo
5. Set the volume to ~200%
6. Click Close

lemmy (lemmyg) wrote :

Hi, you're right.
that means it's a regression, this bugs was corrected in jaunty and mic sound worked properly with the volume to 100%.

Åsmund Hjulstad (asmund) wrote :

If it may help others: I added

set-source-volume 1 170000

to my /etc/pulse/default.pa, so I don't have to reset the volume every time I log on.
(And also remember to unset the "let Skype control volume automatically" option)

http://myramblingsonprogramming.wordpress.com/2010/09/09/mic-volume-on-dell-xps-m1330-running-ubuntu-10-04/

Daniel T Chen (crimsun) wrote :

source fixes have been applied for Maverick's current pulse. Please test.

Daniel T Chen (crimsun) on 2010-10-10
Changed in alsa-lib (Ubuntu):
status: Triaged → Invalid
Andy Whitcroft (apw) on 2011-02-14
Changed in linux (Ubuntu):
status: Incomplete → In Progress
status: In Progress → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

David Henningsson (diwic) wrote :

I'm closing this bug because it is very old and has not been updated recently, and because problems of this sort is hardware specific in general.
If you're still having problems, please file a new bug.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in somerville:
status: New → Invalid
no longer affects: dell

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305827

no longer affects: somerville
Displaying first 40 and last 40 comments. View all 226 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.