Ubuntu

[intrepid] Wine>=1.1.6 + PulseAudio : alsa is broken

Reported by Rocko on 2008-10-09
84
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ALSA driver
Fix Released
Low
alsa-driver (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alsa-base

Yesterday's Intrepid updates of alsa/pulseaudio cause the sound to crackle on my Dell XPS 1530 when playing games under wine. The sound doesn't crackle if you tell winecfg to use the OSS driver instead of the ALSA driver; it didn't crackle a few days ago using the (default) ALSA driver.

version info:

intrepid kernel 2.6.27-6-generic amd64
alsa-base 1.0.17.dfsg-2ubuntu1
pulseaudio 0.9.10-2ubuntu7
wine 1.1.5-579-g19d18f0 (compiled from git sources)

hardware:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)

Rocko (rockorequin) wrote :

Actually, ALSA is more comprehensively broken than I realised:

- alsamixer only shows master gain (it doesn't show the controls for the HDA Intel card any more)

- alsa no longer provides correct default sound card information - skype doesn't work until you specifically choose the correct card (ie default no longer works)

- the digital mic sensitivity control no longer works (gnome-volume-control). You can alter the level, but it has no effect

- if you choose alsa as the sound capture device (gnome-sound-properties) and then run sound recorder and start recording, the recorded time shoots up rapidly (minutes and then hours) and when you press stop, it hangs.

... and the sound still crackles in wine under alsa.

I tried a fresh install from the Intrepid i386 beta disk and updated everything, and audio is still broken, but differently:

- it doesn't show the digitial microphone controls at all: volume control preferences has 'digital input source' but no 'digital' available, and the recording tab doesn't appear if you choose to see the 'HDA Intel (ALSA mixer)' controls (you have to choose one of the capture inputs, and then you only get a master volume control that doesn't have any effect)

- skype (audio out) still won't run using the standard default driver settings

- sound recorder still works incorrectly and hangs if you choose ALSA as the input

- and sound still crackles in wine.

Dan Quade (danquade) wrote :

I am confirming this. I have the same sound card (Intel Corporation 82801H (ICH8 Family)) and the same problems on Intrepid. It was working fine on Hardy.

Rocko (rockorequin) on 2008-10-16
Changed in alsa-driver:
status: New → Confirmed
Rocko (rockorequin) wrote :

I'm still getting these problems with kernel 2.6.27-7-generic and pulseaudio 0.9.10-2ubuntu8 (alsa-base hasn't changed version).

Just an observation - I've found that only version wine 1.1.6 has the crackling - 1.1.5 is fine with this ALSA. (But 1.1.6 doesn't crackle in Hardy.)

The more important problem is the lack of microphone settings, the inability of programs like skype to auto-detect audio devices, and programs like sound-recorder and gnome-sound-properties hanging. (The latter one hangs for about 20 seconds if you choose ALSA as the sound capture device, press 'Test' and then press 'OK'.)

On my system, the microphone does work if I choose HDA Intel STAC92xx Analog (ALSA) as the capture device, but I have no way of adjusting the recording level, and unfortunately it defaults to very quiet.

Some more info:

- BIOS reports that my audio controller is a SigmaTel 9205, although cat /proc/asound/card0/codec#* | grep Codec shows the SigmaTel STAC9228 controller

- I tried adding the line "options snd-hda-intel model=X" to /etc/modprobe.d/alsa-base and rebooting a few times, with X=auto, dell-bios, dell-3stack, dell-m44 (as per the advice on various forums and ALSA configuration pages, eg http://ubuntuforums.org/showpost.php?p=5131958&postcount=2, http://ge.ubuntuforums.com/showthread.php?t=616845, http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt) but it didn't help. I tried dell-m44 since it's supposed to be for the 9205, not the 9228

- I'm getting this in dmesg:

hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x20171704

I can confirm this. I installed (from CD) Intreprid 2 days ago and audio worked. I run a "apt-get dist-upgrade" yesterday evening between 4 and 9pm utc.

I rebooted my notebook this morning. Alsa volume-controles where muted. Pulseaudio doesn't start anymore on boottime (it doesn't print any errors when i start it manually). Playing back stuff with alsa seems to work (no errors) but I don't hear anything.

Here's the output of the alsa-information-script: http://www.alsa-project.org/db/?f=5534e300deca110a7cba6325736165fe94e825fe

Uwe Helm (1forthedoctor) wrote :

i can confirm the crackles with alsa+wine too, tested it with a newly created user.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

frost_it:
pulseaudio's normal behaviour in intrepid is to be started as your current user

mabawsa (mabawsa) wrote :

I think this may be a duplicate of https://bugs.launchpad.net/ubuntu/+bug/261018?
Anyway I can confirm the digital microphone issue.

Rocko (rockorequin) wrote :

261018 is about mic sensitivity being too low in Hardy, whereas this bug is about not even getting a microphone sensitivity adjustment in Intrepid (amongst other things).

Reece H. Dunn (msclrhd-gmail) wrote :

I did an update today and am having similar issues. The speaker is muted and when I unmute it, I get a crackling sound. I have seen this listening to a live podcast via Firefox.

Yuval Tal (yuvster) wrote :

I would like to confirm this as well. I somehow managed to remove pulse audio (not before I had to delete a file from /etc/X11/Xsession.d/70...). Once pulse audio was gone, ALSA was working fine.

I'm running on a Dell D630... Intel HDA.

Derek7 (enrico-vittorini) wrote :

yeah! after the upgrade the sound card doesn't work!

I'm having exact same problem as stated above on a Dell 1420n.

Erik Reuter (misc71) wrote :

I have the exact same problem as Reece Dunn, on a Dell inspiron 1720. After the update today, the speaker was muted. Now when I unmute it, the only noise that can be played is a crackling sound -- nothing intelligible.

Erik Reuter (misc71) wrote :

Another symptom of the recent broken ALSA sound is that when I shut down, the system hangs while trying to shut down ALSA.

I tried Yuval Tal's suggestion and edited

  /etc/X11/Xsession.d/70pulseaudio

to comment out the code that loads pulseaudio. Then I rebooted, and ALSA sound is working again:

# If we are loading a GNOME session, load pulseaudio.

#if [ "$BASESTARTUP" = gnome-session -o \
# \( "$BASESTARTUP" = x-session-manager -a \
# "`readlink /etc/alternatives/x-session-manager`" = \
# /usr/bin/gnome-session \) ]; then
# STARTUP="/usr/bin/pulse-session $STARTUP"
#fi

Shashmik (philbinj) wrote :

This bug is also hitting me on a Dell Vostro 200. My soundcard is

> lspci
...
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

matthew (matthewbstanton) wrote :

I can confirm this on a sony vaio hd audio controller.

Catherine West (kerriganw) wrote :

I'm also seeing this bug on a Dell Vostro 1500. Soundcard is:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Wine sound output crackles through alsa whether or not the default device is set to pulse (normally my default).

Sound output from wine works fine if I use the wine oss driver.

I'm not seeing any of the other general crackling audio output problems described here. Alsa shutdown works as expected. I can't really comment on the mic problems, though, as I don't have anything to test that right now.

This is all using latest from intrepid.

Bas Grolleman (bgrolleman) wrote :

Another confirm, Dell D420
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

Get a crackle when using alsa or autodetect, and working sound when using OSS

Evgeny Kuznetsov (nekr0z) wrote :

I used to have the same problem on a Lenovo 3000 N100 with Intel HDA since upgrade to Intrepid, but some updates fixed this for me last weekend.

Messó (redhat24) wrote :

i'm using the latest intrepid (updated from repo tomorrow) and having same issues:
* if I set up ALSA as sound recorder, then sound-recorder hangs up (as for Rocko).
* wine sound is noisy if i use alsa (oss is okay)

Changed in alsa-driver:
status: Unknown → Confirmed
Shashmik (philbinj) wrote :

I'd just like to add, in case it wasn't clear that the sound doesn't work for me in ANY app, not only under Wine.

Reece H. Dunn (msclrhd-gmail) wrote :

For me, this is not a wine+alsa issue, this is an alsa and/or pulseaudio issue.

The only sound I get when using alsa (in Firefox, wine or the Ubuntu startup) is a low background hiss and the occasional hum. With OSS, I get sound as normal.

$ lspci
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

I think that we have two issues: (1) the wine-bugs #15559 issue, with stuttering/crackling sound, and (2) no sound except for a hissing sound.

Also of note, I also experienced a hang in the alsa driver when shutting down to reboot my machine after the update that broke alsa. So here's a question: did this corrupt one of the alsa setting files (e.g. the volume settings) and as a result is causing the hissing?

tyle (tyle7) wrote :

I notice stuttering sound when I run virtualbox OSE 2.0.4 with "host audio driver" set to alsa. Switching audio driver to OSS works there as well.

It seems like this is not a problem only for wine.

This is on Ubuntu 8.10, kernel 2.6.27-7-generic, alsa-base 1.0.17.dfsg-2ubuntu1

Rocko (rockorequin) wrote :

This bug seems to cover a great many problems with ALSA and/or pulseaudio (which is why I changed its title after reporting it to "just ALSA is broken"). But some people are having trouble getting sound to play, some people are having trouble with the digital microphone controls, some people report their computer is hanging on shutdown, some people are having trouble with crackling under wine > 1.1.5, etc. I wonder what changed that caused so many bugs all at once?

Perhaps we need to open a bug for each one so each one can be better targeted?

Catherine West (kerriganw) wrote :

I don't know if this helps or not but I looked at http://bugs.winehq.org/show_bug.cgi?id=15559 and tried applying the patch given, but no luck. Didn't seem to change the situation with wine 1.1.7 (patched) and alsa 1.0.17.dfsg-2ubuntu1.

It might help to mention that if I test wine sound using the wine configuration gui, everything is fine if I use the oss driver. If I use the alsa driver, however, the sound plays, but then the program then locks at the end of the sound and winecfg.exe has to be killed.

I'm going to try compiling wine with debugging turned on and see exactly where it hangs.

Catherine West (kerriganw) wrote :

I'm not sure if this will help, but here's the output of WINEDEBUG=+wave winecfg with unpatched wine 1.1.7

Messó (redhat24) wrote :

balint@balint-desktop:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

I was experimenting yesterday. Here are my results:

1. We start with pulseaudio (it's default install in intrepid, i think you don't have to use anything)
* everything works. I can listen to rythmbox, watch youtube, etc. (in the same time ofc.)
* System->Pref->Sound : everything on automatic (or PulseAudio), recording is on PulseAudio (if alsa, it hangs up)
* wine works also -> I use OSS, and i start wine programs with +padsp+ (OSS wrapper for PulseAudio), so sound works (can listen to anything in the same time, so wrapper works (if only oss, then only 1 app can use the sound device at the same time)

2. If I want to switch alsa now, sound gets crackier, noisy, etc. as for other people in wine, but everything else working, but recording. So if i select ALSA for playing sound (in gnome-sound-properties from automatic to ALSA), it's work (maybe it's using pulseaudio-alsa bridge, i don't know).
I tried the following:
balint@balint-desktop:~$ ps ax | grep pulse
 6281 ? S 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute x-session-manager
 6285 ? S<sl 0:01 /usr/bin/pulseaudio -D --log-target=syslog
 6288 ? S 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
 6894 pts/2 S+ 0:00 grep pulse

I killed the process with PID=6285, now i switch the recorder to (in gnome-sound-properties) HDA Intel ALC885 Analog (ALSA). (If i want to switch ALSA - Advanced Linux Sound Arch., then it says: "gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Couldn't open for recording"). Everything else is on Automatic which seems to be the OSS (only this works for playing). This is bad because you can only use 1 app with sound. I can't switch the playing devices to ALSA, because it says: "audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Couldn't open for playing"), and nothing seems to be working, but OSS.

But now ALSA is working in wine (winecfg->ALSA in sound prefs) and in games, it won't be noisy, cracking, etc. But you can't hear anything else (so it seems OSS is still be using), e.g.: a playing rythmbox.

So I think ALSA is deprecated in intrepid or so, and only pulseaudio seems to be working. And wine you should use OSS, and start programs with pulseaudio-oss wrapper (padsp).

Messó speaks the truth! I've also killed PulseAudio (/usr/bin/pulseaudio -D --log-target=syslog) and sound in all my games works flawlessly, with Alsa or OSS. I've tested so far Team Fortress 2 and Everyday Shooter on Steam.

However, with no PulseAudio only one application can play sound at any time. Look for this site for the hints, how to deal with it on Steam - http://bugs.winehq.org/show_bug.cgi?id=15559

Forgot to add - I've got Wine 1.1.7, Ubuntu 8.10, Alsa 1.0.17, PulseAudio 0.9.10.

Daniel T Chen (crimsun) wrote :

There are far too many issues being confused in this bug report, which makes this bug report largely incomprehensible to all but experienced ALSA triagers.

To everyone other than Rocko, please file a separate bug report for each symptom. I will address Rocko's bug summary first, since his report is the only one of import.

Firstly, sound issues such as crackling should not be assigned against ("affects") the alsa-driver source package, which, as shipped by default in Ubuntu, does not contain the sound drivers but only ships a module-init-tools configuration. Normally, they should be assigned against the linux source package. In this case, however, they need to be assigned against the pulseaudio source package.

Secondly, the crackling issue can be pinpointed as a fragments issue within the default PulseAudio configuration (/etc/pulse/daemon.conf, see default-fragments and default-fragment-size-msec toward the EOF). There is no possible manner to ship one default configuration that works on all sound hardware, because the machine configurations varying too widely.

And now, to address everyone else's interjected comments.

The widely varying (and often utterly unrelated) symptoms have several culprits that can be understood as follows:
1) Wine, when configured to use ALSA, actually routes through alsa-lib's pulse plugin. By default, this configuration in Ubuntu 8.10 means that /any/ non-native-PulseAudio application that uses ALSA will be routed through PulseAudio. There are known instances in the alsa-lib pulse plugin that perform less than stellar, and when one removes said routing from the equation, the results from Wine (and other applications) return to expected. A more definite measurement is to bypass PulseAudio completely and simply use ALSA directly, in which case one receives the (same) expected results.

2) Recording via ALSA in a default Ubuntu 8.10 configuration is known-broken and tracked in bug 282316. I'm already providing a fixed libasound2-plugins package in my PPA, and it will be in intrepid-updates after appropriate StableReleaseUpdates (SRU) testing post-release.

3) The hang-on-shutdown/reboot symptom is described in bug 274995. Please do not confuse the issues or clutter this bug report further.

4) Skype needs a specific setting in its preferences. After installing Skype on a default Ubuntu 8.10 configuration, you'll need to choose the pcm.pulse configuration.

5) If you don't hear /any/ sound regardless of whether you use ALSA directly (plughw: or hw:, not default:) or PulseAudio, then please see https://wiki.ubuntu.com/DebuggingSoundProblems and use the alsa-info.sh script. Remember that you need to file a bug that affects the linux source package.

Thanks for helping the audio team triagers maintain their sanity!

Catherine West (kerriganw) wrote :

I'm sorry for being misleading, it is indeed true that when the pulseaudio daemon is killed, wine sound returns to normal.

I was unaware that the default target in alsa was now pulse even in absence of ~/.asoundrc or similar... I hadn't looked at /usr/share/alsa/*.conf.

It is also true that changing default-fragments and default-fragment-size-msec in /etc/pulse/daemon.conf does *affect* the type of crackling I hear in wine apps, but I cannot, through my random and uneducated tweaking, make it go away.

However, on my system the following things work fine:
1. Wine apps using oss redirected to pulseaudio via padsp sound perfect
2. Apps using native pulse, like amarok and gnome system sounds, sound perfect.
3. *I think* other apps that use native alsa and are routed through pulse, such as flash 10. (I'm not sure about how this is coded, but I *thought* it was straight alsa.)

Anyway, I'm confused... is this bug report now about general audio crackling due to pulse at all, problems with pulse via alsa, or is it specifically about wine? My problem only seems to show up using wine... should I file another bug report?

I'm sorry if I'm further cluttering this bug report, and thank you.

Rocko (rockorequin) wrote :

Thanks for the detailed notes, Daniel. Audio problems can be pretty confusing to debug and any information is helpful.

I'll file a separate bug for the missing microphone digital sensitivity control, I guess against linux-source.

Re the wine crackling issue, I tried altering /etc/pulse/daemon.conf's default-fragments to 4 and default-fragment-size-msec to 25 to match my (non-crackling) Hardy configuration, but like Catherine, I still get the crackling/stuttering sound (even after a complete reboot to be absolutely sure everything gets reset), so that doesn't seem to be the problem. Note that the crackling does go away if I reset the audio frequency to 11 kHz instead of 22 or 44 kHz via the game settings in wine.

This is with pulseaudio 0.9.10-2ubuntu10~ppa1, alsa-base 1.0.17.dfsg-2ubuntu1, and wine 1.1.7.

Same thing for me on XPS 1330.

When using alsa only (disabling pulseaudio) the mic works fine (after selecting digital input source = digital mic 1 and maxing the "digital" recording level). With pulseaudio recording works but volume is too low.

Something interesting I noticed is that, when recording through pulseaudio, the volume is not affected by the "digital" level in alsamixer. You can turn digital to 0 and still record with the same (low) volume. I find this strange (for example lowering the master playback level in alsamixer lowers the volume also in pulseaudio). Maybe pulseaudio gets it's input from somewhere else and not from digital? (I'm not an alsa/pulseaudio expert though so I might be missing something)

Ok, I did something stupid :( The previous comment was meant for #261018 (which I had open in a different tab). If someone can delete these two comments it would be great.

Mike (farlo144) wrote :

I've had the same issues since that infamous update. Crackling ALSA (in _all_ application) and the hang on shutdown after the update. Everything worked great before the update.

HP tx1000
(42) lspci | grep Audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

(44) sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861VD Analog [ALC861VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Mike (farlo144) wrote :

Is anyone looking into this anymore?

Mike (farlo144) wrote :

bump. hello???

Rocko (rockorequin) wrote :

Yes, is anyone looking into this? Or are there just too many problems with Intrepid for them all to be addressed? <rant>I've found it to be very buggy compared to earlier versions of Ubuntu - there are sound and microphone problems, the kernel frequently panics running the Intel 4965agn wireless chip, the system log fills the root drive and makes the whole system unresponsive, X freezes with 100% cpu at startup for 20 seconds, fdisk and gparted no longer recognise the mmcblk device partitions, webcams no longer work, vinagre's local mouse cursor disappears if you move it out of the remote window and back in again, the mmcblk driver in the kernel can cause data loss because it doesn't report errors back to the file system (and these are just some bugs that *I* get)... and there seems to be no or very little response to the bug reports. Perhaps it's because the 2.7.27 kernel is not stable enough and so the Ubuntu devs can't do much about all the bugs because they're upstream?</rant>

Anyway, if there's anything further I can do to help debug this bug let me know.

Andy Whitcroft (apw) wrote :

I have found that at least on my Dell Studio 15, that the problem seems to come and go as various updates to the kernel are made. What appears to happen for me is that the various updates are changing the volume of the PCM alsa mixer channel, and only when this channel is set to 0 volume do I see the crackling artifacts when sounds are made. It is cirtainly worth checking that.

Rocko (rockorequin) wrote :

I tried adjusting the PCM level, and the sound still crackles (except if I set PCM too low I can't hear any sound - I typically have PCM set to 100% because the sound is very soft on this PC).

Thorsten Kunz (sfire) wrote :

I do have very similar issues. I am running Intrepid and first I installed wine 1.0.1. The one that ships with 8.10. Games undert wine had good audio quality. Now I switched to wine 1.1.8 from winehq to address some bugs I ran into. Now all of a sudden sound is crackling and occasionally stops to play at all.

dara (dara+ubuntu) wrote :

FYI
I had an issue mentioned here, *crackling sound*, in *all applications*, after an update in Ubuntu Intrepid. (on two intel machines, x86, 32-bit and 64-bit)

Opening volume control and increasing the PCM channel volume above min fixed the 'issue'.

Thanks to Andy who posted here https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/281536/comments/4 in reponse to my queries..

Bogdan Butnaru (bogdanb) wrote :

For the record, this also happens to me only in Fallout, and my PCM volume is not 0.

Mike (farlo144) wrote :

This happens to me, and I don't even have Wine installed. I say a little prayer every time I do an update, but so far no fix. Changing PCM volume levels doesn't make the snap-crackle-and-pop go away.

Id2ndR (id2ndr) wrote :

It seems that there is more activity (than wine-bugs #15559) on following wine bug: http://bugs.winehq.org/show_bug.cgi?id=10495

Reece H. Dunn (msclrhd-gmail) wrote :

I am going to send a patch that reverts the change that broke ALSA to wine-patches (that only reverts the relevant part and cleans up some of the tracing logs). The change was made to fix a crash in the winmm:wave conformance tests. http://bugs.winehq.org/show_bug.cgi?id=15559 has my findings, but I haven't heard from Maarten yet to get any more details.

I would still like to know what is going on w.r.t. the winmm:wave crash, but that is a different issue.

mabawsa (mabawsa) wrote :

I dunno but completely removing pulse solved everything for me. I wonder why pulse was ever used as it causes sooo many problems. Is there any news from the developers on this?

Mike (farlo144) wrote :

Fully removing pulseaudio worked for me too. I followed the following link for hints:
https://bugs.launchpad.net/ubuntu/intrepid/+source/pulseaudio/+bug/294541

Id2ndR (id2ndr) wrote :

I solve the bug by upgrading PulseAudio to 0.9.13 :
- Add Luke Yelavich PPA to APT sources.list https://launchpad.net/~themuso/+archive
- sudo apt-get update && sudo apt-get dist-upgrade
- Fix Bug #294541 by removing /etc/X11/Xsession.d/70pulseaudio
- Close current session and reconnect
- Launch PA manually after login : pulseaudio -D
=> After that, it works like a charm

Upgrading to PulseAudio 0.9.13 didn't work for me - the sound was even worse. But I used packages from jaunty, because I couldn't download them from Luke Yelavich PPA.

Reece H. Dunn (msclrhd-gmail) wrote :

The fix for this issue w.r.t. Wine has gone into the upstream sources (http://source.winehq.org/git/wine.git/?a=commit;h=ef0069cbf5dd7c65089aa9565a5c42f1ab8e7de3). It will be a part of wine 1.1.20.

Id2ndR (id2ndr) wrote :

In fact PulseAudio 0.9.13 doesn't solve the trouble for me : Wine was just using Alsa directly.

I apply the patch on Wine 1.1.9 but I still get trouble (PulseAudio 0.9.10).

Reece H. Dunn (msclrhd-gmail) wrote :

If you go into dlls/winealsa.drv/waveout.c and change period_time in wodOpen to 22000, that fixes playback for pulseaudio 0.9.10. 0.9.13 apparently has other issues.

Changed in alsa-driver:
status: Confirmed → Fix Released
Id2ndR (id2ndr) wrote :

Wine 1.1.10 is out, and as others said in the wine's bug tracker, the sound is worse than in 1.1.9.
However I noticed with pavucontrol that there is no cuttering in the wine's sound output as it was before.

Changed in alsa-driver:
status: Fix Released → Confirmed
Changed in alsa-driver:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
dino99 (9d9) wrote :

don't know if this last release solve these problems but with the latest updates on Lucid A2/wine1.1.36 :

can't use metatrader with wine due to this alsa problem:

alsa plug-in [wine preloader] freeze wine and hide mouse on active windows: huge cpu activity on pulseaudio and gnome-setting-daemon.

Googling around, some users says to deselect alsa and choose esound instead, what i have done in winecfg, then kill pulseaudio.
Wine work better but is very slow with this sound choice. Choising esound or oss does not help much.

Removing/purging alsa/pulseaudio then reinstall them does not work, erasing .pulse neither, nothing special in logs.

This is test on Lucid with wine 1.1.36 that was well working 2 weeks ago before last alsa upgrades.

alpha 2 is insufficient. You need to be fully updated.

dino99 (9d9) wrote :

fully updated: of course, every hour a day , is that enough ?

Daniel T Chen (crimsun) wrote :

I need a verbose PA log, then.

Tristan (tristan-robet) on 2010-01-31
Changed in pulseaudio (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 280534

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

tags: added: kj-triage needs-required-logs
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Rocko (rockorequin) wrote :

I haven't had stuttering sound for a long time. It seems to work just fine now (2.6.33.1 kernel, but the 2.6.32 kernel also is fine).

Changed in alsa-driver:
importance: Unknown → Low
SoloTurn (soloturn) on 2011-04-22
Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.