Failed to change profile to A2DP

Bug #1181106 reported by Christophe on 2013-05-17
344
This bug affects 67 people
Affects Status Importance Assigned to Milestone
Bluez Utilities
New
Undecided
Unassigned
pulseaudio (Debian)
Fix Released
Unknown
pulseaudio (Ubuntu)
High
Daniel van Vugt

Bug Description

I upgraded to 13.04 recently and my A2DP profile, which had been working great under 12.10 is suddenly gone. Neither my blueman applet nor the built-in bluetooth manager applet can connect my external bluetooth speaker to the A2DP profile. They can connect to the bluetooth device itself just fine.

Steps I'm using:

* using blueman, I can connect to the external bluetooth speaker and view the device in the devices listing
* I can connect the device to the Audio sink and I get a message saying it is now connected and will "show in the PulseAudio mixer"
* After connecting the external speaker to the audio sink, I can also see the device in the "Play sound through" listing in the Sound system control panel, but the icon has a circle with a line through it.
* but if I right-click the device and choose "Audio Profile" from the context menu and try to select "High Fidelity Playback (A2DP)" as the new profile, I get an error message stating "failed to change profile to a2dp"

I've already added "Enable=Socket" in /etc/bluetooth/audio.conf, without that I can't pair my headset. Now I can pair it, but I can't activate the A2DP profile.

When I try to activate it, I see this message in my syslog :
pulseaudio[2603]: [pulseaudio] module-bluetooth-device.c: Profile has no transport

I tried the kernel 3.9.0 because of a sound problem with my soundcard, this kernel fixed my soundcard problem, but A2DP still doesn't work

I'm using KDE, but I tried after a reboot with a clean new user profile with Ubuntu session, and I have the same problem, I'm unable to choose A2DP profile.

tags: added: bluetooth
tags: removed: bluetooth

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1181106/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → bluez (Ubuntu)
James Tillman (jptillman) wrote :

I strongly doubt that the problem truly lies in bluez. My bluez is working fine, it seems (I am the reporter of the original support request to which this bug is linked). It appears that the problem is more likely in something that happened to PulseAudio during the 13.04 upgrade, as I suspect that PulseAudio is responsible for the A2DP profile.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
affects: bluez (Ubuntu) → pulseaudio (Ubuntu)
Raimund Specht (raimund-m) wrote :

I had the same problem since I upgraded to 13.04.
I managed to get Bluetooth A2DP audio working again by _removing_ "Enable=Socket" from /etc/bluetooth/audio.conf. It just reads "Enable=" now.

https://mailman.archlinux.org/pipermail/arch-general/2012-December/032496.html

David Henningsson (diwic) wrote :

> I've already added "Enable=Socket" in /etc/bluetooth/audio.conf, without that I can't pair my headset.

I can confirm that PulseAudio as of 13.04 does not work with Enable=Socket. This is IMO a bug on the bluez side.

From what I've been told by the bluez people, the socket interface is deprecated anyway (and completely removed from the next bluez version IIRC), so we should track down who ever relies on this and convince them to port their application to use the newer dbus interface instead.

If I understand well there are 2 bugs ?
#1 A2DP profile not selectable by Pulseaudio when Socket mode is activated. On Bluez side according David, on Pulseaudio side according James.
#2 device that can't be paired when Socket mode is not activated, probably on Bluez side

If the Bluez team deprecated Socket mode, then we should probably focus on the second bug ?

Am I wrong ?

I'm not really certain of the source by any means. My statement about
"strongly doubting it was with bluez" was based on general observations,
not an understanding of the code or how it works, so please don't base any
decisions on what I said. It seems to me that the developers of both
projects ought to take a look at the report and figure out who should fix
what. Why not tag the issue with both and see how it shakes out?

On Mon, May 20, 2013 at 5:06 AM, Christophe
<email address hidden>wrote:

> If I understand well there are 2 bugs ?
> #1 A2DP profile not selectable by Pulseaudio when Socket mode is
> activated. On Bluez side according David, on Pulseaudio side according
> James.
> #2 device that can't be paired when Socket mode is not activated, probably
> on Bluez side
>
> If the Bluez team deprecated Socket mode, then we should probably focus
> on the second bug ?
>
> Am I wrong ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1181106
>
> Title:
> Failed to change profile to A2DP in 13.04 (Raring)
>
> Status in “pulseaudio” package in Ubuntu:
> Confirmed
>
> Bug description:
> I upgraded to 13.04 recently and my A2DP profile, which had been
> working great under 12.10 is suddenly gone. Neither my blueman applet
> nor the built-in bluetooth manager applet can connect my external
> bluetooth speaker to the A2DP profile. They can connect to the
> bluetooth device itself just fine.
>
> Steps I'm using:
>
> * using blueman, I can connect to the external bluetooth speaker and
> view the device in the devices listing
> * I can connect the device to the Audio sink and I get a message saying
> it is now connected and will "show in the PulseAudio mixer"
> * After connecting the external speaker to the audio sink, I can also
> see the device in the "Play sound through" listing in the Sound system
> control panel, but the icon has a circle with a line through it.
> * but if I right-click the device and choose "Audio Profile" from the
> context menu and try to select "High Fidelity Playback (A2DP)" as the new
> profile, I get an error message stating "failed to change profile to a2dp"
>
> I've already added "Enable=Socket" in /etc/bluetooth/audio.conf,
> without that I can't pair my headset. Now I can pair it, but I can't
> activate the A2DP profile.
>
> When I try to activate it, I see this message in my syslog :
> pulseaudio[2603]: [pulseaudio] module-bluetooth-device.c: Profile has no
> transport
>
> I tried the kernel 3.9.0 because of a sound problem with my soundcard,
> this kernel fixed my soundcard problem, but A2DP still doesn't work
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1181106/+subscriptions
>

> #2 device that can't be paired when Socket mode is not activated, probably on Bluez side

Yes. By the book, this should be a new bug and this bug be set as invalid. The new bug could have an explanation with reference to this bug to reduce the risk that someone again thinks it's pulseaudio.

Changed in pulseaudio (Ubuntu):
status: Confirmed → Invalid
Ken Boss (kwboss) wrote :

My apologies if posting on a bug marked Invalid is inappropriate; I am new to this process. David's suggestion was that a new bug be opened; how would I determine if that happened?

FWIW, from my investigations this looks very much like the problem that was resolved in redhat here:

  https://bugzilla.redhat.com/show_bug.cgi?id=964031

where apparently bluez and pulseaudio are not on the same page as regards the deprecation of Enable=Socket in /etc/bluetooth/audio.conf

Anton Anikin (anton-anikin) wrote :

I have the same problem - can't select the A2DP profile...

Nec (nicolas-ecarnot) wrote :

I tried every workaround proposed here, with no success.

13.04

I have the same problem - can't select the A2DP profile...
I think there are 2 bugs as Christophe said.

henring (henring) wrote :

The same problem in 13.10. any treatment?

summary: - Failed to change profile to A2DP in 13.04 (Raring)
+ Failed to change profile to A2DP in 13.04 (Raring) and 13.10 (saucy)
no longer affects: pulseaudio
Changed in pulseaudio (Ubuntu):
status: Invalid → Confirmed

How i solve it:

1) Modify the /etc/bluetooth/audio.conf
================================

[General]
Enable = Source,Sink,Headset,Gateway,Control,Media
Disable = Socket

HFP=false

[A2DP]
SBCSources=1
MPEG12Sources=0

2) Check for pulseaudio module :
==========================

$ pactl list | grep -i module-bluetooth

If you dont have :
     module-bluetooth-policy
     module-bluetooth-discover
     module-bluetooth-device

Just do :
$ sudo apt-get install pulseaudio-module-bluetooth
$ pulseaudio -k
$ pactl load-module module-bluetooth-device
$ pactl load-module module-switch-on-connect

3) Connect the bluetooth headset
===========================

Use blueman to pair, and connect audio sink
Use pavucontrol to change for A2DP (even if blueman said "audio profile off")

Please confirm that works for you too.

Laurent Séguin (cybersdf) wrote :

Sometime, Pulseaudio "module-bluetooth-device" and "module-switch-on-connect" may not remain loaded after a reboot (i didn't seek why).

Raimund Specht (raimund-m) wrote :

#15 does not work for me (xubuntu 13.10): "stream setup failed".

Currently only the second answer from http://askubuntu.com/questions/287254/ubuntu-13-04-bluetooth-a2dp-does-not-work works for me.

Michel-Ekimia (michel.ekimia) wrote :

Hello Laurent Séguin ( Michel Memeteau here :-) )

You made my day, it finally worked for AD2P , the audio.conf in 13.10 is really broken for AD2P !

Nec (nicolas-ecarnot) wrote :

Still failing :

# pactl load-module module-bluetooth-device
Dec 17 14:30:50 pulseaudio[6404]: [pulseaudio] module-bluetooth-device.c: Failed to get device address/path from module arguments.
Dec 17 14:30:50 pulseaudio[6404]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: ""): initialization
 failed.

Uldis Kalniņš (ulcha) wrote :

#15 working, confirmed. After config changes is possible to switch sound profiles from standart sound settings, without pavucontrol.

Doctor Rover (doctor-rover) wrote :

The issue was almost fixed in trusty. But several days ago, it suddenly appeared again.
I can successfully connect my head set (plantronics M155), I can see it in sound settings, I can switch the output to it. Moreover, I can switch the mode to A2DP, but the sound remains mono and of bad quality.

Luc C. (lucouluke) wrote :

The answer in #15 worked for me.

I have lubuntu 13.10 (but installed initially ubuntu 13.10 and added the packages afterwards).

Luc C. (lucouluke) wrote :

But on reboot pulsaudio doesn't load the modules correctly:
For
$ pactl list | grep -i module-bluetooth
 I only get:
      module-bluetooth-policy

Then I was able to make the headset works with
pactl load-module module-bluetooth-discover
pactl load-module module-switch-on-connect

but
pactl load-module module-bluetooth-device
didn't want to load...

I hope I'll be able to use the headset without configuring every sinlge time :p

Echoing Doctor Rover here - I can change to A2DP in Trusty, but the profile doesn't actually switch. If you close the sound control panel and open it back up, it remains on Telephony Duplex.

#15 seems to be working so far.

summary: - Failed to change profile to A2DP in 13.04 (Raring) and 13.10 (saucy)
+ Failed to change profile to A2DP in 13.04 (Raring), 13.10 (saucy), and
+ 14.04 (trusty)

I can confirm that Luc's load-modules do the trick on 14.04. After I run these commands:
pactl load-module module-bluetooth-discover
pactl load-module module-switch-on-connect

my Rapoo headset works again.

Frol (frolvlad) wrote :

Ooops, I'm sorry. That helped only to finally connect to my headset, but I indeed cannot switch to A2DP.

jasonshim (jhundais) wrote :

I followed #15. I too cannot switch to A2DP from HSP on Xubuntu 14.04.

Dmitry (dmitry-tch) wrote :

I can't confirm sulution from #15. I still can't switch to A2DP profile from HSP on Xubuntu 14.04 too.

I followed #15. I cannot too switch to A2DP from HSP on Xubuntu 14.04.

Same problem for me in 14.04.

I have to attempt to connect via blueman to the device first which fails. Then

pactl load-module module-bluetooth-discover

then connect with blueman again. I now get sound, Pulseaudio claims it is a2dp, blueman says not. The sound is poor, so I think blueman is right.

Anthony Kamau (ak-launchpad) wrote :

I have the same problem and the solution for me was to manually change the profile. This post on the Ubuntu forums was very helpful:
http://askubuntu.com/questions/287254/ubuntu-13-04-bluetooth-a2dp-does-not-work

In essence, you need to run the following command to switch profile to a2dp:

sudo pactl list cards short
sudo pactl set-card-profile <card name from above step> a2dp

The interesting thing for me is that when I initially connected the Logitech Mini Boombox, it was found with no problems and it worked flawlessly. However, I forgot to connect the laptop to a power source and when it finally shutdown in the night, I could not get it to work again in the morning - not even after purging and reinstalling all bluetooth related packages as well as pulseaudio. In the end, the two commands above worked just fine.

Cheers,
ak.

Francesco (ceskobassman) wrote :

#15 Worked for me un XUbuntu 14.04 on a Dell e6330.

Thanks

Luc C. (lucouluke) wrote :

Today I upgraded to lubuntu 14.04 the trick I was using doesn't work anymore:
pactl load-module module-bluetooth-discover
pactl load-module module-switch-on-connect

Luc C. (lucouluke) wrote :

Erf. I forgot to install the package.

So what I have done:
* install pulseaudio-module-bluetooth
*in /etc/bluetooth/audio.conf, I have:

[General]
Enable = Source,Sink,Headset,Gateway,Control,Media,Socket
#Disable=Socket
HFP=false
[A2DP]
SBCSources=1
MPEG12Sources=0

#15 doesn't work for me if I don't enable the Socket (I have absolutely no idea why). Then:

pulseaudio -k
pactl load-module module-bluetooth-discover
pactl load-module module-switch-on-connect

and then it works. I couldn't load
 pactl load-module module-bluetooth-device
from #15. I still have to change manually in blueman to A2DP, but at least it works. It was the same under 13.10 for me.

Sometimes if I switch to the mode with microphone then A2Dp doesn't work anymore. Killing pulseaudio seems to be a solution in this case.

PS: Just see what I did as a magic trick, I just copied what I read, I have no idea what I am doing :D

TJ (tj) wrote :

I found this affecting 14.04 Trusty.

$ pactl set-card-profile bluez_card.30_17_C8_8B_DF_B1 a2dp
Failure: Input/Output error

so I thought I'd capture some debug logging to "/var/log/syslog" from bluetoothd (system daemon) by adding "-d" (debug logging) to the Upstart service file ("/etc/init/bluetooth.conf") so the line reads

exec /usr/sbin/bluetoothd -d

I then restarted the service with

sudo service bluetooth restart

and reconnected to the A2DP headset. I was surprised to see that the A2DP profile immediately connected!

I then experimented with changing the profile to see if I could reproduce the error but found that, so far, I cannot:

$ pactl set-card-profile bluez_card.30_17_C8_8B_DF_B1 hsp
$ pactl set-card-profile bluez_card.30_17_C8_8B_DF_B1 a2dp
$

Maybe after a power-off restart, or suspend/resume cycle, the issue will return, but it seems that restarting the bluetooth service and reconnecting to the headset solves the issue in my scenario.

Brooks B (bmbeverst) wrote :

Confirm that this is effecting 14.04 Trusty.

$ pacmd list-cards
. . .
index: 4
        name: <bluez_card.00_18_9A_2E_B3_D1>
        driver: <module-bluetooth-device.c>
        owner module: 28
        properties:
                device.description = "PHILIPS BTM630"
                device.string = "00:18:9A:2E:B3:D1"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/1121/hci0/dev_00_18_9A_2E_B3_D1"
                bluez.class = "0x240404"
                bluez.name = "PHILIPS BTM630"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
        profiles:
                hsp: Telephony Duplex (HSP/HFP) (priority 20, available: unknown)
                a2dp: High Fidelity Playback (A2DP) (priority 10, available: unknown)
                off: Off (priority 0, available: yes)
        active profile: <off>
        ports:
                headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
                        properties:

                headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)
                        properties:

$ pacmd set-card-profile 4 a2dp
Welcome to PulseAudio! Use "help" for usage information.
>>> Failed to set card profile to 'a2dp'.

$ pactl list | grep -i module-bluetooth
        Name: module-bluetooth-policy
        Name: module-bluetooth-discover
        Name: module-bluetooth-device
        Driver: module-bluetooth-device.c

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Confirming this bug on 14.04.

#34 works for me, thank you!

Julian Alarcon (alarconj) wrote :
Changed in pulseaudio (Debian):
status: Unknown → Fix Released
Audun Gangsto (audun-m) wrote :

Still does not work on 14.04.
My solution is to disable socket in audio.conf, then I can connect, but not with the default GUI thing.

Using the bluetooth icon in the titlebar, I connect, and it shows up as connected.
However, using any other tool (blueman-manager, pactl list, pavucontrol) it is obvious it fails to connect, a sink is not established, and the module is not loaded. Sometimes it successfully connects using headset service only, but fails on the A2DP, and still shows up as successful.

So it seems it tries to connect, but does not perform any check if it actually succeded or not. This is a problem in Unity i think.

Using blueman-manager, I can connect, but get this error from bluetoothd:
bluetoothd[14256]: Unable to select SEP
This is mentioned here and is a separate bug:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1199059
The fix for that seems to be to manually load module-bluetooth-discover, and things work.

Still, it would be nice to get some checks in the default applet if it actually connects or not.

Michel-Ekimia (michel.ekimia) wrote :

Hi , just to say that #34 fix did not work on my 14.04.

the fix that work is the one from upstream :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725610#89

Do you know exactly which version of bluez contains the fix and when it should land in trusty-proposed ?

Because this bug is really bad for GNU/linux reputation on the desktop.

I'm running 14.04 and I could not set a2dp today. I had it working, but now I have a terrible sound without a2dp. I can select a2dp in the GUI, but it makes no difference and when I go back to those settings, telephone quality is selected. This is the output from cli:

$ pactl list cards short
0 alsa_card.pci-0000_00_1b.0 module-alsa-card.c
4 bluez_card.8C_DE_52_91_9A_AB module-bluetooth-device.c

$ sudo pactl set-card-profile 4 a2dp
Failure: Input/Output error

mauriciogaston (mauriciojost) wrote :

#15 worked for me on Ubuntu 14.04 on a Lenovo x240.

Thanks!

BeachGeek (labeachgeek) wrote :

I couldn't switch from headset to ad2p mode (have Sockets disabled).

I accidently found out that by clicking the 'mute' button on Logitech headset, it automatically switched to ad2p.
There are now two entries for the headset in pavucontrol/configuration. Both say "Logitech Wireless Headset".
  One is set to 'High Fidelity Playback (A2DP)', the other to 'Off' ... and headset works perfectly.

Changing second entry from 'Off' to 'Telephony Duplex' allowed me to play my music or games in stereo, and use Mumble to talk to others.

So now everytime I turn headset on, I just click the mute button a few times stopping on either mute or unmuted. Both entries appear everytime.

Hope this helps someone.
BG

Ubuntu 14.10, HP Envy dv7, Logitech headset (no model# visible)

KaMbA Dev (kamba-dev) wrote :

Solution that works for Ubunut 14.04 64bit on Thinkpad Edge 13 (not sure which specific model, has AMD Neo K325 CPU) and Jabra BT620s:

1.) backup your /etc/bluetooth/audio.conf

2.) create an empty /etc/bluetooth/audio.conf —> eg "sudo touch /etc/bluetooth/audio.conf"

3.) after reboot/start of the computer, start blueman-manager and add your bluetooth A2DP —> if your are tailing /var/log/syslog, it will state it failed to switch to a2dp

4.) restart bluetooth with "sudo /etc/init.d/bluetooth restart"

5.) again add A2DP profile in blueman-manager

6.) reset/restart/whatever_this_command_actually_does pulseaudio with "pulseaudio -k"

7.) in /var/log/syslog you will notice that an audio device <your_bluetooth_headset> was added with profile A2DP

8.) set the default output device in pavucontrol to your bluetooth headset

KaMbA Dev (kamba-dev) wrote :

One more thing: if you are using more than one bluetooth device and the audio stops when using it, I use this set of commands (found this fix for Ubuntu 10.04, it still works).

1.) sudo hciconfig hci0 lm master

2.) sudo hciconfig hci0 lp hold,sniff,park

It could reset your audio connection, so you need to manually set it back.

You can add it to your /etc/rc.local so it will run on startup.

Best regards and good luck

Sam Gaus (gausie) wrote :

I am running 15.04 and still have this issue.

I had the same problem when upgrading from 14.04 -> 14.10 and then again from 14.10 -> 15.04. My solution -which I found somewhere in the web- was the same both times: Simply delete(!) /etc/bluetooth/audio.conf (or rename it) and restart the bluetooth service. At least this worked for me.

Hi all:

I have exactly the same problem as everyone, and tried everything commented here without success. But I found a way of doing it work, which maybe helps to fix the error:

* Paired my headset, but didn't set it as trusted. Restarted the bluetooth service (did this only once, not every time I want to connect your headset; is just to set it in a know state).
* Now, every time I want to use the headset, I turn it on. Bluetooth icon in gnome will briefly show as connected, but returns to disconnected (because it detected the paired device, but, as it is not a trusted one, will no connect automatically to it).
* Wait about ten seconds until I hear a little "pop" in my headset (I suspect it is when, after waiting a connection, it puts in some kind of sleep mode to save battery)
* Now I can go to the bluetooth icon and set A2DP mode, and everything works fine.

If I try to connect it before that status change, the headset will stuck in HSP/HFP mode and will refuse to change to A2DP mode.

But there is a case when this fails: sometimes, when turning on the headset, Gnome shell shows a popup and asks me if I want to accept the connection. In that case, no matter if I accept or deny it, waiting to hear the "pop" doesn't work: it will also remain stuck in HSP/HFP mode.

f mds (fmds) wrote :

Hi,
Before update error
fmds@fmds-note:~$ sudo grep a2dp /var/log/syslog
[sudo] password for fmds:
Nov 10 13:05:12 fmds-note pulseaudio[2183]: [pulseaudio] module.c: Failed to load module "module-bluetooth-device" (argument: "address=5C:32:5B:00:A1:92 profile=a2dp"): initialization failed.
Nov 10 21:24:40 fmds-note pulseaudio[2078]: [pulseaudio] module-bluetooth-device.c: Profile not connected, refused to switch profile to a2dp

In atached file package's install bluetooth

After update kernel 3.19.0-33 *** connection A2DP successful
fmds@fmds-note:~$ uname -a
Linux fmds-note 3.19.0-33-generic #38~14.04.1-Ubuntu SMP Fri Nov 6 18:17:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

/var/log/syslog
Nov 10 21:25:37 fmds-note bluetoothd[890]: /org/bluez/890/hci0/dev_5C_32_5B_00_A1_92/fd3: fd(25) ready
Nov 10 21:25:41 fmds-note bluetoothd[890]: Audio connection got disconnected
Nov 10 21:25:41 fmds-note bluetoothd[890]: /org/bluez/890/hci0/dev_5C_32_5B_00_A1_92/fd4: fd(24) ready
Nov 10 21:35:23 fmds-note pulseaudio[2078]: [bluetooth] module-bluetooth-device.c: Skipping 10685 us (= 1884 bytes) in audio stream
Nov 10 21:41:23 fmds-note pulseaudio[2078]: [bluetooth] module-bluetooth-device.c: Skipping 1083 us (= 188 bytes) in audio stream

My /etc/bluetooth/audio.conf

# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
Enable=Source,Sink,Media
Disable=Socket
# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=false

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
[A2DP]
SBCSources=1
MPEG12Sources=0

Julian Alarcon (alarconj) wrote :

Hi

I'm using Ubuntu 15.10 that has bluez 5. Iand using a Sony Bluetooth handsfree SBH50.

Now I can choose the A2DP value, but, now I have another issue.
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/219057

Bluetooth can't coexist with Wifi.

Set MaxConnected=1 in audi.conf file

This work for me

I encountered the same issue in Ubuntu 15.10. Restarting the bluetooth service as per #35 fixes the problem.

Adam Niedling (krychek) on 2016-04-23
tags: added: xenial
summary: - Failed to change profile to A2DP in 13.04 (Raring), 13.10 (saucy), and
- 14.04 (trusty)
+ Failed to change profile to A2DP
summary: - Failed to change profile to A2DP
+ Failed to change profile to Advanced Audio Distribution Profile
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium

I have the same problem with Xenial, recently upgraded from Trusty.
In Trusty my BT loudspeaker worked correctly, and now I have

module-bluez5-device.c: Refused to switch profile to a2dp_sink: Not connected

when I try to switch to A2DP, and in HSP mode the quality is terrible.

Update: the workaround listed in https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1438510/comments/5 did work for me.

Hope this helps...

summary: - Failed to change profile to Advanced Audio Distribution Profile
+ Failed to change profile to A2DP (syslog says "Profile has no
+ transport")
summary: - Failed to change profile to A2DP (syslog says "Profile has no
- transport")
+ Failed to change profile to A2DP
tags: added: a2dp
Changed in pulseaudio (Ubuntu):
importance: Medium → High
Changed in pulseaudio (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Michel-Ekimia (michel.ekimia) wrote :

WIth latest Update of Bluez 5.37-0ubuntu5 , the issue is fixed here.

I can reconnect in a2dp mode with a paired headset

Daniel van Vugt (vanvugt) wrote :

Bluetooth audio (A2DP pairing in particular) was improved last week in:

  pulseaudio (1:8.0-0ubuntu3.3) xenial; urgency=medium

The bluez release you mention was released on 2016-03-09 and has remained unchanged :)

It's confusing and unexpected, but Bluetooth audio is mostly implemented in 'pulseaudio' and not in 'bluez'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.