blueman and pulse's module-bluetooth-discover (A2DP audio sink devices failed to work with "bluetoothd : Unable to select SEP" in system log.)

Bug #1199059 reported by V字龍(Vdragon) on 2013-07-08
162
This bug affects 32 people
Affects Status Importance Assigned to Milestone
blueman (Debian)
Fix Released
Unknown
blueman (Ubuntu)
Medium
Unassigned
bluez (Debian)
Fix Released
Unknown
bluez (Ubuntu)
Medium
Unassigned
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

All my A2DP profile devices can't create a audio device properly...
My 2 13.04 machines both have this issue(1 notebook, 2 bluetooth dongles)
UPDATE: Upgraded to 13.10, still reproducible

Possible root cause & fix: Please refer #15

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: bluez 4.101-0ubuntu8b1
ProcVersionSignature: Ubuntu 3.8.0-21.32-generic 3.8.8
Uname: Linux 3.8.0-21-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
Date: Tue Jul 9 01:01:38 2013
InstallationDate: Installed on 2013-01-26 (162 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130126)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-21-generic root=UUID=9bce9679-da3a-44fd-84ec-b16339a84004 ro quiet splash vt.handoff=7
SourcePackage: bluez
UpgradeStatus: Upgraded to raring on 2013-03-01 (128 days ago)
dmi.bios.date: 08/18/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1101
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P7H55-M
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1101:bd08/18/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7H55-M:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: 00:15:83:54:59:9F ACL MTU: 310:10 SCO MTU: 64:8
  UP RUNNING PSCAN ISCAN
  RX bytes:29508 acl:1270 sco:0 events:461 errors:0
  TX bytes:5249 acl:165 sco:0 commands:95 errors:0

V字龍(Vdragon) (vdragon) wrote :
V字龍(Vdragon) (vdragon) wrote :
description: updated
description: updated
Rex Tsai (chihchun) wrote :

It seems that you closed the hci device before the hci messages.
Jul 9 00:45:20 Vdragon-PC1 bluetoothd[997]: Host is down (112)
Jul 9 00:46:04 Vdragon-PC1 bluetoothd[997]: Unable to select SEP

And I see the following logs, are you making the pair or connection and reset the dongle on purpose?
Jul 9 00:40:50 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been disabled
Jul 9 00:40:54 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been enabled
Jul 9 00:41:57 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been disabled
Jul 9 00:42:02 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been enabled
Jul 9 00:42:13 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been disabled
Jul 9 00:42:17 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been enabled
Jul 9 00:43:59 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been disabled
Jul 9 00:44:03 Vdragon-PC1 bluetoothd[997]: Adapter /org/bluez/997/hci0 has been enabled

V字龍(Vdragon) (vdragon) wrote :

I'm not quite remember all the process, but I sure tried re-connecting dongle, re-pairing, and re-setuping the A2DP device a few times.

I can successfully pair the A2DP device but It just not working.

Here's the hcidump and syslog diff of "just try to connect the device"

Vdragon@Vubuntu ~ % tail -f -n0 /var/log/syslog
Jul 11 17:01:02 Vubuntu kernel: [ 5412.828799] input: A0:E9:DB:22:88:A3 as /devices/virtual/input/input12
Jul 11 17:01:02 Vubuntu bluetoothd[8761]: Unable to select SEP
^C
Vdragon@Vubuntu ~ %

Then my bluetooth manager(blueman) returned the message "連線錯誤:Stream setup failed" right away...

I'm pretty sure 12.10 doesn't have this problem, so it might be a regression.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Chorca (chorca) wrote :

I am having a similar issue. My log does not contain the Host issue, but does have the SEP problem. I can pair, but when connecting to the device, Blueman responds with "Connection failed: Stream setup failed".

Log from bluetoothd contains the following:

bluetoothd[2588]: audio/avdtp.c:avdtp_ref() 0x7f49c33da6b0: ref=2
bluetoothd[2588]: audio/sink.c:sink_set_state() State changed /org/bluez/2588/hci0/dev_00_02_3C_41_CA_0D: SINK_STATE_DISCONNECTED -> SINK_STATE_CONNECTING
bluetoothd[2588]: audio/sink.c:sink_connect() stream creation in progress
bluetoothd[2588]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[2588]: plugins/mgmtops.c:mgmt_event() Received 34 bytes from management socket
bluetoothd[2588]: plugins/mgmtops.c:mgmt_device_connected() hci0 device 00:02:3C:41:CA:0D connected eir_len 15
bluetoothd[2588]: src/adapter.c:adapter_get_device() 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/avdtp.c:avdtp_connect_cb() AVDTP: connected signaling channel to 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/avdtp.c:avdtp_connect_cb() AVDTP imtu=672, omtu=895
bluetoothd[2588]: audio/avctp.c:avctp_set_state() AVCTP Connecting
bluetoothd[2588]: audio/avdtp.c:session_cb()
bluetoothd[2588]: audio/avdtp.c:avdtp_parse_resp() DISCOVER request succeeded
bluetoothd[2588]: audio/avdtp.c:avdtp_discover_resp() seid 1 type 1 media 0 in use 0
bluetoothd[2588]: audio/avdtp.c:session_cb()
bluetoothd[2588]: audio/avdtp.c:avdtp_parse_resp() GET_CAPABILITIES request succeeded
bluetoothd[2588]: audio/avdtp.c:avdtp_get_capabilities_resp() seid 1 type 1 media 0
bluetoothd[2588]: audio/sink.c:discovery_complete() Discovery complete
bluetoothd[2588]: Unable to select SEP
bluetoothd[2588]: audio/avdtp.c:avdtp_unref() 0x7f49c33da6b0: ref=1
bluetoothd[2588]: audio/avctp.c:avctp_connect_cb() AVCTP: connected to 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/avctp.c:init_uinput() AVRCP: uinput initialized for 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/avctp.c:avctp_set_state() AVCTP Connected
bluetoothd[2588]: audio/avdtp.c:connection_lost() Disconnected from 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/sink.c:sink_set_state() State changed /org/bluez/2588/hci0/dev_00_02_3C_41_CA_0D: SINK_STATE_CONNECTING -> SINK_STATE_DISCONNECTED
bluetoothd[2588]: audio/avctp.c:avctp_set_state() AVCTP Disconnected
bluetoothd[2588]: audio/avctp.c:avctp_disconnected() AVCTP: closing uinput for 00:02:3C:41:CA:0D
bluetoothd[2588]: audio/avdtp.c:avdtp_unref() 0x7f49c33da6b0: ref=0
bluetoothd[2588]: audio/avdtp.c:avdtp_unref() 0x7f49c33da6b0: freeing session and removing from list
bluetoothd[2588]: plugins/mgmtops.c:mgmt_event() cond 1
bluetoothd[2588]: plugins/mgmtops.c:mgmt_event() Received 14 bytes from management socket
bluetoothd[2588]: plugins/mgmtops.c:mgmt_device_disconnected() hci0 device 00:02:3C:41:CA:0D disconnected
bluetoothd[2588]: src/event.c:btd_event_disconn_complete()
bluetoothd[2588]: src/adapter.c:adapter_remove_connection()

Erik (erikis-9) wrote :

This helped resolve the problem for me:

In /etc/bluetooth/audio.conf:

HFP=false
...
[A2DP]
SBCSources=1
MPEG12Sources=0

Source: https://bbs.archlinux.org/viewtopic.php?id=157326

Under [General], I also added Enable=Source,Media but this may not be necessary.

ekin (ekin) wrote :

I am running the 64 bit version of Ubuntu 13.04 and face the same problem with "Unable to select SEP" errors in syslog. The suggestion in comment #7 unfortunately did not solve the problem for me.

ekin (ekin) wrote :

After removing and installing various versions of pulseaudio and bluez, finally keeping the latest version of bluez [bluez (4.101-0ubuntu8b1) raring] and updating pulseaudio from the saucy ppa to version 4.0 solved my problems. I now can connect via A2DP to my bluetooth enabled speakers.

Willem de Groot (gwillem) wrote :

I am running the same packages as in comment #9 (however, under 13.10 alpha 2) but to no avail.

ii bluez 4.101-0ubuntu8b1 amd64
ii pulseaudio 1:4.0-0ubuntu2+b amd64

Apparently, downgrading to 12.10 versions fixes the problem, as has been reported here:

http://awesomeprogrammer.com/blog/2013/06/22/fixing-bluetooth-audio-issue-on-ubuntu-13-dot-04-based-distors/

Other people with the same issue:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1179801 (imho, incorrectly marked as invalid)
http://ubuntuforums.org/showthread.php?t=2144841&page=2
http://ubuntuforums.org/showthread.php?t=2157137
http://askubuntu.com/questions/287254/ubuntu-13-04-bluetooth-a2dp-does-not-work

V字龍(Vdragon) (vdragon) wrote :

Comment #7 by Erik is a workaround but not a all-time solution(this requires HF(S)P/A2DP dual profile device, but there's bluetooth speaker didn't support HF(S)P profile)

Comment #9 mentioned bug #1179801, which I suspect it is not the exact same issue.

I am running the 64 bit version of Ubuntu 13.10 and face the same problem with "Unable to select SEP" errors in syslog. The suggestion in comment #7 unfortunately did not solve the problem for me.

After several hours of googling and trying various suggested fixes, I have my bluetooth speakers working and have some hints. Hopefully package maintainers et al can coax them into a more usable form

First and foremost I found the following two URLs of enormous help:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725846

http://askubuntu.com/questions/366032/pulseaudio-not-detecting-bluetooth-headset-automatically

The real issue was that module-bluetooth-discover was not loading (and still does not automatically)

Test by:
pactl list | grep -i module-bluetooth-discover

If empty load via
 pactl load-module module-bluetooth-discover

Pulse audio will then (hopefully) recognize the device

The rest is sketchier since I needed to do this the first time, but not there after

First, pulse audio sees the device in the playback menu, normally where you see something like "Built-in Audio Duplex ..."

But the first time I tried the instructions in the URL above for associating the device with a2dp, they did not work. Instead, I went in through the bluetooth widget, selected the device, selected audio profile and then a2dp.

Then you could select the speakers from the pulse audio control panel

Have no idea how to get the pactl load-module to happen automatically, except (of course) I will write a script :)

I hope this helps a few ...

description: updated
V字龍(Vdragon) (vdragon) wrote :

I can confirm @trshemanske's fix does the magic, THANKS!

summary: - A2DP audio sink devices failed to work with "bluetoothd : Unable to
- select SEP" in system log.
+ PulseAudio doesn't load bluetooth modules automatically(A2DP audio sink
+ devices failed to work with "bluetoothd : Unable to select SEP" in
+ system log.)
summary: - PulseAudio doesn't load bluetooth modules automatically(A2DP audio sink
- devices failed to work with "bluetoothd : Unable to select SEP" in
- system log.)
+ PulseAudio doesn't load bluetooth modules automatically(orig.: A2DP
+ audio sink devices failed to work with "bluetoothd : Unable to select
+ SEP" in system log.)

AFAICS this bug is introduced by the Canonical, Ltd.'s patch "Enable the Gateway and Source audio profiles by
default"
Please fix/revert that patch to fix this issue.

reference: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=724735#25

no longer affects: pulseaudio
Changed in pulseaudio (Ubuntu):
status: New → Invalid
description: updated
description: updated
Changed in bluez (Debian):
status: Unknown → Fix Released
V字龍(Vdragon) (vdragon) wrote :

The report of the patch mentioned in #15 is at bug 948613 .

Henry Lin, please try the step in comment #13 -- try to load module-bluetooth-discover, see if this helps the device being recognized.

V字龍(Vdragon) (vdragon) wrote :

@Mathieu Trudel-Lapierre
Yes, the method mentioned in #13 worked (already mentioned in #14 :) ).

Chorca (chorca) wrote :

I'm not sure this is just bluez and not a little of pulseaudio, but i'm still not an expert.

I pulled the source for bluez and recompiled without the enable_audio_sources.patch file using quilt:
apt-get source bluez
quilt pop -a
quilt delete enable_audio_sources.patch
quilt push -a
debuild -us -uc
dpkg -i *.deb

This gets me audio. I've commented out everything in /etc/bluetooth/audio.conf to leave it all to defaults. Here's what I currently have to do to get working audio (after installing the patch-modified version as above):

1. Computer start
2. Attempt connection to paired A2DP device. Fails ("bluetoothd: Unable to select SEP" in syslog)
3. pactl load-module module-bluetooth-discover (endpoints registered in syslog)
4. Attempt connection to paired A2DP device. Success! Pulseaudio device created and available.
5. Open Pulseaudio volume control (to assign default audio output device). Pulseaudio crash!:
Jan 22 23:07:11 chrispad pulseaudio[1955]: [pulseaudio] module-bluetooth-device.c: Failed to acquire transport /org/bluez/999/hci0/dev_00_02_3C_41_CA_0D/fd0
Jan 22 23:07:11 chrispad pulseaudio[1955]: [pulseaudio] module-bluetooth-device.c: Assertion 'u->transport' failed at modules/bluetooth/module-bluetooth-device.c:363, function bt_transport_acquire(). Aborting.
6. Attempt connection to paired A2DP device. Fails ("bluetoothd: Unable to select SEP" in syslog)
7. pactl load-module module-bluetooth-discover (endpoints registered in syslog)
8. Attempt connection to paired A2DP device. Success! Pulseaudio device created and available.
9. Open Pulseaudio volume control (to assign default audio output device). Can finally open and assign output device.

Pulseaudio does seem to crash, as I receive a crash report notification after step 5, and the Volume Control loses connection to the PA server.

All the while, blueman experiences connection issues to the server, particularly after "Unable to select SEP", though that may be poor error handling on blueman's side.

This is on 13.04. I could upgrade to 13.10, but not sure if that will do anything for this.

summary: - PulseAudio doesn't load bluetooth modules automatically(orig.: A2DP
- audio sink devices failed to work with "bluetoothd : Unable to select
- SEP" in system log.)
+ Bug #948613 "Enable the Source and Gateway audio profiles in bluez by
+ default" patch breaks A2DP audio sink devices(orig.: A2DP audio sink
+ devices failed to work with "bluetoothd : Unable to select SEP" in
+ system log.)
themadmax (themadmax) wrote :

Ubuntu 13.10 64bit : fixed by pactl load-module module-bluetooth-discover, thank trshemanske #13

Chorca (chorca) wrote :

Same issue still exists in Xubuntu 14.04. "Unable to select SEP" shows in log when trying to connect to an A2DP device.

RazTaz (qvovadis) wrote :

The same problem exists in Ubuntu 14.04 and trshemanske solution is also valid there. Thanks.

Also please look here: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1283003

The fact that this is fixed just by enabling module-bluetooth-discover, I think we should definitely investigate whether this is something broken by blueman... reassigning.

Changed in blueman (Ubuntu):
status: New → Confirmed
Changed in bluez (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Changed in blueman (Ubuntu):
importance: Undecided → Medium
summary: - Bug #948613 "Enable the Source and Gateway audio profiles in bluez by
- default" patch breaks A2DP audio sink devices(orig.: A2DP audio sink
- devices failed to work with "bluetoothd : Unable to select SEP" in
- system log.)
+ blueman and pulse's module-bluetooth-discover (A2DP audio sink devices
+ failed to work with "bluetoothd : Unable to select SEP" in system log.)
Chorca (chorca) wrote :

It seems to be a bit more complex than simply running that.. the bluetooth device needs to be restarted as well (I cycle the wireless switch on my laptop) and then the device connected/disconnected a few times in order to get it to successfully connect to Pulseaudio.

Well, I think those issues are more typical with associating a bluetooth
device with the computer, no? I mean, if the loadmodule were part of a
startup script (as it should be), then when you turned on your bluetooth
device, the system would at least be ready to interact with it. You may
still have to configure the device in the bluetooth menu, but at least you
should be able to configure it. Without the module loaded, nothing you
would do will help.

And this problem extends beyond pulseaudio since I had to load the module
manually before I could tether my phone to my laptop when wifi was not
available.

On Wed, May 21, 2014 at 1:57 PM, Chorca <email address hidden> wrote:

> It seems to be a bit more complex than simply running that.. the
> bluetooth device needs to be restarted as well (I cycle the wireless
> switch on my laptop) and then the device connected/disconnected a few
> times in order to get it to successfully connect to Pulseaudio.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1199059
>
> Title:
> blueman and pulse's module-bluetooth-discover (A2DP audio sink devices
> failed to work with "bluetoothd : Unable to select SEP" in system
> log.)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1199059/+subscriptions
>

--

Thomas R. Shemanske
Department of Mathematics, Dartmouth College
6188 Kemeny Hall, 27 N Main St
Hanover, NH 03755-3551
603-646-3179

Chorca (chorca) wrote :
Download full text (4.1 KiB)

It seems some of the issues I was having seem to have stemmed from being in standby mode and resuming thereafter.

From a clean boot, here's my current steps/output to get the BT device working:

1. Power on system, wait to 'settle':
May 21 15:00:46 chrispad bluetoothd[832]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/HFPAG
May 21 15:00:46 chrispad bluetoothd[832]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/HFPHS
May 21 15:00:46 chrispad bluetoothd[832]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSource
May 21 15:00:46 chrispad bluetoothd[832]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSink
May 21 15:00:47 chrispad dbus[733]: [system] Activating service name='org.blueman.Mechanism' (using servicehelper)
May 21 15:00:47 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.49 path=/MediaEndpoint/HFPAG
May 21 15:00:47 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.49 path=/MediaEndpoint/HFPHS
May 21 15:00:47 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.49 path=/MediaEndpoint/A2DPSource
May 21 15:00:47 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.49 path=/MediaEndpoint/A2DPSink
May 21 15:00:47 chrispad blueman-mechanism: Starting blueman-mechanism
May 21 15:00:47 chrispad dbus[733]: [system] Successfully activated service 'org.blueman.Mechanism'
May 21 15:00:47 chrispad blueman-mechanism: loading Network
May 21 15:00:47 chrispad blueman-mechanism: loading Config
May 21 15:00:47 chrispad blueman-mechanism: loading Ppp
May 21 15:00:47 chrispad blueman-mechanism: loading RfKill
May 21 15:01:05 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.26 path=/MediaEndpoint/HFPAG
May 21 15:01:05 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.26 path=/MediaEndpoint/HFPHS
May 21 15:01:05 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.26 path=/MediaEndpoint/A2DPSource
May 21 15:01:05 chrispad bluetoothd[832]: Endpoint unregistered: sender=:1.26 path=/MediaEndpoint/A2DPSink
May 21 15:01:05 chrispad bluetoothd[832]: hci0: Remove UUID (0x0011) failed: Busy (0x0a)
May 21 15:01:17 chrispad blueman-mechanism: Exiting

2. Load bluetooth-discover:
$ pactl load-module module-bluetooth-discover
23
May 21 15:01:28 chrispad bluetoothd[832]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/HFPAG
May 21 15:01:28 chrispad bluetoothd[832]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/HFPHS
May 21 15:01:28 chrispad bluetoothd[832]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSource
May 21 15:01:28 chrispad bluetoothd[832]: Endpoint registered: sender=:1.63 path=/MediaEndpoint/A2DPSink

3. Power on Bluetooth device (headset connection is started, then terminated):
May 21 15:02:04 chrispad bluetoothd[832]: /org/bluez/832/hci0/dev_00_16_94_0B_94_FA/fd0: fd(25) ready
May 21 15:02:04 chrispad rtkit-daemon[1390]: Successfully made thread 2301 of process 1968 (n/a) owned by '1000' RT at priority 5.
May 21 15:02:04 chrispad rtkit-daemon[1390]: Supervising 4 threads of 1 processes of 1 users.
May 21 15:02:07 chrispad bluetoothd[832]: Connection refused (111)
May 21 15:02:10 chrispad bluetoothd[832]: Audio connection got di...

Read more...

Sebastian F (sf-lp) wrote :

According to David Henningsson Blueman seems to unload module-bluetooth-discover:
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003/comments/52

The issue persists in Trusty as well, unfortunately. The magic in #13 (https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1199059/comments/13) to the rescue.

I am using Xubuntu 14.04 LTS (trusty) and running the new lxqt desktop. I also still need to use the workaround in post #13 to get my bluetooth speaker to work correctly.....

Hartmut (hesse-hsr) wrote :

I am using a fresh installed Xubuntu 14.04 LTS, after running Ubuntu 10.04 LTS for quite a while on the same laptop Lenovo R500.
Everything worked great after installation, until I came to blueman...
Connecting to two different audio-devices( headset nokia 905i+, bluetooth-speaker DOSS Alonso ) that I own was buggy.
To be more specific: connecting and pairing worked, but there was no sink for pulseaudio available and A2DP setting was not possible.
I followed the discussion: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003.

And here I could finally find the solution:

it seemed that blueman unloads "module-bluetooth-discover" on startup.

David Henningsson (diwic) found the code in
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003/comments/52

he did a quick ppa on that, which unfortunately didn't work
https://launchpad.net/~diwic/+archive/bluemantest

now what?

since I liked the idea, I hacked directly in to that modul
/usr/lib/python2.7/dist-packages/blueman/plugins/applet/PulseAudio.py line: 229
    if v["name"] == "module-bluetooth-discoverX":
the 'X' is my add-on, since I have no idea about python ;)

reboot

now it works! :)

connected my Headset, could set the A2DP and listen to my music right now.

maybe somebody can use this information to build a real fix. looking forward to that

I uninstalled blueman, installed pavucontrol, reboot my PC and then turned on my bluetooth speaker to solve this issue.

I also believe that blueman is the main culprit and that blueman keeps unloading the module-bluetooth-discover module.

So I agree with remark #28 in this thread.

Alan Robertson (alanr-unix) wrote :

Instead of the Xbluetooth manager hack, my hack is to just put a return in that inner function. But I can report that this hack also fixes it for me. In theory, the body of that function should just be a pass... Or maybe the whole thing removed?

Sebastian F (sf-lp) on 2014-07-06
no longer affects: blueman
Sebastian F (sf-lp) wrote :

The Bug is fixed in Debian an will be backported to Trusty (hopefully).
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003/comments/107

Changed in blueman (Ubuntu):
status: Confirmed → Fix Released
Changed in blueman (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.