Comment 8 for bug 1181106

I'm not really certain of the source by any means. My statement about
"strongly doubting it was with bluez" was based on general observations,
not an understanding of the code or how it works, so please don't base any
decisions on what I said. It seems to me that the developers of both
projects ought to take a look at the report and figure out who should fix
what. Why not tag the issue with both and see how it shakes out?

On Mon, May 20, 2013 at 5:06 AM, Christophe
<email address hidden>wrote:

> If I understand well there are 2 bugs ?
> #1 A2DP profile not selectable by Pulseaudio when Socket mode is
> activated. On Bluez side according David, on Pulseaudio side according
> James.
> #2 device that can't be paired when Socket mode is not activated, probably
> on Bluez side
>
> If the Bluez team deprecated Socket mode, then we should probably focus
> on the second bug ?
>
> Am I wrong ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1181106
>
> Title:
> Failed to change profile to A2DP in 13.04 (Raring)
>
> Status in “pulseaudio” package in Ubuntu:
> Confirmed
>
> Bug description:
> I upgraded to 13.04 recently and my A2DP profile, which had been
> working great under 12.10 is suddenly gone. Neither my blueman applet
> nor the built-in bluetooth manager applet can connect my external
> bluetooth speaker to the A2DP profile. They can connect to the
> bluetooth device itself just fine.
>
> Steps I'm using:
>
> * using blueman, I can connect to the external bluetooth speaker and
> view the device in the devices listing
> * I can connect the device to the Audio sink and I get a message saying
> it is now connected and will "show in the PulseAudio mixer"
> * After connecting the external speaker to the audio sink, I can also
> see the device in the "Play sound through" listing in the Sound system
> control panel, but the icon has a circle with a line through it.
> * but if I right-click the device and choose "Audio Profile" from the
> context menu and try to select "High Fidelity Playback (A2DP)" as the new
> profile, I get an error message stating "failed to change profile to a2dp"
>
> I've already added "Enable=Socket" in /etc/bluetooth/audio.conf,
> without that I can't pair my headset. Now I can pair it, but I can't
> activate the A2DP profile.
>
> When I try to activate it, I see this message in my syslog :
> pulseaudio[2603]: [pulseaudio] module-bluetooth-device.c: Profile has no
> transport
>
> I tried the kernel 3.9.0 because of a sound problem with my soundcard,
> this kernel fixed my soundcard problem, but A2DP still doesn't work
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1181106/+subscriptions
>