Ubuntu

PDF v1.7 asks to upgrade Adobe Reader

Reported by Tyson Williams on 2009-01-27
152
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Poppler
Confirmed
High
poppler (Ubuntu)
Low
Unassigned

Bug Description

Evince cannot read the pdf format created with Adobe 8.1.3
This results in the file displaying the below message. Presumably, this is the message that Adobe Reader 8.1.3 and higher will save into the pdf files for readers that are only familiar with older pdf formats. This kind of monopolizing is typical of closed source programs.
------------------------------------
To view the full contents of this document, you need a later version of the PDF viewer. You can upgrade
to the latest version of Adobe Reader from www.adobe.com/products/acrobat/readstep2.html

For further support, go to www.adobe.com/support/products/acrreader.html
-----------------------------------

------
Original complaint is below. The complaint inaccurately attributes the message to a mistake on the part of the linux pdf readers.
------
Binary package hint: evince

1) I am using Ubuntu 8.10 with all updates installed as of the time of this writing (Jan. 26, 2009).

2) The version of the Evince Document Viewer is 2.24.1.

3) What I expected:
By opening the PDF in Adobe's PDF viewer, this PDF is a editable form with text boxes, drop-down menus, check boxes, and two buttons to initiate emailing or printing the form.

4) What actually happened:
This following message was displayed (within the document as though that is what the document actually was):
------------------------------------
To view the full contents of this document, you need a later version of the PDF viewer. You can upgrade
to the latest version of Adobe Reader from www.adobe.com/products/acrobat/readstep2.html

For further support, go to www.adobe.com/support/products/acrreader.html
-----------------------------------

No Linux or Ubuntu user should have to see a message like that...telling them they have to use non-free software.

I am in the process of asking the author of the file information about how she made it...like what program she used, what version it is, and possibly what version of the PDF standard it is, in case that information would help. I will edit this report and comment below if I have any new information.

Sorry that I don't know if this is a truly an Evince bug or Poppler bug. I am doing the best I can to help.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.24.1-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.27-9-generic i686

Instead of the actual document text, Poppler renders this as a single page that
says:

"To view the full contents of this document, you need a later version of the
PDF viewer. You can upgrade
to the latest version of Adobe Reader from
www.adobe.com/products/acrobat/readstep2.html
For further support, go to www.adobe.com/support/products/acrreader.html"

I think Poppler can do better.

Steps to reproduce:
1. Open http://undergradresearch.fsu.edu/Gfx/summer_award.pdf with Evince

Actual results:
Evince displays some lame error message embedded in the PDF.

Expected results:
Evince should display a "best effort" rendering of the actual text I want to
read.

Does this happen every time?
Yes.

Other information:
This seemed similar to some other reported bugs in Evince, but in all the ones I looked at, highlighting the text made it visible. In this case, highlighting does nothing.

That appears to be implemented with javascript. I'm not sure if it is really poppler's job to do that. I'm seeing it more as part of the reader (e.g. okular or evince).

Not positive though.

Well, javascript actions are not supported by poppler. The reader even doesn't know that there is javascript there if poppler doesn't support it.

Well, I originally filed this bug over at the GNOME Bugzilla, on Evince, but someone closed it "NOTGNOME" and said it was a Poppler bug. (The GNOME bug is #512160, but the database seems to be down at the moment...) Anyway, it has to be someone's fault! =)

BTW, is the example file technically a standards-compliant PDF, or a broken, non-standard one?

The pdf is ok, just doing ugly things to keep non acrobat readers viewers out of the game. And i think JavaScript handling should be done inside poppler, at least partially.

Tyson Williams (bender2k14) wrote :
Palash Padliya (palashp) wrote :

I am getting the same error

Changed in evince:
status: New → Confirmed
Palash Padliya (palashp) wrote :

This is a problem on all pdf readers, except newer adobe products. I have checked google's pdf reader, evince and foxit, which all seem to not work. However adobe pdf reader 9 reads this file.

Dimitrios Symeonidis (azimout) wrote :

I have confirmed that the pdf file opens correctly in Adobe Reader 9 on Windows. From Properties I can see it's "PDF version: 1.7 (Acrobat 8.x)"

Changed in evince:
importance: Undecided → Low
Dimitrios Symeonidis (azimout) wrote :

please not that the same appears with xpdf and acroread 8.1.3

stevr1it (stevr) wrote :

it is an evince bug. and also all the pdf readers, i have tried all of them. If you will solve it I will be very happy. thank you Stefano

Aouie (filt05) on 2009-02-23
description: updated
description: updated

the bug has been opened on https://bugs.launchpad.net/bugs/321720

"Evince cannot read the pdf format created with Adobe 8.1.3
This results in the file displaying the below message. Presumably, this is the message that Adobe Reader 8.1.3 and higher will save into the pdf files for readers that are only familiar with older pdf formats. This kind of monopolizing is typical of closed source programs.
------------------------------------
To view the full contents of this document, you need a later version of the PDF viewer. You can upgrade
to the latest version of Adobe Reader from www.adobe.com/products/acrobat/readstep2.html

For further support, go to www.adobe.com/support/products/acrreader.html
-----------------------------------

http://launchpadlibrarian.net/21663221/GradSurvey_pub_0001.pdf

This is a problem on all pdf readers, except newer adobe products. I have checked google's pdf reader, evince and foxit, which all seem to not work. However adobe pdf reader 9 reads this file."

(In reply to comment #0)
> This is a problem on all pdf readers, except newer adobe products. I have
> checked google's pdf reader, evince and foxit, which all seem to not work.
> However adobe pdf reader 9 reads this file."

Because it uses (more or less proprietary) technology from Adobe; the content of the PDF is what is displayed by evince etc. What AR shows is something quite different...

Sebastien Bacher (seb128) wrote :
Changed in poppler:
status: Confirmed → Triaged
Changed in poppler:
status: Unknown → Confirmed

The file at http://eugen.dedu.free.fr/a.pdf shows:
snoopy:~$ file a.pdf
a.pdf: PDF document, version 1.7

Upon opening with evince 2.28.2 (using libpoppler 0.12.2 cairo), a dialog box appears "Password required... The document is locked and requires a password before it can be opened."

pdfcrack says it is not encrypted:
snoopy:~$ pdfcrack a.pdf
Error: Encryption not detected (is the document password protected?)

So I suppose the problem is that the file is pdf v1.7.

Is there a method to see these files on gnu/linux...?

(In reply to comment #2)
> So I suppose the problem is that the file is pdf v1.7.

No. The "problem" is that this file uses an AcroForm (see section
12.7.2 of the ISO PDF Standard). And it uses Adobe LiveCycle.

> Is there a method to see these files on gnu/linux...?

Not yet. Your patch is very welcome.

Please, do not hijack bugs unless you are sure the root cause of the bug is the same.

*** Bug 28153 has been marked as a duplicate of this bug. ***

Basically the PDF uses JavaScript to change which contents to render and that's why we get the plain "dumb" text

Changed in poppler:
importance: Unknown → Medium

Is there such a thing as a user-agent string for pdf viewers? If so, could this be faked so that the document thinks that it is being opened by Acrobat?

Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium

*** Bug 20490 has been marked as a duplicate of this bug. ***

Changed in poppler:
status: Confirmed → Invalid
Changed in poppler:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in poppler:
importance: Unknown → High
status: Unknown → Confirmed

*** Bug 35701 has been marked as a duplicate of this bug. ***

*** Bug 39592 has been marked as a duplicate of this bug. ***

*** Bug 39826 has been marked as a duplicate of this bug. ***

I started looking at what it would take to implement javascript. The problem is all the javascript in this pdf does is check the viewer version and if > 7.0 loads the "XFA" plugin. The pdf contains a stream with 600KB of XML starting with "<template xmlns="http://www.xfa.org/schema/xfa-template/2.1/">".

There is a 1500 page specification for XFA at
http://partners.adobe.com/public/developer/en/xml/xfa_spec_3_3.pdf

Needless to say, at this point I gave up.

If only I could see a dump of the XML that my tax forms consist of, I think there's a snowball's chance in hell that I could get the numbers I need from it. Please don't let the perfect be the enemy of the good enough. Even if I have to poke a function in libpoppler from gdb - anything would be better than nothing.

Here is more information about the format:

http://en.wikipedia.org/wiki/Acroforms#AcroForms
http://en.wikipedia.org/wiki/XML_Forms_Architecture

pdftk has an option that possibly can be used as a workaround/help:

[drop_xfa]
If your input PDF is a form created using Acrobat 7 or Adobe Designer, then it probably has XFA data. Filling such a form using pdftk yields a PDF with data that fails to display in Acrobat 7 (and 6?). The workaround solution is to remove the form's XFA data, either before you fill the form using pdftk or at the time you fill the form. Using this option causes pdftk to omit the XFA data from the output PDF form.
This option is only useful when running pdftk on a single input PDF. When assembling a PDF from multiple inputs using pdftk, any XFA data in the input is automatically omitted.

From the man page: http://linux.die.net/man/1/pdftk

Hi,

I had post some feature request to okular but it probably for poppler :
https://bugs.kde.org/show_bug.cgi?id=299816

There are some preliminary work in itext pdf here : http://support.itextpdf.com/node/134

It may help to implement basic support of xfa.

Best Regards

Mourad

Lack of XML Forms Architecture (XFA) support in Evince 3.4.0 & the document viewer has a problem displaying a PDF file:

"To view the full contents of this document, you need a later version of the PDF viewer. You can upgrade
to the latest version of Adobe Reader from www.adobe.com/products/acrobat/readstep2.html
For further support, go to www.adobe.com/support/products/acrreader.html"

Workaround for novice computer users to business users, install Adobe Acrobat Reader for Linux
1. Edit Software Sources & enable Canonical Partners repository

2. Install from Terminal:
sudo apt-get update && sudo apt-get install acroread

*** Bug 56913 has been marked as a duplicate of this bug. ***

Hi,

Simply a polite question:
Will this issue be fixed in the near future or not?

XFA-Forms are becoming more and more important for me...

Thanks for answering :-)

Adobe would have to document XFA forms before this even could be addressed.

The most up to date info I could find on that front is:

    http://en.wikipedia.org/wiki/XFA#Standardization

As long as Adobe keeps XFA forms proprietary they are not potable and livecycle and acroread are the only way to deal with them.

Speaking only for myself, I’d go so far as to say that private, unpublished extensions to the PDF format make the file not PDF.

Support for ECMA-Script, on the other hand, is merely a matter of coding.

Until poppler or evince add it, you might want to try compiling mupdf master

  (git clone git://git.ghostscript.com/mupdf.git)

with -DV8_PRESENT=1. You’ll need to install v8 first. Your distribution might pacakge it, else look at http://code.google.com/p/v8.

James, can you define the deficiencies in the spec linked from comment #9 so that we can understand which parts of XFA still need to be documented?

>>>>> "b" == bugzilla-daemon <email address hidden> writes:

> James, can you define the deficiencies in the spec linked from comment #9 so
> that we can understand which parts of XFA still need to be documented?

For starters www.xfa.org does not exist. And xfa.org does not have an A
or AAAA record.

-JimC

It looks like the xfa situation isn’t as dire as I’d been led to understand.

OTOH, I’m not entirely certain that the licence text in the preface of the pdf referenced in comment #9 is GPL-compatible. Or even DFSG-compatible.

In any case (unless Albert things otherwise), it probably should not be implemented as part of poppler. I suspect an xfa-specific library would be better.

Poppler, of course, can help by assisting the extraction of the xml.

It is a huge (and likely non-Free) standard, will require web-browser-like implementation, and xfa is not limited to pdf encapsulation.

It might work better as an extension to webkit or gecko.

Most of the information I have about xfa has come from the itext list.

An example of the type of info posted there:

http://support.itextpdf.com/node/134

If there is new info since 2011/12 I’d be interested to know.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.